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Welcome to DEVONthink, a powerful
assistant in your quest to organize many

online.

Now let's get into it…

INSTALLING, UPDATING,
UNINSTALLING

kinds of information. From recipes to
your dissertation, hobbies to health, for

INSTALLING

work or home, DEVONthink can help you
gather, organize, and connect your data.

If you haven't already installed DEVONthink,

This manual will help get you familiarized

here are the easy steps to accomplish that:

with DEVONthink's concepts, interface, and
options. We begin with simple overviews,
move into descriptions of the essential
controls, then conclude with the deepest
details in the appendix.

Download an installer from the Download
page.
If your browser isn't set to open safe
downloaded files, double-click the ZIP file
to decompress it. You will see a disk image

Note this manual is meant as a handy

file.

reference, not as a series of mandates on how

Double-click the disk image to open it.

you must use it. DEVONthink can be used

Drag and drop the application from the

very simply or in very complex ways and each

disk image to the Applications folder

person brings their own personal approach

shortcut.

to using it. To that end, this document can't

After the application has copied, press ⌘E

be an exhaustive guide to everything you

to eject the disk image.

could ever do with it. With the flexibility
and capabilities built-in, that would be an
impossible task. We hope you find this guide
helpful.
Note: Text in blue color (besides hyperlinks

Note: Please note that macOS Services
and the connection to DEVONagent
work only for applications installed into
the Applications folder, and that logout
and login or a restart is suggested after

that might get colored in blue by your
ebook reader) refers to functionality only
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installation to make all parts of macOS

~/Library/Application Scripts/

aware of the additional services that come

com.devon-technologies.think3

with DEVONthink.

~/Library/Preferences/com.devontechnologies.think3.*

UPDATING
Updates to DEVONthink are done per the
schedule set in Preferences > General > Check
for Updates.

All DEVONthink-specific scripts in ~/
Library/Scripts
All DEVONthink-specific workflows in ~/
Library/Workflows/
All DEVONthink-specific scripts in ~/

If you need to manually update the software,

Library/PDF Services/

follow the previous installation instructions,

Uninstall the DEVONthink browser

but allow the Finder to overwrite the

extension, following the uninstallation

old version. Your database(s) will not be

process for the particular browser.

affected. To avoid any potential problems, do

Bookmarklets from your web browser

not use a third-party uninstaller utility. Just

The reference to the global inbox folder in

replace the current version, as directed.

your Finder's sidebar
Keychain entries containing devoncloudy

UNINSTALLING

in the name

If for some reason you need to fully uninstall

The DEVONthink .mailbundle in the ~/

DEVONthink from your Mac, trash the

Library/Mail/Bundles directory.

following files and folders (~ stands for your
account's home folder):

Note: In troubleshooting situations, please
do not uninstall the software without

DEVONthink

talking to our support team beforehand.

~/Library/Application Support/

Most issues can be resolved without

DEVONthink 3

uninstalling the software.
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DEVONTHINK SIMPLIFIED

DEVONthink is a very flexible application,

DEVONthink has two main window types: a

appealing to a broad range of people and

main window (seen immediately when the

accommodating many different working

software opens), and document windows.

styles. Since people use it in such diverse

These windows are used in already familiar

ways, it often leads people to believe there

ways, supporting drag and drop, sorting on

is a "steep learning curve" associated with

different attributes, full screen views, etc.

it. The truth of the matter is DEVONthink is

Whether you are working (or playing) in

a powerful application built on simple, and

DEVONthink, you will be using one or both

often familiar components and concepts.

window types.

Here we'll cover the basics.

INTERFACE

DEVONthink supports different ways of
viewing your items, e.g., in lists or as icons.
You can show or hide many details in the
At its core, DEVONthink is a multi-window,

window, allowing you to work in very simple

document-based application. Multi-window

or complex views of your data. Specifics

merely means you can have more than one

about windows and their component panes

window open. Document-based means it

and bars are discussed in more detail in the

supports viewing, and in some cases editing,

Windows and Inspectors chapters.

documents. Apple Notes is an example of a
document-based application without multiwindow support.
DEVONthink 3.7 Documentation, page 7

DEVONthink also has a powerful array of

In a similar fashion, open databases appear

tools found in its menus. Many of these are

in DEVONthink's sidebar and behave in much

also found in the contextual menus when

the same way.

Control-clicking items in the software. And
to fine-tune some of the options, it also has
extensive preferences.

Global Inbox: Displayed as

, when you

launch DEVONthink, you will immediately
see a database called Inbox. This is a special
database and a core component of the

DATABASES

software. As a core database, you can't
Beyond the interface, DEVONthink has only a

delete or close it, as it provides an always

few core working components: databases and

open database for quickly storing unfiled or

items. Items are comprised of two essential

transient data.

components: groups and documents.
Imagine you are reading about fission
Note: Throughout the documentation, we

reactions and someone sends a link about

use item to represent both groups and

a vacation place in Bali. You jump to the

documents. Things that only apply to one

website and quickly clip a webarchive of

or the other will use the appropriate term.

the page. But instead of putting it in your

Displayed as

and shown only in the

Navigate sidebar, databases are the
fundamental unit in DEVONthink, filled with
items. No matter if your content is grouped,
ungrouped, or a mix, it is all housed in a

research database, you add it to the Global
Inbox and get back to work. You can go
back later and read or sort things to other
databases. If you are familiar with Getting
Things Done you'll recognize the concept.

database. You add, remove, organize, and

The Global Inbox is also special as it is the

search for files within DEVONthink, just as

only database you can add a shortcut to

you've done in the Finder forever. Simple.

in the Finder's sidebar. This allows you to

When you create a database, it is made
as a self-contained package in the Finder.

save a file into the Global Inbox from other
applications.

Packages are technically folders that are

All databases also have an Inbox group with

handled like single files by the Finder.

the same purpose as the Global Inbox. It just

DEVONthink databases are not merely a
series of files and folders in the Finder, but
are isolated from each other and function
a bit more like disks. When you plug in an

allows you to save unfiled data to a more
specific database, as needed.

GROUPS

external drive, it appears in the Finder's

One of the two basic items are groups. No

sidebar isolated from other disks, but still

different than the folders and groups found

capable of moving and organizing data on it.

in many other applications, they merely
serve as ways to keep certain bits of data
together. But within the DEVONthink groups

DEVONthink 3.7 Documentation, page 8

are a few variations. They are all simple to

properties, any group you create will function

recognize and understand, but they bear

this way. For individual groups, you have the

being introduced.

option of choosing Exclude from Tagging from
the contextual menu or Info inspector.

Ordinary Groups: Displayed as

, these are

analogous to folders in the Finder. Except for

As you add items to a group tag, they are

underlying technology, groups operate in the

automatically tagged with the parent folders'

same fashion. Creating, adding and removing

name. Similarly, removing items from a group

contents, and deleting are all essentially the

tag will remove the parent tags. Also, if you

same. Just as in the Finder, you can create

create sub-groups, these will also be created

subgroups to suit your needs.

as group tags. This can be useful if you're
using a group for staging purposes, e.g., a

Looking and behaving like folders you've used
in the Finder, groups are the simplest way to
segregate data. DEVONthink allows you to
create deeply nested hierarchies or simple

groups for unassigned, in progress, and done
items. Moving files between these groups
would change the tag to its current parent
group.

top level groups, whatever you need to keep
things organized in a way that makes sense to

Smart Groups: Displayed as

you.

should be familiar to anyone using saved

New empty groups can be made with the
Data > New > Group command. Groups
of selected items can be easily made and
unmade via the Group Items and Ungroup
Items commands in the Data menu. These
commands are also in the contextual menu.
Groups are also the target of DEVONthink's
classify function. The AI compares
document contents and locations and offers
suggestions for where items may best be
filed. As documents are filed, manually or
taking the AI's suggestions, it becomes more
and more adept at helping you file more
efficiently.
Group Tags: Displayed as

, smart groups

searches in the Finder. Similar to them, smart
groups don't actually contain anything. They
merely show you items matching the criteria
you specify. Sometimes broadly used in
situations where deeply nested groups are
not used, you can create as many as you'd like
no matter your approach.
These special groups allow you to create
virtual groups based on any number of
matching criteria. These can be simple, e.g.,
"all PDF files in a database", or complex, like
"all unread documents with a specific color
label added in the last week but excluding
HTML files". If you like to use a looser filing
method, using smart groups allows you
, these are

to file your items with less concern about

created and operate like ordinary groups, with

where they're located in the database.

one extra function: the name of a group tag is

With smart groups you can also have items

applied as a tag to its contents (sometimes

appear in more than one smart group without

referred to as "children"). By unchecking

replicating or duplicating files explicitly. For

Exclude Groups from Tagging in a database's

example, a smart group could show items

DEVONthink 3.7 Documentation, page 9

tagged with "taxes". You could then create

thesis. Maybe some photos from your

another smart group with items tagged with

vacation you want to link to in a Markdown

"taxes","business", and "2018".

document you're working on. They're all just

Local smart groups, i.e., ones applied to

documents.
a specific database, can be created and

DEVONthink supports adding many kinds

edited via the Data > New > Smart Group

of files to your databases, but note the

command. You can also find this command in

type of file determines its usefulness in the

the contextual menu when Control-clicking

database. For example, images can easily

in the item list. Smart groups can also be

be added but searching for them is limited

created when doing an Advanced search.

to searching by attributes like file type or

When you create a new database,
DEVONthink automatically adds a few
of predefined smart groups for your
convenience:

filename. Remember DEVONthink excels at
text-based operations, so files like rich text
or PDFs are very well supported.
Note: More information on the types of

All Images: Shows all images.
All PDF Documents: Shows all PDF

files you can create or import can be found
in the Documents chapter.

documents.

While not types of document per se, there

Duplicates: Lists all duplicates.

are two variations on documents available to

Note: Smart groups filtering on dates or
unread status are shown with special icons.

you: duplicates and replicants.
Duplicates: Displayed with

to the right of

a document's name or the name optionally
Smart Rules: Displayed as

and found only

in the Navigate sidebar, smart rules are a
type of smart group with an extra function:
they not only match items by the criteria you
specify, they can also act on them. These
actions can even trigger when certain events
happen. For example, you could have a smart
rule matching PDFs in the Global Inbox and
have newly added PDFs be added to the
Reading List.

DOCUMENTS

shown in blue type, there are two ways to
get a duplicate in your database. Firstly, just
as you'd expect in the Finder, select a file
and press ⌘D: a duplicate is made. Secondly,
if DEVONthink examines the contents and
determines it has another file with the same
content, it will mark them as duplicates.
Duplicates are separate files, and changes
to the content of one should remove its
duplicate status.
Replicants: Displayed with

to the right of

a document's name or the name optionally
The second basic item in DEVONthink are
documents. No different than the Finder,
documents are any files you add or create in
your databases. Perhaps you are importing

shown in red type, replicants are conceptually
similar to aliases in the Finder or a second
phone book entry for the very same person.
Replicants are one file showing up in more

spreadsheets for work, or PDFs for your
DEVONthink 3.7 Documentation, page 10

than one location. However, they consume
no more space than a single file. Since they
are clones, changes made to any instance
of a document apply to all instances. This
makes them useful when you want to file a
document in more than one location, but
don't want to have to update each document
individually. It can also be useful if you have
larger files you want filed in more than

THE DETAILS
We hope this has given you some insight
into the basics of DEVONthink. DEVONthink
is deep and powerful, but understanding
these basic concepts and seeing parts you
are already familiar with will hopefully dispel
some of the "fear" that it's complicated and
hard to learn.

one group. A 10 MB PDF, replicated in ten

That being said, we also have more in-depth

different groups, would only use 10 MB of

information for you. From simple overviews

space in the database.

of menu commands to details in the appendix

There is also the possibility of having a

can be found in the remainder of this guide.

document that is both replicated and a
duplicate. This will display this icon to the
right of the name:

BUILDING YOUR DATABASE
The first step in starting your own custom

It's important that you understand how

database is to create a new database with

replicants work before you begin making

File > New Database. Give your database

changes to documents. Any changes to a

an easily recognizable name, and choose

replicant are carried over to all replicants; as

where you want to save your database. We

you might imagine, this means that you can

advocate putting them in a folder in your

to do some very powerful (and potentially

home directory, like ~/Databases. With your

negative) things with your database's

new database created, you are ready to add

contents via replicants. Duplicates, on the

information.

other hand, allow you to change the files
without modifying the original document
or group. Duplicates are less powerful than
replicants, but no less important in the grand
scheme of database organization.

Encrypted Databases: If you have databases
containing sensitive or private information,
you can create an encrypted database. This
is specialized AES-256 encrypted disk image
that will not appear in the Finder or your

On a technical side note, when you add an

desktop when it's open. In the Navigate

ordinary tag to a file, a replicant is made in

sidebar, you will see a key icon to the right

the appropriate tag group.

of the database's name, denoting it is an
encrypted database. Quitting DEVONthink

Note: Replicants cannot be created in the

or closing the database unmounts the disk,

same location as the originating file, nor

so you are always required to enter the

can they be made across databases.

password to access it.
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Choose File > New Encrypted Database and

more selective in what you add (especially

enter a password that will be used to unlock

in the beginning). Having a large, "dump it all

it. Enter a reasonable anticipated size for

in" database can contain a lot of files that

the database, in megabytes or gigabytes.

will do you no practical good (for example,

This is how large you think the database will

DEVONthink can't read your Microsoft Office

get. Since the encrypted database functions

user profile files), and weeding these files out

like a connected drive, you define how large

after-the-fact can be both time-consuming

it is and "fill it up". You can choose to let

and frustrating. Also remember, DEVONthink

Spotlight index the contents, but bear in

has to index metadata and contents of any

mind the Spotlight index is stored locally and

compatible files. This will be less productive

isn't encrypted. This means someone could

if you add files you'd never want to use or

find a document in the database exists via

search for.

a Spotlight search. However, they wouldn't
be able to open and access the database
without the proper password.

Here's a practical example: Your iTunes
database runs over 22 gigabytes. There's
nothing to be gained by simply copying

Note: You cannot create or store a

that into a DEVONthink database. Copying

database in a cloud-synced folder, e.g.,

the iTunes database into DEVONthink

iCloud Drive or Dropbox. This is not data-

would result in a large, inefficient, and slow

safe so the behavior is explicitly disallowed.

DEVONthink database, and would cripple

The advocated location is a folder in your

DEVONthink's ability to manage and use

home directory, like ~/Databases. If you

content in a well-designed manner (much

try to open a database in one of these

less perform simple search and organizational

locations, you will be prompted to let

tasks).

DEVONthink move the database, or reveal
it so you can manually relocate it.

ADDING YOUR FILES

As your growing databases use RAM,
processor time, etc., smaller, more focused
databases are often a more effective
approach than using singular, monolithic

After you've created your database, you'll

databases. Separate databases generally

add your files to it. Often it's a simple

perform better, sync faster, and in the rare

matter of dragging and dropping files into

case of a catastrophe, can help avoid data

your database, but we've covered several

loss since you're not keeping "all your eggs in

additional methods in the In and Out chapter.

one basket". Another benefit of this approach

Also, please take a moment to review the

is the ability to conserve some machine

Import and Index section to familiarize

resources. With a single, large database all

yourself with these two options.

the information is always using resources,

While you may be tempted to dump every
file on your hard drive into DEVONthink
and sort it out later, you're best off being

even files unrelated to what you're working
on at the moment. With separate databases,
you can close and open specific databases as
the need dictates.
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One way to effectively create separate

sense to you. There is no right or wrong way

databases is to use a topical database

to organize it. This is something you've likely

approach. Create multiple databases, with

already been doing in the Finder, making

each holding only related information: a bird

folders and filing things in them. Apply the

watching database full of birding articles and

same personal choices to DEVONthink. You

newsletters; a quantum physics research

can also use smart groups to create virtual

database with research briefs and email.

groups.

This method can improve the effectiveness
of DEVONthink's artificial intelligence
(AI) features with each database. The AI
work best within a database that contains
contextual relationships among many
documents; clogging your new database with
everything from A (apple pie recipes) to Z
(Zengobi user documents) will only hamper
the AI's ability to work effectively.

Remember that creating databases isn't an
inviolable commitment. Create and destroy
them as you see fit. Start with one way of
organization and decide later to re-organize
your databases. With DEVONthink you can
keep multiple databases open simultaneously,
easily moving documents from one database
to the other at any time. As you work with
your databases, new ideas may spark new

Having topical databases can help down the

approaches which can easily be tried and

road as well. You may be collaborating on a

adopted or discarded.

database, syncing between machines in a
group. Imagine having just one database: You
decide to share your painstakingly researched
academic articles with colleagues, only to
find that you've mistakenly also shared
personal financial records and chats. Not
hard to imagine how that has the potential to
be both dangerous and embarrassing. Having
multiple, topical databases will allow you to
keep your data separate and private.

ORGANIZING

CASE STUDY: BILL'S DATABASE FARM
Bill DeVille, formerly DEVONtechnologies'
Evangelist, worked in a number of scientific
areas. Bill's main database covered
environmental science and technology
topics, with related interests in science
and technology exchanges with developing
nations. The database even contained some
projects dealing with graduate education
in environmental sciences and engineering.
There's a broad topical relationship among

Database organization depends on the

these subjects and the database covers

parties involved. For collaborative work,

disciplines ranging from chemistry, toxicology,

you'll want to organize it in a manner that's

statistics, risk assessment, and engineering

understandable to all parties using it. This is

to economics, legal, regulatory, and policy

especially important as our sync technology

issues. These disciplines fit together and

is a mirroring sync, meaning changes to one

combinations of these topics are necessary in

copy of the database gets synced to the

many real-world cases.

other copies. For personal work, just set
up your database in a manner that makes
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As you can imagine from the above
description, Bill's main database was quite
large, containing about 20,000 documents
and over 20,000,000 total words. Because
of the relationships knitting together all
these scientific, technical, legal, and policy
issues, the artificial intelligence features
of DEVONthink worked very well for Bill in
researching the database and contextualizing
the information.

TAGGING
Tagging is a common method of creating
contextual relationships between documents.
For example, you can apply a "hobby" tag
to a woodworking article and a sewing
machine PDF manual. You would then
find both documents when searching for
the "hobby" tag. Used in the Finder and
many other applications, DEVONthink also
supports tagging in your databases (including

In addition to his main database, Bill had

preserving Finder tags on imported and

seven additional databases (so, eight total).

indexed items). Tags are either ordinary tags

For example, he had one database for Apple

or group tags, each discussed below.

Newton literature he has accumulated over
the years. It's almost as big as his main
database, but the topical coverage has no
practical relationship to the main database,
so Bill kept the Apple Newton literature in its
own domain. If he were to keep this unrelated
information in his main research database,
the result would be a larger, slower database,
with poorer performance by the artificial
intelligence.
Occasionally, Bill added topical materials to
it that are not related to its main purpose.

ORDINARY TAGS

However, when those "unrelated" topics grew
large enough in volume, he spun them off into

Similar to tagging methods used in other

to a new database in order to preserve AI

applications, ordinary tags are added to

accuracy and relevance.

items by you.

If you'd like to follow Bill's method, start by

Creating tags: When you add a tag to an item

creating a database with some collections

for the first time, a tag group is automatically

of files that interest you, but don't be afraid

created in the Tags section for the current

to create other databases that contain

database. However, if you want to proactively

"different" material as your interests, and

create tags to be used later, you can select

main your database, grow. And if you need

the Tags section for the database and choose

to search across databases, simply open

the Data > New > Tag command. You can

all of them at the same time. DEVONthink
searches all of them almost simultaneously.
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also choose New Tag from the contextual
menu when Control-clicking the Tags for the
database.

FINDER TAGS
Finder Tags: DEVONthink supports reading
and writing macOS' Finder tags. If tags are

Applying tags: When you apply a tag to an

present on an imported or indexed files, they

item, a replicant of that item is created in the

will be preserved in the database. When

Tags section for the current database. For

tagging imported files, tags are not written to

each tag you apply, you will have a replicant

the filesystem. Instead the tags are recorded

in each tag group. These are not the original

in the Spotlight metadata when the Create

items, but only instances of the items. If

Spotlight Index option is enabled in Database

you delete a tag group, the group and the

Properties popover. This allows searching

replicants it contains are removed. The

for tags in Spotlight using the tags:myTag

original items in the database remain intact.

syntax. If you export or drag and drop files

Ordinary tags are most commonly applied to
items by these methods:

to the Finder, macOS tags will be written
to the exported file. When tagging indexed
files, the tags are immediately written in the

Type tags into the Tag bar under a

filesystem and searchable, just as they would

document's View/Edit pane.

be if you tagged them directly in the Finder.

Type tags into the Tags section of the
Info inspector or the Info popover for a
document.
Drag items to a tag in the Tags section
of the Navigate sidebar. Note: If you drag
an item to a tag in another database,
that item will be moved to the receiving
database.
In the case of multiple selected items, any
tags common to all the items will be shown
in the Info inspector and Info popup. Tags
unique to specific files aren't displayed.
However, you can add tags common to all the
selected items using these views.

Note: If you would like to disable the
tag exchange between DEVONthink
and the Finder, click the On link under
DisableFinderTags in the Hidden
Preferences. Bear in mind this option
inhibits importing and exporting Finder
tags globally.

TAGGING SOURCES
Beyond the tag exchange with macOS, the
following options in DEVONthink's Import
Preferences or RSS preferences control other
tagging mechanisms. The options in the
Import preferences can also be manually

Tags can also be applied by more automated

applied via the commands in the Data > Tags

means, e.g., scripting and smart rules. see the

submenu and the contextual menu in the

Automation chapter for more information.

item list.
RSS: In the RSS preferences, the Convert
categories and hashtags to tags option
converts categories detected in the feed
articles or hashtags in the contents into tags.
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In conjunction with the previously mentioned

Image Tags: The Add tags to images option

Finder tags or Spotlight data, this can lead to

in the Import preferences, will use machine

a large number of macOS tags being added

learning to attempt to add subject matter

automatically in the Finder.

tags to selected images. There are no user-

Hashtags: Popularized in social media,
hashtags are a type of tag prefixed by a #. If
enabled in Preferences > Import, DEVONthink

definable controls for this option.

NESTED TAGS

can detect hashtags in the contents of

Sometimes referred to as "hierarchical tags",

text-based files and convert them to tags

nested tags are a series of related ordinary

for the file automatically. Removing the

tags, combined under a parent tag. When

hashtags from the content will remove the

you add a child tag, the item automatically

tags from the file. Hashtags do not support

inherits the parent tags. In the example

spaces in them and they should be listed on

shown below, adding a tag of "Casper" to an

a separate line. They will not be detected

item would automatically add the "Wyoming"

within existing paragraphs. Of special note,

and "US" tags.

hashtags supports creating nested tags
as noted here. The first tag just needs to
be prefixed with the # to be detected as a
hashtag..

A special mechanism in DEVONthink allows
you to create nested tags automatically:
enter the tags separated by a forward
slash. For example, type a tag of software/

Keywords: When enabled in the Import

productivity to create a parent tag of

preferences, DEVONthink will convert the

software with a child tag of productivity.

keywords of PDFs and rich text documents

Use this option in the places where tags are

into tags.

entered, e.g., the Tags bar, Tags field of the

Properties: Also found in the Import
preferences, DEVONthink will attempt to

Info inspector and Info popover, and the Tags
column in the item list.

convert certain properties to tags, e.g., the

Note: If you are having trouble deleting a

names and email addresses of the sender and

tag from an item, check to see if you are

recipients of emails.

adding a nested tag.

Geolocation: Enable Convert location to

Caution: Tags for a database can have the

tags in the Import preferences to convert

same name. This may seem illogical, but it's

the applied geolocation of a file into tags.

something more commonly seen that you

The Geolocation can be viewed in the Info

may expect. For example, say you have a

inspector.

travel database with points of interest like
restaurants tagged in different locations. You
may find yourself with a tag structure like
this…
Example:
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US

GROUP TAGS
Wyoming
Casper
Restaurant
Minnesota
St. Paul
Restaurant

Previously discussed in the Groups section
earlier in this chapter, group tags allow
you to dynamically assign tags based on
their location. As you add files to a group,
they have tags of the parent groups' name

If you added a tag Restaurant to an item,

assigned to them. Similarly, if you move

what tag would it go to? It actually would go

the items to a new group, the tags are

to the most recently entered instance of the

removed and new ones applied relative to

Restaurant tag.

the new location. Whether used statically

So how is this resolved? Tags are meant to
be unique, so eliminating redundant tags is
first priority. Restaurants aren't specific to a
geographic location. Create the Restaurant

or dynamically, group tags can be used
creatively. They also work in conjunction
with ordinary tags, so you can employ both
methods in one database.

tag as a top level tag. If you had a need

Example:

for hierarchy with the tag, perhaps for tax

Imagine you have a work database with

purposes, you could move it into a parent

groups for different stages of a project:

Tag of Entertainment. Then you would get

Unreviewed, Assigned, In Progress, On

both tags when you added Restaurant. But

Hold, and Done. At the beginning of

again, if you anticipate wanting to use the tag

the process, you'd put the item in the

without the parent tag, you should make it a

Unreviewed group and it would be tagged

top level tag.

as such. After reviewing, you could move

Also, you shouldn't view the tags as a group
structure in and of itself. Nested tags are just
meant to group tags specifically related to
each other, so they can be applied en masse.
Note: Tagging methods and philosophy is
full of strong opinions. Many people feel
tagging should always be flat; only top
level tags and no hierarchies. DEVONthink
accommodates both approaches. However,
if you want to used nested tags, we hope

the file into the Assigned group and
the previous tag would be removed and
replaced with Assigned. As the project
moves through the staging groups, the tag
would change.
And of course you can use ordinary
tags, e.g., Reviewed or a client identifier,
on these items. Those tags would be
preserved no matter where you move them
in the databases.

you carefully consider the caution we've

Groups tags are applied by DEVONthink

presented and use a hybrid method to

automatically. But you can also use do some

avoid unexpected behavior.

automatic filing by entering existing group
tags manually. If you enter the name of an
existing group that is not excluded from
tagging into the Tag bar or an Info panel or
DEVONthink 3.7 Documentation, page 17

popover, the item will be replicated to the

IP to the In Progress group. Now, type

appropriate group. You can also drag an item

IP as a tag and it will be replicated to the

to a group tag in the Tag Cloud at the bottom

In Progress group. When you view the

of the Navigate sidebar.

file, you will see the proper group tag was

Considerations: When you enable using group
tags for a database, it starts as an all-ornothing situation. All groups in the database
function as group tags.
If you want to use group tags for most groups
in a database, you can Control-click specific
groups and choose Exclude from Tagging. You
can also choose this option in the Exclude

automatically added.

SEARCH AND GATHER
Finally, tags have two main functions:
segregating data and searching for data. You
use tags to gather items together in certain
contexts. You also use tags to search for
those items.

from… section of the Info inspector or Info

Searching for items by their tags is easily

popup for a specific group. However, note

done in a few ways:

you must change this setting on all individual
groups you'd like to exclude.

Tag cloud: The Tags Cloud allows you to
filter the current list of files by clicking on

If you only want a limited number of tags, it

available tags. As you click, only related

would be advisable to exclude groups from

tags are shown so you can fine-tune the

tagging for the database and use ordinary

items displayed in the item list.

tags instead.

Search field: The search field at the top of
every main window allows you to search for

AUTOCOMPLETION
When you are typing tags, an autocompletion
list will appear. In the Global Inbox, tags
from any open databases are shown as
potential tags. In other databases, the items

tags by using the advanced options for a
search. You can also search for tags using
a simple tags: prefix. Multiple tags can be
specified, separated by commas. You can
also use tags!:, to exclude tags.

displayed are only from the tags of the

Gathering similarly tagged items is powerfully

current database.

achieved with Smart Groups. Smart groups

While group tags aren't added to the Tags
group for a database, they are displayed in
autocompletion suggestions.

allow you to use the smart group editor
controls to set criteria to be matched.
Included and excluded tags can be added as
criteria. Files matching the parameters of the

Tags and Aliases: DEVONthink also honors

smart group are shown, regardless of their

aliases added to groups. You can add

location in the database. This way you can

"alternative names" to a group using Info

leave your files where they are and create

popup or inspector and later use these

virtual folders for specific purposes.

alternative names as a tag. Continuing the
previous example, you could add an alias of
DEVONthink 3.7 Documentation, page 18

A WORD ABOUT BACKUPS
For many users, the value of the data is much
greater than the value of the computer that

about. Online backups such as Arq Backup
are an alternative if you don't want to own
another piece of hardware to care about.

hosts it. There are many things that could

As a secondary backup option, you can create

go wrong. Your notebook computer could be

an optimized and compressed copy of the

dropped, lost, or stolen. Your hard drive will

whole database that you can then save on

fail (it's not a matter if, but when). A power

a server or other media. Use File > Export >

outage could corrupt the files on your hard

Database Archive or Scripts > Export > Daily

drive. For the truly paranoid (remember,

Backup Archive to create a ZIP file of the

paranoia is sometimes justified), how

database. The former option allows you to

significant would the loss of your database

choose specific place; the latter creates it in

be if your house or office were to burn down?

a Backup folder in your home folder.

Avoid insomnia and back up your database(s)
frequently. Your data stored in DEVONthink is
valuable, so back it up.

Lastly, as events such as house fires and
natural disaster frequently prove, valuable
data should probably be kept at more than

INTERNAL BACKUPS

one location. Consider saving a copy of your
backed up information at a secure, off-site

DEVONthink backs up its database index

location such as a bank safe, or put the

every week, either immediately after opening

exported ZIP files of your database in your

the database (if the backup is overdue) or

cloud account.

during the day when appropriate.
Note: As noted in our FAQ, sync is not a
Note: The internal backups are mainly a

backup, neither advertised nor advocated

troubleshooting mechanism for use in the

as such. While database restoration may

application. Backing up your files, including

be possible with sync data, it is not meant

your DEVONthink databases, is up to you.

to be relied upon or used in lieu of proper
primary backups.

FULL BACKUPS

habit of triggering backups whenever you

TUTORIALS, SCREEN CASTS,
AND MORE

have invested substantial time and effort

In addition to this help resource, explore

into modifying the database. Apple's Time

tutorials and install pre-made scripts and

Machine and an external drive is an easy

templates that extend DEVONthink's

way to do this. Simply connect the drive and

functionality in the Support Assistant. Also

let Time Machine do its thing. With the low

new tutorials are shown in the Extras sidebar.

We strongly recommend you get in the

cost of portable external drives, it's even
feasible to take a 1 TB drive that can fit in a

For a great resource of tips, promotions,

shirt pocket for backups when you're out and

and release announcements, check out our
company blog.
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And if you feel like talking to other people

Take time to learn how to work with the

using our applications, you'll find discussion,

software — and to decide how you want the

camaraderie, and well over a decade's worth

software to work. You'll be rewarded with a

of information at our Forums.

powerful assistant for all your information
organization needs.
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The Concordance function allows you to
view a list of all the words contained in a
document or database. Selecting a word
highlights the word in the current document.
Additionally, a graph of related words is
shown at the bottom of the Concordance.

The number of possible uses for DEVONthink

Right-click a word in the list or graph to

is nearly endless. In this chapter we've tried

exclude them. And if you're wondering about

to outline a few typical use cases that show

other documents containing a word, double-

how you can use DEVONthink in your daily life

click one to start a search for that term.

and work.

Other functions of the AI's analyses include
the Classify function. This examines the text

ANALYZE TEXT DOCUMENTS
With its built-in artificial intelligence (AI)
functions, DEVONthink can be used to
analyze the documents in your databases.

content and locations of other documents
in your database and makes suggestions for
filing the current document. Additionally, See
Also lists documents with a similar content to
help find connections you may not have found
otherwise.
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Possible uses:

Continue to read here:

Analyze the complexity and focus of a

Import documents from the file system

specific document collection

Use the See Also & Classify Inspector

Find relationships between documents or

Use the Concordance Inspector

snippets quickly
Clean up large collections of documents

ARCHIVE YOUR MESSAGES
DEVONthink is the repository for emails you
want to save.

Its hierarchical groups structure, automatic

attachments, are preserved when possible.

classification function, and powerful

You even can reply to messages directly from

search engine are perfectly suited to

DEVONthink's contextual menu commands!

adding, sorting, and finding emails in
your databases. DEVONthink comes with

Possible uses:

advanced email archiving functions that

Archive important correspondence

transfer selected messages or mailboxes

Archive invoices, offers, purchases, or

from Apple Mail, Microsoft Outlook, and

software licenses

any email applications using standard

Store interesting news bits from

Unix mailboxes, e.g., Thunderbird, to

newsletters

a DEVONthink database. The original

Keep project-related emails and other

structure of the message, as well as all

documents together
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Continue to read here:
Archive email messages
Reply to archived emails
Organize data using Classify and See Also

ARCHIVE PRINTED
DOCUMENTS

When you are working in a team, use the
embedded web server to give your colleagues
access to your data using an interactive web
interface. Even friends using Windows are
invited.
Possible uses:
Archive your important correspondence

DEVONthink is the "paperless office" solution

Archive invoices, offers, purchases, or

for the Mac, a central hub for all your paper

software licenses

and electronic documents.

Store printed documents together with
electronic documents
Keep project-related emails and other
documents together
Keep a central repository for all team
members
Continue to read here:
Scan paper documents
Scan with the Fujitsu ScanSnap
Import existing files with OCR
Organize data using Classify and See Also

Using the integrated scanner support you

Share data with your team

can directly scan documents, make them
searchable through OCR (optical character
recognition),and file them in a database. Of

BROWSE THE INTERNET

course, you can also make existing scanned

Besides being a knowledge and information

documents searchable. If you own a Fujitsu

database, DEVONthink has built-in web

ScanSnap or other compatible document

browsing capabilities. This allows you to

scanner, you can use the fast auto-feeder to

browse and capture online information

scan batches of sheets in one go.

directly in a database.
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DEVONthink enables you to treat web pages

Grab data from web sites and store it in

the same way as you treat documents.

DEVONthink

Whenever you select a bookmark,

Capture and archive complete web pages

DEVONthink immediately loads and displays
its content live from the internet in the

Continue to read here:

View/Edit pane. You can also open a page in

Capture data from the Web

a separate document window. Archive the

Create new bookmarks or HTML

complete page for offline viewing, add a new

documents

bookmark, or drag elements from the page

View "live" and local HTML pages

into your database.

Integrate news feeds with your data

DEVONthink also handles RSS, RDF, Atom,
and JSON news feeds, either through feed
documents or by simply displaying them
via the built-in web browser. Stay up-todate with your subject and clip important
information right away.
Possible uses:
Visit frequently used web sites in a
convenient interface
Integrate "live" content from the web with
your other documents
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CAPTURE DATA FROM THE
WEB

All of these options, except the bookmark,
capture the text content of the page (or a
selected area of it) and hyperlinks if present,
and preserve the text information for
searches in DEVONthink.
Note: There are a number of web sites
that prohibit use of some of the capture
options described above. A secure banking
site or a university portal to journals may
direct a bookmarklet or script capture
option to the login page, which will be
captured instead of the desired content. A
capture option that requires re-download
of the page on such sites will capture only

Increasingly, information is provided not

the login page. The page always can be

on paper but directly through web sites,

selected and captured as rich or plain

blogs, online news sites, social media, and

text. The viewed page can be captured by

user forums. DEVONthink offers a variety of

"printing" it as PDF to the database.

options for conveniently capturing data from
the web:
Bookmark: Captures only the address (URL,
uniform resource locator) of the page.
HTML page: Saves the source code of
the page to the database, but images are
downloaded from the web each time the
page is displayed in the database.
Web archive: Saves both the HTML code
and all resources, like images, necessary to
display the page.

Possible uses:
Capture important news in an easily
searchable database
Collect all relevant data for your project in
one place
Collect links to web pages and captured
data about the same subject in one group
Save data from the web in future-proof
formats such as PDF
Continue to read here:

Rich/Plain text: Grabs selected text/
images and hyperlinks, but avoids saving
unwanted areas of the page to the
database. A plain text capture will not
include formatting, images or links.
PDF: "Freezes" the web page, just like
printing to paper. PDFs from web pages can
be paginated or non-paginated.

Capture data using Services
Capture data using scripts
Capture data with bookmarklets or
browser extensions
Add the global inbox to the Finder's sidebar
"Print" any web page or document as PDF
to your database
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CATALOG YOUR SD CARDS OR
DVDS

CATALOG YOUR PHOTOS AND
MEDIA FILES

By using the Index function, you can use

Besides storing text documents and

DEVONthink to set up a catalog for your data

PDF files, DEVONthink can also contain

DVDs, SD cards, or other removable volumes.

multimedia data such as photos, illustrations,

Create a group for each disk by using the

music, or movies in your databases.

index function, and organize your disks/
groups in any way you like. When you need
a specific file, search for it in DEVONthink,
insert the volume, Control-click the file in
DEVONthink, and select Open With to open
the original file on the removable volume.

While not designed to replace Photos
or Music, DEVONthink can be used as a
repository for images you frequently use or
as an interface to your music library (if you
don't like other music software). If you do not
want to import these files, leave them where

Note you will only see a thumbnail if the

they are in the file system. You can index the

disk or volume is not available. A message

files instead and access them from within

to Mount Volume will be shown if a server

DEVONthink See also p. 132ff

volume is unavailable. Clicking this button
should remount the volume, if possible. For

Possible uses:

removable disks, DVDs, etc., you will have to

Create a dedicated database for photos

reinsert the media.

only

Possible uses:

View your images in full screen mode
Include project-related images, audio, and

Find files even when they're on a removable

video in your databases

volume that is not currently mounted

Play your music from within your work

Create a virtual library of SD cards and

environment

other media
Integrate static documents with other
project-related data
Continue to read here:
Import or index files

Continue to read here:
Import or index files
View files as thumbnails
View images and movies
Search your database

Search your database
Launch the original file of an index item

COLLECT TEXT SNIPPETS AND
OTHER VALUABLE DATA
Use macOS's handy Services menu for
collecting and organizing information bits and
snippets to DEVONthink.
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Continue to read here:
Capture a note quickly using the Services
menu
Use the Sorter
Drag text clippings to the Groups panel

INDEX FILES ON YOUR HARD
DRIVE
Besides importing documents, DEVONthink
can also index files. When indexing files,
DEVONthink reads the contents of the file
Select any piece of data and capture it to
the currently open database with a keystroke
or a quick visit to the Services menu. Most
true macOS applications such as TextEdit,
Safari, or DEVONthink itself support this
mechanism.

and stores it for internal reference, but leaves
the files in place in the Finder. Use indexing
for easily accessing information stored on
removable volumes, creating a library of all
important documents regardless where they
are physically stored, or integrating files

DEVONthink automatically sets the title of

stored elsewhere with your documents in

the newly created snippet to the first line of

DEVONthink. See also p. 51ff

text, so there's a good chance that you won't

Possible uses:

even need to rename it. New snippets are
created in the global inbox or the location you

Keep the folder structures you've created

choose. Also, DEVONthink can help classify

in the Finder, while allowing access to

and file the items using its built-in artificial

DEVONthink

intelligence.

Create a front-end for your document
collection

Possible uses:
Collect recent news from your favorite web
sites

Integrate indexed items with imported and
items you've created in DEVONthink
Continue to read here:

Keep important information from any
source and your other project-related

Import or index files

documents together

Search your database

Create an info collection for a specific topic

Launch the original file of an indexed item

MANAGE YOUR BOOKMARKS
With its integrated, document-based
web browser, DEVONthink can be used
as a bookmark manager. Organize all your
DEVONthink 3.7 Documentation, page 27

bookmarks as bookmark documents and visit
the web sites by simply selecting them with
a preview visible. DEVONthink loads the page
and displays it in the View/Edit pane.

SHARE PROJECT DATA
With its built-in synchronization, DEVONthink
allows you to have your databases on
multiple Apple devices. Changes made on one
machine propagate to the others, keeping
them in sync. It can also be used to manage a
shared project workspace.

If you want to open the web page in your
default browser, simply Control-click the
bookmark and choose Launch URL from the

Keep all your project-related data in an easy

contextual menu.

to structure database and share it with

Possible uses:

your team members. Use a shared WebDAV
volume, a shared cloud account, a local file

Manage your bookmarks

server, or direct connections to propagate

Keep project-related web pages and other

new data to the team automatically.

documents together
Visit frequently used web sites in a
convenient interface
Integrate "live" content from the web with
your other documents
Grab data from web sites and store it in
DEVONthink
Continue to read here:
Create a new bookmark
View "live" and local HTML pages

And if your coworkers don't use a Mac give

Drag URLs to the Sorter

them access via DEVONthink's built-in web
server. You can set up web users and fine-
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tune the access permissions so that visitors

In addition, its integrated web browser

only gets access to what they should see.

supports news feeds and displays them

SSL/TLS encrypts all data in transit.

like any other web page. Use its document-

Possible uses:
Organize project files, use advanced
feature such as tags and smart groups
Add new data from any team member's
computer or even iOS device running
DEVONthink To Go
Integrate "live" data, e.g., web pages or
newsfeeds, with your other documents
Give your colleagues using Windows or
Linux access to your knowledge with web
sharing
Continue to read here:
Set up sync to share data with your team
members
Set up the local web server
Add smart groups to organize data
automatically
Add newsfeeds

READ NEWS FEEDS

oriented structure to organize bookmarks and
store news feeds like internet-updated smart
groups.
Mix live news feeds with static documents,
e.g., in your project materials.
Possible uses:
Read your daily news in a convenient
interface
Integrate "live" newsfeeds with your other
documents
Grab interesting information easily and
store it in DEVONthink
Continue to read here:
Create a new bookmark or HTML
document
View "live" web pages and news feeds
Create a news feed document

TAKE NOTES
DEVONthink is perfectly suited for taking
notes and organizing them.

DEVONthink comes with built-in support
for RSS, RDF, Atom, and JSON news feeds,
which makes it a reliable basic news reader.
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full screen mode, DEVONthink is perfectly
suited for writing many kinds of documents,
from notes to whole books.

Quickly create new notes and file them in
your database using DEVONthink's Tools >
Take Note command to open the Sorter (or
an independent Take Note panel, if the Sorter
is hidden). Alternatively, use the Take Note
command in the Dock menu. Notes can be
created in plain or rich text, Markdown, or

Create new documents with just one click,

formatted note formats.

find related documents in your database,
and connect them with Wiki-style or static

Possible uses:

cross-links. Working these documents in

Write down ideas before they vanish

your databases, you can switch from one

Take quick phone messages

document to another with just one click, and

Keep project notes and your other project-

manage even large projects with ease.

related documents together
Continue to read here:

Utilize markers, like flags or color labels to
help visually distinguish items, by importance
or other criteria using label names. And

Create new documents

similar to the Finder, you can create groups,

Create a new note using the Dock menu

as deeply (or shallowly) nested as you'd like.

Revise notes and documents using the
built-in rich text editor

Possible uses:
Write notes, white papers, and letters

WRITE TEXTS AND OUTLINE
PROJECTS
With its hierarchical group structure,
organization, and navigation functions, as well

Write and organize book chapters
Organize your ideas or projects in outlines
Create a network of information for your
projects or interests

as its advanced text editing capabilities and
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Continue to read here:
Create new documents

Use the See Also & Classify Inspector
Use the Concordance Inspector

Use the built-in rich text editor
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The view/edit pane is where you can see or

Office Documents, Email, and Others

49

edit the current document (with compatible

As DEVONthink is an information and
document management application, it
supports importing many different file
types. While not all formats are editable, if a
QuickLook plugin is installed on the machine,

a selected file. Additionally, there are a few
optional components available: the editing
bar (for compatible formats), the tag bar,
and the contextual menu.

VIEW/EDIT PANE

files). Each file type you view has its own
tools, contextual menu commands, and
keyboard shortcuts.

NAVIGATION BAR

the files should be viewable. Also, if a

At the top of the view/edit pane,

Spotlight importer for these files is installed,

DEVONthink shows a navigation bar that

the files should be indexed by DEVONthink

gives you access to some additional tools

and searchable. In addition, DEVONthink

that deal directly with the contents of

supports creating some common types

the document. Which tools are available

directly in the application.

depends on the type of the document you are

In the General section of this chapter, we will
discuss the essential window components
you'll use when viewing or editing these

viewing. The options below are shown in the
navigation bar for most file types. Specific
options are shown in the separate sections:

documents. Following that are chapters for

Navigates back to the last visited

the types of files DEVONthink supports.

document after following a link.
Navigates back to the next visited

GENERAL

document after going back.
Reloads the displayed page in a web view.

When working with files in DEVONthink,

Only visible for, e.g., bookmarks.

they can be viewed in the view/edit pane of

Shows an action menu with options for

a main window or in a separate document

opening the shown page in Safari, copy its

window. When viewing a document, there

address, or capture the page in a variety of

are two essential components visible: the

formats.
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Shows if the document is locked or

This offers quick access to some editing tools

editable.

related to the file type you're working on. See

Scrolls to the previous highlight, e.g., a

the appropriate file type section for more

search term occurrence.

info.

Scrolls to the next highlight, e.g., a search
term occurrence.

TAG BAR

Scrolls to the next page of the displayed
document.
Scrolls to the previous page of the
displayed document.
Switches to Text Alternative mode. Useful
for selecting text in uneditable formats,

The tag bar, which can be shown or hidden,
shows all tags associated with the document.
Click the tag bar and type to add tags; select
a tag and press the ⌫ Backspace or ⌦ Delete
key to remove it. See also p. 14ff

e.g., Word documents.

When you type the name of a tag,

Switches to Best Alternative mode. For

DEVONthink offers automatic completion.

Markdown documents, this is the rendered

Choose the right option with the mouse

HTML view.

or the arrow keys and press ↩ Return or

Word Count: Shows the number of
paragraphs, words, and characters of the

Enter to accept it. Press ⎋ Escape to use
whatever you entered. Auto-completion
prefers ordinary tags (tags represented in

displayed text.
URL: Shows the URL associated with the
displayed item, if one is present. If a PDF
annotation is selected the URL field shows

the Tags group) over groups used as tags,
and also matches sub-strings. Press ⇥ Tab to
enter another tag.

the associated URL if available. Click to

Note: The tag bar is also visible for

launch the URL in its default application.

multiple selected documents when all the

Hold the ⌥ Option or the ⌘ Command

documents have the same tags attached.

key to open the URL in a new tab. Holding

Use it to change the tags on multiple

⇧⌥ or ⇧⌘ opens the URL in a new tab and

documents.

selects it.
Page Count: Shows the number of pages

CONTEXTUAL MENU ITEMS

as well as the page number of the currently
displayed page. Click the page number in
PDF or PostScript documents and enter a
page number to jump directly to that page.

If you Control-click in many types of
documents in DEVONthink, you are presented
with a contextual menu showing many
options. The options displayed depend on
what you're clicking; e.g., selected text, and in

EDITING BAR

whether you're in an editing or preview mode.
For some formats, e.g., rich text or sheets,

As many of these commands are the same

there is another bar available: the Editing

for most formats, we have provided a list

bar. If you click this icon

, the editing bar

will appear in place of the Navigation bar.
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in the appendix. Items specific to a format

on the method chosen in the WikiLinks

are listed in their respective sections in this

preferences. Note these are not item links.

chapter.

Make Link: In rich text files, you can select
words and choose Format > Make Link to

TOOLBAR & SHORTCUTS
DEVONthink can display documents in
separate windows when you double-click the
documents in a main window. Depending
on the type of document, the tools in the
toolbar can change. Even though not all tools
are always present in the default toolbar for
a particular type, you can easily add some by
choosing View > Customize Toolbar. Changes
made to the toolbar will be persistent for
that file type, but are independent of the
toolbars of other types.

create an active hyperlink of the selected
words. Clicking on the hyperlink will
generate a new WikiLinked document.
Relative and Absolute Links: Often used in
Markdown documents and also supported
in HTML-based formats, these are usually
links similar to what is seen in the source
code of web pages; e.g., /stylesheets/
styles.css. These are not item links.
Copy and Paste: Select an item in the
item list and choose Copy Item Link. This
captures the item's unique link to the
clipboard so you can paste it into another

Please find a list of toolbar items and

document or even another application.

shortcuts in the appendix.

Some other types of links can be captured,
e.g., page links. Refer to the Contextual

Note: Documents are automatically
saved every five minutes after the last
modification, when deactivating the
window, or when quitting DEVONthink.

menu section for the appropriate file
format in the Documents chapter.
Add Link: For text in rich text and
formatted notes, you can select words and
choose Format > Add Link. You can then

DOCUMENT LINKING
Documents in DEVONthink are independent
items but often have contextual relationships
with other documents in your databases.
Here are a few ways to make links in the text
of editable documents and establish those
connections:
WikiLinks: WikiLinks are specialized
links found in plain text, rich text, and
Markdown documents. Use them to link

add a URL, including an item link, to create
an active hyperlink of the selected words.
Drag and Drop: You can Option-Commanddrag and drop a file into a compatible
document to insert an item link.
Insert Link: Edit > Insert > Item Link opens
the Insert Item Link popover, allowing you
to add an item link to a document.
Of the methods listed above, the ones
utilizing item links are of special note.

to existing items or create documents
on-the-fly. For existing items, these links
are automatically detected depending
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INCOMING AND OUTGOING ITEM LINKS

PLAIN AND RICH TEXTS

Incoming and outgoing links are item links
DEVONthink has detected. The two types of
links function as sides of one operation. If you
create an item link to an image, the file will
have an outgoing link detected. The image
you have linked to will have an incoming link
detected since the file has a link pointing to
it.
Documents with incoming or outgoing links
will have a special property icon displayed to
the right of the filename in the item list. See
also p. 210ff . You can display a sortable
Incoming Item Links and Outgoing Item Links
column in the headers of the item list in List
view. There also are incoming and outgoing

PLAIN TEXT

item link criteria usable in toolbar searches,
smart groups, smart rules, and AppleScript.

Plain text files may seem too simple to be
truly useful. No styling. No images. Nothing

VIEWING LINKS

but text. But the reality is these simple files
are underlying a lot of your daily experience.

See the Document > Links section of the

From the HTML code instructing your

Inspectors chapter for information on viewing

browser how to display a web site, to the

the links of a document.

code DEVONthink is written in, plain text is
very powerful. DEVONthink supports plain
text files as a native, editable format.
Plain text files can be imported or created via
Data > New > Plain Text.

RICH TEXT
Word processing applications brought
us text with flair. Need some bold and
italic text? How about adding a photo to
the page? And color? These applications
were providing it all. But their formats are
proprietary so if you don't have the creator
application, you can't open the file or you'll
have to convert it first. The rich text format
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provides a useful text format that supports

Highlight selected text. This uses the

formatted text. These files are generally

currently selected highlight color.

cross-platform compatible and editable in

Add or edit a link applied to the selected

many applications. DEVONthink uses the

text.

same text engine found in Apple TextEdit, so

Convert selected text into an active link.

it's an easy transition if you're already familiar

This can be used to dynamically create Wiki

with it.

documents.

You can attach other documents to rich
text documents simply by dragging them
into the text. Technically the rich text
document becomes an .rtfd package and
the dragged file is saved as part of the
package. Using the contextual menu, you can
show an attachment's content in a Quick
Look preview. Also, if you double-click an
attachment, it will open in the system default
application.
Rich text files can be imported or created via
Data > New > Rich Text.

Show or hide the ruler. Place tab stops with
the mouse, then remove them by dragging
them off the ruler. Drag new tab stops (left
aligned, centered, right aligned, or decimal
aligned) from the repository at the right
side to their desired positions on the ruler.
Use the mouse to adjust the left and right
margins and indent.
Show the Fonts panel.
Show the Color Picker.

THE FORMAT BAR
In addition to formatting options in the
Format menu and the simple controls in the

EDITING BAR

editing bar, DEVONthink provides another

The navigation bar for rich text files includes

toolbar just for rich text editing. Select

the Editing Bar. Click this

Format > Show Format Bar to display a set of

icon and

the editing bar will appear in place of the

rich text controls under the toolbar in main

navigation bar. The tools available here

or document windows. Similar to TextEdit, it

consist of:

provides the following options:

Edit the formatting of a list.

Styles: Select a predefined text style from

Edit parameters of a table.

the pop-up menu. To define your own

Increase the size of the font.

styles, choose Other to open the standard

Decrease the size of the font.

macOS style editor. In the style editor,

Set characters to be subscript.

navigate back and forth through the styles

Set characters to be superscript.

of your document or the stored favorite

Adjust the line spacing of selected text.

styles. (Use the radio buttons to switch

Set bold on the text.

between document and favorite styles.)

Set italic on the text.

Click Select to select all occurrences

Set underlines on the text.

of text with the displayed style in the

Set strikethrough on the text.

document, click Apply to apply the style
to selected text, or click Done to leave
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the style editor. To add a style from your
document to the favorites, click Add
To Favorites; to remove a favorite, click
Remove From Favorites.
Font Controls: Displaying three dropdown

CONTEXTUAL MENU
In addition to the contextual menu items
available with text selections, rich text files
also feature these specific commands:

menus for, choosing the font face, font

Copy Paragraph Link: Copies a link to the

weight, and font size.

current document, but appends a pointer

Colors: Two buttons are available for

to the selected paragraph.

setting the text and background color.

Insert > ...: Inserts special characters or

Basic Styling: Allows you to choose bold,

items into the document.

italic, or underlines.

Quick Look Attachment: Opens a Quick

Alignment: Align the current paragraph

Look panel for the selected attachment in

(the one with the insertion caret inside)

a rich text file.

left, centered, justified, or right by clicking

Split Document: Splits the document

the according alignment buttons in the

at the current insertion position. A new

ruler.

document is created for the text after

Spacing: Choose the desired spacing for

the cursor position and removed from the

the current paragraph from the Spacing

current document. This can be used in rich

pop-up menu. Choose Other to enter

text and plain text, including Markdown

values other than the ones shown.

content in edit mode.

Lists: Make the current paragraph a list
(indented and with a bullet or numbered)
by choosing the desired list style from the
Lists pop-up menu. Choose Other to define
your own list style.
Note: The built-in "mini outliner" is a nice
feature of the macOS rich text editor. On
any blank line in a rich text document,
type ⌥⇥ Option-Tab to create a bullet
point (macOS shows dashes instead of
bullets). Press ↩ Return for the next item,
and so on. Additional ⌥⇥ will increase the
indentation; a ↩ on a blank list line will
decrease it. The mini outliner uses hyphens
to indicate list items by default.
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PDFS

In the Tools menu there are several PDF
related commands, including access
to Annotation tools (also found in the
Navigation bar). Additionally, there are
commands for changing the display, e.g.,
single to two pages, in View > PDF Display.
PDF files can be imported. They can also be
created by capturing web content, directly
in DEVONthink or via our browser extension,
Clip to DEVONthink. You can also use the
PDF Service Save PDF to DEVONthink 3 in
the PDF dropdown of the print dialogs of
most macOS applications. This will print a
paginated PDF to your database.
Inspector Panes: There are two inspector
panes with information specifically
pertaining to PDF documents: the Content

PDFs are a very common format, from

Inspector and the Document Inspector.

academia and online bill payments to

The Content Inspector allows you to see a

equipment manuals. Fortunately, they

list of thumbnails or an available table of

are first-class citizens can be viewed

contents. When this inspector displays the

and annotated within DEVONthink. The

thumbnails, Tools > Split Document and the

annotation tools should be familiar and

same contextual menu command becomes

include options like arrows, text, and link

available to split the PDF before the current

annotations. While DEVONthink may not

page. The Document Inspector gives you a

have some options found in specialized PDF

view of PDF metadata, e.g., keywords, a list

applications, it is still a very capable PDF tool.

of annotations, and a list of links detected in
the document. Please refer to the Inspectors

PDFs often come directly from text

chapter for more specifics.

sources, like word processing or page layout
applications. The content of these files

NAVIGATION BAR

should be indexed and searchable on import.
You can also acquire PDFs from scanned

In the navigation bar for PDFs, the number of

documents. These files will only have a text

pages in the document is displayed. Clicking

layer if OCR is done on them.

on this navigation bar item opens a Go to
page function so you can quickly jump to a

For scanned PDFs, you can do OCR directly in

specific page. In addition, there are options

DEVONthink when needed.

to move to the first, previous, next, or last
page.
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EDITING BAR AND ANNOTATIONS
The navigation bar for PDF files includes the
Editing Bar, providing access to editing and
annotation tools. Click this

and the editing

bar will replace the navigation bar. The tools
available here consist of:
Select text for copy or highlighting.
Select annotations on the page. Double-

Rotate the current page left (counterclockwise).
Rotate the current page right (clockwise).
Add a new blank page before the current
page.
Delete the current page.
Reverse the page order of the document.
The annotation tools in the editing bar are
also available in the Tools > Annotate menu.

click an annotation to edit its properties.
Press the ⌦ Delete key to remove the

CONTEXTUAL MENU

annotation.
Move or scroll the current page.

In addition to many common contextual

Underline selected text in the document.

menu items there are also a few PDF-specific

Strike through selected text in the

options:

document.
Apply or remove highlighting on selected
text. The highlight color will be the color
selected in Format > Highlight Color.
Alternately, click and hold to select another
color.
Add a link to a selected area. Click and
drag over an area to establish a hotspot
for the link to be active. For the Link
Type, choose Link within PDF, navigate
to another page and click Set to create a
link between pages within the same PDF.
Alternatively, choose URL and enter a URL
to an external item. This can be a web site
address, or drag files from the Finder or
your DEVONthink databases into this field.
Add a rectangle annotation.
Add an oval annotation.
Add a line annotation.
Add a note annotation.
Add a text annotation. Drag to create
a text box. To change the font, choose
Format > Font > Show Fonts.. Note only one

Automatically Resize: When checked, the
zoom factor adjusts to the width of the
view/edit pane or document window.
Copy Page Link: Copies a URL to the
clipboard pointing directly to the shown
page of the document.
Delete Annotation: Deletes the selected
annotations.
Single Page/Two Page (Continuous):
Displays the PDF as single or double
pages. Use the Continuous option to allow
quick scrolling through the pages as one
continuous document.
Previous/Next Page: Jumps to the previous
or next page.
Rotate Left/Right: Rotates the current
page 90 degrees in the selected direction.
Insert Blank Page: Insert a new blank page
before the current page.
Delete Page: Delete the current page.
Reverse Page Order: Reverses the order of
the pages in the entire document.

font can apply to each text annotation.
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MARKDOWN DOCUMENTS

see no formatting in the source code, you can
disable WYSIWYG editing in Preferences >
Media > Markdown.
The currently supported WYSIWYG types,
including CriticMarkup syntax, are:
Formatting:
Bold: **bold**.
Italic: *italic* or _italic_.
Bold-Italic: ***bold-italic**.
Highlight: {==highlight==}.
Underscore: {++underscore++}.

Markdown is a simple formatting language
invented by John Gruber that has gained in
popularity over the past few years. It allows
you to write in plain text, using some easily
learned control characters, to produce nicely
rendered HTML output. With some styling
and ingenuity, you can create a wide variety
of documents.

Strikethrough: {--strikethrough--}.
Subscript: ~subscript~.
Superscript: ^superscript^.
Elements:
Header: # Header. Prefix each header with
the appropriate number of pound signs.
Supports header levels 1 through 6.
Link: [Link Text](URL) or <URL>.

Markdown files can be imported or created

Blockquote: > preceding each line in the

via Data > New > Markdown text.

quote.

Editing: Writing Markdown is essentially the

Code block: `code terms`. Note: Those

same as writing plain text documents. As
you're writing you can switch easily between
a plain text editor and the rendered view or
even view both simultaneously using the sideby-side view via the View > Document Display
commands.

are backticks, found on the tilde (~) key.
Fenced code block: ``` - triple backticks
on a line above and below the code. To
show syntax coloring in the rendered
view, see the Markdown Extensions: Prism
subsection below.
Metadata headers: attribute: . As noted

When editing the source of the Markdown,

below, these must be the first lines in the

DEVONthink's hybrid source rendering

document.

will display many types of formatting or
elements as you type. For example, typing
**important** will display the plain text in
bold; `{"name":"Audrey Hepburn"}` will
display as a code block, etc. If you'd prefer to
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Internal styling: <style type="text/
css"> … </style>
HTML Link: <link rel="stylesheet"
type="text/css" href="css/
styles.css" />
XHTML Link: CSS: css/styles.css.
XHTML headers must be placed at the very
top of the document.
Note: If no specific styling is applied, the
font choice in Preferences > Editing >
Rich Text & Note Font will be used when
previewing Markdown documents.
File Transclusion: A special feature of
DEVONthink's Markdown handling is support

Linking: You can reference local images,

for file transclusion. This provides the

scripts, and other resources using item links,

capability of displaying the contents of one

downward-relative (traveling subgroups;

file inside the contents of a Markdown file.

it's not possible to travel up with '..' as

This supports displaying the contents of

documents can have multiple parents) or

plain text, HTML, or other Markdown files.

absolute (start with a forward slash) paths.

For example, you may have several chapters

Here are examples of linking an image:

of a book written in individual Markdown
files. Use transclusion to view them all as
one document with out the need to merge
or copy and paste the content between files,

![link](item.png): Use this when
linking to an item in the same group as the
Markdown document.

similar to some popular writing applications.

![link](group/item.png): Use this when

To use transclusion, just enter the desired

group containing the Markdown document.

document's name or item link between

![link](/group/item): Use this when you

double braces, e.g., {{Chapter 1}}.

are linking to an item in a group outside the

Transclusion supports filenames with and

group containing the Markdown document.

without extensions, relative and absolute

For example, if you have common resources

links, as well as item links. It also supports the

in a specific group, you can link to them

Obsidian syntax, e.g., ![[Chapter 2.md]].

using this format.

linking to an item in a sub-group of the

Styling: Styling your Markdown documents

If you have enabled automatic WikiLinks >

can be done with internal styling or externally

Names & Aliases, documents can be detected

referenced stylesheets. If you have a specific

as you write your Markdown. These WikiLinks

stylesheet you'd like to use globally, you can

are active when previewing the file and

specify one in Preferences > Media > Style

are also preserved in a website export or

Sheet.. Here are the options:

conversion to other formats.
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Drag and drop items into a Markdown

Note: DEVONthink supports many features

document to add the appropriate links. Drag

of MultiMarkdown 6, but not all of them

and drop documents while holding ⌘-⌥ will

(e.g., no file transclusion).

create a URL with an item link. Dropping
an image with create a properly formatted
Markdown image link. Drop .mp3 or .mp4 files
to insert a playable multimedia link.

MARKDOWN EXTENSIONS
To support some features in Markdown
that aren't built in, DEVONthink supports a

Another option for inserting links into

handful of known and widely used extensions.

Markdown documents, Control-click while

The first option below requires no user

editing and choose Insert Link To from the

interaction. The following three can be

contextual menu. A Markdown formatted

enabled in Preferences > Media > Markdown, if

link will be automatically inserted for you.

desired.

For images, just add an exclamation point
before the link if you want it to display in the
rendered document.

Highlighting, strikethrough, …: Text notations,
e.g., for noting changes are sometimes
necessary in documents. DEVONthink

You can learn more about Markdown and its

supports the features of the CriticMarkup

syntax on Gruber's Markdown pages or the

extension of Markdown. It also supports

MultiMarkdown syntax guide.

a few alternate highlighting syntaxes, like

Metadata: One of the features of
MultiMarkdown is metadata headers. These

==text== and ^^text^^, found in some other
Markdown-enabled applications.

allow you to add non-displaying information

MathJax: Markdown is often used

about the document, like authors, dates, and

in academic situations, many using

even linked stylesheets. To use the feature,

mathematical equations in their writing.

format the first line of the document with a

DEVONthink supports the Mathjax extension

colon, e.g., Author: DEVONtechnologies. This

that will beautifully render LaTeX coded

must be the first line of the document. Other

equations in your Markdown documents.

metadata fields you wish to add must follow
immediately after this first line.

Mermaid: Diagrams can be created in
Markdown documents using the Mermaid

However, if you would like the first line of your

extension. Add a line of three backticks as

document to contain a colon, perhaps adding

shown```mermaid. Add the diagram code as

notes like Developer: A. Edwards and Re:

needed and close the diagram with another

OCR, just add a single blank line at the top of

line of three backticks. There are several

the document and the subsequent lines will

diagram types available and discussed on the

be treated as normal paragraphs.

Mermaid.js website.

Emoji: For a little extra personalization, you

Prism: For those writing code in their

can type Slack-style emoji, like :grinning:,

Markdown, DEVONthink supports Lea

directly in the Markdown document.

Verou's Prism extension. Just add a line
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of three backticks ```language- and the

HTML-BASED FORMATS

language you're writing about. For example,
```language-applescript. Remember to
add a line of three backticks under the code
to close it. This displays syntax highlighting
of code blocks in the rendered output. Note
it does not affect the Markdown source as
you're writing, only the rendered output.
Note: Not all languages supported by Prism
are available. Additional languages may
be added in the future if there's sufficient
interest in them.

NAVIGATION BAR
When working with Markdown documents,

HTML-based files in DEVONthink include

you can switch between Preview and Source

bookmarks, web archives, formatted notes,

modes. There also is a special icon

and RSS articles. These are formats that

present

in the navigation bar. This switches to Side-

are viewable in web browsers and are also

by-Side mode, allowing you to edit and

mobile-native.

preview the current document in two side-byside panes.

BOOKMARKS
Bookmarks are exactly the same as the

CONTEXTUAL MENU

ones found in your web browser. With

In addition to the contextual menu items

DEVONthink's ability to act as a browser,

available with text selections in the

bookmarks can be a valuable part of your

document source, Markdown documents have

experience. When using File > Import >

a special command: Copy Section Link. This

Bookmarks, you can bring your bookmarks

copies a link to the current document, but

into DEVONthink easily. Though this depends

appends a pointer to the selected paragraph.

on the capability of the individual browser,
you may be able to drag links directly into
your database. You can also capture them
with DEVONthink's browser extension, Clip to
DEVONthink.
Note: If you import your bookmarks from
a browser, this is a copy operation not
a sync, i.e., if you modify bookmarks in
your browser, this will have no effect on
DEVONthink's contents. However, you

DEVONthink 3.7 Documentation, page 43

can do another import to add the new

Bear in mind, the underlying markup

bookmarks to your database without

in formatted notes can't be edited in

duplicating the previous ones.

DEVONthink. However, you can open the files

In addition to importing bookmark files, they

in a compatible external editor, if you'd like.
can be created via Data > New > Bookmark.

Note: Since images are completely

Just provide a URL and title. If you don't enter

embedded in the documents, the resulting

a title, DEVONthink will attempt to detect

file size can grow large very quickly. Resizing

and use the page title.

images before adding them is encouraged.

FORMATTED NOTES AND HTML

HTML Files: are similar to formatted notes,
but they do not preserve the state of

Formatted Notes: allow to write simple

checkboxes and form fields. You also cannot

formatted text including embedded images

add images by dragging them into the live

that can be viewed on any system with

editing view. However, you can edit the

just a web browser. While the range of

underlying HTML code using the Source and

formatting options is smaller that that of

Side-by-Side modes found in the navigation

rich text they are much more compatible to

bar.

today's standards. You can find all available
formatting commands in the Edit and Format
menus. When creating new formatted
notes, DEVONthink will use the font set in
Preferences > Editing > Rich Text & Note
Font. Captured or imported formatted
notes, e.g., from Evernote, use the font set in
Preferences > Web > Standard Font
Technically formatted notes are based on
HTML, the language of the world-wide web.
Images are embedded directly into the
HTML code so that formatted notes are
completely self-contained. The HTML code
is also cleaned from unnecessary tags and
an identifying meta tag is inserted that lets
DEVONthink distinguish formatted notes
from normal HTML pages. Form tags, e.g., for
checkboxes and input fields are not removed

Formatted notes can be imported or created
via Data > New > Formatted note. When
using the Notes from Evernote or Folders
& Attachments from Notes options in the
File > Import menu, the imported notes are
formatted notes. HTML files can be imported
or created via Data > New > HTML page.

WEB ARCHIVES
Web archives are a special HTML file format
intended to create offline archives of
individual web pages. The downloaded data
preserves the look and feel of the page very
closely. It is often a more useful capture
option when a PDF would generate a very
long page since web archives always view at
the size determined by the browsing area.

and the status of checkboxes and form fields

They function in a similar fashion as

is retained.

formatted notes, so you can actually edit the
captured contents and save your changes.
This can be very handy for highlighting
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passages or removing unwanted elements,

controlled by an internal CSS stylesheet

e.g., ads, in a captured web page. Also, since

specified in Preferences > RSS > Feed Style

they are HTML files the underlying markup

Sheet. Other formats will get their styling

can be edited using the Source and Side-by-

from the source they're downloaded from.

Side modes found in the navigation bar.
Note: When using an option other
Note: Web archives can be very useful with

than Automatic as the feed format,

web pages using statically linked content.

DEVONthink must download the linked

However, some popular and monetized

content and convert it to the appropriate

sites get their contents dynamically from

format.

other sources, so the actual data is not
in the underlying HTML. These pages may
have missing content due to this, require
an internet connection to display content,
and run JavaScript. If you encounter this, a
PDF may be a better archiving option.
Web archives files can't be directly made.

RSS feeds can be created via Data > New >
Feed. Provide a URL and title. If you don't
enter a title, DEVONthink will attempt to
detect and use the feed's title. You will also
notice a special feed in this menu: Twitter
Feed. This can be used to import feed articles
from a specific Twitter account.

They are the result of capturing web content,
either in DEVONthink or using our browser
extension.

EDITING BAR
Like rich text files, editing HTML-based files

Note: Web archives made on macOS

(excluding bookmarks) includes the Editing

Mojave aren't necessarily compatible with

Bar. Click this

earlier versions of macOS.

appear in place of the navigation bar. The

icon and the editing bar will

tools available here consist of:
RSS
Increase the size of the font.
RSS feeds are special "web pages" that don't

Decrease the size of the font.

show as pages but as a stream of news

Set characters to be subscript.

articles. DEVONthink allows you to keep that

Set characters to be superscript.

news flowing directly into your databases.

Set bold on the text.

Supporting RSS, RDF, Atom, and JSON feeds,

Set italic on the text.

DEVONthink functions as a basic newsreader.

Set underlines on the text.

RSS feeds are treated as a special type of
file that functions as a group. Feed articles
are downloaded to the feed and saved
in a format you specify in DEVONthink's
Preferences > RSS > Feed Format. The default
is Automatic and saves summary files as
HTML. The styling of the HTML articles is

Set strikethrough on the text.
Highlight selected text. This uses the
currently selected highlight color.
Add or edit a link applied to the selected
text.
Show or hide the ruler. Place tab stops with
the mouse, then remove them by dragging
them off the ruler. Drag new tab stops (left
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aligned, centered, right aligned, or decimal

Update Bookmark: Updates the URL of this

aligned) from the repository at the right

document to the current one, e.g., after

side to their desired positions on the ruler.

navigating to a sub-page.

Use the mouse to adjust the left and right

Update Captured Archive: Updates the

margins and indent.

contents of a web archive file with the live

Show the Fonts panel.

version on the Internet.

Show the Color Picker.

CONTEXTUAL MENU
In addition to the contextual menu

Add Page to Downloads: Adds the page
address to the Download Manager.
Download Video: Downloads the video
using the Download Manager.

commands available with text selections in
a document, HTML based files often include

SHEETS

these items:
Add Page to Reading List: Adds the current
page the Reading List as a bookmark.
Capture …: Captures the Control-clicked
frame, image, link to the inbox of the
current database.
Capture Page: Captures the current page
in the selected format to the inbox of the
current database.
Copy … Address: Copies the frame URL of
a Control-clicked frame, image, page, or
video to the clipboard.
Insert > ...: Inserts checkboxes into the
document.
Open … in New Tab: Opens a Controlclicked image, page, or video in a new
DEVONthink tab.
Open Image in PhotoStickies: Opens the
image in PhotoStickies.
Open Page in Browser: Opens the current
page in your default web browser.
Open Page in DEVONagent: Opens the

Sheets contain text in a table and can be
used to store any kind of tabular data from an
address book to recording health statistics to
employee timesheets. They are made up of
records, defined by parameters displayed as a
form or columns. For example, a simple sheet
could contain a table of peoples' name, title,
and department.

current page in DEVONagent Pro.

When you create a sheet or make changes

Reload: Reloads the page from the Internet.

to the sheet columns via the Column Editor,
you will specify the column names and their
types. An explanation of the data types can
be found in the Data section of the appendix.
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Sheets can be displayed as a table or a form
via the View > Document Display menu or
using the

and

buttons in the navigation

bar. The table view is similar to standard
spreadsheet views. Form view is similar to
the record view e.g., in FileMaker.

EDITING BAR
To make working with sheets even more
efficient, DEVONthink includes the editing
bar with some basic tools:
Add a new record to the sheet.
Duplicate the current or selected records.
Delete a new record from the sheet.
Add a new column to the sheet.
Displays the Column Editor to allow editing
and managing the columns.
Delete a column from the sheet.
In Text Alternative, there is one more option
in the editing bar: Delete Selected Column

Use sheets like any other document. Add
new rows using Tools > Sheets > Add Record,
delete rows by selecting them and using Edit

allows you to delete a column. Just click on
the column header you want to delete, then
this option is enabled.

> Delete. Alternatively, use the contextual
menu. Click a cell to edit its content, press
the ⎋ Escape key to stop editing, and use the

CONTEXTUAL MENU

Tab or Return keys to navigate from cell to

There are a few sheet-specific contextual

cell. Hold the ⌘ Command key to activate a

menu items available when you're Control-

link in a cell.

clicking in a sheet.

If you import tab or comma-delimited files,

Cut/Copy/Paste: Cuts, copies, or pastes

e.g., CSV or TSV files, they will be imported

whole records in a sheet. Use them, for

and displayed as sheets. Sheets can also be

example, to duplicate records. Pasting

created via Data > New > Sheet. You will just

always pastes as the last record in the

need to provide starting column headings,

sheet.

which you can certainly add or take away

Delete Records/Columns: Deletes the

from later.

selected record(s) or column(s).
Edit Columns: Displays the Column Editor

NAVIGATION BAR

to allow editing and managing the columns.
New Column: Creates a new column in the

The Navigation bar displays the current
record and the total number of records in the
sheet. Clicking on this information opens a
Go to record function so you can quickly jump
to a specific record in the sheet. In addition,

sheet.
New Record: Creates a new record in the
sheet.
Duplicate Record: Duplicates a selected
record in the sheet.

there are options to go to the first, previous,
next, or last records.
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Note: Despite any visual or behavior

adding a sepia tone, etc. The Effects tab

similarities with Microsoft Excel, sheets

provides some simple pre-defined image

are not spreadsheets and therefore do not

effects. The Details tab displays metadata

provide functions and formulae.

about the image, including EXIF metadata
and a map of the geolocated origin of the file.

IMAGES, AUDIO, AND VIDEO
NAVIGATION BAR
For audio and video files, there is a special
option available in the navigation bar: the
playback time. This displays the current time
of playback (audio and video only). Also,
if you click the time it shows a Go to time
function so you can quickly jump to another
time in the playback.

CONTEXTUAL MENU
There are a few media-specific contextual
menu items available, excluding common
ones related to magnifying the image. In
addition to the standard controls, e.g.,
DEVONthink uses macOS core technologies

volume, playback position, etc., some of the

to display images and videos, and also play

same contextual menu options are found in

audio. Interacting with images uses the same

the action menu for these files.

controls you are used to, like pinch to zoom
in and out, two-finger tap to zoom to width,

Rotate Left/Right: Rotate the image

and even two-finger rotation in 90 degree

left and right. The image is saved in an

increments. Audio and video files display the

uncompressed TIFF format.

familiar macOS controls.

Flip Horizontal/Vertical: Flip the image on
the chosen axis. The image is saved in the

Images, audio, and video files can be

lossless TIFF format.

imported. Also in DEVONthink's Sorter you

Edit: Opens the Edit panel.

can capture the screen to an image, as well as

Copy Frame Link: Copies a URL linking to

record audio and video notes.

the current playback time in the file.
Copy Image: Copies the image or current

EDIT PANEL

video frame to the clipboard. When used

When working with images, double-clicking
opens an edit panel with three tabs. The
Adjust tab allows you to do some basic image
editing, like adjust exposure, saturation,
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with an image, an uncompressed TIFF file

When searching an EPUB file, the view/edit

will be captured.

pane will switch automatically to the Text

Set As Thumbnail: Makes the current frame

Alternative view to display the search hits.

the thumbnail of the video (only available
when the video is not playing).

OFFICE DOCUMENTS

Note: Edits to or copying an image via

Word processing, spreadsheet, and

contextual menu items produces an

presentation applications are common in

uncompressed TIFF file. These files can

many situations. When using the proprietary

be quite sizable, but are also saved in a

formats from these applications, like

lossless format.

Microsoft Word documents (.doc, .docx)
instead of rich text files, these formats aren't

OFFICE DOCUMENTS, EMAIL,
AND OTHERS

directly editable in DEVONthink. However, it
does support importing and indexing these
particular document types:

DEVONthink is the central hub for many
environments, from home to office, and you

Apple Pages, Numbers, and Keynote from

are likely using several other applications

Apple's iWork suite

along side it. As often mentioned,

Word, Excel, and PowerPoint from

DEVONthink supports importing many file

Microsoft's Microsoft Office suite.

types; some editable, some not. If a format

Files from supporting applications, like the

is text-based, like XML files, they may be

OpenOffice or LibreOffice suites.

directly editable. But even if a file is not

Files from the popular macOS Mellel word

editable, it may be searchable. This section

processor.

is obviously not exhaustive in what kind of
files can be added to DEVONthink, but if
you have a format we haven't discussed, the
easiest thing to do is just try importing it.
Any failures will be reported in Window > Log.

These formats can only be imported, however
it is possible to add template files of these
formats. For example, you may have a
boilerplate Pages document you often use.
This could be added as a template to quickly
add to your database, then opened and

EPUB
EPUB files (.epub) are a popular format,

edited in Pages. See the appendix for a bit
more information.

commonly used for digital books (including
our manual). While they can't be edited
in DEVONthink, their contents are fully
indexed and searchable, making them a viable
resource in your databases.

EMAIL
Imported email messages have their
contents indexed (excluding the contents of
attachments). This makes them searchable

Navigate an EPUB file in the Content > Table

and a valuable asset, whether you're archiving

of Contents inspector or choose the View >

email for personal or professional reasons.

Document Display > Text Alternative view.
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TEXT AND BEST ALTERNATIVE

Text Alternative mode for these files, some

For some document formats, e.g., email
messages or Word documents, DEVONthink
only allows you to select and copy text in
the Text Alternative view. If DEVONthink is

but not all contextual items related to text
selections are available. See also p. 215ff

LINKED FILES

able to interpret and convert the document

On occasion we get an inquiry about

format, you can use the

importing files with linked assets, like Adobe

and

buttons

in the navigation bar to switch between a

Illustrator or InDesign files. While it's certainly

view that allows you to select, copy, and drag

possible to import these, the links will be

text or the Quick Look view showing a more

broken if you try to import a folder structure

"accurate" view of a file.

containing the links. Groups in DEVONthink
do not exist in the file system, so the groups

Also note you will have text-related
contextual menu items available when
you can make text selections in the Text
Alternative view of a file.

that are created when you import a folder
structure from the Finder don't exist as
real folders in the database. The files inside
the folders are imported into the internal

Note: For uneditable formats, DEVONthink

structure of the database, so their paths are

uses Quick Look to display the file,

not pointing to the groups in the database.

provided an appropriate Quick Look plugin
or application providing one is installed. If a
document you want to view in DEVONthink
does not show a Quick Look preview, you
may need to contact the maker of the
source application and ask them to add
Quick Look support.

If you want to include these kinds of files in
your databases, you could keep the linked
files external and only import the documents.
You could also index the complete folder
structure containing your files into the
database, leaving them where they are in the
Finder. Since the paths aren't changing, the
links would be preserved when you open the

CONTEXTUAL MENU ITEMS

documents.

Contextual menu items aren't available
in Quick Look views, e.g., Control-clicking
in a PowerPoint file. Also, when using the
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IN & OUT
IN THIS CHAPTER

When you drag-and-drop files or choose File

Importing & Indexing
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Drag & Drop

54

Sorter

55

Archiving Email

56

Sync

59

Capturing Paper (Image Capture)

68

Capturing Paper (Other Options)

70

> Import > Files and Folders, files are copied.
This does leave the originals in the Finder,
which you can choose to keep or delete. But
note there is no connection between the
files any longer. Editing the file in the Finder
after importing has no effect on the file in
the database, as the database has a copy of
it. If you want to access and edit the files, do

Extensions and Bookmarklets

71

Web sharing

72

Services

76

If you hold the ⌘ Command key when you

PDF Services

77

drag into DEVONthink, the file will be moved,

Third-Party Applications

77

not copied, into the database. If you are using

DEVONthink is not an island. It integrates
with the rest of your Mac and iOS devices
in a variety of ways to make it easy for you
to add data to DEVONthink. There are even
some options that allow you to share your
data with friends and colleagues.

so from inside DEVONthink.

File > Import > Files and Folders, you can
click the Options button and enable Move
Originals to Trash.

INDEX
Creates links to files outside the database.
This allows more direct access to the files in

IMPORTING & INDEXING

the Finder by other applications or people.
A common example is people using a cloud

When it comes to getting data into your

service like Dropbox and indexing folders

databases, there are two fundamental

in the local Dropbox folders. DEVONthink

methods to consider: importing and indexing.

indexes the content and metadata for use
with classification and other content-related

IMPORT
Importing copies files into the internal
structure of the database. This creates a
portable, self-contained database that can
be moved as a single file. This is the default
behavior of DEVONthink.

functions, just as it does with imported
items. Do note while indexing doesn't copy
the contents of the files, the full text of
text-based is stored. This can still take up a
considerable amount of space.
Finder files and folders can be indexed using
File > Index. You can also hold ⌥⌘ while
dragging and dropping into your database.
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When you do, you will see a curved arrow

folder and could be indexed with all its

on the cursor while dragging, indicating the

contents included. You could also index an

items will be indexed. Indexed items with

individual folder, e.g., the "Data" folder, which

have a small square Finder icon to the right of

would be treated as a parent folder for its

the item's name.

contents. And you could also index individual
files within or outside of any folders. Each

INDEXING AND THE FILESYSTEM
Indexing is not the default option for getting

of these options has specific behaviors you
should be aware of, covered below.

files into your databases. This is not only

Moving Indexed Items: DEVONthink stores

because importing creates a singular,

individually indexed items by its absolute

portable database, but also due to some

path in the filesystem. If you move an

technical things that must be considered

individually indexed file or folder, it will

when indexing. Here are a few behaviors you

disappear when the database updates or be

should know and understand before indexing.

reported as missing. This is because the item

With indexing, the integration with the
filesystem is very tight. When you rename a
file in DEVONthink, the file's name changes
in the Finder. If you rename in the Finder, the
change should be automatically reflected in
the database. DEVONthink tries to keep the
group in the database and the folder in the
Finder in the same state.

no longer exists in the indexed location, so
the absolute path points to nothing. If you
move a file or subfolder inside an indexed
parent group, the change should be reflected
in the database or the Finder. The parent
folder still exists in the same location and
DEVONthink can adjust for the changed
relative paths within it.

When indexing items into DEVONthink,
you can index a file, an individual folder,
or a parent folder, i.e., one containing
subfolders. In the image shown, the
"DEVONtechnologies" folder is the parent
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If you delete a subgroup or a file in an indexed
group and empty the database's trash, you
will be shown the standard trash warning
shown here. If you accept this, the item
Deleting Indexed Items: When deleting

will be moved to the system Trash from

indexed items, you will see one of two

its location in the Finder. In this situation,

warnings when you empty the database's

DEVONthink is modifying the content of the

trash, depending on how you've indexed

indexed parent to ensure both the Finder and

the item. With individually indexed files, an

database's contents match.

indexed folder, or a parent folder, you will see
a warning prompting you to choose whether
to delete the item from the filesystem or
just the reference in the database. In this
instance, DEVONthink is prompting you to
make sure you aware of the potential removal
of a top level indexed item.

Duplicating Indexed Items: When you
duplicate an indexed item, the behavior
depends on if you're duplicating with
a database or across databases. if you
duplicate the item in the same database,
a copy will be created in the Finder in
anticipation of potential changes. If you
duplicate the item into another database, no
copy will be created in the Finder. However,
changes made to the item - in either
database - will affect both databases as the
indexed item is pointing at the same item in
the Finder.
Note: While you cannot replicate files
across database, the duplication of an
indexed file across databases can provide
you with a similar behavior. However,
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the files will not be marked as duplicates

Note: While DEVONthink can handle large

since duplicates are not detected across

amounts of data, it is inadvisable to import

databases.

or index uncurated data, like entire hard
drives or your Home directory. You should

Replicating Indexed Files: Replicating indexed

be judicious in what you put into your

files within a database, individually or within

databases.

parent folders, has no effect on the files in
the Finder. Replicating only adds a record
of another instance of the file. However, if

DRAG & DROP

you delete a replicant of an indexed file and

The Mac has always been an an environment

empty the database's trash, this will have

with rich drag-and-drop support.

no effect on the files in the Finder. They will

DEVONthink is a well-behaved citizen in this

remain intact.

regard. Here are some ideas:

Indexing Cloud-synced Folders: One of
the common uses of indexing is to keep

IN

a local folder in a cloud-synced location,

The easiest way to add data to DEVONthink,

e.g., Dropbox, and have access to the files

other than creating the documents directly

within DEVONthink. While this is certainly

inside the application, is to drag files or

supported, be aware that changes made to

selected data, e.g., text, images, etc., into a

the local folder, especially when the cloud

DEVONthink window.

service syncs changes to the local folder,
the changes may not always be detected

Drag files from the Finder into a database.

by DEVONthink. In that instance, you can

Holding certain command keys will allow

manually update the indexed group by

you to copy, move, or index them. See also

selecting and hoisting it via the disclosure

p. 51ff

triangle or choosing the File > Update Indexed

Drag files from the Finder to DEVONthink's

Items command. Also, you should only index

dock icon. Files will be sent to the default

local data, e.g., on the local hard drive or

destination.

connected drives. DEVONthink doesn't

With applications supporting drag-and-

support indexing data that resides only in the

drop, you can drag data between them

cloud.

and DEVONthink. For example, you can
drag messages from Apple Mail into your

Lastly, if you are indexing content and want

database or DEVONthink's dock icon.

to sync the databases between devices,

Inside DEVONthink, you may be able to

please review the Indexing and Sync section.

drag content from a file into the database.

Due to the flexibility of DEVONthink, it's
possible to have a database containing both

If you have an email message with an
attachment imported into your database,

imported and indexed files.
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you can drag the attachment out as a

Dragging: Moves items, by default.

separate file.

Option-Dragging: Duplicates items to the

With some file types it's possible to select

dropped location.

text and drag it out to create a new file.

Option-Command-Dragging: Replicates

DEVONthink will attempt to create the

items to the dropped location. Note you

most appropriate file type.

cannot replicate a file to the same location

Note: With the last two options, you may

as the dragged file.
be able to drag-and-drop content between
files.

SORTER
The Sorter is a multi-purpose utility built into

OUT
DEVONthink isn't just a receiver; it also allows
drag-and-drop of its files too.

DEVONthink providing options for adding
files and creating various types of notes.
When enabled in Preferences > Sorter, it
is found in the menubar at the top of your

For email applications lacking good
automation support, drag a document onto

screen — displayed as DEVONthink or the
nautilus icon — or docked to the side of

its dock icon or into a draft email to attach

your window. Details about the views and

it.

controls of the Sorter are covered in the

Drag documents or groups to the Finder as

Sorter section of the Windows chapter.

a quick export option. When you do this,
DEVONthink will apply tags you've added to
the documents also to the exported files as
Finder tags.
If you need to upload a document to
a website, drag the document in the
database to the page or the upload sheet,
if the site requires it. Note that groups
can't be added this way. You'd need to drag
the group to the Finder first, then to the
site.

INSIDE

The first view of the Sorter is the Navigation

And obviously DEVONthink allows

view. Access your favorites, or browse and

dragging database items inside itself for

search for groups in the open databases.

reorganization.

Double-clicking a found group will open it in
a new DEVONthink window. Drag and drop
files on the Sorter to quickly file them in a
favorited group, an inbox, or a location you've

DEVONthink 3.7 Documentation, page 55

found in a search. When docked, the Sorter

applications. It also allows you to import

will lock open during a search so you can

UNIX mailboxes (.mbox files) that can be

easily drop files into the desired location.

exported from some other email clients.

The Sorter's other views allow for quick and
easy note creation. It supports these note
types:
Take Note: Create text notes in plain or
rich text, Markdown, or formatted note
formats.
Voice Note: Record an audio note.
Video Note: Record a video note with the
built-in camera.
Screen Capture: Snap screen captures with
the option of adding metadata, e.g., tags,
rating, etc. directly into DEVONthink.

Beyond dragging and dropping emails from
an email client, you can select the View >

The Sorter allows you to clip web content as

Import command to show the Import sidebar.

well. It also functions as the interface to the

DEVONthink currently supports the following

Clip to DEVONthink browser extension.

email applications:

Clip content from the current page in your

Apple Mail

default web browser.

Microsoft Entourage

Clip content from a URL detected on your

Microsoft Outlook

clipboard.
Clip content via Clip to DEVONthink or
enter information and a URL manually, if
desired.

The imported email messages are saved
in their original file format (.eml) and
are displayed using QuickLook. MailTags
metadata on the messages is preserved as

All these methods give you the option of

tags. In addition, the "read" and "flagged"

capturing the content in a variety of formats,

status of email messages are transferred

with or without extra metadata, directly into

from Microsoft Entourage and Microsoft

your DEVONthink databases.

Outlook independently from your settings in
Preferences > Email.

ARCHIVING EMAIL
Email is an important item in many
situations, both professional and personal.
DEVONthink allows you to import email
messages directly from supported email

DEVONthink communicates with your email
application using either AppleScript or, if
you are using Apple Mail, through a special
plugin that implements a direct link between
Mail and DEVONthink. If the plugin is not
automatically installed select DEVONthink >
Install Add-Ons to install it.
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In addition to speeding up the transfer

imported emails are excluded from the

of email messages from Apple Mail to

mailbox view, subsequent visits to the

DEVONthink, the plugin adds an Add to

Import sidebar will only show newly

DEVONthink 3 command to the Mailbox

received emails. Using the Archive Mailbox

and Message menus of Apple Mail. This

option will import only those new emails

allows you to directly archive selected

into the existing Emails group in the

messages or mailboxes to your DEVONthink

database.

database while inside Mail. When accessing
a supported mail application via AppleScript,
automatic fetching of new mail is disabled.
This does not happen when you use Apple
Mail with the DEVONthink plugin installed.
Note: We highly recommend you install
the Apple Mail plugin as the AppleScript
implementation in Apple Mail is slow.
Also, due to limitations in the AppleScript
interface of Mail it's not possible to archive
complete conversations from Apple Mail
without the plugin installed.

IMPORT OR ARCHIVE
When it comes to archiving email, the
question arises: "Do I use import or archive?"
Here's the simple way to understand it:

Depending on the settings in Preferences
> Email > Conversations, DEVONthink can
attempt to import complete conversations
and optionally group them.
Note: Email threading is not an exact
process. There has also been no standard
defining relationships between messages
for a very long time. DEVONthink will
attempt to thread the conversations, but
cannot guarantee all related emails will be
detected.

IMPORTING UNIX MAILBOXES
UNIX mailboxes (.mbox files) exported from
some email applications, e.g., Thunderbird
or Postbox, can be imported into your
database. There is no mailbox structure in

Import Email: While Import can be used on

these exported files so multiple mailboxes

a mailbox, it is generally used on selected,

have to be exported and imported separately.

individual emails. This is especially useful

They can be imported into DEVONthink in

when using a filtered view, e.g., filtering

one of two ways:

by a date range or recipient. You'd select
those files and use the Import option.
Archive Mailbox: As the name implies, this
command can only be used on selected
mailboxes. The mailbox will be imported
into a special Emails group. DEVONthink
will attempt to preserve the mailbox
structure shown in the email application.
This is very useful for archiving a mailbox

File > Import: Use File > Import > UNIX
Mailboxes, then select the .mbox file in
the Open dialog and press Open. This will
import the messages into a group in the
current location.
Drag and Drop: Drag and drop the .mbox
file onto DEVONthink's dock icon to import
the messages into your database.

and keeping it up to date. Since previously
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PROBLEMS IMPORTING OR MOVING EMAILS
Briefly discussed in the Appendix, the UUID
is a value given to each item in DEVONthink.
It is unique to each item and more than one
item can't have the same UUID. When email

as replicants. However, this still will not allow
moving messages into databases already
containing those emails.

REPLYING AND SENDING

messages are imported, they are given such

To reply to an archived email message,

an identifier based on metadata from the

Control-click it in the item list and choose

actual email. This means you can't import the

Send Reply. A draft message will be

same message into a database more than

composed in your default email application.

once, as that would result in more than one
file having the same UUID. This will be shown
in DEVONthink's Window > Log. It can also

Choose Send by Email to email a selected
document from the item list.

cause issues when moving messages between

Note: The inter-application communication

databases. If you already imported messages

capabilities of the email client you are using

into a database and forgot you did, trying to

determine how well these two commands

move the same email into it will fail.

work. If the commands aren't producing

In Preferences > Email you can enable
Previously imported will become replicants to
import the messages into the same database

the expected results, check with the
developer about what kind of interactions
they allow between applications.
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SYNC

Before we discuss particular details of sync

of a database. Changes are made locally

methods, take a moment to check out the

then synced through the sync location to the

Preferences > Sync section. This gives you an

connected devices.

overview of the preference pane where syncs
are set up. Additionally, you will find a short

The only variations are:

glossary of sync-related terminology in the

If the second machine already has a

Appendix.

opened copy of the database, you will have
the option to merge with the sync data in

SYNC SIMPLIFIED
Sync is an incredibly simple concept. You
have a database on one machine. You want

the sync location.
Using a Bonjour sync, in which you'd import
and sync directly between devices.

that database on another machine. From

That's it. Every sync is conceptually the same.

the machine with the database, you upload

The differences you find are the requirements

the database to a sync location accessible

of the particular sync method, e.g., Dropbox,

from both machines. On the machine without

and are covered below. Bonjour and local sync

the database, you'd access the same sync

stores show a few more specific (but simple)

location and import the database. This way,

steps, but they all follow the same essential

every device, Mac or mobile, has a local copy

pattern shown here:
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Enable a location (with or without an

If you copy the database (.dtBase2 file)

encryption key).

between machines, that is clearly a true copy

Upload a database to the sync location.

of the database. Also, importing a database

Enable the same location in DEVONthink

via sync logically yields a true copy of the

on another Mac or DEVONthink To Go in

database. True copies are databases that

iOS (using the same encryption key, only if

have the same internal identifier (UUID).

specified).
Import from or merge a database to the
sync location.
Repeat as needed.

BASICS AND HOW TO

What is an encryption key?: Regarding
the privacy of your synced data, all sync
methods allow you to specify an optional
(but recommended) encryption key for a
sync location. The key is an alphanumeric
string of your choice and length. This key

This sync section isn't long because it's

is used to "scramble" or "descramble" the

complicated; it's long because of the variety

sync data using AES-256 encryption and

of options available. While the basics of sync

the data is stored in an encrypted state.

are very simple, questions will arise and there

All databases synced to a location using an

are details to be covered. Below we answer

encryption key will sync encrypted data. If

some common questions, then describe

you specify a key when syncing, you must use

specifics per sync method.

the same encryption key when setting up the

What is a sync store?: A sync store is a folder
on a server or service (the 'sync location')

same sync location on other devices running
DEVONthink or DEVONthink To Go.

that DEVONthink uses to store sync data

Note: Bonjour syncs don't allow you to

for your syncing databases. Give it a name

explicitly specify a key, but the sync data is

made only of alphanumeric characters. A

encrypted by default.

concatenated name, e.g., Research_01 can
be used. Note this folder is only for use by our
sync engine.

Can I encrypt after I've already synced?: It
is not possible to simply add an encryption
key after syncing as DEVONthink cannot

What is a 'copy of the database'?: One

encrypt already synced data. Indeed, if you

detail to understand about syncing: Only

add, remove, or modify an encryption key

true copies of a database will sync together.

post-sync, you will see Invalid encryption

Two databases having the same name but

key warnings in the Log window. In order to

created independently are not the same

switch to an encrypted sync, you'll need to

database. These databases will never sync

clean the sync location first. Control-click

together. This is also why you shouldn't

the sync location and choose Clean Location.

create a database on the receiving machine,

After the clean has been successfully

hoping to "fill it up" with data from the source

reported in the Log window, Control-click the

database.

sync location again, modify the encryption
key as desired, then enable databases to sync
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again. However, remember that changing or

throttled, the speed of the sync will be

removing the key will require making that

affected. Syncs on your local network, e.g.,

change in DEVONthink or DEVONthink To

Bonjour, are much less likely to be affected.

Go if they are syncing with the same sync
location.

INDEXING AND SYNC

What are the Local and Remote sections

Often people index content from the local

for?: As noted above, a database must

repository of a cloud service like Dropbox.

be local to the machine so it must either

The question then arises: "If I have my data

be open in DEVONthink or imported from

on Dropbox' servers and I sync to Dropbox

the sync location. For a non-Bonjour sync

via DEVONthink, aren't I just using twice the

location, Local section of the Databases

space?" The answer is practically, yes. In the

list displays all local open databases. For a

Show Info for a sync location in Preferences >

Bonjour location, the Local section displays

Sync there is an option Synchronize contents

databases that are open both on the local

of indexed items. Unchecking this will sync

machine and the Bonjour server machine.

only the metadata for the files, not the

The Remote section displays any databases

contents. However, you should only disable

that aren't open locally or those that have

this option if:

never been imported to the local machine.
You cannot sync to a remote database. It
must be imported locally, then you sync the
local copy.

You are syncing another Mac, linked to
your Dropbox account, and having the
local Dropbox folder in the same relative
location. The default location is ~/Dropbox.

How quickly will it sync?: DEVONthink's

If the locations are different, the files will

sync does not run constantly. To balance

appear as missing on the second Mac.

performance and reduce unnecessary

You are not syncing with our mobile

network noise, it syncs on an interval. While

application, DEVONthink To Go.

the interval can vary by sync method, a good

DEVONthink To Go does not support

standard to consider is: sync will initiate

indexed items. Also, if you are using

up to 45 seconds after a change is saved

the Download Files: On demand option

in a database and every 4.5 minutes of idle

in DEVONthink To Go, you could never

time when set to Automatic. You can set a

download the contents since the contents

different interval, noting a longer interval,

are not present in the sync location.

e.g., Hourly, can help lessen the resource load.
For the most flexibility, it is advisable to
Another consideration with a remote sync

ensure you have enough storage space for

is the quality of the network and server

syncing.

responses. If your network is slow or poor
quality or the remote servers are slow, not
responding quickly, or bandwidth is being
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BONJOUR

Note: Bonjour does not function over
VPNs. This is a technical limitation of the
technology, not DEVONthink.
Bonjour Setup:
Step 1: On the machine acting as the
server, open Preferences > Sync and press
the Bonjour Options button.
Step 2: Click Enable Incoming Connections
to use this Mac as a Bonjour server of
its databases. Optionally, have closed
databases open when a client initiates a
sync.

Bonjour (also called a direct connection) is
technology you are almost certainly already
acquainted with. If you have a wireless printer
or scanner and notice how your Macs and
mobile devices can see those devices by
name with no setup by you, they are using
Bonjour. Bonjour is a way for devices, or
services like DEVONthink's sync, to broadcast

Step 3: Enter a mandatory password. This
password is required for other devices to
act as a client of DEVONthink's. If you are
working with an IT department who has
assigned a port for you, or you have a port
you'd specifically like to use, enter it in the
Port field. Otherwise, leave this blank and
DEVONthink will assign one for you.

its presence on a network without requiring

The Mac with Bonjour enabled should now

technical know-how by the user.

be visible as a sync location to other devices

When it comes to syncing, a Bonjour sync
deals directly between devices. One device
acts as a server, the other a client to that
server. The participating devices must be

on your local network. On the other devices,
enable it, enter the password, and you can
import databases or sync existing databases
directly with it.

on, running DEVONthink or DEVONthink

Note: You should never use more than

To Go, and on the same network. There

one device as a Bonjour server for a given

is no intermediary location where data is

database.

stored. This is much faster than uploading
all data to some server on the internet and

LOCAL SYNC STORE

downloading it again on another device. But,
when you leave your office and you haven't
synchronized your databases, you'll need to
wait until you come back another day.

A local sync store is a specialized folder
containing sync data on your local machine or
connected drives and servers. This is a very
fast and reliable sync method for Mac-to-Mac
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syncing. You can use one sync store to sync

Note: Due to technical limitations, a local

multiple databases or create more than one,

sync store currently cannot be used for

e.g., one for a particular group of databases.

Mac-to-mobile syncing. iOS doesn't have

Setup a new local Sync store:
Step 1: Open Preferences > Sync and enable

the ability to mount file servers.

ICLOUD (LEGACY)

the Local Sync Store option. If you already
have one created, click the + button and
choose Add Local Sync Store.
Step 2: In the sheet that appears, navigate
to the location you want to save the
sync store. Enter a name and an optional
encryption key, if desired. Then press Add.
Step 3: When the location is created,
select it and enable the databases you
want to sync in the Databases list on the
right.
Setup an existing local sync store:
As most Apple devices are logged into your
Step 1: Locate the local sync store
(.dtCloud) file in the Finder.
Step 2: Double-click the sync store or drag
and drop it into the Locations pane in the
Sync preferences.
Step 3: If you used an encryption key when
you first synced to the existing location
from another machine, select the sync
location and press the Info button to open

Apple ID, iCloud is the simplest method to
set up and sync with. Since it's logged into
your personal account, it can only be used
for syncing with your own devices. If you
want to keep your databases in sync but
not share them with others this is a great
choice. We strongly recommend an iCloud
plan with enough storage. Here are the simple
instructions to set it up.

the Info popup. Enter the appropriate
encryption key.
Step 4: When the location is created,
select it and you should see any importable
databases listed in the Remote section of
the databases list.
Step 5: Double-click a database you want
to import, saving it to a safe location,
e.g., the Databases folder in your Home
directory.

iCloud Setup:
Step 1: Open Preferences > Sync and enable
the iCloud (Legacy) option.
Step 2: Enter an optional encryption key, if
desired. If you are already syncing to this
location from another machine, you must
enter the same key you used. Leave it blank
if you didn't use an encryption key.
Step 3: Select the sync location and enable
the databases you want to sync in the
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Databases list on the right. If you already
synced from another machine, double-click
a database in the Remote section, saving it
to a safe location, e.g., ~/Databases.
One thing to realize with iCloud syncing, the
sync is done locally. After sync is finished,
iCloud uploads to Apple's servers, then to
devices using your Apple ID. This means
databases may not be immediately available
to sync on the other devices. The initial
sync requires patience, as DEVONthink has
no control over the speed and reliability
of iCloud's process. It syncs to the iCloud

CloudKit Setup:

folder, iCloud does the rest. See the CloudKit

Step 1: Open Preferences > Sync and enable

section below for an alternative option.

the CloudKit (iCloud) option.
Step 2: Enter an optional encryption key, if

CLOUDKIT (ICLOUD)
Utilizing the same active iCloud account, the
CloudKit option offers a single-stage sync
with the same simple setup as the iCloud
(Legacy) method. However, with this option,
the sync is directly to Apple's servers. This
can appear to be a bit slower than the legacy
option, but once the sync is finished the
files are already uploaded without having
to wait for iCloud to sync on its own. This

desired. If you are already syncing to this
location from another machine, you must
enter the same key you used. Leave it blank
if you didn't use an encryption key.
Step 3: Select the sync location and enable
the databases you want to sync in the
Databases list on the right. If you already
synced from another machine, double-click
a database in the Remote section, saving it
to a safe location, e.g., ~/Databases.

also conserves space as no sync data is
temporarily stored on the local machine's
hard drive. The instructions are essentially
the same as setting up iCloud (Legacy).
You're just choosing the CloudKit (iCloud)
option instead.
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DROPBOX

done on other devices you are setting
up this same Dropbox sync location.
Once the authentication is allowed, you
subsequently can add and remove other
Dropbox sync locations in DEVONthink.

If you are using a Dropbox sync and also the
Dropbox application, it is advisable to exclude
If you have a Dropbox account you can use

the DEVONthink Packet Sync folder inside

it just like you'd use WebDAV. DEVONthink

the Apps folder from being synchronized with

creates a private folder for its sync stores

your Mac. This keeps the Dropbox app from

and so keeps its data separate from your

wasting valuable disk space and bandwidth

photos and other documents. Of course it

by re-downloading all changes you've made to

does not get access to anything except its

your databases, and from spamming you with

own files. Dropbox and DEVONtechnologies

notifications.

respect your privacy.
Step 1: Click the Dropbox icon in the
The setup for a Dropbox sync location is

menubar at the top of your screen,

essentially the same as for iCloud. However,

then click the account icon and choose

there are two differences of which to take

Preferences.

note:

Step 2: Select the Sync tab and click the

Sync Store Name: You will have to enter a

Choose folders to sync button.

Sync Store Name. This is where the sync

Step 3: Select the Apps folder, and uncheck

data will be stored in the Apps folder of

Step 4: Click the Update button and okay

your Dropbox account. You can add more
than one sync location, if desired.

the DEVONthink Packet Sync folder.
the removal of the local data.

Authentication: Since the Dropbox sync

Note: Due to Dropbox' API restrictions,

connects and syncs directly with the

you cannot sync between Dropbox

Dropbox servers, you are required to

accounts, .e.g., between yours and a

authenticate the connection. When you

colleague's account. Also it is not possible

first enable a Dropbox sync location in

to connect DEVONthink to more than one

DEVONthink your default web browser

Dropbox account at a time.

will open and ask you to allow access
to our sync engine. This will need to be
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WEBDAV

DEVONthink to connect to the WebDAV
server.
Note: A typical complete path would
be similar to: https://myWebDAV.com/
WebDAVvolume/WebDAVFolder. The volume
and folder are generally case-sensitive.
Specifying a WebDAV folder may be
required if the server doesn't allow you to
write to the root of the volume. Check with
the manufacturer or provider.

If you run your own WebDAV server, your ISP
offers it as a service, or you have subscribed
to an online service such as CloudMe, this
might be for you. Generally, if you can access
the WebDAV server with Go > Connect to
Server in the Finder, you should be able to
connect DEVONthink to it.
Your data is stored in encrypted sync stores
on the server. You can keep all your devices in
sync at any time as long as you have internet

CloudMe: A European cloud service offering

access.

WebDAV services, there is a built-in template

Setting up a WebDAV connection follows
the same simple pattern and allows you to
specify a sync store name. But there are a
few parameters that must be entered to
make the connection:
URL: This is the address of the WebDAV
server to which you are connecting. Make
sure you use the proper protocol of http
or https. Also make sure the URL is a

for syncing with it. Just enter the username
and password you use to log into the service,
enter a store name, and DEVONthink with
connect with a proper WebDAV URL for you.
Other cloud services: If you are interested in
other cloud services to sync with, services
offering WebDAV connections should be
supported. Check the FAQ or Support pages
to see if it's supported.

complete path, as required by the server or

Rolling your own: It is possible to run

service you're using.

a WebDAV server on your own. Some

Username/Password: Enter the defined or

NAS drives, e.g., Synology, have WebDAV

provided username and password to allow

capabilities and you can run a WebDAV server
by repurposing an older Mac. Even some
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more full-featured packages like OwnCloud

and DEVONthink To Go. You cannot go into a

or NextCloud can be set up for WebDAV

sync location and retrieve a specific file, and

services. However, these options can provide

neither could anyone else, friend or foe.

more technical challenges in setup and
administration beyond the scope of our
support.

Should I use one sync store per database:
This is either a personal choice or a
requirement of your specific situation. A sync

Note: With Dropbox and WebDAV

location can be used with one, several, or

connections, if you are connecting to a

all databases. However, if you'd like to use

location you've already synced to, a list of

one sync store per database, it may lessen

existing sync stores is displayed in the Sync

the time in troubleshooting in case of a sync

Store Name dropdown. This way you can

issue. In situations where you need to sync

quickly add the proper sync store instead

certain databases to certain individuals, you

of trying to remember the exact name you

can use one sync store for each subset of

gave it.

databases.

Q&A

I want to sync a database with multiple
sync locations.: While using a Bonjour or a

I'll just put my databases in (name your cloud

local sync store sync as a secondary option

service): This is not data-safe and never

should work, this is not suggested generally

has been. The mechanisms used by cloud

when using a remote sync option like iCloud

services are not compatible with package

or Dropbox. Multiple sync stores are best

files, like our databases. Due to the number

used only for different databases and/or

of broken databases we've seen over the

different devices, e.g., to synchronize specific

years, DEVONthink will neither sync nor open

databases via one sync store for personal use

databases stored in these locations. We

and sync others via a second sync store for

suggest keeping them in a folder in your home

business purposes. Otherwise unnecessary

folder, like ~/Databases.

duplicates might be caused, especially if

I want to access my databases from one
location: Along with the previous note, this is
not possible. Databases are stored locally and
must be imported to the current machine.
I want to find my files in the sync location:

the Conflicts setting in sync preferences
is set to Duplicate documents. Each sync
location is updated independently so changes
may not be received on one before it syncs.
Also, syncing a database to multiple remote
locations can waste space and bandwidth.

Your databases do not "live in the cloud". Sync
does not copy your databases and files into
any sync location. It transmits raw, chunked,
and optionally encrypted DEVONthinkspecific data, only useful to DEVONthink

TROUBLESHOOTING
Generally, syncing is a transparent and
reliable process. However, poor network
conditions, unreliable servers, etc. may cause
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unexpected issues. Please refer to the Sync

DEVICES

section of the Troubleshooting chapter for
some possible fixes.

CAPTURING PAPER (IMAGE
CAPTURE)
DEVONthink comes with built-in support for
Image Capture compliant scanners, as well as
for the Fujitsu ScanSnap.
OCR: DEVONthink optionally makes scanned
documents searchable by using optical
character recognition (OCR). OCR adds an

Select your connected scanner or camera in

invisible text layer to the scanned file that is

the Devices section of the sidebar to run a

computer-readable and searchable; a layer

scan or download images from a connected

that is recognized by DEVONthink's AI engine.

iOS device or camera. The main pane shows

OCR on scans is generally enabled by default.

an interface similar to what Apple Image

For best results we recommend scanning at

Capture uses.

200 dpi in color and with 100 percent quality.
Choose the scan destination in the To popNote: If you are using a Fujitsu ScanSnap,

up menu. Either send the scan directly to any

see the next section.

of your databases, add them as single files

To capture paper using an Image Capture
compliant scanner open the Import sidebar

to the Imports section, or choose any binder
that you have created there.

using View > Import or selecting the icon over

Scanners: DEVONthink generates an overview

the sidebar. It is divided into a sidebar and

scan of the current page in the scanner,

a main pane, which changes depending on

and allows you to select which parts of the

your selection in the sidebar. The options

page you want to capture and set the scan

in the sidebar are arranged from top to

options. Click Scan to capture the page.

bottom according to a typical scan workflow:
Scan, check the scanned pages, arrange the

Cameras: DEVONthink shows the available

pages in a document, and save them to the

images. Select the images you want to

database.

import, rotate them if necessary, and click
Download or Download All to download the

If you are using a scanner with an automatic

images to your computer. You can also delete

document feeder (ADF), you can also use a

images from your camera with the Delete

Queue to prepare a pile of sheets for batch

button.

processing and scan them in one go.
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IMPORTS

click or Control-click images to add them
to an existing or new document using the
contextual menu.

QUEUE

The Imports section contains scanned pages
or binders of collected scans. Create empty
binders here to which you add your scanned
pages. Alternatively, use the Create new
Binder button at the bottom of the sidebar.
Add pages by dragging them from to the
desired binder, in the current view or the
sidebar. Rearrange added pages if desired
and set the document properties by clicking
the Properties button. Use the Sort button

If you are using a document scanner with
automatic document feeder, you can use the
queue to add multiple pages or even multipage documents to the feeder and scan them
in one go.

to reverse the sort order or shuffle pages,

Choose your scanner in the pop-up menu

e.g., when scanning all front pages first, then

above the list. Then use the Add and Delete

the back pages. Choose Sort and Merge

buttons to add or delete steps and rearrange

Documents to merge two documents where

them by dragging. Edit the fields to set a title

one contains all the odd pages and the other

or tags, or to change the document type or

all even pages.

destination. Check OCR to convert a scan to

Note: You cannot save multi-page

a searchable PDF after import.

documents as images; therefore, PDF is the

To scan a batch of paper, set the Separator

only option for the file type here.

either to Page Count and the number of
pages in the document or to Blank Page to

TRASH
This is where you find images that you have

begin a new document every time a blank
page is encountered.

deleted from Scans & Images or Imports.

Before starting the batch run, adjust your

Empty the trash using the Empty button

scan settings by clicking the Configure

at the bottom of the window or right-

button. If you want to convert the scans
to searchable PDFs, you should choose a
resolution of minimum 300 dpi. Then click the
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Start button to start scanning. Finished steps
are marked as "Sent". To remove finished
items from the list, select the ones to remove
and press the minus button at the bottom of
the window. Alternatively, click the dropdown
button and choose Remove Sent or Remove
All.

USING AN UNSUPPORTED SCANNER
You can also capture paper using an
unsupported scanner and import the finished
scans into DEVONthink. To do this, use the
scan application that came with your scanner
or a third-party scan application. Check
the scan application's preferences and look
out for an option that allows you to open

CAPTURING PAPER (OTHER
OPTIONS)

the finished scan with another application,

DEVONthink works with the Fujitsu

application for the scan to DEVONthink.

ScanSnap, ExactCode ExactScan, and other
scanners that are not directly supported.

e.g., an image editor. Change the default

DEVONthink knows the identifiers of many
scan applications and will convert the

In addition, you can add already scanned

incoming scan to a searchable PDF if possible.

pages to your DEVONthink database and

If DEVONthink does not recognize your scan

manually convert them to searchable PDFs.

application, please create a Zip archive of
the application and send it to us so that we

USING A SCANSNAP SCANNER

can add its identifier to a future release of
DEVONthink.

DEVONthink recognizes scans sent to it from
the Fujitsu ScanSnap Home application or

Note: In the settings for the scanning

the older ScanSnap Manager software. To

application you're using, it is best to leave

send scans automatically to your databases,

the default location for the output path,

simply add DEVONthink to ScanSnap Home

often ~/Pictures. Do not set the path to

or ScanSnap Manager as the application

DEVONthink's Global Inbox, as this can lead

to use for opening completed scans. The

to errors when DEVONthink tries to import

scanner app will send the created PDFs to

a scan that is not completed yet.

DEVONthink which in turn will import the
document. The files will be imported into
the Global Inbox or a selected location,
depending on the option set in Preferences >
Import > Destination.

IMPORTING EXISTING FILES WITH OCR
If you already have an archive of documents
that have been scanned without OCR, or
if you cannot use the capture function for

ScanSnap's scanning software can provide

whatever reason, you can import image files

already OCR'd PDFs. However, if you don't

while applying OCR.

enable this option, DEVONthink can perform
the OCR on the incoming scans if you've
enabled Preferences > OCR > Convert
Incoming Scans.

To import an image file while applying OCR,
choose File > Import > Image with OCR. Click
the Options button to choose the output
format and whether to send the original to
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the system trash after importing. The image

an option, Add to DEVONthink that allows

will be processed with DEVONthink's OCR

you to send data from the application to

engine and be imported to the database

DEVONthink.

in the format chosen. If you have enabled
Searchable PDF: Set metadata after
text recognition in the OCR preferences,
DEVONthink will show the metadata entry
window when the OCR process is completed
(before the file is actually imported to the
database).
The date of the created document is set to
the date of the original file. Thus, for archival
purposes, the searchable document is
identical to the original one. The modification
date is set to the current date and time to
reflect the addition of the searchable text
layer. If you're importing a PDF, any keywords
in the original file are retained and used as
tags.

Installation: Just as other sharing extensions
are installed, open System Preferences >
Extensions > Share Menu and enable the
option for DEVONthink. It should now be
available in any sharing-enabled application's
Share menu.
Note: The data being sent is controlled by
the sending application, not DEVONthink.
If there are issues with the data received
in your database, please contact the
developer of the application to report your
findings.

BROWSER EXTENSIONS
Browser extensions add functionality to your
favorite web browser. DEVONthink's Clip to

EXTENSIONS AND
BOOKMARKLETS

DEVONthink extension usually appears as a
nautilus icon in the web browser's toolbar.
When clicked, the Clip to DEVONthink will

DEVONthink provides a sharing extension
(requires OS X Yosemite or later), a web
browser extension, as well as bookmarklets,
for conveniently clipping information from
other applications into your DEVONthink

identify data about the current page in the
browser and open the Web Clip section of
the Sorter. Here you can simply select the
location to clip the content or add optional
metadata, like tags, label color, etc.

database.
Installing: The Clip to DEVONthink for Safari
SHARING EXTENSIONS

extension is installed by DEVONthink by
default. The extensions for Firefox and

Sharing extensions let you "share" data with
other applications or web services such
as Twitter and Facebook. Extensions are
mainly intended for the sandboxed App

Chrome can be installed from our Extras
download page. You can also access these
pages via the DEVONthink > Install Add-Ons
panel.

Store environment where applications can
no longer easily communicate with each
other. When you access the Share menu in
a compatible application, you should see
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Note: While there is no direct support for

browser extension or bookmarklets. Other

other browsers, some allow you to install

browsers allow you to make a persistent

Chrome extensions. This may allow you

choice about this behavior.

to install our browser extension in those
browsers as well.

BOOKMARKLETS

WEB SHARING
DEVONthink allows you to give others on the
local network access to your databases using

Similar in function to a browser extension,

a standard web browser on any operating

but much simpler, bookmarklets are special

system (including Windows and Linux). The

bookmarks that execute some JavaScript

embedded web server provides an interactive

to capture the current page or selection in

web interface that allows defined users to

the browser. To use one of the bookmarklets,

interact with the shared databases. Here are

load the page you wish to archive or clip

the first steps to getting started using this

text from in your web browser. When the

powerful feature.

page is fully shown, select the bookmarklet
in your bookmarks bar. Instead of loading
another page as normal bookmarks do, the
bookmarklet adds the selected text or the
whole page as text, bookmark, HTML code,
web archive, or PDF to DEVONthink's default
destination.
Installing: Bookmarklets can be installed
from our Extras download page. Typically,
the bookmarklet can just be dragged and
dropped to the browser's bookmarks toolbar.

SECURING YOUR SHARED DATABASES

However, you may need to Control-click
the bookmarklet and copy the code to

Before you start sharing your data it's a good

add it manually, if the browser requires it.

idea to check the security settings.

We have provided separate bookmarklets,
one for each type, currently supporting
capturing: bookmark, web archive, HTML,
PDF (paginated or single page), plain text, or
the selection as plain text.

To enhance the security for the databases
you broadcast, you define users and give
them per-database permissions. You will
also set a certificate for the server, so the
connecting users can validate they are

Note: Due to increased security in macOS,

connecting to a safe server. These items

Apple Safari will prompt you to allow

are set in Preferences > Server. Users will

launching DEVONthink when using the

only be able to interact with the databases
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based on the permissions you give them,

in the preferences, your users may be able to

including disallowing them even to see certain

add a bookmark to their browser for quick

databases.

access.

Note: Depending on the certificate settings

Note: We believe in data privacy and

specified in the preferences, a warning

hope you do too. Browsers may present

about an invalid certificate may be shown

options to save login credentials. Some

when users access the web sharing. This

may even save the credentials by default.

is especially true when using a self-signed

We are cautious of the first and not a fan

certificate. While this warning is something

of the second. If the user is on a shared

to be suspicious of when browsing in

computer, consider what access other

general, you and your users can accept it in

users could have if using these options to

this case.

save credentials.

SHARING A DATABASE

USING THE WEB INTERFACE

Start and stop the server: Once the

The interactive web interface imitates the

certificate and users have been set up to

look-and-feel of DEVONthink in many ways,

your liking, press the Start button to start

but in a condensed form. Contrary to a static

the server. You can also select the Tools >

web site, it only loads once; clicking buttons

Start Server command or choose the Start

or links does not reload the whole page but

Server option in DEVONthink's dock icon. If

dynamically updates it. This also means you

the server is running, these will display Stop

should use the Back and Forward controls in

instead.

the user interface instead of the ones in your

Share your server's address: Once the web

browser's toolbar.
server is started, you will see links at the

Similar to the DEVONthink, the web interface

bottom of the preference pane. These are

is divided into panes: toolbar, sidebar, item

the active links you will share to individuals

list, and view/edit pane. But note some

you have defined as users. One option is

operations, e.g., deleting or organizing items,

to Control-click the link, select Share from

are dependent on the permissions you've

the contextual menu, and share it via your

been given for the specific databases.

preferred method. You can also use Copy Link
and paste it where you need to. Lastly, you
can click and drag the link directly to many
applications, like Apple Messages.
The person who receives your link will open
the page, login with the username and
mandatory password you've defined for
them, and have access to the databases you
want them to see. If you have specified a port

Sidebar: The sidebar is where you can
navigate the databases' inboxes, groups, tags,
and trashes in the sidebar. You can even drag
items from the item list to reorganize things.
Item List: Selecting items in the sidebar will
display the contents in the item list. When
using the standard preview position, the list
can be sorted by clicking the column headers.
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There are options to enable or disable

access to the computer. Lastly, it gives you

them in the contextual menu. Items can be

access to two powerful options: the See Also

dragged, handily for filing loose documents

pane and the search field.

into groups. Double-click groups to display
their contents in the item list. For quick
navigation, press the < and > arrows to go
back and forward to visited locations in the
databases. You can also click the locations in

See Also: When you show the inspector
pane, the second view is a See Also view. This
displays potentially related files in the current
database you are viewing.

the path bar above the item list to jump to a

Search: Searching the viewable databases

parent location.

can be done in the search field. Enter search

View/Edit pane: Displayed below the item
list or to the right, depending on the preview
choice made in the toolbar, this pane will
attempt to display the contents of the
selected file. Clicking and dragging the divider
bar allows you to resize the pane, relative

terms, including using search prefixes to
focus the searches. For example, you can do a
search for text:housing tags:government.
If you want to restrict where you're searching,
select All Databases or a specific database to
search in.

to the item list. A select number of file

Descriptions of the controls in the user

types, e.g., plain text, formatted notes, and

interface can be found in the Web Sharing

Markdown files can be viewed and edited in

section of the Windows chapter.

this pane. When the Info inspector is shown it
will display as a pane on the right side of the

ACCESSING YOUR DATA OVER THE

view/edit pane.

INTERNET

Note: Due to the limitations of browser

Web sharing is best used on a local area

technologies, some file types cannot be

network (LAN). But there may be situations

displayed.

where you want to share the database to

Toolbar: Some handy options are available
in the toolbar, including switching the
position of the view/edit pane, adding
some metadata, e.g label or rating, to a

users that aren't on your network. While we
can't provide specific support due to the
differences in equipment and environments,
we have provided a simple guide you can try.

selected item, and creating groups and a

To access your database from outside your

few document types. It also has controls for

network, you need to make your Mac "visible"

uploading new documents and downloading

to the outside world. In general, when you

currently selected ones. A user menu allows

a using a DSL or cable modem, you are also

you to switch between English and German

using a router. Routers create an intranet that

language and also provides a Log Out option

your Mac is connected to and "route" traffic

for more security when allowing others

between the internet and your personal
intranet. Now, you need to create a route
from the outside leading to the Mac sharing
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your database. This offers a port on the

interface you are using (usually Built-In

outside that is directly connected to the port

Ethernet or Wi-Fi).

on which DEVONthink is publishing.

Step 4: Decide on a public port for

If everything goes well, you will be able to
access your database using an address like:
http://xxx.xxx.xxx.xxx:port, where
xxx.xxx.xxx.xxx is your current public IP
address. (Note: This is your router's address
on the internet, not your Mac's.) Next, port
is the outside port number leading to your
published database.

DEVONthink. The port should be in the
range 1025-65500. We suggest that you
use port 8080, which is traditionally a
default port for private web servers.
Step 5: Configure port forwarding on
your router. The steps to do this vary
from router to router, but all of them
require you to provide these details: Public
port, private destination IP, and private

Port forwarding done manually: The following

destination port. You found the private

is only a rough outline of the steps needed

destination port in step 2, and the private

to configure port forwarding manually. The

destination IP in step 3, and you selected

precise way to do it varies from router to

the public port in step 4. If you are in doubt

router. You will need to consult the manual for

about how you configure your router to

your router in order to determine exactly how

do port forwarding, you need to consult

to set things up. To configure port forwarding,

the manual that came with your router.

follow these steps:

It is usually done through a web-based
interface or custom-built administration

Step 1: Begin by determining your Mac's
public IP address. This can be done
by visiting a web site like https://
www.whatismyip.com from your machine.
Step 2: Determine the port on which
DEVONthink published on your Mac. You
set the port in Preferences > Server.
To publish on the internet, enter a port
number here and do not let DEVONthink
set it automatically as the port number
may then change every time you open the
application.
Step 3: Determine your Mac's private
IP address. The IP address is usually of
the form 10.x.y.z, 192.168.y.z or
172.16.y.z. You can find your Mac's

application. For instance, AirPort routers
can be configured using the AirPort Admin
Utility.
Step 6: Save the configuration changes
on your router, and restart the router if
required. At this point, you are ready to
connect to your DEVONthink from the
outside.
Step 7: From the remote computer, open
a web browser and enter the address as
follows: http://xxx.xxx.xxx.xxx:port,
where xxx.xxx.xxx.xxx is the public IP
address you found in step 1, and port the
public port you selected in step 4. Press
↩ Return and you should get presented
with your database's web interface.

private IP address by going to the Network
preferences panel in System Preferences
and looking it up under TCP/IP for the
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Setting up port forwarding can be tricky, but

This service is also available in the Finder's

the difficult part is mainly in determining

contextual menu.

how to configure your particular router. If you

Capture Bookmark: Adds a bookmark to a

are in doubt, search online for your router's

URL selected in text.

name and combine it with a search for "port

Add to Reading List: Adds a bookmark to a

forwarding" or "port mapping."

URL selected in text to the Reading List.
Take Plain/Rich Note: Adds selected text

SERVICES

to the global inbox as a plain or rich text
note from any application that support

The DEVONthink > Services menu gives

services. Taking a rich text note also copies

you access to special commands provided

images and clickable links. If the source

either by other applications, such as TextEdit

document is a web page or a news feed,

or Safari, or by services extensions such

DEVONthink tries to capture the address

as DEVONtechnologies' WordService or

of the page or feed as well. This only works

CalcService. Also, DEVONthink publishes its

with applications that support this feature,

own services in the Services menu.

such as Safari, DEVONagent Pro, and other
web browsers.
Append Plain/Rich Note: Adds selected
text as plain or rich text to the last note
taken using the DEVONthink Services
menu items.
Lookup: Opens the search pane in
DEVONthink with the selected text copied
as search term.
Summarize: Creates a new note in
DEVONthink's inbox with a summary
of the selected text. DEVONthink uses
all documents in the open database
for determining what's important and
what's not. The summarization settings
in Preferences > Editing, define whether

DEVONTHINK SERVICES

the summary are be based on sentences or
paragraphs.

DEVONthink installs several services for
copying or summarizing selected text,
capturing a web page, or searching for
documents in your databases.

If you want to assign hotkeys to services,
go to System Preferences > Keyboard >
Keyboard Shortcuts > Services. Do note that
application hotkeys can override hotkeys set

Add to DEVONthink 3: Adds selected files,

here. Try to make sure to specify unused key

bookmarks, or images to your database.

combinations in your shortcuts. Also, due to
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the way macOS loads menus, you may need

Note: This requires an installed printer to

to show the DEVONthink > Services menu

work properly.

once before the hotkey will become active.

THIRD-PARTY APPLICATIONS
PDF SERVICES

DEVONthink offers many standard ways to

Another way to get files into DEVONthink is

integrate with third-party apps including

using PDF services. Installing DEVONthink's

drag-and-drop of common data formats,

service adds a Save PDF to DEVONthink

copy-and-paste, and AppleScript. In

option to the PDF button of the print dialog

addition DEVONthink comes with special

in any Mac application. This allows you

arrangements for applications often used

to print a paginated PDF directly to your

together with it.

database.
Bookends: Choose File > Import >
To install the PDF service, select DEVONthink

References from Bookends to import

> Install Add-ons and check PDF Services in

Bookends references as rich text

the dialog window. Then click Install and the

documents with a back link to the original

option should now be available.

item in Bookends.

Printing to your database: To "print" (save) a
document to DEVONthink as a PDF, open it
in its creator application (this could even be
DEVONthink itself). Then, do the following:

Evernote: Choose File > Import > Notes
from Evernote to import selected Evernote
notebooks.
Tinderbox: Copy notes in Tinderbox and
choose Data > New > With Clipboard to

Select File > Print.

create plain or rich text copies of the notes

In the appearing print dialog window, click

in DEVONthink including backlinks and

the PDF button at the lower left corner

tags.

and select Save PDF to DEVONthink from

Yojimbo: Choose File > Import > Items from

the menu. A PDF will be printed and sent

Yojimbo to import all items from Yojimbo.

to DEVONthink. Depending on your choice

Items without URLs are backlinked.

in Preferences > Import > Destination, the
file import into the Global Inbox or let you
choose the destination group.

Apple Mail: DEVONthink adds its own menu
commands into Apple Mail to facilitate
importing selected message or mailboxes
into your databases. See also p. 56ff
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WINDOWS
IN THIS CHAPTER

DEVONthink uses a number of windows to

Main Window

79

Sidebar: Navigate

85

Sidebar: Filters

90

Sidebar: Smart Group and Rule Editor

93

Sidebar: Reading List

94

Sidebar: Image Capture

94

Sidebar: Email

97

Sidebar: Extras

98

Document Window

99

Download Manager

100

The Sorter

102

Preferences

107

Database Properties

107

Popovers

109

Web Sharing

111

Support Assistant

113

Log

115

Activity

116

present information. These windows are
used for displaying and manipulating groups
and documents, finding information, editing
metadata, analyzing text, and changing the
properties of your database.

DEVONthink 3.7 Documentation, page 78

MAIN WINDOW

The main window is split into simple sections,

You can can toggle the pane's visibility in the

some of which will be familiar from other

View > Preview menu or via a toolbar button.

applications. In fact, as we introduce the
components of the window you'll see

Layouts:

DEVONthink has many familiar elements in

Widescreen: The View/Edit pane is

it. We start off with the fundamental panes

displayed to the right of the item list, an

you'll use.

option common in many Mac applications.
Standard: The View/Edit pane is displayed

VIEW/EDIT PANE
When You launch DEVONthink you will see
an empty pane at the bottom of the window
reading Nothing Selected. This is the View/
Edit pane, a preview pane displaying the
currently selected document. This pane gives
you a view of the content of compatible

under the item list. This is a bit more
traditional but very useful on smaller
screens, e.g., MacBooks.
None: Hides the View/Edit pane. Note you
can still select any file and press the space
bar to preview it in a Quick Look pane, as
needed.

documents. It also allows you to work on

As noted above, DEVONthink allows

compatible files directly in the main window

displaying and editing, and even creating,

when the pane is shown. Or you can hide the

some file types. Please refer to the

preview, perhaps if you want to concentrate
on information about a group of documents.
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Documents chapter for more information on

opens groups in a new window checkbox

this and other components related to the

in Preferences > General. Note this view is

View/Edit pane.

best used without a preview or in standard
layout.

ITEM LIST
When you open a Finder window, you are
presented with a list of files in a certain
location. The view may be icons or a list, etc.
but you are still just viewing the contents of a
folder, hard drive, etc.

List: Behaving much like Finder's List
view, the

List view shows a list view

of the items with metadata columns.
Drag the columns left and right to reorder
them to your liking. Sort them by clicking
the column headers, switching between
ascending and descending each time you

DEVONthink is no different in this respect.

click. Control-click the headers to add or

When you open a main window, you will see a

remove columns. Or make these choices

list of groups and documents in the current

from the Tools menu.

location. Clicking on or opening other groups

Columns: The Mac OS X Finder received

shows their contents. Smart groups, just like

the Columns view from its NextStep

the Finder's smart folders, also display their

counterpart, then iTunes adopted it for

contents in an item list. The item list also

browsing music. DEVONthink's

supports familiar operations like drag-and-

view functions in the same way. This option

drop between groups, copy and paste, group

works best with a preview in standard

and ungroup, contextual menu items when

layout, for quickly viewing selected files,

you Control-click, etc., just as you've done in

but you can also use Show Details to

the Finder.

display metadata and the file's thumbnail.

Column

Expanding the width of the column by
Views: Again, taking a cue from the Finder,
the item list allows you to display your
documents in some familiar views:
Icon: For the more visual folks, we have the
Icon view. This displays the thumbnails

dragging the separator will scale the
thumbnail, if desired.
Cover Flow: An iTunes feature that found
its way to the Finder and DEVONthink is
Cover Flow. Similar to the Icon view but

of the documents with just their name. You

with dynamically created thumbnails, i.e.,

can choose Show Details to display some

the displayed image is generated from

additional metadata in a widescreen view.

the contents of the file. This side-scrolling

Change the size of the thumbnails with

item list can be useful when making visual

the slider in the information bar, noting

assessments of documents. It is best

this will affect the amount of metadata

used with a standard layout or without a

shown as well when details are shown.

preview displayed.

Double-clicking groups behaves just as
double-clicking a Finder folder, displaying
the contents in the current or a new
window, depending on the Double-click
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All these views can be easily changed in the

The Flag column shows the state,

View > View options, as well as the quartet of

or unflagged, or the

icons

items. Clicking in the flag column toggles the

on the right-hand side of the

Information bar.

flagged

unread status of

flagged state. If an item is unread, a circle

Sort: In addition to sorting the item list by
clicking column headers or using the View
> Sort menu, you can also choose a sort
method in the Sort dropdown menu in the

will appear in this column. If you have a group
containing a mix of flagged and unflagged
items, a dash will appear in this column,
showing an indeterminate state.

information bar. By default it reads by Name.

Additionally, DEVONthink displays special

Also, notice there is a Customize Metadata

property icons to the right of item names

command in the Tools > Columns menu, the

for attributes like Spotlight comments,

contextual menu, and this menu. Select it

reminders, etc. A key of the item icons can

to fine tune what columns are available to

be found in the Iconology section of the

display, including any custom sets you've

appendix

created yourself.
Contextual menu items: When you ControlVisual Cues: DEVONthink provides some

click in a Finder window, a contextual menu

visual cues applied to items in the item list.

appears with a host of commands for you to
choose from. DEVONthink's item list also has
a contextual menu available. The commands
shown depend on what is selected and
in what pane you're using. A list of the
commands can be found in the Contextual
Menu Items section of the appendix.
Note: To keep visual consistency and
make some functions more broadly
accessible, item lists are used throughout

Duplicates: Duplicate files display their

DEVONthink's interface, so you'll see

name emboldened in blue or with the

them in some other panes. But note some

icon, depending on your setting in

functions, like specific contextual menu

Preferences > General > Mark duplicates

items, may change, depending on the

and replicants in color.

specific pane you're using.

Replicants: Replicant files display their
name in red italics or the

icon, again

depending on the preference setting.
Unread: Unread items, including groups
with unread items in them, display their
name in bold.

TOOLBAR
At the top of most Mac applications you
encounter, including the Finder, you will see
the toolbar. For people who prefer working
with tracking devices, e.g., mice, trackpads,
etc., the toolbar allows you to have quick
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access to some functions without having
to go through the menus. DEVONthink also
provides a toolbar in main and document
windows.

INSPECTORS
In some applications, extra information about
files is shown in a pane on the right side of
a window. DEVONthink also provides such a

The toolbar comes pre-installed with a handy

pane in its main windows with individual sub-

default set of buttons, including the search

panes called Inspectors. For example, data

field (see below). It can be customized via the

about the name, tags, type, etc. of a selected

Tools > Customize Toolbar command. You can

file are available in the Info Inspector. Unlike

also Control-click the toolbar and choose this

other applications, it gives you multiple

command from the contextual menu. Add,

inspectors presenting more information

remove, and reorder these items to suit your

and functions, all docked in the inspectors

particular needs. On a side note, if you want

panes. This gives you quick access to all the

to quickly reorganize items on the toolbar,

inspectors in one unified window, especially

hold the ⌘ Command key and drag the item

helpful on smaller screens.

to its desired location, or off the toolbar to
remove it.

The inspectors are individually discussed in
the Inspectors chapter.

If you're looking for a little more space for
your toolbar, or even a little less, you can
choose to display the toolbar as Icon and
Text, Icons Only, or Text Only. Do bear in
mind, the Icon Only view will not show the
current document's title or icon.
A list of the available toolbar items is
available in the Toolbar section of the
appendix.

SIDEBARS
Seen in scores of applications for many
years, a sidebar is a top level organizational
structure, typically found on the left side
of an application window. The Finder or
Apple Mail sidebars are perfect examples
of this. Looking at them, you should
see the immediate similarities with
DEVONthink. However, unlike most other
apps, DEVONthink has multiple sidebars,
each with their own special functions covered
a bit later in this chapter.
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SEARCH PANE

Storing information is a useful thing, but

Live while typing: Enable this option to

it's more useful when you can find things

search while typing or disable it to search

too. DEVONthink offers a strong search

only when you press ↩ Return.

function for finding items in your databases,

Partial matches while typing: This option

all integrated into a main window.

assumes an asterisk wildcard at the end of

In the toolbar is a search field for entering
your search terms. Type in a word and the
search pane appears showing any matched
items — and yes, it's another item list
supporting the different views and sort
methods discussed above. Additionally, the
View/Edit pane can be shown to display
selected results. For contents-based

the last search term.
Ignore Diacritics: This allows you to ignore
special marks on letters, like umlauts or
accents.
Fuzzy: This uses fuzzy-logic to expand the
possible matches DEVONthink makes.
For example, hello and hullo would be
matched.

searches, the search terms will be highlighted

Search prefixes: Anything you type into

in the preview, whenever possible.

the search field will be treated as searching

Search options: In the search field, you will
notice a

magnifying glass icon. Click this

icon to see where to search, list the ten most
recent search queries, one choose among the
following options:

in all possible attributes. However, if you
want to focus on specific attributes, e.g.,
file types or tags, the search field supports
prefix operator searches, similar to Spotlight.
Common examples are searches like
name:DEVON or tags:tech;sync, separating
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multi-valued attributes like tags with a

Searching inboxes or all databases creates

comma. There are a wide variety of prefixes

a global smart group, shown in the Smart

available, as well as different prefix operators.

Groups section of theNavigate sidebar.

A complete list of these items is included in
the Search Prefixes section of the appendix.
In addition to search prefixes, DEVONthink

Note: The search index contains
alphanumeric characters as well as the
following symbols: $€£¥%§

supports Boolean operators, parenthesis for
grouping terms, and quotes to match specific
terms. Read more about operators and how
to use them in the Search Operators section
of the appendix.

PATH BAR
On the left side of the main window, just
below the toolbar, is the Path Bar. This is
a specialized bar displaying a crumb trail

Search scopes: After you've done a search,

of your current location in a database. For

you will also see a bar above the search

example, if you are in a nested group, it will

results allowing you to choose the scope of

show something like Coding > AppleScript

the search. The scope is the "where" you're

> WWDC > 416, beginning with the current

searching. You will be shown All Databases,

database.

Inboxes, the name of the current database,
and the name of the current group, if you're
currently viewing one. Choose one to expand
or limit where DEVONthink is searching.

Each item in the crumb trail is a live link, so
you can click it to jump to any parent folder
or back to the top level of the database. ⌃click an item in the crumb trail to open the

Advanced and save: To the right of the search

location in a new main window or reveal it in

scopes, you will see two buttons. Clicking the

the current window.

Advanced button displays the criteria of the
current search. You can modify the search
with the same kind of controls used in the
Finder's smart folders, as well as some other
applications with advanced search methods.
Note these controls are also used in creating
smart groups and smart rules.

This bar also has < and > buttons so you can
navigate back and forth between locations
you've visited in this window. Bear in mind,
these buttons only relate to the history of the
specific window. If you open a new window,
it will have no history so the buttons will
not function until you've navigated to some

If you have done a search you'd like to use

locations. As an added feature, click and hold

again, press the Save button. Enter a name

one of these buttons to be shown a list of

and DEVONthink will create a smart group

previous locations you've visited, just like in a

for you. If your search scope is in a group,

web browser.

the smart group will be created there. If you
are searching a specific database, the smart
group is created in the root of the database.
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INFORMATION BAR
Another specialized bar, the Information
Bar displays the number of items selected

smart groups and smart rules, selecting
multiple items will show a union of their
contents in the item list.

and the total number of items in the current

The sections in the Navigate sidebar can

location. As mentioned previously, this

be dragged to reorganize them as desired.

bar also hosts the Sort dropdown and the

Sections you don't need to use as often

view icons.

can be collapsed to reclaim the space or to
provide a bit of privacy.

SIDEBAR: NAVIGATE
UNIFIED ELEMENTS
The Navigate pane is the default sidebar
where you will access to your databases, tags,
items located in Favorites, etc. Additionally,
you have access to some specialized items:
global smart groups and smart rules.

By default, specific parts of databases are
shown gathered in specific sections, similar
to how Apple Mail displays the inboxes of all
accounts in the same section.
Globals: The Globals section provides quick
access to three locations common to all
databases: the Inbox, Tags, and the Trash.
If you click a top level section, e.g., Inboxes,
you will see a combined view of items in the
inboxes of all open databases. This can be
especially handy if you want a view of all the
tags you're using in your databases. Click the
disclosure triangle next to each section to
show the locations for each open database,
allowing you to access the locations on an

Each section in the Navigate sidebar has its

individual database level.

own specific purpose: giving you access to
frequently used files, navigating database
groups, or viewing a list of similar files. The
sidebar will only show databases and groups.
Selecting one of these items will display
its groups and files in the item list. This
allows a clear view of the group structure
in the sidebar, while still allowing you to
interact with the contents in the item
list. Alternatively, you can view the group

Inboxes: The inbox of a database, like the

hierarchies directly in the sidebar. Excluding

real-world counterpart on an office desk,
is where incoming, unfiled items are kept.
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Every database has one by default and you

Tag. Or from the contextual menu, Control-

can see the name of the database each inbox

click the database's top level Tags group or an

belongs to. The Global Inbox, shown just as

existing tag and select New Tag.

Inbox, is a special, always-open database
present in every installation of DEVONthink.
This is highly useful when quickly capturing
data, e.g., web clipping, screen captures, etc.,
without stopping to file things. You can then
go back later and file these items at your
leisure.

If you find yourself in a situation with multiple
tags you'd like to merge, select the Tags group
for the current database to view the tags in
the item list. You can then select the tags
there and choose Tools > Merge Items.
Removing entire tag groups can be done by
dragging and dropping to the sidebar's trash.
From the contextual menu, you can choose
Move to Trash. You can delete tags in the
item list as well. One thing to note: When you
delete a tag, the original file in the database
is preserved. What you see in the database's
trash is the replicant that was created in the
tag group when you added the tag.

Tags: The Tags section provides quick access
to all the tags you are using or tags within
individual databases. If you click the top level
tags, the item list will display all the tags
you've created. Open this group and click on
a database's name to show its tags. If you like
to create nested or hierarchical tags, you can
drag and drop existing tags in the sidebar or
the item list.
Typically you will use the Tags bar in the
View/Edit pane or the Info Inspector or
Info popup to apply or create tags. You can
also drag items in your database to the
individual tags. When you create a tag it will
automatically appear in the Tags group of the
database you're in. If you want to create new
tags to be used later, select the Tags group
for the database and choose Data > New >

Trash: Every database has its own individual
trash. This allows you to see, and potentially
retrieve, items you've deleted from your
individual databases. Just as with the realworld trash bin, we do suggest you empty
your databases' trash regularly. It is not
meant as another filing location, and items
marked as missing will still register as a
problem for a database. Select the trash,
the top level or individual database's trash,
and choose DEVONthink > Empty Trash. The
command is also available in the contextual
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menu, when Control-clicking a trash. Trashed

Note: With Unify Inboxes and Tags both

files are not deleted completely from the

disabled, the database's contents will

machine but are put into the system trash.

appear similar to how DEVONthink 2
displayed databases.

Open Databases: This section is where you
see and access any databases you have
currently open. Click the database's name
to display items in the root of the database.

Databases: When disabled, DEVONthink

Clicking the disclosure triangle allows you to

displays a database's name in the Open

show groups, and subsequently sub-groups in

Databases section of the sidebar but the

the database. As mentioned above, selecting

contents will be shown in a separate section.

a database or group will display its subgroups

The current database will be marked on the

and files in the item list.

left by an asterisk (*) and its groups will be
shown in a separate active database section

NON-UNIFIED ELEMENTS

in the sidebar. This creates an isolated view
of that database regardless of the number

As the unified views may be less comfortable
for some people, DEVONthink allows you to
decide what database elements you want to
unify. Controlled by options in Preferences >

of databases that are open. Interacting with
elements in the active database section
displays contents in the item list, similar to
the Three Pane view from DEVONthink 2.

General > Sidebar, you can enable or disable
unifying: Inboxes, Tags, or Databases.

For switching between active databases,
select another database and the active

Inboxes: If you disable unifying the inboxes,
only the Global Inbox will be shown in the
Globals section. The inboxes of individual
databases will be shown in the item list when

database section will display only the groups
and smart groups of that database. Also,
there are Previous Database and Next
Database commands in the Go menu.

the database is selected.
When using the keyboard, hold the Command
Tags: Similar to the inboxes, disabling this
option will display the Tags group with other
elements in the selected database.

key and press the up and down arrows to
view the contents of another open database
in the item list while showing the contents of
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the previously active database in the active
database section. Press ⇧-↩ to change the
active databases section to the currently
selected database.

CONTEXTUAL MENU

FAVORITES
There are many times we have specific
databases, groups, or documents we return
to, again and again. Shown at the top of the
sidebar by default, the Favorites section
allows you to create shortcuts to quickly

There are a few specific contextual menu

access any of these kind of items. Drag a

items found in these sections of the Navigate

group or a document to this section's header

sidebar. These commands are also found in

and you'll see a curved arrow on the cursor.

the File or Data menus:

Drop the file and you have a new favorite. An

Copy Database/Item Link: Copies a link to
the selected item.
Database Properties: Displays information
about the chosen database.
Close Database: Closes the chosen

option to Add to Favorites is available in the
contextual menu commands of most items
in DEVONthink. Use Remove from Favorites
when Control-clicking on already favorited
items to remove them.

database. In the case of encrypted

Select an item in Favorites to quickly access

databases, the encrypted volume will be

it. If an item was last viewed without a

ejected as well.

preview, it will be displayed in its own

Delete Database: Deletes the chosen

window. If you see a favorite is greyed out,

database to the system trash. This includes

it means the containing database isn't

its cache and Spotlight index as well.

open. Double-clicking the item will open the

New Window: Opens a new main window

database, if possible, and display the item.

for the chosen database. When used
on closed databases in the Favorites or
Recent Databases sections, hold the ⌥
key for the alternate command, Open
Database in New Window.
Rename: Change the name of the chosen
database. This can also be done in the

Drag items in the section to reorder them.
Groups in Favorites behave as normal groups,
so you can drag items into a favorited group
for quick filing. This includes using ⌥ and ⌘⌥
to duplicate or replicate items while dragging
and dropping to them.

Database Properties.

Note: Favorites only support one level of

Reveal: Display the location of the item and

content, so you can't group or nest items

select it in the item list.

here.

Show in Finder: Reveals the database file in
the Finder.

RECENT DATABASES

Any section-specific contextual menu items

The Recent Databases section provides quick

that may require explanation are discussed in

access to reopen closed databases. This will

their respective sections below.

list the last ten recently closed databases.
Double-click any databases you'd like to open.
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SMART GROUPS
The global smart groups function the same
as local smart groups, i.e., the ones in your

a smart rule, ⌃-click the desired smart group,
hold the ⌥ key, and choose Duplicate as
smart rule.

individual databases, but generally their

If you have exported smart groups in the

scope is all open databases. This allows

Finder, double-clicking them will import them.

you to have reusable searches targeting all

You can also drag them to the smart rules

your open databases, e.g., all Markdown

section of the sidebar.

documents in all databases created in the
last month. These global smart groups can be
modified to target more specific locations,
but such a smart group would be better
suited as a local smart group, i.e., in the
particular database. DEVONthink comes with
some pre-installed global smart groups:
Today: Shows all documents added or
modified today.
Recently Added: Shows all documents
added in the last week.
Due This Week: Shows all documents with
a due date set for this week.
Top Hits: Shows documents opened more
than five times in the last 30 days.

For more information on editing smart group
properties, global or local, see the Smart
Group Editor section of this chapter.

SMART RULES
Similar to smart groups, smart rules are
created, edited, and behave in a similar
fashion. However, they have one distinct
difference: they can act on the items
matched. The smart rule matches items just
as a smart group does but they perform
actions when certain events take place. This
makes them a very powerful way to add
automation to your DEVONthink life.

Unread: Shows all documents marked as

DEVONthink provides a few useful example

unread.

smart rules to get you started:

You can create a smart group from the

Automatic Locking: Locks unlocked

contextual menu or the + button at the

documents (excluding RSS articles), that

bottom of the sidebar. By default all open

haven't been modified in the last 30 days.

databases will be targeted. However, if you

This requires user intervention.

have an item selected in the Globals or Open

Bates Number: A specialized rule that adds

Databases sections, the smart rule will use

the current database's name and a Bates

that location for the matching.

number to a filename. The original name is

Control-click a smart group to Edit, Rename,
Duplicate, or Remove it. You can also copy a
link to a smart group, export it to the Finder,
or import previously exported ones. If you'd
like to convert an existing smart group into

preserved as a document alias.
Filter Duplicates: Automatically puts
duplicated items in a database's trash
when you import them.
Reminders: Displays the name of a
document and plays the system "glass"
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sound when a reminder on a matched item

Drag and Drop: Lastly, you can drag and drop

triggers.

items onto smart rules to apply their actions

If you Control-click a smart rule and choose
Edit, you will see the criteria, event trigger,
and actions for that rule. Like smart groups,
you can create a smart rule from the
contextual menu or the + button at the
bottom of the sidebar. The target of the
smart rule also follows the same behavior
as a smart group: all databases are targeted
unless you have an item selected in the
Globals or the Open Databases section of
this sidebar.
Control-click a smart rule to Edit, Rename,
Duplicate, or Remove it. You can also copy a

to them. Dropped items will be acted on,
ignoring the location and criteria specified in
the smart rule. For example, you may have a
smart rule to add the date to the beginning
of the name of images imported into your
Global Inbox. However, you could drag and
drop a rich text file from a separate database
on to the smart rule and the date would
be prefixed to the name, even though the
location and file type do not match the rule.
For more information on editing smart
rules, see the Smart Rules section of the
Automation chapter.

link to a smart rule, export it to the Finder,
or import previously exported ones. Double-

SIDEBAR: FILTERS

clicking exported smart rules imports them,

Providing yet another way to isolate files

and so does dragging them to the sidebar.

in the item list, the Filters pane allows

In the contextual menu for a smart rule,
notice there is also a smart rule-specific
command: Apply Rule. This runs the clicked
command on any matching files. This means
it will performs its actions, even if the event
trigger is not set to On Demand. Be cautious
about using this command unless you are

you to only show files that share common
attributes. This pane, displayed at the
bottom of the Navigate sidebar an be shown
or hidden via the Tools > Filter menu or the
trio of icons at the bottom of the Navigate
sidebar. The pane can be resized by moving
the divider at the top of the pane.

certain you want to affect all matched items.
There is also an option to copy the item link
for a smart rule by choosing Copy Rule Link.
There are two commands in the Tools menu
related to smart rules:

INFO
Displayed by selecting Tools > Filter > Info, the
Info filters pane let you shows only files that
share common dates, ratings, color labels,
etc.

Tools > Apply Rules: This runs the actions
of a chosen rule on selected items, but only
ones matched by the smart rule.
Tools > Perform Rules: This performs the
chosen rule as defined, not acting on the
selection.
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File Location: Click the dropdown to choose
whether to display Imported, Indexed, or
both with Any.

TAGS
Choosing the Tags filter via Tools > Filter >
Tags displays a tag cloud derived from the
tags on the current list of files. The cloud
shows the tags in varying sizes depending on
the number of occurrences of each tag on
these documents. The more files with a given
tag, the larger it displays. This makes it easy
to identify commonly used tags. If there are
no tags on the files in the current item list, No
Tags will be displayed. Additionally, Controlclick in this pane to sort the tags by Name or
Dates: Click the Date dropdown to choose

by Count.

the type of date you want to filter on: Added,
Created, Modified, Opened, or Due. Click on
a date in the calendar display to only show
files related to the day and type of date
you selected. Use the small arrows to move
backward and forward through time, and click
the circle between them to quickly return to
the last selected date.
Marks: Choose the type of mark, or a
combination of them, on which you want to
filter. For example, you can click the flag and
a rating of 3 to show only those files. You can
filter on these attributes:
Flagged or unflagged
Read or unread
Locked or unlocked
Rating

To filter the files, click any tag. You will

Label

immediately see the tag cloud reduce in
number and only related tags are shown. This
allows you to drill down into files that share

DEVONthink 3.7 Documentation, page 91

common tags, but also exposes tags that
have been used with the previously selected
tags.
Note: The tags you choose will also be
shown in the Information bar above the
item list. Hovering over one of these tags
displays a

close button at the right side

of the tag. Click it to stop filtering on that
tag. You can also press the Reset button to
clear all filtered tags.
Control-clicking a tag in the tag cloud shows
these options:
Reveal Tag: Displays the Tag group in the
list of tags from all open databases.
Remove Tag: Removes the tag from the
Tags groups and also from any document it

The map functions similar to Apple or Google

was applied to.

Maps, allowing you to use familiar pinch

Related Tags: Displays the top two tags

gestures or double-click or Option-double-

most commonly used with this tag.

click to zoom in and out, panning, etc. The

Selecting a tag from this list filters the files

map shows pins for all documents with

on that tag.

geolocation data in the selected location in

View>: Allows you to switch between cloud

the Navigate sidebar. Selecting a pin in the

and list view.

map displays the files with that geolocation

Sort: Allows you to sort the tags by name

data in the item list.

or count.

MAP
Utilizing geolocation data from your files,
the Maps filter shows documents related by
location. Show this filter pane by selecting
Tools > Filter > Maps. By default, the pins on
the map show the place a document was
created. However, the geolocation data can
be manually changed to a relative location,
like the site of a historic event. (See the Info
Inspector for more information on this.)
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SIDEBAR: SMART GROUP AND
RULE EDITOR

the terms in the text of selected search
results, if possible.

PREDICATES
The second section of the editor shows the
search predicates. These define criteria you
want to match. Criteria may be content- or
attribute-related, e.g., documents containing
a specific word or groups added this week.
Note: The predicate editor is also shown
When you create or edit a smart group or

when using the Advanced options when

smart rule, a sheet appears with options for

searching your databases. It is also shown

specifying options, like the criteria to match

in a similar sheet when you run the Tools >

or from where to match items.

Batch Process command.
The list of predicates consists of a list of

OPTIONS

blocks, each beginning with All or Any,

The top section of the sheet contains a

defining whether all (Boolean AND) or any

mandatory name and search location, as well

(Boolean OR) of the contained predicates

as a few optional items.

need to be true for the document to be
returned as a result. Predicates themselves

Name: Enter a name for the smart item.
Search in: Select where you want this
smart item to search.

consist of the field to search (like "Content"
or "Tag"), and the condition and the data that
needs to be matched.

Exclude Subgroups: Enable this to ignore
items in subgroups of the location selected

Add as many criteria as you need. Use the +

in the Search in dropdown.

and - buttons to add more predicates to your
smart group or to delete them. Predicates

In the Comparison section, you will see these
options:

can be rearranged with drag-and-drop. Hold
the ⌥ Option key and click a ... button to

Ignore Diacritics: Check this to treat

create a "compound predicate" also called

letters with diacritics, e.g., umlauts or

"branch". Each branch also has its own All or

accented characters, the same as their

Any option as well. This allows you to create

regular counterparts.

very targeted searches.

Fuzzy: Check this to apply fuzzy logic to
contents-based criteria, ignoring simple
typos so that instances of "hello" and
"hallo" are both found.
Highlight Occurrences: When used with

Example: To find all Microsoft Excel files
use the condition Filename ... ends in ...
xslx. To find items created in the last 7 days
use the condition Date created ... is ... Last
Week.

contents-based matching, this will highlight
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Note: In some predicates you can use

Items in the Reading List can be moved to

wildcards, Boolean operators, phrases, and

other locations by dragging them to any item

parenthesis, too. See also p. 218ff

list in a main window. The drag operations
also allow you to duplicate or replicate the

SIDEBAR: READING LIST
Similar to the section found in Safari (and

files, holding ⌥ or ⌥⌘, respectively.

CONTEXTUAL MENU

now many other browsers), the Reading
List provides a place to access documents

The contextual menu (which appears when

and groups you've "set aside" for later

you Control-click an item) offers these

consideration. The items are listed in All

commands:

and Unread views. Newly added items are
displayed at the top of the list.

Open in New Tab: Opens the clicked item in
a new tab.
Open in New Window: Opens the clicked
item in a new document window.
Mark as Read/Unread: Changes the read
state of the clicked item.
Reveal Item: Reveals the item in its current
location.
Move to Trash: Moves the item to the
database's Trash. Emptying the Trash
removes the file and its reference from the
Reading List.
Copy: Copies the selected item(s).

Add files from the item list via drag and drop
when this pane is visible. Alternately, choose
the Data > Add to > Reading List menu item.
This command may also be available when
Control-clicking in an item list or in images
and PDFs.
Items added to this pane will automatically
appear in the Unread view. Selecting an item

Select/Deselect All: Selects all or none of
the items, respectively.
Remove Item: Removes the clicked item
from the Reading List.
Clear All Items: Removes all Reading List
items.
Note: The last two options cannot be
undone.

with the View/Edit pane visible will treat the
item as read and the item will only be shown
in the All view.

SIDEBAR: IMAGE CAPTURE
The Import sidebar pane gives you access
to two common sources of external data:
scanning and email. Each section in this
sidebar provides controls to import from any

DEVONthink 3.7 Documentation, page 94

supported scanner or a compatible email

efficiently. This interface should be familiar

client, e.g., Apple Mail or Outlook. This makes

to anyone using Apple's Image Capture

DEVONthink a reliable companion at home,

application or scanning in Preview.

in an office, in the hands of an archivist,
and many other scenarios. We will cover the
scanning controls in this section. We have
also provided a more practical overview in
Capturing Paper section of the In & Out
chapter.

Overview: The overview of what's being
scanned. When using a Custom Size you
will define the scan area in this pane.
From: Choose where you'll be inserting the
paper into the scanner.
Mode: Choose the color type: Black &
White, Grayscale, or Color.
Duplex: Enable double-sided scanning, if
available.
Resolution: Set the desired resolution
of the scan. 300 dpi is the suggested
resolution for most cases.
Size: Choose a pre-defined page size or
check Custom Size and manually change
the scan area in the overview. Resize the
scan area or even drag multiple scan areas
on the same scan. You can also enter

Archiving documents is an important

specific measurements. Switching to a

function in many situations. The Image

pre-defined size will clear any custom scan

Capture section of this sidebar allows you

areas.

to control compatible scanners or import

Orientation: Change the orientation of the

images from connected cameras or iOS

final document.

devices.

Name: Enter a name for the final
document. If left empty, a date stamp will

DEVICES

be used as an automatic name.
To: Choose where to send the document:

The Devices section allows you to choose
an input device. Choosing a scanner offers
different controls and options than selecting
a connected iOS device or camera.

Imports, create a new binder or use an
existing one, or choose a destination in a
database.
Destination: The chosen location in a

Selected Scanner: If you select a scanner you

database will be shown here. You can also

will be presented with controls and settings

choose a location to send binders to when

to scan your documents. This allows you to

saving.

use your scanner directly in DEVONthink very

Kind: Choose the format for the final
document.
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Tags: Enter optional tags to be applied to

finished document. This section can be very

the document.

useful when batch scanning. The following

OCR: Enable OCR for the scan, if desired.

controls are shown in this view:

Camera or Mobile Device: Clicking on a

Scanner: Choose an available scanner.

connected camera or mobile device displays

Flatbed/Document Feeder: Choose where

an item list of photos to import. These

you'll be inserting the paper into the

items can be imported for a variety of

scanner.

uses. Additionally, for documents you've

Document List: Defined documents and

photographed, the images can be added

their parameters are listed here.

to a scanning document (described below)

Add/Delete: Add or delete new document

and OCR can be done to create searchable

definitions.

PDFs. This can be very useful for everyday

Remove Sent/All: Contained in a popup

things like receipts to archiving historical

menu, remove already processed or all

documents.

documents from the list.

To: Choose to import items to Imports, into
a new or existing binder.
Thumbnails/Details: Switch between a
thumbnail or a detailed list of photos.
The size of thumbnails is controlled by

Configure: Global scanner settings for
color type, resolution, page size, and duplex
scanning (double-sided, if available).

IMPORTS

the slider at the lower right corner of the

Containing individual scans or Binders,

window.

collections of scanned pages. Create or

Delete: Shown as a stop symbol, use this to

access existing binders and scanned pages in

delete selected images from the connected

this section.

device. A warning will be displayed this
action cannot be undone.
Download: Download selected items to the
location set in the To dropdown. Optionally,
you can double-click items to import them.
All: Download all the items on the
connected device.

QUEUE

Document List: A list of thumbnails of
scanned images.
Create new Binder: Create a new empty
binder.
Properties: Change properties of a
selected scan or binder, e.g., where the
scan will be sent, the title, type, tags, and
optionally enabling OCR. You can also add a
Author or Subject for PDF output.

Select the Queue option to display the

Edit: Change the orientation or make

scanning queue where you can pre-define

image modifications of a selected scan.

documents to scan. Define parameters for

Double-click a scanned page to display the

each document, including: Title, Destination,

image modification pane.

Type (PDF or Image), Separator, whether

Play: Play video imported from an iOS

OCR is enabled, and optional Tags for the

device.
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Delete: Delete the selected scan(s).

Open the pane pane by choosing View >

Save: Sends the selected scans or binders

Import. Here we discuss the controls used in

to the To set in the Properties for each.

this section. For a more practical overview

Select a specific binder in the sidebar to
show a thumbnail view of the pages it
contains. Rearrange the pages by drag-and-

of the email archiving process, check out
the Archiving Email section of the In & Out
chapter.

drop or drag pages from one document to
another. Press the Sort button to use these
options:
Reverse Order: Reorder all pages from last
to first.
Shuffle Odd/Even Pages: Automatically
switch odd and even pages
Sort and Merge Documents: Choose two
documents to merge their contents. One
document is chosen as the starting odd
page, the other as the starting even page.
The pages are then interleaved into the
current document.

TRASH

ACCOUNTS AND MAILBOXES
The lefthand section of the Email section
displays the active accounts and mailboxes of
Apple Mail or Microsoft Outlook. Select your

Any scans or documents you've deleted from

email client, then click the disclosure triangle

the scanning interface will appear here. When

to show the accounts then its mailboxes.

you have this selected, empty the trash with
the button at the lower right corner of the
window.

Mailbox View: When you select a mailbox in
a specific account, the window will display
more controls for filtering and importing
messages from that mailbox. The central view

SIDEBAR: EMAIL
In addition to scanning, the Import pane also
provides the controls to archive emails from

shows the contents of a chosen mailbox. This
is where you can select individual messages
to import, if desired.

Apple Mail and Microsoft Outlook. While you

This view is separated into columns that can

can drag email messages individually from

be sorted by clicking the column headers.

your email client, the Email section of this

The columns include From, Subject, To, the

sidebar also allows you to import individual

Flagged state. If you are choosing to show

messages or archive mailboxes directly into

already imported messages, there is a special

your DEVONthink database.

column showing those items. For emails
marked as high priority, the flagged column
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will also show two exclamation points and the

Imported: Enabled by default, this hides

subject, etc. will show in red. Control-click in

messages you've already imported into the

the Mailbox view to refresh its contents.

current database. As you can't import the
same message into a database multiple

FILTER AND IMPORT
When a mailbox is selected, the righthand
side of the window shows options for filtering
the messages displayed. It also lets you
choose the location where the messages will
be imported.

times, changing the Destination changes
what messages are displayed when this
option is enabled. If you disable it, already
imported messages will show a checkmark
next to their name
Deleted: Hide messages you've put in the
account's trash.

Destination: Choose the destination for the

Junk: Hide messages moved to the

imported messages or mailboxes.

account's junk mailbox.

Search: Use this search field to search for

The last two items are buttons for importing

messages by the sender or recipient's Name,

selected emails in the Mailbox view or

email address, or the subject line. Note this

archiving the currently selected mailbox. See

only allows for a single term to be used.

also p. 56ff

However, the search is matching substrings,
so a search for jun would match "junk",

SIDEBAR: EXTRAS

"jungle", and "jejune".
The Extras sidebar gives you a place to check
Show: Select options in this section to

for current information from us. It's an easy

further fine-tune the list of importable

way to stay up to date with some of the

messages, if desired. You can use:

goings on at DEVONtechnologies.

Read: Show emails messages have been

Support: Here you will find our recently

read, unread, or either.

published tips, scripts, smart rules, and

Flagged: Show messages that have been

templates.

flagged in the email application.
Priority: Show messages that have an
assigned priority
Date Range: Choose a range of dates to
display messages received between them.
Hide: Use these controls to hide certain items
from the mailbox view. All these options are
enabled by default, but can be selectively
disabled, if needed. However, when these
options are enabled it makes it easy to see
only new messages, ready for import.

DEVONthink 3.7 Documentation, page 98

DOCUMENT WINDOW

Tips & Tricks: This shows recent blog posts
of handy tips about all things DEVONthink,
presented in a RSS feed style. To read the
full article, click the article's title.

You can isolate a document in its own

Scripts and Smart Rules: From time to

window, known as a document window. These

time, we publish publicly available scripts

windows are convenient for split screen work.

and smart rules. You will see a brief

For any editable file formats, you can open

description and a link that allows you to

a document window by double-clicking a

install the script directly from this section.

document in any view of a main window.

Templates: We also offer templates for a

Alternately, you can choose Data > Open or

broad audience. This section lists recently

Open from the contextual menu to open

published ones. As with the scripts and

any document in a document window. For

smart rules, a description and installation

most file types that can't be edited directly

link is provided.

in DEVONthink, double-clicking the file will

If you'd like to quickly mark all items as Read,
⌃-click and select the Mark All as Read from
the contextual menu.
For a view of all available scripts and
templates, as well as easy installation and
uninstallation, see the Support Assistant.
DEVONtechnologies: This section provides
a list of blog posts regarding updates and
promotions.

open it in the system default application. For
example, double-clicking a Word file will open
it in the same application that opens if you
had opened the file in the Finder.
See the Documents chapter for a detailed
description of the various document types
DEVONthink supports.
Note: Command-clicking the window title
shows the document's location including
the database it's stored in.

Note: For the sake of transparency,
DEVONthink does connect to our web
server to bring you this information.
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TOOLBAR ITEMS
Similar to the main window, a document
window has a toolbar at its top. The default
toolbar buttons may vary, depending on
the type of file being viewed in the window.
You can customize the toolbar via View >
Customize Toolbar, but note there are fewer
options than you have with a main window.
A list of available toolbar items is available in
the Toolbar section of the appendix.

DOWNLOAD MANAGER

A list of a items to be downloaded
A status bar at the bottom
A

button for adding items to and a

button for deleting selected items from the
list
A

reload button

A Start/Stop button to enable or disable
downloads.
An

Action menu

ADDING FILES
To download a web site or any other file,
simply add it to the Download Manager by

Window > Download Manager opens

dragging its URL to the Download Manager

DEVONthink's Download Manager panel.

panel. Alternatively, you can click the

Using the Download Manager, you can

the panel and add the URL manually, as well

download files or complete web sites from

as a referrer, user name, and password. If

the internet, and either store the information

Automatic is checked, DEVONthink creates

in your database or as files on your hard

a referrer automatically when downloading

drive. Offline archives stored in DEVONthink

whole web sites.

in

are also used when you visit bookmarks or
open a link in a new tab and your computer is

You can also paste one or more URLs (copied

currently offline.

Safari bookmarks, DEVONthink links,
or copied links from DEVONagent Pro's
Download Manager), or add files to the
Download Manager by using the contextual
menu in web and HTML views in DEVONthink.
Note: You can also copy URLs in the
Download Manager to the clipboard or
drag them to other applications (like the
Finder or Safari's bookmark manager).
The Download Manager also supports
URLs for local files (POSIX path, a file://
localhost/ URL, or a file:/// URL).

PANEL ELEMENTS
The Download Manager panel consists of:
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ACTION MENU
Most actions are available through the Action
menu or the contextual menu. Click the

For your convenience, DEVONthink comes
with predefined option sets that you can
directly select from the action menu.

gear button or Control-click an item in the

Only Added Files: Downloads only the files

Download Manager panel to display more

you have manually added to the Download

commands:

Manager.

Add: Manually add a URL to the list.
Edit: Edit the parameters of a selected
item in the list.
Retry: Attempts to reload an item that
failed to download.
Remove: Removes the selected items from
the list. Alternatively, you can press the
⌫ Backspace or ⌦ Delete key.
Enable/Disable: Checks or unchecks the
selected items. Only checked items will be
downloaded.
Start/Stop Queue: Starts or stops the
download queue. Same as the play/pause
buttons at the bottom of the panel. Note
this will only pause queued items. Any in
progress downloads will continue.
Purge Queue: Removes all items from the
list that have been completely downloaded.
Only Added Files to Thumbnail Gallery:
Offers various predefined option sets (see
below).
Import Files to Database: Selects which
database the downloaded files shall be
stored in. Select Folder to save them
directly to the file system.
Options: Opens the options dialog sheet,
which allows you to specify in detail what
to download, which links to follow, and
where to store the downloaded files (see
below).

Offline Archive: Downloads the files you
have added to the Download Manager
including embedded images, style sheets,
and scripts. Use this option set to archive/
download web pages with everything
necessary to display them properly.
Alternative: Create a web archive.
Subdirectory (Complete): Downloads the
files you have added to the Download
Manager including all embedded or linked
files. This option set follows all links leading
to (items in) sub-directories. For example,
use this option set to download a complete
web site for offline archiving.
Subdirectory (Images & Multimedia):
Same as above, but downloads only
linked images, linked multimedia files
including Flash and QuickTime movies,
and embedded images in the item's
directory and all sub-directories. Use this
set to download a complete web site for
offline archiving (without all linked Office
documents, PDFs, etc.)
Thumbnail Gallery: Downloads the files
you have added to the Download Manager
including linked images, embedded images,
style sheets, and scripts. Use this option
set to download a thumbnail gallery
including all full-size images linked to each
thumbnail for offline archiving.
Note: Downloaded items are by default
excluded from classification and tagging.

DEVONthink 3.7 Documentation, page 101

OPTIONS
The options dialog defines which file types
the Download Manager downloads, which
links it follows, and where it stores the files.
Files: Check all file types you want the
Download Manager to download (plain
texts, rich texts, Office documents and
PDF files, style sheets and scripts, images,
embedded images, multimedia files, markup language files, etc.) Use the Follow
Links pop-up menu to define how far
DEVONthink should follow links on the
downloaded HTML pages (see below).
Check Overwrite existing to update an
existing archive.
Folder: When you choose Download to >
Folder in the action menu of the Download
Manager panel, DEVONthink stores
all downloaded items in the directory
you specify. Click Set to choose your
preferred location. Use this option to
use the integrated Download Manager

control what gets downloaded--only the
actual pages or a complete web site.
DEVONthink supports the following options:
Off: Does not follow any links.
On Same Host: Follows links, but only as
long as they refer to the same web server/
web site. Files on other web servers will not
be downloaded.
In Same Directory: Follows links, but only
as long as they refer to items in the same
directory as the downloaded HTML page.
In Subdirectories: Follows links, but only
as long as they refer to items in the same
directory as the downloaded HTML page or
its sub-directories.
One Level: Follows all links regardless of
where they point, but only one level deep.
Links on pages linked to from the original
page are not downloaded.
Two Levels: Follows all links regardless of
where they point to, but only two levels
deep.

for downloading software archives or

Note: Following links two levels deep can

other files you don't want to store in your

result in very large downloads.

database. Double-click any part of the
location to reveal it in the Finder.

THE SORTER

Download: Define how many connections
the Download Manager opens at the same

The Sorter is a multi-purpose popup that

time. (Choose fewer connections for

allows you to quickly add content to your

slower Internet connection, more for DSL

databases, even when DEVONthink isn't the

or broadband.) Also, check Automatically

active application. Depending on the option

purge queue to have previously downloaded

you choose in Preferences > Sorter, it will

items automatically removed from the

appear in the menubar at the top of your

queue.

screen or docked to the left or right side
of your screen. When shown as a menu bar

The Follow Links options defines how far

icon, you can choose to display it as the word

DEVONthink follows links on the downloaded

DEVONthink or a space-saving nautilus icon.

HTML pages. This feature allows you to
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It supports several views, each providing

section of the global sidebar. Drag items

handy shortcuts to getting data into your

onto your favorites to import them.

databases. Switch between these views by

Control-clicking a group or database gives

clicking the icons at the top of the pane.

you the option to Reveal or Open the item.

Below we cover the different views the

You can also double-click an item to open it

Sorter provides for quickly capturing data.

in a new window.
Databases: Provides a list of open

NAVIGATION
The Navigation view provides a convenient
list of the databases and groups in
DEVONthink.

databases and access to their groups.
Behaves in the same way items in your
Favorites do.
Hotkeys: The Navigation view supports these
hotkeys:
Tab: Switch the cursor focus between the
search field and databases list.
Command-Option: Hold these keys when
dragging Finder files or folders to index
them.
Command: Hold this key when dropping an
item to move it into the database, putting
the original in the system trash.
Up/Down Arrows: Navigate up and down
through the database listing.
Left/Right Arrows: Open and close groups

To add files in the Sorter, drag over the

containing subgroups. Hold the ⌥ Option

docked tab or menu bar item. The Sorter will

key while pressing the right or left arrow to

spring open. then drop items into specific

fully expand or collapse all the subgroups,

groups to quickly import them. Also equipped

respectively.

with a handy search field, you can search
for and isolate groups for more targeted

Note: The ⎋ Escape key can be used in all

importing. This view is composed of three

views to quickly close the Sorter.

sections:
CREATING FILES
Search Field: Use the search field to help
quickly locate specific groups. This uses

The remaining views are focused on creating

substring matching, so you can enter

files, whether that's a simple plain text file,

parts of words to find matches. The

a screen capture of an application's window,

view updates while you type for efficient

or some recorded video. Each of the following

searching.

views support the following options:

Favorites: Provides a convenient list of
the groups you've added to the Favorites
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Add: Saves the file in the specified format

create a title from the first sentence of the

in the chosen location. You can also press

body.

⌘S to save the current content.

Body: Enter your note text here.

Reset: Displayed as a

URL: If there is a URL you'd like to associate

backward pointing

circular arrow, click it to clear the view to

with the file, perhaps a link back to a

its default settings.

source, enter it here.

Control-Tab/Shift-Control-Tab: Move

Info: Add metadata about the file here,

the cursor between fields, e.g., between

including: read status, locked state, flagged

the body and URL. Hold Shift to cycle

state, rating, or color labels.

backwards through the fields.

Tags: Enter tags for the file. Tag
suggestions will be made from the tags of

TAKE NOTE

all open databases.
Format: Choose the format of the saved

The Take Note view is for those times when
you just need to quickly write a note but don't
want to go back into your databases to create
a new file.

note. Choose from: plain text, rich text,
formatted note, and Markdown.
Location: Choose the location to save your
file from the dropdown list. The location of
the last saved file will be preserved for the
next note you create.
Add: Saves the file in the specified format
in the chosen location.
Take Note Panel: The Take Note panel is
displayed when the Sorter is set to None
in Preferences > Sorter. It has the same
functions as the view in the Sorter and also
will be pinned over any open windows.

VOICE NOTE
Allowing you to write notes in several

Use this view to record a voice note directly

formats, the text will be displayed in the font

into your database. This creates an AIFF-C

defined in Preferences > Editing. Make your

file in the location you choose. With simple

note taking a little faster by defining a hotkey

controls, it's easy to record impromptu audio.

with the Preferences > Sorter > Take Note
Hotkey. This view supports these attributes:
Name: The title of your file. If left as
Automatic DEVONthink will attempt to
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VIDEO NOTE
Use this view to capture a video from your
Mac's built-in camera. Videos are saved as
MP4 files for convenient compatibility across
platforms and devices.

This view has a few simple sections:
Audio Levels and Timer: At the top is a
sound meter to help visualize your audio
level as you record. The elapsed time
is shown as it records, convenient for
projects like rehearsing a presentation.
Begin/Stop Recording: Press the red
circular button to begin recording. Press
the black square button to end recording.
When you've stopped recording, you will be

Like the audio note, this is presented in very

shown:

simple controls:

Playback and Volume: Playback your audio

Begin/Stop Recording: Press the red

to ensure it's good before you save it. Press

circular button to begin recording. Press

the Reset button to clear the audio and

the black square button to end recording.

record again.

Source: Choose the video and audio

Name: Enter a name for the audio file. If no

source in the small downward facing caret

name is provided, a date and timestamped

next to the record button. Any attached

name will be automatically given.

compatible audio-visual devices should be

Info: Add metadata about the file here,

available here.

including: read status, locked state, flagged
state, rating, or color labels.

When you've stopped recording, you will be
shown:

Tags: Enter tags for the file. Tag
suggestions will be made from the tags of

Name: Enter a name for the video file. If no

all open databases.

name is provided, a date and timestamped

Location: Choose the location to save your

name will be automatically given.

file from the dropdown list.

Playback and Volume: Playback your video
before you save it. Or press the Reset
button to clear the video and record again.
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Trim: Shown as scissors, click this to access
simple editing tools. You can drag the ends
of the yellow frame to change the start
and end of the video. Click and drag inside
the frame and a red line will appear. This
displays the time above the line.
Info: Add metadata about the file here,
including: read status, locked state, flagged
state, rating, or color labels.
Tags: Enter tags for the file. Tag
suggestions will be made from the tags of
all open databases.
Location: Choose the location to save your
file from the dropdown list.

This view has one simple section with three
options, also accessible via shortcuts:

SCREEN CAPTURE

Screen: Capture your entire screen (⌘-1).

Screen captures are a common way to

Window: Capture a specific window

quickly gather information about things on

(⌘-2). Hover over a window and it will be

our computers. While the Apple provided

highlighted in blue. Click once to capture it.

mechanisms still work, the Screen Capture

Selection: Capture a specified area by

view allows you to quickly snap a screen

dragging a bounding box around the

shot, add some metadata, e.g., tags or labels,

desired area (⌘-3). To reposition the area,

then direct it to a specific location in your

hold the space bar. To stop the capture

databases. The captures will be saved as

action, press the ⎋ Escape key.

JPEG files.

As with other views, name and information
options will appear after the screen is
captured.
Name: Enter a name for the screen
capture. If no name is provided, a date and
timestamped name will be automatically
given.
Info: Add metadata about the file here,
including: read status, locked state, flagged
state, rating, or color labels.
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Tags: Enter tags for the file. Tag

timestamped name will be automatically

suggestions will be made from the tags of

given.

all open databases.

Info: Add metadata about the file here,

Location: Choose the location to save your

including: read status, locked state, flagged

file from the dropdown list.

state, rating, or color labels.
Tags: Enter tags for the file. Tag

WEB CLIP
Use the Web Clip view to quickly clip the
current web page, a URL from your clipboard,
or enter a URL manually. Each option is also
accessible via shortcuts.

suggestions will be made from the tags of
all open databases.
Location: Choose the location to save your
file from the dropdown list.
When using the default browser option or
the Clip to DEVONthink extension, click the
Preview button and DEVONthink will attempt
to display a preview of the intended capture.
This can be helpful in predetermining if the
capture of sites with logins will be successful.

PREFERENCES
The Preferences window, opened using
DEVONthink > Preferences, contains all
available options, which you can modify to
adapt DEVONthink to your personal needs.
Default Browser: Displaying the icon of

Because the preferences are so important,

your default browser, click this to capture

we have created a separate chapter for them.

the current page (⌘-1). This shows the
same options as the Clip to DEVONthink

DATABASE PROPERTIES

browser extension.
Clipboard URL: If you have copied a URL,
click this option to detect and capture it
(⌘-2).
Manual: Click this to manually enter a URL

The Database Properties popup displays
preferences for a specific database. Select
a database and open the properties popup
using File > Database Properties

to capture (⌘-3).
Before clipping, you can add other
information to the item:
Name: Enter a name for the screen
capture. If no name is provided, a date and
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A database has two names: the displayed
name, set here in the properties, and the
filename, the name of the database file in
the Finder. When you create a database, the
names will be the same. If you change the
displayed name in the database's properties,
the name of the database file will also
change. However, you can close the database
and change the filename in the Finder,
should you choose to. This can be used in
any situation, including office, health care,
and litigation environments where clients
or cases have a unique number associated
with them. A database could have a filename
of 10459.dtBase2 but the displayed name
of Company A in DEVONthink. When you
close the database, the filename will be
GENERAL

shown in the Recent Databases section of
the Navigate sidebar.

Location: Shows the location of the database
in your filesystem. Note you can double-click
any part of the database location to reveal it
in the Finder.
Create Spotlight Index: Check to make this
database available to Spotlight. Checking this
option lets DEVONthink create a folder in ~/

Comments: Add comments about this
database. These comments are only used in
DEVONthink, i.e., not exported to the Finder.
Exclude Groups from Tagging: Excludes all
groups in this database from being used as
tags. Ordinary tags can always be added to

Library/Cache/Metadata that Spotlight

items using the Tag bar.

uses for accessing the documents in the

Inherit Tags of Groups: Applies tags added to

database. If you are having issues finding

a group also to the group's children.

DEVONthink documents in a Spotlight
search, you can click the Rebuild button to

Case Insensitive Tagging: Check this option

recreate this folder from scratch.

to disallow tags with different capitalization.
Protection: To add a layer of protection

OPTIONS

when syncing your databases, you can add

Name: Enter a name for your database here.

a username and password to the database.

It will appear in the title bar of every main

Anyone trying to import the database from

window of this database.

a sync location will need to provide these
credentials. Click on the padlock button to
unlock the entry fields, enter a user name
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and password, and then click on the padlock

INFORMATION POPOVERS

button again to lock your changes and hide
the password.
Note: For a locally secured database, create
an encrypted database via File > New
Encrypted Database.

STATISTICS
This section displays some basic statistics
about the contents of the database, e.g.,
counts of some different file types, total size
of the contents, and number of words in the
index of the database.

POPOVERS
Popovers are a specialized panel that
appears on command and disappears
after interacting with it. These are usually
used for quickly viewing information about
a selected item but can also be used in
some other ways. For example, Database
Properties is an information popover you may
already be familiar with. Here are a few more

Info: The Info popover shows information
about the currently selected item. It displays
the contents of the Info, Annotations &
Reminders, and Properties inspectors. Open
this popover via Tools > Get Info, ⇧⌘I, or
pressing the

toolbar button.

DEVONthink offers, starting with information
popovers and followed by utility popovers.

Log: The Log popover displays any
information available in the Log window. This
allows you to quickly glance at any messages
without having to open a separate window.
Open this popover via the

toolbar button.
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Note this button will only be enabled if there

location within the same database. Note the

are messages available to be viewed. You can

text in the popver will change to reflect the

clear the log or press the Save button to save

kind of operation will take place.

the log, usually to send to our support team.

UTILITY POPOVERS
The utility popvers provide extra functions
for moving files, navigating databases, or
linking documents. Each popover has a search
field at the top for helping to narrow the
results. You can use an abbreviated search
syntax matching the beginning of words to
help speed the process. For example, if you

Go to Group: This popover allows you to

are looking for a group named "Household

quickly jump to another location. Open this

Expenses" you could type hou exp to find

popover via Go > To Group or ⌃⌘G. One

matches. After tsearching, double-clicking

special property of this popover is the ability

a result will move the file to the selected

to act as a floating pane. Open the popover

location. For keyboard navigation, you can

then click and drag it away from the toolbar.

press ⇥ Tab to put the focus in the results list

It will remain open as a searchable floating

then navigate with the arrow keys. Pressing ↩

pane you can use for quick navigation. You

will accept the choice and close the popover

can also drag and drop files to it, similar to

automatically. There is also a plus (+) button

the Navigation view of the Sorter.

for creating a new group in the current
location when needed.

Go to Document: This popover allows you to
Move to: This popover allows you to organize
selected files quickly. Open this popover via
Data > Move To or pressing ⌃⌘M.

quickly navigate to a specific file. Open this
popover via Go > To Document or ⌃⌘O. Note
this popover does not support abbreviated
syntax, i.e., matching substrings or non-

The default behavior of this popover is

contiguous words, as the fuzzy matching

moving files. However, the behavior can be

would lead to far too many results. Given

changed using command keys. Hold the ⌥

a filename of DEVONthink sync timing

key to duplicate files to a selected location.

tests.md, timing tests would match;

Hold ⌘-⌥ to replicate the files to a selected

DEVONthink timing would not.
DEVONthink 3.7 Documentation, page 110

Insert Link: Used when editing text-based
documents, e.g., rich text, this popover allows
you to search for and quickly insert a link to

The layout of the web sharing should

that file in the current document. The type

immediately be familiar to users of

of link inserted will be appropriate to the

DEVONthink. While not as full featured as

current document type, e.g., a Markdown

the native application, it behaves in ways

document will have a properly formatted

similar to DEVONthink's main window. Here

Markdown link. Open this popover via Edit

we will give you an overview of the parts of

> Insert > Item Link, the Insert > Item Link

this interface.

command, or ⌃⌘E in the contextual menu
while editing a compatible document.

Note: The permissions given by the
administrator of the shared databases

WEB SHARING

determine database visibility as well as
what actions you can take. Due to this,

DEVONthink comes with a built-in server

some actions, e.g., creating new documents

for broadcasting your databases on a

or downloading documents, may not be

network. While the operation is covered

available. If you do not have permissions

in the In & Out chapter, here we cover the

to modify the database you're browsing,

interface shown when accessing shared

the cursor will change to show the option is

databases in a browser window. Also note the

disallowed.

preferences for setting up shared databases,
including setting up users and per-database
permissions are covered in the Preferences >
Server section of the Preferences chapter.

SIDEBAR
A condensed version of the Navigate sidebar
found in DEVONthink's main windows, this
provides access to the contents of any
shared databases. Some basic contextual
menu items, e.g., New Group, New Feed,
Rename, and Move to Trash, are available
when Control-clicking in the sidebar.
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Move files by dragging from the item list over

Mark: Toggle the Flagged, Unread, or

a group in the sidebar to file them in a new

Locked state of a selected file.

location. Holding the ⌘ Command key allows

Rating: Adjust the rating for a selected file.

you to copy the file instead of move it.

Upload Document: Use this to upload a new

If you hover over a section in the sidebar, you
can hide the Globals or Shared Databases
section. Also, you'll notice this interface
has been built in a responsive manner. This
causes the sidebar to disappear when the

document to the database.
Download Document: Download the
currently selected file(s).
Move to Trash: Move the selected file(s) to
the database's Trash.

browser window becomes to narrow for it be

While you can't reorder the items manually,

effective. You can still use toolbar buttons to

the item list can be sorted by clicking on the

toggle the visibility, as needed.

column headers. Click the header again to
toggle between an ascending or descending

ITEM LIST

sort. Control-click the headers to enable and

The item list, like it's DEVONthink
counterpart (See also p. 80ff ), shows items
in the current location. Items can be selected

disable individual headers.

VIEW/EDIT PANE

and reorganized by drag-and-drop, to the

When an item is selected in the item list, a

sidebar or groups in the same location. Above

preview of any compatible file will be shown

the item list is the path bath with active

here. Many non-proprietary text-based

links to parent locations. Click on them to

formats commonly can be displayed. Plain

quickly jump back to a parent location. To

and rich text, Markdown, JPEG or PNG files,

navigate back and forth through locations

PDF, etc. are easily searchable and viewable.

you've visited, use the

There is also support for editing plain and

and

buttons in

the path bar.

rich text, formatted notes, and Markdown
documents directly in this pane. Just click in

Again, taking its example from DEVONthink's

the preview and begin editing.

main window, Control-click items in the
item list to show these commands in the

Navigation bar: The navigation bar above the

contextual menu:

pane varies what it displays, based on the
type of file it's displaying. If an item has a

New: The submenu allows you to create
new items: plain text, formatted note,
Markdown, Bookmark, RSS feed, and
groups.
Get Info: Shows the Inspector pane for the

URL, it will be active and displayed here. The
bar also allows you to move back and forth
through previously viewed files via the

and

buttons.

selected file.

Of special note are the behavior of formatted

Label: Apply or remove a color label to a

notes. They are displayed with a handy

selected file.

toolbar providing some editing options, like
adding bold or italic type. You can also select
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text and create a hyperlink with it. Lastly,

Show/Hide Sidebar: Toggles the visibility of

you can choose an image to insert into the

the Globals sidebar.

document.

Preview: Toggle between standard and

For the Markdown fans, you will see the
same navigation bar options, showing Edit,
Preview, and Side-by-Side modes.

widescreen view, with the preview on the
bottom or right, respectively.
Action: Displayed with a gear icon, this
shows the same options as the contextual

Note: While it is a force of habit — and in

menu in the item list.

general, a good one to be in — you do not

Add: The submenu allows you to create

need to press ⌘S after editing a file. The

new items: plain text, formatted note,

changes are saved automatically.

Markdown, Bookmark, RSS feed, and
groups.

INSPECTORS

Move to Trash: Put the selected item in the
database's trash.

Info: A simplified view of the Info Inspector
pane found in a main window. Shown by
clicking the right-most toolbar button or
choosing the Get Info command from the
Action button, this shows basic metadata
about the item selected in the item listing.
If you have permissions to make changes to
the current database, it is possible to change
some of the metadata, like ratings or labels.

Refresh: Manually refreshes the current
item list.
Download Document: Downloads the
selected items in the item list and
downloads them to the downloads location
for the browser you're using. For some
formats, a ZIP file may be created and
downloaded.
Language: Switch the interface language

See Also: The second view of the inspector

between English, French, and German.

shows the See Also pane. This gives you some

Search: Search for files in the open

suggestions about other documents that may

databases by entering search terms.

be related to to the currently selected item.

Search prefixes can be used and are

Clicking on an item in the results will display

covered in more detail here: See also p.

that document in the view/edit pane.

83ff
Show/Hide Inspectors: Toggle the

TOOLBAR
There are a handful of toolbar tools in the
web sharing interface. Note a few items will
be discussed separately.

Inspectors panes.

SUPPORT ASSISTANT
The integrated Support Assistant combines a
welcome screen with a first launch assistant,
tips, installable extras, and a support page
that guides you through the available support
options.
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WELCOME
This screen welcomes you when you start
DEVONthink for the very first time. It offers:
The option to subscribe the free
DEVONtechnologies newsletter, as well as a
number of welcome tips
The tip of the day
The extra of the day

first steps of using the application: creating
a new database, installing the add-ons, and
adjusting the preferences.

GET SUPPORT
The Support screen guides you through the
three common steps for troubleshooting
DEVONthink. In addition, you can update
your details in DEVONtechnologies' customer

Click the links at the bottom of the window

database, or buy an upgrade or a second

to access the other Support Assistant

license.

sections. You can also check or uncheck the
Show this window when DEVONthink opens
checkbox at the bottom of the window to set
whether to show the Support Assistant each
time DEVONthink is launched.

FIRST LAUNCH ASSISTANT
The first launch assistant opens
automatically the very first time you open

INSTALL EXTRAS
On the Extras screen, DEVONthink lists all
available extras that you can download and
install from DEVONtechnologies' server:
Scripts
Templates
Smart Rules

DEVONthink, and guides you through the
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Browse the list of extras and install them

Templates menu the extra will show up after

with the Install button. The last line of the

installation. Remove installed extras with the

description shows where in the Scripts or

Remove button.

The extras are updated live from

TIPS AND TUTORIALS

DEVONtechnologies' server so it's a good
idea to check back from time to time. The
latest extra is also always mentioned on the
welcome screen. If you check the Install &
update extras automatically checkbox at the
bottom of the window, any updates to scripts

Here you can find the latest tips and
tutorials to help you squeeze the best out
of DEVONthink. Tutorials can be slideshows
describing basic tasks in DEVONthink or
screencasts.

or templates you've downloaded here will be

Both tips and tutorials are updated live from

updated as needed.

DEVONtechnologies' server so it's a good idea

Note: If one of these categories does not
show up in your copy of DEVONthink, there
might be no extras of this type currently

to check back on a regular basis. The latest
tip or tutorial is also always mentioned on the
welcome screen.

available.

LOG
The Log panel displays messages and
warnings when importing files and folders,
results of performing maintenance routines,
and AppleScript errors from script actions
in smart rules or reminders. The panel shows
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the date of the message, any affected

> Log. For important notifications, the log

files, and a little information about what

is always shown automatically, ignoring this

happened. If you feel you are having sync

setting.

issues, this panel is the first place to look.
Also, when doing any database or sync

ACTIVITY

location maintenance, this is where the
results are shown.

The Activity panel shows a list of currently
running background processes, e.g.,
converting scans to searchable PDFs,
refreshing news feeds, downloading PDF
documents and web archives via our browser
extension, or sync activity. You can manually
open this pane via Window > Activity. You
can manually stop them to free computer

You can save the list to a text file with the

resources or for other reasons.

Save button, and clear the log with the
Clear button. To sort the log, click a column
title to sort on that column, changing from
ascending to descending each time you click
it. If you Control-click individual log entries

There is also an Activity pane at the bottom

you will be shown options to reveal the

of the Navigate sidebar. Providing a less

item in its location or move it to the trash.

intrusive experience, this pane will appear

Alternatively, double-click the entry to reveal

and disappear quietly on its own.

the file.
Note: The Activity window is only used if
Uncheck Show log automatically to prevent

it was opened by the user or if there is no

the log popping up automatically. You can

main window to show an Activity pane.

open the Log panel at any time using Window
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INSPECTORS
IN THIS CHAPTER

name to comments and other metadata.
Open the Info pane by selecting Tools >

Info pane

117

Annotations & Reminders

119

Content

123

Note: When you have multiple items

Document

124

selected, some editable attributes can be

Concordance

125

modified. For example, tags can be applied

See Also & Classify

127

to multiple files at once. However, if you

Search

128

add tags to the same files separately, only

the Inspector panes displayed on the right
side of a main window provide an incredible
amount of information and functionality
when working with files in DEVONthink.

Inspector > Info > ….

tags common to them will be shown if you
select them together again.

GENERIC

Covering a range of options, from basic

The Generic view shows additional basic

metadata to setting reminders to in-

information about a selected document or

document search and replace functions. Each

group, similar to what is shown in the Get

of the Inspectors is individually covered in

Info window in the Finder. Additionally, it

this chapter.

shows some other attributes like ratings,
color labels, and geolocation data. Here are

INFO PANE

the attributes shown:
Icon and Name: Displays the name of the
selected item. To change the icon of the
item, select it and paste any image you
want over it. To change the name of the
item, use the Name field below.
Name: Displays the name of the selected
item. This is an editable attribute.
Aliases: Displays any aliases for the
selected item. Enter one or more words
here, separated by semicolons, as
alternative targets for Wiki links. Generally,

The Info pane, just like its counterpart in the
Finder, displays additional information about
a selected document or group, from icon and

Wiki links refer to the name of contents,
and aliases make this system even more
flexible.
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URL: Displays a URL associated with the

Location: Displays the location of the item

selected item. This is an editable attribute.

in the database. This is an active item;

While it is typically used for web addresses,

hovering over items will display their full

it also may contain other types; e.g., file

names and clicking them will navigate to

URLs, URL with custom schemes, etc. Click

the clicked group.

the down arrow and choose: Launch to

Instances: Displays how many duplicates

open the URL, Copy to copy the URL to the

or replicants of the selected item are in

clipboard, or Remove to clear the URL.

the database. Click to show a pop-up menu

Path: Displays the item's file's path in the

listing all instances and duplicates and their

Finder. This is not an editable attribute.

enclosing groups. Select any item to reveal

Click the down arrow and choose: Launch

it.

to open the file in the system default

Format: For news feeds you can set the

application; Show in Finder to open a

default format in which new articles are

Finder window with the file selected, and

saved.

Copy to copy the file path to the clipboard.

Color: Allows you to set a color for a tag.

Attached Script: Displays the name of an

Only available when a tag is selected. Click

AppleScript script attached to the object.

the title Color for options to clear or copy

This is a script that is triggered when you

the color.

select the item in the database. Click the

Geolocation: Displays geolocation data

down arrow and choose: Select to choose

based on the creation origin of the file;

a triggered script to attach, or Remove to

i.e., the geographic location when the file

remove the script from the item. See also

was originally created. This is an editable

p. 192ff

attribute and can be changed if you'd like

Added: Displays the date an item was

the location to be relative to something

added to the database. This is not an

else, e.g., the site of a historic event.

editable attribute.

Marks: Displays these attributes for the

Created/Modified: Displays the date an

selected item: Flagged, Read, Locked,

item was created or modified. These are

Rating, and Label.

editable attributes. Click the calendar icon

Tags: Displays the tags applied to the

to choose a date and time. You can also

current item. Click the + button to add a

select individual parts of the date or time

new tag. Tags will be suggested from the

and type or modify them with the up and

existing tags in the current database. If the

down arrows. When typing, press the ⇥Tab

item is selected from the Inboxes in the

key to commit the change.

sidebar, suggestions will come from the

Size: Displays the size of the item. For

tags of all open databases. Click an added

groups and news feeds, this field shows the

tag to reveal the Tag group, or remove it

size of all contained items.

from the selected item.

Kind: Displays the kind of the selected
item. For documents, the file type will be
shown, e.g., Markdown.
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Exclude From…: These checkboxes allow

available fields you have defined are shown in

you to exclude an item from being used in

this pane. Note some fields may be specified

various ways. For example, you can exclude

as data types that include some extra actions

temporary groups from classification to

in this view. For example, if you create a

increase the accuracy of the built-in artificial

custom parameter with an Item Link data

intelligence. You can exclude an item from

type, you will have an option to reveal the file.

these operations:
Item Link: Click the down arrow and
Classification: When enabled on a group,

choose: Reveal to reveal the item in the

this will keep DEVONthink from suggesting

database.

or using the group as a possible filing

Single-line Text: Type in a value or click the

location.

dropdown menu to choose from a list you

See Also: When enabled on any file,

defined in the preferences .

DEVONthink will not include it as an item

URL: Click the down arrow and choose:

potentially related to the current file.

Launch to open the URL or Copy to copy

Search: When enabled on any item, it will

the URL to the clipboard.

no longer appear in toolbar search results,
smart groups, or smart rules.

ANNOTATIONS & REMINDERS

Tagging: Used with group tags and Tag
groups, this inhibits the Tag from being
applied to any item.
Wiki Linking: When enabled on any item,
it will not be detected by automatic
WikiLinking, neither by name or alias.

CUSTOM

This pane contains Reminders, Finder
Comments and information about
Annotations. It can be shown Tools >
Inspectors > Annotations & Reminders.

REMINDERS
While there are many reminder applications,
The Custom view displays custom metadata

including Apple's own Reminders, sometimes

fields and their values. These custom fields

you just want to set a quick reminder for an

are defined by you in Preferences > Data. All

item, or multiple items, in DEVONthink. The
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Reminders section allows you set a reminder,

reminder, e.g., 1 for every year. Choose

even a recurring one, as well as an optional

which months you want a reminder. Also,

alarm.

choose On the … to choose a regular

After choosing a schedule, set a date and
time for the reminder or to begin a recurring

interval like the last day of those chosen
month(s).

reminder. For recurring alarms, the data or

Alarm: Reminders are most useful when

time you set will be the beginning of the

you have an alarm to, well, remind you of

alarms. Reminders can be set to:

something. There are several alarms available

Once: Only trigger an alarm once.

for a reminder:
Hourly: Set an hourly reminder, triggering

No Alarm: —

at the minutes of time you set, e.g, 10:15,

Bounce Dock Icon: Bounce the icon in the

11:15, etc. Set an interval for how many

dock. This will only occur if DEVONthink is

hours should elapse before the next

not the active application.

reminder, e.g., 4 for every four hours.

Display Notification: Displays a notification

Daily: Set a daily reminder, triggering at

using the Notification Center, appearing

the hour and minutes you set, e.g., daily at

at the upper right of your screen. The

9:35 AM. Set an interval for how many days

message shown can be a combination of

should elapse before the next reminder,

static text and placeholder text. It defaults

e.g., 2 for every other day.

to the Name placeholder. Control-click

Weekly: Set a weekly reminder, triggering

and choose Insert Placeholder to add

at the hour and minutes you set. Choose

additional placeholders. Note System

a day of the week the reminder should

Preferences > Notifications > DEVONthink

trigger on. Set an interval for how many

> must be enabled for this alarm to

weeks should elapse before the next

display. Notification are also only shown

reminder, e.g., 3 for every third week.

when DEVONthink is not the frontmost

Monthly: Set a monthly reminder,

application.

triggering at the hour and minutes you set,

Display Alert: Displays an alert dialog when

e.g., daily at 9:35 AM. Set an interval for

DEVONthink is or becomes the active

how many months should elapse before

application. If it's not frontmost, the dock

the next reminder, e.g., 1 for every month.

icon will bounce until you switch to it.

Choose Each and set which days of the

Like Display Notification, this contains

month you want a reminder, e.g., the 1st

static and placeholder text, and defaults to

and 15th of the month. Alternately, choose

Name.

On the … to choose a regular interval like

Speak Text: Using the Mac's speech

the second Thursday of the month.

synthesis, this alarm will speak the

Yearly: Set a yearly reminder, triggering

specified static and placeholder text.

at the hour and minutes you set, e.g.,

Play Sound: Choose one of the system

daily at 9:35 AM. Set an interval for how

alert sounds found in System Preferences >

many years should elapse before the next

Sound > Sound Effects.
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Send Mail: Enter email addresses to which
to send the matching items. This can be
a comma-delimited list of addresses,
names, or enter the name of a group you've
defined in your contacts.
Add to Reading List: Add the file to

FINDER COMMENTS
Similar to the Comments in the Get Info pane
in the Finder, the Finder Comments field
can be used to store miscellaneous bits of
information about the selected objects.

DEVONthink's Reading List.

Note: These comments will not appear in

Open Externally: Open the document in the

the files in the Finder unless the files are

system default application.

indexed or exported from the database.

Launch URL: Opens the URL associated
with the document, if present.

ANNOTATIONS

Execute External Script: Run a selected
script. External scripts are stored in
~/Library/Application Scripts/
com.devon-technologies.think3/
Reminders. Add your own scripts to this
location to make them available for use
with reminders.
Execute Embedded Script: Run an ad-hoc
script written for the current reminder.

This pane displays or allow you to create
annotation files for a selected document.
Annotation files are separate files where you
can store notes about a specific document.
These files can link back to the original file for
quick access. Commonly used with PDF files,
they can actually be used for making notes
with any document in your database.

Press the … button to display a popup

Note: Annotation files are created in an

prepopulated with a core script. Edit this

Annotations group at the root of the

and press the compile button at the lower

database. However, you can move the file

left. Embedded scripts are only available

to another location, if desired.

to the reminder they are created in. If you
want to use the same script with other

If an annotation file doesn't exist, you can

reminders, use an external script instead.

make one with commands from the down
arrow in this section.

As a bonus, reminder alarms will open
databases containing the item when an alarm

New from Template: Opens a submenu

triggers.

containing three options: Create an
Annotation file from the default template,

Note: When setting a reminder on multiple

choose a custom template added to

items, alarms are delivered individually. For

DEVONthink's internal Annotations folder,

example, an alert notification will show for

or open the Annotations folder to access

each file, even if they were set for the same

any custom templates you've added.

time.

New from Clipboard: Choose this option

If you are interested in the use of scripts in
alarms, please refer to the Reminder Script
chapter of the Automation chapter.

to create an annotation with content from
the clipboard.
Insert Back Link: This inserts a back link
to the original file into a new annotation
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file. If no annotation file exists, one will be

or created in DEVONthink and exported

created with this command.

via File > Export > as Template to the

Insert Quote: This inserts both the

Annotations.noindex folder.

selected text and a backlink to the page
or paragraph in the original file. If no
annotation file exists, one will be created
with this command. This option is only

To create backlinks to the original file, there
are two placeholders for use in the body of
your template:

supported by PDF, plain text, and rich text

%documentName%: Resolves to the name

documents.

of the original document.

If an annotation file is detected by
DEVONthink or you've just created one,

%documentLink%: Resolves to the item
link of the original document.

an editable preview of the file will appear

Rich Text: To create the backlink in a rich

here. Clicking the down arrow reveals these

text template, use the %documentLink%

options:

placeholder and the document name will be

Open: Open the annotation file.

added as the link's text.

Reveal: Reveal the annotation file in its

Markdown: To create the backlink in

current location.

a Markdown template, use the form:

Insert Back Link: Insert a link back to

[%documentName%](%documentLink%).

the original document in the current
annotation file. With audio and video
files, the back link will include the current
playback time. With multi-page PDFs, the
back link will include the current page .
Export: Exports the current annotation
file to the Finder in one of these formats:

Plain Text: Since plain text files don't support
live links, you can use WikiLinks to create a
backlink. For example, if you are using the
Square Brackets WikiLink syntax, you could
use [[%documentName%]] in the body of the
plain text.

PDF, rich text, plain text, or Word (.doc)
formats.
Remove: Moves the annotation file to
the database's Trash and removes the
reference from the original document.
Creating an Annotation File: DEVONthink has
a built-in default annotation file in rich text
format, suitable for general use. However, you
can create your own custom template in plain
text, rich text, or Markdown formats. These
files can be created externally and added
to ~/Library/Application Support/
DEVONthink 3/Annotations.noindex
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CONTENT

THUMBNAILS
The Thumbnails view shows a list of
thumbnails, one for each page in the
document. This allows for a more visual
approach to moving through your document.
By default, the thumbnails are shown in a
single column but they can be displayed in
multiple rows if the sidebar is expanded. This
view allows for actions like these:
Jump to or select any page by clicking on it.
Extend a range of selected pages by holding

Navigating PDF documents can sometimes
be difficult when you are just scrolling
through endless pages of documents.
The Content Inspector shows two views,
similar to what you see in Apple's Preview
application: Table of Contents and
Thumbnails.

the ⇧Shift key to select consecutive pages.
Hold the ⌃ Control key to select nonconsecutive pages.
To quickly remove unwanted pages, press
the ⌫ Backspace key.
If you want to reorder some pages, select
the page(s) to move and drag and drop
them within the thumbnails. A blue line

TABLE OF CONTENTS

will appear at the place the pages will be
inserted. This will also work if you drag

The Table of Contents view will display the

thumbnails from one PDF to another.

outline of a PDF document, provided that

Drag selected pages to another location in

PDF contains one. Click on the disclosure

your database and DEVONthink will create

triangle to show or hide sections within

a new PDF containing only those pages.

chapters. Click on any section heading to
jump directly to the beginning of it.

You also have several options available in the
contextual menu when you Control-click in

For even quicker navigation, the table of

the Thumbnails view:

contents can be navigated via keyboard, using
the arrow keys to move around.

Cut/Copy: Cut or copy the selected
page(s) to be pasted into another PDF.

There are two contextual menu items in the

Copy Page Link: Copies a URL to the

Table of Contents view: Copy Page Link for

clipboard pointing directly to the current

use with PDF documents, and Copy Section

page of the document.

Link for use with Markdown documents.

Reverse Page Order: Reverse the page
order of the document.
Split Document: Splits the document
at the current page. A new document is
created from the preceding pages and
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removed from the current document. This

Author

item is unavailable when the first page of

Company

the document is selected. Also, note this

Copyright

action cannot be undone.

Title

Insert Blank Page: Insert a new blank page.

Subject

Delete Selected Page(s): Delete the

Keywords

selected page(s).

Comments

Rotate Left/Right: Rotate the selected

Organization

pages left or right.
Select/Deselect All: Select or deselect all
pages in the document.

Depending on the document type, you may
be able to edit or view these properties. More
fields may be available depending on the
document type.

DOCUMENT
There are two parameters supporting extra
actions:
Click the Title button and select Copy, or
select Set Name As to quickly change the
document's name.
Click Keywords and choose Convert to Tags
to apply the keywords as DEVONthink tags.

ANNOTATIONS

The Document inspector provides specific
information about the current document.
This information is presented in three
specialized views: a view of RTF and PDF
metadata, a list of annotations in a PDF,
and a list of links found in certain document
types.

PROPERTIES
The Document Properties section gives you

As PDF files are often used in DEVONthink,

access to all metadata stored for selected

annotating these documents is

RTF and PDF documents. This metadata can

commonplace. The Annotations view displays

include some of the following:

a listing of the annotations in the current
document. Each annotation is listed with
the following metadata: page number,
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type, content or author, and the date

Select a link in the list to show it in the view/

the annotation was made. In the case of

edit pane. Double-click a link to open it in a

highlights, text, or note annotations, the

document window or an external application.

content will be displayed. With graphic

Option-click or Shift-Option-click a link to

annotations, e.g., rectangle or ovals, the

open it in a new tab. Opening the contextual

author will be displayed. The list can be

menu in the Link list offers the following

sorted by clicking the appropriate header.

options:

Select an item in the list to switch to the
proper page. The annotation on the page will
be selected. This makes it easy to navigate
via the document's annotations.

Open: Opens the link in an external
application.
Open in Tabs: Opens the link in a new tab,
when possible.

At the bottom of the view is a Details

Copy: Copies the URL to the clipboard

section. For Note annotations, this will show

Delete: Deletes the link and the text.

the text of the annotation. Details can be

Select/Deselect All: Quickly select or

added to other annotation types as well, but

deselect the items in the list.

only supports plain text entries.
In the Incoming Links section, the contextual
Opening the contextual menu in the

menu has an extra command: Copy Name.

Annotations list offers the following options:

Use this to copy the name of a linked file and

Copy: Copies the metadata and any text in

paste it into another document as a WikiLink.
the Details to the clipboard as plain text.
Copy Page Link: Copies a URL to the

CONCORDANCE

clipboard pointing directly to the current

The Concordance pane, opened in the Tools

page of the document.

> Inspectors menu, gives you a tool for

Delete: Delete the current annotation.

analyzing the textual contents of documents.

Select/Deselect All: Quickly select or

When the inspector is open, selecting

deselect the items in the list.

different items will show varying results.
If one or more documents is selected, the

LINKS
For the selected document, DEVONthink will
attempt to determine if it contains links.
These may be web URLs, file URLs, item links,
and even DEVONthink's WikiLinks. (You may
be surprised by the number of links in many
documents.) The top section of the Links

results will be inclusive of the text in all of
them. If there is no selection, the results
will be based on the text of documents in
the current location, whether a group or a
database. This also applies to selecting items
matched in smart groups, both local and
global.

view displays a list of any outgoing links, i.e.,

These results are presented in three distinct

links to other files, websites, etc. The bottom

views: List, Cloud, and Graph.

Incoming Links view shows incoming links, i.e.,
links in other files to the current document.
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Select/Deselect All: Quickly select or
deselect the items in the list.
Show/Hide Excluded Words: Select this to
show or hide any excluded terms. Excluded
terms will shown with a strikethrough.

CLOUD

LIST
The List view displays the concordance
results in a list, separated by these
parameters:
Word frequency
Number of groups with items containing a
specific word

The Cloud view present the concordance as

Word length

a word cloud. The size of the terms is relative

Word weight (relevance, depends on the

to the frequency in the selection or database.

contents of the database)

Selecting terms highlights the occurrences in

Alphabetical listing

the current document.

Click the column headers to sort on a
given parameter. Select a word in the list

RELATED WORDS

to highlight all occurrences in the current
document. Double-click a word to open a
database-wide search for the term.
Opening the contextual menu in the results
offers these options:
Copy: Copies the values for the selected
word to the clipboard.
Exclude/Include Word: Use this to define
stop-words or to include them again.

Of special note is the Related Words graph
shown under the List and Cloud views. Select
a word in the list or cloud and it becomes
the central term in a graph of related words.
These are words found throughout your
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database. Double-clicking a node initiates
a database-wide search. The contextual
menu provides options for copying the word's
information, as well as excluding the word.

GRAPH

GROUPS
Based on analyzing the contents of the
current document, the AI cross-references
the contents and locations of other files
in the database. The results are shown in
the Groups section. This list offers a range

The frequency graph shows a graph of the

of suggested locations, displaying a heat-

word frequency over the rank number of the

mapped score of its relevance and the

word (see above).

location of the group. The highest ranked

Note: There are no contextual menu
options in this view.

suggestion is presented first. Obviously,
you can choose any other them. If there's a
group you'd like to use, double-clicking the
suggested group will file the document for

SEE ALSO & CLASSIFY

you. You can also click the Move to button,
press ⌃C, or drag and drop to file it in any of
the suggested groups. Lastly, if a suggested
group is in the same database as the selected
file, you can hold the ⌥ key and the Move to
button changes to a Replicate button.
Directly above the classify results is a
search field. If there is another group you're
thinking of that hasn't been suggested, type
part of the group name to filter the list of
suggestions. Then file into the location of
your choice.

The See Also & Classify inspector is the
main interface to DEVONthink's brain, our
built-in AI engine. This engine is analyzing
the contents and locations of all documents
in your database and making connections
between them. These connections can be
seen in this inspector pane.

On a related note, in the Data menu, you will
find two menu items: Move to … again and
Classify to…. The first provides you the option
to classify the current document in the group
into which you classified. If you filed into
a particular group via the Groups section,
this menu item would remember it and offer

This inspector will be shown when a

that group as a place to classify the current

document is selected and you choose Tools

document. The second menu item offers

> Inspectors > See Also & Classify. When the

its top ranked suggestion for classifying the

inspector opens, you will be presented with

current document, if you'd like to just follow

two sections: Classify and See Also.

the AI's suggestions.
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DOCUMENTS

SEARCH

Another benefit of the AI's content analysis is
the ability to offer suggestions of documents
that may be related to the current document.
These files are listed in the Documents
section of the inspector. Like the Groups
section, this list shows the location of the
document and heat mapped score of the
potential relevance. Hovering over a result
shows a tooltip displaying its full title and
location.
Select a document in the results to display it
in the view/edit pane. For your convenience,
DEVONthink always lists the original
document near the top of the list. This way
you can select it to go quickly back to the
original document. Double-click a document
to open it in a document window. Drag a
document from the list to move it to another
location. When dragging, you can create
duplicates by holding the ⌥ Option key.

The Search inspector provides in-document
searching. Using the same familiar ⌘F hotkey
you use in most macOS application, you can
not only search, but replace found words.
Additionally, DEVONthink provides a list
of the found words to help navigate the
results. The results also show the search hits
in context, either in a sentence or paragraph,
depending on the setting in See also p.
157ff .

You can also create replicants by holding
⌘ Command and ⌥ Option and dragging to

Searches match substrings by default. This

another location in the database.

means a search for "some" would also match
"something" or "worrisome".

CONTEXTUAL MENU

Something you may find useful is the live

The See Also and the Classify sections host

updating when you select other files. If you

many of the same contextual menu items

search for a word in the current document

as the item list. A list of these commands is

and leave the Search inspector open,

included in the contextual menu section of

DEVONthink will automatically search newly

the appendix. Also an alternative command

selected files.

is available when holding the ⌥ key: Reveal in
New Window.

SEARCH AND REPLACE
The Search and Replace section offers these
simple intuitive controls:
Find: Enter the word(s) you'd like to search
for. Note this matches substrings be
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default, so entering "word" would match
"words" and "wording" as well. Use spaces
before or after the word to treat it as a full
word.
Ignore Case: Ignores case-sensitivity when
searching.
Enable Wildcards and Operators: Allows
using wildcards and operators, e.g.,
DEVONthink NEAR sync. If this option
is enabled, the Edit > Find > Find Next/

SEARCH RESULTS
The results provide a convenient list of the
found words. This includes the line number
of each hit and the number of occurrences
found. It also includes part of the surrounding
text to help give some context to the found
words. Additionally, there a some contextual
menu options available when you Controlclick in the results:

Previous commands and next/previous

Copy: Copies the paragraph fragment

buttons in the inspector are available.

selected. You can optionally drag and drop

Previous/Next Arrows: Use these arrows

this fragment into the database or another

to cycle backward and forward through the

compatible document.

highlighted results.

Copy Paragraph/Page Link: Copies a link

Replacement Text: Enter replacement text,

to the current document, but appends

as desired. Note this field is only enabled

a parameter pointing to the selected

when you have editable text in the current

paragraph for rich text files or the page for

document; e.g., rich text or a Markdown

PDF documents.

document in editing mode.

Add to Favorites: Adds the current

Replace: Replace the currently highlighted

document to the Favorites.

word and move to the next search hit in

Add to Reading List: Adds the current

the document.

document to the Reading List.

All: Replace all occurrences of the found

Select/Deselect All: Selects all or none of

word.

the items, respectively.

In Selection: If you make a selection in the
text, you can replace all occurrences of the
found word in that selection.
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MENUS
IN THIS CHAPTER
The Application Menu

130

The File Menu

132

The Edit Menu

136

The Data Menu

138

The Format menu

141

The Tools menu

143

The View menu

146

The Go menu

148

The Window menu

150

The Scripts menu

150

The Help menu

151

The Dock menu

152

ABOUT & CHECK FOR UPDATES
About DEVONthink: Shows information
about DEVONthink including the version

A complete listing of all the commands

number to whom the software is registered.

available in the menu bar of DEVONthink, the
Services menu, and the contextual menu of

Check for Updates: Checks if updates

the DEVONthink's Dock icon.

for DEVONthink are available. By
default, DEVONthink checks for updates

THE APPLICATION MENU

automatically, however you can change
the update settings in the Preferences >

The DEVONthink menu is a utility menu,

General. If an automatic update is pending

similar to those found in other Mac

choosing this command shows a window with

applications. It has commands that allow you

additional information about the update.

check the version via the splash screen or
check for application updates. You can install
our add-ons, access the preferences, access
the Services menu, empty your databases'
Trash, and quit the application.

Note: When checking for updates no
information is uploaded from your
computer to the DEVONtechnologies
server. DEVONthink only downloads a file
listing the most current versions to your
Mac. This option is not available if you have
purchased DEVONthink from the Mac App
Store. In this case, all updates are handled
by the App Store.
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ADD-ONS
This command allows you to install, or
reinstall, some of our extra support files and
scripts.

windows. Use it to save directly to the
inbox from any application. Note: The name
of the inbox is "Inbox" regardless of your
computer's language preferences.
ABBYY FineReader OCR: Installs the
ABBYY Finereader OCR resources for use
with images and PDFs with no text layer.
Apple Mail Plugin: A plugin for Apple Mail
that allows you to archive messages or
whole mailboxes directly from within
Mail. On Mac OS Mojave you'll have
to manually activate the plugin after
installation. In Apple Mail visit Preferences
> General > Manage Plug-ins and activate
DEVONthink's plugin.
Note: The Safari browser extension is now
installed by default, but you'll need to go

The following options are available.

into Safari's Preferences > Extensions
and enable it. Also while extensions for

Google Chrome Extension: Opens the
Chrome Web/Store page in Google
Chrome where you can install the browser
extension. You have to do this manually and

browsers like Opera, Vivaldi, and Brave
are not explicitly available, it is possible to
install them from the Chrome Web Store,
while in those browsers.

follow Google's rules.
Firefox Extension: Opens the Mozilla Add-

PREFERENCES, TRASH, CACHE

Ons page in Firefox where you can install
the Firefox add-on (similar to the Safari

Preferences: Opens the application

extension). You have to do this manually

Preferences.

and follow Mozilla's rules.
PDF Services: Adds Save PDF to
DEVONthink to the PDF menu of print
dialogs. This allows you to print a PDF

Empty Trash: Moves the contents of all open
databases' trash to your computer's file
system trash.

directly to DEVONthink.

Empty Cache: Empties the web browser

Additional Scripts: Installs the mail rule

cache. This frees up space and makes sure

scripts for Apple Mail, Folder Action scripts

that all, when displaying a web page, all data

, and Menu extra scripts.

is freshly loaded instead of using a cached

Global Inbox in Save Dialogs: Inserts

copy.

DEVONthink's Global Inbox into the
Finder's sidebar and all "Save As" dialog
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PURCHASE & LICENSES

NEW & OPEN

Purchase: Opens the DEVONthink product

New Database: Creates a new database in

page from where you can put the app

the selected location.

into your shopping cart. If this copy of
DEVONthink is already licensed, you will be
presented with upgrade choices.

New Encrypted Database: Creates an
AES-256 encrypted database file at a userspecified size. Technically this database

Enter License: Enter your purchased license

uses an encrypted disk image but will not

code here. It is best to use copy-and-paste

be visibly mounted in the Finder. Obviously,

for transferring the license code from the

when you enable Spotlight for the database

email message to the appropriate field.

the data that Spotlight needs to store will

Note: Enter License changes into License
and Purchase License into Purchase
License or Upgrade as soon as you have

not be encrypted. The anticipated size of the
database can be specified in megabytes (MB)
or gigabytes (GB).

entered a valid license code (and a paid

Open Database: Opens previously created

upgrade exists). Available options depend

databases. You can select multiple

on whether you have purchased your copy

databases.

from DEVONtechnologies or from the Mac
App Store.

SERVICES
The Services submenu gives your access
to special commands published by other
Mac applications such as TextEdit or
Safari, or by services extensions such as
our own WordService or CalcService. Also,
DEVONthink publishes its own services. See
also p. 132ff

Open Recent: Presents a list of recently used
databases, which gives you quick access to
your frequently used databases. Choose
Clear Menu to remove all items from the
menu.
New Window: Opens a new main window for
the selected database.

IMPORT & EXPORT
Import: The Import submenu contains various
options for importing data, e.g.,selected files,

THE FILE MENU

bookmark, contacts, and some data from
compatible applications. Some options will

The File menu contains commands creating
and deleting databases. There are options

import files into their own special groups at
the root of the database.

for adding or exporting files, as well
synchronizing them. Additionally, if you need

Files and Folders: Imports selected files

to do database maintenance, you will find

or folders. Files will be imported to the

those commands here.
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current location. Finder tags and Spotlight

Images (with OCR): Imports images and

comments will be imported.

applies optical character recognition (OCR)

Bookmarks: Imports bookmarks from

to create a searchable PDF. This makes all

DEVONagent Pro, Firefox, Google Chrome,

written text searchable and available to

or Safari as bookmarks. Bookmarks are

DEVONthink's AI functions. You can change

imported into a newly created group

the setting in Preferences > OCR. See also

bearing the name of the chosen browser.

p. 70ff

Only new bookmarks are imported if you

References from Bookends: Imports

use this command again.

selected collections from the presented

Contacts: Imports Apple Contacts

dialog into a newly created group named

addresses selected in the import dialog

"Bookends". Already imported references

into a newly created group named

are updated. The keywords assigned to

"Addresses". Contacts can be imported as

a Bookends reference are added to the

a sheet, as vcards (.vcf), or as bookmarks.

Document Properties of the created rich

Previously created groups are reused.

text document. Use the optional script

Tip: To import all addresses, select all

Scripts > Tags > Convert keywords to tags

addresses in the group "All" and import

to convert the keywords to tags if needed.

them. Address card bookmarks link to the

Unix Mailbox: Imports Unix mailboxes, like

original card in the Contacts application.

those exported from Thunderbird. See also

Folders & Attachments from Notes:

p. 56ff

Imports your notes from Apple Notes.

Website: Opens the Download Manager

Items from Yojimbo: Imports all items from

and downloads a complete web page/site

Yojimbo into a newly created group named

for archiving and offline viewing. Make sure

"Yojimbo". Imported items retain their

the download options are set correctly,

name, label, flag, URL, comments, tags

especially the options that define which

and creation/modification dates. Items

links DEVONthink should follow (if any).

without a URL link back to the original item

All links within the site are modified so

in Yojimbo.

that they point to the downloaded images

Notes from Evernote: Imports selected

or other embedded objects. This ensures

notebooks from an import dialog into a

that the page/site can be displayed at

newly created group named "Evernote".

any time. By default, groups created by

Tags, dates, and URLs should be preserved.

the Download Manager are excluded from

Notes are stored as formatted notes. This

tagging.

option requires the Evernote application to

Scan from ScanSnap: Scans a paper

be installed.

document using an attached Fujitsu

Note: The import from Evernote command

ScanSnap scanner.
only works with Evernote's "legacy

Note: Groups created when importing

version" as Evernote 10 no longer supports

bookmarks, contacts, email messages, and

AppleScript

items from Evernote or Yojimbo are not
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automatically excluded from classification

embedded items (RTF) or with them

and tagging. This makes it easier to classify

(RTFD).

them later.

Text: Exports the selected items as one

Export: The Export submenu presents
options for exporting selected documents
or groups to the file system. In addition,
the Export menu provides export methods
based on plugins. DEVONthink comes with
a number of standard plugins for exporting
documents in different formats. For these
formats, the export creates a single merged
document when multiple files are selected.

merged plain text file.
Word 2007/97 Document: Exports the
selected items as one merged Microsoft
Word .docx (Word 2007) or .doc (Word
97) document.
Website: Exports the selected items as
standalone web site that you can upload to
your web server and share with colleagues.
In the presented dialog window, choose
the desired template, text encoding, and

Document: Exports the currently viewed

whether DEVONthink should convert

document in its native format. For images

diacritics and accented characters to

exported from a separately opened

HTML entities or not. Check Create Index

document window, DEVONthink lets you

Pages to create index.html pages with

choose the desired file format or image

cross-links to all included documents.

quality; e.g.,you can export a PNG files as a

Markdown and formatted notes are

JPEG file.

rendered to HTML, other file types that

Files and Folders: Exports the selected

cannot be displayed in a web browser,

documents in their native format. Groups

e.g., Pages files, are converted to PDF

are exported as Finder folders, preserving

if possible. Cross-links are converted

the group structure you have built in

correctly. For the export templates are

DEVONthink. DEVONthink tags are

used that you can modify yourself.

applied as Finder tags to the exported

Template: Saves the selected documents

files. Internal metadata for the items is

as a template, which can then be used

preserved in invisible .DEVONtech_storage

to quickly create new documents using

files, used for reimporting into

Data > New from Template. Export multiple

DEVONthink. If you will not be reimporting

documents and/or groups at once to

the exported files, you can safely delete

create e.g.,a project template. Data & New

.DEVONtech_storage files.

from Template & Open Template Folder;

OPML: Exports the selected items as one

can be used to organize templates.

OPML file.

Database Archive: Creates an optimized

PDF Document: Exports the selected items

ZIP file of the current database in the

as a paginated PDF. Hold the ⌥ Option

selected location. This can be useful as a

key to change allow the command to PDF

secondary backup strategy.

Document without Annotations.
RTF/RTFD Document: Exports the selected
items as one merged rich text file without

Unix Mailbox: Exports all selected email
messages and saves them as Unix mailbox
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file that can be imported into other email

Note: Indexed groups are excluded from

applications. Note this only applies to

tagging by default. For more information

exporting native email (.eml) files, not

on importing and indexing, please see the

files that have been converted to other

Import and Index section of the In & Out

formats, like plain or rich text.

chapter.

Share: This shows the standard Mac share
menu.

SYNCHRONIZE
Synchronize: Synchronizes the selected

INDEX
Index: Use this command to add external
files and folders from the Finder. This creates
links to the files but leaves them in the
current location. Regarding see-also and
classification, DEVONthink treats these

database with all its locations. Note, this
command will be disabled if the current
database has no active synchronization.
Holding the ⇧Shift key shows the Synchronize
All option to synchronize all actively syncing
databases.

files the same as imported files. To easily

Download Pending Files: Downloads the files

distinguish indexed items, a small Finder icon

of selected documents if they are available

is displayed to the right their name.

through one of the database's locations. Only

Update Indexed Items: Indexed items are
updated when you view them. If you need
to be sure everything is up-to-date use
this command. If nothing is selected, the

necessary of none of the database's locations
is set to synchronize indexed files.

DATABASE PROPERTIES & CLOSE

enclosing group of the current group is used.

Database Properties: Opens the Database

It also reads changes made to the Finder or

Properties popup for the current database.

Spotlight comments of the to-be-updated

This panel presents a few options, statistics

files and applies the changes to the files'

about the database, and allows you to change

counterparts in the database. Finally, this

the displayed name, add comments, and add

command removes indexed items that have

a username and password.

lost their external counterpart. It does not
affect items moved manually to the group.

Close Database: Closes a selected database.
If multiple databases are open, use Close

Use Update Indexed Items to keep indexed

All to close them all at once. If you'd like to

groups and their originating folders in sync

keep the current database open but close the

or to manually update an item that you have

others, use Close All Except. Note that closed

changed directly inside the database package

databases will not reopen on launch. Only

when DEVONthink was not running.

databases that were open when DEVONthink
quits will reopen on the next launch.
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DATABASE MAINTENANCE

PRINT

Like any database, DEVONthink databases

Page Setup: Sets your preferred page size and

need a bit of maintenance from time to time.

printer settings.

All the commands you'll need for this can be
found here.
Verify & Repair: Verifies all database

Print: Prints the current document or view.

THE EDIT MENU

structures and repairs them if necessary.
Use this whenever you feel it is necessary.

The Edit menu contains all commands and

By default, DEVONthink automatically

options relating to editing. You'll find the

verifies the database structure every time

classic Mac cut/copy/paste and find/replace

you open a database. If it finds significant

commands here, as well as many more.

errors, DEVONthink will advise you to run this
command.

UNDO, CUT/COPY/PASTE, …

Optimize Database: Creates an internal

Undo/Redo: Use these commands to undo or

backup of the database and then optimizes

redo the last action, e.g.,to undo deleting a

the database structure. Optimizing removes

file. Undo and Redo work for most actions.

unnecessary internal elements from the
database and rebuilds the internal structure

Cut/Copy/Paste: Do exactly what their
names say.

to optimize performance. DEVONthink
also creates internal backups on a regular

Copy URL: Copies the URL of the selected or

basis. Hold the ⌥ Option key to display the

frontmost document to the clipboard.

Restore Backup option. This allows you to roll
back the metadata to a previous date. This
option would only be used in troubleshooting
situations.

Copy Item/Page Link: Copies a URL to the
clipboard that links to the selected document
or group. These links can be used to create
a back link to the document in applications

Rebuild Database: Completely rebuilds

that support live hyperlinks. For PDFs, hold

the database by exporting all items to a

the ⇧Shift key to reveal the Copy Page Link

temporary folder in the file system, creating

option.

an empty database, and reimporting all
items. This removes any structural problems.
Depending on the size of your database,
this can take from a few seconds to several
hours. This option is typically only used in a

Paste and Match Style: Pastes text from the
clipboard, matching the styles in the current
document.
Delete: Deletes the selected piece of text.

troubleshooting situation.
Complete: Tries to auto-complete the
Delete Database: Closes a selected database

partial word before the insertion caret. This

and moves it to the Finder trash.

standard Mac function uses the currently
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active dictionary, chosen in the language

language used for spell checking, or for

dropdown of the Spelling and Grammar >

auto-completion (see above), open the

Show Spelling and Grammar panel.

spell checker panel with Edit > Spelling and

Select All/Deselect All: Selects or deselects
the complete content of the frontmost
document. Hold the ⇧Shift key to reveal the
Deselect All option.

Grammar > Show Spelling and Grammar and
choose your language of choice from the popup menu.
Substitutions: Shows the standard
Substitutions preference panel and switch
SUMMARIZE, TAGS, SET NAME
Summarize: Summarizes the selected piece
of text. Unlike the Mac's Summarize service,
this command takes advantage of the builtin AI of DEVONthink, and uses the complete
"knowledge" contained in the open databases
for improving the results. The better your
databases, the better the results.
Tags: Use this command to quickly enter tags
for the current document. This displays the
Tag bar, if necessary.

the available options manually on and off:
Smart Copy/Paste, Smart Quotes, Smart
Dashes, Smart Links, Data Detectors, and
Text Replacements. Data Detectors analyze
shown text and make context-sensitive
actions available, e.g., when you hover
the cursor over a phone number or postal
address.
Note: The Spelling and Grammar
and Substitutions commands can be
temporarily applied to the current
document. If you'd like these to be

Set Name As: Applies the selected text as

persistent choices, you can make global

the document's name.

changes in Preferences > Editing.

FIND, SPELLING, INSERT
Find: This submenu contains standard
Mac find commands, like those available in
TextEdit. Searches on the current document
are displayed in the Search Inspector. Two
commands of note are:
In Database: Brings the search field of the
frontmost window into focus.
Scroll To Selection: In long documents, this
command scrolls the current document to
selected text.
Spelling and Grammar: Provides the standard
macOS functionality for checking text for

Transformations: Use this submenu to change
selected text to all lowercase or uppercase, or
to capitalize every word.
Speech: Starts or stops speaking the
selected piece of text.
Insert: Inserts items, like pictures,
checkboxes, bulleted lists, etc. The options
available are dependent on the current file
type.

DICTATION & EMOJIS
Start Dictation: Starts the Mac's dictation
function.

spelling or grammar errors. To choose the
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Emoji & Symbols: Shows the standard Special

by pressing the ↩ Return key. Name the

Characters panel for inserting characters and

columns and sort the sheets by dragging

emoji that you cannot enter directly with

them with the mouse. Click OK to create

your keyboard.

the new sheet.
Bookmark: Creates a new bookmark. Type

THE DATA MENU

the URL and optionally name it to create a
bookmark, just as any browser does. If you

The Data menu contains all commands that

don't type in a name, DEVONthink will set

deal directly with documents or groups. Here

one automatically.

you'll find commands for creating, labeling,

Feed: Creates a new RSS feed document.

classifying or group new documents, and

The feed behaves like a special type of

more.

group that contains RSS entries published
by the feed's author. Type the URL and

NEW DOCUMENTS & TEMPLATES
New: This submenu provides access to the
built-in items DEVONthink allows you to
create.

optionally enter a name. If you don't type
in a name, DEVONthink will attempt to set
one automatically. You can change the URL
later by selecting the feed document and
changing the URL field in the Info inspector.

With Clipboard: Creates a new document

Twitter Feed: Creates a new RSS feed

based on the contents of the clipboard.

from a specified Twitter account. Enter

Note: Some applications such as Microsoft

the Twitter handle, e.g.,devontech, and

Word put data in multiple formats into

an optional name, to get a feed of recent

the Clipboard. DEVONthink tries to use

tweets from the account. If no name is

the most logical data when creating a new

entered, DEVONthink will attempt to set

document.

one automatically. As with other feeds, you

Plain Text: Creates a new plain text

also can change the URL, if for example, the

document.

feed isn't working as expected.

Rich Text: Creates a new rich text

Group: Create an empty group. This option

document.

appears as Tag if you are currently in the

Formatted Note: Creates a new formatted

Tags group of a database.

note.

Smart Group: Creates a new smart group.

Markdown Text: Creates a new Markdown

This is a special group that shows items

text document.

matching your specified criteria, similar to

HTML Page: Creates a new HTML page.

the Finder's "Saved Search". DEVONthink

You can use the built-in macOS WYSIWYG

opens the Smart Group Editor, which

editor to edit the HTML page or switch to

lets you define your search criteria.

its source code (from the navigation bar)

When saved, the contents are updated

and edit it directly.

every time you display the smart group's

Sheet: Creates a new sheet. Add columns

contents.

to the new sheet by using the + button or
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New from Template: This submenu allows you

Reveal: Reveals the location of the frontmost

to access any installed templates and add

document in either the same main window, if

them to the current group in your database.

possible, or by opening a new one.

There are two other commands to note:
Show in Finder: Opens a new Finder window
Open Templates Folder: Select this to

with the item selected. Note this only works

open ~/Library/Application Support/

for documents and indexed groups.

DEVONthink 3/Templates.noindex in the
Finder. You can add your own documents to
be used as templates here.
More Templates: Opens the Extras section
of the Support Assistant to install any
available DEVONthink templates.

Send by Email: Creates a new message in
the default email application and adds the
selected items as attachments. Supported
email applications are Apple Mail, Airmail
2, Microsoft Outlook, and Postbox, as well
as some legacy email application . If the

Note: For more information on the

selected item is an email message, the sender

pre-installed templates, check out the

is automatically inserted as the recipient and

Templates section of the appendix.

the text of the original message is inserted
instead of an attachment. Notes: Postbox is

OPEN, LAUNCH, REVEAL, SEND
Open: Opens the selected document or
group in a separate document window. This
command opens a second main window
for the selected group. If you have selected
multiple documents, hold the ⌥ Option key

currently only able to send one selected file.
Unsupported email clients (e.g.,Thunderbird)
can only send the plain text of one selected
file.

SAVE, REVERT, DUPLICATE

to display the Open in Tabs command. If

Save/Save All/Revert To Saved: Saves the

the View/Edit pane is visible, this opens the

frontmost document or all documents

selected items in new tabs. If the View/Edit

to disk. Hold the ⇧Shift key to show the

pane isn't visible, a new document window

alternate menu item, Save All.

will open with each selected document in its
own tab in the window.
Open with: Displays a list of applications
compatible with the current file type. Opens
the selected documents in the chosen
application. If your desired application is
not listed in the submenu, choose Other to
browse for it.
Launch URL: Opens the file, folder, or internet

Revert To Saved: Restores the frontmost
document to the last saved version.
Duplicate: Creates a duplicate of the selected
items. The name of the new item ends in
"copy", and because their contents are
identical both items are marked with the
icon for duplicates (or, depending on your
preferences, show their name in bold and
blue).

location indicated by the URL field in the Info
inspector.
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MOVE INDEXED ITEMS IN AND OUT
Note: The following two commands are only
for use with indexed files.

> Properties inspector for PDF or rich text
files, into a DEVONthink tag.
Convert Geolocation to Tags: Converts
geolocation data, if present on the file, into

Move Into Database: Use this command to

DEVONthink tags.

move an indexed file into the database. Use

Add Tags to Images: Adds tags to selected

this command with caution as it moves the

images using Apple's machine learning

file from its current location into the internals

technologies.

of your database. It does not copy the file.

Scan Barcodes: This option will attempt
to detect a barcode in a selected image.

Move To External Folder: Use this command
to move a non-indexed item, e.g.,imported
or created in DEVONthink, out to an indexed

A successfully detected barcode will be
added to the custom metadata for the
document.

folder in the Finder.
Note: The Add Tags to Images and Scan
FAVORITES, READING LIST, METADATA

Barcodes options require macOS 10.13 or
later.

Add To: Commands in this submenu add
the currently selected documents to your

CONVERT, OCR, THUMBNAILS

Favorites or the Reading List.
Convert: This submenu contains commands
Mark: Allows you to mark the item as
flagged/unflagged, locked/unlocked, and
read/unread.

for converting between some file formats,
e.g.,between rich and plain text. Note the
options presented are dependent on the

Rating: Allows you to set a rating, from no

type of the selected document. Also, due to

stars to five stars.

differences in the formats, any formatting
in the source document may not be able to

Label: Allows you to mark the selected groups

be perfectly preserved in the destination

or documents with one of seven labels, just

document.

as in the Finder. You can define the color and
the text of the labels in Preferences > Colors.

OCR: This menu contains options for
choosing an output format when doing

Tags: This submenu offers special commands

OCR on a selected compatible document

for automatically adding some kinds of tags.

(JPEG, PNG, TIFF, PDFs with no text layer).

Convert Keywords to Tags: Converts
keywords, found in the Document >
Properties inspector for PDF or rich text
files, into DEVONthink tags.
Convert Properties to Tags: Converts the
Author property, found in the Document

The currently supported output formats
are: Searchable PDF, RTF, Word , and Web
Archive. Additionally, there are two special
commands: to Comment and to Annotation,
which sets the Finder comment or creates
an Annotation file with the text. Neither
command alters the original file.

DEVONthink 3.7 Documentation, page 140

Thumbnails: Use these commands to add,
remove, or update a thumbnail for the
selected files.

GROUP & UNGROUP
Group Items: Creates a new group containing
all the selected items. This is similar to
creating a new group and moving the selected
items into it. The alternate command Group
Similar Items, shown when the ⇧ key is held,
will attempt to file selected items with
similar content in groups.
Ungroup Items: The exact opposite of Group

THE FORMAT MENU
The Format menu contains the commands
and options dealing with all aspects of text
formatting. Here you'll find the standard font,
alignment, and ruler commands, as well as
very special DEVONthink commands.
Note: Many commands in this menu
only work with rich text, Markdown, or
formatted notes. Plain text documents do
not allow formatting. (That's why they're
called "plain" text.) Some formatting
options are also available for editable PDFs
and web archives.

Items. Moves all items in the groups one level
up and deletes the now-deserted groups.

SEE ALSO & CLASSIFY

FONTS, STYLES, ALIGNMENT, RULERS
Font: This submenu is responsible for
controlling the font and the document

The following commands use DEVONthink's

background color (rich text documents only).

built-in AI to suggest good locations for the

Open the fonts panel with Show Fonts, then

selected documents:

increase or decrease the font size of selected
text with Bigger and Smaller, adjust the

Move (to): This command allows you to
quickly move other selected files to the last
destination chosen in the See Also & Classify

text styles and the document background
color. Of special note are these two submenu
commands:

inspector.
Copy Font: Copies the font formatting of a
Classify: Using DEVONthink's AI, this
command will move selected files to the AI
suggested location. This command is disabled
if DEVONthink is not sure enough about

selected piece of rich text.
Paste Font: After using the previous
command, applies the copied font to
another selection of rich text.

possible destinations.
Style: Commands in this submenu apply
MOVE TO TRASH

a certain style, such as italics, bold, or
underlined, to selected text. Also, the

Move to Trash/Move All Instances to Trash:
Moves the selected items to the trash. If

commands give you access to some highend font control like kerning, baseline

you have selected a replicated item, hold the
⌥ Option key and choose Move All Replicants
to Trash to move the selected item and all its
replicants to the database's trash.
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shift, ligatures, and character shape
(only applicable to Asian languages). One
command to take special note of:

LINKS, SPACING, LISTS, TABLES
Make/Remove Link: Converts the selected
text into an active link, or disables the

Styles: The Styles command opens the

link. This command can be used to create

macOS styles editor. With it, you can step

WikiLinks quickly.

through all the styles used in the current
document. If there's one you'd like to reuse,
add them to your favorites. Use the popup menu to select a saved style and, if you
don't need it any more, delete it. You can
use saved styles from the ruler (see below).
Alignment: Align paragraphs left, right,
centered, or justified. Here, Asian or Arabic
users can also change the direction of writing,
if required.

Add/Edit Link: Use this command if you want
to add a specific link to some text. If the text
is already linked, the menu will display Edit
Link, allowing you to change or remove the
URL. The behavior you'll see when clicking
linked text depends on the target of the link:
If the text was a valid URL, the URL will be
the target of the link. Editing the link text
later does not change the target. Use the
Edit Link command of the contextual menu

Ruler: This submenu allows you to display

to edit the link target.

the ruler above the preview of rich text

Otherwise, DEVONthink treats the link as

documents. There are also two special

a Wiki-style link. Clicking the Wiki-style

commands:

link jumps to a document with exactly

Copy Ruler: Copies the current ruler
attributes (tabs stops, indents, etc.) of a
selected piece of rich text.
Paste Ruler: After using the previous
command, applies the copied ruler
attributes to another selection of rich text.

HIGHLIGHTS
Highlight, Highlight Color: In rich text
documents, editable PDFs, and web archives
use Highlight to highlight a selected piece
of text just as you would using with a
colored pen on a piece of paper. To remove
highlighting, select the highlighted piece of

the same name as the linked text (or any
document with a Wiki alias of that name).
If there is no document of that name,
clicking the link creates a new rich text
document named after the linked text and
pre-filled by the template you set in the
Preferences > Editing.
Spacing: This command allows you to adjust
the line spacing of selected text in rich text
documents. You can adjust the line height
to an exact value or define a minimum and
maximum height, adjust inter-line spacing,
and define the space before and after a
paragraph.

text and choose Highlight again. Use the

List: Creates a bulleted list. Select your

Highlight Color submenu to choose your

prefix, bullet style, and suffix in the dialog

favorite highlight color.

sheet and click OK to insert a new list. In the
list, press ↩ Return to insert new items, and
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press ⇥ Tab and ⇧⇥ Shift-Tab to indent/de-

the ruler, and displaying the color picker are

indent items, just as you would in any word

shown. For sheets, tools to add/remove/

processor.

duplicate records, as well as editing columns

Table: Inserts a new table into a rich text

are shown.
document and opens the table inspector

Show Colors: Shows the color panel, e.g., for

panel. Use the table inspector to adjust the

changing the foreground color of selected

number of rows and columns, cell alignments,

text in rich text documents.

cell colors, border widths, and colors. Also,
you can merge and split cells and create
tables within a cell.

PLAIN & RICH TEXT, HYPHENATION,

Show Invisible Characters: Toggles display of
invisible characters such as spaces, tabs, and
line feeds. Shown invisible characters appear
in light gray.

LAYOUT

THE TOOLS MENU
Make Plain/Rich Text: Converts a rich text
document to plain text and vice versa.

The Tools menu provides tools to get more

Converting a rich text to plain text removes

detailed information about your documents,

all formatting, while converting a plain text

as well as some specialized commands.

document to rich text applies default rich
text font settings to the document.

INFO & FILTERS

Allow Hyphenation: Enables or disables

Get Info: Opens an popup containing more

hyphenation for the current rich text

detailed information about the currently

document.

selected file or group. It combines frequently
used elements of the Info inspector and

Make Layout Vertical/Horizontal: Enables

contains three panes:

orienting and editing the document text
vertically or horizontally.

Info: The Generic panel shows basic
information including name, aliases, URLs,

BARS, COLORS, INVISIBLE CHARACTERS

file dates, and kind. The Custom pane
shows metadata specified in Preferences >

Show Formatting Bar: Displays a toolbar of

Data that has been applied to the file.

formatting tools under the toolbar, providing

Annotations & Reminders: Shows a

access to styles, font and paragraph

summary of reminders set for this

attributes, and lists. These tools are only

document, Finder (Spotlight) comments,

used with RTF files.

and Annotations.

Show Editing Bar: Displays tools above the
current preview pane for some file types.
For example, rich text formats display
several common tools including increasing/
decreasing font size, highlighting, toggling

Properties: Shows metadata specific to
PDF and rich text files. This includes things
like keywords, author, and subject that are
sometimes included with these types of
files.
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Inspectors: This submenu provides access to

by frequency, groups, length, or weight.

the inspectors panes.

The data can be viewed in a List, Cloud,

Show/Hide: Shows or hides the inspector
pane.
Info: The Generic view shows basic
information including name, aliases, URLs,

or Graph. Additionally, selected words are
highlighted in the current text and a data
graph showing related words will appear in
the List and Cloud views.

file dates, and kind. The Custom view

Filter: The commands in this submenu

shows metadata specified in Preferences >

filter the list of files in the location you are

Data that has been applied.

currently viewing. As you select options

Annotations & Reminders: This inspector

in these panes, the list of files will change

shows a summary of reminders set for

accordingly. The filters are also covered in the

this file, Finder (Spotlight) comments, and

windows chapter.

annotations.
Content: When viewing PDF files, this
inspector provides a Thumbnails and a
Table of Contents pane. Note that the
Table of Contents panel is only displayed if
the current PDF contains one. DEVONthink
does not generate the table on its own.
Document: Useful when viewing PDF
and RTF files, this inspector displays
Properties, Annotations, and Links.
See Also & Classify: This inspector is
the main interface to DEVONthink's
brain, our built-in AI engine. This engine
is analyzing the contents and locations
of all documents in your database and
making connections between them. These
connections can be seen in this inspector
pane.
Search: This pane allows you to search

Info: Shows a pane with options for
filtering on dates, flagged state, unread
status, rating, or color label. When using
the calendar, you can click Any Date to set
which date you want to filter on: added,
created, modified, opened, or due.
Tags: Shows a tag cloud, with frequencybased sizing, i.e., more frequently used
tags will be larger. Clicking on tags removes
unrelated tags from the cloud, only showing
tags that have been applied with the
current tag.
Maps: Shows a small map showing pins
from geolocation data will be shown.
Clicking on a pin will show you files created
in that location. The behavior of this pane
is similar to Apple Maps, e.g., pinch to zoom
in and out, etc.

the current document, displaying the

Note: When Info or Maps is selected, the

found words in context and on what lines

options will appear at the bottom of the

they occur. Additionally, you can use the

sidebar. When Tags is selected, they will

Replace field to quickly replace selected or

also appear there, but will also show in the

all occurrences of the found words.

information bar above the item list if the

Concordance: The Concordance is a

sidebar is hidden.

specialized view showing data about the
words in a document. This can be sorted
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ANNOTATIONS
Annotate: This submenu provides access to
the PDF annotation tools: Oval, Rectangle,
Line, Note, Text, and Link.
Mode: Use the commands in this submenu to
switch between three modes of interaction
in PDF documents: Move, Text Selection, and
Annotation Selection.

Columns,and Delete Columns. See the
Documents chapter for more information on
sheets.

ROTATE & FLIP
Rotate Left/Right: Choose this to rotate
images, or individual pages in a PDF
document.
Flip Horizontal/Vertical: Choose this to flip

CAPTURE, IMPRINT, EDIT PDFS & SHEETS
Capture: This submenu provides options for
capturing the current document to a new

an image on its horizontal or vertical axis.

CREATE, SUMMARIZE, MERGE, SPLIT

file in a few different formats: Bookmark,

Create Expense Report: Creates a sheet

Plain/Rich Text, Formatted Note, HTML, Web

summarizing custom metadata dates and

Archive, and PDF (One Page/Paginated).

currencies of selected files. Totals for the

Captures are made to the current group.

amounts will also be included.

There is also an option to use the Clip to
DEVONthink command. This allows you to
clip to a chosen location.
Note: The available options in the Capture
menu are dependent on the type of the
current document.

Create Metadata Overview: Creates a sheet
with records for each selected file. The
columns contain data from the generic and
custom metadata of each file.
Create Table of Contents: Opens a submenu
to create a rich text or Markdown document

Imprinter: Choose an imprint you have

with links to the currently selected

defined in Preferences > Imprinter to apply it

documents.

to the current image or PDF.
Summarize Highlights: Creates a document
PDF Document: This submenu provides

with all highlighted text passages of the

options for editing the current PDF

currently selected documents. In case of

document: Insert Blank Page, Delete Selected

items located in multiple databases the

Page, and Reverse Page Order. See the

summary is created in the global inbox.

Documents chapter for more information on

From the submenu, choose to create the

PDF documents.

summary in a rich text document, Markdown

Sheets: This submenu provides access to

document, or a sheet.
the following tools for editing a sheet: New
Record,Duplicate Records,New Column,Edit
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Merge Items: Merge the selected documents

specifically defining a rule. This can be

into one. This creates a new file, preserving

useful to modify multiple selected files.

the originals. Hold the ⌥ key to choose Merge
& Delete n Documents, removing the original
files after the merged document is created.

START SERVER, TAKE NOTES
Start/Stop Server: Use this command to

When merging documents, the order of the

start and stop the integrated web server. See

merge will be the order shown in the item

also p. 72ff

list. The topmost selected document will
be the first page with the pages beneath it
following. The order of the documents can be
controlled by the current sort method in the

Take Note: Opens the Sorter to the Take Note
view. If the Sorter is not shown, it opens the
Take Note window.

item list. See also p. 147ff

THE VIEW MENU
Note: The resulting file type of a Merge
operation depends on the types of the

The View menu contains all the commands

selected files. Selecting mixed formats,

for modifying the way DEVONthink displays

e.g., a web archive and an image, usually

groups and documents.

results in an RTFD file being created.
SIDEBAR & LAYOUTS
Split PDF into Chapters: Used on a PDF
containing a table of contents, separate per-

Sidebar: The Sidebar view options allow you

chapter files are created.

to switch between the four different sidebar
views in a main window. You can toggle the

Split Document: Splits the current document

sidebar's visibility by selecting the same

(PDF, plain or rich text) at the insertion mark

option again.

position in the document.
Navigate: This is the main sidebar view,
RULES

giving you easy access to your databases,
favorites, and global smart groups. See also

These commands allow you to set or run

p. 85ff

smart rule commands

Reading List: Similar to Safari's Reading

Apply Rules: Apply the selected rule on
selected items that match the rule's
criteria, including the location defined in
the smart rule.
Perform Rules: Run the selected rule at any
time or in any location. This is not isolated

List, this sidebar view allows you
to maintain a list of items for later
consideration. See also p. 94ff
Extras: This view gives you access to recent
updates in tutorials, scripts, and templates.
And if you want to keep up on updates

to the documents in the current location.
Batch Process: Use this command to
quickly define and run commands without
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from us, it includes links to promotions and

as kind, label, size, word count, creation

release announcements. See also p. 98ff

date, and modification date. Available in all

Import: The Import sidebar view gives you

windows using icon or column views.
access to scanning and email archiving. See

Show Only Documents: When checked, this

also p. 97ff

hides groups and smart groups in List and

View: Choose one of the following options
to switch between different layouts for the
item list in a main window. All these views are
similar to options you find in Finder windows.
Icons: Displays items as icons.
List: Displays items in a list view with userspecified columns shown.
Columns: Displays the item list as a set of

Icons views. Note this is a per-database
setting, i.e., you can enable or disable it for
each open database.

COLUMNS & SORTING
Columns: This submenu lists all columns
available to be displayed as column headers in
the item list.

columns.

Sort: This submenu lists all the attributes

Cover Flow: Displays large thumbnails in a

that can be used to sort the current item

side-scrolling view.

list. Choose Unsorted to manually sort the

Preview: These options allow you to control
the position of the current document's
preview, or dismiss it altogether.

items. DEVONthink remembers sort settings
for every group separately and uses those
settings when the group is displayed in its
own main window

None: This creates a list only view.
Standard: This shows a preview under the
file listing.
Widescreen: This shows the preview to the
left of the file listing.

FULLSCREEN & ZOOM
Full Screen: Displays either the current
document in a full screen mode optimized for
reading and editing, or the frontmost window

Quick Look/Slideshow: Opens the Quick Look

in full screen. There are two options available

panel for the selected items which can be

here:

useful for times when the view/edit pane
isn't displayed. Holding the ⌥ Option key
allows you to display the selected files in a
Quick Look slideshow.

SHOW TAGS & DETAILS
Show/Hide Tags: Shows or hides the tag bar.

Document: Shows the current document in
full screen. Note this is a distraction-free
view, not the standard macOS fullscreen
view.
Window: Shows the current window in a
standard macOS full screen view.
Zoom: Depending on the document type, you

Show/Hide Details: Switches between

can zoom or out of the document's preview

displaying icons only or displaying icons

to your needs:

together with detailed information such
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Actual Size: Displays the document

PDF Display: This submenu lets you adjust

at actual size, calculated using the

the way PDF documents are displayed:

resolution of the screen and the resolution
information of the image or PDF.
All Pixels: Displays the document at a 1:1
ratio so that one pixel of the image equals
one pixel on the screen (PDFs and images
only).
Zoom In/Out: Zooms in or out of the
document.
Zoom to Fit: Displays the document so
that it exactly fits either the height or the
width of the window/preview pane (PDFs
and images only).
Zoom to Width: Displays the document so
that its width fits the width of the window
or view/edit pane (PDFs and images only).

DOCUMENT & PDF OPTIONS
Document Display: This submenu contains

Single Page, Two Pages: Shows a multipage document as single pages or two
pages facing each other (as in a magazine).
Continuous Scroll: When checked, shows
the pages of the PDF as one long scroll.
When unchecked, only one page is shown
at a time.
Book Mode: When checked, facing pages
start with one single page (the title page),
then facing pages. When unchecked, they
start facing.
Page Breaks: When checked, pages are
shown with a small break between the
pages. When unchecked, the pages appear
as a continuous document.
Crop Box, Media Box: Crops the page to
the crop or media box. By default, PDF
pages are cropped to the crop box.

commands for displaying alternate views of
some documents. Note there are alternate
commands shown when used with sheets or
HTML and Markdown files.
Best Alternative/Preview/Table View:
Shows a QuickLook view, or a rendered
view for HTML-based and Markdown files,

TOOLBAR
Hide/Show Toolbar: Hides or shows the
toolbar of the frontmost window.
Customize Toolbar: Lets you configure the
toolbar of the frontmost window.

the Table view for sheets.
Text Alternative/Source/Form View:
Shows a text-only view of some file types,
e.g.,Word or email. Also shows the page
source of HTML-based and Markdown files
or the Form view for sheets.
Side-by-Side: Shows a side-by-side view
of the rendered view and source for HTML
and Markdown files. Note this does not
apply to Formatted Notes.

THE GO MENU
For people who prefer to use the keyboard
for navigation, the Go menu contains all
commands for navigating the hierarchy
of your DEVONthink database, all with
keyboard shortcuts. Use these commands
to go backwards and forwards through your
documents, or to move back to the top level
of the group hierarchy.
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DATABASES
Previous Database: Selects the previous
database in the Navigate sidebar.
Next Database: Selects the next database in
the Navigate sidebar.

GROUPS

Previous/Next Instance: Navigates
backwards and forwards through all instances
of a replicated document. Use these
commands to find out where the other
instances of a replicated item are.
Previous/Next Highlight: Navigates
backwards and forward through all
highlighted passages within a document,

Top Group: Returns you to the top level of the

regardless of whether these passages have

database (also known as the "root").

been highlighted by a search or manually
using Format > Highlight.

Enclosing Group: Changes the view to
the parent folder of the current group or

Next Unread Item: Navigates to the next

document.

item with an unread status in the current
database.

Selected Group: Changes the view to the
currently selected group.

Go to Page/Time: Allows you to jump to a
specified page (PDF documents) or time

To Group: Opens a popup where you can

(supported video and audio files).

search for a group by name. Results are
shown as you type. The chosen group from

Favorites: Displays a menu of items in the

the results will display as the current group.

Favorites section of the Navigate sidebar,
allowing easy access to the items.

DOCUMENTS
WORKSPACES
Back/Forward: Moves backwards and
forwards through all documents/web pages

Workspaces allow you to save the state of

you have visited by following cross-links or

your open databases, as well as the contents

Wiki-style links.

and positions of all open windows, so that
you can restore them later. This is ideal if you

First/Previous/Next/Last Document:
Navigates to the first, previous, next, or last
document of all documents in the current
group. This is useful when you have opened

are working with the same set of windows
over and over again. Save these windows as
a workspace and recall them whenever you
need them again.

a document in a separate window and want
to move to another document in the same

Add: Saves the currently open windows as

group.

a workspace.
Edit: Opens a window that allows you

To Document: Opens a popover to quickly
navigate to a specific document.

to edit saved workspaces. Click on a
workspace name to change it, reorder by
dragging, and delete with the - button.
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Update: Updates an existing workspace

Download Manager: This command opens

to the current state of databases and

the Download Manager panel of DEVONthink.

windows.

Using the Download Manager, you can

Workspaces: Choose a workspace from the

download files or complete web sites from

list of saved workspaces to load it.

the internet and store them directly in your
database.

THE WINDOW MENU

Log: Opens the Log panel. The log lists error

Just like most every macOS application, the

messages and warnings that occurred while

Window menu lists all open windows of the

importing new documents. It also opens

active application and gives you access to

automatically when an error occurs. You can

commands for managing them.

save the log to a text file or clear it.

WINDOWS & TABS

OPEN WINDOWS

Close, Zoom, Minimize: These three

Window List: Select any open window from

commands resemble the red, yellow, and

the menu to bring it to the front.

green buttons of any window title bar, and
consequently close the window, minimize
the window to the Dock, or maximize the
window. No magic here. Hold the ⌥ Option
key to change allow the command to affect
all windows.

THE SCRIPTS MENU
The Scripts menu is located left of the Help
menu and shows a stylized AppleScript
symbol instead of a normal menu title. It
contains a collection of useful, predefined

New, Close, Select Next/Previous Tab: Opens

AppleScripts you can use directly from within

a new tab, closes the active tab, or moves the

DEVONthink.

focus to the next or previous tab.
Note: Tabbed browsing needs to be
enabled for these commands to work.
Bring All to Front: Brings all windows of
DEVONthink to the front. Hold the ⌥ Option
key to change Bring All to Front to Arrange in
Front.

ACTIVITY, DOWNLOADS, LOG
Activity: Opens the Activity panel. This panel
shows all running processes, e.g.,OCR or sync
activity, and allows you to manually stop
them.
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DEVONTHINK
Use these commands to open the integrated
help pages, get directions on installing the
browser extension and bookmarklets, or
access the list of changes to DEVONthink.
Some of the scripts work without having
selected a document, while others require

SUPPORT

you to select the document you want the

Your Account: Opens the login page for your

script to interact with. In general, the script

DEVONtechnologies account where you can

will tell you what you have to do when you

get information on your licenses and the

select it from the

devices they're registered to.

menu.

Use More Scripts to install additional

Support Assistant: Opens the support

scripts and read more about scripts and

screen of the Welcome to DEVONthink

DEVONthink's

assistant with more direct links to the

menu here.

DEVONtechnologies website, tips, and

THE HELP MENU

tutorials. Note this function requires an
Internet connection.

The Help menu contains commands
for opening the integrated help pages,

Tutorials: Opens the Tips and Tutorials

the support assistant, or visiting the

screen of the Welcome to DEVONthink

DEVONtechnologies website.

assistant. The tutorials help get you started
by explaining everyday DEVONthink tasks
in step-by-step detail. Note this function
requires an Internet connection.
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DEVONTECHNOLOGIES
These commands take you directly to the
corresponding pages on our website or send
feedback directly us.

It also contains the generic macOS
commands and an Options menu common to
all macOS applications. DEVONthink-specific
items are listed below:

DEVONtechnologies, User Forum: Quickly
access our home page or our user forum in
your default browser.
Contact Us/Report Bug: Use this to draft a
general email to us. When you need to report
an issue, hold the ⌥ Option key to show the
Report Bug. This creates a new message
in your default email client or Apple Mail
containing the console log and all related
crash logs in a ZIP archive, ready to be sent to
our customer support.

THE DOCK MENU
The Dock menu appears when you click
DEVONthink's icon in the Dock with the
⌃ Control key pressed, when you right-click it,

Recent Databases: Quickly reopen a closed

or when you left-click it and hold the mouse

database from this list.

button for one second or longer. When items
are added to a database, a badge appears
on this icon. Longer tasks, e.g., importing,
indexing, or running scripts, may show a
progress indicator on the dock icon.

Open Windows: Switch to any open window
from this list. The active window is displayed
with a checkmark next to it.
Take Note: Opens the Take Note panel.
Start/Stop Server: Starts or stops the web
server.
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GENERAL

The Preferences window, which you open

Stricter recognition of duplicates: Check to

by selecting Preferences in the application

have DEVONthink mark files as duplicates

menu, is the place to go to change global

consider the file type and size, as well as the

settings for DEVONthink. In addition to

content, when determining duplicate files.

global settings, databases also have separate
settings in their Database Properties

Enable reminder alarms: Enables or disables

window that you open using File > Database

using DEVONthink Reminders. This can be set

Properties.

on a per-machine basis.

There is also a number of hidden preferences,

INTERFACE

intended for customer support, but maybe
useful for you, too. See also p. 237ff

These options control the behavior of
the interface, e.g., when double-clicking
documents.
Double-click opens groups in a new
window: This option allows you to open a
new window when you double-click a group.
If unchecked, the group will be selected
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and its contents will be replace the file list

if you'd like to view the document title in a

being currently viewed.

tab bar when only one document is open.

Double-click opens documents externally:
Check this if you'd like documents to open
in an external application when doubleclicked. DEVONthink uses the application
set as the default application for the
file type in the operating system, e.g.,
TextEdit for RTF documents. If unchecked,
any document that can be edited in
DEVONthink will be opened in its own
window.
Click on links opens them externally:
Enable opening links in document text
in the system default application. Use
⇧-click to open and activate the default
application. Note ⌘ or ⌥-clicks can be
still used to open links in new tabs or
to add them to the Download Manager,
respectively.
Keep groups on top when sorting: Always
display groups at the top of the item list,
independent of the sort method, e.g., by
Name, by Date Added, etc.
Retain view: When enabled, the view
settings in the current main window, e.g.,
Icons in Widescreen, override the view
settings of other groups or databases.
If a change is made to the current view,
that change will persist when switching.
If no changes are made, the previous view
settings will be restored after disabling this
option.
Enable tabbed browsing: When checked,

SIDEBAR
Automatically expand & collapse: Check
this to automatically show the sidebar
when revealing an item or opening a group
in a new window.
Unify Databases: When enabled,
navigate the groups of the root of all
open databases in the Open Databases
section of the Navigate sidebar. When
disabled, the groups of the root of the
active database are displayed in an active
database section in the sidebar. This allows
isolating the groups of a database. The
active database will have an asterisk to the
left of the name.
Unify inboxes: Display the inboxes of open
databases only in the Globals section of
the Navigate sidebar. When disabled, the
inbox will be displayed in the item list for
the current database.
Unify tags: Display the Tags group of open
databases only in the Globals section of
the Navigate sidebar. When disabled, the
Tags group will be displayed in the item list
for the current database
Keyboard Navigation: Enables keyboard
navigation with typing selection, and arrow
key hoisting of groups in the Navigate
sidebar.

click with ⌘ Command pressed a link in

ALERTS

web, PDF or text views to open it in a new

Click Reset to make DEVONthink show alerts

tab. When unchecked or the ⌘ modifier key

again that you previously dismissed with

isn't pressed, documents are opened in the

"Don't show again" checked.

same view, in the default application or in
new windows. Check Always show tab bar
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CHECK FOR UPDATES
Change the settings in this tab to define
when you want DEVONthink to check for new
versions: never, on startup, daily, weekly, or
monthly. DEVONthink only performs checks
for updates when the computer is connected
to the Internet.

Highlight Internet links in views: Check to
show bookmarks in the file list and links in
documents marked in blue and underlined.
Mark duplicates and replicants in color:
Check to highlight duplicates marked in
blue and replicants marked in red in most
views. When unchecked duplicates and
replicants display an special icon to the

Click Check Now to immediately check for a

right of a document's name.

new version.

Show filename extensions: Check this if
you prefer to see the file type's extension

APPEARANCE

at the end of filenames.
Use dark background for documents: When
enabled, compatible documents, e.g., rich
text, will display white text on a black field
when using macOS' dark mode. When
disabled, documents will display normally.

LABELS
Choose how you would like labels to be shown
in lists.
Classic: Tints the group/document icon
(like on Mac OS 9).
These options define some parts of the visual
appearance.

Modern: Puts the group/document name in
a colored bubble (like on older versions of

Alternating row colors in views: Check

OS X).

to color every second row in item lists

Dots: Shows a colored dot in the list (like

differently.

on macOS).

Display number of items inside groups:
Check to show the number of documents
in groups. In the sidebar, the total number
of items in the group is shown. News feeds
will show the number of unread items. In
the item list, this shows the number of

FONTS
Use Sidebar Text Size to set the font size
DEVONthink uses in the sidebars. Use View
Text Size to set the font size used in the item
list and the contents of sheets in table view.

unread and read documents contained in
a group. For example, "2/10" shows there
are two unread documents out of ten total
documents.
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EDITING

Smart links: Detect web addresses and
turn them into clickable links.
Smart dashes: Convert characters, e.g.,
two hyphens into a proper dash.
Data detectors: Detect dates, times or
addresses in text, and show possible
actions when the mouse cursor moves over
them.
Text replacement: Use the system-wide
text replacements when editing text.

AUTHOR, RULER UNITS AND FONTS
Author: Enter your name. It will be used as
The Editing tab defines all options that fine
tune DEVONthink's text editing behavior,
from the ruler units to default font settings
to summarization options.

default for metadata, e.g., for new rich text
documents or PDF annotations.
Ruler Units: Select your personal
preference for ruler units: centimeters,
inches, points, or picas.

GENERAL

Plain Text: Select your preferred font.

Display PDF attachments of rich texts:

This is the font automatically used when

When checked, a PDF inserted into an

you create new documents. Additionally,

RTFD documents will display its first page.

specify the background and text colors to

Unchecked, you will see a link and the PDF's

suit your taste.

filename.

Rich Text & Note: Select your preferred

Scale image attachments: Images added

fonts for new rich text formats. This is the

to rich text files and formatted notes are

font automatically used when you create

scaled to the current width of the view/

new rich text documents or formatted

edit pane.

notes. It is also the default used for

Check spelling while typing: Spellcheck

rendered Markdown documents, if no

while you write.

default stylesheet is specified.

Check grammar with spelling: Check

Note: Hold the ⌥ Option key to restore the

grammar as well as spelling while you write.

default fonts.

Correct spelling automatically: Correct
misspelled words automatically.

FULL SCREEN

Smart quotes: Convert straight quotes
("inch marks") to typographer's quotes

Full Screen: Select your preferred font for

("curly quotes") while you type.

reading and editing plain text files in full

Smart copy/paste: Insert or remove spaces
before and after cut or pasted text.
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screen mode. Rich text documents will

For more information on creating WikiLinks

display their user-specified fonts.

and other linking methods, see the Document

Background: Choose a background color for

Linking section.

the full screen mode.
Text: Choose a text color for the full screen
mode.
Width: Choose a width for displaying
documents in full screen mode. This setting
will apply wider or narrower left and right

WIKILINKS
To enable WikiLinking, check the Automatic
checkbox and choose from the options shown
here:

margins, based on a percentage of the

MashedWords: Commonly used to avoid

screen width.

creating links from individual words,
mashed words are document titles of

SUMMARIZATION
Select whether you wish DEVONthink to
summarize based on sentences or whole
paragraphs.

joined words. If you type a mashed word,
it will automatically create a link. If a
matching document is detected, it will
open when clicking the link. If a matching
document isn't detected, DEVONthink
will create a new rich text document,

WIKILINKS

prepopulated with information defined in
the Template section below.
Square Brackets: WikiLinked text can
be defined using square brackets. Type
two opening square brackets and the
beginning of a document name. Then
press ⌥⎋ Option-Escape to show a list of
potential item matches in the database.
Choose a document and press ↩ Return to
complete the link.
Names and Aliases: Matches documents

WikiLinks are a way to create interconnected

based on their name or any aliases defined

documents in your databases. When enabled,

in the Info Inspector.

DEVONthink attempts to detect other

All Items/Only Documents/Only Groups:

documents matching the terms you've

Choose whether to match only documents,

typed in plain text, rich text, or Markdown

groups, or both.

documents. This creates an active hyperlink

Case-insensitive Linking: Enable this to

to the detected document, allowing you

ignore capitalization when matching Names

to quickly jump to it by clicking the link.

and Aliases, e.g., GlobalEconomy and

WikiLinked text displays as underlined text.

globaleconomy both would match.
Open new documents in separate
windows: When clicking a WikiLink, the
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linked document will open in its own
document window.

TEMPLATE
Text and items entered here will be used to
create a new WikiLinked document. You can
type any text you want as well as Controlclick and use Insert Placeholder to insert a
token that will be automatically replaced
when the template is created. The default
title contains several of these tokens already.
Check out the placeholders section of the
appendix for information on the available
choices.

DESTINATION
Choose the default destination where
incoming data is stored.
Select group: A group selector is shown
that lets you choose the destination. The
group selector appears as a black panel
floating on top of all other windows. Use it
to select the group where you want to file
the items.
Global inbox: The data is stored in the
global inbox.

TEXT ENCODING
Choose the default encoding used for plain

IMPORT

text documents. Select Automatic to let
DEVONthink choose the best encoding.

TAGS
Imported files can have metadata that may
be useful as tags. Choose options to convert
specific types of information to DEVONthink
tags.
Convert keywords to tags: Check this to
Here you can choose options for the location,

convert embedded keywords from PDFs

encoding, and tagging of files coming from

and RTF(D) files to tags.

external sources, including bookmarklets,

Convert properties to tags: Check this to

DEVONagent Pro, items dropped on the dock

convert embedded properties from PDF

icon, (external) scripts, or services.

and RTF(D) files to tags.
Convert geolocation to tags: Check this to

NEW NOTES

convert proper names of geolocation data
to tags, e.g., "Orlando", "FL", and "United

Check Select (and display) automatically to

States".

automatically select and display the last note

Convert Hashtags to tags: Check this to

you have taken.

convert found hashtags to tags.
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Add tags to images: Check this to

Menu Extra Title: Choose whether to

automatically apply tags to imported

show the menu extra as text, or a space-

images.

conserving icon.

Scan Barcodes: Check this to allow

Screen Capture: Check this to play the

DEVONthink to try and detect a barcode in

system default screen capture sound.

an imported image. The detected barcode
will be added as custom metadata

HOTKEYS

These options are honored by email archiving,

Set system-wide hotkeys for: Take Note, Copy

scanning and OCR, importing from Bookends,

Selection, Clip to DEVONthink, and Search.

Evernote, Apple Notes, and Yojimbo, as well
as documents created via the Sorter and the
web interface (Server edition only).

To change the hotkeys, click the Click to
record shortcut button, then press the
hotkey that you want to use. Press the
⎋ Escape key to cancel recording a new

SORTER

shortcut.
Note: On macOS Mojave, you will be asked
to grant Accessibility permissions for Copy
Selection, and Automation permissions for
Clip to DEVONthink.

MEDIA
In the media preferences, you tell
DEVONthink how to display multimedia files,
images, PDFs and other documents. You can
The Sorter preference allows you to choose

also set options to generate thumbnails for

the window's appearance and location, and

certain filetypes.

assign a hotkeys for capturing data or taking
a new note. See also p. 55ff

APPEARANCE, LOCATION,…
Appearance: Choose to display the Sorter
as a menu extra, a docked tab on the side
of your screen, or not at all.
Position: Choose the onscreen position
of the docked tab. These options will be
disabled if Show as Dock Tab isn't selected.
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MathJax support: Supports rendering
mathematical equations via the MathJax
extension.
Mermaid support: Supports rendering
diagrams via the Mermaid extension.
Prism support: Supports syntax coloring
of rendered inline code and code blocks via
the Prism extension.

MARKDOWN
Choose options for the default mode when
selecting Markdown files, styling, or any
extensions to be used when rendering the
Markdown.
Markdown Display: Choose whether you want
to open Markdown documents by default in
editing or preview mode.
WYSIWYG editing: Toggle the display of
formatting and detected elements in the
source code of a Markdown document.
Style Sheet: If you want to choose a default
stylesheet to display your Markdown
documents, click the Select button to access
stylesheets stored on your machine, e.g.,
in ~/Library/Application Support/
DEVONthink3/StyleSheets or paste the URL
of an online stylesheet.

MULTIMEDIA
Choose options for media playback or the
default display mode of PDFs or images. You
can also choose a background color for these
media types.
Play Media: Check Play automatically to
play audio and video files automatically
when you display them. Check Loop if
you want to play the clips in a loop. Set a
desired background color for the selected
media file.

Extensions: Check the desired options for

Image Display: Choose a default zoom

Markdown extensions:

factor and a background color for viewing
images
PDF Display: Choose the default display
size background color for viewing PDFs in
windowed and fullscreen modes. Check
Automatically resize to automatically
resize PDFs in the view/edit pane. Set the
background color.
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COLORS

SHEETS
Choose the default display mode, Table View
or Form View, and background color for
sheets.

Label: Set the name of color for color labels
applied to files and groups in your database.
Highlight: Set the name and color to be
used for highlighting text in compatible file
formats, like PDFs.
Note: These are global settings, i.e., you
can't have per database label or highlight
colors. Also, following Apple's example,
we only allow setting seven colors in each
category.

WEB
THUMBNAILS
Choose the file types for which DEVONthink
should automatically generate thumbnail
icons. For images, choose whether to
generate the thumbnails from the actual
image, ignoring any embedded thumbnails.

The web preferences resembles the settings
of most web browsers. Use these preferences
to define how DEVONthink's displays web
documents and "live" web pages.
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WEB CONTENT

ACCEPT COOKIES

These settings define how DEVONthink

Cookies are little text files with information

treats special web contents:

that web pages store on your computer use

Enable ...: Check these options to use
installed third-party plugins, (such as Flash
or RealPlayer plugins), and to run Java
applets or JavaScript scripts contained in,

to recognize you as a returning customer,
among other things. While most cookies are
harmless, you may want to control what is
being stored on your hard disk.

or linked to, a web page.

Always: Accept all cookies.

Block ...: Check Block pop-up windows to

Never: Don't accept any cookies.

block pop-up windows, which are often

Only from sites you navigate to: Accept

advertisements; check Only automatic

cookies, but only from web sites you

JavaScript windows to block only pop-up

navigate to (not from other sites, such as

windows opened by JavaScript. Uncheck

ad trackers).

this option if the web page you're visiting

Delete cookies on quit: Delete all stored

uses pop-up windows for actual content.

cookies when you quit DEVONthink.

(Some web content management systems
do this.) Check Block zooming to keep web
sites from automatically zooming windows
to full size. Check Block advertisement
to block common inline advertisements
provided by some search engines.

FONTS
Set the fonts you want to use for displaying
web pages; set separately for variable-width
and fixed-width text.

Zoom text only: Check to zoom only the

Note: Hold the ⌥ Option key to restore the

text and uncheck to use Safari-4-style

default fonts.

zooming.
STYLE SHEET
IMAGES
You can further control the way DEVONthink
These settings define how DEVONthink

displays web pages by applying a CSS style

displays graphics in web pages:

sheet that changes the rendering on the fly.

Display images when the page opens:

Click Select and choose your style sheet to

Check this option to display web pages

apply it to DEVONthink's integrated web

with images. Just remember, if unchecked,

browser. Note: This is for experts since it

you may miss some information.

modifies how all web pages are displayed and

Animate images, Loop animation: Check

can lead to undesired effects.

these options to run web graphics
animations and to run animated graphics in
a loop.
Scale images to fit: Check this option to
scale (large) images to fit.
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TEXT ENCODING
Select your desired text encoding for
displaying web pages. Automatic tries
to choose the best available encoding. If
this does not work for you, choose a more
appropriate text encoding for your language
group.

Remove immediately instead of moving
to the trash: Immediately deletes the RSS
articles.
Feed Format: Choose a file format for
the downloaded articles. (RSS articles are
presented as HTML files, by default.) Check
Use clutter-free layout to try to remove
unwanted ads, etc. from the article.
Feed Style Sheet: For HTML (Feed Format:

RSS

Automatic) articles, DEVONthink comes
with multiple styles for displaying them.
You can use your own RSS stylesheets by
placing them into ~/Library/Application
Support/DEVONthink 3/StyleSheets.

DATA

DEVONthink comes with built-in RSS
capabilities that enable you to add RSS feeds
to your database and have DEVONthink
update them automatically. Use these
preferences to define how often DEVONthink
checks for new articles, whether to skip
duplicates when updating feeds, when to
remove older articles, and which CSS style
sheet to use for displaying the articles.
Check for updates: Set how often you want
DEVONthink to refresh your feeds.

Here you can define custom metadata fields
that can be assigned to your documents.

Convert categories to tags: Some RSS
articles have tag metadata to help people

CUSTOM METADATA

more easily navigate the publisher's site.

The Custom Metadata column contains a

Check this option to convert these to

range of built-in fields, ready to use or modify,

DEVONthink tags. Note this can add a

as needed. These cover a variety of common

great number of tags to your database.

uses and a list of the pre-defined fields can

Remove articles: Set how often older

be found in the Data section of the appendix.

articles are removed from the feed. Check
Also unread articles to remove them, even
if they're unread.
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Enable any field by checking the checkbox

Add and remove the items with the + and -

next to it. Use the buttons below the Custom

buttons. Control-click an item to change it.

Metadata column for extra options:
Note: Please refer to the Data section for
Add: Click the + to create and name a new

more detailed information on the data

custom field.

types.

Remove: Click the - to remove any field.
When deleting a field, a warning will be

EMAIL

displayed. This warning can be suppressed.
Action: Select any field and click

for

more options, including duplicating and
renaming the selected field.
The order of the fields is also the order in
which they appear in the Info inspector.
Note: These options are also available from
the contextual menu.

PROPERTIES
Use these options to define how email is
Use these controls to modify the properties

imported and displayed inside DEVONthink.

of the selected field.
Identifier: This is a special name used in

CONVERSATIONS

automating with AppleScript. The term is

Import complete conversations:

derived from the field's name, and cannot

DEVONthink can import not only selected

be entered or modified manually.

email messages, but also other messages

Type: This is the specific type of the

related to a conversation. Check this box to

current field. Choose one of twelve data

let DEVONthink scan your Sent Messages

types, such as Date, Boolean, Decimal

folder and import sent messages that

Number, or Languages.

belong to the same conversation.

Format: Only displayed with certain data

Group conversation threads: Check this

types, you can choose some pre-defined

option to combine all messages belonging

formats, like Percent. With the Currency

to a conversation thread into a group. This

option, you will have an option to enter a

makes identifying conversations easier

currency symbol.

and automatically adds structure to the

Values: Only displayed with the Single-

imported messages.

line Text and Set types, define a list of
items to choose from. These choices will be

Note: These features only work if the email

displayed in a dropdown menu when in use.

program maintains references to previous
messages sent.
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MESSAGES

FONT, QUOTED TEXT, LABELS

Previously imported will become

Use fixed-width font for plain text

replicants: Check this option to import

messages: Check to show plain text

previously imported messages again as

messages using a fixed-width font such

replicants. When this option is unchecked,

as Courier. This is useful if the messages

DEVONthink skips previously imported

contain tables or footers formatted with

messages.

spaces.

Use alternative view: Check this option to

Color quoted text: Check to mark text

view email messages as text alternative by

quoted from previous recipients in

default.

messages. Click the color buttons to
change the color for first, second, and third

MESSAGE CONTENT
Fallback text encoding: When decoding
an email message, DEVONthink uses
the message's encoding information.
When there is no encoding information,
DEVONthink uses the encoding that you
set in this pop-up menu.

level quotes.
Labels: Select which labels you want to
assign to messages that were flagged
or marked as "high priority". Since items
can only have one label at a time, flagged
messages are treated as more important
than messages marked as "high priority".

Download remote images in HTML

Note: The first two options above only

messages: Check to store the image

modify the display of email messages in

references required by HTML messages

the text view. By default, messages are

in the database. Spammers and other

displayed using QuickLook.

unfriendly agencies may use these images
to track if you have read the message.

OCR

Therefore this is unchecked by default.
Decrypt secure messages: Check this to
decrypt and file secure email messages.
This allows DEVONthink to search or apply
AI-based functions such as Classify or See
Also to them.
Note: The email message will be stored
decrypted in the database package.
Its contents are available from within
DEVONthink and to other applications or
Spotlight.

DEVONthink contains an optical character
recognition (OCR) module that allows you to
import scanned documents and make them
searchable. These documents are "read" by
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the embedded OCR engine and stored as PDF

author of the document, and any keywords

files that contain an additional (invisible) text

describing the document. You can also adjust

layer with the recognized, computer-readable

the timestamp of the PDF to the actual date

text. Use these options to fine tune the OCR

of the paper document. The dialog window

process.

is shown when OCR processing has been

You can import scanned documents, or scan
them directly from within DEVONthink.

completed.
When checked, the metadata entry dialog
will appear whenever you scan a document
CONVERT INCOMING SCANS
Check Convert to searchable PDF to
apply OCR to file that have been sent

or import an image file with OCR. You may
want to switch this option off when you are
scanning/importing multiple files in a batch.

to DEVONthink from a known scanning

Note: Information you enter in this dialog

software, e.g., ScanSnap Home. Choose

will be available to Spotlight and can

the desired format of the resulting file:

be changed in the Preview application.

searchable PDF, RTF document, Word

The title field will be used to name the

document, or WebArchive.

document, the keywords will go into the
Comments field, and the creation date will

ORIGINAL DOCUMENT
Check Move to Trash if you want DEVONthink
to move the original documents to the trash
after they have been successfully imported

become the creation date of the document
in DEVONthink. You can access this
information in the Document Properties
panel.

using OCR. If files are converted by OCR

Check Compress PDF to apply compression

within the database, the original document

to the resulting PDF, creating a smaller

is deleted from the database. If files are

file. Compression only applies when

converted at import, the original document is

adding metadata post-OCR or preserving

moved to the Finder's trash. Using this option

annotations from an original PDF after OCR.

is a great way to prevent your incoming
group/folder or database from growing
cluttered after OCR is done.

RESOLUTION
Set the desired resolution for the image layer

Note: This option cannot delete files

in the PDF. Only values between 150 and 300

received from the ScanSnap software.

dpi are allowed.

SEARCHABLE PDF

AUTO CORRECT

Check Enter metadata after text recognition

Check Deskew to allow DEVONthink to

to metadata entry dialog whenever a PDF is

attempt to straighten the resulting PDF.

imported using OCR. Use this dialog window
to enter the preferred document name, the

Check Page Orientation to allow DEVONthink
to detect and correct the page orientation.
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DICTIONARY AND LANGUAGES

IMPRINTER

Custom Dictionary: Check Use Dictionary to
use a custom dictionary of acceptable words.
For example, you may have an unusual spelling
of someone's name in some documents. You
can enter the name as an acceptable choice
for the OCR engine to choose from.
Click the Configure button to add custom
entries for OCR detection. Note you can
only have one dictionary, specified for the
language chosen in the Language dropdown.
Languages: The Languages section of the
OCR preferences lets you identify the
languages of the documents you scan
in. DEVONthink's OCR engines uses this
information to improve the accuracy of
the text recognition. DEVONthink comes
with more than 150 different language

Imprints are custom bits of data that can be
stamped onto images or the pages of PDF
documents. Imprints can be used in a variety
of ways, from stamping when an invoice was
paid to adding specialized numbering. With
the ability to include placeholders, you can
create many kinds of watermarks for your
documents.

dictionaries.
CONFIGURATIONS
Select the languages you intend to scan or
import with OCR. Set a primary language
and add one or more secondary languages
using the pop-up menu . Simply select the
languages you want to use from the list
on the right (Available) and move them to
the left side (Selected) using the right-toleft arrow button. To deactivate a selected

This column lists any custom imprints
you've already created. Click an existing
configuration to change its appearance or
location on future documents, or click and
release to change the name. Use the buttons
below the Configurations column for extra
options:

secondary language, select it from the list

Add: Click the + to create and name a new

on the left and move it to the right using the

custom field.

arrow button. You can select a maximum of

Action: Select any field and click

four secondary languages.

more options, including duplicating,

Note: The primary language and the
secondary languages are treated equally.

for

renaming, and deleting the selected
configuration. A special item in the menu,
New Combined Configuration is discussed
below.
Preview: Click this button to see an
example of the imprint, as specified by the
current settings.
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New Combined Configuration: Found in

can be reordered easily by dragging and

the

dropping.

action menu, this option allows you

to create new imprints from your existing

Font: In the Font options, choose the

ones. This extends the usefulness of existing

font, weight, color, and other styling for

imprints.

the watermark. If you choose the outline

From the action menu, select the New
Combined Configuration option. Two panes
will be displayed: Combined and a second
Configurations pane. In the righthand pane,
select an existing configuration and click
the < button to add it to the Combined pane
in the center. To remove an item from the

style, you can choose the Thickness of the
outline.
Border Style: Choose and style a predefined border, if desired. When using a
border, you can also specify the border
Color and Thickness and an optional Fill
color.

Combined pane, select it and press the >

Note: There is only one font style for the

button. It will reappear in the Configurations

watermark. You cannot have mixed styles,

pane on the right. Combined items will be

e.g., displaying one word larger or in a

displayed in the order you add them. To see

different color.

what the imprint looks like, press the Preview
button.

LOCATION

Note: DEVONthink remembers the location

In the Location tab, choose and fine-tune the

and styling of the individual imprints in a

position of the watermark, as well as on what

combined configuration.

pages it will appear.

GENERAL OPTIONS

Position: Choose a general position for the
imprint to appear on the document.

Check Duplicate item before imprinting to

Offset X/Y: Fine-tune the position of the

duplicate the document before imprinting it.

watermark. Negative values are to the left
(X) and down (Y). Positive values are to the

APPEARANCE
Use these controls to define the parts of the
watermark, its font attributes, and the style
of a containing box, if desired.
Title: This is the body of the imprint. Type

right (X) and up (Y).
Rotate: Set your imprint on an angle, if
desired.
Occurrence: Choose what pages the
imprint should appear on. Use Custom to
have the imprint appear on specific pages.

any static text you want to appear in the
imprint. Right-click > Insert Placeholder
to define sections of the watermark with
placeholders. Any of these items can be
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SERVER

To learn more about using web sharing and
how best to make your database available
from the "outside" internet, please read on
here.

GENERAL
Start on Launch: To automatically start
DEVONthink's web server as soon as you
launch DEVONthink, check this checkbox.
Convert images & PDF documents
to searchable PDF: Check this to
automatically convert all images and nonDEVONthink features a built-in web server

OCRed PDF documents added from web

that allows you to share documents on your

sharing users to searchable PDFs.

local area network, and optionally, over the
internet. As soon as the web server starts,
other users can use a standard web browser
to search your database, view documents,
and download them.

BONJOUR SETTINGS
Use these settings to define your
DEVONthink server's identity, everything
from the name and port, to creating a

Note: In order to operate properly,

certificate vouching for the "safety" of the

DEVONthink needs to be running and will

server's activity.

only serve open databases.
Enter all necessary details in the General tab
and define users and permissions in the Users
tab. Then click the Start button to start the
web server available to users whom you have
allowed access.

Identity:
Bonjour Name: Enter a distinct name for
your computer here that identifies it on
the local network using Bonjour. This name
will be shown in the list of Bonjour services
on other Macs on your network. Switch

As soon as the server starts, DEVONthink

to the Bookmarks view in Safari or your

shows the name and two URLs for your

preferred browser and select Bonjour in the

database at the bottom of the window.

sidebar.

Use either the Bonjour services list of the

Bonjour Domain: Set the Bonjour domain

Bookmarks view in Safari or enter the listed

if necessary. Leave this field empty unless

URLs into the address field of your web

you know what you're doing.

browser to access your database. Use the

Port: If left empty, DEVONthink will assign

numeric address if the Bonjour does not work

a random, unused port when the server

for your network.

launches. If the server will be accessed
regularly, or from outside your network,
setting a static port is suggested. As nonDEVONthink 3.7 Documentation, page 169

standard ports can be prohibited on some

USERS

networks, consult with your IT department.
Security:
TLS Certificate: If you have a TLS
Certificate, select it from this dropdown.
P12 Certificate: If you have been issued a
P12 file, import it by clicking the Load P12
file button.
Self-signed Certificate: If you have neither,
it's possible to generate a self-signed
certificate for the server. When this option
is chosen, users connecting to the server
will be prompted the certificate may be
insecure. Instruct them to accept your
certificate as valid to allow their browser to

User List: The Users tab on the left allows you
to add and remove individual users, as well as
set per database permissions for them.

accept your server's identity.

Add: Click the + button to add a new user.

Allow insecure HTTP connection on

Remove: Click the - button to remove a

port: DEVONthink's server runs on SSL

user.

connections for secure browsing. If you

Password: Enter a login password for the

have a compelling reason to use the older

selected user in the Password field under

http protocol, check this box and enter the

the Databases list.

port to be used.
Note: If you have DEVONagent Pro
Note: When using the server in

installed, it will be added as a default user.

administered networks, e.g., public,

This allows it to search DEVONthink's

corporate, or educational scenarios,

databases in the same way it searches

you may need to consult with the IT

other websites.

department for successful operation.
Database Permissions: The Databases list
on the right allows you to set per-database
permissions for the selected user. All open
databases will be listed in this pane, followed
by the permissions that can be set. When a
user is selected in the Users pane, you can
set specific permissions for that user. The
permissions are as follows:

DEVONthink 3.7 Documentation, page 170

Read: Allow the user to access the

SYNC

database. When unchecked the database
will not be visible to the user.
Download: Allow the user to download
documents from the database.
Add: Allow the user to add items to the
database.
Organize: Allow the user to move around
documents and groups in the database.
Delete: Allow the user to delete items in
the database.
Note: Right-click the database's name to
quickly enable or disable all permissions for
that database.
Technical Info: If you need more information
on the activity of the web server, you can find
some deeper details here.

DEVONthink allows you to keep your
databases in sync with multiple Macs and
iOS devices running DEVONthink To Go. Use
these options to control which databases are
synced, how often they're synced, with which

Server Details: The section under the

locations. Learn more about synchronization

Databases pane shows some basic

and how to set it up in a separate part of this

technical data about DEVONthink's server

documentation.

activity.
Log: In cases where deeper technical
information about the server's activities is
required, click the Log button in the lower
right corner. The log file will open in macOS'
Console application.

LOCATIONS
The first column lists all sync locations you
have set up. In addition it lists available
direct connections and templates for quickly
setting up new locations. Active locations
are checked. Disabled, inaccessible, or
unactivated locations are shown in grey.
Locations that have an encryption key
specified show a key icon to the right of the
name.
Check any location to activate it. If it is
not yet set up, DEVONthink will show a
sheet requesting all necessary details. Only
a subset of the following fields is shown,
depending on the nature of the sync location:
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URL: The URL of your WebDAV volume

synchronized. This is generally only used in

including path to the folder where the sync

special circumstances.

store is located or shall be created.

Verify uploaded items: Check to verify all

User name: The user name for the service.

uploaded items to make sure that they're

Password: The password for the service.

intact. Usually only necessary on very

Sync Store Name: The name of the sync

unstable network connections or in case

store. If you are setting up an already

you experience troubles with defective

active sync location, e.g., you've already

files.

synced from another device, click the
dropdown menu to choose from a list of
existing stores.

Use the tools below the locations list for
more options:

Encryption password: The password used

Add Location: Click the + icon to add

to encrypt the sync store with AES 256 bit

locations not listed by default, e.g., adding

encryption.

another local sync store.

Synchronize label names & colors: Check

Remove Location: Select a location and

if you want to bidirectionally synchronize

click - to remove the location.

label names and colors using this location.

Show Info: Select a location and click to

Be aware, changes to the colors and names

show and change the location properties.

on any syncing machine will sync to the
others.
Synchronize reading positions: Check if
you want to bidirectionally synchronize
reading and playback positions using this
location. This can help you keep your place
in PDFs you're reading or audio/video you're

Action (Locations): The Locations
Action menu also is used for information,
troubleshooting, and removing chosen sync
locations. In addition to Show Info, and
Remove Location, it contains these special
commands:

playing.

Reveal in Finder: Opens a Finder window

Synchronize custom metadata definitions:

with the chosen sync store selected. This

Check if you want to sync any custom

only applies to local sync stores.

definitions found in the Preferences > Data

Verify Location: Used in troubleshooting

of the higher editions of DEVONthink and

situations, this quickly verifies the integrity

actively used on items in your databases.

of the sync data of the chosen sync

If you are collaboratively syncing, you may

location. Hold the ⌥ key to select Verify

want to disable this option to avoid the

Location Thoroughly.

other party from receiving your specific

Clean Location: Used in troubleshooting

metadata definitions.

situations, this removes the sync data for

Synchronize content of indexed files:

all databases synced to the chosen sync

Check if you want to synchronize the

location.

content of indexed files using this location.
If you uncheck this option only the

All the commands listed above are also

metadata about the document will be

available via the contextual menu.
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Note: You can also add existing local

you can double-click a remote database to

sync stores (packages with the file name

import it.

extension .dtCloud) by dragging them into

Synchronize Database: Select a checked

the locations list, DEVONthink's Dock icon,

database and click

or by simply double-clicking them.

database with this location.

to manually sync the

Refresh List: Refreshes the list of remote
DATABASES

databases for the selected location.

The second column lists all currently open

Action (Databases): The Databases Action

databases as well as all databases available

menu also contains commands for importing,

remotely in the selected location. The

manually synchronzing, troubleshooting, and

Local section lists all open database and a

removing sync data. In addition to Import

message about their sync status, e.g, the

Database, Synchronize Database, and Refresh

timestamp of the last sync. The Remote

List, it also contains these commands:

section lists all databases available for import
or databases that are currently not open on
the machine. When attempting to import the
latter, the local database will be opened by
DEVONthink.

Import Encrypted Database: Import a
database as an encrypted database. You
will need to specify the maximum database
size and an encryption key. See also p. 11ff
This option can be used when importing

Check any database that you want to have

any database, but it will not encrypt an

synchronized using the selected location. If

unencrypted database on the source.

the database is also already available through

Verify Database: Used in troubleshooting

the location, both versions of the database

situations, this quickly verifies the integrity

will be merged and conflicts solved using the

of the sync data of the chosen database.

chosen conflict solving strategy (see below).

Hold the ⌥ key to select Verify Database

Uncheck databases you want to discontinue

Thoroughly.

syncing with the selected location.

Clean Database: Used in troubleshooting

Note: Unchecking databases does not
remove the sync data from the location.
See the Clean Database command below or
See also p. 178ff

the chosen database in the current sync
location.
All the commands listed above are also

Use the tools below the locations list for
more options:

available via the contextual menu.
Note: If you have specific databases you'd

Import Database: Select a remote
database and click

situations, this removes the sync data for

to download the data

of the database and save it locally. The
database will be automatically configured

like to remove from a sync location, e.g.,
old, no longer used or test databases, the
Clean Database command can be used on
select databases in the Remote section of
the Databases list.

to sync with this location. Alternatively,
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OPTIONS

BONJOUR OPTIONS

Change the general sync settings, noting they
affect all locations and databases.
Synchronize: Choose if you want to
synchronize automatically, manually,
or in fixed intervals. Check On Quit or
Deactivation to automatically synchronize
when you quit DEVONthink or when you
switch to another application.
Max. Connections: Choose the maximum

Click the button Bonjour Options to control

number of connections DEVONthink

if and how other instances of DEVONthink or

should open. The faster your internet

DEVONthink To Go can connect to your Mac.

connection the higher you can usually go.

Your Mac becomes the sync host or sync

The recommended value is 16.

server, the other devices the clients.

Conflicts: Choose how to solve the conflict
if an item was changed both locally and
remotely. Use latest document preserves
the most recently changed document.
Duplicate documents keeps both versions
of the conflicting item and appends "copy"
to the end of one's filename.

Enable incoming connections: Check to
let other devices connect to your copy of
DEVONthink and synchronize.
Open databases automatically: Check
to open databases automatically if the
connecting side (client) requests it.
Port: If needed you can change the IP port

Note: The number of maximum

number used for incoming connections.

connections used is controlled by the

Leave empty to let DEVONthink choose the

service you're using.

best port number for you (recommended).
Password: Set the password necessary to
connect to your instance of DEVONthink
(mandatory). This password is also used for
AES-256-bit-encrypting the connection at
all times.
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TROUBLESHOOTING
IN THIS CHAPTER

Also, while DEVONthink supports importing

Problems importing files

175

Email import does not work as

many different file types, there are
thousands of types and we can't guarantee
trouble-free importing or usefulness with

expected

176

Unlocking a database

177

Problems using Services

177

Sync Issues

178

Repairing a defective database

182

DEVONthink crashes

185

DEVONthink uses Apple's Quick Look

DEVONthink behaves irrationally

185

technology to display previews of many

DEVONthink was created with robustness
in mind. But any computer hardware or
software, regardless of how carefully
developed and built, can write defective data
or destroy files. If you have some general
questions about DEVONthink, sales and
licensing, etc., plase check out our Questions
and Answers section on our site. If you
experience specific technical problems with
DEVONthink or its databases, please check
the following sections.

every type.

WHY DOES DEVONTHINK NOT DISPLAY MY
DOCUMENT CORRECTLY?

file formats. If a document is not properly
displayed, especially if it is a proprietary file
format, it may be you don't have a Quick
Look plugin installed for this file type or
the application that created the file is not
installed on your Mac (and supports Quick
Look). Control-click the file and choose Show
In Finder to reveal it. With the file selected
in the Finder, press the spacebar to open a
Quick Look window to determine if the item
is viewable.

WHY ISN'T MY PDF WORKING?

PROBLEMS IMPORTING FILES
Bad PDFs: PDFs have been around so long,
WHY DOES DEVONTHINK NOT RECOGNIZE

it would seem they'd be easily supported in

MY FILES?

DEVONthink. However, the truth is there are
many bad PDFs out there. If you encounter a

If DEVONthink does not recognize a file, make

bad PDF, try acquiring a new copy of the file.

sure the file has a proper file name extension.
DEVONthink needs a file name extension to

No Text: You will receive a "No Text" log

determine the file type. Add the correct file

message with PDFs having no text layer, i.e.,,

name extension to your files (e.g., .txt for

scans that have not had OCR run on them.

plain text files, .rtf for rich text files, .pdf
for PDFs and .doc for Microsoft Word files)

In order for their text to be searchable, you
must run OCR on them.

and try again.
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Protected PDFs: DEVONthink cannot extract

Importing takes a long time or stalls:

the text part of print- or edit-protected

Importing email is not a trivial process. Not

PDFs. When you import these PDFs, you get a

only does it copy the message into your

log entry that tells you that the file contains

database, but it also reads and analyzes

"no text". When you select these PDFs in

the entire contents of each one. If you are

DEVONthink, the status bar shows Image

importing a large mailbox, the process could

instead of PDF+text.

cause a timeout.

One potential solution for this problem is

To increase the timeout to five minutes,

Michele Balistreri's PDFKey. It allows you to

please enter this in /Applications/

print protected PDFs. Use PDFKey to "print" a

Utilities/Terminal.app (each as a

PDF file into a new PDF that is both printable

separate command) while DEVONthink is not

and editable, which allows DEVONthink to

running:

extract the text for searching and classifying.
Note: There are sometimes questions
regarding the PDF functionality available
in other applications. DEVONthink uses
Apple's PDFKit framework, the same as
found in their Preview application. If you
have an issue with a PDF in DEVONthink,
check to see if you have the same issue

Terminal:
$ defaults write com.devontechnologies.think3
MailImport.FetchTimeout -float 300
$ defaults write com.devontechnologies.think3 MailImport.Timeout float 300

in Preview. Other applications, including

Another possibility is to split the mailbox

those from Adobe where PDFs were

into multiple smaller ones. Lastly, you don't

invented, are using their own frameworks.

have to import the entire mailbox at once.
Importing smaller batches often proves to be

EMAIL IMPORT DOES NOT
WORK AS EXPECTED
Messages aren't imported or can't be filed:
Email messages are imported with a special
identifier (UUID) that helps DEVONthink
keep track of messages that have already
been imported. Since a UUID must be unique,
you can't have more than one file with that
identifier. If you try to import the same
message into a database, you will receive
a logged message stating "n emails already
imported".

less taxing on the machine's resources.
Why can't I import from email application
X?: Inter-application communication,
something at which DEVONthink excels, isn't
universally developed. In order for more true
automation between applications to occur,
the developers need to implement robust
and reliable mechanisms, like AppleScript.
Some apps may provide simple URL schemes
but they are limited in use and capabilities,
often only able to process one file at a time.
Better results can usually be had by merely
dragging and dropping. For email clients with
a good AppleScript dictionary, the potential
for streamlined workflows is increased.
DEVONthink 3.7 Documentation, page 176

Note: If you are running macOS Mojave or

other databases, do a Spotlight search for

later, you will need to give permissions for

kind:database dtBase2.

the Apple Mail plugin to access your email.

Select the database file and press ⌘I to

Quit DEVONthink.

show the Info pane.

Quit Apple Mail.

At the bottom, you'll see Sharing &

Enable Full disk access in System

Permissions. Click the lock icon to unlock

Preferences > Security > Privacy for

it. You will be prompted to enter your

DEVONthink.

administrative password. (This is the

Launch DEVONthink and install (or

password you use to log into your account

reinstall) the Mail plugin from the

on your Mac.)

DEVONthink > Install Add-Ons.

Make sure the account marked (Me) is set

Launch Apple Mail and enable the plugin

to Read & Write.

via Apple Mail > Preferences > General >

Click the Action menu and choose Apply to

Manage Plug-ins.

enclosed items, if it is available, then close
the Info pane.

UNLOCKING A DATABASE

Double-click the database file to reopen it
in DEVONthink.

If you open DEVONthink and see an icon of a
crossed pencil to the right of the database's

If this does not resolve the issue, please

name, the database has a file permissions

contact our support team.

issue. This makes the database readable,
but not writeable, so you can't modify the

PROBLEMS USING SERVICES

contents in any way.
A permissions issue like this uncommon
but generally caused by three events, in

WHY DO THE SERVICES MENU COMMANDS
SHOW NO SHORTCUTS?

order from most to least common: restoring

They should; however, the keyboard shortcuts

from Apple's Migration Assistant, restoring

for Services menu commands are only

from Time Machine, or an operating system

requested by the supplying application.

or hardware error. Doing things like using

macOS assigns these shortcuts and has

Migration Assistant will not always cause a

ultimate control over which application

permissions issue, but if you have a crossed

or service gets what. If the DEVONthink

pencil icon and you've recently migrated to a

Services menu items do not have shortcuts

new machine, this would be the likely cause.

assigned, it is likely that macOS assigned

To resolve the issue, do this:
Close the database in DEVONthink.

these shortcuts to another command, or
that they are used by the current active
application.

Locate your database. If it's the Global
Inbox, it's located in ~/Library/
Application Support/DEVONthink 3. For
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WHY DO SPECIFIC SERVICES NOT APPEAR

a remote service, the Sync Store Name

IN THE MENU?

dropdown should list available sync stores

The operating system relies on information
supplied by the current application to
determine which services should be shown
in the Services menu. For some applications,
often those developed for both Mac and
Windows, this information may not be
what's anticipated. When this occurs, certain
services may not be present. For example,
selecting text on a web page in Firefox will

to choose from.
Make sure you're using the correct
encryption key value for the sync location.
See also p. 181ff
Make sure you have sufficient space for
sync data, especially when using cloud
accounts.

VERIFY & CLEAN

display the service DEVONthink: Take Plain

Verifying: If there is an issue reported with

Note. The same text on the same page

syncing, e.g., broken structures or missing

in Safari will show that option as well as

manifests, you can verify the sync data to

DEVONthink: Take Rich Note.

see if it's intact and consistent. Verification
is a good first step in these cases. The results

SYNC ISSUES

of a verification will be reported in the log
window.

DEVONthink's synchronization was designed
to run in self-maintenance mode. If you are

Cleaning: If the verification fails, you can

having issues syncing your DEVONthink

clean the sync location or database to

databases, the first place to look is Windows

remove the sync data in that location. The

> Log. Most sync related errors and reports

results of the clean will be reported in the

will be shown here.

Log window. After a successful clean, you can
upload the database(s) again.

Below we cover some things you can check
for the type of sync method you're using as

Note: To ease anyones' mind, cleaning a

well as some common questions you may

sync location has no effect on the local

have.

databases on your devices. Sync data is
not your database and is separate from the

THINGS TO TRY FIRST

local databases on your devices, Mac and
mobile.

Here are a few general things to try when you
have a sync issue:

To verify or clean sync data, open Preferences
> Sync and…

Check your network connections, including
trying to log into a remote service.

Sync Location: To clean or verify all

Reboot the computer

the sync data from a specific location,

For non-Bonjour and non-iCloud sync

Control-click it and choose the appropriate

locations, make sure you're entering the

command. For a verification you can

correct store name. When logged into

hold the ⌥ Option key and choose Verify
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Location Thoroughly to perform a deeper

Make sure you have entered the same

verification of the sync data. For a remote

password that you have set in the server

sync location, there may be a pause while a

Mac's Bonjour options. See also p. 171ff

connection is established.

Make sure DEVONthink is running on the

Database: To clean or verify the sync data

other Mac or iOS device and both devices

for a specific database, select the sync

are awake.

location to display the databases list.

Make sure only one device is acting as the

Control-click the specific database and

Bonjour server for a given database. You

choose the appropriate command. For a

should not have two devices with incoming

verification you can hold the ⌥ Option key

connections enabled trying to serve the

and choose Verify Database Thoroughly to

same databases.

perform a deeper verification of the sync

Make sure the databases you want to

data. Repeat this with any databases, as

synchronize are open on the other Mac,

needed.

or enable Preferences > Sync > Bonjour

Both these actions can be used at any time,
for preventative purposes or just to get a
fresh start with syncing. Also, you may see
unwanted databases in the Remote section
of the databases list for a sync location.
Cleaning the location will remove these
databases too. But if you want to keep the
sync data for your current databases, you can
Control-click and clean specific databases in
the Remote section.

BONJOUR

Options: Open databases automatically on
the server Mac.
Restart the other Mac, the iOS device, or
both.
Make sure this computer is connected to
the same network as the other syncing
device.
Make sure any firewalls or applications
like Little Snitch are allowing traffic from
DEVONthink.
Check if there are any routers or switches
involved. The more switches and routers
the less reliable the connection due to

Bonjour syncs are generally transparent,

port filtering, conflicts, or other unknown

but it can only be used on a local network

factors.

that allows Bonjour traffic and non-standard

Restart your router.

ports. Many public networks disallow this
kind of traffic to protect their customers.
Also, corporate networks will often disallow
this traffic for security reasons.

If you find yourself on a network that
disallows Bonjour syncing, it is possible to
connect your iOS device to your Mac via your
Lightning cable. This creates a simple ad-

Note: Bonjour connections cannot be used

hoc network that will allow Mac-to-mobile

over VPN. This is technologically infeasible,

syncing. If you are in a corporate situation,

at least at the moment.

please discuss this with your IT department
to ensure you're not violating any security
policies. They may also issue an exception
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for a specific port you could use for Bonjour
syncing. This port would be entered in the
Port section of the Bonjour options.

ICLOUD

WEBDAV
Our support for WebDAV services allows
you to use cloud services that are WebDAVenabled. It also presents some self-hosting
options, even with some NAS devices.

Since your devices are generally signed into

However, they can sometimes be technically

your Apple ID, using iCloud for syncing is

more difficult to implement. Here are some

the easiest to set up. However, it should be

things to check:

understood it can only be used for personal
syncing. Collaborative syncing is not possible
unless all participants are sharing an Apple ID.

Make sure the service or device you're
trying to connect to is reachable. This is
especially true when self-hosting. If you see

Also, syncing to iCloud is done locally first,

errors in the 500 range in the Log window,

the operating system will then upload the

it's a problem with the remote server.

changes to Apple's servers and propagate

Make sure you are using the proper

the information about it to all other devices.

protocol in the URL, http:// or https://.

It generally happens smoothly and in the

Make sure the URL is complete. This will

background but it means you can't expect the

be specific to the device or service you're

changes to be ready on other devices as soon

using. For a Synology NAS, for example,

as DEVONthink has finished synchronizing to

you have to add the target volume to

iCloud.

the path (a valid URL would look like:

Here are a few things to check:

http://diskstation.local:5005/
research). Refer to the service or

Make sure you have enabled DEVONthink in

manufacturer's instructions for the proper

System Preferences > iCloud > iCloud Drive

URL construction.

> Options on each device.

Make sure you have entered your user

Make sure all syncing devices are logged

credentials correctly.

into the same Apple ID.

Note: WebDAV implementations vary so

Note: Be aware iCloud can stall. This is a

it's not possible to guarantee compatibility

sporadic, but documented, issue that can

in all situations. For self-hosting, Apache

cause your devices to get out of sync. This

implementations are the most compatible.

is not under our control, nor can we even
detect it. Please try a thorough verification
of the sync location first. For further help,
contact our support staff for assistance.

DROPBOX
Dropbox is our longest supported sync
method and is generally reliable and a good
performer. However, there are a few things to
consider.

DEVONthink 3.7 Documentation, page 180

According to Dropbox' rules, you cannot sync

a key, is stored for that sync location. This

across user accounts. You also can't share

value must be entered on other devices

the Apps folder between accounts. Also, they

syncing with this sync location.

only allow our sync engine to be logged into
one Dropbox account at a time. If you have
a work and a personal account, you can only
sync to one with DEVONthink.

You can't add, remove, or modify the
encryption key value for a sync location
after the first sync. If you want to make a
change, you must clean the sync location

Log into your Dropbox account to make

first. After, the clean, Control-click the sync

sure it's reachable. If you see errors in

location again, choose Show Info, and make

the 500 range in the Log window, it is a

the modification to the key. After the first

problem with the remote server.

sync, this will be the value stored for the

Make sure you are connected to the correct

location. Remember, you must change the

Dropbox account. The active account will

value on the other syncing devices. And no,

be shown under the sync location's name in

you do not need to do the clean on the other

the sync preferences.

devices before changing the value.

Collaborative syncing may be possible using

I am seeing a message about missing

a common Dropbox account, i.e., using the

manifests: Missing manifests are bits of

same username and password for syncing.

transactional sync data that cannot be

But again, you can only sync to one active

located by the sync engine. When this occurs,

Dropbox account at a time.

it can't validate the information about what
has been synced. This is not an issue with the

COMMON QUESTIONS
I enabled the sync and nothing's happening:
Our sync engine will not sync, upload or

databases. See the Verify & Clean section
above regarding verifying and cleaning the
sync data.

download, without being told to. We believe

It's telling me I have a duplicate database

in opt-in processes whenever possible.

UUID: As noted in the glossary, a UUID is

Merely enabling a sync location just sets up a

a unique value given to all DEVONthink

location to be ready to receive and transmit

databases. If you copy and rename a

data. You need to enable individual databases

database file in the Finder, this UUID is

to sync. If you have enabled databases to

preserved and DEVONthink sees two

sync, check Window > Log for errors.

databases with the same UUID. This will not

I'm seeing a message about an invalid
encryption key: When you set up a sync

sync correctly. Please contact our support
team for assistance on resolving this.

location, you have the option of entering an
encryption key. This is used to scramble and
descramble the sync data so it's stored in an
encrypted state. Once you've synced the first
time, this value, even if you aren't specifying
DEVONthink 3.7 Documentation, page 181

REPAIRING A DEFECTIVE
DATABASE
DEVONthink databases are packages

case, the path no longer exists as the names
in the path have changed. Changing the name
back will resolve this.

containing of your files and the supporting

The second most common cause of missing

AI-based index. In rare cases this index can

files is people modifying the internal contents

get corrupted or out-of-sync. But as your

of a database. Some Finder replacement

files are stored separately, this is not the

applications, like PathFinder, allow you to

end of the world. If your database starts

access package files like normal folders.

behaving strangely, or if DEVONthink finds

The internals can also be accessed by other

inconsistencies during start-up, it is time for

methods, like the command line or the

some housekeeping.

Finder's contextual menu. If you delete or

First we'll deal with the two common terms
you'll see in a repair process: missing and

reorganize anything, you can easily cause
missing files.

orphaned files. Then we'll give you steps to

Dealing with missing files: Missing files are

try and restore some order in your databases.

reported in DEVONthink's Window > Log. To
deal with these files, Control-click the item

MISSING FILES

in the Log window and choose one of two
options:
Reveal: Reveals the item in the expected
location in the database. If the View/Edit
pane is visible, the expected file path is
shown beneath a document thumbnail.
This path is especially useful when dealing

All documents in a DEVONthink database
have a path the file system where their
content file is located. This path is stored
for every document, imported or indexed. If
DEVONthink can't find a file at a path stored
in its index, it will be reported as missing.

with missing indexed files as it shows the
path in the Finder from which the file was
indexed. If the path shows the file inside
a Files.noindex directory, you may use the
following option if the file is of no concern
or contact our support team.
Move to Trash: If the missing file is of no

The most common cause of missing files is

value to you, this command moves the

indexed files being moved in the Finder, or

file to the database's Trash. Then choose

the indexed parent folder being renamed. In

the DEVONthink > Empty Trash command

the first case, the file isn't in the location it

to completely remove the file from the

was indexed from. Moving the file back into

database.

place will resolve this issue. In the second
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ORPHANED FILES
Just as with any database application,
controlling the data flow in and out is a
critical process. DEVONthink should be the
gatekeeper of the files in its databases. If an
external agent, whether and application or
a user, adds files outside DEVONthink, they
will cause an internal inconsistency and lead

Note: Modifying the internal contents
of a database outside DEVONthink is
unsupported behavior and can lead to
broken or inconsistent databases. You
should only get into a database's internals
when instructed to by our support team.

STEP 1: VERIFY & REPAIR

to orphaned files when following the steps

As a first step, use >File > Verify & Repair

below.

Database to check your database's

The most common cause of orphaned files
is a simple and common one: attempting to
create revisions. Say you open a file, a Word
document, in an external application. As
you are reading it, you decide to make some
changes. You type your edits, and select File
> Save As (or File > Duplicate the file first).
The application most commonly will open
the Save dialog in the location of the original

consistency and allow DEVONthink to take
all necessary steps to repair any discovered
problems. This check will include reporting
any missing files, as discussed above, and
importing any orphaned files. If Verify &
Repair Database was able to repair your
database, use File > Optimize to optimize
your database and have DEVONthink create
an internal copy of the index.

file, in this case, inside the internals of the

Note: Verify & Repair isn't just for

database. You have just created an orphaned

emergencies. Running this command on an

file DEVONthink knows nothing about. So the

occasional basis is not a bad idea. In fact,

question becomes, how do I create a revision

if you're a fairly heavy user of DEVONthink,

without causing this issue?

running it weekly or bi-weekly does no

Duplicate: Duplicate the item in

harm. It's just a routine checkup.
DEVONthink first.

If Verify & Repair was not successful or your

Rename: Rename the duplicated item.

problems are not resolved, proceed with the

This can be quickly done by immediately

next step.

pressing ↩ Return, typing the change, then
pressing ↩ again.
Open and Edit: Now you can open the new
file and make your edits.
The other common cause is the same as
with missing files: getting into the database
package and adding files manually.

STEP 2: RESTORE FROM BACKUP
DEVONthink keeps up to two copies of the
index files in case that the index is damaged
beyond repair.
To restore the index file(s) from a previously
saved internal backup, hold the ⌥ Option key
and select File > Restore Backup. DEVONthink
presents you with a list of all available
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backups. Choose the latest one and click

Time Machine: Restore your database from

Open. This swaps the current set of index

your Time Machine backup or whichever

files with the chosen backup metadata

backup medium you use. If you don't use

(the current set of index files becomes the

Time Machine, we strongly advise you to do

backup, the backup becomes the current set)

so. External hard disks are cheap, and Time

so that data is never overwritten. Run File >

Machine makes backing up your important

Verify & Repair to check the consistency of

files quick and simple.

this index version and if everything is in the
right order use File > Optimize to optimize
your database and have DEVONthink create a
fresh internal copy of the good index.
If the backed-up index files are also defective,
try the other backups, if available. If all
backups are broken or corrupted, proceed
with the next step.

STEP 3: REBUILD YOUR DATABASE

Manual Rebuild: If you find yourself in the
unfortunate situation where you have no
backups, it may be possible to rebuild your
database manually, following these steps:
Locate the database (.dtBase2 file) in the
Finder.
Rename the file by adding, e.g., an xto the
beginning of the name.
Control-click the database and choose
Show Package Contents in the contextual

Since your files and DEVONthink's index

menu.

are stored independently within the

Copy the most recent backup folder where

database package, the index can be rebuilt

your database is located.

at any time without you losing metadata.

Copy the Files.noindex folder into the

However, we generally only suggest this when

copied Backup folder.

troubleshooting a database issue.

Rename the copied Backup folder to the

To rebuild the database from scratch, use
File > Rebuild Database. During the rebuild
process, the index is completely recreated.
Your actual files are not touched. Any
problems that occur during this process are
logged. Also, a new backup metadata set will
be created at the beginning of the rebuild.

STEP 4: RECOVER OR MANUAL REBUILD
If everything above failed, your database is
severely damaged. You have basically two
options:

previously used name and add the file
extension .dtBase2, okaying the extension
when prompted.
Double-click the new database file to open
it in DEVONthink.
Use File > Verify & Repair to ensure that the
database is operating properly.

STEP 5: CONTACT SUPPORT
If none of the above steps helped solving
the problems you have with your database,
please contact us with a precise-as-possible
description of your problem.
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Note: In a worst case scenario, if you do not
have a current backup of your documents
and a manual rebuild didn't work, you can
rescue your files manually, but you will lose
any group structure. To manually copy your
files from the defective database, show the
database package in the Finder, Controlclick it, and choose Show package contents
from the contextual menu. Copy the files
in the Files.noindex subfolder, which are

DEVONTHINK BEHAVES
IRRATIONALLY
No software on this planet is bug-free, and
if an application behaves irrationally there
is a good chance that your have just found a
bug. But there could also be another cause:
The application package could have become
damaged during an update or through a bug
in a totally unrelated piece of software on
your computer.

sorted by kind, to a safe location, e.g., the
desktop. If you want, you can create a new

STRANGE APPLICATION BEHAVIOR

database, re-import the files, but you will
have to rebuild the database's structures,
tags, etc.

If you see odd behavior like
menus disappearing or silently refusing to
do anything,

DEVONTHINK CRASHES
If DEVONthink crashes while it's running,
please hold the ⌥ Option key and choose

windows showing graphical artifacts,
or applications not opening at all or
opening with strange error messages,

Help > Report Bug.

the first step is to reboot the machine.

If DEVONthink crashes on startup, there is no

If that doesn't resolve the issue, try deleting

opportunity for you to use our bug reporting

DEVONthink's preferences files. Please quit

mechanism. However, you can manually

DEVONthink, launch Terminal app, and enter

retrieve the crash logs:

this:

In the Finder, hold the ⌥ Option key and

Terminal:

select Go > Library.
Open the Logs/DiagnosticReports folder
and locate the most recent crash report for

$ defaults delete com.devontechnologies.think3

DEVONthink. (The date and time is in the

Note: Rebooting a machine can often

filename.)

cure a host of issues, closing down rogue

Attach the crash log when you start a

processes, releasing memory, etc. We

support ticket.

suggest rebooting your devices at least

In either case, please try to reproduce the
crash before reporting it. Also provide enough

once a week, just to mitigate potential
issues.

detail about what you were doing at the time
of the crash.
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STRANGE BEHAVIOR RELATED TO

If you have checked the appropriate sections

DOCUMENTS

and didn't find your issue or a resolution,

If the strange behavior only happens with
a particular document, it is possible the
document is damaged, was created in a very
old or extremely new file format that is no
longer or not yet properly supported, or uses

please do the following: Hold the ⌥ Option
key and choose Help > Report Bug. This
creates a draft email, ready to send to us,
containing troubleshooting information and
logs.

a damaged or malfunctioning Quick Look

Note: The industry standard turnaround

plugin.

in software development is 48 business

Please file a support ticket and attach
the document in question, packaged as
a .zip archive, so that we check to see if the

hours, i.e., weekends excluded. However,
we usually respond earlier. Thanks for your
patience and understanding.

problem lies with DEVONthink or if it the file
itself.
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AUTOMATION
IN THIS CHAPTER

extraordinary. This mature but easy to learn
technology is the one we will focus on. See

AppleScript

188

Basic AppleScript Terminology

189

Internal Scripts

192

Smart Rules: DEVONthink also offers

Triggered Scripts

192

a technology for those with little to no

Reminder Scripts

193

programming experience: smart rules. Smart

Toolbar Scripts

193

rules are conceptually similar to smart groups

Smart Templates

194

but allow you to choose pre-defined actions

Smart Rules

196

to take on matched items. This makes them

Smart Rule Scripts

197

accessible to all users, while still providing

Apple Mail Rules

199

AppleScript execution in the smart rules.

Application Scripts

200

Folder Actions

201

Automator

202

Item links

204

URL Commands

205

also p. 188ff

They also allow automation based on events.
See also p. 196ff
Item Links: While not an automation
technology in itself, item links are itemspecific identifiers in DEVONthink that can

Automation. No matter how efficient we

be used in automation. Providing a way to

are, there is always some process that could

refer to files by a unique and unchanging

be done more quickly, and sometimes more

value, they can help avoid automation

accurately. This may be as simple as renaming

problems when items are moved or renamed

a file, or as complex as filing, emailing, and

in your databases. See also p. 204ff

archiving. While not everything can be
automated, and careful thought should go
into your automation plans, DEVONthink
offers a level of automation capabilities rarely
rivaled in other Mac applications.

JavaScript: In addition to AppleScript,
JavaScript for Automation (JXA) is
supported. However, it is bridged by the
operating system from AppleScript,
not specifically coded for. We advocate

AppleScript: Most of DEVONthink is built

AppleScript for its ease of use by new and

on a solid foundation of AppleScript. Not

less-experienced programmers.

only used in the scripts you can install from
DEVONthink > Install Add-Ons, they are
also at the core of several pre-installed
templates. Additionally, in conjunction with
other AppleScript-enabled applications,
the potential for automation on your Mac is

On a side note, our AppleScript dictionary
has a do JavaScript command you can use
to interact with web content viewed in a
DEVONthink window. With a bit of creativity,
some pretty amazing things can be done!
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AppleScript Objective-C: This is supported,

by choosing DEVONthink > Install Add-Ons.

for those who are inclined that direction.

The scripts from this panel are installed in a

Terminal: For those who are into other

number of locations:
technologies, like Python, bash, Ruby, etc.,

Script Menu Extra Scripts: These scripts

the question arises: Is there a command line

are accessed from the global Script menu

interface (CLI) for DEVONthink? The answer

when you are in specific applications, e.g.,

is no. However, you can still use a do shell

Safari. They are installed in an application-

script command in AppleScript when needed.

specific subfolder of ~/Library/Scripts/

Actually, the combination of the shell and

Applications. See also p. 200ff

AppleScript creates even more opportunities,

Folder Action Scripts: These scripts are

as their individual strengths compensate for

used to created hot folders in the Finder.

the other's weaknesses.

They are installed in ~/Library/Scripts/
Folder Action Scripts. See also p.

APPLESCRIPT

201ff
Apple Mail Rule Scripts: These scripts

AppleScript is an automation technology

for use with Apple Mail Rules. They are

introduced by Apple in 1993. Over the years it

installed in ~/Library/Application

has matured and become the friend of many

Scripts/com.apple.mail. See also p.

Mac users wanting to exert more control over

199ff

their computing experience. Written in an
easy to learn, almost conversational language,

DEVONthink Scripts: The internal scripts

it offers a tremendous amount of power with

found in DEVONthink's Scripts menu are

less effort than many languages. DEVONthink

installed in ~/Library/Application

has very robust AppleScript support and

Scripts/com.devon-technologies.think3.

comes with many built-in scripts. These, and

The scripts will be found in one of four

those you write or obtain, make it possible

directories:

to automate nearly every aspect of the
application, and to integrate the application
with almost every other macOS application
that supports AppleScript.

Menu: These are the scripts found in
DEVONthink's Script menu. See also p.
192ff
Toolbar: These scripts are available to add
as toolbar buttons. See also p. 193ff

INSTALLATION

Reminders: These scripts will be executed

Add-On Scripts: All add-on scripts that

when a reminder is triggered with an alarm

come with DEVONthink are automatically

of Execute External Script. See also p.

installed or updated when you open a new

193ff

version of DEVONthink for the first time.

Smart Rules: These scripts are used as

You can, however, manually (re-)install them

External Scripts in the actions of smart
rules. See also p. 196ff
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Additional scripts, like those you write
yourself, can be put into any of these
folders to be used in these contexts. Other
scripts that may include integration with
DEVONthink can be located wherever it's
convenient.

SCRIPT SHORTCUTS

LEARNING APPLESCRIPT
While this documentation is not an
AppleScript language guide, all the scripts
that come with DEVONthink are editable
and can be explored or modified as you see
fit. The separate sections in this chapter
provide any required terminology and a
simple example script or two. Additionally,

Many people like mousing around their

there are some great resources available

applications, while others like to use their

online and in print. For the official archived

keyboards. If you want to add keyboard

documentation, refer to Apple's AppleScript

shortcuts to scripts in this menu, you have

web site. Some additional resources are listed

two options:

below:

System Preferences: Open System
Preferences > Keyboard > Shortcuts > App
Shortcuts. Add a shortcut for DEVONthink,
enter the exact name of the menu item,
and assign a hotkey.
Append Filename: Locate the script in
the Finder and append three underscores

Online:
DEVONtechnologies Community
MacScripter
AppleScript, the Language of Automation
TECsoft Hands-On Trainings
Books:

followed by abbreviated command keys and
characters. For example, eMail Current
URL___Cmd-Alt-F2.scpt. The command

AppleScript: The Missing Manual
AppleScript: The Definitive Guide

key abbreviations are as follows: Cmd
stands for the ⌘ Command, Alt or Opt for
the ⌥ Option, Ctrl for the ⌃ Control, and

BASIC APPLESCRIPT
TERMINOLOGY

Shift for the ⇧ Shift keys.

AppleScript is not a difficult language

Note: When using macOS Mojave, you

to learn. Its plain English approach of

will often be prompted by the operating

"talking" to applications and elements is

system to allow applications to "control" on

easily understandable. However, like any

another. These permissions are stored in

language, there are some variations in the

System Preferences > Security & Privacy >

words you can use; dialects, if you will.

Security > Automation. Please make sure to

AppleScript is implemented by the developer

allow any requests of these kind regarding

of an application, so the commands and

DEVONthink's control of other applications

parameters may be conceptually the

or your automation attempts will fail for

same as another application's, but using a

obvious reasons.

different term. This is certainly not meant
to be a complete guide to AppleScripting
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DEVONthink, but what follows are some

Note: The use of the is almost always

common terms or concepts you're likely to

optional, but including it can make the script

encounter. The examples here and in this

seem a bit less robotic. For example, both

chapter are meant to give you basic ideas

lines in this script are functionally the same:

about scripting DEVONthink.

TALKING TO DEVONTHINK

Example:
tell application id "DNtp"
set state of children of current group to

In AppleScript you "talk" to programs like

true

DEVONthink using a tell statement,

current group to true

typically referring to an application
either by its name, "DEVONthink 3",
or its bundle identifier, "com.devontechnologies.think3". While these forms
will work, they might become incompatible
with a future version, e.g., DEVONthink

set the state of the children of the
end tell

As noted above, the dictionary is the best
place to find specific terminology to be used
with DEVONthink. However, here are two
things to understand:

4, so we strongly recommend to talk to

Records: Every item in a DEVONthink

DEVONthink using the application ID DNtp,

database is a record, a record with

like in the following statement:

properties. Do a search for "record" in the

Example:

dictionary and you'll see it's a fundamental

tell application id "DNtp"

unit with a wide range of properties

close current database

associated with it. This means you won't be

end tell

writing code like, get the second rich
text file…. You will be dealing with records

DEVONTHINK'S DICTIONARY

with a particular type, in this case rtf.

AppleScript-capable applications have their

There are many commands specifically for

commands, elements, and properties listed

use with records: create record with,

in an AppleScript dictionary. DEVONthink

exists record with…, etc. Also note there

includes a large dictionary as a great

are some commands that require the term

reference for you. To view the dictionary,

record. For example: move, delete, and

open the Script Editor application, select File

convert. You will see a dictionary listing move

> Open Dictionary and choose DEVONthink

record, so you can see the command isn't

in the appearing window. You can also add

merely move, it's move record.

DEVONthink to your Script Editor library.
Select Window > Library, click the + button
and choose DEVONthink. This way you keep
DEVONthink's dictionary at hand.

Parents and Children: Another concept to
understand is parents & children. Generally
speaking, these classes deal with the
container or the contents of some object.
The parent of an object is the group
containing it. The children of a group are
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the immediate contents of that group, i.e.,

with a forward slash denoting the root of

it does not list the children of sub-groups.

the database.

Children can be documents or groups;

get record with UUID…: When using an

parents will only be groups.

item link, you can use the alpha-numeric

Example:
tell application id "DNtp"
set thisGroup to current group

string from the reference URL to point to
a specific item. (This command works with
both groups and documents.) This form is

name of (the children of thisGroup whose

very useful since it doesn't change when an

(type is XML))

item's name or location changes.

end tell

Example:

USING LOCATIONS

tell application id "DNtp"

One of the common tasks people want to

Files"

perform with AppleScript is importing files

import "~/Desktop/001.txt" to myGroup

to a specific group. In order to direct the files
to a given location, you need to reference it
properly. Below are three general options for

set myGroup to get record at "/Inbox/New

set groupTwo to get record with uuid
"98BBF96D-7743-46C6-9EB4-51C6EF68373C"
import "~/Desktop/002.txt" to groupTwo
end tell

choosing a location:
WORKING WITH A SELECTION
incoming group: This targets the Global
Inbox, or the inbox of a database when

Many times you want to process items

using incoming group of current

you have selected in DEVONthink. Perhaps

database.

you want to generate a list of names and

current group: This targets the currently

dates for use in a document you're working

selected group in the current database.

on. Below is a handler commonly seen in

display group selector: This shows the

DEVONthink scripts:

group selector so you can choose a location
on demand.

repeat with thisRecord in (selection as
list) … end repeat: This is a very common

There are many times you want to direct files

handler, used when processing a selection,

into a specific group. That group may not

single or multiple items.

be the current group you're in and you may
not want to choose a destination each time.
Here are two common ways of specifying
a particular group in your database to be a
destination group in your script:
get record at…: This command allows you

Example:
tell application id "DNtp"
if selection is not {} then
set nameList to {}
repeat with thisRecord in (selection as
list)
copy ((name of thisRecord) & ": " &

to set a variable by specifying a group's

(creation date of thisRecord as string) &

location in your group structure. The

return) to end of nameList

location is a text string, always beginning

end repeat
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create record with {name:"Files",

ATTACHING A TRIGGERED SCRIPT

type:text, content: (nameList as string)}
in incoming group

While it's possible to write a script that

end if

specifies a triggered script for an item in

end tell

DEVONthink, the usual method is manually
attaching one.

INTERNAL SCRIPTS

Select the item you want to attach a script

The Scripts menu of DEVONthink, located to

to.

the left of the Help menu, gives you access

Select Tools > Get Info or Tools > Inspectors

to a large number of pre-made scripts, with

> Generic.

more scripts available. These scripts are not

Click the down arrow next to Script

only useful for every day use, but are also

and choose Select. Note the script

great for learning how to script DEVONthink.

can be located anywhere, but it must

All the scripts we provide are editable
using the Apple's Script Editor, though
we do suggest making copies to work
on. They are located in ~/Library/
Application Scripts/com.devontechnologies.think3/Menu. Open this
folder in the Finder with Scripts > Open

remain in that location for the script
to trigger. For convenience, you can
create a folder for them in ~/Library/
Application Scripts/com.devontechnologies.think3/Menus.
REMOVING A TRIGGERED SCRIPT

Scripts Folder command. Add your own

Since a triggered script runs when you

scripts to the menu by adding them to the

interact with the item, it can sometimes

appropriate subfolder in this directory, even

be difficult to detach the script, e.g., if

creating subfolders of your own.

a script switches to another application

A complete listing of the installed scripts can
be found here: See also p. 234ff

TRIGGERED SCRIPTS

when triggered. For instances like this, to
remove a triggered script from an item do the
following:
Control-click the item you want to remove
the triggered script from and choose Get

Triggered scripts are AppleScripts that you

Info.

attach to an item in DEVONthink (a group

Click the down arrow next to Script and

or document) and that are executed each

choose Remove.

time you select the item. Items with attached
triggered scripts show an AppleScript icon

TERMINOLOGY

behind their name.
Triggered scripts are defined by a specific
Using triggered scripts, you can add your
own custom behaviors when interacting with
items in your database.

handler: on triggered(var), where var is
the variable representing the item the script
is attached to.
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Example:

To write an embedded script for a reminder,

on triggered(theRecord)

choose Execute Embedded Script as the

tell application id "DNtp"

alarm. Click the … button and a popup will

display alert "" & (name of theRecord as
string)
end tell
end triggered

appear with a pre-built handler in place.
Add your code as necessary, then press the
compile button, the one with the stylized eye,
to make sure it compiles correctly. If it does,

REMINDER SCRIPTS

you will see the code format itself subtly. If
not, you will hear a system alert. Click outside

Reminders have several pre-built alarms

the popup to dismiss it. When the alarm goes

available for notifications. However, you

off, the script will be executed.

can only specify one alarm per reminder.
Reminder scripts are AppleScripts run by an
alarm set on a specific reminder for an item.
By using or writing your own, you can extend
notification possibilities of your reminders.

Note: When a reminder is set to Once, the
reminder is removed and the embedded
script lost after the alarm goes off. If you
have code you'd like to potentially use
again, put it in an external script.

ADDING AN EXTERNAL SCRIPT
TERMINOLOGY
To add an external script as an alarm
for a reminder, choose Execute External
Script. The next dropdown lists any
available AppleScripts in the ~/Library/
Application Scripts/com.devon-

Triggered scripts are defined by a specific
handler: on performReminder(var), where
var is the variable representing the item the
alarm is set for.

technologies.think3/Reminders directory.

Example:

Add any of your own scripts to this directory

on performReminder(theRecord)

to make them available for any alarm you set.

tell application id "DNtp"
set label of theRecord to 1

Currently, there is only one example script

say (name of theRecord as string)

pre-installed:

end tell
end performReminder

Open Document: Opens the document in a
new window when the alarm triggers.

ADDING AN EMBEDDED SCRIPT
Sometimes you only need to add a script for
a specific purpose, not general use with all
reminders. DEVONthink allows you to quickly
write an ad-hoc AppleScript specifically for

TOOLBAR SCRIPTS
Scripts can also be added to the toolbar
of any DEVONthink window. While there
is a limited amount of space available in
a window's toolbar, this is a handy way to
launch commonly used scripts with one click.

the current reminder.
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To add a toolbar script place the

one or multiple .lproj folders, one for

script into the folder ~/Library/

each supported language. Depending on the

Application Scripts/com.devon-

system language, you can let DEVONthink

technologies.think3/Toolbar. In order

import the files in the correct language.

for the script to be available for use in

If you inspect the contents of a template

the toolbar, you must quit and relaunch

package, e.g., Classifications > Decimal Filing

DEVONthink. Then Control-click the toolbar

System.dtTemplate, you will see the project

of a DEVONthink window and choose

folders and their assets as a great example of

Customize Toolbar. Drag your script into the

this type of template.

toolbar and it's ready for use.
SMART TEMPLATES
TERMINOLOGY
The more advanced type of automated
Unlike some other script types, there are no

templates are smart templates. These are

special handlers required for a toolbar script.

not simple files, but actually AppleScript

You only need valid AppleScript talking to

packages containing script code, and often

DEVONthink.

including related assets that can be inserted

Example:
tell application id "DNtp"
open tab for record (content record)
end tell

into your database. This allows for some very
powerful actions like:
The script can add information to the builtin template, e.g., the current date and time
or data from the web.

SMART TEMPLATES
Some of the DEVONthink provided templates
are "template packages" (.dtTemplate) and
"smart templates" (.templatescriptd). Both
templates provide a great deal of flexibility
and power, like allowing for inclusion of
language resources. With some creativity
and scripting know-how, you can set up

The script can act intelligently on data
on the clipboard: If it's a simple text, it
adds the text; if it's a URL, it adds it to a
different area of the document and makes
it clickable.
The script can check if a certain application
is installed, e.g., OpenOffice, before adding
a document.

everything from commonly used group
hierarchies to daily journal entries and much
more.

CREATING TEMPLATES
Template Packages: To create your own
template package, you can duplicate an

TEMPLATE PACKAGES
The simpler type of automated templates
DEVONthink supports are: template
packages. These are folders with the file
name extension .dtTemplate that contain

existing template, Control-click it, choose
Show Package Contents and edit the
internals as needed. Also note exporting
multiple selected files will yield a template
package.
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Smart Templates: To make your own

%author%: The author entered in

smart templates, have a look at the

Preferences > Editing > Author

prefabricated smart templates. Duplicate

%username%: The user's name

a .templatescriptd file, like the "Note"

%fullUsername%: The user's full name

template. Control-click it, and choose

%organization%: The user's organization

Show Package Contents. You can inspect

from Contacts

and modify the supporting assets and the

%emailAddress%: The user's email

main.scpt file to fit your needs.

addresses from Contacts

TEMPLATE PLACEHOLDERS

%host%: The host name
%databaseName%: The database name

Placeholders in templates are simple control

%databasePath%: The database's path

codes that are replaced by DEVONthink

%groupName%: The name of the parent

when a template file is imported. These

group

placeholders can be used in your files,

%topGroupName%: The name of the top

including simple templates, or folder

group

names of your templates packages. When

%clipboard%: The clipboard contents as

used in files, they are typed in the text of

plain text

DEVONthink-native files; e.g., plain or rich

%styledClipboard%: The clipboard

text, Markdown, etc. These can be manually

contents as rich text

typed or you can Control-click in the text and

%clipboardLink%: The clipboard contents

choose Insert Placeholder. Below is a list of

as a clickable rich text link if the clipboard

valid placeholders:

contains a valid URL

%time%: The current time

Note: There are more placeholders from

%date%: The current date

the contextual menu than can be used in

%shortDate%: The current date in short

a template. For example, the placeholder

format

%record_locality% relates to an existing

%longDate%: The current date in long

record, so this placeholder will not be used

format

when creating a file from a template.

%monthname%: The month name of the
current date
%weekday%: The week day name of the
current date
%day%: The day number of the current
date
%month%: The month number of the
current date
%year%: The year number of the current
date

Custom Placeholders: One more powerful
feature of smart templates is the ability
to define custom placeholders, extending
the possibilities beyond the list shown here.
This allows you to add a custom placeholder
in the text of a template, then define the
replacement value for that placeholder in the
main.scpt. As a great example, check out the
use of the custom %project% placeholder in
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the Project smart template. Notice the use of

Smart rules are conceptually simple and can

the placeholder in the enclosed rich text file

be summed up as follows: When this event

and the script.

occurs > do this action > on items matched >
in this location. Smart rules are made of four

TERMINOLOGY

parts:

With the internal script of a smart template,

A location: This is where the smart rule will

there are no special handlers required.

look for matching items.

However, the internal script must be located

Matching criteria: Like a smart group, you

in the Contents/Resources/Scripts folder

can specify criteria to be matched. The

inside the package, and it must remain

smart rule will only act on the matched

named main.scpt. Beyond that, you only

items.

need valid AppleScript.

An action: This is the action the smart rule
performs when the event occurs.

TOOLBAR TEMPLATES
To add any template to the toolbar, place
the template into the folder ~/Library/
Application Support/DEVONthink 3/
Templates.noindex/Toolbar. In order
for the script to be available for use in

An event: This is an event that causes an
action to occur, e.g., an "On Quit" event.
If used in a smart rule, a specified action
would run when you quit DEVONthink.

CREATE A SMART RULE

the toolbar, you must quit and relaunch

Smart rules can be created in one of two

DEVONthink. Then Control-click the toolbar

ways:

of a DEVONthink window and choose
Customize Toolbar. Drag your template into
the toolbar and it's ready for use.

Click the + button at the bottom of the
sidebar and choose New Smart Rule. The
Search in dropdown will target the current
location.

SMART RULES

Control-click an item in the sidebar

Smart rules are smart groups‚ evolved. Built

and choose New Smart Rule from the

in the same style as smart groups, smart

contextual menu. This will specifically

rules don't just show items matching criteria,

target that item in the Search in dropdown.

they can act on them! From something
as simple as adding (or changing) a color
label, to modifying a filename then filing

Note in either case you can change the
Search in parameter to target other
locations, including all open databases.

a document in another location, smart
rules provide some powerful automation

Note: Smart rules are considered global

possibilities. And they're not just for the

objects and can be created only in the

technically inclined. No programming

Navigate sidebar of a main window. If you

experience is needed for almost every action
available.
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want to create a smart rule for a group

Note: Bear in mind, smart rule actions run

in the item list, choose Data > Reveal to

in series, i.e., the actions run from top to

display it in the sidebar.

bottom, first to last. This means the order

When you create a new smart rule, you will be
shown the predicate editor, just as you see
with smart groups. Just follow these simple

of the actions affects the outcome. Think
carefully about this if you decide to create
chained actions.

steps to define the parameters of the rule

We hope this has given you a good overview

(with an example):

of creating a smart rule. Please see the

Name: Give the rule a name, like Label
Edited Screencaptures.

appendix for a complete list of available
Events and Actions.

Location: Set the Search in dropdown to

For those interested in the Execute Script

target your desired location, like a group

action, continue to the next section…

you add screen captures to. The more
specific the better; a good idea is to use
e.g., a database's inbox.
Matching: Add any criteria to be matched,
e.g., Name begins with screen and Kind is
Image.
Event: Choose an event to trigger the
smart rule, like specifying On Save to run
the smart rule when matched items are
saved in DEVONthink
Action: Choose an action for the smart

IMPORTING AND EXPORTING
Smart rules can be exported to the Finder,
sent by email, and e.g., reimported to
DEVONthink on another Mac. Drag a smart
rule to the desktop to save it to a file or
Control-click it and choose Export. Doubleclick a saved smart rule to import it, drag
it into the sidebar, or Control-click into the
sidebar and choose Import.

rule, perhaps Change Name to add
"_edited" to the name.

SMART RULE SCRIPTS

This rule shown above would add "_edited"

Smart Rule scripts are AppleScripts run by an

as a suffix to the name of any edited images

Execute Script action in a smart rule. These

whose name begins with "screen".

scripts allow you to extend the possibilities
beyond the already powerful pre-defined

One step further‚ chained actions: If you

actions.

hadn't noticed, there's a + button to the
right of the action you specified. And yes,

Note: Smart rule scripts will be executed

that means you can chain multiple actions

based on the event handler in the specific

in a smart rule! For example, we could add

rule. For testing, it can be useful to set the

an action to open the edited imaged in the

event to On Demand. This way you can select

system default application after it has been

the rule to see its matches, then Control-click

renamed.

it and choose Apply Rule to run it and see the
effects on the matched items.
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Also be aware the effects of smart rules

Tags - Add Keywords: Automatically adds

are very broad, i.e., they affect all the items

Tags from the concordance of the matched

they match. While you are testing, it's a good

file.

idea to put some limiting criterion in place.

Tags - Assign: Automatically adds tags,

For example, instead of matching all images

based on Apple's machine learning

in all databases, try matching images in a

technology for images or hashtags and

specific group or only images that begin with

known tags in titles and content.

"Screen".

ADDING AN EXTERNAL SCRIPT

Downloads - Add Embedded Images:
Add embedded images to the Download
Manager. Used with HTML-based files, e.g.,
To add an external script to a smart rule,

web archives, etc.

add an Execute Script action and choose

Downloads - Add Linked Images: Add linked

External. The next dropdown lists any

images to the Download Manager. Used

available AppleScripts in the ~/Library/

with HTML-based files, e.g., web archives,

Application Scripts/com.devon-

etc.

technologies.think3/Smart Rules

Downloads - Add Podcasts: Add detected

directory. Add any of your own scripts to

podcast links images to the Download

this directory to make them available for any

Manager. Used with podcast RSS feeds

smart rule you define. Here is a list of the pre-

containing download links.

installed scripts, for everyday use and your
education:

ADDING AN EMBEDDED SCRIPT

Check Links: Check if bookmarks are valid.

There are times you may need to add some

Close All Databases: Closes all databases

code for a specific situation. Similar to

but the Global Inbox.

some other macOS utility applications,

Download Bibliographic Metadata:

DEVONthink allows you to write an

Attempts to retrieve the digital object

AppleScript directly in the smart rule's editor.

identifier (DOI) of the document and set
the title and metadata.
Move Into Database: Moves indexed files
into the database.
Move to External Folder: Moves imported
files out to the Finder when they're located
in an indexed group.
Reminders - Next Week: Set a reminder for
a week from the current time and date.
Reminders - Remove: Remove an applied
reminder from the matched item(s).
Reminders - Tomorrow: Set a reminder for

To write an embedded script for a smart
rule, add or specify an Execute Script action
and choose Embedded. Click the Edit Script
button and a popup will appear with a prebuilt handler in place. Add your code as
necessary, then press the compile button,
the one with the stylized eye, to make sure it
compiles correctly. If it does, you will see the
code format itself subtly. If not, you will hear
a system alert. When done, click outside the
popup to dismiss it

the same time tomorrow.
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Note: For those learning AppleScript, the

One of the actions available is Run

repeat loop in the pre-built handler is a

AppleScript. Selecting this option shows a

very common (and useful) code snippet for

dropdown with any installed Mail Rule scripts.

processing all files returned by a smart rule.

These scripts are installed in ~/Library/

Take note of it.

Application Scripts/com.apple.mail
folder. If you write or obtain other scripts for

TERMINOLOGY
Smart Rule scripts are defined by a specific
handler: on performSmartRule(var),

use with Mail Rules, they can also be placed
in this directory. The scripts provided by
DEVONthink are:

where var is the variable representing items

Mail Rule - Add attachments to

matched by the smart rule.

DEVONthink: Adds the attachment of the

Example:
on performSmartRule(theRecords)
tell application id "DNtp"

message it acts on as separate documents
to DEVONthink.
Mail Rule - Add links to DEVONthink: Adds

repeat with theRecord in theRecords

detected links in the messages as individual

if (name of theRecord as string) contains

bookmarks in DEVONthink

"Piglet" then

Mail Rule - Add messages to DEVONthink:

set state of theRecord to true

Adds the messages it acts on to

end if
end repeat

DEVONthink.

end tell

Mail Rule - File messages & attachments:

end performSmartRule

Adds the messages it acts on including all
attachments to DEVONthink.

APPLE MAIL RULES

Mail Rule - File messages & attachments

When considering importing emails into your

acts on including all attachments to

DEVONthink databases, the question of

DEVONthink, recreating the mailbox

"automatic" email importing invariably comes

structure.

hierarchically: Adds the messages it

up. While this isn't fully possible yet, there is
a mechanism in Apple Mail that can provide

TERMINOLOGY

some level of "automatic": Mail Rules.
A full lesson on writing scripts for Mail Rules
Found in Apple Mail's Preferences > Rules,

is beyond the scope of this help, but you can

these are a rules consisting of criteria to be

open and explore the installed scripts.

matched and an associated action (similar
to smart rules). As incoming emails are
detected, Mail will check for matches in a rule
and execute any actions you've specified in
the rule.

Do note there are two required handlers:
using terms from application "Mail"
and on perform mail action with
messages theMessages for rule theRule,
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where theMessages is a variable representing
the items matched by the rule. Here's a
simple example:

MAIL SCRIPTS
Importing email into your DEVONthink
databases is a possible use of AppleScript.

Example:

Using AppleScript-enabled email

using terms from application "Mail"

applications, especially those with a robust

on perform mail action with messages

scripting dictionary, increases the potential

theMessages for rule theRule
tell application "Mail"
repeat with thisMessage in theMessages
display alert "" & (subject of
thisMessage)
end repeat

for processing emails. This can help you
quickly file those emails directly into
DEVONthink.
DEVONthink comes with scripts for Apple

end tell

Mail, Microsoft Entourage, and Microsoft

end perform mail action with messages

Outlook. Just select a message or mailbox in

end using terms from

a supported email application and choose the

Note: Mail Rules are controlled by Apple
Mail, not DEVONthink. While they generally

desired script from the global scripts menu.
DEVONthink provides the following scripts:

behave as expected, we can't control

Add attachment(s) to DEVONthink: Adds

whether the rules will be triggered in Apple

the attachments of selected emails to

Mail.

DEVONthink.
Add mailbox(es) to DEVONthink: Adds the

APPLICATION SCRIPTS

selected mailboxes to DEVONthink.
Add mailbox(es) & attachments to

AppleScript is perfectly suited for integrating
different applications, interchanging
information, and creating workflows.
DEVONthink comes with a number of
scripts that exchange information between
DEVONthink and other AppleScript
supporting applications, like Safari or Mail.

DEVONthink: Adds the selected mailboxes
to DEVONthink. Attachments are imported
separately.
Add message(s) to DEVONthink: Adds the
selected mailboxes to DEVONthink.
Add message(s) & attachments to
DEVONthink: Adds the selected mailboxes

The Script Menu Extra Scripts provided by

to DEVONthink. Attachments are imported

DEVONthink are installed in an application-

separately.

specific folder in ~/Library/Scripts/

Note: The import of entire mailboxes via

Applications, e.g., ~/Library/Scripts/
Applications/Safari. These scripts are
accessible from the global scripts menu in
the menu bar at the top of your screen while

AppleScript can be a resource-intensive
process. Use the Apple Mail plugin for
a more robust experience importing
mailboxes.

you're in the specific application.
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WEB BROWSERS

FOLDER ACTIONS

Depending on the capabilities of the web

Folder actions are scripts that you can attach

browser you're using, you may be able to

to folders in the Finder. These act on all items

use application scripts. We have included

you add to these "hot folders." When you

a handful of simple scripts that can be run

add items, the operating system detects

while browsing in Safari or DEVONagent.

the added files and runs any folder actions
attached to the folder.

Add abstracts to DEVONthink: Creates a
sheet containing information about items

The actions supplied by DEVONthink are

in a DEVONagent search. This includes

installed in ~/Library/Scripts/Folder

the title, score, summary, and URL of each

Action Scripts, and you can add your

result. (DEVONagent only)

own scripts to this directory, as needed.

Add linked images to DEVONthink: Detects

For everyday use and exploration, here

images on the current page and adds them

are the folder action scripts provided by

to your database.

DEVONthink:

Add tabs to DEVONthink: Adds bookmarks
for active tabs the browser.

DEVONthink - Import: Imports files into
your databases.

Add linked images to DEVONthink's

DEVONthink - Import & Delete: Imports

downloads: Detects images on the current

files into your database, and moves the

page and adds them to DEVONthink's

files to the trash afterwards.

Download Manager.

DEVONthink - Import to selected group:

Add links to DEVONthink's downloads:

Imports files to the currently selected

Detects URLs on the current page and adds

group.

them to DEVONthink's Download Manager.

DEVONthink - Index: Index files to your
database, creating links to the original

OTHER APPLICATIONS

items in the Finder.
DEVONthink - Index to selected group:

Obviously we haven't covered all the possible
applications or scenarios on your machine,

Index files to the currently selected group
in your database.

and we are sure you have ideas we haven't
thought of. If you have an application you'd

DEVONthink - Import, OCR & Delete:

like to integrate with DEVONthink, check if

Imports files into your database, converts

it has an AppleScript dictionary. If it does,

them to searchable PDFs if necessary, and

the potential exists to communicate between

moves the files to the trash afterwards.

the applications. But also be aware the
commands, elements, and properties you
can work with are coded by the developer of
those applications.

ATTACHING A FOLDER ACTION
To attach a folder action script to a folder, do
the following:
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Control-click a folder in the Finder.

Note: Folder actions, like any computer

Select Services > Folder Actions Setup

processes, are treated very literally. When

from the contextual menu.

processing files with a folder action, it's

From the list of available actions, select

best to move or delete the files from the

the folder action script click Attach.

watched folder. This keeps the action from

Manage folder actions: To manage all your

trying to reprocess files.
folder actions, Control-click a folder and
choose Services > Folder Actions Setup from

AUTOMATOR

the contextual menu. Use the Folder Actions

Apple's Automator application was created

Setup utility to see which folders have scripts

mainly to help non-programmers take some

attached, and to remove folder actions from

control of their machines. It allows you to

folders.

visually string together simple steps in an

Note: If you are running macOS Mojave,
you will be prompted to allow the Folder
Actions Setup application to run. This
notification is controlled by the operating
system, not DEVONthink.

automated process. While much more limited
due to its linear nature, it may still be useful
for some routines. Additionally, Automator
offers creation of other types of items like
Services (or Quick Actions).
While DEVONthink does not provide

TERMINOLOGY
While we can't provide specific training
on how to create folder actions, check out
Apple's documentation. However, the on

Automator actions, using the Run
AppleScript action in Automator makes it
possible to have some degree of integration
with our application.

adding folder items to folderVariable
after receiving filesVariable is the
handler most commonly used in our folder
action scripts. Here is a simple example:
Example:
on adding folder items to theFolder after
receiving theFiles
repeat with thisFile in theFiles
tell application id "DNtp"
set newRecord to import thisFile to
incoming group
if exists newRecord then tell application
"Finder" to delete thisFile
end tell
end repeat
end adding folder items to
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TERMINOLOGY

DEVONthink to Finder: Passing paths from
Finder to DEVONthink: Since DEVONthink
doesn't provide specific actions for
Automator, you can't merely detect things
like a selection. The key to integration with

DEVONthink can be done by processing
the paths of files. Here is an example Run
AppleScript action placed at the beginning of
the workflow:

DEVONthink is passing file paths, specifically

Example:

POSIX paths. For example, if you used a Get

on run {}

Selected Finder Items action, you could use

tell application id "DNtp"

a Run AppleScript action like this to import
selected files in the Finder into DEVONthink :
Example:
on run {input}
tell application id "DNtp"
repeat with thisFile in input
import (POSIX path of thisFile) to
incoming group
end repeat
end tell

set fileList to {}
if selection ≠ {} then
repeat with thisRecord in (selection as
list)
copy (path of thisRecord as string) to end
of fileList
end repeat
end if
return fileList
end tell
end run

Immediately following this action, use
a Get Specified Finder Items action to
pass the paths to subsequent actions. Be
very cautious when using the paths from
DEVONthink. Actions like moving, deleting,
renaming etc. would compromise your
database. It is advisable to use a Copy Finder
Items command if you are going to do such
operations.
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Note: While we may investigate

the specified document. Usage:

DEVONthink-specific questions regarding

search=<string>.

Automator, we do not offer support

time: Directly jumps to the specified time

specifically for it.

in seconds in a video or audio document.
Usage: time=<float>.

ITEM LINKS

Example:

Every database, group, or document in your

x-devonthink-item://<recordID>?reveal=1

DEVONthink database has a URL (uniform
resource locator) associated with it. While
web URLs typically begin with http:// or
https://, DEVONthink's URLs take the form
of x-devonthink-item:// followed by a
long alphanumeric ID. For PDFs, the link can
contain a reference to a specific page. For
audio and video, a reference to the current
playback time. And for RTFs, you can get
a reference to a specific paragraph in the

x-devonthink-item://<pdfID>?page=5
x-devonthink-item://<textFileID>?
search=iPad%20Pro
x-devonthink-item://<movieID>?time=43.5

Note: The first parameter after the ID is
always added after a question mark (?),
additional ones after an ampersand (&),
and any values must be percent-encoded.

TERMINOLOGY

document. These links can be used in any

Manually getting item links can be useful

file type or application that supports live

for some hard-coded cases, but there

hyperlinks, e.g., the notes fields of OmniFocus

are many times you want to get them

tasks. This allows you to access DEVONthink

programmatically. There are two AppleScript

documents as easily as clicking a link in a web

properties for a record related to item links:

browser.
reference URL: This is the item link as
You can get this item link manually by

described above.

selecting a document or group and choosing

UUID: This is the unique identifier of the

Edit > Copy Link. In addition you can manually

item, i.e., the long alpha-numeric string in

extend the copied URL with the following

the reference URL.

parameters:
Here is an example of getting and using an
page: Opens a PDF to the specified page.

item link to create a Markdown compliant link

Usage: page=<integer>.

on the clipboard:

reveal: Reveals an item in the item list
instead of opening it in a new window.
Usage: reveal=1.
search: Directly jumps to the first
occurrence of the search string in

Example:
tell application "DNtp"
set recordName to name of content record
set recordURL to reference URL of content
record
set the clipboard to ("[" & recordName &
"](" & recordURL & ")")
end tell

DEVONthink 3.7 Documentation, page 204

The terminology for using item links can
depend on the capabilities of the application
you're scripting. Here is an example, using a
hard-coded URL, with an application that can
open URLs:

Commands:
createFormattedNote: Creates a
formatted note.
createHTML: Creates a new HTML
document.

Example:

createMarkdown: Creates a Markdown

tell application "Opera"

document.

tell window 1

createPDF: Creates a PDF.

make new tab with properties {URL:"xdevonthink-item://929D101B-35AC-474C-801CD8818C48DB80?line=125"}
end tell
end tell

createRTF: Creates a rich text document.
createWebArchive: Creates a web archive.
createBookmark: Creates a new bookmark.
Note: Use the location parameter set

P.S.: For the shell scripters, the URLs can be

to a URL with the commands above to

used with an open command.

download the page in the specified format.
createGroup: Creates a group.

URL COMMANDS

createText: Creates a new plain text

URL commands are a type of item link

document.

that don't merely point to an existing file,

clip: Opens the Clip to DEVONthink panel.

they issue some special commands to

note: Opens the Take Note panel.

DEVONthink. Though not as powerful as

search: Initiates a search in the open

AppleScript, these commands can be used in

databases.

special circumstances.

TERMINOLOGY

Parameters:
title: The title of the item to be created
(string).

The URLs are constructed from a single
command and optional parameters, with the
following format:

comment: A Comment to be added
(string).
location: The URL linking to the content,

x-devonthink://<command>?
<parameter=value&parameter=value&...>

e.g., the URL of the website for the

Note: The first parameter after the ID is

tags: Tags to be added (comma separated

always added after a question mark (?),

strings).

additional ones after an ampersand (&),

destination: The UUID of a group where the

and any values must be percent-encoded.

item shall be created (string).

Listed below are the commands and
parameters available:

bookmark (URL).

source: The HTML content for HTML
documents (string, only used by
createHTML and createFormattedNotes).
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text: The text content for text documents

referrer: The URL that referred to the item

(string, used by createText and

(URL).

createMarkdown).

selection: The selected text (string, only

width: The page width (integer, only used

used by createRTF).

by createPDF).
paginated: Paginate the created PDF
(boolean, only used by createPDF).
hide: Hide and deactivate application after

Example:
x-devonthink://createRTF?title=New
%20bookmark&location=http%3A%2F
%2Fwww.devontechnologies.com&noselector=1

executing the comment (boolean).
noselector: Skip group selector (boolean).
query: The query to search for (string, only
used by search).
reader: Post-process the page (integer, 0 =

Note: These are not x-callback-urls. An
x-callback-url is a specific type of URL
scheme that returns a value to the calling
application.

no post-processing, any other value = postprocess).
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APPENDIX
⇧ The Shift key.

IN THIS CHAPTER

⎋ The Escape key (usually labeled with

Glossary

207

Iconology

210

Toolbar Items

210

Keyboard Shortcuts

213

Contextual Menu Items

215

Search operators

218

Search Prefixes

220

Bars: Smaller sections of a window

Templates

224

providing specialized information or

Metadata

227

controls, e.g., the Information Bar found

Placeholders

229

just above the item listing. It shows

Smart Rule Events and Actions

230

information about the selection as well as

Scripts

234

buttons to sort or change the view.

Web site export templates

237

Contextual menu: The menu that appears

Hidden preferences

237

when you right-click (or Control-click)

In the appendices you will find additional
information that helps you getting familiar
with DEVONthink, such as a glossary of
commonly used terms, a listing of the
Boolean operators used in searches,
commonly found contextual menu items, and
much more.

"esc").
⇥ The Tab key.
↩ The Return key.

INTERFACE ELEMENTS

something. The contextual menu gives
you access to frequently used commands
that deal directly with the clicked object.
Specific contextual menu items are
discussed in their respective sections, but
there is a list of commonly seen commands
in the Contextual Menu Items section of
this appendix.
Inspectors: Specialized panes at the right

GLOSSARY
Become familiar with these terms to get the
most out of working with DEVONthink.

of a main window, providing information
about the current selection as well as
functions like See Also & Classify.
Item list: The list of items in the current

KEYBOARD SYMBOLS

location, viewable as a list, icons, columns,
or Cover Flow. Items can be documents,

⌘ The Command key, usually next to the

groups, or smart groups.

Space bar.

Sidebar: The panes found at the left side of

⌥ The Option key.

a main window, comprised of the Navigate,

⌃ The Control key (usually labeled with

Reading List, Import, and Extras panes.

"ctrl").
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View/Edit pane: A pane of the

is started and accessible through the

DEVONthink main and document windows

sidebar. The Global Inbox can be set as

that lets you view a document or, when

the default destination in Preferences >

possible, edit it. The view/edit pane

Import.

displays the content of your documents

Inbox: A special group for data coming in

depending on their type. See also p. 79ff

to a database. Every database has an Inbox

View: The layout for a DEVONthink main

group.

window. You can change the layout using

News feed: Also referred to as RSS, a

the commands found in the View menu.

news feed is like a web page, but split

Window: DEVONthink uses three different

into multiple articles. A feed reader or

types of windows: main, document, and

web browser can split the feed "page"

other. Main windows show lists of items

into its parts and show each of them as

and, in some views, also the contents of

a separate news item and/or store it in a

the selected document, whereas document

local database. DEVONthink stores feeds in

windows can be opened for individual

a database and displays them like a group.

documents.

The contents are updated live from the
internet as the connected feed changes.

DOCUMENTS & GROUPS
Database: A collection of all documents
stored in DEVONthink. You can create and
open as many databases as you like.
Document: A file in the database; for
example, a plain or RTF text, a PDF, or an
image (.jpg, .tiff, .png, etc.). Technically a
document is an entry in a database with
text, RTF, or image content, sometimes
simply referred to as "content".
Default destination: The default
destination group for incoming data. Set in
Preferences > Import.
Duplicate: A copy of a file, either explicitly
created or detected by DEVONthink's AI.
Group: A collection of documents or other
groups inside the database. Similar in
appearance and behavior to a folder in the
Finder. See also p. 138ff
Global Inbox: A special database serving as
a destination for incoming data. The Global
Inbox is always opened when DEVONthink

Older news bits are kept, while fresh news
bits are added and marked as unread.
When you add a bookmark that points
a feed, DEVONthink tries to add it as a
proper feed document if possible.
Replicant: A document or a group that
appears in more than one place in the
database. Unlike an alias in the file system,
a replicant is not a real document pointing
to another file (usually the original);
rather it is a second entry in the table of
contents for the very same document.
Consequently, there is no original; when
you replicate a document you'll end up with
two replicants.
Sheet: A collection of records or structured
sets of data, presented in a spreadsheet
style, similar to data viewed in Apple
Numbers or Microsoft Excel. Alternatively,
the data can be displayed in form view,
similar to browsing records in, e.g.,
FileMaker.
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Smart group: A special type of group with

deleted (groups, documents) or modified

a set of search criteria saved with it. This

(documents).

is similar to "Saved Search" folders in the

Read/Unread: Items can be marked read

Finder. Every time you visit this smart

or unread, which is useful for captured or

group, DEVONthink runs the attached

automatically downloaded news items or

search and displays it as the content of the

documents that you want to read later.

group. DEVONthink creates a number of

Both unread items and groups containing

pre-defined smart groups when you create

unread items are shown in bold.

a new database.

UUID: Each database, group, or document

Trash: A temporary location in a database

in DEVONthink receives a unique identifier

for deleted files. Similar to the Trash in

(UUID) when it's created. This is a read-

the Finder, all trashed items are stored

only alphanumeric string that refers only to

until you explicitly delete them using

the particular item. The UUID allows you to

DEVONthink > Empty Trash.

reference an item regardless if its location
or name changes, and is usually found in

TAGS

item links.

Group tag: Groups within a database that

See the Iconology section for icons specific to

apply their name as tags to their contents.

the flagged, locked, or unread states.

Items moved out of these groups will not
retain the group tags. Group tags appear
grey in all tag lists.
Ordinary tag: Tags created through the
Tag bar or other means are created in a
special top-level Tags group. They are called
"ordinary tags" and appear blue in all tag
lists.

SYNCHRONIZATION
Sync location: Sync locations are used to
keep your databases on all your devices in
sync. They summarize all information about
which databases to sync through what kind
of connection (e.g., direct connections to
DEVONthink on a Mac, WebDAV, CloudMe,

See the Iconology section for icons specific to

Dropbox etc.) and with which sync store.

these two items.

Bonjour (Direct connection): A sync
method for syncing one device to another

ITEM PROPERTIES
Flagged/Unflagged: Items can be checked
or unchecked for your personal use, e.g.,
for creating a to-do list, maintaining a
shopping list, or writing a list of project
tasks.
Locked/Unlocked: Items can be locked
to keep them from being unintentionally

Mac or mobile device running DEVONthink
or DEVONthink To Go, respectively.
Unlike other sync methods, there is no
intermediary storage location for the sync
data. It is direct - device to device.
Sync store: A sync store is a special folder
containing sync data. These can be direct,
local, e.g., on your Mac or a thumb drive, or
remote, as used with cloud services.
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Encryption key: A user-defined word used

Item has been flagged.

to "scramble" or "unscramble" your sync

Item is indexed, not imported.

data when syncing. When used, your sync

Item is locked.

data is stored in an encrypted state in the

Item has a comment.

sync store.

Item has an annotation.

Local database: A database that exists and

Item has a reminder set.

is open on this device.

Item has outgoing item links.

Remote database: A database that is not

Item has incoming item links.

open on this device, or exists at the sync

Item has a script attached.

location, e.g., on Dropbox, but has not been

Group is a tag, too.

downloaded to this device.

Item has an attachment (email messages

Pending document: A document for which

only).

only the metadata is locally available.

Item is synced but its content is not (yet)

This happens when you choose not to

downloaded.

synchronize indexed files for the sync
location.
WebDAV: A type of web server used
by some cloud services, some network
attached storage devices, or running

Item is a duplicate
Item has one or more replicant(s)
Item is a duplicate, but also has one or
more replicant(s)

locally. It can usually be used by
DEVONthink for syncing.

TOOLBAR ITEMS
DEVONthink provides a wide variety of

ICONOLOGY
Additional icons behind item names, e.g., in
main windows, indicate that the item has
been indexed instead of imported, is locked,

toolbar items, giving you quick "push-button"
access to many everyday tools.

DEFAULT ITEMS

has a comment or annotation attached,

The following toolbar buttons are available in

is encrypted, e.g., PDFs or encrypted

the default set you see when you first launch

databases, or has a triggered script attached.

DEVONthink:

Groups also serving as tags show a tag icon.
Depending on your preferences, replicants,
duplicates, or replicated duplicates are
indicated with a little grey icon instead of
appearing in color.

Sidebar: Show and hide the global sidebar.
Preview: None: Hides the document
preview.
Preview: Standard: Shows the document
preview below the item listing.

Item has encryption applied, e.g.,

Preview: Widescreen: Shows the

encrypted PDFs, and encrypted database,

document preview besides the item listing.

or an encryption key has been specified for

Actions: Contains the contextual menu for

a sync location in Preferences > Sync.

items selected in the item listing..

Item is unread.
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New: Adds documents in DEVONthinknative formats. Similar to Data > New.
Open: Opens the current item in a
DEVONthink window if possible.
Open externally: Open the current
document in the system default

ADDITIONAL ITEMS
In addition to the default set, there are many
other specific buttons available, shown in the
essential order found in View > Customize
Toolbar:

application.

Scripts: Provides access to the contents of

Share: Opens the macOS Share menu for

the Scripts menu.

the selected items. This does not apply to

Quick Look: Opens a Quick Look preview

groups.

for the selected document.

Mark: Flagged: Changes the flagged state

Zoom In: Zooms into the current item.

of the selected item.

Actual Size: Zooms the current item to the

Mark: Read: Changes the read statue of

default zoom level.

the selected item.

Zoom Out: Zooms out of the current item.

Mark: Locked: Changes the locked state of

Zoom to Fit: Sets the magnification of the

the selected item.

current item to fit the bounds of the view/

Label: Changes the label color of the

edit pane.

selected item.

Zoom to Width: Sets the magnification of

Search: This is the main search bar,

the current item to the width of the view/

accessing all or specific groups and

edit pane.

databases.

Full Screen: Displays the current document

Synchronize: Initiates a manual sync of the

in DEVONthink's full screen mode.

current database. See also p. 171ff

Groups: Group: Creates a new group in the

Get Info: Opens a popup from the button

current location.

displaying a number of commonly used

Groups: Smart Group: Creates a new smart

inspectors.

group in the current location.

Show/Hide Inspectors: Shows or hides the

Group: Groups the selected items into a

Inspector panes.

new group.

Show/Hide Tags: Shows or hides the Tags

Ungroup: Ungroups the selected group and

bar under a document's preview.

deletes the now-deserted empty group.

Note: The items for showing or hiding the
document preview as well as for marking
items flagged, read, or locked are also
available as a combined toolbar item.

Classify: Attempts to classify the current
item.
Plain Text: Creates a plain text file in the
current location.
Rich Text: Creates a rich text file in the
current location.
Markdown Text: Creates a Markdown file in
the current location.
Formatted Note: Creates a formatted note
in the current location.
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Sheet: Creates a sheet in the current

Synchronize All: Initiates a manual sync of

location.

all open and actively syncing databases.

Bookmark: Create a bookmark in the

Take Note: Opens the Take Note view,

current location.

either in the Sorter or a Take Note panel.

Launch URL: Opens a URL associated with
the current item in the system default
browser.
Save: Explicitly save changes to a
document.
Delete: Moves the current item to the

Imprinter: Provides access to any imprints
available in the Tools > Imprinter menu.
OCR: Runs OCR on a compatible file, e.g.,
PDFs or images, producing the selected
output type.

database's trash.

Note:

Print: Prints the selected document. If

Reveal: Be cautious with this button. When

a document cannot be printed, the item

used on imported files, it will reveal them

listing will be printed.

in the internals of the database. You do not

Import: Imports files into the current

want to modify these internal files in the

location.

Finder. This option is best used on indexed

Export: Provides access to the contents of

files.

the File > Export menu.
Update: Manually updates indexed items in
a database.
Show in Finder: Reveals a file in its location

Verify & Repair: Please refer to the
troubleshooting chapter for information on
database maintenance and repairs.

in the Finder.

Send by Email: The ability to add the

Reveal: Reveals a file in smart groups or

attachments depends on the inter-

search results in its current location.

application capabilities of the email

Merge: Merges multiple files into one,

application. If it doesn't provide support

leaving the originals intact.

for this, you may be able to drag

Merge and Delete: Merge multiple files into

documents into draft messages or the

one, putting the originals in the database's

email application's dock icon.

trash.
Optimize: Does an internal optimization

Some items are also available as a

and backup of a database's metadata.

compound toolbar icon.

Verify: Checks the integrity of the
database and repairs items it can.
Log: Opens a popover showing available
messages from the Log window.
Send by Email: Creates a new message
in your default email app and attaches
selected items.

CUSTOM ITEMS
If you are creating scripts or templates, they
will be available to add to the toolbar after
quitting and relaunching DEVONthink. See
the appropriate sections for information
on where to save these files for use in the
toolbar.
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KEYBOARD SHORTCUTS
Keyboard shortcuts make using DEVONthink
much more efficient for many people. Some
of the following shortcuts are common
to most Mac applications; others are only
available in DEVONthink. In addition, many
menu commands have keyboard shortcuts.

Option-click (the triangle in front of a
group): Expands or collapses all groups that
are contained within this group as well.
Option-Left/Right arrow: Expands or
collapses the selected groups and all their
children the item list.
Selecting items:

These are shown directly in the menu.
Shift-click: Selects consecutive items.
Note: You can change the shortcuts for

Shift-arrow: Extends the next consecutive

menu commands in System Preferences >

item to the current selection.

Keyboard > Shortcuts > App Shortcuts.

Command-click: Adds a non-consecutive
item to the selection.

WINDOWS
Manipulating items:
Control-Tilde (~): Cycles through open
application windows. This is a common
macOS shortcut.
Control-Tab: Cycles focus between the
item list, view/edit pane, and the Tags bar
or Inspectors (if visible).
Escape: Cancels processes, closes dialogs
or Quick Look previews, etc., depending on
the context.
Command-}: Cycles to the next tab.
Command-{: Cycles to the previous tab.
Note: Hold ⇧ to cycle in reverse order.

Return: Renames documents.
Backspace: Deletes selected items.
Command-Drag: When dragging items from
the Finder, this moves, not copies, the file
into the database.
Option-drag: Duplicates items to the drag
destination instead of moving it.
Command-Option-drag: Creates replicants
for the items at the drag destination.
Dragging items from the Finder to
DEVONthink with ⌥⌘ pressed indexes the
item. Dragging items into documents with
⌥⌘ held inserts a link to the item.

DOCUMENT LISTS
Item List:
Navigating items:
Command-Shift-O: Opens a selected
Up/Down arrow: Navigates up and down in

document in the system default

all views. Use ⇧ to select multiple entries.

application.

Left/Right arrow: Expands or collapses the

Tab: Jumps to the first or next editable

selected groups in horizontal split, vertical

column when using View > List.

split or List views, or navigates to previous/

Space: Opens the standard Quick Look

next item in other views.

panel showing a preview of the selected
items.
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Option-Space: Opens a full screen Quick
Look slideshow.
Option-bracket: Using [ and ], goes

THE SORTER
General Note Creation and Clipping:

backwards and forwards through the

Command-S: Saves the entered data.

visited locations.

Equivalent to clicking Add.
Escape: Clears any entered data.

VIEW/EDIT PANE
Home/End: Goes to beginning of, or end of,
any view.

Equivalent to pressing the retreating circle
icon.
Voice and Video Note:

Page up/down: Scrolls one page up and
down in any view.
Space/Shift-Space: Scrolls one page down

Spacebar: Start and stop recording.
Screen Capture:

or up in non-editable views, e.g., web pages,
images, or PDF documents.

Command-1: Capture the entire window.

Command-click: Opens the target of a link

Command-2: Capture a highlighted window.

in a new tab or separate window.

Command-3: Capture a marqueed area.

Command-Option-drag: Inserts a cross-

Web Clip:

link for groups or documents dropped
into a rich text document. Dragging files

Command-1: Clips from the default

or folders from the Finder to a rich text

browser.

document with ⌥⌘ pressed creates links to

Command-2: Clips from a URL you've

them.

copied to the clipboard.

Command-Shift-click: Opens a link in a new

Command-3: Type a URL to clip and any

tab and activates it. This requires enabling

associated data, e.g., comments, tags, etc..

tabbed browsing in Preferences > General.
Option-bracket: Using [ and ], goes

Clip to DEVONthink:

backwards and forwards through the

Command-F: Toggles the Clutter-free

documents or visited web pages .

option.

Option-drag: Selects text using a
rectangular selection ribbon.
Option-click (a link): For HTML-based files,
adds the clicked URL to the Download
Manager panel.
Option-click (a word): Initiates a search
with the clicked word as the search term.
Shift-arrow: Expands or contracts the
current text selection.

SHEETS
Return: Moves one cell down for editing.
Shift-Return: Moves one cell up for editing.
Tab: Moves one cell to the right for editing.
Shift-Tab: Moves one cell to the left for
editing.
Arrows: Moves the editing selection.
Escape: Stops editing.
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PDFS

Text or links in text:

+: Zooms in.

Add Link to Reading List: Adds a link to the

-: Zooms out.

Reading List.

Command-drag: Scrolls the visible area

Add Link: Allows you to enter a URL for the

with the mouse.

selected text, converting the text to an
active link.

IMAGES
+: Zooms in.
-: Zooms out.

Add tag [word]: Tags the document with
the selected word (only available if the
word is not already a tag of the document).
Convert to Item Link: Converts a selected
WikiLink into an item link. See also p. 34ff

CONTEXTUAL MENU ITEMS
DEVONthink also provides many commands
in contextual menu items, shown when you
Control-click on elements in the application.
Many of the contextual menu items are also
found in DEVONthink's menus. Below is a
list of common menu items you'll find in
the contextual menus for documents and
windows.

An alternate command, available when
holding the ⌥ key, Convert All to Item
Links converts all WikiLinks in the current
document into item links. These commands
only apply to plain text, rich text, and
Markdown documents.
Copy Link: Copies a clicked link to the
clipboard (only available for selected links).
Edit Link: Edits the destination of a
selected link. Selecting this option allows

DOCUMENT CONTENTS

you to remove the link as well.
Insert Link To: Inserts a link to an item you

When you Control-click in the contents of

select in the submenu (only available when

documents, you will see a contextual menu

no text is selected).

with commands and options. The items

Insert Placeholder: Inserts a predefined

shown are related to the file type and if you're

placeholder or one specified as custom

interacting with a selection in the document.

metadata in Preferences > Data.

Specific items, e.g., commands relating only

Highlight: Highlights the selection with

to PDFs, are covered in their respective

the current highlight color. Using this

sections.

command on a selection again removes the

In editable documents:

highlighting.
Link To: Makes the selected piece of text a

Add to Favorites: Adds the current

cross-link and links it directly to the group

document to the Favorites.

or document you select in the submenu.

Add to Reading List: Adds the current

Look Up [word]: Looks the selected text up

document to the Reading List.

in macOS's Dictionary.

Services: Displays the macOS Services

Make Link: Makes the selected piece of

menu.

text a WikiLink. The destination of the
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WikiLink is a document with the same

Set Name As: Sets the name of the

name as the selected text. If no document

document to the selected piece of text

with that name exists, clicking the created

(needs to be less than 256 characters).

link creates it using the template you have

Share: Shares selected text via the

set in the Preferences.

available sharing extensions.

Open Link in Browser: Opens the selected
link in the default browser or application.
Open Link in DEVONagent: Opens the
selected link in a DEVONagent Pro browser

Add Link to Downloads: Adds a link to the
Download Manager.
Images and PDF documents:

window.
Open Link in New Tab: Opens the selected
link in a new tab in DEVONthink.
Open Link in PhotoStickies: Opens a link in
PhotoStickies.
Open Link: Opens the selected link.
Remove Link: Use this to remove the link
status of selected text.
Search with Google: Searches for the
selected text in Google.
Search [word]/Selected Phrase: Searches
for the selected word or phrase in your
open databases.
See Related Text: Displayed like search

Actual Size: Displays the document at
its actual size. Uses also the resolution
information contained in the file.
All Pixels: Zooms the image so that one
image pixel equals one pixel on the screen.
Zoom In/Out: Zooms in or out of the
document, or displays it in its actual size.
Zoom To Fit: Zooms the image so that
it fits into the view/edit pane or the
document window.
Zoom To Width: Zooms the image to fit
the width of the view/edit pane or the
document window.

results, this shows a list of documents
related to the selected text passage. This

ITEM LIST

option is only available when more than

These contextual menu items are commonly

one word is selected.

shown when you ⌃-click items in a main

See [word]: Opens a drawer with

window's item lists. In items lists, the

documents related to the selected word.

commands are also often available in the
Actions toolbar button. Some of these
commands are also seen in the See Also &
Classify Inspector pane.
Add To: Commands in this submenu add
the currently selected documents to your
Favorites or the Reading List.
Apply Rules: Runs a chosen smart rule on
selected items matching the location and
criteria of the rule.
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Convert: This submenu displays options for

New: This submenu allows you to quickly

converting from one file type to another.

create several built-in file types. See the

The options shown here are dependent on

Data menu for more information on these

the type of file selected.

file types.

Copy Item Link: Copies a link to the current

New from Template: This submenu allows

item.

you to create new documents from any of

Copy URL: Copies the URL of the selected

the installed templates.

document to the clipboard. This only

Open: Opens the selected item in a

appears when one document is selected.

separate main window or document

Duplicate To: Duplicates the selected item

window.

to the group you select from the submenu.

Open in Tabs: Hold the ⌥ Option key and

Get Info: Opens an popup containing more

Open changes to Open in Tabs. If the View/

detailed information about the currently

Edit pane is visible, this opens the selected

selected file or group.

items in new tabs. If the View/Edit pane

Group Items: Groups multiple selected

isn't visible, a new document window will

items in an item list.

open with each selected document in its

Label: Changes the label of the selected

own tab in the window.

item.

Open With: Opens the selected item in an

Launch URL: Opens the URL in the selected

external application.

item's URL field. Hold the ⌥ Option key to

Rating: Allows you to set a rating, from no

choose Launch URL in Background. This

stars to five stars.

keeps DEVONthink in the foreground.

Replicate To: Replicates the selected item

Mark: Changes the flagged, locked, or read

to the group you select from the submenu.

status of the selected item.

Reveal: Shows and selects the selected

Move Into Database: Moves an indexed

item in its location in DEVONthink.

item into the database. Use this command

Send by Email: Sends the selected item by

with caution as it moves the file from its

email.

current location into the internals of your

Show in Finder: Shows the selected item in

database. It does not copy the file.

the Finder.

Move To External Folder: Moves a non-

Tags: This submenu offers special

indexed item, e.g., imported or created in

commands for automatically adding some

DEVONthink, out to an indexed folder in

kinds of tags. See the Tagging > Tagging

the Finder.

Sources section of the manual for more

Move To: Moves the selected item to the

information.

group you select from the submenu.

Thumbnails: This submenu allows you to

Move to Trash: Moves the clicked item to

Create, Update, or Remove the thumbnail

the Trash. Hold the ⌥ Option key to shows

for a file.

Move All Instances to Trash when used in

Ungroup Items: Ungroups a group, leaving

items lists.

its contents behind. The group is not
preserved.
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Imprinter: Choose an imprint you've

Send by Email: The ability to add the

defined in Preferences > Imprinter to apply

attachments depends on the inter-

it to the current image or PDF.

application capabilities of the email

OCR: Choose the output file type and

application. If it doesn't provide support

convert a compatible file via OCR.

for this, you may be able to drag files into

Note:

draft message or the email application's
dock icon.

SEARCH OPERATORS
Searching in DEVONthink already is a powerful function. The addition of Boolean operators,
parentheses, and wildcards extend the power to fine-tune your search even further.
Note: The syntax of the operators is compatible to DEVONagent and EasyFind, the Finder,
Spotlight, common search engines as well as common programming languages such as C, C++,
Objective-C, Java, and JavaScript. The complexity of the query is unlimited.

CASE
All terms are case-insensitive. You may, if you wish, use capitalization for proper names in a query,
but DEVONthink will ignore case in interpreting the query.

PRECEDENCE OF TERMS
Search terms and associated operators will be interpreted from left to right, except as modified
by including portions of the query within parentheses.

WILDCARDS
You can replace parts of words with wildcards matching one, multiple, or a range of characters:
?: Matches exactly one character.
*: Matches none, one, or multiple characters.
[a-b]: Matches one character of the range a through b.
[abc...] or [a|b|c|...]: Matches one character out of the given list of characters.
[^...]: Matches one character that is not contained in the given list or range.

BOOLEAN OPERATORS
The operators (often called Boolean operators) are words or symbols that establish logical rules
for the terms in the search query. If no operator is given, DEVONthink infers AND. The available
Boolean operators are:
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term1 AND term2: Contains term1 AND term2
term1 BUT term2: Contains term1 AND term2
term1 OR term2: Contains term1 OR term2
term1 XOR term2: Contains term1 or term2, but not both
term1 EOR term2: Contains term1 or term2, but not both
NOT term: Does not contain term
"term1": Contains the string of words term1, in exactly this form
Besides the classic Boolean operators, DEVONthink uses a number of operators that usually are
found in high-end databases. Use these operators as a replacement for AND and "quotes" to fine
tune your query.
term1 OPT term2: term1 is required, term2 is optional. If term2 is also found, the found
document ranks higher in the search results.
term1 NEAR term2: term1 occurs 10 words or less before or after term2
term1 NEAR/n term2: term1 occurs n or less words before or after term2
term1 BEFORE term2: term1 occurs before term2
term1 BEFORE/n term2: term1 occurs n or less words before term2
term1 NEXT term2: term1 occurs right before term2 (shortcut for BEFORE/1)
term1 NEXT/n term2: term1 occurs n or less words before term2 (synonym for BEFORE/n)
term1 AFTER term2: term1 occurs after term2
term1 AFTER/n term2: term1 occurs n or less words after term2
~term1: Contains term1, also as part of a word
For convenience, some of these operators can also be abbreviated using commonly used symbols:
AND: &, &&, +
OR: |, ||
XOR: ^, ^^
NOT: !, Operators are evaluated in the following priority: parenthesis > phrase/hyphens > (NOT)
BEFORE/AFTER/NEAR/NEXT > NOT > AND/OR/XOR/EOR. Terms with same priority but without
parenthesis are evaluated from left to right.

WHITE SPACE HANDLING
Words linked by non-white separators (e.g., page-index or page_id) are treated like phrases put
into "quotes". Words separated by hyphens are handled like word1word2 OR "word1 word2".
Characters separated by dots are considered to be abbreviations and therefore handled like
words separated by hyphens, e.g., the term t.a.t.u is equal to "t a t u" OR tatu.
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EXAMPLES
By using any or all of the operators and rules laid out above you can create complex queries that
find the exact information you're looking for. Here are some example queries that show how the
operators are used.
Example: Devonian Dinosaurs
This query looks for all documents that contain the words "devonian" and "dinosaurs".
Example: (Steve NEAR Jobs) AND iMac BUT NOT MacBook OPT Pro
This query looks for documents that contain the words "Steve" and "Jobs" no farther ten words
away from each other, as well as the word "iMac" (no specific position relative to Steve and Jobs),
but not the word "MacBook". The word "Pro" does not need to occur, but if it does, the document
is ranked higher in the list of search results.
Example: Paracetamol NEAR (~effect OR impact) AND ((side OR second*) NEAR/2
~effect)
This query looks for documents containing the word "Paracetamol" near (within 10 words) to
words either starting with "effect" (and so also "effects") or "impact". In addition, the document
needs to contain the word "side" or any word starting with "second" located within two words
range of any word starting with "effect".

SEARCH PREFIXES

SEARCH PREFIXES

DEVONthink supports a wide variety of

Below is a list of the available search field

searchable attributes. These include common

prefixes as you would manually type into the

attributes, like names or tags, but also

search field or a script:

include document or DEVONthink-specific
items, like word counts or custom metadata
you've defined.

text: Text contents in a file.
metadata: The metadata for a file.
name: The name of a file. This is distinct

Similar to searching with Spotlight or some

from the filename and does not include the

other applications, the use of search prefixes

file extension.

is supported. These take the form of a

url: The associated URL.

prefix and a prefix operator, e.g., name:,

comment: Spotlight Comments.

followed by the search term. These prefixes
are automatically applied when you choose
criteria in an advanced search but they can
also be manually entered in the search field.

docAuthors: The name of the sender of an
email.
docAuthorEmailAddresses: The email
address of the sender of an email.
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docRecipients: The name of a recipient of

length: The number of pages in a file or

an email.

length of a media file in seconds.

docRecipientEmailAddresses: The email

size: The size of a file in bytes, KB, MB, or

address of a recipient of an email.

GB, e.g., size >= 50 MB.

docTitle: The title of a file. The title may be

wordcount: The number of words in the

distinct from its name, e.g., a song title for

contents of a file.

an MP3 file.

charactercount: The number of characters

docComment: The RTF-specific comments

in the contents of a file.

for a file.

hits: The number of times a file has been

docHeadline: A headline applied to some

viewed or opened.

files. Rare.

filename: The name of the file in the file

docSubject: The subject line from an email.

system, including the file extension.

docDescription: The description found on

extension: The extension of a file, e.g., txt.

some files, typically images.

This also supports an Any Extension option

docKeywords: The PDF or RTF specific

to filter filenames having or lacking an

keywords for a file.

extension.

docOrganization: The company specified in

kind: Supports any, group, smartgroup,

imported links or vCards from the Contacts

tag, ordinarytag, grouptag, text,

application.

rtf, formattednote, markdown, html,

docCopyright: Copyright information in the

webarchive, xmlfile, propertylist,

metadata of a file.

image, pdf, quicktime, video, audio,

docAlbum: The album information from

bookmark, feed, news, script, sheet,

media metadata, e.g., MP3 files.

email, and other.

docComposer: The composer information
from media metadata, e.g., MP3 files.
docCreator: The process or application
used to create a file.
docProducer: The producer of a file, usually

Item prefixes: These special prefixes are
for state-based queries, like the locked or
indexed state of items. They all follow the
form of item:<specified state>, e.g.,

applied to media files.

item:locked. However, when choosing

aliases: Aliases applied to a file.

toolbar search, choose the Marked option for

tags: Tags applied to a file.

the Flagged, Unread, and Locking states.

label: The color label of a file, from 0 (no
label) though 7 or by name, e.g., Important.

criteria in the Advanced options of the

The search prefix item: is still shown these
options.

rating: The star rating of a file, from 0

Flag: The flag state of a file. Supports

(unrated) through 5.

flagged or unflagged.

width: The width of a document in points,

Unread: The unread state of a file.

i.e., the width multiplied by 72.

Supports read or unread.

height: The height of a document in points,
i.e., the height multiplied by 72.
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Locking: The locking state of a file.

md_zipcode: The postal code detected in

Supports locked or unlocked.

the geolocation data for a file.

Item: A special item supporting instance

md_area: The state, province, or region

states: replicated, duplicated, indexed,

detected in the geolocation data for a file.

pending, or tagged.

md_locality: The city detected in the

additionDate: The date the file was added

geolocation data for a file.
to the database.

Custom Metadata: Any custom metadata

creationDate: The date the file was

attributes defined in See also p. 163ff are

created.

also available as search prefixes. The search

modificationDate: The date the file was

prefix you will type is a concatenated form

last modified.

of the attribute's name, prefixed with md. For

openingDate: The date the file was last

example, an attribute of Total Cost would

opened.

have a search prefix of mdtotalcost.

dueDate: The due date set in a Reminder
for a file.
md_attachments: The number of
attachments in an email or the number of
resources added to an RTFD file.
md_annotationcount: The number of
annotations set in a PDF file.
md_encrypted: The encrypted state of
a PDF. This is a Boolean value denoted
numerically, e.g., md_encrypted==1 when a
file is encrypted.
md_incomingItemLinkCount: The number
of item links to a document from other
documents in DEVONthink.
md_outgoingItemLinkCount: The number

There are also two special prefixes you can
use:
scope: This limits where you are searching.
It supports selection (the current group
or database), referring to a database by
name (in quotes), and inboxes. If no scope
is specified, the search applies to all open
databases. When used, scope: should be
the last parameter in the query.
any: When used, this allows you to specify
whether to return results matching any of
the criteria. This can only be used when
specifying more than one search prefix,
e.g., tags and filename.

of item links to other documents present in

Example:

a document.

additionDate>=2019-03-10

md_language: An abbreviation of the

scope:selection

detected language in the contents of a file.

tags:sync; methods scope:"Tech

For a list of values, select a language in the

Stuff"

criteria and note the abbreviation to use.

any: name:test OR imprint {any:

md_country: An abbreviation of the

tags:blue; red}

country in the geolocation data for a file.
For a list of values, select a country in the
criteria and note the abbreviation to use.

Sub-criteria searches: Yes, you may have
noticed in the last example a tags search in
curly braces. This creates sub-criteria for the

DEVONthink 3.7 Documentation, page 222

search. This obviously extends the search

:~ is equal to contains. (The tilde is the

options to allow creating even more complex

second key down on the top left of an English

forms.

keyboard.)

PREFIX OPERATORS

Example:
Subject begins with party →

Many times prefixes end with a colon, e.g.,

docSubject:<party

tags: but some use other forms, depending

Locality ends with field →

on the available options in the criterion.

md_locality:>field

For example, words can "begin with" some

Name contains tech → name:~tech

characters, but a size is greater or less than a
value. If you select a criterion you would see
what options apply. Use the keys below to
map the option to its operator.
Matches, Is, Is Not:
: is equal to the term matches. With stringsbased queries, it allows for wildcards to
be used. It is also used for state-based
queries, like Kind. The negated form, :! is also
supported.

Number Matching: In addition to the == and
!= operators, numbers can also use these
operators:
< is equal to the term is less than.
<= is equal to the term is less than or equal
to.
> is equal to the term is greater than.
>= is equal to the term is greater than or
equal to.

== is equal to the term is. This must be an
exact match of the search term. These can
be used in strings and number-based queries.
The negated form, != is also supported.
Example:
Kind is Group → kind:group
Item is indexed → item:indexed
Item is not Replicated → item:!

Example:
Word Count is less than 1000 →
wordcount<1000
Size is greater than 10MB → size>10 MB
Hits is greater than or equal to 1 → hits>=1
Date Operators: These are operators used
with date-based queries, like the creation

replicated

date of files.

Extension is XML Document →

< is equal to the term before.

extension==XML
Language is not English → language!=en
String Matching: These are operators that are
used with string-based queries, like names or
text content. These queries also support:
:< is equal to begins with.
:> is equal to ends with.

<= is equal to the term before or on.
> is equal to the term later.
>= is equal to the term later or on.
:# is equal to the term within last number
of days. The negated form, :!# is also
supported.
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: is equal to the term is for date-based
queries. Supported date options are Today,
Yesterday, This Week, Last Week, This Month,
Last Month, This Quarter, Last Quarter, This
Year, and Last Year. The negated form, :! is
also supported.
Example:
Date Created is after January 31, 2019 →
creationDate>=2019-01-31
Date opened is not within last 5 days →
openingDate:!#5days

Date Due is not Today → dueDate:!Today
Date searching allows for some flexibility in
formats. Time is not a required parameter,
but can be specified. These searches are all
equivalent:
Example:
additionDate>10 march, 2019
additionDate>March 10, 19
additionDate>2019-03-10 08:30:00
-0500

TEMPLATES
DEVONthink comes with a number of built-in templates for general use. Use these templates to
add a task list, a quote, or whole group structure for project management to your database.
Templates are stored in the ~/Library/Application Support/DEVONthink 3/
Templates.noindex folder. In order to manage your templates, rename them, organize them
in subfolders, or delete them, you can quickly access this folder by selecting Data > New from
Template > Open Templates Folders. More templates are available by selecting Data > New from
Template > More Templates, or as extras in the Support Assistant or in the Extras sidebar.
A very useful thing you can do is add your own files to this folder, even if the files aren't directly
editable in DEVONthink. For example, you may have a specific Pages template you often use.
Open the template in Pages and save it into DEVONthink's Templates folder. Now you can add
documents to your database even more efficiently.

BUILT-IN TEMPLATES
DEVONthink comes with the following built-in templates, which serve as great examples of the
template feature.
Accounts & Passwords:
Email Accounts: Adds a sheet to record technical details of an email account details.
Online Account: Adds a sheet for storing website account details.
Serial Number: Adds a sheet for storing product serial numbers.
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Classifications:
Decimal Filing System: Adds ten groups for the decimal filing system used by many European
companies for filing (scanned) paper documents.
Dewey Decimal Classification: Inserts a group with sub-groups that builds the first levels of the
Dewey Decimal Classification. Use this feature for databases that contain knowledge spanning
many subjects.
Library of Congress Classification: Inserts a group with sub-groups that builds the first
levels of the Library of Congress Classification. Use this feature for databases that contain
knowledge spanning many subjects.
Education:
Cornell Notes: Adds a document that allows you to write notes in Cornell style on a topic of
interest. Available as Markdown or rich text documents.
Cornell Notes (Education): Adds a document that allows you to write notes in Cornell style for
a particular course and topic. Available as Markdown or rich text documents.
Lab Notes: Adds a document that allows you to create lab reports. Available as Markdown or
rich text documents.
References: Adds a sheet for recording citation information such a DOI, authors, journal,
publication year, etc.
Reference (from Bookends): Adds the reference selected in Bookends to your database.
Reference (from Endnote): Adds the reference selected in Endnote to your database.
Quotes: Adds a sheet for recording quotes along with the author, source, comments, etc.
Quote (from clipboard): Adds a rich text document for a quotation or citation. The clipboard
content is automatically inserted and, if it's an Internet address (URL), it is automatically made
clickable.
Articles: Adds a sheet for keeping track of articles.
Booklets: Adds a sheet for keeping track of booklets.
Books: Adds a sheet for keeping track of books.
Manuals: Adds a sheet for keeping track of manuals.
Proceedings: Adds a sheet for keeping track of proceedings.
Technical Reports: Adds a sheet for keeping track of technical reports.
Theses: Adds a sheet for keeping track of theses.
PubMed: Runs a query in PubMed and adds the resulting documents formatted as rich text
documents to your database.
Productivity:
Daily Journal: Adds Journal group with month and day subgroups, containing a file with a
daily quote, some news headlines, and space to write your thoughts. This template is a good
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example of smart templates. The journal is available in two separate templates: Text (rich text)
and Markdown.
Note: Adds a new note. If the clipboard contains text, it is automatically inserted.
Phone Note: Adds a new phone note, automatically inserting the current date and time.
Project: Adds a simple project group structure including an "About this project" document. The
smart template asks for a project name; retrieves your name, department, email address, and
phone number from your contact card; and adds this information to the "About this project"
document.
Task List: Adds a simple task list.
Weekly Review: Adds a formatted note displaying checklist items and space to review the
week.
Registers:
1--31: Adds 31 groups, numbered 1 through 31.
A--Z: Adds 26 groups, named A through Z.
Days of the Week: Adds groups for the days of the week.
Months: Adds groups for the twelve Christian months.
Smart Groups:
Email ... Videos: Adds smart groups displaying documents of a given kind.
Due or Flagged: Adds a smart group displaying flagged items or items with a due date this
week.
Last ...: Adds smart groups displaying documents modified within a given period.
Documents with Annotations: Adds a smart group displaying files with annotations, e.g.,
highlights.
Large Documents: Add a smart group displaying documents larger than 5 MB.
PDF (not searchable): Add a smart group displaying all PDF documents that don't contain
machine-readable text.
Star Ratings (1-5): Add a smart group displaying items with a rating of one or five stars.
Toolbar: By default this contains no templates. Add your own templates to ~/Library/
Application Support/DEVONthink 3/Templates.noindex/Toolbar. These can be added to
the DEVONthink windows using View > Customize Toolbar.
Note: Some of the included templates are just simple files. Others are smart templates,
packages that contain assets and scripts that provide powerful template generation. See the
Automation chapter for more information on them.
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METADATA
DEVONthink stores a large number of
metadata fields internally when importing
documents from the file system, e.g., from

Recipients
Recipient email addresses
Email addresses
Media and Publication Metadata:

PDF, RTF, MP3, EXIF/IPTC, HTML, and email
messages as well as from all files that deliver
metadata through the Spotlight metadata
importer. Here's a partial list of theoretically
supported fields:

Album
Composer
Contributors
Publishers
Editors

FILE METADATA
General Metadata:
Title
Headline
Subject
Creator
Producer

Organizations
MultiMarkdown Metadata:
title
description
author
comment
subject
organization

PDF Metadata:
Author
Title
Subject
URL
Keywords
RTF Metadata:

keywords
publisher
email
copyright
generator
dc.title
dc.creator
dc.subject
dc.description

Author
Title
Comment
Subject
URL
Keywords
Organization
Copyright

dc.rights
dc.contributor
dc.keywords
dc.publisher
og:title
og:description
geo.position
ibcm

Email Metadata:
Authors
Author email addresses
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CUSTOM METADATA
Another powerful feature of DEVONthink
is custom metadata fields. Specified in the
Preferences > Data, you can define fields that
are meaningful to you, your company, your
research group, or even your family!

Multi-line Text: Enter a small paragraph of
text. Line breaks can be typed by pressing
Option-Return.
Rich Text: Same as Multi-line text but
supports basic formatting, e.g., bold or
italic text.
Set: Similar to the Single-line text, this

When you create a custom metadata

shows a dropdown with values pre-defined

field, you give it a name. DEVONthink uses

for the field in the Data preferences.

this name to create an identifier for use

However, new values can't be entered

in automated processes. This identifier

outside the preferences.

is created automatically and cannot be

URL: Accepts any valid URL, including

changed.

filesystem URLs.
Link: A special dropdown that allows you to

Data Types: When you define a custom field,
you choose a data type for it. So what's a

choose an item in your databases. a link for
the chosen item is used.

"data type"? It's simply a kind of a value; like
"a" is a character and "42" is a (the!) number.

Note: The Countries and Languages lists

The following data types are supported,

are lengthy, but not necessarily exhaustive.

including any interface items associated with

For Multi-line Text and Rich Text, only one

them, e.g., checkboxes or dropdown menus:

line will be displayed in its column in the
item list.

Boolean: This is a true or false value.
Displayed as a checkbox.

Predefined Custom Metadata: In Preferences

Countries: A dropdown menu providing a

> Data, we have provided some custom

list of country names.

metadata fields to get you started. These are

Languages: A dropdown menu providing a

ready to use and explore and serve as great

list of languages.

examples of the data types discussed above:

Integer: A whole number, e.g., with no
fractional part, like 17.
Decimal Number: A fractional number,
represented with a decimal point.
Date: Can be specified as Date & Time or
Date.
Identifier: Any alphanumeric value,
specified as needed, e.g., a customer or
patient number.
Single-line Text: A dropdown providing a
list of terms you defined for the field in the
Data preferences. You can also type in a
new value.

Date
Company
Author
Abstract
Status
Serial Number
ISSN/ISBN
Digital Object Identifier (DOI)
PubMed ID
PMC ID
Barcode
Format
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Category

File Name: The filename in the file system.

Subcategory

File Extension: The extension of the file.

Genre

Kind: The kind of the file, e.g., group or rich

Country

text document.

Language

URL: The URL in the Info pane.

Price

Location: The location in the database; e.g.,

Tax

/Inbox/Research.

Tip

Tags: Tags applied to the file.

Decimal

Digital Object Identifier: The unique digital
object identifier of the file, if available.

PLACEHOLDERS

Item Link: A universal URL referencing the
document.

One of the most powerful features of
DEVONthink is the ability to insert data

Index: This is a number that increments

dynamically. A placeholder is a bit of code

based on the number of items being

DEVONthink interprets when used in these

processed by a smart rule.

scenarios, replacing it with a specific value.

Counter: Similar to the Index, this is a zero-

You may have an imprint with a Name

padded incrementing number.

placeholder defined in the title. When the

Document Amount: This is an amount

imprint is used on a PDF, the placeholder is

detected in the name or content of

converted to the name of the file!

documents, like receipts or invoices. Often
used with smart rules.

To extend the possibilities even further,

Document String: This is a string detected

you can combine static text and multiple

in the name or content of documents.

placeholders to achieve truly custom results.

Typically used with smart rules.

You can use these in smart rules and the

Bates Number: Inserts a Bates number.

command Tools > Batch Process, in alarms on

Page Count: The total number of pages in

Reminders, custom imprints on images and

the document.

PDFs, and in templates for creating WikiLinks
documents.

Group Name: The name of the group
containing the document, e.g., /001/a/b/

Below is a list of placeholders currently

myfile.txt would report b as the group

available:

name.

Name: The name or title of the document.
Proposed Name: A suggested name derived
from a document's title or from the first
line of the document if no title is present.
Aliases: Any aliases applied to the file.
Finder Comment: Any Finder comments

Top Group Name: The name of the top level
group in the root of the database, e.g.,
/001/a/b/myfile.txt would report 001 as
the top group name.
Database Name: The name of the database
containing the document.

applied to the file.
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Database Path: The filesystem path of the

short or long formats as well. You can also

database.

choose specific parts of the date or time, e.g.,

Attachments: The number of attachments

the month, year, or hour only.

in a file.
Clipboard: Inserts content currently on the
Language: An abbreviation of language

clipboard. It can be inserted as rich text,

detected in the document's indexed

plain text, or a link, depending on the type

contents.

of data and the file the data is inserted

Country: The country in the geolocation

into.

data for a file.

Predefined Author: This is the Author

Postal Code: The postal code derived from

specified in DEVONthink's Preferences >

the geolocation data for a file.

Editing.

Administrative Area: This is state, province,

Username: The shortname of the current

or region in the geolocation data for a file.

macOS account.

Locality: The city in the geolocation data

Full Username: The longname of the

for a file.

current macOS account.

Tab: A tab character.
Line Break: A line break (return) character
for multi-line text.

Organization: This is the company name, if
defined by the (Me) contact card in macOS
Contacts.
Email Address: The primary email address,

Current Date: Today's date.

as defined by the (Me) contact card in

Addition Date: The date the file added to

macOS Contacts.

the database.

Host: The hostname of the machine.

Creation Date: The date the file was
created.
Modification Date: The date the document
was last modified.
Document Date: This is a date detected in

Properties: These are potential metadata
properties found in the current file. A more
extensive listing of these can be found in the
Metadata section.

the document's contents, e.g., in a receipt.

Custom Metadata: This menu lists any

For PDFs only the first four pages are used.

custom metadata fields applied to the file.

Newest/Oldest Document Date: The
newest or oldest date detected in the
document. For PDFs, only the first four

SMART RULE EVENTS AND
ACTIONS

pages are used.
Smart rules in DEVONthink provide many
When using dates, you can choose the format

powerful actions and events that can trigger

as defined in System Preferences > Language

these actions. Below is a list of the available

& Region > Advanced > Dates. The default

options for both.

is the medium format, but you may choose
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EVENTS
When an action is triggered is almost as
important as the action itself. Actions can be
triggered when any of these events occur:

On Import: Runs when documents are
added to the specified location.
On Clipping: Runs when documents
are added via clipping, e.g., via menu
commands, the Sorter, DEVONagent,

On Demand: Run only when Apply Rule is

bookmarklets, or AppleScript.

selected in a contextual menu or Tools >

On Download: Runs when items are

Apply Rules.

downloaded via DEVONthink's Download

On Startup: Runs when DEVONthink

Manager.

launches.

On Scan: Runs after a scanning operation

Before Synchronization: Runs all actions

has completed.

before DEVONthink begins synchronizing

On OCR: Runs after an OCR operation has

to any sync location.

completed.

After Synchronization: Runs all actions

On News: Runs when an RSS feed refreshes

after DEVONthink completes synchronizing

and receives new articles.

to any sync location, i.e. all uploads,
downloads, and changes are committed.
On Quit: Runs when DEVONthink quits.
Every Minute: Runs the specified actions
every minute.
Hourly/Daily/Weekly: Runs the specified
actions on an hourly, daily, or weekly
schedule.
On Workdays: Runs on Monday through
Fridays.
On Weekends: Runs on Saturday or Sunday.
On Creation: Runs when a new document
is created in the specified location. To
trigger actions when taking notes or screen
captures with the Sorter, choose Via
Sorter.
Before Saving: Runs before saving a
matched document.
After Saving: Runs after saving a matched
document.
On Imprinting: Runs when any matched
document has been imprinted.

On Upload: Runs when an item is uploaded
through DEVONthink's web server.
On Open: Runs when a matching item is
opened in a new document window or
viewed in a main window.
On Open Externally: Runs when a matching
file is opened in an external application.
On Launch URL: Runs when the URL
associated with the item is launched.
On Reminder: Runs when an alarm set on a
matching item's Reminder comes due.
On Renaming: Runs after matched items
are manually renamed.
On Moving: Runs when matched items are
moved to the specified location.
On Classifying: Runs when matching items
are classified by DEVONthink.
On Tagging: Runs when matched items are
tagged
On Labelling: Runs when a label is added to
or changed on an item.
On Replicating: Runs when matched items
are replicated.

DEVONthink 3.7 Documentation, page 231

On Duplicating: Runs when matched items

Speak Text: Using your computer's voice

are duplicated.

synthesis, it will speak the message you

On Moving into Database: Runs when

specify.

indexed items are moved into the

Play Sound: Plays a selected system alert

database, becoming imported items.

sound.

On Moving to External Folder: Runs when
imported or created items in a database
are moved to external locations, becoming
indexed items.

Send Mail: Enter email addresses to send
the matching items. This can be a commadelimited list of addresses, names, or enter
the name of a group you've defined in your

You can and and remove multiple event

contacts.

triggers by pressing the + or - buttons. Fox

Add to Reading List: Add the matched

example, you could use an On Import and

items to the Reading List.

an On Moving event trigger to act on files
imported or moved into it.

ACTIONS

Open Externally: Open the matched file in
the system default application.
Launch URL: Open the URL associated
shown in the Info Inspector & URL.

The power in smart rules is the actions.

Check Bookmarks: Checks the URL of the

DEVONthink provides actions that cover

matched items. Any issues with the URL

simple tasks, e.g., prefixing a filename, all the

are reported in the Log window or the Log

way to ultra-powerful AppleScript injection

popover.

via external or embedded scripts. Since you

Execute Script: Execute External or

can chain multiple actions together, the

Embedded scripts. Embedded scripts are

possibilities are nearly endless. Here's a list of

created in a popup menu and only available

available actions:

to the smart rule they are created in. See

Bounce Dock Icon: Causes DEVONthink's

also p. 197ff
dock icon to bounce. This will only trigger

Item scanning: The next two actions allow

when DEVONthink isn't the active

you to scan the name or text of a document

application.

and use the results when found. Each of the

Display Notification: Shows a message

actions also has a parameter you specify

via the Mac's Notification Center.

for the type of data you're scanning for.

Notifications need to be enabled in System

These actions and parameters can be used

Preferences > Notifications for Display

with subsequent actions that support

Notification to operate correctly.

placeholders, e.g., Scan Text: Date →

Display Alert: Shows a message in an alert

Document Date with Change Modification

window.

Date. If the action returns no results, actions
using the results will not be executed.
However, unrelated actions in the smart rule
chain will be executed normally.
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Scan Name: Scans the name of the file.

Using the Regular Expression parameter,

Scan Text: Scans the contents of the file.

Bill To: ([A-Za-z0-9 ,]+) would

The following four parameters are used with
the Scan Name and Scan Text actions. With ,
, and , a prefix and/or suffix before/after the
wildcard has to be specified.
String: An asterisk (*) wildcard specifies
data to be captured. Other terms added
will be used to help located the desired
string. In subsequent actions, use the
Document String placeholder to represent
the captured string.
Date: Similar to String parameter, use the
desired format of the Document Date
placeholder to represent the captured
string in subsequent actions.
Amount: Similar to String parameter,
use the desired format of the Document
Amount placeholder to represent the
captured string in subsequent actions.
Regular Expression: Items in parentheses

capture the name of the person or
company billed. \1 would be used in the
subsequent action.
Change Name/Aliases/Comment/Label/
Rating: Change the specific attribute of
the matched file. For items with an existing
attribute, e.g., a comment, a placeholder
will preserve the existing value.
Mark: Toggle the state of read/unread,
flagged/unflagged, and locked/unlocked.
Note you change more than one of these
attributes with one action, but you can
chain more than one Mark action in the
smart rule.
Change Creation/Modification Date:
Change the creation or modification date
of matched files to: current, addition,
creation, modification, or the document
date.

are captured; items outside parentheses

Add Tags: Add tags to the matched files.

are ignored. You can specify multiple

As you type, tags from all open databases

captures in an expression. Using the

will be suggested. Press the comma key to

captured text in subsequent actions is

commit the tag.

specified by using backslash, \, and the

Add Tags from Document: Adds existing

number of the capture, starting at 1. Note

tags if they are detected in the matched

we use Apple's NSRegularExpression which

document's contents.

supports the ICU regular expression syntax.

Remove Tags: Removes specific tags you

Example:
Using the String parameter, Invoice *
would capture 0012345 in a file named
Invoice 0012345..
Using the Date parameter, * would
capture the date in a file named
2020-01-01.
Using the Amount parameter, $* would
capture the dollar amount detected.

enter.
Remove All Tags: Removes all tags from the
items.
Tags: Adds or converts tags to matched
documents from these commands:
Convert HashTags, Convert Keywords,
Convert Properties, Convert Geolocation,
Add Tags to Images, and Scan Barcodes.
(See the View menu for more information
on these options.)
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Move/Replicate/Duplicate: Move, replicate,

with OCR. This action does not generate

or duplicate a matched file to a chosen

new files.

location.

Imprint: Apply the selected imprint to any

Duplicate & Continue: Duplicates matched

matching files, if possible.

files and applies subsequent actions to the

Custom Metadata: If you have specified

copies.

custom metadata fields, you will have

File: Allows you to file items into a group.
Specify subgroups using a forward slash,
e.g., 2019/DEVONtech would create or file
into the DEVONtech subgroup of a 2019
group in the current group. You can use

options to change values with an action.
For example, if you had a Boolean field
named "Done", you could have the action
set this field to true when the action is
triggered.

placeholders to define the location.

Move to Trash: Move the item to the

Classify: Using our AI, this will attempt

database's trash. The items are not

to move any matched files to an apropos

removed from the database until the trash

location. Failures to classify files are noted

is emptied.

in the Log window.

Delete: Be very cautious with this option.

Move Into Database: Moves indexed items
into the database, essentially importing
them. Note this removes the file from the

Delete truly deletes a file. It is not sent to
the database's trash. It is not sent to the
Finder's trash. It is completely deleted.

original location in the filesystem.
Move To External Folder: For an item

SCRIPTS

located in an indexed group, this moves the

Below is a list of the DEVONthink supplied

file to the indexed folder in the Finder.

scripts, segregated by the menu items in the

Convert: Attempts to convert files
into plain/rich text, formatted notes,

Script menu:
Comments:

Markdown, HTML, web archive, or PDF.
Convert & Continue: Converts files and

Append Selected Text: Adds the selected

applies subsequent actions to the copies.

text to the comments of the current

Thumbnails: Adds, updates, or removes a

document.

matched file's thumbnail.

Assemble: Collects the comments of the
selected documents and creates a new

OCR: This will perform OCR on a file, if

document listing them.

possible. Choose a format to generate

Convert to Tags: Converts the tag

a new file in the selected file type. Note

contained in the comments field to real

the file type selected will override the

tags if the comments field of the selected

option set in Preferences > OCR > Convert
incoming scans to. Choose Apply to
convert a matched file directly to a PDF
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document contains tags separated by
commas.
Speak: Speaks the comments of the
selected documents.
Data:
Move Duplicates to Trash: Moves all
duplicates of the selected document to the
trash.
Find & Remove Similar Contents: Finds and
removes similar documents.
Group With Duplicates: Creates a group
with duplicates of the selected documents.
Group With Replicants: Creates a group
with replicants of the selected documents.
Verify & Optimize Databases: Runs a
verification on all open databases and
optimizes them if they verify successfully.
Errors are alerted and logged to Window >
Log.
Download:
Linked Images of Page: Adds linked images
of a displayed web page to the database.
Images of Page: Adds the images of a
displayed web page to the database.
Links of Page: Adds links contained on a

Execute:
AppleScript: Executes an AppleScript
script.
Perl: Executes a Perl script.
Shell: Executes a shell script.
Export:
Listing: Saves a UTF-8 text file containing
a text listing of the names of all contents/
groups of the current database.
Daily Backup Archive: Creates a
compressed backup (.Zip) of the current
database in ~/Backup. All backups are
include a datestamp in the filename for
easy tracking and identification. These can
be useful for copying to external media or
uploading to a cloud service as a secondary
backup strategy.
Feeds:
Nature -- Hubble News: Downloads the
latest Hubble news.
iTMS -- Added Albums: Downloads covers
of albums recently added to the iTunes
Music Store.
Format:

displayed web page to the database.
Download as…: Converts bookmarks to
one of these formats: Formatted Notes,
HTML Pages, PDF Documents (One Page or
Paginated), and Web Archives

Body Normal: Formats selected text as
"Body Normal".
Body Small: Formats selected text as
"Body Small".
Header Capitalized: Formats selected text

Edit:
Count Characters: Counts the characters
in the current selection.
Count Words: Counts the words in the
current selection.

as "Header Capitalized".
Header Main: Formats selected text as
"Header Main".
Header Secondary: Formats selected text
as "Header Secondary".
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Source: Formats selected text as "Source".
Reset Spacing: Resets the line and
paragraph spacing of selected rich text.
Images:
Copy Info to Comment: Copies basic image
info to the comment field.
Flip Horizontal / Vertical: Flips the image
horizontally/vertically.
Rotate Left / Right: Rotates the image
left/right.
Landscape to Portrait: Rotates only
landscape images to portrait.
Portrait to Landscape: Rotates only
portrait images to landscape.
Scale to 1024 pixels: Scales the image to

Reminders:
Add as Event to Calendar: Adds a new
event to Calendar linking back to the
selected item in DEVONthink.
Add as To Do to OmniFocus: Adds
the selected item as a to-do item to
OmniFocus.
Add as To Do to Reminders: Adds
the selected item as a to-do item to
Reminders.
Add as To Do to The Hit List: Adds the
selected item as a to-do item to The Hit
List.
Add as To Do to Things: Adds the selected
item as a to-do item to Things.

1,024 pixels.

Note: These are scripts for integrating with

Scale to 200%: Scales the image to 200

external applications. For scripting internal

percent.

reminder scripts, see the Reminder Scripts

Scale to 50%: Scales the image to 50

section of the chapter about automation.

percent.
Import:

Rename:
Append Selected Text: Appends the
Del.icio.us: Imports your del.icio.us

selected text to the title of the currently

bookmarks. The descriptions are used to

selected item.

name the imported bookmarks; the notes

Replace Text: Replaces a text passage in

and the tags are added to the comments.

the titles of selected documents.

If the keychain does not contain a key for

To Webpage Title: Sets the titles of the

del.icio.us, dialogs pop up allowing you to

selected documents to the names of the

enter the user name and password.

web pages pointed to by their URL fields.

Man Page: Imports a UNIX manual page as

To Subject: Sets the titles of the selected

a PDF document.

documents to the subject lines of the email

Perldoc: Imports the documentation of Perl

messages if the selected documents are

pages, modules, functions, or programs.

email messages.
Sheets:
Add Multiple Records: Adds up to 999
empty records to a sheet.
Column Sum&Mean Value: Calculates the
sum and average of a table column.
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Row Sum&Mean Value: Calculates the sum
and average of a table row.
Check sums in last column: Checks the
sums in the last column on validity.
Tabs:

WEB SITE EXPORT TEMPLATES
For exporting selected groups or files as
a web site, DEVONthink uses templates
available in ~/Library/Application
Support/DEVONthink 3/Websites/ to
create HTML files from documents. You

Open Bing: Open a new tab for the Bing
search engine.
Open Google: Open a new tab for the

can choose the template in the save dialog
that appears when you use File > Export > as
Website.

Google search engine.
Open Location: Open a new tab for a

In the markup of HTML templates, the

location you specify.

following placeholders can be used:

Note: The last script does no URL

%charset%

validation, though DEVONthink's dictionary

%comment%

makes it possible to script this too.

%content%
%databasePlusLocation%

Thumbnails:

%modification%

Flip Horizontal / Vertical: Flips the

%stylesheet%

thumbnails of selected documents

%title%

horizontally/vertically.

%url%

Rotate Left / Right: Rotates the

%tags%

thumbnails of selected documents left/
right.
Landscape to Portrait: Rotates only
landscape thumbnails to portrait.
Portrait to Landscape: Rotates only
portrait thumbnails to landscape.
Note: While these scripts work with all

These placeholders will be replaced with
actual information during the export.
The placeholders will only be replaced in
documents that are converted to HTML
during export, namely plain text, rich text,
Microsoft Office/OpenOffice documents,
scripts, chat logs, and sheets.

image formats including PDF, they should
not be used for PDF documents. They will

HIDDEN PREFERENCES

only work on the first page of the PDF and
destroy all embedded metadata.

There are a few settings in DEVONthink that
you cannot set through the Preferences

Caching: All scripts in the Scripts menu

window. Most of them are intended to

are cached, meaning their properties are

facilitate customer support but they might

persistent until you quit and relaunch the

be interesting for you as well.

application or DEVONthink automatically
updates the menu, e.g., after adding or
removing scripts.
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Note: These hidden preferences are not an

2014-07-31 08:25:27.101

official feature and could be changed or

defaults[21950:3312262] The domain/

removed with any update.

HOW TO ACCESS THE HIDDEN
PREFERENCES

default pair of (/Users/eb/Library/
Preferences/com.devon-technologies.think3
AdditionalPlainTextExtensions) does not
exist
# This "error" shows there are no

All hidden preferences are simple on/off

additional formats specified.

switches. You set and unset them using the

$ defaults write com.devon-

"defaults" command in the Terminal. To set

technologies.think3

preferences via the Terminal DEVONthink

AdditionalPlainTextExtensions -

must not be running or it will overwrite your

string .otl.todotxt

changes when you close it.
To set a preference using the Terminal, noting
the commands are case-senstive, they are
written like this:
Terminal:
$ defaults write com.devontechnologies.think3
ShouldScaleAttachedImages -bool TRUE

$ defaults read com.devontechnologies.think3
AdditionalPlainTextExtensions
.otl.todotxt

AVAILABLE HIDDEN PREFERENCES KEYS
AdditionalPlainTextExtensions: Adds
additional plain text extensions, separated
by dots.

The above command activates the preference

AdditionalXMLExtensions: Adds additional

with the key "ShouldScaleAttachedImages".

XML file name extensions, separated by

Change TRUE to FALSE to deactivate it. Use

dots.

any of the preferences keys below to activate

BatesNumberDigits: Specifies the number

or deactivate them.

of digits used for the placeholder.

There is a special preference to
allow DEVONthink to detect other
plain text formats as plain text:
"AdditionalPlainTextExtensions". As it
replaces the list of additional plain text
extensions we recommend that you read the
current list first (empty by default) before
adding your own to the end of the list.
Terminal:
$ defaults read com.devontechnologies.think3
AdditionalPlainTextExtensions

CounterDigits: Specifies the number of
digits used for the placeholder.
DisableActivityWindow: Disables
automatically showing/hiding of the
Activity window.
DisableAutomaticDeconsolidation:
Inhibits items added to indexed groups in
DEVONthink from automatically moving
out to the indexed Finder folder.
DisableAutomaticUpdatingOfIndexedItems:
Disables automatic updating of indexed
items.
DisableBadgeLabel: Disable the badge label
on DEVONthink's Dock icon.
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DisableFileSystemEvents: DEVONthink no

MonospacedSidebarFont: Use a

longer listens to file system events.

monospaced system font in the sidebars of

DisableFinderTags: DEVONthink no longer

main windows.

imports or exports Finder tags.

MonospacedViewFont: Use a monospaced

DisplayGroupsInPreviewPane: DEVONthink

system font in the item list of main

will display the contents of selected

windows.

groups, smart groups, and feeds in the

PlainTextIsMarkdown: Treat all plain text

view/edit pane of main windows. The

files as markdown.

preview only displays files, not groups.

RichNotesWithoutAttachments: Services

DisableHighlightColorMapping: Uses the

create RTF instead of RTFD.

same colors when highlighting documents

ShowAdditionalInfoInPathBar: Shows

in dark and light mode.

some details about the selected item in the

DisableTagAutocompletion: Disable

Information Bar.

displaying the popup of tag suggestions

SyncDebugLog: Enable additional sync

when entering tags, e.g., in the Tags bar.

logging for debugging.

EnableApplicationFiles: Applications can

WindowToolbarStyleExpanded: Enable the

be imported/indexed.

expanded toolbar style on macOS Big Sur.

EnablePDFDrawing: Enables DEVONthink's

This shows the title bar above the toolbar

own drawing of PDF pages. This was

instead of the new unified default style.

a workaround for macOS Sierra and is
incompatible to macOS High Sierra.
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VERSION HISTORY
New

Improved

Fixed

Removed

VERSION 3.7
This release not only provides bug fixes and improvements of many kinds, but features more
extensions to Markdown handling. The first, a new hybrid Markdown source rendering: WYSIWYG
editing. While editing your Markdown, you will see bold characters embolden, italics italicize,
etc. in the source. DEVONthink also now supports transclusion, allowing the display of another
Markdown, plain text, or HTML document's content in a Markdown document. Additionally,
DEVONthink indexes certain MultiMarkdown metadata types and makes them usable with smart
rules, batch processing, and automatic tag assignment.
Among the other changes, the Sorter has shortcut keys in the Screen Capture view and a
shortcut for the clutter-free option in the Web Clip view. Autocompletion of square bracket
WikiLinks searches anywhere in an item's name, and you can create WikiLinks in the Annotations
inspector. We have improved handling and deleting RSS articles as well as the maintenance
routines that allow for some more valid types of zero-byte (empty) files. On the sync side we
made some changes to reduce issues with Bonjour timeouts. And for the AppleScripters, we
added some new commands, including one to automate summarizing document highlights.
The Markdown source view now supports simple WYSIWYG editing for: bold, italic, underlined,
strikethrough, highlighting, headers, code blocks, metadata headers, subscript, superscript,
blockquotes, and links. This includes support for Roam, Obsidian, and iA Writer syntax. Also,
the WYSIWYG source is displayed when viewing a Markdown annotation in the Document
> Annotations inspector. Enable or disable WYSIWYG editing in Preferences > Media >
Markdown (enabled by default).
Markdown documents now support file transclusion to display other documents' contents
inline in a document. This option supports plain text, Markdown, and HTML documents.
Enclose absolute and relative paths (with or without the file name extension), absolute file
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system paths, or item links in double braces, e.g., {{/Inbox/colophon.md}} to transclude
them or use Obsidian's ![[myFile.md]] syntax. You can transclude documents recursively.
Added option Click on links opens them externally to Preferences > General > Interface to
enable opening links in document text in the default application for their scheme. Use Shiftclick to open and activate the default application. Note that you can still use Commandclick or Option-click to open links in new tabs or to add them to the Download Manager,
respectively.
Added alternate menu item Open Database in New Window to the Navigate sidebar's
contextual menu and the Action toolbar menu. Hold the Option key to access this new option.
For use with favorited items in open databases, added a new Reveal command and extended
the contextual menu of the Navigate sidebar and the toolbar Action menu.
Added Remove immediately instead of moving to the trash option to Preferences > RSS
(disabled by default).
Added Remove command to the URL field in the Info inspector and the Custom inspector of
the Pro and Server editions.
Added shortcut keys ⌘1 through ⌘3 to the Screen Capture and Web Clip views of the Sorter.
Also added the shortcut ⌘F to the Clip to DEVONthink view to quickly select the Clutter-free
option.
Added a Preview button to the Clip to DEVONthink view to try to preview the clipped data.
This can be useful in previewing the decluttering layout or whether any login issues would
cause troubles.
Added a default Markdown annotation template to the Document > Annotations inspector.
Added Thumbnails > Create/Update/Remove smart rule actions.
Added Change URL action to smart rules and batch processing. You can use it to remove a
document's URL as well.
Added new %recordLink% placeholder. Also available in Insert Placeholder submenus of
contextual menus (e.g. in smart rules and batch processing). In addition, %documentName% and
%documentLink% can be used instead of %recordName% and %recordLink%.
Added color and exclude from Wiki linking to the AppleScript properties of records.
Currently the color property only applies to tags.
Added summarize highlights of AppleScript command.
Markdown documents in the Document > Annotations inspector or created via Tools >
Summarize Highlights > Markdown now support the syntax of Roam, Obsidian, and iA Writer.
The Editing bar supports subscript and superscript with Markdown documents and recognizes
alternate syntax for highlighting and strikethrough.
Certain MultiMarkdown metadata is now indexed and therefore searchable and viewable,
e.g. in the Document > Properties inspector or in List view columns. You can also use this
information in smart rules or for tagging via Data > Tags or the Preferences > Import > Tags
options. The supported keys are listed in the Appendix > Metadata section.
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Checkboxes in Markdown documents work also in nested lists and lists containing links.
The conversion of rich text to Markdown supports images and adds them as base-64 encoded
data URLs.
Pasting rich text containing only a URL, e.g., copied by the Messages app, into Markdown
documents no longer escapes brackets and parentheses.
Completion of automatic Wikilinks using square brackets now searches the complete title of
items for the entered string if it's longer than two characters.
Updated MultiMarkdown to version 6.6.0 and improved the Markdown parser.
Searching in PDF documents doesn't jump to the first occurrence if you already selected an
occurrence.
Highlighting in PDFs now supports replacing highlights in already highlighted text, e.g.,
highlighting a passage, then highlighting specific words with another color.
Right-clicking or Control-clicking locations in the crumb trail of the Path bar opens a
contextual menu to open or reveal the item. In addition, Command-clicking an item in the Path
bar opens the item in a new window.
The Document > Annotations inspector now supports automatic WikiLinking in annotations. It
also hides the due date and the alarm when the reminder is set to Never.
In addition to long-pressing the back and forward buttons in the Path bar, you can right- or
Control-click the buttons to open the history popup. Hold the Command key while choosing
one of the history items to open it in a new window instead of the current one.
If Fuzzy searching is enabled in the toolbar search field options, searches for groups or tags
in the See Also & Classify inspector, the Navigation view of the Sorter, utility popovers, and
group selectors now ignore umlauts.
After revealing a search result or closing a search it's now possible to go back to the search via
the Path bar.
The search fields of the Tags filter, the Sorter's Navigation tab, the See Also & Classify
inspector, and utility popovers match aliases of items.
Local inboxes can be found in Go To and Move To popovers and group selectors by searching
either for the name of the inbox, Inbox by default, or a database's name.
Renamed the menu item "View > Columns" to View > List Columns to make it easier to assign
keyboard shortcuts to items in this submenu.
The height of the Tags field in the Info inspector is unlimited again.
The button to switch between the Editing and Navigation bars is now always visible.
Items in the trash which will be completely removed from the database by emptying the trash
are displayed using strikethrough.
Improved toolbar icon appearance for dark mode in macOS Catalina.
Updating indexed items manually now removes locked items if they no longer exist in the file
system, otherwise this causes missing files to be reported.
Moving external folders into a database logs an error if a folder isn't empty.
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In the case of broken RTFD data, e.g., provided by other apps to services or copied to the
clipboard, DEVONthink now tries to store an RTF version instead.
New HTML pages created via Data > New now have default content and use the default font
for rich text and notes set in Preferences > Editing.
Improved default content of formatted notes created via Data > New.
File > Import > Notes from Evernote uses the icon of Evernote Legacy, if available. It also
remaps note links to item links, if the destination of a note link is part of the import. Instead of
"No notebooks", a more useful error message is now logged after trying to import notes from
Evernote 10.x.
Improved recognition of document dates in case of Australian dates dd/mm/yyyy.
Item links which were converted to lower case by third-party apps are now supported too.
Improved compatibility of the feed parser with unusual URL encodings, like
http:&#x2F;&#x2F;.
Improved handling of already downloaded articles and reduced number of error messages that
an RSS feed is invalid.
The Log window and Log popover merge identical but not yet viewed entries to avoid too
many redundant messages, e.g., in the case of databases that need to be repaired for sync.
Improved error logging in case of items which can't be moved to other databases due to
missing files.
Improved maintenance algorithms when verifying databases to allow for more valid types of
zero-byte files.
More efficient monitoring of filesystem events.
More reliable reminder handling.
More reliable creation of unknown file types via AppleScript.
Improved overall reliability and performance.
Pro — Item links in rich text custom metadata are now indexed, too, and supported by the
Document > Links inspector.
Pro — Copying selected rows in the Concordance > List inspector now copies only the visible
columns, uses localized column titles, and honors the column order for tab-separated text. If
desired, use Data > New with Clipboard to create a sheet in DEVONthink.
Pro — Improved sorting of dates in custom metadata.
Sync — Added a file consistency check while importing files downloaded from sync locations.
Files which are empty but shouldn't be are logged, marked as pending, and skipped so that
only their metadata is imported. This ensures that a verification of the database doesn't fail
afterwards and that the sync isn't blocked.
Sync — Better progress indication of and added the possibility to cancel verification of sync
stores.
Sync — Improved keep-alive handling of Bonjour connections to reduce timeouts.
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Sync — Improved handling of rate limiting when downloading data from CloudKit sync
locations.
Sync — Feeds are now always deleted even if they still contain news. Otherwise a feed deleted
on computer A wouldn't be deleted on computer B by the sync if the feed on computer B
contains additional items due to a refresh of the feed.
Sync — Automatic sync attempts are made less frequently in case of issues blocking the
synchronization, e.g., a busy or read-only database. This also reduces the number of logged
error messages.
Sync — Dropbox timeouts are no longer unnecessarily reported when awakening a device.
Sync — Improved reliability of sync stores.
The current tab or the view/preview pane no longer resets after starting a search returning
multiple results.
List view column sizing wasn't always handled correctly on macOS Big Sur. Fixed.
The view or preview handling in the global inbox had minor issues. Fixed.
Videos and bookmarks in Cover Flow view didn't work correctly in macOS Catalina and later.
Fixed.
The Document > Properties inspector wasn't updated after saving modified Markdown or
HTML. Fixed.
The Search in drop-down menu of local smart groups was shown as empty and also wasn't
limited to the current database. Fixed.
The background color of the Take Note view of the Sorter was sometimes incorrect when
switching between light and dark modes. Fixed.
Tags sometimes could be applied while typing them. Fixed.
DEVONthink sometimes incorrectly identified already used shortcuts in Preferences > Sorter.
Exporting templates via File > Export > as Template didn't support exporting the Tags group
and other selected items at the same time. Fixed.
Searching for phrases or proximity operators could fail if only certain data, e.g. using the text:
prefix, was searched. Fixed.
Smart groups and smart rules excluding subgroups and set to search the root of any database
could return too many results. Fixed.
Go > Next Unread Item didn't work if the next unread item was in a different database using
columns view or if Inbox, Tags, or Trash groups were selected in the Navigate sidebar. Fixed.
The Navigation bar could display incorrectly with newly created HTML pages or formatted
notes. Fixed.
Syntax coloring of HTML or XML files wasn't always shown immediately after opening a
document or leaving full screen mode. Fixed.
Conversion of rich text to Markdown could create unnecessary code blocks. Fixed.
Link annotations in PDFs covered by other annotations weren't detected or active. Fixed.
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A local Inbox inside the Global Inbox could be created when syncing with previous releases
of DEVONthink To Go. This extraneous inbox was invisible if Unify Inboxes was enabled in
Preferences > General > Sidebar. Note that it can be ungrouped, if found. Fixed.
Changing the name of the global inbox on another device and synchronizing or via AppleScript
could rename the database on disk and cause a new inbox to be created. Fixed.
Automatically generated thumbnails of bookmarks overwrote custom user-added icons. Fixed.
Document dates having a two-digit year in the range 70 through 99 weren't properly
recognized. Fixed.
When moving items to different databases on other computers or devices, incoming item links
weren't indexed. Fixed.
Moving or duplicating special groups, e.g. email messages, to other databases didn't retain the
type of the group. Fixed.
Merging a group containing items replicated in other groups removed the additional replicants.
Fixed.
Evernote notes containing multiple attachments could fail to import all the attached files.
Fixed.
Indexed folders were not always updated automatically after unzipping archives in them. Fixed.
Footnotes in Markdown documents were not indexed and automatic WikiLinks weren't
supported in them. Fixed.
The File Items Using @Destination in Name smart rule script didn't work with group
tags. Fixed.
The touch bar could cause rare crashes while setting up smart rule and batch processing in
macOS Big Sur. Fixed.
The Screen Capture view of the Sorter could cause multi-threading issues. Fixed.
The Sorter could crash on macOS El Capitan. Fixed.
Pro — Custom metadata, e.g. item links and URLs being item links, were not indexed and
therefore the incoming and outgoing documents were not marked or supported by the
Document > Links inspector. Fixed.
Pro — Dropping non-scanned content to the Import section of the Import > Image Capture
sidebar could cause a crash. Fixed.
Pro — Whole decimal numbers in custom metadata values were displayed as integers, i.e., no
trailing zero.
Sync — A Bonjour sync could cause a rare multi-threading crash. Fixed.
Sync — Moving indexed files into a database could sometimes cause garbage collection issues
with a sync store. Fixed.
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VERSION 3.6.3
This maintenance release provides modifications to address some issues with iCloud (CloudKit)
syncing. For the list makers, creating checkboxes is now supported in Markdown documents.
Importing from Evernote is faster when handling notes with attachments. And, of course, there
are the usual bug fixes and reliability improvements.
Added On Labelling smart rule event trigger. This is also supported in AppleScript.
Checkboxes are now supported by Markdown rendering and conversion. The syntax is - [ ] or
- [x] at the beginning of a line.
The Insert > Checkbox command in the Edit and contextual menus can now be used when
editing Markdown documents.
Pasting or dropping rich text into Markdown documents now attempts to convert the content
to Markdown syntax. The DEVONthink 3: Create Markdown Document service will also
attempt the conversion.
JavaScript is now internally automatically enabled to preview Markdown documents if
MathJax, Prism, or Mermaid support are enabled in Preferences > Media and JavaScript is
disabled in Preferences > Web.
Improved the behavior of the alternative command Data > Group Similar Items.
Improved the speed of importing of ENEX files and File > Import > Notes from Evernote with
notes containing many and/or large attachments, e.g., Noteshelf notes.
Moving an indexed group to another indexed group no longer changes the filename of the
group.
Limited the height of automatically resized text fields in the Info > General inspector as, e.g.,
long URLs could require a lot of space.
Improved VoiceOver support in the Document > Links inspector.
File > Verify & Repair Database and automatic verification before synchronizing databases can
detect and repair more issues.
Improved overall reliability.
Sync — Improved handling of retries and throttling related to temporary iCloud (CloudKit)
issues.
Sync — Improved reachability handling of iCloud (CloudKit) sync locations.
Sync — Improved overall reliability of, e.g., the deletions handling and import of pending items.
In light mode, the Take Note view of the Sorter could remain dark. Fixed.
When the Sorter is set as a docked tab, the Search shortcut set in Sorter preferences didn't
focus the search field of the Sorter. Fixed.
Rendering and conversion of Markdown textbundle files didn't display linked images from
within the bundle. Fixed.
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When multiple documents were selected, Tools > Summarize Highlights did not list the title of
each document in Markdown or rich text summaries. Fixed.
Closing the toolbar search did not always display the currently selected sidebar item(s). Fixed.
Double-clicking the header of the item list in List view could cause the selection to be opened
if the list view was not scrolled to the top. Fixed.
Renaming long file names in the item list in Column view displayed incorrectly on macOS Big
Sur. Fixed.
Setting a Yearly reminder in the Annotations & Reminders inspector could freeze the
application. Fixed.
Loading the Preferences > Imprinter preference pane did not work in some cases. Fixed.
Certain files added to the Inbox folder in the Finder were imported multiple times, e.g., OPML
or ENEX files. Fixed.
Formatted notes could unexpectedly lose focus on macOS Big Sur. Fixed.
A rare multi-threading issue after installing the OCR engine could crash the app. Fixed.
Scripts executed by smart rules after synchronization didn't always work as expected. Fixed.
The relevance of search results set via AppleScript was undefined and could affect the sorting.
Fixed.
Sync — The encryption key of iCloud (CloudKit) sync locations was not added to the keychain.
Fixed.
Sync — The garbage collection of iCloud (CloudKit) sync stores could cause temporary 'Missing
manifest' issues. Fixed.
Sync — The global inbox was never marked as needing sync after receiving push notifications
and so not immediately synchronized if the schedule was automatic. Fixed.

VERSION 3.6.2
This release includes a new sync option: CloudKit. It's a single-stage sync, similar to Dropbox,
but works with iCloud and is just as simple to set up. Additionally, we have reduced resource
consumption with sync.
For Markdown users, DEVONthink uses CriticMarkup more extensively for formatting,
conversion, and when creating summaries. We added support for some alternate highlighting and
strikethrough Markdown syntax as well as support for Mermaid.js so you can create diagrams in
Markdown documents.
Export documents to the .docx format. Maintenance routines, e.g., Verify & Repair detect and
fix more issues and are faster. And, as always, we added many fixes and improvements to make
DEVONthink faster and more reliable.
Added new menu command File > Export > as Word 2007 Document (DOCX) and renamed File
> Export > as Word Document to as Word 97 Document (DOC).
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Added menu command Tools > Summarize Highlights > as Sheet.
Added alternate menu command Reveal In New Window to the contextual menu of the results
in the See Also & Classify and Search inspectors. This command is available while pressing the
Option modifier key.
Added Mermaid support option to Preferences > Media > Markdown > Extensions.
Added Convert to Item Link and an alternate Convert All to Item Links command to the
contextual menus of plain text, rich text, and Markdown views. This allows converting a
document's WikiLinks to permanent item links. The alternate command is available while
pressing the Option modifier key when the contextual menu is open.
Added hidden preference DisableTagAutocompletion to disable auto-completion in tagging
fields, e.g., the Tags bar.
Added .rmd to the list of known Markdown extensions.
Added new external smart rule script File Items Using @Destination in Name which moves
items to the group specified in the name after @, similar to Evernote's email filing.
Added name without extension AppleScript property.
Added optional force parameter to the open window for AppleScript command to force
DEVONthink to always open a new window, even if the item is already opened or visible in a
window.
Pro — Added a suppressible alert to Preferences > Data before deleting custom metadata
definitions.
Sync — Added iCloud (CloudKit) sync location as an alternative iCloud sync option. The
previous iCloud location is now named iCloud (Legacy).
Sync — Added the option to disable synchronizing custom metadata definitions set in
Preferences > Data. This can be useful when people use the same sync location but not the
same databases.
Updated the application icon, about/launch panels, disk image background, menu extra icon,
and the icon of the Databases folder for macOS Big Sur. Also updated the icons for Finder
items, e.g., sync stores and database files.
The name of closed databases in the Navigate sidebar is now shown in italics.
The Recent Destinations and Favorites sections, e.g., in the Move/Replicate/Duplicate To
contextual menus, no longer include items in the trash.
The Log panel isn't hidden anymore while the application is inactive.
Tagging fields, e.g. in the Tags bar or the Info inspector, now support entering nested tags by
separating the tags with a forward slash, e.g., software/productivity/DEVONthink. This will
create a parent tag and child tags in the Tags group of the current database.
The Document > Annotations inspector supports CriticMarkup in Markdown documents in
source or side-by-side mode with Markdown documents.
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Conversion of rich text to Markdown now uses CriticMarkup to support conversion of
strikethrough and highlighted text.
The Markdown editor supports Format > Highlight, Format > Style > Strike Through, and
Format > Style > Underlined. These options are also available in the editing bar. CriticMarkup is
used to support these formatting options.
The highlighting and strikethrough syntax of some other Markdown-enabled applications is
now supported for Markdown documents when previewing, converting, and exporting as a
website. ==text==, ^^text^^, and ~~text~~ are alternate choices.
Tools > Summarize Highlights > as Markdown uses CriticMarkup formatting for the summary.
Summarizing Markdown documents as rich text is also now supported.
Preview and conversion of Markdown documents now strips double square brackets around
WikiLinks.
Improved appearance of tabs, especially of document windows (macOS Big Sur).
Sorting the Document > Annotations inspector by type now also uses the color of the
annotations.
Improved accessibility support of the Document > Annotations and Document > Links
inspectors.
The Sort method of the top level Tags and Trash items in the Navigate sidebar is now
independent of the Sort method of the global inbox.
Go > To Document now supports document windows too and does not always open documents
in a new window.
Revised Preferences > Media to provide more space for potential future options.
Improved Tab key handling in smart group and smart rule editors.
Improved appearance of the predicate editor in smart group, smart rule, and advanced search
options (macOS Big Sur).
Tools > Summarize Highlights is more compatible to PDF annotations and their details added
in DEVONthink To Go.
Importing PDF documents without searchable text no longer logs a message.
Importing and indexing items now uses any available kMDItemWhereFroms extended attribute,
not only web URLs.
Improved handling of item link parameters.
The Document > Links inspector now ignores redundant links inside documents, e.g., in
Markdown or tables of contents.
The Smart Quotes and Smart Dashes options are now disabled by default when editing the
source of HTML pages or web archives.
Improved recognition of document dates in the dd/MM/YY format.
Improved detection of document amounts.
Renamed the external smart rule script "Tags - Add Keywords" to Tags - Add Most Important
Words as the Concordance is used, not keywords of the document's properties.

DEVONthink 3.7 Documentation, page 249

Improved the dictionary description of the open tab for AppleScript command.
Verifying, repairing, and rebuilding databases now can detect and fix more issues. Optimizing
databases is also up to twice as fast.
The Spotlight metadata importer plugin adds additional metadata to improve the
compatibility with third-party Spotlight-enabled applications like HoudahSpot.
Improved support for volumes mounted by AutoMounter. This can improve handling indexed
items on such volumes as well as verifying and synchronizing databases.
DEVONthink asks the user for automation permissions on macOS Mojave and later before
clipping websites if not yet enabled.
DEVONthink now sets the extended attribute com.apple.metadata:kMDItemWhereFroms
instead of kMDItemWhereFroms after changing the URL of items. This improves compatibility
with other applications and the latest macOS versions. However, both attributes are still
supported when importing or exporting.
Refreshing RSS feeds now only logs HTTP errors, e.g. 404 not found, and no longer logs
network issues.
Improved usage of number formatting defined in System Preferences.
More reliable clipping and conversion of web pages to formatted notes.
Improved smart group and smart rule performance.
Reduced memory usage while indexing and parsing HTML-based documents.
Improved overall performance, especially when handling large numbers of tags and aliases.
Pro — Importing .mbox files now ignores Preferences > Email > Conversations > Import
complete conversations to improve performance. Also this option isn't applicable to such
imports.
Pro — Improved importing and indexing the content of emails not having a properly formatted
sender.
Pro — File > Export > as Unix mailbox now supports exporting selected groups and smart
groups containing emails.
Pro — Toggling the checkbox of an item in the Download Manager changes the state of all
currently selected sites if the clicked site is also selected.
Pro — More reliable handling of custom metadata identifiers by the get custom meta data
AppleScript command.
Server — The web interface now supports using local Markdown stylesheets specified in
Preferences > Media.
Sync — Reduced resource consumption of the iCloud upload monitor.
Sync — Reduced the number of automatic sync attempts after failures.
Sync — Improved error handling and logging of receiving invalid sync data.
Intermittent crash of Cover Flow. Fixed.
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In macOS Big Sur on M1 Macs some file types couldn't be imported into encrypted databases.
Fixed.
The Navigate sidebar was still sometimes automatically expanded when the option to
Automatically expand & collapse was disabled in Preferences > General > Sidebar. Fixed.
The thumbnail size in Icon View wasn't always restored with the Global Inbox. Fixed.
Selections in the Favorites section of the Navigate sidebar didn't always work as expected.
Fixed.
Some toolbar search options were not restored on startup if all windows were closed before
quitting. Fixed.
Saving a modified tab with selected items in main windows, e.g. after opening multiple tabs,
reset the tab. Fixed.
Importing encrypted databases from a sync location attached the panel to the wrong window.
Fixed.
If the name of a database was changed by sync, the filename and Favorites were not updated.
Fixed.
Rare issues of expansion of the item list in List View. Fixed.
Temporary memory leaks could occur after closing tabs. Fixed.
The Info item of the toolbar's overflow menu didn't always work. Fixed.
The Tags filter pane didn't always work properly when switching from a database showing a
selected document to another database without a selection. Fixed.
Links shown in the Navigation bar while hovering over links in web views, including Markdown
previews, could flicker. Fixed.
The preview of documents could automatically switch from Text alternative to Best
alternative, e.g., after editing Word documents externally. Fixed.
The URL wasn't immediately shown in the Navigation bar after hiding the editing bar. Fixed.
The Document > Annotations inspector could display incorrectly when background colors using
an opacity value less than 100% was used. Fixed.
Edit > Find > Next/Previous didn't work correctly in full-screen document mode if the Search
inspector was visible before entering this mode. Fixed.
The Operators & Wildcards checkbox of the Search inspector was sometimes automatically
enabled. Fixed.
The progress indicator shown while rebuilding a database wasn't updated while importing on
macOS Big Sur. Fixed.
The Sorter did not appear in the menu bar when using Bartender. Fixed.
The Copy Selection command of the Sorter did not work in full-screen apps. Fixed.
Changing the size of system fonts, e.g., setting the size of the full-screen plain text font in
Preferences > Editing, no longer worked in the latest macOS releases.
Tools > Summarize Highlights created an incorrect name when only one document was
selected. Fixed.

DEVONthink 3.7 Documentation, page 251

The Auto correct: Page orientation option of Preferences > OCR was ignored in some cases.
Fixed.
Inconsistent handling of the contents and details of PDF text annotations in the Document >
Annotations inspector. Fixed.
Markdown documents containing base64-encoded data or automatic WikiLinks from
MashedWords or Names & Aliases didn't display correctly. Fixed
Styles and tabs at the beginning of lines in rich text documents weren't handled correctly
when converted to Markdown. Fixed.
Converting a sheet column from or to rich text didn't convert the fields of the column. Fixed.
Sheets using the Set data type in a column didn't print or convert to PDF correctly. Fixed.
Offline viewing of downloaded web pages didn't always navigate properly. Fixed.
Clipping pages from our user community as web archives or HTML didn't work properly. Fixed.
Indexed iCloud Drive files, which are not locally available sometimes, caused issues. Fixed.
Markdown section headings containing links didn't behave properly, e.g., in the Content > Table
of Contents inspector. Fixed.
Scanning item links could cause unnecessary updates to the Spotlight index. Fixed.
Rare exception while parsing HTML metadata. Fixed.
Scheduled smart rules, e.g. every minute, having valid conditions and both record-specific,
e.g. move, and non-specific actions, e.g. play sound, were unnecessarily executed even with no
matching records. Fixed.
Pro — The scanning interface displayed some artifacts in dark mode and on macOS Big Sur.
Fixed.
Pro — Imports from the ScanSnap were not always saved, the name of imported scans was
not always used, and certain pages in the created PDF did not use the same rotation as the
original when the auto-rotation option was not enabled.
Pro — The Download Manager could cause failed imports and too many downloads. Fixed.
Pro — Custom metadata with multiple identical values in a set could lead to incorrect
selections being displayed. Fixed.
Pro — Poorly written scripts could create invalid custom metadata identifiers via the add
custom meta data command. Fixed.
Server — In the web interface more results could not be downloaded and the wrong date
format was used for the US locale. Fixed.
Server — Minor fixes for changes in Safari 14.0.3.
Sync — Obsolete files or folders might not have been removed from DEVONthink's
Application Support folder after cleaning sync stores. Fixed.
Sync — With sync locations being used by more than two devices, locally changed UUIDs could
lead to unnecessary intermittent uploads. Fixed.
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VERSION 3.6.1
This maintenance release fixes some issues with macOS Big Sur, including a crash when accessing
DEVONthink's preferences. It also has some modifications for increased compatibility with Apple
Silicon Macs.
Added hidden preference WindowToolbarStyleExpanded to enable the expanded toolbar
style on macOS Big Sur. This shows the title bar above the toolbar instead of the new unified
default style.
Changed title of "Save Search" dialog to Save as smart group.
More reliable item link scanning.
Word and OpenOffice documents are now ignored while scanning databases for item links to
avoid potential crashes.
Improved user notifications in case of new releases, promotions, and sidebar extras. In
addition, clicking on the notification jumps directly to the item if the notification is only
related to one item, e.g., one promotion or one release.
Pro — Added Import command to the contextual menu of the messages list in the View >
Sidebar > Import > Email sidebar pane.
Sync — More reliable detection whether the Cloudy folder was copied to another computer.
Some interface elements were incorrectly positioned when running on Apple Silicon Macs.
Fixed.
The view and preview modes, as well as sorting and columns widths of the item list couldn't be
changed for the global inbox. Fixed.
The Title column in the items list wasn't persistent on macOS Big Sur. Fixed.
The Log and Info toolbar buttons didn't work in full screen mode on macOS Catalina and later.
Fixed.
The Document > Annotations inspector didn't display thumbnails of attached images in dark
mode. Fixed.
Fixed glitches of the sidebar, the Templates menu, and the Scripts menu on macOS Big Sur
and in dark mode.
Choosing an already opened encrypted database in Go > Favorites didn't jump to it. Fixed.
In some cases, DEVONthink could crash when accessing the Preferences in macOS Big Sur.
Fixed.
Encrypted databases containing non-ASCII characters in the filename were disabled in the
sidebar while opened. Fixed.
Caching could cause outdated Markdown previews, e.g., after changing WikiLink preferences.
Fixed.
Rare issue of automatic WikiLinking, especially in Markdown previews. Fixed.

DEVONthink 3.7 Documentation, page 253

Copying links to Markdown sections didn't work in case of non-Latin characters, e.g., Asian
languages. Fixed.
Printing a web-based document in macOS Big Sur on an M1 Mac could crash the application.
Fixed.
AppleScript command create record with didn't accept the search group parameter.
Fixed.

VERSION 3.6
This release brings compatibility for macOS 11 Big Sur, with both cosmetic and technological
improvements. Also, document links are a focus in this version. Databases are scanned for link
relationships between documents: either outgoing links or incoming Links ("back links"). The
numbers of incoming and outgoing links can also be used to search, as smart criteria, or to sort
the item list.
Other enhancements include better in-document searching via the Search inspector which now
allows wildcards and operators, e.g., DEVONthink NEAR support. We have added more Markdown
support including a new Daily Journal template and creating a table of contents file in Markdown.
There is now the ability to duplicate and replicate via the Move to popover when modifier keys
are held. PDFs with a table of contents can be split by chapters into separate documents. The
AppleScript dictionary also received several additions and improvements, including faster
processing of selected items. Lastly, there are performance and reliability improvements for
DEVONthink and its synchronization.
Added support for scanning documents for links to and from other documents. This is
supported for all newly created files in DEVONthink's native formats. Existing databases will
be scanned the first time they're opened.
Added File > Close > All Except command to leave the current database open.
Added an Enable Operators & Wildcards option to the Search inspector allowing use of
operators and wildcards for in-document searches. If disabled, the search terms will be
treated as substrings. The Edit > Find > Find Next/Previous commands and next/previous
buttons in the inspector are available when this option is enabled.
Added Tools > Split PDF into Chapters command to split one or more selected PDF documents
having multiple pages and a table of contents with multiple entries into the separate chapter
documents.
Added Go > To Document to quickly open a document in the current main window if the View/
Edit pane is visible or a new document window, if not.
Added Copy Section Link and Copy Page Link to the contextual menu of the Table of Contents
inspector, for Markdown and PDF documents.
Added an Incoming Links pane to the Document > Links inspector showing incoming links
("back links") from other documents. This includes WikiLinks from plain and rich texts, as
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well as Markdown documents. Clicking on an incoming link displays the backlinked document.
Dragging incoming links to Markdown or rich text documents with Command-Option held is
also supported.
Added support for querying or sorting on the number of incoming or outgoing links to many
sections of the interface, including smart groups, smart rules, advanced searching, sorting the
item list, etc.
Added property icons to the item list denoting items have incoming or outgoing links.
Added Daily Journal — Markdown template to Data > New from Template > Productivity. Also,
updated and renamed the original Daily Journal template to Daily Journal - Text.
Added two new services to capture bookmarks, DEVONthink 3: Capture Bookmark, and to
add links to the Reading List, DEVONthink 3: Add to Reading List. Both require having a URL
selected.
Added a File Location pop-up menu to the Tools > Filters > Info pane to filter imported or
indexed items in the current location.
Added a submenu to Tools > Create Table of Contents to create a table of contents as rich
text or Markdown document.
Added Copy Section Link to the contextual menu of the Markdown editor.
Added Any Extension criterion for use with smart groups, smart rules, and searches. This
can be used to check for filenames with or without an extension, e.g., Extension is not Any
Extension.
Added AppleScript terms incoming references and outgoing references to get explicit
link relationships between records.
Added AppleScript terms incoming Wiki references and outgoing Wiki references to
get automatic WikiLink relationships between records.
Added AppleScript term selected records for application and main windows. Contrary
to the still supported selection property this supports bulk retrieval of properties of the
selection. Queries like name of selected records or UUID of selected records are up to
100 times faster.
Added a generic UUID for the global inbox for use with item links, smart groups, and smart
rules.
Added hidden preference DisableHighlightColorMapping to use the same highlight colors
for web documents in both light and dark mode on macOS Mojave and later.
Added hidden preference ExcludeOpenedDatabasesFromTimeMachine. This option is off by
default.
The Data > Move To command can now be used with files open in document windows.
Opening favorite documents via Go > Favorites tries to open them in the current main window
if the View/Edit pane is visible.
The sidebar header of main windows now shows the number of unread items in the Reading
List.
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Tooltips of results, e.g., search results or See Also & Classify results, are shown if the location
of the item is abbreviated.
The Database Properties popover no longer requires selecting only the root of the database in
the Navigate sidebar.
Items newly added to the Reading List are shown at the top.
The Info inspector now shows the total duration when multiple multimedia files are selected.
Added a Copy Name command to the contextual menu of the Document > Links inspector.
The Table of Contents inspector now detects the alternate heading syntax in Markdown
documents.
Insert Back Link and Insert Quote commands of the Annotations & Reminders inspector now
support plain text and Markdown annotation.
Relative links in HTML-based documents and item links referencing web-based documents now
support anchors, e.g., [001](001.md#conclusion) in Markdown.
Added shortcut ⌃⌘E to Edit > Insert > Item Link.
Changed shortcut of Data > Launch URL to ⌃⌘U and Data > Launch URL in Background to
⌃⌥⌘U.
Holding the Option or Command-Option modifier keys can be used to duplicate or replicate
items via the Data > Move To popover. The title of the popover is updated according to the
current modifier keys.
Both Data > Move to external folder and automatic moving to external folder, e.g., after
adding/moving items to indexed groups, tries to retain the original filenames of the
documents.
Groups created by File > Import > Notes from Evernotenow retain the creation or modification
date of the imported notes. Note: This command only works with Evernote's "legacy version"
as Evernote 10 no longer supports AppleScript.
Animated GIFs now animate when displayed. However, they can no longer be modified.
Added Delete Page and Insert Blank Page commands to the contextual menu of the View/Edit
pane when viewing PDFs.
The Editing bar used with PDFs now supports inserting blank pages, deleting the current page,
and reversing the page order without the Thumbnails inspector being visible.
Sheet templates now support placeholders.
Dragging audio or video files in a database into a Markdown document now inserts video or
audio HTML tags.
The sharing extension uses URLs provided by source application for files, images, and movies,
if a URL is available. The extension also supports more input types, improves reliability, and is
more compatible with macOS Big Sur.
More efficient updating and reloading of sidebars in main windows.
Improved parsing of toolbar searches using the search prefix tags: now strips unnecessary
white spaces.
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The summaries in the Search inspector now use the Summarize setting in Preferences >
Editing.
Improved performance of the Search inspector for web documents and views.
Renamed Move All Instances to Trash to Move All Replicants to Trash.
Scanning text of documents, e.g., via smart rule actions or date or amount placeholders, now
scans the first eight pages of PDF documents and up to 40k of text.
Improved escaping characters while converting documents to Markdown.
Improved conversion of rich text to Markdown now retains bold, italics, underlining, and links.
In addition, lines containing only bold text are converted to headers.
Conversion of hashtags to tags now ignores the content of certain types of files, e.g., CSS
stylesheets, source code, code blocks in Markdown files, etc. as they can generate a large
number of unwanted tags.
Relative paths to video or audio files in the same database are now supported in Markdown or
HTML documents.
More reliable indexing of third-party file formats requiring Spotlight metadata importers.
Improved updating indexed files with Finder comments, especially in folders containing many
files with comments.
Improved recognition of document dates using MM/DD/YY format.
More consistent handling of file coordination to improve opening or editing imported
documents externally.
Revised user-agent while downloading RSS feeds to improve the compatibility with certain
feeds, e.g., some Atom feeds.
Improved HTML parser makes the AppleScript command get embedded images of more
compatible to websites loading images dynamically.
Exporting templates no longer replaces % in the name of exported items.
The Add to Reading List service now automatically names the added item.
Improved checking free disk space before optimizing, rebuilding, or adding files to databases.
Updated scripts of Scripts > Execute menu.
Files added to the Global Inbox folder in the Finder are no longer processed by DEVONthink
while smart rules or scripts are running.
Invalid arguments of AppleScript commands now report an error.
The Filename criterion in smart groups, smart rules, and searches now support is not and
does not contain/begin/end forms.
More efficient storing of internal and custom metadata.
The Support Assistant now uses SSL/TLS.
More background activities now block the synchronization of a database until complete to
avoid unnecessary or outdated transfers.
Improved timeout handling of background tasks.
Improved reliability and performance, including handling filesystem events.
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Pro — The Apple Mail plugin is now compatible to Big Sur and is included by default. Newer
plugins will be downloaded from our servers if available and necessary. In addition, old plugins
used by former macOS versions are automatically removed.
Pro — Improved compatibility when downloading multimedia files via the Download Manager.
Pro — OCR jobs in queue are cancelled after a crash of the OCR helper.
Server — Updated web interface fixes the display of scores in search view and improves
rendering Markdown documents.
Server — video and audio HTML tags in Markdown documents are now supported in the web
interface. They are also supported in File > Export > as Website command in all editions.
Sync — Dropbox connections try to alleviate timeouts or rate limiting by the service.
Sync — Reduced CPU and memory usage of the iCloud upload monitor.
Sync — Improved the overall reliability of WebDAV sync stores.
Sync — Improved the efficiency and speed of uploads, especially with smaller databases.
After canceling mounting encrypted databases or entering the wrong password multiple
times, the extension wasn't reverted to .dtSparse on macOS Catalina and later. Fixed.
Encrypted databases added to Favorites didn't work. Fixed.
Favorite encrypted databases were disabled while opened. Fixed.
Recent encrypted databases were disabled after closing them. Fixed.
After saving edited Markdown documents in both side-by-side and fullscreen document mode,
the source view lost the keyboard focus. Fixed.
Edit > Set Name As did not work in case of Markdown and HTML documents viewed in side-byside mode. Fixed.
Minor issues of the Table of Contents inspector with Markdown documents. Fixed.
MultiMarkdown metadata headers could be processed incorrectly by automatic Wiki linking.
Fixed.
Tab-indented lists in Markdown weren't parsed correctly. Fixed.
Go > Complete News was not disabled while the Support Assistant or a document window
showing a web document or Markdown preview was the frontmost window. Fixed.
Backward and forward handling after clicking on a link in RSS news or using Go > Complete
News wasn't working properly. Fixed.
Tags based on hashtags were updated when RSS feeds updated or after using the Append
Plain Note or Append Rich Note services. Fixed.
The RSS parser could affect the rendering of the Extras sidebar. Fixed.
Reordering of Reading List items via drag-and-drop shouldn't have been possible when
showing only unread items. Fixed.
macOS data detectors and filenames containing the same word multiple times could cause
issues with automatic WikiLinks. Fixed.
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Website exports didn't resolve automatic Wiki links based on the square bracket syntax in
Markdown documents. Fixed.
Page links copied by the Document > Annotations inspector incorrectly referenced the next
page. Fixed.
Empty toolbar queries like aliases!= didn't work. Fixed.
Searching, e.g., only for tags could return items in groups excluded from searching. Fixed
.applescript files showed an empty preview. Fixed.
.scpt and .scptd were incorrectly editable. Fixed.
Web archives without an internal URL were not rendered and could not be converted to HTML
or formatted notes. Fixed.
The Reveal command wasn't available in contextual menus when viewing files in ordinary tags.
Fixed.
The Recent Destinations section in the Move To, Replicate To, or Duplicate To submenus
incorrectly could contain ordinary tags. Fixed.
The Highlight submenu of the contextual menu when viewing PDF documents was disabled on
macOS Catalina and later if the current text selection was already highlighted. Fixed.
Glitch of Label menus in dark mode. Fixed.
Property icons, e.g., of indexed items, were not always shown in icon view with files having very
short names (one or two characters). Fixed.
The height of the headers of the List view was incorrect after enabling the second column.
Fixed.
The Length column in List view reported "1 pages" for single-page PDFs. Fixed.
Smart group and smart rule editors with too many conditions or actions couldn't be resized to
accommodate them. Fixed.
Border of Quick-Look-based standard preview of emails on Mojave and later was incorrect.
Fixed.
The Search inspector didn't show when searching web pages navigated to, i.e., not a bookmark
in the database. Fixed.
The Sorter could display incorrect colors when run as a menu extra on macOS Big Sur. Fixed.
Document windows were not always automatically closed after emptying the trash. Fixed.
The Mount Volume button of the view/edit pane locked the application while mounting
unmounted volumes. Fixed.
Certain reminder alarm actions didn't work properly with groups, smart groups, and RSS feeds.
Fixed.
The number of hits of accessed groups were incremented by 2 each time it was accessed. Also
the hits of feeds was incorrectly incremented when the feeds were refreshed. Fixed.
Filesystem events, e.g., after deleting file A in a folder and renaming file B as file A immediately
afterwards, could cause duplicate items. Fixed.
Document dates with unknown file types could be incorrectly detected or missed. Fixed.
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Tag issues when moving items to a group having the same tags in a different database not
using group tags. Fixed.
Scripts > Data > Verify & Optimize Databases could fail while databases were synchronizing.
Fixed.
The search AppleScript command returned incomplete results when providing an invalid in
parameter. Fixed.
A rare AppKit exception could occur while processing images. Fixed.
Pro — In Apple Mail, the command Mailbox > Add to DEVONthink 3 didn't support importing
the inbox if there was only one email account active. Fixed.
Pro — Retrieval of message IDs while email archiving could fail in case of not fully downloaded
emails and could lead to duplicate imports. Fixed.
Pro — Data > Tags > Convert Properties and Preferences > Import > Convert properties to tags
didn't convert the recipient's email addresses from imported emails. Fixed.
Pro — DEVONthink would sometimes crash on quit after using email archiving. Fixed.
Pro — Some OCR output had incorrectly rotated pages or unselectable text. Fixed.
Pro — OCR on PDFs containing multiple page sizes would output unexpected results. Fixed.
Pro — Non-specific smart rule actions, e.g., playing a sound or displaying a notification with
static text, were performed for each item after an OCR action instead of only once. Fixed.
Pro — Results in the See Also inspector could include groups or tags having custom metadata.
Fixed.
Pro — Automatic grouping of images didn't work. Fixed.
Server — Empty Markdown documents couldn't be edited or viewed in the web interface.
Fixed.
Server — Deleting the complete content of a plain text or Markdown document in the web
interface wasn't possible. Fixed.
Pro — Removed unsupported OCR languages from Preferences > OCR: Old English, French,
German, Spanish, Italian, Slovian, Thai, Thai, Latvian language written in Gothic.
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LICENSE AGREEMENT
PLEASE READ THIS LICENSE CAREFULLY
BEFORE USING THIS SOFTWARE. BY USING
THIS SOFTWARE, YOU ARE AGREEING TO
BE BOUND BY THE TERMS OF THIS LICENSE
AGREEMENT. IF YOU DO NOT AGREE TO

3. Disclaimer of Warranty on Software:
You expressly acknowledge and agree that
use of the Software is at your sole risk. The
Software and related documentation is
provided "AS IS" and without warranty of any
kind.

THE TERMS OF THIS LICENSE, DELETE THE

4. Limitation of Liability: UNDER NO

SOFTWARE OR RETURN THE SOFTWARE

CIRCUMSTANCES INCLUDING NEGLIGENCE,

AND RELATED DOCUMENTATION TO

SHALL DEVONTECHNOLOGIES BE LIABLE

DEVONTECHNOLOGIES, LLC.

FOR ANY INCIDENTAL, SPECIAL OR

1. License: The application and other
components (sound and graphics)
accompanying this License, whether
on disk, in read only memory, or on any
other media (the "Software"), and the
related documentation are licensed
to you by DEVONtechnologies. You
own the disk on which the Software is

CONSEQUENTIAL DAMAGES THAT RESULT
FROM THE USE OR INABILITY TO USE THE
SOFTWARE OR RELATED DOCUMENTATION.
In no event shall DEVONtechnologies' total
liability to you for all damages, losses and
causes of action (whether in contract, tort
(including negligence) or otherwise) exceed
the amount paid by you for the Software.

recorded but DEVONtechnologies and/or

Apple, Cocoa, ColorSync, Darwin, macOS,

DEVONtechnologies' Licensor(s) retain title

QuickTime, Quartz and all other registered

to the Software and related documentation.

names are trademarks of their respective

This License allows you to non-simultaneously

owners.

use the Software on multiple computers by
the same person.

CREDITS

2. Restrictions: The Software contains
copyrighted material, trade secrets and
other proprietary material and in order
to protect them you may not decompile,
reverse engineer, disassemble or otherwise

ABBYY FINEREADER ENGINE
ABBYY FineReader 11.x Engine Copyright
© ABBYY Software Ltd. OCR by ABBYY
Software House.

reduce the Software to a human-perceivable
form. You may not sub-license, modify, rent,

MULTIMARKDOWN

lease, or create derivative works based upon
the Software in whole or in part. You may
not distribute the Software in any form,
including, but not limited to, electronic
information service distribution, bulletin
board distribution, and magnetic or optical

Copyright © 2016-2018 Fletcher T. Penney.
MultiMarkdown is released under both the
GPL and MIT licenses. You may pick the
license that best fits your needs.

medium distribution.
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Modifications to remove reliance on Glib2:

of the Software, and to permit persons to

Copyright © 2011 Daniel Jalkut, licensed

whom the Software is furnished to do so,

explicitly MIT.

subject to the following conditions: The

LyX export code © 2013-2014 Charles R.

above copyright notice and this permission

Cowan, licensed under both GPL and MIT

notice shall be included in all copies or

licenses.

substantial portions of the Software. THE

Portions based on: peg-markdown.

SOFTWARE IS PROVIDED "AS IS", WITHOUT

Copyright © 2008-2011 John MacFarlane.

WARRANTY OF ANY KIND, EXPRESS OR

ODF output code © 2011-2013 Fletcher T.

IMPLIED, INCLUDING BUT NOT LIMITED TO

Penney. peg-markdown is released under

THE WARRANTIES OF MERCHANTABILITY,

both the GPL and MIT licenses. You may

FITNESS FOR A PARTICULAR PURPOSE AND

pick the license that best fits your needs.

NONINFRINGEMENT. IN NO EVENT SHALL

Original Markdown specification by John

THE AUTHORS OR COPYRIGHT HOLDERS

Gruber.

BE LIABLE FOR ANY CLAIM, DAMAGES OR

The GPL: This program is free software;
you can redistribute it and/or modify it
under the terms of the GNU General Public
License as published by the Free Software
Foundation; either version 2 of the License,
or (at your option) any later version. This
program is distributed in the hope that it will
be useful, but WITHOUT ANY WARRANTY;

OTHER LIABILITY, WHETHER IN AN ACTION
OF CONTRACT, TORT OR OTHERWISE,
ARISING FROM, OUT OF OR IN CONNECTION
WITH THE SOFTWARE OR THE USE OR
OTHER DEALINGS IN THE SOFTWARE.

PANTOMIME
Copyright © 2001-2009 Ludovic Marcotte.

without even the implied warranty of
MERCHANTABILITY or FITNESS FOR A
PARTICULAR PURPOSE. See the GNU General
Public License for more details. You should
have received a copy of the GNU General
Public License along with this program; if

SHORTCUTRECORDER
Copyright © 2006, contributors to
ShortcutRecorder. (See the contributors
listed in detail later in the file.)

not, write to the Free Software Foundation,

All rights reserved. Redistribution and use

Inc., 51 Franklin St, Fifth Floor, Boston, MA

in source and binary forms, with or without

02110-1301 USA

modification, are permitted provided that

The MIT License: Permission is hereby

the following conditions are met:

granted, free of charge, to any person

Redistributions of source code must retain

obtaining a copy of this software and

the above copyright notice, this list of

associated documentation files (the

conditions and the following disclaimer.

"Software"), to deal in the Software without

Redistributions in binary form must

restriction, including without limitation the

reproduce the above copyright notice,

rights to use, copy, modify, merge, publish,

this list of conditions and the following

distribute, sublicense, and/or sell copies

disclaimer in the documentation and/
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or other materials provided with the

Ilya Kulakov. ShortcutRecorder 2.0 and

distribution.

further support.

The name of the contributors may not

Alexander Ljungberg. Graphics for

be used to endorse or promote products

ShortcutRecorder 2.0

derived from this software without specific
prior written permission.
THIS SOFTWARE IS PROVIDED BY THE
CONTRIBUTORS "AS IS" AND ANY EXPRESS
OR IMPLIED WARRANTIES, INCLUDING, BUT
NOT LIMITED TO, THE IMPLIED WARRANTIES
OF MERCHANTABILITY AND FITNESS FOR
A PARTICULAR PURPOSE ARE DISCLAIMED.
IN NO EVENT SHALL THE CONTRIBUTORS
BE LIABLE FOR ANY DIRECT, INDIRECT,
INCIDENTAL, SPECIAL, EXEMPLARY, OR
CONSEQUENTIAL DAMAGES (INCLUDING,
BUT NOT LIMITED TO, PROCUREMENT OF
SUBSTITUTE GOODS OR SERVICES; LOSS

SPARKLE
Copyright © 2006-2013 Andy Matuschak
Permission is hereby granted, free of charge,
to any person obtaining a copy of this
software and associated documentation
files (the "Software"), to deal in the Software
without restriction, including without
limitation the rights to use, copy, modify,
merge, publish, distribute, sublicense, and/
or sell copies of the Software, and to permit
persons to whom the Software is furnished
to do so, subject to the following conditions:

OF USE, DATA, OR PROFITS; OR BUSINESS

The above copyright notice and this

INTERRUPTION) HOWEVER CAUSED AND

permission notice shall be included in

ON ANY THEORY OF LIABILITY, WHETHER

all copies or substantial portions of the

IN CONTRACT, STRICT LIABILITY, OR TORT

Software.

(INCLUDING NEGLIGENCE OR OTHERWISE)
ARISING IN ANY WAY OUT OF THE USE OF
THIS SOFTWARE, EVEN IF ADVISED OF THE
POSSIBILITY OF SUCH DAMAGE.

THE SOFTWARE IS PROVIDED "AS IS",
WITHOUT WARRANTY OF ANY KIND,
EXPRESS OR IMPLIED, INCLUDING BUT
NOT LIMITED TO THE WARRANTIES

Contributors to Shortcut Recorder, in no

OF MERCHANTABILITY, FITNESS

order in particular:

FOR A PARTICULAR PURPOSE AND

Jesper, waffle software. Initial idea and
concept, first shot at implementation
using NSView.
David Dauer. Refinement, cleaner
reimplementation, documentation, IB
Palette.
Jamie Kirkpatrick, Kirk Consulting Ltd.
Further modularisation and re-factoring,

NONINFRINGEMENT. IN NO EVENT SHALL
THE AUTHORS OR COPYRIGHT HOLDERS
BE LIABLE FOR ANY CLAIM, DAMAGES OR
OTHER LIABILITY, WHETHER IN AN ACTION
OF CONTRACT, TORT OR OTHERWISE,
ARISING FROM, OUT OF OR IN CONNECTION
WITH THE SOFTWARE OR THE USE OR
OTHER DEALINGS IN THE SOFTWARE.

and general bug fixes.
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SKIM
Copyright © 2008-2018, Christiaan Hofman
and contributors All rights reserved.

NEGLIGENCE OR OTHERWISE) ARISING
IN ANY WAY OUT OF THE USE OF THIS
SOFTWARE, EVEN IF ADVISED OF THE
POSSIBILITY OF SUCH DAMAGE.

Redistribution and use in source and binary
forms, with or without modification, are
permitted provided that the following
conditions are met:

LETSMOVE
Public domain. More information can be
found atLetsMove.

Redistributions of source code must retain
the above copyright notice, this list of

ZIPZAP

conditions and the following disclaimer.

Copyright © 2012, Pixelglow Software. All

Redistributions in binary form must
reproduce the above copyright notice, this

rights reserved.

list of conditions and the following disclaimer

Redistribution and use in source and binary

in the documentation and/or other materials

forms, with or without modification, are

provided with the distribution. Neither the

permitted provided that the following

name of Christiaan Hofman nor the names

conditions are met:

of any other contributors may be used to
endorse or promote products derived from
this software without specific prior written
permission.

Redistributions of source code must retain
the above copyright notice, this list of
conditions and the following disclaimer.
Redistributions in binary form must

THIS SOFTWARE IS PROVIDED BY THE

reproduce the above copyright notice,

COPYRIGHT HOLDERS AND CONTRIBUTORS

this list of conditions and the following

"AS IS" AND ANY EXPRESS OR IMPLIED

disclaimer in the documentation and/

WARRANTIES, INCLUDING, BUT NOT

or other materials provided with the

LIMITED TO, THE IMPLIED WARRANTIES OF

distribution.

MERCHANTABILITY AND FITNESS FOR A
PARTICULAR PURPOSE ARE DISCLAIMED.
IN NO EVENT SHALL THE COPYRIGHT
OWNER OR CONTRIBUTORS BE LIABLE
FOR ANY DIRECT, INDIRECT, INCIDENTAL,
SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
DAMAGES (INCLUDING, BUT NOT LIMITED
TO, PROCUREMENT OF SUBSTITUTE GOODS
OR SERVICES; LOSS OF USE, DATA, OR
PROFITS; OR BUSINESS INTERRUPTION)
HOWEVER CAUSED AND ON ANY THEORY
OF LIABILITY, WHETHER IN CONTRACT,
STRICT LIABILITY, OR TORT (INCLUDING

THIS SOFTWARE IS PROVIDED BY THE
COPYRIGHT HOLDERS AND CONTRIBUTORS
"AS IS" AND ANY EXPRESS OR IMPLIED
WARRANTIES, INCLUDING, BUT NOT
LIMITED TO, THE IMPLIED WARRANTIES OF
MERCHANTABILITY AND FITNESS FOR A
PARTICULAR PURPOSE ARE DISCLAIMED.
IN NO EVENT SHALL THE COPYRIGHT
HOLDER OR CONTRIBUTORS BE LIABLE
FOR ANY DIRECT, INDIRECT, INCIDENTAL,
SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
DAMAGES (INCLUDING, BUT NOT LIMITED
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TO, PROCUREMENT OF SUBSTITUTE GOODS

STRICT LIABILITY, OR TORT (INCLUDING

OR SERVICES; LOSS OF USE, DATA, OR

NEGLIGENCE OR OTHERWISE) ARISING

PROFITS; OR BUSINESS INTERRUPTION)

IN ANY WAY OUT OF THE USE OF THIS

HOWEVER CAUSED AND ON ANY THEORY

SOFTWARE, EVEN IF ADVISED OF THE

OF LIABILITY, WHETHER IN CONTRACT,

POSSIBILITY OF SUCH DAMAGE.
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TECHNOLOGY
FEATURES
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General Concept
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The DEVONtechnology is a rock-solid

Features

266

foundation suitable for a variety of

Structure

266

completely independent applications.

Applications

267

Therefore it is ideal for the rapid
development of a huge range of new

All commercial DEVONtechnologies
applications are based on a proprietary
AI technology, with rock-solid database
foundation that allow them to manage large

database-, signal-processing- and languageanalysis-driven applications. The ability to
deal with any kind of digital data makes it
extremely flexible.

numbers of documents or knowledge bits
while analyzing them almost instantly at the

The size of DEVONtechnology-based

same time.

databases can, depending on the type of
data stored, grow logarithmically and make

GENERAL CONCEPT

indexing is completely unnecessary. Also,

DEVONtechnology, on which all

improve themselves continuously (the more

DEVONtechnologies' applications are built, is

data they handle, the better the results),

a new technology at the very beginning of its

are language-independent and iron out any

development. DEVONtechnologies constantly

irregularities by applying fuzzy logic.

applications based on the DEVONtechnology

improves the technology and enhances it for
more functionality, efficiency, robustness and
flexibility.

STRUCTURE
The DEVONtechnology consists of a kernel

Development of the DEVONtechnology is a
battle on two main forefronts of information
processing technology. DEVONtechnologies is

and several layers. Together they perform all
the underlying computing, from 'simple' data
handling to complex signal processing.

working hard on unifying both the top-down
and the bottom-up AI concepts by imitating

Kernel: The kernel is the foundation for all

high-level functions and simulating the basic

layers and applications and is responsible

functionality of natural systems. This leads

for data handling, semantic and associative

to highly functional, fast and efficient AI

data processing, signal processing, fast

systems that can be used in a great variety

statistic analyses and all fuzzy algorithms.

of information processing contexts, such as

It has to be as fast, flexible, and extensible

pattern recognition, signal processing and

as possible; it is 64-bit aware and uses a

information storage and retrieval.

generic, proprietary file format (see above)
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allowing it to verify and repair low level data
consistency, featuring logarithmic growth
of the database and logarithmic speed
decrease with increasing database size. The
DEVONtechnology kernel is Unicode-aware,
completely language-independent and selfoptimizing and self-organizing.

APPLICATIONS
Some of the most likely applications for
the DEVONtechnology are databases
(knowledge bases, expert systems, search
engines, table-of-content-generators,
instant data-mining), intelligent agents,
encryption, compression and archiving.

Layers: The layers form a shell around the

Other uses for DEVONtechnology may be

kernel and provide high-level functions

chat-bots, context-sensitive help, optical

for the applications built on top of them.

character recognition (OCR), speech analysis,

The database layer, for example, is used to

recognition and synthesis, staticstics,

store and organize data and supports all

thesauri and automatic translations.

kinds of relations (1:n, n:1, n:n), hierarchies
and freeform databases. No indexing or
primary keys are required, strings can be
unlimited in size and it's possible at any time
to extend the range of pre-defined data
types (Boolean, character, float, double,
signed, unsigned, string, date, time, blob,
color, size, and point). Another layer, the

In particular, applications dependant on
processing human language, either written or
spoken, benefit from the flexible technology
foundation. So, DEVONtechnologies' main
focus in the development of new applications
is in these areas: databases, 'intelligent'
agents, text and speech analysis, statistics.

XML layer, makes it easy to handle XML code

Look forward to see a great range of different

within the DEVONtechnology; it has a very

applications based on the DEVONtechnology.

small overhead, compared to DOM parsers or

A few have already been announced

available XML databases, requires no indexing

on the DEVONtechnologies web site:

and supports the tight integration of other

www.devontechnologies.com.

databases (and vice versa).
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OTHER PRODUCTS
IN THIS CHAPTER

If you have a moment feel free to visit our

Overview

268

DEVONthink

268

DEVONagent

268

DEVONsphere

269

Needful Things

269

lively user community. Here users of all skill
levels meet to discuss our applications, talk
about our technology, and exchange tips and
tricks for DEVONthink & Co.

DEVONTHINK
Besides DEVONthink, DEVONtechnologies
publishes a number of other commercial,
shareware, and freeware applications and
services that might be helpful for you.

Organize and work with all your documents,
bookmarks, email messages, text files,
images, PDFs, in one place, regardless where
they originated. Quickly capture data without

OVERVIEW
DEVONtechnologies is focused on developing
innovative applications for finding, storing,
and organizing information. Our main
objective is to make complex yet flexible
technology that is both easy to use and

interrupting your workflow. DEVONthink's
unique AI assists you in getting the most out
of your data collection.
Learn more about DEVONthink
Check your upgrade options if you want to
upgrade to a higher edition

lightning fast. All applications are based on
the DEVONtechnology, a powerful and solid

DEVONAGENT

core unique to DEVONtechnologies.

DEVONagent Pro helps you search more

DEVONthink
DEVONagent
DEVONsphere

efficiently on the web. It searches multiple
sources, frees you from hunting for the really
relevant results, and gives you power tools
for your research. DEVONagent Express and

We also publish some freeware apps and

DEVONagent Lite (free) make searching

services for your everyday work with your

the web as easy as using Spotlight. Search

Mac.

Google, Bing, YouTube, Facebook, Twitter,
even the Mac App Store, right from the menu

NEWSLETTER & COMMUNITY

bar.

Would you like us to keep you informed about

Learn more about DEVONagent Pro.

updates and new product releases? Visit our
blog and subscribe to our free newsletter.
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DEVONSPHERE
Make your Mac smarter: Let DEVONsphere
Express keep track of related emails, articles
on the same subject, and similar web pages.
Discover the hidden connection between
seemingly unrelated files.
Learn more about DEVONsphere Express.

NEEDFUL THINGS
Search files on your hard disk, watch web
cams, create thumbnails, or access all your
files and apps from the menu bar. Reformat
paragraphs in your favorite word processor or
do little calculations anywhere you can type
in text. All for free.
Learn more about our freeware apps and
services.
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