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Welcome to DEVONthink, a powerful
assistant in your quest to organize many

online.

Now let's get into it…

INSTALLING, UPDATING,
UNINSTALLING

kinds of information. From recipes to
your dissertation, hobbies to health, for

Note: The following procedures do

work or home, DEVONthink can help you

not apply when you have purchased

gather, organize, and connect your data.

DEVONthink on the Mac App Store.

This manual will help get you familiarized

Installing, updating, and uninstalling are

with DEVONthink's concepts, interface, and

handled by the App Store application in

options. We begin with simple overviews,

this case.

move into descriptions of the essential
controls, then conclude with the deepest
details in the appendix.
Note this manual is meant as a handy
reference, not as a series of mandates on how
you must use it. DEVONthink can be used
very simply or in very complex ways and each
person brings their own personal approach
to using it. To that end, this document can't
be an exhaustive guide to everything you
could ever do with it. With the flexibility
and capabilities built-in, that would be an
impossible task. We hope you find this guide
helpful.

INSTALLING
If you haven't already installed DEVONthink,
here are the easy steps to accomplish that:
Download an installer from the Download
page.
If your browser isn't set to open safe
downloaded files, double-click the ZIP file
to decompress it. You will see a disk image
file.
Double-click the disk image to open it.
Drag and drop the application from the
disk image to the Applications folder
shortcut.

Note: Text in blue color (besides hyperlinks

After the application has copied, press ⌘E

that might get colored in blue by your

to eject the disk image.

ebook reader) refers to functionality only
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Note: Please note that macOS Services

DEVONthink

and the connection to DEVONagent

~/Library/Application Support/

work only for applications installed into

DEVONthink 3

the Applications folder, and that logout

~/Library/Application Scripts/

and login or a restart is suggested after

com.devon-technologies.think3

installation to make all parts of macOS

~/Library/Preferences/com.devon-

aware of the additional services that come

technologies.think3.*

with DEVONthink.

All DEVONthink-specific scripts in ~/
Library/Scripts

UPDATING
Updates to DEVONthink are done per the
schedule set in Preferences > General > Check
for Updates.

All DEVONthink-specific workflows in ~/
Library/Workflows/
All DEVONthink-specific scripts in ~/
Library/PDF Services/
Uninstall the DEVONthink browser

If you need to manually update the software,

extension, following the uninstallation

follow the previous installation instructions,

process for the particular browser.

but allow the Finder to overwrite the

Bookmarklets from your web browser

old version. Your database(s) will not be

The reference to the global inbox folder in

affected. To avoid any potential problems, do

your Finder's sidebar

not use a third-party uninstaller utility. Just

Keychain entries containing devoncloudy

replace the current version, as directed.

in the name

App Store to Free-World Conversion: If you

~/Library/Mail/Bundles/

purchased DEVONthink in the Mac App Store

DEVONthink.mailbundle

you can also download the update from the
Download page. It will retrieve the existing
receipt and accept it as valid license.

UNINSTALLING

Note: In troubleshooting situations, please
do not uninstall the software without
talking to our support team beforehand.
Most issues can be resolved without
uninstalling the software.

If for some reason you need to fully uninstall
DEVONthink from your Mac, trash the
following files and folders (~ stands for your
account's home folder):
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DEVONTHINK SIMPLIFIED

DEVONthink is a very flexible application,

DEVONthink has two main window types: a

appealing to a broad range of people and

main window (seen immediately when the

accommodating many different working

software opens), and document windows.

styles. Since people use it in such diverse

These windows are used in already familiar

ways, it often leads people to believe there

ways, supporting drag and drop, sorting on

is a "steep learning curve" associated with

different attributes, full screen views, etc.

it. The truth of the matter is DEVONthink is

Whether you are working (or playing) in

a powerful application built on simple, and

DEVONthink, you will be using one or both

often familiar components and concepts.

window types.

Here we'll cover the basics.

INTERFACE

DEVONthink supports different ways of
viewing your items, e.g., in lists or as icons.
You can show or hide many details in the
At its core, DEVONthink is a multi-window,

window, allowing you to work in very simple

document-based application. Multi-window

or complex views of your data. Specifics

merely means you can have more than one

about windows and their component panes

window open. Document-based means it

and bars are discussed in more detail in the

supports viewing, and in some cases editing,

Windows and Inspectors chapters.

documents. Apple Notes is an example of a
document-based application without multiwindow support.

DEVONthink also has a powerful array of
tools found in its menus. Many of these are
also found in the contextual menus when
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Control-clicking items in the software. And

Global Inbox: Displayed as

to fine-tune some of the options, it also has

launch DEVONthink, you will immediately

extensive preferences.

see a database called Inbox. This is a special

, when you

database and a core component of the
DATABASES

software. As a core database, you can't

Beyond the interface, DEVONthink has only a
few core working components: databases and
items. Items are comprised of two essential
components: groups and documents.
Note: Throughout the documentation, we
use item to represent both groups and
documents. Things that only apply to one
or the other will use the appropriate term.
Displayed as

and shown only in the

delete or close it, as it provides an always
open database for quickly storing unfiled or
transient data.
Imagine you are reading about fission
reactions and someone sends a link about
a vacation place in Bali. You jump to the
website and quickly clip a webarchive of
the page. But instead of putting it in your
research database, you add it to the Global
Inbox and get back to work. You can go

Navigate sidebar, databases are the

back later and read or sort things to other

fundamental unit in DEVONthink, filled with

databases. If you are familiar with Getting

items. No matter if your content is grouped,

Things Done you'll recognize the concept.

ungrouped, or a mix, it is all housed in a
database. You add, remove, organize, and
search for files within DEVONthink, just as
you've done in the Finder forever. Simple.
When you create a database, it is made
as a self-contained package in the Finder.
Packages are technically folders that are
handled like single files by the Finder.
DEVONthink databases are not merely a

The Global Inbox is also special as it is the
only database you can add a shortcut to
in the Finder's sidebar. This allows you to
save a file into the Global Inbox from other
applications.
All databases also have an Inbox group with
the same purpose as the Global Inbox. It just
allows you to save unfiled data to a more
specific database, as needed.

series of files and folders in the Finder, but
are isolated from each other and function
a bit more like disks. When you plug in an
external drive, it appears in the Finder's
sidebar isolated from other disks, but still
capable of moving and organizing data on it.
In a similar fashion, open databases appear
in DEVONthink's sidebar and behave in much
the same way.

GROUPS
One of the two basic items are groups. No
different than the folders and groups found
in many other applications, they merely
serve as ways to keep certain bits of data
together. But within the DEVONthink groups
are a few variations. They are all simple to
recognize and understand, but they bear
being introduced.
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Ordinary Groups: Displayed as

, these are

As you add items to a group tag, they are

analogous to folders in the Finder. Except for

automatically tagged with the parent folders'

underlying technology, groups operate in the

name. Similarly, removing items from a group

same fashion. Creating, adding and removing

tag will remove the parent tags. Also, if you

contents, and deleting are all essentially the

create sub-groups, these will also be created

same. Just as in the Finder, you can create

as group tags. This can be useful if you're

subgroups to suit your needs.

using a group for staging purposes, e.g., a
groups for unassigned, in progress, and done

Looking and behaving like folders you've used
in the Finder, groups are the simplest way to
segregate data. DEVONthink allows you to

items. Moving files between these groups
would change the tag to its current parent
group.

create deeply nested hierarchies or simple
top level groups, whatever you need to keep

Smart Groups: Displayed as

things organized in a way that makes sense to

should be familiar to anyone using saved

you.

searches in the Finder. Similar to them, smart

New empty groups can be made with the
Data > New > Group command. Groups
of selected items can be easily made and
unmade via the Group Items and Ungroup
Items commands in the Data menu. These
commands are also in the contextual menu.
Groups are also the target of DEVONthink's
classify function. The AI compares
document contents and locations and offers
suggestions for where items may best be
filed. As documents are filed, manually or
taking the AI's suggestions, it becomes more
and more adept at helping you file more
efficiently.
Group Tags: Displayed as

, smart groups

groups don't actually contain anything. They
merely show you items matching the criteria
you specify. Sometimes broadly used in
situations where deeply nested groups are
not used, you can create as many as you'd like
no matter your approach.
These special groups allow you to create
virtual groups based on any number of
matching criteria. These can be simple, e.g.,
"all PDF files in a database", or complex, like
"all unread documents with a specific color
label added in the last week but excluding
HTML files". If you like to use a looser filing
method, using smart groups allows you
to file your items with less concern about
, these are

where they're located in the database.

created and operate like ordinary groups, with

With smart groups you can also have items

one extra function: the name of a group tag is

appear in more than one smart group without

applied as a tag to its contents (sometimes

replicating or duplicating files explicitly. For

referred to as "children"). By unchecking

example, a smart group could show items

Exclude Groups from Tagging in a database's

tagged with "taxes". You could then create

properties, any group you create will function

another smart group with items tagged with

this way. For individual groups, you have the

"taxes","business", and "2018".

option of choosing Exclude from Tagging from
the contextual menu or Info inspector.
DEVONthink 3.6 Documentation, page 9

Local smart groups, i.e., ones applied to

vacation you want to link to in a Markdown

a specific database, can be created and

document you're working on. They're all just

edited via the Data > New > Smart Group

documents.

command. You can also find this command in
the contextual menu when Control-clicking
in the item list. Smart groups can also be
created when doing an Advanced search.

DEVONthink supports adding many kinds
of files to your databases, but note the
type of file determines its usefulness in the
database. For example, images can easily

When you create a new database,

be added but searching for them is limited

DEVONthink automatically adds a few

to searching by attributes like file type or

of predefined smart groups for your

filename. Remember DEVONthink excels at

convenience:

text-based operations, so files like rich text

All Images: Shows all images.

or PDFs are very well supported.
All PDF Documents: Shows all PDF

Note: More information on the types of

documents.

files you can create or import can be found

Duplicates: Lists all duplicates.

in the Documents chapter.

Note: Smart groups filtering on dates or

While not types of document per se, there

unread status are shown with special icons.

are two variations on documents available to
you: duplicates and replicants.

Smart Rules: Displayed as

and found only

in the Navigate sidebar, smart rules are a

Duplicates: Displayed with

to the right of

type of smart group with an extra function:

a document's name or the name optionally

they not only match items by the criteria you

shown in blue type, there are two ways to

specify, they can also act on them. These

get a duplicate in your database. Firstly, just

actions can even trigger when certain events

as you'd expect in the Finder, select a file

happen. For example, you could have a smart

and press ⌘D: a duplicate is made. Secondly,

rule matching PDFs in the Global Inbox and

if DEVONthink examines the contents and

have newly added PDFs be added to the

determines it has another file with the same

Reading List.

content, it will mark them as duplicates.
Duplicates are separate files, and changes

DOCUMENTS

to the content of one should remove its
duplicate status.

The second basic item in DEVONthink are
documents. No different than the Finder,

Replicants: Displayed with

to the right of

documents are any files you add or create in

a document's name or the name optionally

your databases. Perhaps you are importing

shown in red type, replicants are conceptually

spreadsheets for work, or PDFs for your

similar to aliases in the Finder or a second

thesis. Maybe some photos from your

phone book entry for the very same person.
Replicants are one file showing up in more
than one location. However, they consume
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no more space than a single file. Since they
are clones, changes made to any instance
of a document apply to all instances. This
makes them useful when you want to file a
document in more than one location, but
don't want to have to update each document
individually. It can also be useful if you have
larger files you want filed in more than
one group. A 10 MB PDF, replicated in ten

THE DETAILS
We hope this has given you some insight
into the basics of DEVONthink. DEVONthink
is deep and powerful, but understanding
these basic concepts and seeing parts you
are already familiar with will hopefully dispel
some of the "fear" that it's complicated and
hard to learn.

different groups, would only use 10 MB of

That being said, we also have more in-depth

space in the database.

information for you. From simple overviews

There is also the possibility of having a
document that is both replicated and a

of menu commands to details in the appendix
can be found in the remainder of this guide.

duplicate. This will display this icon to the
right of the name:

BUILDING YOUR DATABASE

It's important that you understand how

The first step in starting your own custom

replicants work before you begin making

database is to create a new database with

changes to documents. Any changes to a

File > New Database. Give your database

replicant are carried over to all replicants; as

an easily recognizable name, and choose

you might imagine, this means that you can

where you want to save your database. We

to do some very powerful (and potentially

advocate putting them in a folder in your

negative) things with your database's

home directory, like ~/Databases. With your

contents via replicants. Duplicates, on the

new database created, you are ready to add

other hand, allow you to change the files

information.

without modifying the original document
or group. Duplicates are less powerful than
replicants, but no less important in the grand
scheme of database organization.

Encrypted Databases: If you have databases
containing sensitive or private information,
you can create an encrypted database. This
is specialized AES-256 encrypted disk image

On a technical side note, when you add an

that will not appear in the Finder or your

ordinary tag to a file, a replicant is made in

desktop when it's open. In the Navigate

the appropriate tag group.

sidebar, you will see a key icon to the right
of the database's name, denoting it is an

Note: Replicants cannot be created in the

encrypted database. Quitting DEVONthink

same location as the originating file, nor

or closing the database unmounts the disk,

can they be made across databases.

so you are always required to enter the
password to access it.

DEVONthink 3.6 Documentation, page 11

Choose File > New Encrypted Database and

more selective in what you add (especially

enter a password that will be used to unlock

in the beginning). Having a large, "dump it all

it. Enter a reasonable anticipated size for

in" database can contain a lot of files that

the database, in megabytes or gigabytes.

will do you no practical good (for example,

This is how large you think the database will

DEVONthink can't read your Microsoft Office

get. Since the encrypted database functions

user profile files), and weeding these files out

like a connected drive, you define how large

after-the-fact can be both time-consuming

it is and "fill it up". You can choose to let

and frustrating. Also remember, DEVONthink

Spotlight index the contents, but bear in

has to index metadata and contents of any

mind the Spotlight index is stored locally and

compatible files. This will be less productive

isn't encrypted. This means someone could

if you add files you'd never want to use or

find a document in the database exists via

search for.

a Spotlight search. However, they wouldn't
be able to open and access the database
without the proper password.

Here's a practical example: Your iTunes
database runs over 22 gigabytes. There's
nothing to be gained by simply copying

Note: You cannot create or store a

that into a DEVONthink database. Copying

database in a cloud-synced folder, e.g.,

the iTunes database into DEVONthink

iCloud Drive or Dropbox. This is not data-

would result in a large, inefficient, and slow

safe so the behavior is explicitly disallowed.

DEVONthink database, and would cripple

The advocated location is a folder in your

DEVONthink's ability to manage and use

home directory, like ~/Databases. If you

content in a well-designed manner (much

try to open a database in one of these

less perform simple search and organizational

locations, you will be prompted to let

tasks).

DEVONthink move the database, or reveal
it so you can manually relocate it.

ADDING YOUR FILES

As your growing databases use RAM,
processor time, etc., smaller, more focused
databases are often a more effective
approach than using singular, monolithic

After you've created your database, you'll

databases. Separate databases generally

add your files to it. Often it's a simple

perform better, sync faster, and in the rare

matter of dragging and dropping files into

case of a catastrophe, can help avoid data

your database, but we've covered several

loss since you're not keeping "all your eggs in

additional methods in the In and Out chapter.

one basket". Another benefit of this approach

Also, please take a moment to review the

is the ability to conserve some machine

Import and Index section to familiarize

resources. With a single, large database all

yourself with these two options.

the information is always using resources,

While you may be tempted to dump every
file on your hard drive into DEVONthink
and sort it out later, you're best off being

even files unrelated to what you're working
on at the moment. With separate databases,
you can close and open specific databases as
the need dictates.
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One way to effectively create separate

sense to you. There is no right or wrong way

databases is to use a topical database

to organize it. This is something you've likely

approach. Create multiple databases, with

already been doing in the Finder, making

each holding only related information: a bird

folders and filing things in them. Apply the

watching database full of birding articles and

same personal choices to DEVONthink. You

newsletters; a quantum physics research

can also use smart groups to create virtual

database with research briefs and email.

groups.

This method can improve the effectiveness
of DEVONthink's artificial intelligence
(AI) features with each database. The AI
work best within a database that contains
contextual relationships among many
documents; clogging your new database with
everything from A (apple pie recipes) to Z
(Zengobi user documents) will only hamper
the AI's ability to work effectively.

Remember that creating databases isn't an
inviolable commitment. Create and destroy
them as you see fit. Start with one way of
organization and decide later to re-organize
your databases. With DEVONthink you can
keep multiple databases open simultaneously,
easily moving documents from one database
to the other at any time. As you work with
your databases, new ideas may spark new

Having topical databases can help down the

approaches which can easily be tried and

road as well. You may be collaborating on a

adopted or discarded.

database, syncing between machines in a
group. Imagine having just one database: You
decide to share your painstakingly researched
academic articles with colleagues, only to
find that you've mistakenly also shared
personal financial records and chats. Not
hard to imagine how that has the potential to
be both dangerous and embarrassing. Having
multiple, topical databases will allow you to
keep your data separate and private.

ORGANIZING

CASE STUDY: BILL'S DATABASE FARM
Bill DeVille, formerly DEVONtechnologies'
Evangelist, worked in a number of scientific
areas. Bill's main database covered
environmental science and technology
topics, with related interests in science
and technology exchanges with developing
nations. The database even contained some
projects dealing with graduate education
in environmental sciences and engineering.
There's a broad topical relationship among

Database organization depends on the

these subjects and the database covers

parties involved. For collaborative work,

disciplines ranging from chemistry, toxicology,

you'll want to organize it in a manner that's

statistics, risk assessment, and engineering

understandable to all parties using it. This is

to economics, legal, regulatory, and policy

especially important as our sync technology

issues. These disciplines fit together and

is a mirroring sync, meaning changes to one

combinations of these topics are necessary in

copy of the database gets synced to the

many real-world cases.

other copies. For personal work, just set
up your database in a manner that makes
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As you can imagine from the above
description, Bill's main database was quite
large, containing about 20,000 documents
and over 20,000,000 total words. Because
of the relationships knitting together all
these scientific, technical, legal, and policy
issues, the artificial intelligence features
of DEVONthink worked very well for Bill in
researching the database and contextualizing
the information.

TAGGING
Tagging is a common method of creating
contextual relationships between documents.
For example, you can apply a "hobby" tag
to a woodworking article and a sewing
machine PDF manual. You would then
find both documents when searching for
the "hobby" tag. Used in the Finder and
many other applications, DEVONthink also
supports tagging in your databases (including

In addition to his main database, Bill had

preserving Finder tags on imported and

seven additional databases (so, eight total).

indexed items). Tags are either ordinary tags

For example, he had one database for Apple

or group tags, each discussed below.

Newton literature he has accumulated over
the years. It's almost as big as his main
database, but the topical coverage has no
practical relationship to the main database,
so Bill kept the Apple Newton literature in its
own domain. If he were to keep this unrelated
information in his main research database,
the result would be a larger, slower database,
with poorer performance by the artificial
intelligence.
ORDINARY TAGS
Occasionally, Bill added topical materials to
it that are not related to its main purpose.
However, when those "unrelated" topics grew
large enough in volume, he spun them off into

Similar to tagging methods used in other
applications, ordinary tags are added to
items by you.

to a new database in order to preserve AI

Creating tags: When you add a tag to an item

accuracy and relevance.

for the first time, a tag group is automatically

If you'd like to follow Bill's method, start by
creating a database with some collections
of files that interest you, but don't be afraid
to create other databases that contain
"different" material as your interests, and
main your database, grow. And if you need
to search across databases, simply open
all of them at the same time. DEVONthink

created in the Tags section for the current
database. However, if you want to proactively
create tags to be used later, you can select
the Tags section for the database and choose
the Data > New > Tag command. You can
also choose New Tag from the contextual
menu when Control-clicking the Tags for the
database.

searches all of them almost simultaneously.
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Applying tags: When you apply a tag to an

Tags can also be applied by more automated

item, a replicant of that item is created in the

means, e.g., scripting and smart rules. see the

Tags section for the current database. For

Automation chapter for more information.

each tag you apply, you will have a replicant
in each tag group. These are not the original
items, but only instances of the items. If
you delete a tag group, the group and the
replicants it contains are removed. The
original items in the database remain intact.

NESTED TAGS
Sometimes referred to as "hierarchical tags",
nested tags are a series of related ordinary
tags, combined under a parent tag. When
you add a child tag, the item automatically

When applying tags to indexed items, the

inherits the parent tags. In the example

tags are immediately written to the indexed

shown below, adding a tag of "Casper" to an

files as macOS Tags. If you tag imported

item would automatically add the "Wyoming"

items, tags are handled internally, but will be

and "US" tags.

applied to the files when you export them
or drag and drop them from DEVONthink to
the Finder. However, you can still search for
them with a Spotlight search of tag:myTag if

Note: If you are having trouble deleting a
tag from an item, check to see if you are
adding a nested tag.

you have enabled Create Spotlight Index in a

Caution: Tags for a database can have the

database's Database Properties.

same name. This may seem illogical, but it's

Ordinary tags are most commonly applied to
items by these methods:

something more commonly seen that you
may expect. For example, say you have a
travel database with points of interest like

Type tags into the Tag bar under a

restaurants tagged in different locations. You

document's View/Edit pane.

may find yourself with a tag structure like

Type tags into the Tags section of the

this…

Info inspector or the Info popover for a
document.
Drag items to a tag in the Tags section
of the Navigate sidebar. Note: If you drag
an item to a tag in another database,
that item will be moved to the receiving
database.
In the case of multiple selected items, any
tags common to all the items will be shown
in the Info inspector and Info popup. Tags
unique to specific files aren't displayed.
However, you can add tags common to all the

Example:
US
Wyoming
Casper
Restaurant
Minnesota
St. Paul
Restaurant

If you added a tag Restaurant to an item,
what tag would it go to? It actually would go
to the most recently entered instance of the
Restaurant tag.

selected items using these views.
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So how is this resolved? Tags are meant to

creatively. They also work in conjunction

be unique, so eliminating redundant tags is

with ordinary tags, so you can employ both

first priority. Restaurants aren't specific to a

methods in one database.

geographic location. Create the Restaurant
tag as a top level tag. If you had a need
for hierarchy with the tag, perhaps for tax
purposes, you could move it into a parent
Tag of Entertainment. Then you would get
both tags when you added Restaurant. But
again, if you anticipate wanting to use the tag
without the parent tag, you should make it a
top level tag.

Example:
Imagine you have a work database with
groups for different stages of a project:
Unreviewed, Assigned, In Progress, On
Hold, and Done. At the beginning of
the process, you'd put the item in the
Unreviewed group and it would be tagged
as such. After reviewing, you could move
the file into the Assigned group and

Also, you shouldn't view the tags as a group

the previous tag would be removed and

structure in and of itself. Nested tags are just

replaced with Assigned. As the project

meant to group tags specifically related to

moves through the staging groups, the tag

each other, so they can be applied en masse.

would change.

Note: Tagging methods and philosophy is

And of course you can use ordinary

full of strong opinions. Many people feel

tags, e.g., Reviewed or a client identifier,

tagging should always be flat; only top

on these items. Those tags would be

level tags and no hierarchies. DEVONthink

preserved no matter where you move them

accommodates both approaches. However,

in the databases.

if you want to used nested tags, we hope
you carefully consider the caution we've
presented and use a hybrid method to
avoid unexpected behavior.

GROUP TAGS

Groups tags are applied by DEVONthink
automatically. But you can also use do some
automatic filing by entering existing group
tags manually. If you enter the name of an
existing group that is not excluded from
tagging into the Tag bar or an Info panel or

Previously discussed in the Groups section

popover, the item will be replicated to the

earlier in this chapter, group tags allow

appropriate group. You can also drag an item

you to dynamically assign tags based on

to a group tag in the Tag Cloud at the bottom

their location. As you add files to a group,

of the Navigate sidebar.

they have tags of the parent groups' name
assigned to them. Similarly, if you move
the items to a new group, the tags are
removed and new ones applied relative to
the new location. Whether used statically

Considerations: When you enable using group
tags for a database, it starts as an all-ornothing situation. All groups in the database
function as group tags.

or dynamically, group tags can be used
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If you want to use group tags for most groups
in a database, you can Control-click specific
groups and choose Exclude from Tagging. You
can also choose this option in the Exclude
from… section of the Info inspector or Info
popup for a specific group. However, note
you must change this setting on all individual
groups you'd like to exclude.
If you only want a limited number of tags, it

SEARCH AND GATHER
Finally, tags have two main functions:
segregating data and searching for data. You
use tags to gather items together in certain
contexts. You also use tags to search for
those items.
Searching for items by their tags is easily
done in a few ways:

would be advisable to exclude groups from

Tag cloud: The Tags Cloud allows you to

tagging for the database and use ordinary

filter the current list of files by clicking on

tags instead.

available tags. As you click, only related
tags are shown so you can fine-tune the

AUTOCOMPLETION
When you are typing tags, an autocompletion
list will appear. In the Global Inbox, tags
from any open databases are shown as
potential tags. In other databases, the items
displayed are only from the tags of the
current database.
While group tags aren't added to the Tags
group for a database, they are displayed in
autocompletion suggestions.

items displayed in the item list.
Search field: The search field at the top of
every main window allows you to search for
tags by using the advanced options for a
search. You can also search for tags using
a simple tags: prefix. Multiple tags can be
specified, separated by commas. You can
also use tags!:, to exclude tags.
Gathering similarly tagged items is powerfully
achieved with Smart Groups. Smart groups
allow you to use the smart group editor

Tags and Aliases: DEVONthink also honors

controls to set criteria to be matched.

aliases added to groups. You can add

Included and excluded tags can be added as

"alternative names" to a group using Info

criteria. Files matching the parameters of the

popup or inspector and later use these

smart group are shown, regardless of their

alternative names as a tag. Continuing the

location in the database. This way you can

previous example, you could add an alias of

leave your files where they are and create

IP to the In Progress group. Now, type

virtual folders for specific purposes.

IP as a tag and it will be replicated to the
In Progress group. When you view the

A WORD ABOUT BACKUPS

file, you will see the proper group tag was
automatically added.

For many users, the value of the data is much
greater than the value of the computer that
hosts it. There are many things that could
go wrong. Your notebook computer could be
dropped, lost, or stolen. Your hard drive will
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fail (it's not a matter if, but when). A power

Database Archive or Scripts > Export > Daily

outage could corrupt the files on your hard

Backup Archive to create a ZIP file of the

drive. For the truly paranoid (remember,

database. The former option allows you to

paranoia is sometimes justified), how

choose specific place; the latter creates it in

significant would the loss of your database

a Backup folder in your home folder.

be if your house or office were to burn down?
Avoid insomnia and back up your database(s)
frequently. Your data stored in DEVONthink is
valuable, so back it up.

INTERNAL BACKUPS

Lastly, as events such as house fires and
natural disaster frequently prove, valuable
data should probably be kept at more than
one location. Consider saving a copy of your
backed up information at a secure, off-site
location such as a bank safe, or put the

DEVONthink backs up its database index

exported ZIP files of your database in your

every week, either immediately after opening

cloud account.

the database (if the backup is overdue) or
during the day when appropriate.

Note: As noted in our FAQ, sync is not a
backup, neither advertised nor advocated

Note: The internal backups are mainly a

as such. While database restoration may

troubleshooting mechanism for use in the

be possible with sync data, it is not meant

application. Backing up your files, including

to be relied upon or used in lieu of proper

your DEVONthink databases, is up to you.

primary backups.

FULL BACKUPS
We strongly recommend you get in the

TUTORIALS, SCREEN CASTS,
AND MORE

habit of triggering backups whenever you

In addition to this help resource, explore

have invested substantial time and effort

tutorials and install pre-made scripts and

into modifying the database. Apple's Time

templates that extend DEVONthink's

Machine and an external drive is an easy

functionality in the Support Assistant. Also

way to do this. Simply connect the drive and

new tutorials are shown in the Extras sidebar.

let Time Machine do its thing. With the low
cost of portable external drives, it's even

For a great resource of tips, promotions,

feasible to take a 1 TB drive that can fit in a

and release announcements, check out our

shirt pocket for backups when you're out and

company blog.

about. Online backups such as Arq Backup
are an alternative if you don't want to own
another piece of hardware to care about.
As a secondary backup option, you can create

And if you feel like talking to other people
using our applications, you'll find discussion,
camaraderie, and well over a decade's worth
of information at our Forums.

an optimized and compressed copy of the
whole database that you can then save on
a server or other media. Use File > Export >
DEVONthink 3.6 Documentation, page 18

Take time to learn how to work with the
software — and to decide how you want the
software to work. You'll be rewarded with a
powerful assistant for all your information
organization needs.
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The number of possible uses for DEVONthink

The Concordance function allows you to

is nearly endless. In this chapter we've tried

view a list of all the words contained in a

to outline a few typical use cases that show

document or database. Selecting a word

how you can use DEVONthink in your daily life

highlights the word in the current document.

and work.

Additionally, a graph of related words is
shown at the bottom of the Concordance.

ANALYZE TEXT DOCUMENTS

Right-click a word in the list or graph to
exclude them. And if you're wondering about

With its built-in artificial intelligence (AI)

other documents containing a word, double-

functions, DEVONthink can be used to

click one to start a search for that term.

analyze the documents in your databases.

Other functions of the AI's analyses include
the Classify function. This examines the text
content and locations of other documents
in your database and makes suggestions for
filing the current document. Additionally, See
Also lists documents with a similar content to
help find connections you may not have found
otherwise.
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Possible uses:

Continue to read here:

Analyze the complexity and focus of a

Import documents from the file system

specific document collection

Use the See Also & Classify Inspector

Find relationships between documents or

Use the Concordance Inspector

snippets quickly
Clean up large collections of documents

ARCHIVE YOUR MESSAGES
DEVONthink is the repository for emails you
want to save.

Its hierarchical groups structure, automatic

attachments, are preserved when possible.

classification function, and powerful

You even can reply to messages directly from

search engine are perfectly suited to

DEVONthink's contextual menu commands!

adding, sorting, and finding emails in
your databases. DEVONthink comes with

Possible uses:

advanced email archiving functions that

Archive important correspondence

transfer selected messages or mailboxes

Archive invoices, offers, purchases, or

from Apple Mail, Microsoft Outlook, and

software licenses

any email applications using standard

Store interesting news bits from

Unix mailboxes, e.g., Thunderbird, to

newsletters

a DEVONthink database. The original

Keep project-related emails and other

structure of the message, as well as all

documents together
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Continue to read here:
Archive email messages
Reply to archived emails
Organize data using Classify and See Also

ARCHIVE PRINTED
DOCUMENTS

When you are working in a team, use the
embedded web server to give your colleagues
access to your data using an interactive web
interface. Even friends using Windows are
invited.
Possible uses:
Archive your important correspondence

DEVONthink is the "paperless office" solution

Archive invoices, offers, purchases, or

for the Mac, a central hub for all your paper

software licenses

and electronic documents.

Store printed documents together with
electronic documents
Keep project-related emails and other
documents together
Keep a central repository for all team
members
Continue to read here:
Scan paper documents
Scan with the Fujitsu ScanSnap
Import existing files with OCR
Organize data using Classify and See Also

Using the integrated scanner support you

Share data with your team

can directly scan documents, make them
searchable through OCR (optical character

BROWSE THE INTERNET

recognition),and file them in a database. Of
course, you can also make existing scanned

Besides being a knowledge and information

documents searchable. If you own a Fujitsu

database, DEVONthink has built-in web

ScanSnap or other compatible document

browsing capabilities. This allows you to

scanner, you can use the fast auto-feeder to

browse and capture online information

scan batches of sheets in one go.

directly in a database.
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DEVONthink enables you to treat web pages

Grab data from web sites and store it in

the same way as you treat documents.

DEVONthink

Whenever you select a bookmark,

Capture and archive complete web pages

DEVONthink immediately loads and displays
its content live from the internet in the

Continue to read here:

View/Edit pane. You can also open a page in

Capture data from the Web

a separate document window. Archive the

Create new bookmarks or HTML

complete page for offline viewing, add a new

documents

bookmark, or drag elements from the page

View "live" and local HTML pages

into your database.

Integrate news feeds with your data

DEVONthink also handles RSS, RDF, Atom,
and JSON news feeds, either through feed
documents or by simply displaying them
via the built-in web browser. Stay up-todate with your subject and clip important
information right away.
Possible uses:
Visit frequently used web sites in a
convenient interface
Integrate "live" content from the web with
your other documents
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CAPTURE DATA FROM THE
WEB

All of these options, except the bookmark,
capture the text content of the page (or a
selected area of it) and hyperlinks if present,
and preserve the text information for
searches in DEVONthink.
Note: There are a number of web sites
that prohibit use of some of the capture
options described above. A secure banking
site or a university portal to journals may
direct a bookmarklet or script capture
option to the login page, which will be
captured instead of the desired content. A
capture option that requires re-download
of the page on such sites will capture only

Increasingly, information is provided not

the login page. The page always can be

on paper but directly through web sites,

selected and captured as rich or plain

blogs, online news sites, social media, and

text. The viewed page can be captured by

user forums. DEVONthink offers a variety of

"printing" it as PDF to the database.

options for conveniently capturing data from
the web:
Bookmark: Captures only the address (URL,
uniform resource locator) of the page.
HTML page: Saves the source code of
the page to the database, but images are
downloaded from the web each time the
page is displayed in the database.
Web archive: Saves both the HTML code
and all resources, like images, necessary to
display the page.

Possible uses:
Capture important news in an easily
searchable database
Collect all relevant data for your project in
one place
Collect links to web pages and captured
data about the same subject in one group
Save data from the web in future-proof
formats such as PDF
Continue to read here:

Rich/Plain text: Grabs selected text/
images and hyperlinks, but avoids saving
unwanted areas of the page to the
database. A plain text capture will not
include formatting, images or links.
PDF: "Freezes" the web page, just like
printing to paper. PDFs from web pages can
be paginated or non-paginated.

Capture data using Services
Capture data using scripts
Capture data with bookmarklets or
browser extensions
Add the global inbox to the Finder's sidebar
"Print" any web page or document as PDF
to your database
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CATALOG YOUR SD CARDS OR
DVDS

CATALOG YOUR PHOTOS AND
MEDIA FILES

By using the Index function, you can use

Besides storing text documents and

DEVONthink to set up a catalog for your data

PDF files, DEVONthink can also contain

DVDs, SD cards, or other removable volumes.

multimedia data such as photos, illustrations,

Create a group for each disk by using the

music, or movies in your databases.

index function, and organize your disks/
groups in any way you like. When you need
a specific file, search for it in DEVONthink,
insert the volume, Control-click the file in
DEVONthink, and select Open With to open
the original file on the removable volume.
Note you will only see a thumbnail if the
disk or volume is not available. A message
to Mount Volume will be shown if a server
volume is unavailable. Clicking this button
should remount the volume, if possible. For
removable disks, DVDs, etc., you will have to
reinsert the media.
Possible uses:

While not designed to replace Photos
or Music, DEVONthink can be used as a

Find files even when they're on a removable

repository for images you frequently use or

volume that is not currently mounted

as an interface to your music library (if you

Create a virtual library of SD cards and

don't like other music software). If you do not

other media

want to import these files, leave them where

Integrate static documents with other

they are in the file system. You can index the

project-related data

files instead and access them from within
DEVONthink See also p. 129ff

Continue to read here:
Possible uses:
Import or index files
Search your database

Create a dedicated database for photos

Launch the original file of an index item

only
View your images in full screen mode
Include project-related images, audio, and
video in your databases
Play your music from within your work
environment

DEVONthink 3.6 Documentation, page 25

Continue to read here:

Possible uses:

Import or index files

Collect recent news from your favorite web

View files as thumbnails

sites

View images and movies

Keep important information from any

Search your database

source and your other project-related
documents together

COLLECT TEXT SNIPPETS AND
OTHER VALUABLE DATA
Use macOS's handy Services menu for
collecting and organizing information bits and
snippets to DEVONthink.

Create an info collection for a specific topic
Continue to read here:
Capture a note quickly using the Services
menu
Use the Sorter
Drag text clippings to the Groups panel

INDEX FILES ON YOUR HARD
DRIVE
Besides importing documents, DEVONthink
can also index files. When indexing files,
DEVONthink reads the contents of the file
and stores it for internal reference, but leaves
the files in place in the Finder. Use indexing
for easily accessing information stored on
removable volumes, creating a library of all
Select any piece of data and capture it to
the currently open database with a keystroke
or a quick visit to the Services menu. Most
true macOS applications such as TextEdit,
Safari, or DEVONthink itself support this

important documents regardless where they
are physically stored, or integrating files
stored elsewhere with your documents in
DEVONthink. See also p. 48ff
Possible uses:

mechanism.
Keep the folder structures you've created
DEVONthink automatically sets the title of

in the Finder, while allowing access to

the newly created snippet to the first line of

DEVONthink

text, so there's a good chance that you won't

Create a front-end for your document

even need to rename it. New snippets are

collection

created in the global inbox or the location you

Integrate indexed items with imported and

choose. Also, DEVONthink can help classify

items you've created in DEVONthink

and file the items using its built-in artificial
intelligence.
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Continue to read here:
Import or index files
Search your database
Launch the original file of an indexed item

Integrate "live" content from the web with
your other documents
Grab data from web sites and store it in
DEVONthink
Continue to read here:

MANAGE YOUR BOOKMARKS

Create a new bookmark

With its integrated, document-based

View "live" and local HTML pages

web browser, DEVONthink can be used

Drag URLs to the Sorter

as a bookmark manager. Organize all your
bookmarks as bookmark documents and visit
the web sites by simply selecting them with
a preview visible. DEVONthink loads the page
and displays it in the View/Edit pane.

SHARE PROJECT DATA
With its built-in synchronization, DEVONthink
allows you to have your databases on
multiple Apple devices. Changes made on one
machine propagate to the others, keeping
them in sync. It can also be used to manage a
shared project workspace.

If you want to open the web page in your
default browser, simply Control-click the
bookmark and choose Launch URL from the
contextual menu.

Keep all your project-related data in an easy
to structure database and share it with

Possible uses:
Manage your bookmarks
Keep project-related web pages and other
documents together

your team members. Use a shared WebDAV
volume, a shared cloud account, a local file
server, or direct connections to propagate
new data to the team automatically.

Visit frequently used web sites in a
convenient interface
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READ NEWS FEEDS

And if your coworkers don't use a Mac give
them access via DEVONthink's built-in web
server. You can set up web users and fine-

DEVONthink comes with built-in support

tune the access permissions so that visitors

for RSS, RDF, Atom, and JSON news feeds,

only gets access to what they should see.

which makes it a reliable basic news reader.

SSL/TLS encrypts all data in transit.

In addition, its integrated web browser

Possible uses:

supports news feeds and displays them
like any other web page. Use its document-

Organize project files, use advanced

oriented structure to organize bookmarks and

feature such as tags and smart groups

store news feeds like internet-updated smart

Add new data from any team member's

groups.

computer or even iOS device running
DEVONthink To Go
Integrate "live" data, e.g., web pages or
newsfeeds, with your other documents

Mix live news feeds with static documents,
e.g., in your project materials.
Possible uses:

Give your colleagues using Windows or
Linux access to your knowledge with web
sharing

Read your daily news in a convenient
interface
Integrate "live" newsfeeds with your other

Continue to read here:
Set up sync to share data with your team
members
Set up the local web server

documents
Grab interesting information easily and
store it in DEVONthink
Continue to read here:

Add smart groups to organize data
automatically
Add newsfeeds

Create a new bookmark or HTML
document
View "live" web pages and news feeds
Create a news feed document
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TAKE NOTES
DEVONthink is perfectly suited for taking
notes and organizing them.

WRITE TEXTS AND OUTLINE
PROJECTS
With its hierarchical group structure,
organization, and navigation functions, as well
as its advanced text editing capabilities and
full screen mode, DEVONthink is perfectly
suited for writing many kinds of documents,
from notes to whole books.

Quickly create new notes and file them in
your database using DEVONthink's Tools >
Take Note command to open the Sorter (or
an independent Take Note panel, if the Sorter
is hidden). Alternatively, use the Take Note
command in the Dock menu. Notes can be
created in plain or rich text, Markdown, or

Create new documents with just one click,

formatted note formats.

find related documents in your database,

Possible uses:

and connect them with Wiki-style or static
cross-links. Working these documents in

Write down ideas before they vanish

your databases, you can switch from one

Take quick phone messages

document to another with just one click, and

Keep project notes and your other project-

manage even large projects with ease.

related documents together
Utilize markers, like flags or color labels to
Continue to read here:
Create new documents
Create a new note using the Dock menu
Revise notes and documents using the
built-in rich text editor

help visually distinguish items, by importance
or other criteria using label names. And
similar to the Finder, you can create groups,
as deeply (or shallowly) nested as you'd like.
Possible uses:
Write notes, white papers, and letters
Write and organize book chapters

DEVONthink 3.6 Documentation, page 29

Organize your ideas or projects in outlines
Create a network of information for your
projects or interests

Continue to read here:
Create new documents
Use the built-in rich text editor
Use the See Also & Classify Inspector
Use the Concordance Inspector
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DOCUMENTS
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view/edit area and the navigation bar. These
will always be available when working with
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Document Linking

33

Plain and Rich Texts

34

PDFs

36

Markdown Documents

38

HTML-Based Formats

40

Sheets

43

Images, Audio, and Video

45

The view/edit pane is where you can see or

Office Documents, Email, and Others

46

edit the current document (with compatible

As DEVONthink is an information and
document management application, it
supports importing many different file
types. While not all formats are editable, if a
QuickLook plugin is installed on the machine,

a selected file. Additionally, there are a few
optional components available: the editing
bar (for compatible formats), the tag bar,
and the contextual menu.

VIEW/EDIT PANE

files). Each file type you view has its own
tools, contextual menu commands, and
keyboard shortcuts.

NAVIGATION BAR

the files should be viewable. Also, if a

At the top of the view/edit pane,

Spotlight importer for these files is installed,

DEVONthink shows a navigation bar that

the files should be indexed by DEVONthink

gives you access to some additional tools

and searchable. In addition, DEVONthink

that deal directly with the contents of

supports creating some common types

the document. Which tools are available

directly in the application.

depends on the type of the document you are

In the General section of this chapter, we will
discuss the essential window components
you'll use when viewing or editing these

viewing. The options below are shown in the
navigation bar for most file types. Specific
options are shown in the separate sections:

documents. Following that are chapters for

Navigates back to the last visited

the types of files DEVONthink supports.

document after following a link.
Navigates back to the next visited

GENERAL

document after going back.
Reloads the displayed page in a web view.

When working with files in DEVONthink,

Only visible for, e.g., bookmarks.

they can be viewed in the view/edit pane of

Shows an action menu with options for

a main window or in a separate document

opening the shown page in Safari, copy its

window. When viewing a document, there

address, or capture the page in a variety of

are two essential components visible: the

formats.
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Shows if the document is locked or

This offers quick access to some editing tools

editable.

related to the file type you're working on. See

Scrolls to the previous highlight, e.g., a

the appropriate file type section for more

search term occurrence.

info.

Scrolls to the next highlight, e.g., a search
term occurrence.

TAG BAR

Scrolls to the next page of the displayed
document.
Scrolls to the previous page of the
displayed document.
Switches to Text Alternative mode. Useful
for selecting text in uneditable formats,

The tag bar, which can be shown or hidden,
shows all tags associated with the document.
Click the tag bar and type to add tags; select
a tag and press the ⌫ Backspace or ⌦ Delete
key to remove it. See also p. 14ff

e.g., Word documents.

When you type the name of a tag,

Switches to Best Alternative mode. For

DEVONthink offers automatic completion.

Markdown documents, this is the rendered

Choose the right option with the mouse

HTML view.

or the arrow keys and press ↩ Return or

Word Count: Shows the number of
paragraphs, words, and characters of the

Enter to accept it. Press ⎋ Escape to use
whatever you entered. Auto-completion
prefers ordinary tags (tags represented in

displayed text.
URL: Shows the URL associated with the
displayed item, if one is present. If a PDF
annotation is selected the URL field shows

the Tags group) over groups used as tags,
and also matches sub-strings. Press ⇥ Tab to
enter another tag.

the associated URL if available. Click to

Note: The tag bar is also visible for

launch the URL in its default application.

multiple selected documents when all the

Hold the ⌥ Option or the ⌘ Command

documents have the same tags attached.

key to open the URL in a new tab. Holding

Use it to change the tags on multiple

⇧⌥ or ⇧⌘ opens the URL in a new tab and

documents.

selects it.
Page Count: Shows the number of pages

CONTEXTUAL MENU ITEMS

as well as the page number of the currently
displayed page. Click the page number in
PDF or PostScript documents and enter a
page number to jump directly to that page.

If you Control-click in many types of
documents in DEVONthink, you are presented
with a contextual menu showing many
options. The options displayed depend on
what you're clicking; e.g., selected text, and in

EDITING BAR

whether you're in an editing or preview mode.
For some formats, e.g., rich text or sheets,

As many of these commands are the same

there is another bar available: the Editing

for most formats, we have provided a list

bar. If you click this icon

, the editing bar

will appear in place of the Navigation bar.

DEVONthink 3.6 Documentation, page 32

in the appendix. Items specific to a format

on the method chosen in the WikiLinks

are listed in their respective sections in this

preferences. Note these are not item links.

chapter.

Make Link: In rich text files, you can select
words and choose Format > Make Link to

TOOLBAR & SHORTCUTS
DEVONthink can display documents in
separate windows when you double-click the
documents in a main window. Depending
on the type of document, the tools in the
toolbar can change. Even though not all tools
are always present in the default toolbar for
a particular type, you can easily add some by
choosing View > Customize Toolbar. Changes
made to the toolbar will be persistent for
that file type, but are independent of the
toolbars of other types.

create an active hyperlink of the selected
words. Clicking on the hyperlink will
generate a new WikiLinked document.
Relative and Absolute Links: Often used in
Markdown documents and also supported
in HTML-based formats, these are usually
links similar to what is seen in the source
code of web pages; e.g., /stylesheets/
styles.css. These are not item links.
Copy and Paste: Select an item in the
item list and choose Copy Item Link. This
captures the item's unique link to the
clipboard so you can paste it into another

Please find a list of toolbar items and

document or even another application.

shortcuts in the appendix.

Some other types of links can be captured,
e.g., page links. Refer to the Contextual

Note: Documents are automatically
saved every five minutes after the last
modification, when deactivating the
window, or when quitting DEVONthink.

menu section for the appropriate file
format in the Documents chapter.
Add Link: For text in rich text and
formatted notes, you can select words and
choose Format > Add Link. You can then

DOCUMENT LINKING
Documents in DEVONthink are independent
items but often have contextual relationships
with other documents in your databases.
Here are a few ways to make links in the text
of editable documents and establish those
connections:
WikiLinks: WikiLinks are specialized
links found in plain text, rich text, and
Markdown documents. Use them to link

add a URL, including an item link, to create
an active hyperlink of the selected words.
Drag and Drop: You can Option-Commanddrag and drop a file into a compatible
document to insert an item link.
Insert Link: Edit > Insert > Item Link opens
the Insert Item Link popover, allowing you
to add an item link to a document.
Of the methods listed above, the ones
utilizing item links are of special note.

to existing items or create documents
on-the-fly. For existing items, these links
are automatically detected depending
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INCOMING AND OUTGOING ITEM LINKS

PLAIN AND RICH TEXTS

Incoming and outgoing links are item links
DEVONthink has detected. The two types of
links function as sides of one operation. If you
create an item link to an image, the file will
have an outgoing link detected. The image
you have linked to will have an incoming link
detected since the file has a link pointing to
it.
Documents with incoming or outgoing links
will have a special property icon displayed to
the right of the filename in the item list. See
also p. 206ff . You can display a sortable
Incoming Item Links and Outgoing Item Links
column in the headers of the item list in List

PLAIN TEXT

view. There also are incoming and outgoing
item link criteria usable in toolbar searches,
smart groups, smart rules, and AppleScript.

Plain text files may seem too simple to be
truly useful. No styling. No images. Nothing
but text. But the reality is these simple files

VIEWING LINKS

are underlying a lot of your daily experience.
From the HTML code instructing your

See the Document > Links section of the

browser how to display a web site, to the

Inspectors chapter for information on viewing

code DEVONthink is written in, plain text is

the links of a document.

very powerful. DEVONthink supports plain
text files as a native, editable format.
Plain text files can be imported or created via
Data > New > Plain Text.

RICH TEXT
Word processing applications brought
us text with flair. Need some bold and
italic text? How about adding a photo to
the page? And color? These applications
were providing it all. But their formats are
proprietary so if you don't have the creator
application, you can't open the file or you'll
have to convert it first. The rich text format
provides a useful text format that supports
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formatted text. These files are generally

Add or edit a link applied to the selected

cross-platform compatible and editable in

text.

many applications. DEVONthink uses the

Convert selected text into an active link.

same text engine found in Apple TextEdit, so

This can be used to dynamically create Wiki

it's an easy transition if you're already familiar

documents.

with it.

Show or hide the ruler. Place tab stops with

You can attach other documents to rich
text documents simply by dragging them
into the text. Technically the rich text
document becomes an .rtfd package and
the dragged file is saved as part of the
package. Using the contextual menu, you can
show an attachment's content in a Quick
Look preview. Also, if you double-click an
attachment, it will open in the system default
application.

the mouse, then remove them by dragging
them off the ruler. Drag new tab stops (left
aligned, centered, right aligned, or decimal
aligned) from the repository at the right
side to their desired positions on the ruler.
Use the mouse to adjust the left and right
margins and indent.
Show the Fonts panel.
Show the Color Picker.

THE FORMAT BAR

Rich text files can be imported or created via
Data > New > Rich Text.

In addition to formatting options in the
Format menu and the simple controls in the
editing bar, DEVONthink provides another

EDITING BAR

toolbar just for rich text editing. Select

The navigation bar for rich text files includes

Format > Show Format Bar to display a set of

the Editing Bar. Click this

rich text controls under the toolbar in main

icon and

the editing bar will appear in place of the

or document windows. Similar to TextEdit, it

navigation bar. The tools available here

provides the following options:

consist of:

Styles: Select a predefined text style from

Edit the formatting of a list.

the pop-up menu. To define your own

Edit parameters of a table.

styles, choose Other to open the standard

Increase the size of the font.

macOS style editor. In the style editor,

Decrease the size of the font.

navigate back and forth through the styles

Set characters to be subscript.

of your document or the stored favorite

Set characters to be superscript.

styles. (Use the radio buttons to switch

Adjust the line spacing of selected text.

between document and favorite styles.)

Set bold on the text.

Click Select to select all occurrences

Set italic on the text.

of text with the displayed style in the

Set underlines on the text.

document, click Apply to apply the style

Set strikethrough on the text.

to selected text, or click Done to leave

Highlight selected text. This uses the

the style editor. To add a style from your

currently selected highlight color.

document to the favorites, click Add
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To Favorites; to remove a favorite, click

Copy Paragraph Link: Copies a link to the

Remove From Favorites.

current document, but appends a pointer

Font Controls: Displaying three dropdown

to the selected paragraph.

menus for, choosing the font face, font

Insert > ...: Inserts special characters or

weight, and font size.

items into the document.

Colors: Two buttons are available for

Quick Look Attachment: Opens a Quick

setting the text and background color.

Look panel for the selected attachment in

Basic Styling: Allows you to choose bold,

a rich text file.

italic, or underlines.

Split Document: Splits the document

Alignment: Align the current paragraph

at the current insertion position. A new

(the one with the insertion caret inside)

document is created for the text after

left, centered, justified, or right by clicking

the cursor position and removed from the

the according alignment buttons in the

current document. This can be used in rich

ruler.

text and plain text, including Markdown

Spacing: Choose the desired spacing for

content in edit mode.

the current paragraph from the Spacing
pop-up menu. Choose Other to enter

PDFS

values other than the ones shown.
Lists: Make the current paragraph a list
(indented and with a bullet or numbered)
by choosing the desired list style from the
Lists pop-up menu. Choose Other to define
your own list style.
Note: The built-in "mini outliner" is a nice
feature of the macOS rich text editor. On
any blank line in a rich text document,
type ⌥⇥ Option-Tab to create a bullet
point (macOS shows dashes instead of
bullets). Press ↩ Return for the next item,
and so on. Additional ⌥⇥ will increase the
indentation; a ↩ on a blank list line will

PDFs are a very common format, from

decrease it. The mini outliner uses hyphens

academia and online bill payments to

to indicate list items by default.

equipment manuals. Fortunately, they
are first-class citizens can be viewed

CONTEXTUAL MENU

and annotated within DEVONthink. The
annotation tools should be familiar and

In addition to the contextual menu items

include options like arrows, text, and link

available with text selections, rich text files
also feature these specific commands:
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annotations. While DEVONthink may not

view of PDF metadata, e.g., keywords, a list

have some options found in specialized PDF

of annotations, and a list of links detected in

applications, it is still a very capable PDF tool.

the document. Please refer to the Inspectors

PDFs often come directly from text
sources, like word processing or page layout
applications. The content of these files

chapter for more specifics.

NAVIGATION BAR

should be indexed and searchable on import.

In the navigation bar for PDFs, the number of

You can also acquire PDFs from scanned

pages in the document is displayed. Clicking

documents. These files will only have a text

on this navigation bar item opens a Go to

layer if OCR is done on them.

page function so you can quickly jump to a

For scanned PDFs, you can do OCR directly in
DEVONthink when needed.

specific page. In addition, there are options
to move to the first, previous, next, or last
page.

In the Tools menu there are several PDF
related commands, including access
to Annotation tools (also found in the
Navigation bar). Additionally, there are
commands for changing the display, e.g.,
single to two pages, in View > PDF Display.
PDF files can be imported. They can also be
created by capturing web content, directly
in DEVONthink or via our browser extension,
Clip to DEVONthink. You can also use the
PDF Service Save PDF to DEVONthink 3 in
the PDF dropdown of the print dialogs of
most macOS applications. This will print a
paginated PDF to your database.

EDITING BAR AND ANNOTATIONS
The navigation bar for PDF files includes the
Editing Bar, providing access to editing and
annotation tools. Click this

and the editing

bar will replace the navigation bar. The tools
available here consist of:
Select text for copy or highlighting.
Select annotations on the page. Doubleclick an annotation to edit its properties.
Press the ⌦ Delete key to remove the
annotation.
Move or scroll the current page.
Underline selected text in the document.

Inspector Panes: There are two inspector

Strike through selected text in the

panes with information specifically

document.

pertaining to PDF documents: the Content

Apply or remove highlighting on selected

Inspector and the Document Inspector.

text. The highlight color will be the color

The Content Inspector allows you to see a

selected in Format > Highlight Color.

list of thumbnails or an available table of

Alternately, click and hold to select another

contents. When this inspector displays the

color.

thumbnails, Tools > Split Document and the

Add a link to a selected area. Click and

same contextual menu command becomes

drag over an area to establish a hotspot

available to split the PDF before the current

for the link to be active. For the Link

page. The Document Inspector gives you a

Type, choose Link within PDF, navigate
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to another page and click Set to create a

pages. Use the Continuous option to allow

link between pages within the same PDF.

quick scrolling through the pages as one

Alternatively, choose URL and enter a URL

continuous document.

to an external item. This can be a web site

Previous/Next Page: Jumps to the previous

address, or drag files from the Finder or

or next page.

your DEVONthink databases into this field.

Rotate Left/Right: Rotates the current

Add a rectangle annotation.

page 90 degrees in the selected direction.

Add an oval annotation.

Insert Blank Page: Insert a new blank page

Add a line annotation.

before the current page.

Add a note annotation.

Delete Page: Delete the current page.

Add a text annotation. Drag to create

Reverse Page Order: Reverses the order of

a text box. To change the font, choose

the pages in the entire document.

Format > Font > Show Fonts.. Note only one
font can apply to each text annotation.

MARKDOWN DOCUMENTS

Rotate the current page left (counterclockwise).
Rotate the current page right (clockwise).
Add a new blank page before the current
page.
Delete the current page.
Reverse the page order of the document.
The annotation tools in the editing bar are
also available in the Tools > Annotate menu.

CONTEXTUAL MENU
In addition to many common contextual
menu items there are also a few PDF-specific

Markdown is a simple formatting language

options:

invented by John Gruber that has gained in
popularity over the past few years. It allows

Automatically Resize: When checked, the
zoom factor adjusts to the width of the
view/edit pane or document window.
Copy Page Link: Copies a URL to the
clipboard pointing directly to the shown

you to write in plain text, using some easily
learned control characters, to produce nicely
rendered HTML output. With some styling
and ingenuity, you can create a wide variety
of documents.

page of the document.
Delete Annotation: Deletes the selected

Markdown files can be imported or created

annotations.

via Data > New > Markdown text.

Single Page/Two Page (Continuous):
Displays the PDF as single or double
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Writing Markdown is essentially the same

![link](item.png): Use this when

as writing plain text documents. As you're

linking to an item in the same group as the

writing you can switch easily between a plain

Markdown document.

text editor and the rendered view or even

![link](group/item.png): Use this when

view both simultaneously using the side-by-

linking to an item in a sub-group of the

side view.

group containing the Markdown document.

Styling: Styling your Markdown documents
can be done with internal styling or externally
referenced stylesheets. If you have a specific
stylesheet you'd like to use globally, you can
specify one in Preferences > Media > Style
Sheet.. Here are the options:
Internal styling: <style type="text/
css"> … </style>
HTML Link: <link rel="stylesheet"
type="text/css" href="css/
styles.css" />
XHTML Link: CSS: css/styles.css.

![link](/group/item): Use this when you
are linking to an item in a group outside the
group containing the Markdown document.
For example, if you have common resources
in a specific group, you can link to them
using this format.
If you have enabled automatic WikiLinks >
Names & Aliases, documents can be detected
as you write your Markdown. These WikiLinks
are active when previewing the file and
are also preserved in a website export or
conversion to other formats.

XHTML headers must be placed at the very

Drag and drop items into a Markdown

top of the document.

document to add the appropriate links. Drag

Note: If no specific styling is applied, the
font choice in Preferences > Editing >
Rich Text & Note Font will be used when
previewing Markdown documents.
Linking: You can reference local images,
scripts, and other resources using item links,
downward-relative (traveling subgroups;
it's not possible to travel up with '..' as
documents can have multiple parents) or
absolute (start with a forward slash) paths.
Here are examples of linking an image:

and drop documents while holding ⌘-⌥ will
create a URL with an item link. Dropping
an image with create a properly formatted
Markdown image link. Drop .mp3 or .mp4 files
to insert a playable multimedia link.
Another option for inserting links into
Markdown documents, Control-click while
editing and choose Insert Link To from the
contextual menu. A Markdown formatted
link will be automatically inserted for you.
For images, just add an exclamation point
before the link if you want it to display in the
rendered document.
You can learn more about Markdown and its
syntax on Gruber's Markdown pages or the
MultiMarkdown syntax guide.
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Metadata: One of the features of

a special command: Copy Section Link. This

MultiMarkdown is metadata headers. These

copies a link to the current document, but

allow you to add non-displaying information

appends a pointer to the selected paragraph.

about the document, like authors, dates, and
even linked stylesheets. To use the feature,

HTML-BASED FORMATS

format the first line of the document with a
colon, e.g., Author: DEVONtechnologies. This
must be the first line of the document. Other
metadata fields you wish to add must follow
immediately after this first line.
However, if you would like the first line of your
document to contain a colon, perhaps adding
notes like Developer: A. Edwards and Re:
OCR, just add a single blank line at the top of
the document and the subsequent lines will
be treated as normal paragraphs.
Emoji: For a little extra personalization, you
can type Slack-style emoji, like :grinning:,
directly in the Markdown document.

HTML-based files in DEVONthink include

Note: DEVONthink supports many features
of MultiMarkdown 6, but not all of them

bookmarks, web archives, formatted notes,
and RSS articles. These are formats that
are viewable in web browsers and are also

(e.g., no file transclusion).

mobile-native.
NAVIGATION BAR
BOOKMARKS
When working with Markdown documents,
you can switch between Preview and Source
modes. There also is a special icon

present

in the navigation bar. This switches to Sideby-Side mode, allowing you to edit and
preview the current document in two side-byside panes.

Bookmarks are exactly the same as the
ones found in your web browser. With
DEVONthink's ability to act as a browser,
bookmarks can be a valuable part of your
experience. When using File > Import >
Bookmarks, you can bring your bookmarks
into DEVONthink easily. Though this depends

CONTEXTUAL MENU

on the capability of the individual browser,
you may be able to drag links directly into

In addition to the contextual menu items

your database. You can also capture them

available with text selections in the

with DEVONthink's browser extension, Clip to

document source, Markdown documents have

DEVONthink.
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Note: If you import your bookmarks from

checkboxes and input fields are not removed

a browser, this is a copy operation not

and the status of checkboxes and form fields

a sync, i.e., if you modify bookmarks in

is retained.

your browser, this will have no effect on
DEVONthink's contents. However, you
can do another import to add the new
bookmarks to your database without
duplicating the previous ones.
In addition to importing bookmark files, they
can be created via Data > New > Bookmark.
Just provide a URL and title. If you don't enter
a title, DEVONthink will attempt to detect
and use the page title.

Bear in mind, the underlying markup
in formatted notes can't be edited in
DEVONthink. However, you can open the files
in a compatible external editor, if you'd like.
Note: Since images are completely
embedded in the documents, the resulting
file size can grow large very quickly. Resizing
images before adding them is encouraged.
HTML Files: are similar to formatted notes,
but they do not preserve the state of

FORMATTED NOTES AND HTML
Formatted Notes: allow to write simple
formatted text including embedded images
that can be viewed on any system with
just a web browser. While the range of
formatting options is smaller that that of

checkboxes and form fields. You also cannot
add images by dragging them into the live
editing view. However, you can edit the
underlying HTML code using the Source and
Side-by-Side modes found in the navigation
bar.

rich text they are much more compatible to

Formatted notes can be imported or created

today's standards. You can find all available

via Data > New > Formatted note. When

formatting commands in the Edit and Format

using the Notes from Evernote or Folders

menus. When creating new formatted

& Attachments from Notes options in the

notes, DEVONthink will use the font set in

File > Import menu, the imported notes are

Preferences > Editing > Rich Text & Note

formatted notes. HTML files can be imported

Font. Captured or imported formatted

or created via Data > New > HTML page.

notes, e.g., from Evernote, use the font set in
Preferences > Web > Standard Font

WEB ARCHIVES

Technically formatted notes are based on

Web archives are a special HTML file format

HTML, the language of the world-wide web.

intended to create offline archives of

Images are embedded directly into the

individual web pages. The downloaded data

HTML code so that formatted notes are

preserves the look and feel of the page very

completely self-contained. The HTML code

closely. It is often a more useful capture

is also cleaned from unnecessary tags and

option when a PDF would generate a very

an identifying meta tag is inserted that lets

long page since web archives always view at

DEVONthink distinguish formatted notes

the size determined by the browsing area.

from normal HTML pages. Form tags, e.g., for
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They function in a similar fashion as

in a format you specify in DEVONthink's

formatted notes, so you can actually edit the

Preferences > RSS > Feed Format. The default

captured contents and save your changes.

is Automatic and saves summary files as

This can be very handy for highlighting

HTML. The styling of the HTML articles is

passages or removing unwanted elements,

controlled by an internal CSS stylesheet

e.g., ads, in a captured web page. Also, since

specified in Preferences > RSS > Feed Style

they are HTML files the underlying markup

Sheet. Other formats will get their styling

can be edited using the Source and Side-by-

from the source they're downloaded from.

Side modes found in the navigation bar.
Note: When using an option other
Note: Web archives can be very useful with

than Automatic as the feed format,

web pages using statically linked content.

DEVONthink must download the linked

However, some popular and monetized

content and convert it to the appropriate

sites get their contents dynamically from

format.

other sources, so the actual data is not
in the underlying HTML. These pages may
have missing content due to this, require
an internet connection to display content,
and run JavaScript. If you encounter this, a
PDF may be a better archiving option.
Web archives files can't be directly made.

RSS feeds can be created via Data > New >
Feed. Provide a URL and title. If you don't
enter a title, DEVONthink will attempt to
detect and use the feed's title. You will also
notice a special feed in this menu: Twitter
Feed. This can be used to import feed articles
from a specific Twitter account.

They are the result of capturing web content,
either in DEVONthink or using our browser
extension.

EDITING BAR
Like rich text files, editing HTML-based files

Note: Web archives made on macOS

(excluding bookmarks) includes the Editing

Mojave aren't necessarily compatible with

Bar. Click this

earlier versions of macOS.

appear in place of the navigation bar. The

icon and the editing bar will

tools available here consist of:
RSS
Increase the size of the font.
RSS feeds are special "web pages" that don't

Decrease the size of the font.

show as pages but as a stream of news

Set characters to be subscript.

articles. DEVONthink allows you to keep that

Set characters to be superscript.

news flowing directly into your databases.

Set bold on the text.

Supporting RSS, RDF, Atom, and JSON feeds,

Set italic on the text.

DEVONthink functions as a basic newsreader.

Set underlines on the text.

RSS feeds are treated as a special type of
file that functions as a group. Feed articles
are downloaded to the feed and saved

Set strikethrough on the text.
Highlight selected text. This uses the
currently selected highlight color.
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Add or edit a link applied to the selected

Open Page in DEVONagent: Opens the

text.

current page in DEVONagent Pro.

Show or hide the ruler. Place tab stops with

Reload: Reloads the page from the Internet.

the mouse, then remove them by dragging

Update Bookmark: Updates the URL of this

them off the ruler. Drag new tab stops (left

document to the current one, e.g., after

aligned, centered, right aligned, or decimal

navigating to a sub-page.

aligned) from the repository at the right

Update Captured Archive: Updates the

side to their desired positions on the ruler.

contents of a web archive file with the live

Use the mouse to adjust the left and right

version on the Internet.

margins and indent.
Show the Fonts panel.
Show the Color Picker.

CONTEXTUAL MENU
In addition to the contextual menu

Add Page to Downloads: Adds the page
address to the Download Manager.
Download Video: Downloads the video
using the Download Manager.

SHEETS

commands available with text selections in
a document, HTML based files often include
these items:
Add Page to Reading List: Adds the current
page the Reading List as a bookmark.
Capture …: Captures the Control-clicked
frame, image, link to the inbox of the
current database.
Capture Page: Captures the current page
in the selected format to the inbox of the
current database.
Copy … Address: Copies the frame URL of
a Control-clicked frame, image, page, or
video to the clipboard.
Insert > ...: Inserts checkboxes into the

Sheets contain text in a table and can be

document.

used to store any kind of tabular data from an

Open … in New Tab: Opens a Control-

address book to recording health statistics to

clicked image, page, or video in a new

employee timesheets. They are made up of

DEVONthink tab.

records, defined by parameters displayed as a

Open Image in PhotoStickies: Opens the

form or columns. For example, a simple sheet

image in PhotoStickies.

could contain a table of peoples' name, title,

Open Page in Browser: Opens the current

and department.

page in your default web browser.
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When you create a sheet or make changes

need to provide starting column headings,

to the sheet columns via the Column Editor,

which you can certainly add or take away

you will specify the column names and their

from later.

types. An explanation of the data types can
be found in the Data section of the appendix.

NAVIGATION BAR

Sheets can be displayed as a table or a form

The Navigation bar displays the current

via the View > Document Display menu or

record and the total number of records in the

using the

sheet. Clicking on this information opens a

and

buttons in the navigation

bar. The table view is similar to standard

Go to record function so you can quickly jump

spreadsheet views. Form view is similar to

to a specific record in the sheet. In addition,

the record view e.g., in FileMaker.

there are options to go to the first, previous,
next, or last records.

EDITING BAR
To make working with sheets even more
efficient, DEVONthink includes the editing
bar with some basic tools:
Add a new record to the sheet.
Duplicate the current or selected records.
Delete a new record from the sheet.
Add a new column to the sheet.
Displays the Column Editor to allow editing
and managing the columns.
Delete a column from the sheet.
Use sheets like any other document. Add
new rows using Tools > Sheets > Add Record,
delete rows by selecting them and using Edit
> Delete. Alternatively, use the contextual
menu. Click a cell to edit its content, press
the ⎋ Escape key to stop editing, and use the
Tab or Return keys to navigate from cell to
cell. Hold the ⌘ Command key to activate a
link in a cell.
If you import tab or comma-delimited files,
e.g., CSV or TSV files, they will be imported

In Text Alternative, there is one more option
in the editing bar: Delete Selected Column
allows you to delete a column. Just click on
the column header you want to delete, then
this option is enabled.

CONTEXTUAL MENU
There are a few sheet-specific contextual
menu items available when you're Controlclicking in a sheet.

and displayed as sheets. Sheets can also be

Cut/Copy/Paste: Cuts, copies, or pastes

created via Data > New > Sheet. You will just

whole records in a sheet. Use them, for
example, to duplicate records. Pasting
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always pastes as the last record in the

and even two-finger rotation in 90 degree

sheet.

increments. Audio and video files display the

Delete Records/Columns: Deletes the

familiar macOS controls.

selected record(s) or column(s).
Edit Columns: Displays the Column Editor
to allow editing and managing the columns.
New Column: Creates a new column in the
sheet.
New Record: Creates a new record in the
sheet.

Images, audio, and video files can be
imported. Also in DEVONthink's Sorter you
can capture the screen to an image, as well as
record audio and video notes.

EDIT PANEL

Duplicate Record: Duplicates a selected

When working with images, double-clicking

record in the sheet.

opens an edit panel with three tabs. The

Note: Despite any visual or behavior
similarities with Microsoft Excel, sheets
are not spreadsheets and therefore do not
provide functions and formulae.

Adjust tab allows you to do some basic image
editing, like adjust exposure, saturation,
adding a sepia tone, etc. The Effects tab
provides some simple pre-defined image
effects. The Details tab displays metadata
about the image, including EXIF metadata

IMAGES, AUDIO, AND VIDEO

and a map of the geolocated origin of the file.

NAVIGATION BAR
For audio and video files, there is a special
option available in the navigation bar: the
playback time. This displays the current time
of playback (audio and video only). Also,
if you click the time it shows a Go to time
function so you can quickly jump to another
time in the playback.

CONTEXTUAL MENU
There are a few media-specific contextual
menu items available, excluding common
ones related to magnifying the image. In
DEVONthink uses macOS core technologies
to display images and videos, and also play
audio. Interacting with images uses the same
controls you are used to, like pinch to zoom

addition to the standard controls, e.g.,
volume, playback position, etc., some of the
same contextual menu options are found in
the action menu for these files.

in and out, two-finger tap to zoom to width,
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Rotate Left/Right: Rotate the image
left and right. The image is saved in an
uncompressed TIFF format.
Flip Horizontal/Vertical: Flip the image on
the chosen axis. The image is saved in the
lossless TIFF format.
Edit: Opens the Edit panel.
Copy Frame Link: Copies a URL linking to
the current playback time in the file.
Copy Image: Copies the image or current

EPUB
EPUB files (.epub)are popular format,
commonly used for digital books (including
our manual). While they can't be edited
in DEVONthink, their contents are fully
indexed and searchable, making them a viable
resource in your databases.

OFFICE DOCUMENTS

video frame to the clipboard. When used

Word processing, spreadsheet, and

with an image, an uncompressed TIFF file

presentation applications are common in

will be captured.

many situations. When using the proprietary

Set As Thumbnail: Makes the current frame

formats from these applications, like

the thumbnail of the video (only available

Microsoft Word documents (.doc, .docx)

when the video is not playing).

instead of rich text files, these formats aren't

Note: Edits to or copying an image via
contextual menu items produces an
uncompressed TIFF file. These files can

directly editable in DEVONthink. However, it
does support importing and indexing these
particular document types:

be quite sizable, but are also saved in a

Apple Pages, Numbers, and Keynote from

lossless format.

Apple's iWork suite
Word, Excel, and PowerPoint from

OFFICE DOCUMENTS, EMAIL,
AND OTHERS

Microsoft's Microsoft Office suite.
Files from supporting applications, like the
OpenOffice or LibreOffice suites.

DEVONthink is the central hub for many
environments, from home to office, and you

Files from the popular macOS Mellel word
processor.

are likely using several other applications
along side it. As often mentioned,

These formats can only be imported, however

DEVONthink supports importing many file

it is possible to add template files of these

types; some editable, some not. If a format

formats. For example, you may have a

is text-based, like XML files, they may be

boilerplate Pages document you often use.

directly editable. But even if a file is not

This could be added as a template to quickly

editable, it may be searchable. This section

add to your database, then opened and

is obviously not exhaustive in what kind of

edited in Pages. See the appendix for a bit

files can be added to DEVONthink, but if

more information.

you have a format we haven't discussed, the
easiest thing to do is just try importing it.
Any failures will be reported in Window > Log.
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EMAIL

CONTEXTUAL MENU ITEMS

Imported email messages have their

Contextual menu items aren't available

contents indexed (excluding the contents of

in Quick Look views, e.g., Control-clicking

attachments). This makes them searchable

in a PowerPoint file. Also, when using the

and a valuable asset, whether you're archiving

Text Alternative mode for these files, some

email for personal or professional reasons.

but not all contextual items related to text
selections are available. See also p. 210ff

TEXT AND BEST ALTERNATIVE
For some document formats, e.g., email

LINKED FILES
messages or Word documents, DEVONthink

On occasion we get an inquiry about

only allows you to select and copy text in

importing files with linked assets, like Adobe

the Text Alternative view. If DEVONthink is

Illustrator or InDesign files. While it's certainly

able to interpret and convert the document

possible to import these, the links will be

format, you can use the

broken if you try to import a folder structure

and

buttons

in the navigation bar to switch between a

containing the links. Groups in DEVONthink

view that allows you to select, copy, and drag

do not exist in the file system, so the groups

text or the Quick Look view showing a more

that are created when you import a folder

"accurate" view of a file.

structure from the Finder don't exist as
real folders in the database. The files inside

Also note you will have text-related
contextual menu items available when
you can make text selections in the Text

the folders are imported into the internal
structure of the database, so their paths are
not pointing to the groups in the database.

Alternative view of a file.
If you want to include these kinds of files in
Note: For uneditable formats, DEVONthink
uses Quick Look to display the file,
provided an appropriate Quick Look plugin
or application providing one is installed. If a
document you want to view in DEVONthink
does not show a Quick Look preview, you
may need to contact the maker of the
source application and ask them to add

your databases, you could keep the linked
files external and only import the documents.
You could also index the complete folder
structure containing your files into the
database, leaving them where they are in the
Finder. Since the paths aren't changing, the
links would be preserved when you open the
documents.

Quick Look support.
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IN & OUT
IN THIS CHAPTER

When you drag-and-drop files or choose File

Importing & Indexing
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Drag & Drop

51

Sorter

52
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52

Sync

55

Capturing Paper (Image Capture)

62

Capturing Paper (Other Options)

64

Extensions and Bookmarklets

65

Web sharing

67

Services

70

> Import > Files and Folders, files are copied.
This does leave the originals in the Finder,
which you can choose to keep or delete. But
note there is no connection between the
files any longer. Editing the file in the Finder
after importing has no effect on the file in
the database, as the database has a copy of
it. If you want to access and edit the files, do
so from inside DEVONthink.
If you hold the ⌘ Command key when you

PDF Services

71

drag into DEVONthink, the file will be moved,

Third-Party Applications

71

not copied, into the database. If you are using

DEVONthink is not an island. It integrates
with the rest of your Mac and iOS devices
in a variety of ways to make it easy for you
to add data to DEVONthink. There are even
some options that allow you to share your
data with friends and colleagues.

File > Import > Files and Folders, you can
click the Options button and enable Move
Originals to Trash.

INDEX
Creates links to files outside the database.
This allows more direct access to the files in

IMPORTING & INDEXING

the Finder by other applications or people.
A common example is people using a cloud

When it comes to getting data into your

service like Dropbox and indexing folders

databases, there are two fundamental

in the local Dropbox folders. DEVONthink

methods to consider: importing and indexing.

indexes the content and metadata for use
with classification and other content-related

IMPORT
Importing copies files into the internal
structure of the database. This creates a
portable, self-contained database that can
be moved as a single file. This is the default
behavior of DEVONthink.

functions, just as it does with imported
items. Do note while indexing doesn't copy
the contents of the files, the full text of
text-based is stored. This can still take up a
considerable amount of space.
Finder files and folders can be indexed using
File > Index. You can also hold ⌥⌘ while
dragging and dropping into your database.
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When you do, you will see a curved arrow

subfolders. In the image shown, the

on the cursor while dragging, indicating the

"DEVONtechnologies" folder is the parent

items will be indexed. Indexed items with

folder and could be indexed with all its

have a small square Finder icon to the right of

contents included. You could also index an

the item's name.

individual folder, e.g., the "Data" folder, which
would be treated as a parent folder for its

INDEXING AND THE FILESYSTEM
Indexing is not the default option for getting
files into your databases. This is not only
because importing creates a singular,

contents. And you could also index individual
files within or outside of any folders. Each
of these options has specific behaviors you
should be aware of, covered below.

portable database, but also due to some

Moving Indexed Items: DEVONthink stores

technical things that must be considered

individually indexed items by its absolute

when indexing. Here are a few behaviors you

path in the filesystem. If you move an

should know and understand before indexing.

individually indexed file or folder, it will

With indexing, the integration with the
filesystem is very tight. When you rename a
file in DEVONthink, the file's name changes
in the Finder. If you rename in the Finder, the
change should be automatically reflected in
the database. DEVONthink tries to keep the
group in the database and the folder in the
Finder in the same state.

disappear when the database updates or be
reported as missing. This is because the item
no longer exists in the indexed location, so
the absolute path points to nothing. If you
move a file or subfolder inside an indexed
parent group, the change should be reflected
in the database or the Finder. The parent
folder still exists in the same location and
DEVONthink can adjust for the changed
relative paths within it.

Deleting Indexed Items: When deleting
indexed items, you will see one of two
warnings when you empty the database's
trash, depending on how you've indexed
the item. With individually indexed files, an
indexed folder, or a parent folder, you will see
When indexing items into DEVONthink,

a warning prompting you to choose whether

you can index a file, an individual folder,

to delete the item from the filesystem or

or a parent folder, i.e., one containing

just the reference in the database. In this
DEVONthink 3.6 Documentation, page 49

instance, DEVONthink is prompting you to

the files will not be marked as duplicates

make sure you aware of the potential removal

since duplicates are not detected across

of a top level indexed item.

databases.
Replicating Indexed Files: Replicating indexed
files within a database, individually or within
parent folders, has no effect on the files in
the Finder. Replicating only adds a record
of another instance of the file. However, if
you delete a replicant of an indexed file and
empty the database's trash, this will have

If you delete a subgroup or a file in an indexed
group and empty the database's trash, you

no effect on the files in the Finder. They will
remain intact.

will be shown the standard trash warning

Indexing Cloud-synced Folders: One of

shown here. If you accept this, the item

the common uses of indexing is to keep

will be moved to the system Trash from

a local folder in a cloud-synced location,

its location in the Finder. In this situation,

e.g., Dropbox, and have access to the files

DEVONthink is modifying the content of the

within DEVONthink. While this is certainly

indexed parent to ensure both the Finder and

supported, be aware that changes made to

database's contents match.

the local folder, especially when the cloud

Duplicating Indexed Items: When you
duplicate an indexed item, the behavior
depends on if you're duplicating with
a database or across databases. if you
duplicate the item in the same database,
a copy will be created in the Finder in
anticipation of potential changes. If you
duplicate the item into another database, no
copy will be created in the Finder. However,
changes made to the item - in either
database - will affect both databases as the

service syncs changes to the local folder,
the changes may not always be detected
by DEVONthink. In that instance, you can
manually update the indexed group by
selecting and hoisting it via the disclosure
triangle or choosing the File > Update Indexed
Items command. Also, you should only index
local data, e.g., on the local hard drive or
connected drives. DEVONthink doesn't
support indexing data that resides only in the
cloud.

indexed item is pointing at the same item in

Lastly, if you are indexing content and want

the Finder.

to sync the databases between devices,

Note: While you cannot replicate files

please review the Indexing and Sync section.

across database, the duplication of an

Due to the flexibility of DEVONthink, it's

indexed file across databases can provide

possible to have a database containing both

you with a similar behavior. However,

imported and indexed files.
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Note: While DEVONthink can handle large

you can drag the attachment out as a

amounts of data, it is inadvisable to import

separate file.

or index uncurated data, like entire hard

With some file types it's possible to select

drives or your Home directory. You should

text and drag it out to create a new file.

be judicious in what you put into your

DEVONthink will attempt to create the

databases.

most appropriate file type.
Note: With the last two options, you may

DRAG & DROP

be able to drag-and-drop content between

The Mac has always been an an environment

files.

with rich drag-and-drop support.
DEVONthink is a well-behaved citizen in this
regard. Here are some ideas:

OUT
DEVONthink isn't just a receiver; it also allows
drag-and-drop of its files too.

IN
For email applications lacking good
The easiest way to add data to DEVONthink,
other than creating the documents directly
inside the application, is to drag files or
selected data, e.g., text, images, etc., into a
DEVONthink window.

automation support, drag a document onto
its dock icon or into a draft email to attach
it.
Drag documents or groups to the Finder as
a quick export option. When you do this,

Drag files from the Finder into a database.

DEVONthink will apply tags you've added to

Holding certain command keys will allow

the documents also to the exported files as

you to copy, move, or index them. See also

Finder tags.

p. 48ff

If you need to upload a document to

Drag files from the Finder to DEVONthink's

a website, drag the document in the

dock icon. Files will be sent to the default

database to the page or the upload sheet,

destination.

if the site requires it. Note that groups

With applications supporting drag-and-

can't be added this way. You'd need to drag

drop, you can drag data between them

the group to the Finder first, then to the

and DEVONthink. For example, you can

site.

drag messages from Apple Mail into your
database or DEVONthink's dock icon.
Inside DEVONthink, you may be able to
drag content from a file into the database.
If you have an email message with an

INSIDE
And obviously DEVONthink allows
dragging database items inside itself for
reorganization.

attachment imported into your database,
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Dragging: Moves items, by default.

found in a search. When docked, the Sorter

Option-Dragging: Duplicates items to the

will lock open during a search so you can

dropped location.

easily drop files into the desired location.

Option-Command-Dragging: Replicates
items to the dropped location. Note you
cannot replicate a file to the same location
as the dragged file.

The Sorter's other views allow for quick and
easy note creation. It supports these note
types:
Take Note: Create text notes in plain or

SORTER

rich text, Markdown, or formatted note
formats.

The Sorter is a multi-purpose utility built into
DEVONthink providing options for adding
files and creating various types of notes.
When enabled in Preferences > Sorter, it
is found in the menubar at the top of your
screen — displayed as DEVONthink or the

Voice Note: Record an audio note.
Video Note: Record a video note with the
built-in camera.
Screen Capture: Snap screen captures with
the option of adding metadata, e.g., tags,
rating, etc. directly into DEVONthink.

nautilus icon — or docked to the side of
your window. Details about the views and

The Sorter allows you to clip web content as

controls of the Sorter are covered in the

well. It also functions as the interface to the

Sorter section of the Windows chapter.

Clip to DEVONthink browser extension.
Clip content from the current page in your
default web browser.
Clip content from a URL detected on your
clipboard.
Clip content via Clip to DEVONthink or
enter information and a URL manually, if
desired.
All these methods give you the option of
capturing the content in a variety of formats,
with or without extra metadata, directly into

The first view of the Sorter is the Navigation

your DEVONthink databases.

view. Access your favorites, or browse and
search for groups in the open databases.

ARCHIVING EMAIL

Double-clicking a found group will open it in
a new DEVONthink window. Drag and drop
files on the Sorter to quickly file them in a
favorited group, an inbox, or a location you've

Email is an important item in many
situations, both professional and personal.
DEVONthink allows you to import email
messages directly from supported email
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applications. It also allows you to import

In addition to speeding up the transfer

UNIX mailboxes (.mbox files) that can be

of email messages from Apple Mail to

exported from some other email clients.

DEVONthink, the plugin adds an Add to
DEVONthink 3 command to the Mailbox
and Message menus of Apple Mail. This
allows you to directly archive selected
messages or mailboxes to your DEVONthink
database while inside Mail. When accessing
a supported mail application via AppleScript,
automatic fetching of new mail is disabled.
This does not happen when you use Apple
Mail with the DEVONthink plugin installed.
Note: We highly recommend you install

Beyond dragging and dropping emails from

the Apple Mail plugin as the AppleScript

an email client, you can select the View >

implementation in Apple Mail is slow.

Import command to show the Import sidebar.

Also, due to limitations in the AppleScript

DEVONthink currently supports the following

interface of Mail it's not possible to archive

email applications:

complete conversations from Apple Mail

Apple Mail

without the plugin installed.

Microsoft Entourage
Microsoft Outlook
The imported email messages are saved
in their original file format (.eml) and
are displayed using QuickLook. MailTags

IMPORT OR ARCHIVE
When it comes to archiving email, the
question arises: "Do I use import or archive?"
Here's the simple way to understand it:

metadata on the messages is preserved as

Import Email: While Import can be used on

tags. In addition, the "read" and "flagged"

a mailbox, it is generally used on selected,

status of email messages are transferred

individual emails. This is especially useful

from Microsoft Entourage and Microsoft

when using a filtered view, e.g., filtering

Outlook independently from your settings in

by a date range or recipient. You'd select

Preferences > Email.

those files and use the Import option.

DEVONthink communicates with your email
application using either AppleScript or, if
you are using Apple Mail, through a special
plugin that implements a direct link between
Mail and DEVONthink. If the plugin is not
automatically installed select DEVONthink >
Install Add-Ons to install it.

Archive Mailbox: As the name implies, this
command can only be used on selected
mailboxes. The mailbox will be imported
into a special Emails group. DEVONthink
will attempt to preserve the mailbox
structure shown in the email application.
This is very useful for archiving a mailbox
and keeping it up to date. Since previously
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imported emails are excluded from the
mailbox view, subsequent visits to the
Import sidebar will only show newly
received emails. Using the Archive Mailbox
option will import only those new emails
into the existing Emails group in the
database.

PROBLEMS IMPORTING OR MOVING EMAILS
Briefly discussed in the Appendix, the UUID
is a value given to each item in DEVONthink.
It is unique to each item and more than one
item can't have the same UUID. When email
messages are imported, they are given such
an identifier based on metadata from the

Depending on the settings in Preferences

actual email. This means you can't import the

> Email > Conversations, DEVONthink can

same message into a database more than

attempt to import complete conversations

once, as that would result in more than one

and optionally group them.

file having the same UUID. This will be shown

Note: Email threading is not an exact
process. There has also been no standard
defining relationships between messages
for a very long time. DEVONthink will
attempt to thread the conversations, but

in DEVONthink's Window > Log. It can also
cause issues when moving messages between
databases. If you already imported messages
into a database and forgot you did, trying to
move the same email into it will fail.

cannot guarantee all related emails will be

In Preferences > Email you can enable

detected.

Previously imported will become replicants to
import the messages into the same database

IMPORTING UNIX MAILBOXES
UNIX mailboxes (.mbox files) exported from
some email applications, e.g., Thunderbird
or Postbox, can be imported into your
database. There is no mailbox structure in

as replicants. However, this still will not allow
moving messages into databases already
containing those emails.

REPLYING AND SENDING

these exported files so multiple mailboxes

To reply to an archived email message,

have to be exported and imported separately.

Control-click it in the item list and choose

They can be imported into DEVONthink in

Send Reply. A draft message will be

one of two ways:

composed in your default email application.

File > Import: Use File > Import > UNIX

Choose Send by Email to email a selected

Mailboxes, then select the .mbox file in

document from the item list.

the Open dialog and press Open. This will
import the messages into a group in the
current location.
Drag and Drop: Drag and drop the .mbox
file onto DEVONthink's dock icon to import
the messages into your database.

Note: The inter-application communication
capabilities of the email client you are using
determine how well these two commands
work. If the commands aren't producing
the expected results, check with the
developer about what kind of interactions
they allow between applications.
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SYNC

Before we discuss particular details of sync

of a database. Changes are made locally

methods, take a moment to check out the

then synced through the sync location to the

Preferences > Sync section. This gives you an

connected devices.

overview of the preference pane where syncs
are set up. Additionally, you will find a short

The only variations are:

glossary of sync-related terminology in the

If the second machine already has a

Appendix.

opened copy of the database, you will have
the option to merge with the sync data in

SYNC SIMPLIFIED
Sync is an incredibly simple concept. You
have a database on one machine. You want

the sync location.
Using a Bonjour sync, in which you'd import
and sync directly between devices.

that database on another machine. From

What is a sync store?: A sync store is a folder

the machine with the database, you upload

on a server or service (the 'sync location')

the database to a sync location accessible

that DEVONthink uses to keep syncable

from both machines. On the machine without

copies of databases. Sync stores can contain

the database, you'd access the same sync

multiple databases. Some people use one

location and import the database. This way,

sync store for all databases. Some use one

every device, Mac or mobile, has a local copy

store per database. Some use one store for
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a group of databases, and another store for

sync method, e.g., Dropbox, and are covered

another group. It's up to you and your specific

below. Bonjour and local sync stores show

use case.

a few more specific (but simple) steps, but

What is a 'copy of the database'?: One

they all follow the same essential pattern:
detail to understand about syncing: Only

Enable a location (with or without an

true copies of a database will sync together.

encryption key)

Two databases having the same name but

Upload a database

created independently are not the same

Enable the same location (using the same

database. These databases will never sync

encryption key, only if specified)

together. This is also why you shouldn't

Import or merge a database

create a database on the receiving machine,
hoping to "fill it up" with data from the source
database.

INDEXING AND SYNC
Often people index content from the local

If you copy the database (.dtBase2 file)

repository of a cloud service like Dropbox.

between machines, that is clearly a true copy

The question then arises: "If I have my data

of the database. Also, importing a database

on Dropbox' servers and I sync to Dropbox

via sync logically yields a true copy of the

via DEVONthink, aren't I just using twice the

database. True copies are databases that

space?" The answer is practically, yes. In the

have the same internal identifier (UUID).

Show Info for a sync location in Preferences >

Security: Regarding the privacy of your
synced data, all sync methods allow you to
specify an optional (but recommended)
encryption key for a sync location. This key is
used to "scramble" or "descramble" the sync

Sync there is an option Synchronize contents
of indexed items. Unchecking this will sync
only the metadata for the files, not the
contents. However, you should only disable
this option if:

data using AES-256 encryption and the data

You are syncing another Mac, linked to

is stored in an encrypted state. All databases

your Dropbox account, and having the

synced to this location will sync encrypted

local Dropbox folder in the same relative

data. Note you must use the same encryption

location. The default location is ~/Dropbox.

key when setting up the same sync location

If the locations are different, the files will

on other devices running DEVONthink or

appear as missing on the second Mac.

DEVONthink To Go.

You are not syncing with our mobile

Note: Bonjour syncs don't allow you to
explicitly specify a key, but the sync data is
encrypted by default.

application, DEVONthink To Go.
DEVONthink To Go does not support
indexed items. Also, if you are using
the Download Files: On demand option

Sync pattern: That's it. Every sync is

in DEVONthink To Go, you could never

conceptually the same. The differences you

download the contents since the contents

find are the requirements of the particular

are not present in the sync location.
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For the most flexibility, it is advisable to

when you leave your office and you haven't

ensure you have enough storage space for

synchronized your databases, you'll need to

syncing.

wait until you come back another day.

BONJOUR

Note: Bonjour does not function over
VPNs. This is a technical limitation of the
technology, not DEVONthink.
Bonjour Setup:
Step 1: On the machine acting as the
server, open Preferences > Sync and press
the Bonjour Options button.
Step 2: Click Enable Incoming Connections
to use this Mac as a Bonjour server of
its databases. Optionally, have closed
databases open when a client initiates a
sync.
Step 3: Enter a mandatory password. This

Bonjour (also called a direct connection) is
technology you are almost certainly already
acquainted with. If you have a wireless printer
or scanner and notice how your Macs and
mobile devices can see those devices by
name with no setup by you, they are using
Bonjour. Bonjour is a way for devices, or

password is required for other devices to
act as a client of DEVONthink's. If you are
working with an IT department who has
assigned a port for you, or you have a port
you'd specifically like to use, enter it in the
Port field. Otherwise, leave this blank and
DEVONthink will assign one for you.

services like DEVONthink's sync, to broadcast

The Mac with Bonjour enabled should now

its presence on a network without requiring

be visible as a sync location to other devices

technical know-how by the user.

on your local network. On the other devices,

When it comes to syncing, a Bonjour sync
deals directly between devices. One device
acts as a server, the other a client to that

enable it, enter the password, and you can
import databases or sync existing databases
directly with it.

server. The participating devices must be

Note: You should never use more than

on, running DEVONthink or DEVONthink

one device as a Bonjour server for a given

To Go, and on the same network. There

database.

is no intermediary location where data is
stored. This is much faster than uploading

LOCAL SYNC STORE

all data to some server on the internet and
downloading it again on another device. But,

A local sync store is a specialized folder
containing sync data on your local machine or
connected drives and servers. This is a very
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fast and reliable sync method for Mac-to-Mac

Note: Due to technical limitations, a local

syncing. You can use one sync store to sync

sync store currently cannot be used for

multiple databases or create more than one,

Mac-to-mobile syncing. iOS doesn't have

e.g., one for a particular group of databases.

the ability to mount file servers.

Setup a new local Sync store:

ICLOUD

Step 1: Open Preferences > Sync and enable
the Local Sync Store option. If you already
have one created, click the + button and
choose Add Local Sync Store.
Step 2: In the sheet that appears, navigate
to the location you want to save the
sync store. Enter a name and an optional
encryption key, if desired. Then press Add.
Step 3: When the location is created,
select it and enable the databases you
want to sync in the Databases list on the
right.
Setup an existing local sync store:

As most Apple devices are logged into your

Step 1: Open Preferences > Sync and enable

Apple ID, iCloud is the simplest method to

the Local Sync Store option. If you already

set up and sync with. Since it's logged into

have one created, click the + button and

your personal account, it can only be used

choose Add Local Sync Store.

for syncing with your own devices. If you

Step 2: In the sheet that appears, navigate

want to keep your databases in sync but

to the location the existing sync store is

not share them with others this is a great

located. Click the sync store to capture the

choice. We strongly recommend an iCloud

name. If an encryption key was specified,

plan with enough storage. Here are the simple

enter it. Otherwise, leave it empty. Then

instructions to set it up.

press Add.

iCloud Setup:

Step 3: When the location is created,
select it and you should see any importable

Step 1: Open Preferences > Sync and enable

databases listed in the Remote section of

the iCloud option.

the databases list.

Step 2: Enter an optional encryption key, if

Step 4: Double-click a database you want

desired. If you are already syncing to this

to import, saving it to a safe location, e.g.,

location from another machine, you must

~/Databases.

enter the same key you used. Leave it blank
if you didn't use an encryption key.
Step 3: Select the sync location and enable
the databases you want to sync in the
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Databases list on the right. If you already

The setup for a Dropbox sync location is

synced from another machine, double-click

essentially the same as for iCloud. However,

a database in the Remote section, saving it

there are two differences of which to take

to a safe location, e.g., ~/Databases.

note:

One thing to realize with iCloud syncing, the

Sync Store Name: You will have to enter a

sync is done locally. After sync is finished,

Sync Store Name. This is where the sync

iCloud uploads to Apple's servers, then to

data will be stored in the Apps folder of

devices using your Apple ID. This means

your Dropbox account. You can add more

databases may not be immediately available

than one sync location, if desired.

to sync on the other devices. The initial

Authentication: Since the Dropbox sync

sync requires patience, as DEVONthink has

connects and syncs directly with the

no control over the speed and reliability of

Dropbox servers, you are required to

iCloud's process. It syncs to the iCloud folder,

authenticate the connection. When you

iCloud does the rest.

first enable a Dropbox sync location in
DEVONthink your default web browser

DROPBOX

will open and ask you to allow access
to our sync engine. This will need to be
done on other devices you are setting
up this same Dropbox sync location.
Once the authentication is allowed, you
subsequently can add and remove other
Dropbox sync locations in DEVONthink.

If you have a Dropbox account you can use
it just like you'd use WebDAV. DEVONthink
creates a private folder for its sync stores
and so keeps its data separate from your
photos and other documents. Of course it
does not get access to anything except its
own files. Dropbox and DEVONtechnologies
respect your privacy.

If you are using a Dropbox sync and also the
Dropbox application, it is advisable to exclude
the DEVONthink Packet Sync folder inside
the Apps folder from being synchronized with
your Mac. This keeps the Dropbox app from
wasting valuable disk space and bandwidth
by re-downloading all changes you've made to
your databases, and from spamming you with
notifications.
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Step 1: Click the Dropbox icon in the

Your data is stored in encrypted sync stores

menubar at the top of your screen,

on the server. You can keep all your devices in

then click the account icon and choose

sync at any time as long as you have internet

Preferences.

access.

Step 2: Select the Sync tab and click the
Choose folders to sync button.
Step 3: Select the Apps folder, and uncheck
the DEVONthink Packet Sync folder.
Step 4: Click the Update button and okay
the removal of the local data.
Note: Due to Dropbox' API restrictions,
you cannot sync between Dropbox
accounts, .e.g., between yours and a
colleague's account. Also it is not possible
to connect DEVONthink to more than one
Dropbox account at a time.

WEBDAV

Setting up a WebDAV connection follows
the same simple pattern and allows you to
specify a sync store name. But there are a
few parameters that must be entered to
make the connection:
URL: This is the address of the WebDAV
server to which you are connecting. Make
sure you use the proper protocol of http
or https. Also make sure the URL is a
complete path, as required by the server or
service you're using.
Username/Password: Enter the defined or
provided username and password to allow
DEVONthink to connect to the WebDAV
server.
Note: A typical complete path would
be similar to: https://myWebDAV.com/
WebDAVvolume/WebDAVFolder. The volume
and folder are generally case-sensitive.
Specifying a WebDAV folder may be
required if the server doesn't allow you to
write to the root of the volume. Check with
the manufacturer or provider.

If you run your own WebDAV server, your ISP
offers it as a service, or you have subscribed
to an online service such as CloudMe, this
might be for you. Generally, if you can access
the WebDAV server with Go > Connect to
Server in the Finder, you should be able to
connect DEVONthink to it.
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Store Name dropdown. This way you can
quickly add the proper sync store instead
of trying to remember the exact name you
gave it.

Q&A
I'll just put my databases in (name your cloud
service): This is not data-safe and never
has been. The mechanisms used by cloud
services are not compatible with package
files, like our databases. Due to the number
of broken databases we've seen over the
CloudMe: A European cloud service offering

years, DEVONthink will neither sync nor open

WebDAV services, there is a built-in template

databases stored in these locations. We

for syncing with it. Just enter the username

suggest keeping them in a folder in your home

and password you use to log into the service,

folder, like ~/Databases.

enter a store name, and DEVONthink with
connect with a proper WebDAV URL for you.

I want to access my databases from one
location: Along with the previous note, this is

Other cloud services: If you are interested in

not possible. Databases are stored locally and

other cloud services to sync with, services

must be imported to the current machine.

offering WebDAV connections should be
supported. Check the FAQ or Support pages
to see if it's supported.

I want to find my files in the sync location:
Your databases do not "live in the cloud". Sync
does not copy your databases and files into

Rolling your own: It is possible to run

any sync location. It transmits raw, chunked,

a WebDAV server on your own. Some

and optionally encrypted DEVONthink-

NAS drives, e.g., Synology, have WebDAV

specific data, only useful to DEVONthink

capabilities and you can run a WebDAV server

and DEVONthink To Go. You cannot go into a

by repurposing an older Mac. Even some

sync location and retrieve a specific file, and

more full-featured packages like OwnCloud

neither could anyone else, friend or foe.

or NextCloud can be set up for WebDAV
services. However, these options can provide
more technical challenges in setup and
administration beyond the scope of our
support.

Should I use one sync store per database:
This is either a personal choice or a
requirement of your specific situation. A sync
location can be used with one, several, or
all databases. However, if you'd like to use

Note: With Dropbox and WebDAV

one sync store per database, it may lessen

connections, if you are connecting to a

the time in troubleshooting in case of a sync

location you've already synced to, a list of

issue. In situations where you need to sync

existing sync stores is displayed in the Sync
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certain databases to certain individuals, you

invisible text layer to the scanned file that is

can use one sync store for each subset of

computer-readable and searchable; a layer

databases.

that is recognized by DEVONthink's AI engine.

I want to sync a database with multiple
sync locations.: While using a Bonjour or a
local sync store sync as a secondary option

OCR on scans is generally enabled by default.
For best results we recommend scanning at
200 dpi in color and with 100 percent quality.

should work, this is not suggested generally

Note: If you are using a Fujitsu ScanSnap,

when using a remote sync option like iCloud

see the next section.

or Dropbox. Multiple sync stores are best
used only for different databases and/or
different devices, e.g., to synchronize specific
databases via one sync store for personal use
and sync others via a second sync store for
business purposes. Otherwise unnecessary
duplicates might be caused, especially if
the Conflicts setting in sync preferences
is set to Duplicate documents. Each sync
location is updated independently so changes
may not be received on one before it syncs.
Also, syncing a database to multiple remote
locations can waste space and bandwidth.

To capture paper using an Image Capture
compliant scanner open the Import sidebar
using View > Import or selecting the icon over
the sidebar. It is divided into a sidebar and
a main pane, which changes depending on
your selection in the sidebar. The options
in the sidebar are arranged from top to
bottom according to a typical scan workflow:
Scan, check the scanned pages, arrange the
pages in a document, and save them to the
database.
If you are using a scanner with an automatic
document feeder (ADF), you can also use a

TROUBLESHOOTING
Generally, syncing is a transparent and
reliable process. However, poor network
conditions, unreliable servers, etc. may cause

Queue to prepare a pile of sheets for batch
processing and scan them in one go.

DEVICES

unexpected issues. Please refer to the Sync
section of the Troubleshooting chapter for
some possible fixes.

CAPTURING PAPER (IMAGE
CAPTURE)
DEVONthink comes with built-in support for
Image Capture compliant scanners, as well as
for the Fujitsu ScanSnap.
OCR: DEVONthink optionally makes scanned

Select your connected scanner or camera in

documents searchable by using optical

the Devices section of the sidebar to run a

character recognition (OCR). OCR adds an

scan or download images from a connected
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iOS device or camera. The main pane shows

Add pages by dragging them from to the

an interface similar to what Apple Image

desired binder, in the current view or the

Capture uses.

sidebar. Rearrange added pages if desired

Choose the scan destination in the To popup menu. Either send the scan directly to any
of your databases, add them as single files
to the Imports section, or choose any binder
that you have created there.

and set the document properties by clicking
the Properties button. Use the Sort button
to reverse the sort order or shuffle pages,
e.g., when scanning all front pages first, then
the back pages. Choose Sort and Merge
Documents to merge two documents where

Scanners: DEVONthink generates an overview

one contains all the odd pages and the other

scan of the current page in the scanner,

all even pages.

and allows you to select which parts of the
page you want to capture and set the scan
options. Click Scan to capture the page.

Note: You cannot save multi-page
documents as images; therefore, PDF is the
only option for the file type here.

Cameras: DEVONthink shows the available
images. Select the images you want to
import, rotate them if necessary, and click
Download or Download All to download the
images to your computer. You can also delete
images from your camera with the Delete
button.

IMPORTS

TRASH
This is where you find images that you have
deleted from Scans & Images or Imports.
Empty the trash using the Empty button
at the bottom of the window or rightclick or Control-click images to add them
to an existing or new document using the
contextual menu.

The Imports section contains scanned pages
or binders of collected scans. Create empty
binders here to which you add your scanned
pages. Alternatively, use the Create new
Binder button at the bottom of the sidebar.
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QUEUE

the window. Alternatively, click the dropdown
button and choose Remove Sent or Remove
All.

CAPTURING PAPER (OTHER
OPTIONS)
DEVONthink works with the Fujitsu
ScanSnap, ExactCode ExactScan, and other
scanners that are not directly supported.
In addition, you can add already scanned
If you are using a document scanner with
automatic document feeder, you can use the

pages to your DEVONthink database and
manually convert them to searchable PDFs.

queue to add multiple pages or even multipage documents to the feeder and scan them

USING A SCANSNAP SCANNER

in one go.
DEVONthink recognizes scans sent to it from
Choose your scanner in the pop-up menu
above the list. Then use the Add and Delete
buttons to add or delete steps and rearrange
them by dragging. Edit the fields to set a title
or tags, or to change the document type or
destination. Check OCR to convert a scan to
a searchable PDF after import.

the Fujitsu ScanSnap Home application or
the older ScanSnap Manager software. To
send scans automatically to your databases,
simply add DEVONthink to ScanSnap Home
or ScanSnap Manager as the application
to use for opening completed scans. The
scanner app will send the created PDFs to

To scan a batch of paper, set the Separator

DEVONthink which in turn will import the

either to Page Count and the number of

document.

pages in the document or to Blank Page to
begin a new document every time a blank
page is encountered.

ScanSnap's scanning software can provide
already OCR'd PDFs. However, if you don't
enable this option, DEVONthink can perform

Before starting the batch run, adjust your

the OCR on the incoming scans if you've

scan settings by clicking the Configure

enabled Preferences > OCR > Convert

button. If you want to convert the scans

Incoming Scans.

to searchable PDFs, you should choose a
resolution of minimum 300 dpi. Then click the
Start button to start scanning. Finished steps
are marked as "Sent". To remove finished
items from the list, select the ones to remove
and press the minus button at the bottom of

USING AN UNSUPPORTED SCANNER
You can also capture paper using an
unsupported scanner and import the finished
scans into DEVONthink. To do this, use the
scan application that came with your scanner
or a third-party scan application. Check
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the scan application's preferences and look

window when the OCR process is completed

out for an option that allows you to open

(before the file is actually imported to the

the finished scan with another application,

database).

e.g., an image editor. Change the default
application for the scan to DEVONthink.

The date of the created document is set to
the date of the original file. Thus, for archival

DEVONthink knows the identifiers of many

purposes, the searchable document is

scan applications and will convert the

identical to the original one. The modification

incoming scan to a searchable PDF if possible.

date is set to the current date and time to

If DEVONthink does not recognize your scan

reflect the addition of the searchable text

application, please create a Zip archive of

layer. If you're importing a PDF, any keywords

the application and send it to us so that we

in the original file are retained and used as

can add its identifier to a future release of

tags.

DEVONthink.

application you're using, it is best to leave

EXTENSIONS AND
BOOKMARKLETS

the default location for the output path,

DEVONthink provides a sharing extension

often ~/Pictures. Do not set the path to

(requires OS X Yosemite or later), a web

DEVONthink's Global Inbox, as this can lead

browser extension, as well as bookmarklets,

to errors when DEVONthink tries to import

for conveniently clipping information from

a scan that is not completed yet.

other applications into your DEVONthink

Note: In the settings for the scanning

database.
IMPORTING EXISTING FILES WITH OCR
If you already have an archive of documents

SHARING EXTENSIONS

that have been scanned without OCR, or

Sharing extensions let you "share" data with

if you cannot use the capture function for

other applications or web services such

whatever reason, you can import image files

as Twitter and Facebook. Extensions are

while applying OCR.

mainly intended for the sandboxed App

To import an image file while applying OCR,
choose File > Import > Image with OCR. Click
the Options button to choose the output
format and whether to send the original to
the system trash after importing. The image
will be processed with DEVONthink's OCR
engine and be imported to the database

Store environment where applications can
no longer easily communicate with each
other. When you access the Share menu in
a compatible application, you should see
an option, Add to DEVONthink that allows
you to send data from the application to
DEVONthink.

in the format chosen. If you have enabled

Installation: Just as other sharing extensions

Searchable PDF: Set metadata after

are installed, open System Preferences >

text recognition in the OCR preferences,

Extensions > Share Menu and enable the

DEVONthink will show the metadata entry
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option for DEVONthink. It should now be
available in any sharing-enabled application's
Share menu.

BOOKMARKLETS
Similar in function to a browser extension,
but much simpler, bookmarklets are special

Note: The data being sent is controlled by

bookmarks that execute some JavaScript

the sending application, not DEVONthink.

to capture the current page or selection in

If there are issues with the data received

the browser. To use one of the bookmarklets,

in your database, please contact the

load the page you wish to archive or clip

developer of the application to report your

text from in your web browser. When the

findings.

page is fully shown, select the bookmarklet
in your bookmarks bar. Instead of loading

BROWSER EXTENSIONS
Browser extensions add functionality to your
favorite web browser. DEVONthink's Clip to
DEVONthink extension usually appears as a

another page as normal bookmarks do, the
bookmarklet adds the selected text or the
whole page as text, bookmark, HTML code,
web archive, or PDF to DEVONthink's default
destination.

nautilus icon in the web browser's toolbar.
When clicked, the Clip to DEVONthink will

Installing: Bookmarklets can be installed

identify data about the current page in the

from our Extras download page. Typically,

browser and open the Web Clip section of

the bookmarklet can just be dragged and

the Sorter. Here you can simply select the

dropped to the browser's bookmarks toolbar.

location to clip the content or add optional

However, you may need to Control-click

metadata, like tags, label color, etc.

the bookmarklet and copy the code to
add it manually, if the browser requires it.

Installing: The Clip to DEVONthink for Safari
extension is installed by DEVONthink by
default. The extensions for Firefox and
Chrome can be installed from our Extras
download page. You can also access these

We have provided separate bookmarklets,
one for each type, currently supporting
capturing: bookmark, web archive, HTML,
PDF (paginated or single page), plain text, or
the selection as plain text.

pages via the DEVONthink > Install Add-Ons
panel.

Note: Due to increased security in macOS,
Apple Safari will prompt you to allow

Note: While there is no direct support for
other browsers, some allow you to install
Chrome extensions. This may allow you
to install our browser extension in those

launching DEVONthink when using the
browser extension or bookmarklets. Other
browsers allow you to make a persistent
choice about this behavior.

browsers as well.
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WEB SHARING
DEVONthink allows you to give others on the
local network access to your databases using
a standard web browser on any operating
system (including Windows and Linux). The
embedded web server provides an interactive
web interface that allows defined users to
interact with the shared databases. Here are
the first steps to getting started using this
powerful feature.

Note: Depending on the certificate settings
specified in the preferences, a warning
about an invalid certificate may be shown
when users access the web sharing. This
is especially true when using a self-signed
certificate. While this warning is something
to be suspicious of when browsing in
general, you and your users can accept it in
this case.

SHARING A DATABASE
Start and stop the server: Once the
certificate and users have been set up to
your liking, press the Start button to start
the server. You can also select the Tools >
Start Server command or choose the Start
Server option in DEVONthink's dock icon. If
the server is running, these will display Stop
instead.
Share your server's address: Once the web
server is started, you will see links at the

SECURING YOUR SHARED DATABASES

bottom of the preference pane. These are
the active links you will share to individuals

Before you start sharing your data it's a good

you have defined as users. One option is

idea to check the security settings.

to Control-click the link, select Share from

To enhance the security for the databases
you broadcast, you define users and give
them per-database permissions. You will
also set a certificate for the server, so the
connecting users can validate they are

the contextual menu, and share it via your
preferred method. You can also use Copy Link
and paste it where you need to. Lastly, you
can click and drag the link directly to many
applications, like Apple Messages.

connecting to a safe server. These items

The person who receives your link will open

are set in Preferences > Server. Users will

the page, login with the username and

only be able to interact with the databases

mandatory password you've defined for

based on the permissions you give them,

them, and have access to the databases you

including disallowing them even to see certain

want them to see. If you have specified a port

databases.

in the preferences, your users may be able to
add a bookmark to their browser for quick
access.
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Note: We believe in data privacy and

their contents in the item list. For quick

hope you do too. Browsers may present

navigation, press the < and > arrows to go

options to save login credentials. Some

back and forward to visited locations in the

may even save the credentials by default.

databases. You can also click the locations in

We are cautious of the first and not a fan

the path bar above the item list to jump to a

of the second. If the user is on a shared

parent location.

computer, consider what access other
users could have if using these options to
save credentials.

USING THE WEB INTERFACE

View/Edit pane: Displayed below the item
list or to the right, depending on the preview
choice made in the toolbar, this pane will
attempt to display the contents of the
selected file. Clicking and dragging the divider

The interactive web interface imitates the

bar allows you to resize the pane, relative

look-and-feel of DEVONthink in many ways,

to the item list. A select number of file

but in a condensed form. Contrary to a static

types, e.g., plain text, formatted notes, and

web site, it only loads once; clicking buttons

Markdown files can be viewed and edited in

or links does not reload the whole page but

this pane. When the Info inspector is shown it

dynamically updates it. This also means you

will display as a pane on the right side of the

should use the Back and Forward controls in

view/edit pane.

the user interface instead of the ones in your
browser's toolbar.
Similar to the DEVONthink, the web interface
is divided into panes: toolbar, sidebar, item
list, and view/edit pane. But note some
operations, e.g., deleting or organizing items,
are dependent on the permissions you've
been given for the specific databases.

Note: Due to the limitations of browser
technologies, some file types cannot be
displayed.
Toolbar: Some handy options are available
in the toolbar, including switching the
position of the view/edit pane, adding
some metadata, e.g label or rating, to a
selected item, and creating groups and a

Sidebar: The sidebar is where you can

few document types. It also has controls for

navigate the databases' inboxes, groups, tags,

uploading new documents and downloading

and trashes in the sidebar. You can even drag

currently selected ones. A user menu allows

items from the item list to reorganize things.

you to switch between English and German

Item List: Selecting items in the sidebar will
display the contents in the item list. When
using the standard preview position, the list
can be sorted by clicking the column headers.
There are options to enable or disable

language and also provides a Log Out option
for more security when allowing others
access to the computer. Lastly, it gives you
access to two powerful options: the See Also
pane and the search field.

them in the contextual menu. Items can be
dragged, handily for filing loose documents
into groups. Double-click groups to display
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See Also: When you show the inspector

If everything goes well, you will be able to

pane, the second view is a See Also view. This

access your database using an address like:

displays potentially related files in the current

http://xxx.xxx.xxx.xxx:port, where

database you are viewing.

xxx.xxx.xxx.xxx is your current public IP

Search: Searching the viewable databases
can be done in the search field. Enter search
terms, including using search prefixes to
focus the searches. For example, you can do a

address. (Note: This is your router's address
on the internet, not your Mac's.) Next, port
is the outside port number leading to your
published database.

search for text:housing tags:government.

Port forwarding done manually: The following

If you want to restrict where you're searching,

is only a rough outline of the steps needed

select All Databases or a specific database to

to configure port forwarding manually. The

search in.

precise way to do it varies from router to

Descriptions of the controls in the user
interface can be found in the Web Sharing
section of the Windows chapter.

router. You will need to consult the manual for
your router in order to determine exactly how
to set things up. To configure port forwarding,
follow these steps:

ACCESSING YOUR DATA OVER THE

Step 1: Begin by determining your Mac's

INTERNET

public IP address. This can be done

Web sharing is best used on a local area
network (LAN). But there may be situations
where you want to share the database to
users that aren't on your network. While we
can't provide specific support due to the
differences in equipment and environments,
we have provided a simple guide you can try.

by visiting a web site like https://
www.whatismyip.com from your machine.
Step 2: Determine the port on which
DEVONthink published on your Mac. You
set the port in Preferences > Server.
To publish on the internet, enter a port
number here and do not let DEVONthink
set it automatically as the port number

To access your database from outside your

may then change every time you open the

network, you need to make your Mac "visible"

application.

to the outside world. In general, when you

Step 3: Determine your Mac's private

a using a DSL or cable modem, you are also

IP address. The IP address is usually of

using a router. Routers create an intranet that

the form 10.x.y.z, 192.168.y.z or

your Mac is connected to and "route" traffic

172.16.y.z. You can find your Mac's

between the internet and your personal

private IP address by going to the Network

intranet. Now, you need to create a route

preferences panel in System Preferences

from the outside leading to the Mac sharing

and looking it up under TCP/IP for the

your database. This offers a port on the

interface you are using (usually Built-In

outside that is directly connected to the port

Ethernet or Wi-Fi).

on which DEVONthink is publishing.

Step 4: Decide on a public port for
DEVONthink. The port should be in the
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range 1025-65500. We suggest that you

SERVICES

use port 8080, which is traditionally a

The DEVONthink > Services menu gives

default port for private web servers.
Step 5: Configure port forwarding on
your router. The steps to do this vary
from router to router, but all of them
require you to provide these details: Public
port, private destination IP, and private
destination port. You found the private

you access to special commands provided
either by other applications, such as TextEdit
or Safari, or by services extensions such
as DEVONtechnologies' WordService or
CalcService. Also, DEVONthink publishes its
own services in the Services menu.

destination port in step 2, and the private
destination IP in step 3, and you selected
the public port in step 4. If you are in doubt
about how you configure your router to
do port forwarding, you need to consult
the manual that came with your router.
It is usually done through a web-based
interface or custom-built administration
application. For instance, AirPort routers
can be configured using the AirPort Admin
Utility.

DEVONTHINK SERVICES

Step 6: Save the configuration changes
on your router, and restart the router if

DEVONthink installs several services for

required. At this point, you are ready to

copying or summarizing selected text,

connect to your DEVONthink from the

capturing a web page, or searching for

outside.

documents in your databases.

Step 7: From the remote computer, open
a web browser and enter the address as
follows: http://xxx.xxx.xxx.xxx:port,
where xxx.xxx.xxx.xxx is the public IP
address you found in step 1, and port the
public port you selected in step 4. Press
↩ Return and you should get presented
with your database's web interface.

Add to DEVONthink 3: Adds selected files,
bookmarks, or images to your database.
This service is also available in the Finder's
contextual menu.
Capture Bookmark: Adds a bookmark to a
URL selected in text.
Add to Reading List: Adds a bookmark to a
URL selected in text to the Reading List.

Setting up port forwarding can be tricky, but

Take Plain/Rich Note: Adds selected text

the difficult part is mainly in determining

to the global inbox as a plain or rich text

how to configure your particular router. If you

note from any application that support

are in doubt, search online for your router's

services. Taking a rich text note also copies

name and combine it with a search for "port

images and clickable links. If the source

forwarding" or "port mapping."

document is a web page or a news feed,
DEVONthink tries to capture the address
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of the page or feed as well. This only works

To install the PDF service, select DEVONthink

with applications that support this feature,

> Install Add-ons and check PDF Services in

such as Safari, DEVONagent Pro, and other

the dialog window. Then click Install and the

web browsers.

option should now be available.

Append Plain/Rich Note: Adds selected
text as plain or rich text to the last note
taken using the DEVONthink Services
menu items.
Lookup: Opens the search pane in

Printing to your database: To "print" (save) a
document to DEVONthink as a PDF, open it
in its creator application (this could even be
DEVONthink itself). Then, do the following:

DEVONthink with the selected text copied

Select File > Print.

as search term.

In the appearing print dialog window, click

Summarize: Creates a new note in

the PDF button at the lower left corner

DEVONthink's inbox with a summary

and select Save PDF to DEVONthink from

of the selected text. DEVONthink uses

the menu. A PDF will be printed and sent

all documents in the open database

to DEVONthink. Depending on your choice

for determining what's important and

in Preferences > Import > Destination, the

what's not. The summarization settings

file import into the Global Inbox or let you

in Preferences > Editing, define whether

choose the destination group.

the summary are be based on sentences or
paragraphs.

Note: This requires an installed printer to
work properly.

If you want to assign hotkeys to services,
go to System Preferences > Keyboard >
Keyboard Shortcuts > Services. Do note that

THIRD-PARTY APPLICATIONS

application hotkeys can override hotkeys set

DEVONthink offers many standard ways to

here. Try to make sure to specify unused key

integrate with third-party apps including

combinations in your shortcuts. Also, due to

drag-and-drop of common data formats,

the way macOS loads menus, you may need

copy-and-paste, and AppleScript. In

to show the DEVONthink > Services menu

addition DEVONthink comes with special

once before the hotkey will become active.

arrangements for applications often used
together with it.

PDF SERVICES
Another way to get files into DEVONthink is
using PDF services. Installing DEVONthink's
service adds a Save PDF to DEVONthink
option to the PDF button of the print dialog
in any Mac application. This allows you
to print a paginated PDF directly to your
database.

Bookends: Choose File > Import >
References from Bookends to import
Bookends references as rich text
documents with a back link to the original
item in Bookends.
Evernote: Choose File > Import > Notes
from Evernote to import selected Evernote
notebooks.
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Tinderbox: Copy notes in Tinderbox and

in DEVONthink including backlinks and

choose Data > New > With Clipboard to

tags.

create plain or rich text copies of the notes

Yojimbo: Choose File > Import > Items from
Yojimbo to import all items from Yojimbo.
Items without URLs are backlinked.
Apple Mail: DEVONthink adds its own menu
commands into Apple Mail to facilitate
importing selected message or mailboxes
into your databases. See also p. 52ff
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WINDOWS
IN THIS CHAPTER

DEVONthink uses a number of windows to

Main Window

74

Sidebar: Navigate

80

Sidebar: Filters

85

Sidebar: Smart Group and Rule Editor

87

Sidebar: Reading List

88

Sidebar: Image Capture

89

Sidebar: Email

92

Sidebar: Extras

93

Document Window

94

Download Manager

95

The Sorter

97

Preferences

102

Database Properties

102

Popovers

103

Web Sharing

106

Support Assistant

108

Log

110

Activity

present information. These windows are
used for displaying and manipulating groups
and documents, finding information, editing
metadata, analyzing text, and changing the
properties of your database.

111
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MAIN WINDOW

The main window is split into simple sections,

You can can toggle the pane's visibility in the

some of which will be familiar from other

View > Preview menu or via a toolbar button.

applications. In fact, as we introduce the
components of the window you'll see

Layouts:

DEVONthink has many familiar elements in

Widescreen: The View/Edit pane is

it. We start off with the fundamental panes

displayed to the right of the item list, an

you'll use.

option common in many Mac applications.
Standard: The View/Edit pane is displayed

VIEW/EDIT PANE
When You launch DEVONthink you will see
an empty pane at the bottom of the window
reading Nothing Selected. This is the View/
Edit pane, a preview pane displaying the
currently selected document. This pane gives
you a view of the content of compatible

under the item list. This is a bit more
traditional but very useful on smaller
screens, e.g., MacBooks.
None: Hides the View/Edit pane. Note you
can still select any file and press the space
bar to preview it in a Quick Look pane, as
needed.

documents. It also allows you to work on

As noted above, DEVONthink allows

compatible files directly in the main window

displaying and editing, and even creating,

when the pane is shown. Or you can hide the

some file types. Please refer to the

preview, perhaps if you want to concentrate

Documents chapter for more information on

on information about a group of documents.

this and other components related to the
View/Edit pane.
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ITEM LIST
When you open a Finder window, you are
presented with a list of files in a certain
location. The view may be icons or a list, etc.
but you are still just viewing the contents of a
folder, hard drive, etc.

best used without a preview or in standard
layout.
List: Behaving much like Finder's List
view, the

List view shows a list view

of the items with metadata columns.
Drag the columns left and right to reorder
them to your liking. Sort them by clicking

DEVONthink is no different in this respect.

the column headers, switching between

When you open a main window, you will see a

ascending and descending each time you

list of groups and documents in the current

click. Control-click the headers to add or

location. Clicking on or opening other groups

remove columns. Or make these choices

shows their contents. Smart groups, just like

from the Tools menu.

the Finder's smart folders, also display their

Columns: The Mac OS X Finder received

contents in an item list. The item list also

the Columns view from its NextStep

supports familiar operations like drag-and-

counterpart, then iTunes adopted it for

drop between groups, copy and paste, group

browsing music. DEVONthink's

and ungroup, contextual menu items when

view functions in the same way. This option

you Control-click, etc., just as you've done in

works best with a preview in standard

the Finder.

layout, for quickly viewing selected files,

Column

but you can also use Show Details to
Views: Again, taking a cue from the Finder,
the item list allows you to display your
documents in some familiar views:
Icon: For the more visual folks, we have the

display metadata and the file's thumbnail.
Expanding the width of the column by
dragging the separator will scale the
thumbnail, if desired.

Icon view. This displays the thumbnails

Cover Flow: An iTunes feature that found

of the documents with just their name. You

its way to the Finder and DEVONthink is

can choose Show Details to display some

Cover Flow. Similar to the Icon view

additional metadata in a widescreen view.

but with dynamically created thumbnails,

Change the size of the thumbnails with

i.e., the displayed image is generated from

the slider in the information bar, noting

the contents of the file. This side-scrolling

this will affect the amount of metadata

item list can be useful when making visual

shown as well when details are shown.

assessments of documents. It is best

Double-clicking groups behaves just as

used with a standard layout or without a

double-clicking a Finder folder, displaying

preview displayed.

the contents in the current or a new
window, depending on the Double-click
opens groups in a new window checkbox
in Preferences > General. Note this view is

All these views can be easily changed in the
View > View options, as well as the quartet of
icons

on the right-hand side of the

Information bar.
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Sort: In addition to sorting the item list by

Additionally, DEVONthink displays special

clicking column headers or using the View

icons to the right of item names for

> Sort menu, you can also choose a sort

attributes like Spotlight comments,

method in the Sort dropdown menu in the

reminders, etc. A key of the item icons can

information bar. By default it reads by Name.

be found in the Iconology section of the

Also, notice there is a Customize Metadata

appendix

command in the Tools > Columns menu, the
contextual menu, and this menu. Select it
to fine tune what columns are available to
display, including any custom sets you've
created yourself.

Contextual menu items: When you Controlclick in a Finder window, a contextual menu
appears with a host of commands for you to
choose from. DEVONthink's item list also has
a contextual menu available. The commands

Visual Cues: DEVONthink provides a few

shown depend on what is selected and

visual cues applied to items in an item list.

in what pane you're using. A list of the
commands can be found in the Contextual
Menu Items section of the appendix.
Note: To keep visual consistency and
make some functions more broadly
accessible, item lists are used throughout
DEVONthink's interface, so you'll see

Duplicates: Duplicate files display their

them in some other panes. But note some

name in blue or the

functions, like specific contextual menu

icon, depending on

your setting in Preferences > General >

items, may change, depending on the

Mark duplicates and replicants in color.

specific pane you're using.

Replicants: Replicant files display their
name in red or the

icon, again depending

on the preference setting.

At the top of most Mac applications you

Unread: Unread items, including groups
with unread items in them, display their
name in bold.

encounter, including the Finder, you will see
the toolbar. For people who prefer working
with tracking devices, e.g., mice, trackpads,

The Flag column shows the state,
or unflagged, or the

TOOLBAR

flagged

unread status of

etc., the toolbar allows you to have quick
access to some functions without having

items. Clicking in the flag column toggles the

to go through the menus. DEVONthink also

flagged state. If an item is unread, a circle

provides a toolbar in main and document

will appear in this column. If you have a group

windows.

containing a mix of flagged and unflagged
items, a dash will appear in this column,
showing an indeterminate state.

The toolbar comes pre-installed with a handy
default set of buttons, including the search
field (see below). It can be customized via the
Tools > Customize Toolbar command. You can
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also Control-click the toolbar and choose this

file are available in the Info Inspector. Unlike

command from the contextual menu. Add,

other applications, it gives you multiple

remove, and reorder these items to suit your

inspectors presenting more information

particular needs. On a side note, if you want

and functions, all docked in the inspectors

to quickly reorganize items on the toolbar,

panes. This gives you quick access to all the

hold the ⌘ Command key and drag the item

inspectors in one unified window, especially

to its desired location, or off the toolbar to

helpful on smaller screens.

remove it.
If you're looking for a little more space for

The inspectors are individually discussed in
the Inspectors chapter.

your toolbar, or even a little less, you can
choose to display the toolbar as Icon and
Text, Icons Only, or Text Only. Do bear in
mind, the Icon Only view will not show the
current document's title or icon.
A list of the available toolbar items is
available in the Toolbar section of the
appendix.

SIDEBARS
Seen in scores of applications for many
years, a sidebar is a top level organizational
structure, typically found on the left side
of an application window. The Finder or
Apple Mail sidebars are perfect examples
of this. Looking at them, you should
see the immediate similarities with
DEVONthink. However, unlike most other
apps, DEVONthink has multiple sidebars,
each with their own special functions covered
a bit later in this chapter.

INSPECTORS
In some applications, extra information about
files is shown in a pane on the right side of
a window. DEVONthink also provides such a
pane in its main windows with individual subpanes called Inspectors. For example, data
about the name, tags, type, etc. of a selected
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SEARCH PANE

Storing information is a useful thing, but

Live while typing: Enable this option to

it's more useful when you can find things

search while typing or disable it to search

too. DEVONthink offers a strong search

only when you press ↩ Return.

function for finding items in your databases,

Partial matches while typing: This option

all integrated into a main window.

assumes an asterisk wildcard at the end of

In the toolbar is a search field for entering
your search terms. Type in a word and the
search pane appears showing any matched
items — and yes, it's another item list
supporting the different views and sort
methods discussed above. Additionally, the
View/Edit pane can be shown to display
selected results. For contents-based

the last search term.
Ignore Diacritics: This allows you to ignore
special marks on letters, like umlauts or
accents.
Fuzzy: This uses fuzzy-logic to expand the
possible matches DEVONthink makes.
For example, hello and hullo would be
matched.

searches, the search terms will be highlighted

Search prefixes: Anything you type into

in the preview, whenever possible.

the search field will be treated as searching

Search options: In the search field, you will
notice a

magnifying glass icon. Click this

icon to see where to search, list the ten most
recent search queries, one choose among the
following options:

in all possible attributes. However, if you
want to focus on specific attributes, e.g.,
file types or tags, the search field supports
prefix operator searches, similar to Spotlight.
Common examples are searches like
name:DEVON or tags:tech;sync, separating
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multi-valued attributes like tags with a

Searching inboxes or all databases creates

comma. There are a wide variety of prefixes

a global smart group, shown in the Smart

available, as well as different prefix operators.

Groups section of theNavigate sidebar.

A complete list of these items is included in
the Search Prefixes section of the appendix.
In addition to search prefixes, DEVONthink

Note: The search index contains
alphanumeric characters as well as the
following symbols: $€£¥%§

supports Boolean operators, parenthesis for
grouping terms, and quotes to match specific
terms. Read more about operators and how
to use them in the Search Operators section
of the appendix.

PATH BAR
On the left side of the main window, just
below the toolbar, is the Path Bar. This is
a specialized bar displaying a crumb trail

Search scopes: After you've done a search,

of your current location in a database. For

you will also see a bar above the search

example, if you are in a nested group, it will

results allowing you to choose the scope of

show something like Coding > AppleScript

the search. The scope is the "where" you're

> WWDC > 416, beginning with the current

searching. You will be shown All Databases,

database.

Inboxes, the name of the current database,
and the name of the current group, if you're
currently viewing one. Choose one to expand
or limit where DEVONthink is searching.

Each item in the crumb trail is a live link, so
you can click it to jump to any parent folder
or back to the top level of the database.
This bar also has < and > buttons so you can

Advanced and save: To the right of the search

navigate back and forth between locations

scopes, you will see two buttons. Clicking the

you've visited in this window. As an added

Advanced button displays the criteria of the

feature, click and hold one of these buttons

current search. You can modify the search

to be shown a list of previous locations you've

with the same kind of controls used in the

visited, just like in a web browser.

Finder's smart folders, as well as some other
applications with advanced search methods.
Note these controls are also used in creating
smart groups and smart rules.

INFORMATION BAR
Another specialized bar, the Information
Bar displays the number of items selected

If you have done a search you'd like to use

and the total number of items in the current

again, press the Save button. Enter a name

location. As mentioned previously, this

and DEVONthink will create a smart group

bar also hosts the Sort dropdown and the

for you. If your search scope is in a group,

view icons.

the smart group will be created there. If you
are searching a specific database, the smart
group is created in the root of the database.
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SIDEBAR: NAVIGATE

UNIFIED ELEMENTS

The Navigate pane is the default sidebar

By default, specific parts of databases are

where you will access to your databases, tags,

shown gathered in specific sections, similar

items located in Favorites, etc. Additionally,

to how Apple Mail displays the inboxes of all

you have access to some specialized items:

accounts in the same section.

global smart groups and smart rules.
Globals: The Globals section provides quick
access to three locations common to all
databases: the Inbox, Tags, and the Trash.
If you click a top level section, e.g., Inboxes,
you will see a combined view of items in the
inboxes of all open databases. This can be
especially handy if you want a view of all the
tags you're using in your databases. Click the
disclosure triangle next to each section to
show the locations for each open database,
Each section in the Navigate sidebar has its
own specific purpose: giving you access to

allowing you to access the locations on an
individual database level.

frequently used files, navigating database
groups, or viewing a list of similar files. The
sidebar will only show databases and groups.
Selecting one of these items will display
its groups and files in the item list. This
allows a clear view of the group structure
in the sidebar, while still allowing you to
interact with the contents in the item
list. Alternatively, you can view the group
hierarchies directly in the sidebar. Excluding
smart groups and smart rules, selecting
multiple items will show a union of their
contents in the item list.

Inboxes: The inbox of a database, like the
real-world counterpart on an office desk,

The sections in the Navigate sidebar can

is where incoming, unfiled items are kept.

be dragged to reorganize them as desired.

Every database has one by default and you

Sections you don't need to use as often

can see the name of the database each inbox

can be collapsed to reclaim the space or to

belongs to. The Global Inbox, shown just as

provide a bit of privacy.

Inbox, is a special, always-open database
present in every installation of DEVONthink.
This is highly useful when quickly capturing
data, e.g., web clipping, screen captures, etc.,
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without stopping to file things. You can then

If you find yourself in a situation with multiple

go back later and file these items at your

tags you'd like to merge, select the Tags group

leisure.

for the current database to view the tags in
the item list. You can then select the tags
there and choose Tools > Merge Items.
Removing entire tag groups can be done by
dragging and dropping to the sidebar's trash.
From the contextual menu, you can choose
Move to Trash. You can delete tags in the
item list as well. One thing to note: When you
delete a tag, the original file in the database
is preserved. What you see in the database's
trash is the replicant that was created in the
tag group when you added the tag.

Tags: The Tags section provides quick access
to all the tags you are using or tags within
individual databases. If you click the top level
tags, the item list will display all the tags
you've created. Open this group and click on
a database's name to show its tags. If you like
to create nested or hierarchical tags, you can
drag and drop existing tags in the sidebar or
the item list.
Typically you will use the Tags bar in the
View/Edit pane or the Info Inspector or
Info popup to apply or create tags. You can

Trash: Every database has its own individual

also drag items in your database to the

trash. This allows you to see, and potentially

individual tags. When you create a tag it will

retrieve, items you've deleted from your

automatically appear in the Tags group of the

individual databases. Just as with the real-

database you're in. If you want to create new

world trash bin, we do suggest you empty

tags to be used later, select the Tags group

your databases' trash regularly. It is not

for the database and choose Data > New >

meant as another filing location, and items

Tag. Or from the contextual menu, Control-

marked as missing will still register as a

click the database's top level Tags group or an

problem for a database. Select the trash,

existing tag and select New Tag.

the top level or individual database's trash,
and choose DEVONthink > Empty Trash. The
command is also available in the contextual
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menu, when Control-clicking a trash. Trashed

Note: With Unify Inboxes and Tags both

files are not deleted completely from the

disabled, the database's contents will

machine but are put into the system trash.

appear similar to how DEVONthink 2
displayed databases.

Open Databases: This section is where you
see and access any databases you have
currently open. Click the database's name
to display items in the root of the database.
Clicking the disclosure triangle allows you to

Databases: When disabled, DEVONthink

show groups, and subsequently sub-groups in

displays a database's name in the Open

the database. As mentioned above, selecting

Databases section of the sidebar but the

a database or group will display its subgroups

contents will be shown in a separate section.

and files in the item list.

The current database will be marked on the
left by an asterisk (*) and its groups will be

NON-UNIFIED ELEMENTS
As the unified views may be less comfortable
for some people, DEVONthink allows you to
decide what database elements you want to
unify. Controlled by options in Preferences >
General > Sidebar, you can enable or disable
unifying: Inboxes, Tags, or Databases.
Inboxes: If you disable unifying the inboxes,
only the Global Inbox will be shown in the
Globals section. The inboxes of individual
databases will be shown in the item list when
the database is selected.
Tags: Similar to the inboxes, disabling this
option will display the Tags group with other
elements in the selected database.

shown in a separate active database section
in the sidebar. This creates an isolated view
of that database regardless of the number
of databases that are open. Interacting with
elements in the active database section
displays contents in the item list, similar to
the Three Pane view from DEVONthink 2.
For switching between active databases,
select another database and the active
database section will display only the groups
and smart groups of that database. Also,
there are Previous Database and Next
Database commands in the Go menu.
When using the keyboard, hold the Command
key and press the up and down arrows to
view the contents of another open database
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in the item list while showing the contents of

allows you to create shortcuts to quickly

the previously active database in the active

access any of these kind of items. Drag a

database section. Press ⇧-↩ to change the

group or a document to this section's header

active databases section to the currently

and you'll see a curved arrow on the cursor.

selected database.

Drop the file and you have a new favorite. An
option to Add to Favorites is available in the

CONTEXTUAL MENU
There are a few specific contextual menu
items found in these sections of the Navigate
sidebar. These commands are also found in
the File or Data menus:
Copy Database/Item Link: Copies a link to
the selected item.
Database Properties: Displays information
about the chosen database.
Close Database: Closes the chosen
database. In the case of encrypted

contextual menu commands of most items
in DEVONthink. Use Remove from Favorites
when Control-clicking on already favorited
items to remove them.
Select an item in Favorites to quickly access
it. If an item was last viewed without a
preview, it will be displayed in its own
window. If you see a favorite is greyed out,
it means the containing database isn't
open. Double-clicking the item will open the
database, if possible, and display the item.

databases, the encrypted volume will be

Drag items in the section to reorder them.

ejected as well.

Groups in Favorites behave as normal groups,

Delete Database: Deletes the chosen

so you can drag items into a favorited group

database to the system trash. This includes

for quick filing. This includes using ⌥ and ⌘⌥

its cache and Spotlight index as well.

to duplicate or replicate items while dragging

New Window: Opens a new main window

and dropping to them.

for the chosen database.
Rename: Change the name of the chosen
database. This can also be done in the
Database Properties.
Show in Finder: Reveals the database file in
the Finder.
Any section-specific contextual menu items
that may require explanation are discussed in
their respective sections below.

FAVORITES
There are many times we have specific
databases, groups, or documents we return
to, again and again. Shown at the top of the
sidebar by default, the Favorites section

Note: Favorites only support one level of
content, so you can't group or nest items
here.

RECENT DATABASES
The Recent Databases section provides quick
access to reopen closed databases. This will
list the last ten recently closed databases.
Double-click any databases you'd like to open.

SMART GROUPS
The global smart groups function the same
as local smart groups, i.e., the ones in your
individual databases, but generally their
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scope is all open databases. This allows

If you have exported smart groups in the

you to have reusable searches targeting all

Finder, double-clicking them will import them.

your open databases, e.g., all Markdown

You can also drag them to the smart rules

documents in all databases created in the

section of the sidebar.

last month. These global smart groups can be
modified to target more specific locations,
but such a smart group would be better
suited as a local smart group, i.e., in the
particular database. DEVONthink comes with
some pre-installed global smart groups:
Today: Shows all documents added or
modified today.
Recently Added: Shows all documents
added in the last week.
Due This Week: Shows all documents with
a due date set for this week.
Top Hits: Shows documents opened more
than five times in the last 30 days.
Unread: Shows all documents marked as
unread.
You can create a smart group from the

For more information on editing smart group
properties, global or local, see the Smart
Group Editor section of this chapter.

SMART RULES
Similar to smart groups, smart rules are
created, edited, and behave in a similar
fashion. However, they have one distinct
difference: they can act on the items
matched. The smart rule matches items just
as a smart group does but they perform
actions when certain events take place. This
makes them a very powerful way to add
automation to your DEVONthink life.
DEVONthink provides a few useful example
smart rules to get you started:

contextual menu or the + button at the

Automatic Locking: Locks unlocked

bottom of the sidebar. By default all open

documents (excluding RSS articles), that

databases will be targeted. However, if you

haven't been modified in the last 30 days.

have an item selected in the Globals or Open

This requires user intervention.

Databases sections, the smart rule will use

Bates Number: A specialized rule that adds

that location for the matching.

the current database's name and a Bates

Control-click a smart group to Edit, Rename,
Duplicate, or Remove it. You can also copy a
link to a smart group, export it to the Finder,
or import previously exported ones. If you'd
like to convert an existing smart group into
a smart rule, ⌃-click the desired smart group,
hold the ⌥ key, and choose Duplicate as
smart rule.

number to a filename. The original name is
preserved as a document alias.
Filter Duplicates: Automatically puts
duplicated items in a database's trash
when you import them.
Reminders: Displays the name of a
document and plays the system "glass"
sound when a reminder on a matched item
triggers.
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If you Control-click a smart rule and choose

Drag and Drop: Lastly, you can drag and drop

Edit, you will see the criteria, event trigger,

items onto smart rules to apply their actions

and actions for that rule. Like smart groups,

to them. Dropped items will be acted on,

you can create a smart rule from the

ignoring the location and criteria specified in

contextual menu or the + button at the

the smart rule. For example, you may have a

bottom of the sidebar. The target of the

smart rule to add the date to the beginning

smart rule also follows the same behavior

of the name of images imported into your

as a smart group: all databases are targeted

Global Inbox. However, you could drag and

unless you have an item selected in the

drop a rich text file from a separate database

Globals or the Open Databases section of

on to the smart rule and the date would

this sidebar.

be prefixed to the name, even though the

Control-click a smart rule to Edit, Rename,

location and file type do not match the rule.
Duplicate, or Remove it. You can also copy a

For more information on editing smart

link to a smart rule, export it to the Finder,

rules, see the Smart Rules section of the

or import previously exported ones. Double-

Automation chapter.

clicking exported smart rules imports them,
and so does dragging them to the sidebar.

SIDEBAR: FILTERS

In the contextual menu for a smart rule,

Providing yet another way to isolate files

notice there is also a smart rule-specific

in the item list, the Filters pane allows

command: Apply Rule. This runs the clicked

you to only show files that share common

command on any matching files. This means

attributes. This pane, displayed at the

it will performs its actions, even if the event

bottom of the Navigate sidebar an be shown

trigger is not set to On Demand. Be cautious

or hidden via the Tools > Filter menu or the

about using this command unless you are

trio of icons at the bottom of the Navigate

certain you want to affect all matched items.

sidebar. The pane can be resized by moving

There is also an option to copy the item link

the divider at the top of the pane.

for a smart rule by choosing Copy Rule Link.
There are two commands in the Tools menu
related to smart rules:
Tools > Apply Rules: This runs the actions
of a chosen rule on selected items, but only
ones matched by the smart rule.

INFO
Displayed by selecting Tools > Filter > Info, the
Info filters pane let you shows only files that
share common dates, ratings, color labels,
etc.

Tools > Perform Rules: This performs the
chosen rule as defined, not acting on the
selection.
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TAGS
Choosing the Tags filter via Tools > Filter >
Tags displays a tag cloud derived from the
tags on the current list of files. The cloud
shows the tags in varying sizes depending on
the number of occurrences of each tag on
these documents. The more files with a given
tag, the larger it displays. This makes it easy
to identify commonly used tags. If there are
no tags on the files in the current item list, No
Tags will be displayed. Additionally, ControlDates: Click the Date dropdown to choose

click in this pane to sort the tags by Name or

the type of date you want to filter on: Added,

by Count.

Created, Modified, Opened, or Due. Click on
a date in the calendar display to only show
files related to the day and type of date
you selected. Use the small arrows to move
backward and forward through time, and click
the circle between them to quickly return to
the last selected date.
Marks: Choose the type of mark, or a
combination of them, on which you want to
filter. For example, you can click the flag and
a rating of 3 to show only those files. You can
filter on these attributes:
Flagged or unflagged

To filter the files, click any tag. You will

Read or unread

immediately see the tag cloud reduce in

Locked or unlocked

number and only related tags are shown. This

Rating

allows you to drill down into files that share

Label

common tags, but also exposes tags that

File Location: Click the dropdown to choose
whether to display Imported, Indexed, or
both with Any.

have been used with the previously selected
tags.
Note: The tags you choose will also be
shown in the Information bar above the
item list. Hovering over one of these tags
displays a

close button at the right side
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of the tag. Click it to stop filtering on that
tag. You can also press the Reset button to
clear all filtered tags.
Control-clicking a tag in the tag cloud shows
these options:
Reveal Tag: Displays the Tag group in the
list of tags from all open databases.
Remove Tag: Removes the tag from the
Tags groups and also from any document it
was applied to.
Related Tags: Displays the top two tags
most commonly used with this tag.
Selecting a tag from this list filters the files
on that tag.
View>: Allows you to switch between cloud
and list view.
Sort: Allows you to sort the tags by name

The map functions similar to Apple or Google
Maps, allowing you to use familiar pinch
gestures or double-click or Option-doubleclick to zoom in and out, panning, etc. The
map shows pins for all documents with
geolocation data in the selected location in
the Navigate sidebar. Selecting a pin in the
map displays the files with that geolocation
data in the item list.

or count.

MAP

SIDEBAR: SMART GROUP AND
RULE EDITOR

Utilizing geolocation data from your files,
the Maps filter shows documents related by
location. Show this filter pane by selecting
Tools > Filter > Maps. By default, the pins on
the map show the place a document was
created. However, the geolocation data can
be manually changed to a relative location,
like the site of a historic event. (See the Info
Inspector for more information on this.)
When you create or edit a smart group or
smart rule, a sheet appears with options for
specifying options, like the criteria to match
or from where to match items.

OPTIONS
The top section of the sheet contains a
mandatory name and search location, as well
as a few optional items.
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Name: Enter a name for the smart item.

returned as a result. Predicates themselves

Search in: Select where you want this

consist of the field to search (like "Content"

smart item to search.

or "Tag"), and the condition and the data that

Exclude Subgroups: Enable this to ignore

needs to be matched.

items in subgroups of the location selected
in the Search in dropdown.

Add as many criteria as you need. Use the +
and - buttons to add more predicates to your

In the Comparison section, you will see these

smart group or to delete them. Predicates

options:

can be rearranged with drag-and-drop. Hold

Ignore Diacritics: Check this to treat
letters with diacritics, e.g., umlauts or
accented characters, the same as their
regular counterparts.
Fuzzy: Check this to apply fuzzy logic to

the ⌥ Option key and click a ... button to
create a "compound predicate" also called
"branch". Each branch also has its own All or
Any option as well. This allows you to create
very targeted searches.

contents-based criteria, ignoring simple

Example: To find all Microsoft Excel files

typos so that instances of "hello" and

use the condition Filename ... ends in ...

"hallo" are both found.

xslx. To find items created in the last 7 days

Highlight Occurrences: When used with

use the condition Date created ... is ... Last

contents-based matching, this will highlight

Week.

the terms in the text of selected search
results, if possible.

PREDICATES
The second section of the editor shows the

Note: In some predicates you can use
wildcards, Boolean operators, phrases, and
parenthesis, too. See also p. 213ff

SIDEBAR: READING LIST

search predicates. These define criteria you
want to match. Criteria may be content- or

Similar to the section found in Safari (and

attribute-related, e.g., documents containing

now many other browsers), the Reading

a specific word or groups added this week.

List provides a place to access documents
and groups you've "set aside" for later

Note: The predicate editor is also shown

consideration. The items are listed in All

when using the Advanced options when

and Unread views. Newly added items are

searching your databases. It is also shown

displayed at the top of the list.

in a similar sheet when you run the Tools >
Batch Process command.
The list of predicates consists of a list of
blocks, each beginning with All or Any,
defining whether all (Boolean AND) or any
(Boolean OR) of the contained predicates
need to be true for the document to be
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Move to Trash: Moves the item to the
database's Trash. Emptying the Trash
removes the file and its reference from the
Reading List.
Copy: Copies the selected item(s).
Select/Deselect All: Selects all or none of
the items, respectively.
Remove Item: Removes the clicked item
Add files from the item list via drag and drop
when this pane is visible. Alternately, choose
the Data > Add to > Reading List menu item.

from the Reading List.
Clear All Items: Removes all Reading List
items.

This command may also be available when

Note: The last two options cannot be

Control-clicking in an item list or in images

undone.

and PDFs.
Items added to this pane will automatically
appear in the Unread view. Selecting an item
with the View/Edit pane visible will treat the
item as read and the item will only be shown
in the All view.

SIDEBAR: IMAGE CAPTURE
The Import sidebar pane gives you access
to two common sources of external data:
scanning and email. Each section in this
sidebar provides controls to import from any

Items in the Reading List can be moved to

supported scanner or a compatible email

other locations by dragging them to any item

client, e.g., Apple Mail or Outlook. This makes

list in a main window. The drag operations

DEVONthink a reliable companion at home,

also allow you to duplicate or replicate the

in an office, in the hands of an archivist,

files, holding ⌥ or ⌥⌘, respectively.

and many other scenarios. We will cover the
scanning controls in this section. We have

CONTEXTUAL MENU

also provided a more practical overview in
Capturing Paper section of the In & Out

The contextual menu (which appears when

chapter.

you Control-click an item) offers these
commands:
Open in New Tab: Opens the clicked item in
a new tab.
Open in New Window: Opens the clicked
item in a new document window.
Mark as Read/Unread: Changes the read
state of the clicked item.
Reveal Item: Reveals the item in its current
location.
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Resolution: Set the desired resolution
of the scan. 300 dpi is the suggested
resolution for most cases.
Size: Choose a pre-defined page size or
check Custom Size and manually change
the scan area in the overview. Resize the
scan area or even drag multiple scan areas
on the same scan. You can also enter
specific measurements. Switching to a
Archiving documents is an important
function in many situations. The Image
Capture section of this sidebar allows you
to control compatible scanners or import
images from connected cameras or iOS
devices.

pre-defined size will clear any custom scan
areas.
Orientation: Change the orientation of the
final document.
Name: Enter a name for the final
document. If left empty, a date stamp will
be used as an automatic name.

DEVICES

To: Choose where to send the document:
Imports, create a new binder or use an

The Devices section allows you to choose

existing one, or choose a destination in a

an input device. Choosing a scanner offers

database.

different controls and options than selecting

Destination: The chosen location in a

a connected iOS device or camera.

database will be shown here. You can also

Selected Scanner: If you select a scanner you
will be presented with controls and settings
to scan your documents. This allows you to
use your scanner directly in DEVONthink very
efficiently. This interface should be familiar
to anyone using Apple's Image Capture
application or scanning in Preview.
Overview: The overview of what's being
scanned. When using a Custom Size you
will define the scan area in this pane.
From: Choose where you'll be inserting the
paper into the scanner.
Mode: Choose the color type: Black &
White, Grayscale, or Color.
Duplex: Enable double-sided scanning, if

choose a location to send binders to when
saving.
Kind: Choose the format for the final
document.
Tags: Enter optional tags to be applied to
the document.
OCR: Enable OCR for the scan, if desired.
Camera or Mobile Device: Clicking on a
connected camera or mobile device displays
an item list of photos to import. These
items can be imported for a variety of
uses. Additionally, for documents you've
photographed, the images can be added
to a scanning document (described below)
and OCR can be done to create searchable

available.
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PDFs. This can be very useful for everyday

Remove Sent/All: Contained in a popup

things like receipts to archiving historical

menu, remove already processed or all

documents.

documents from the list.

To: Choose to import items to Imports, into
a new or existing binder.
Thumbnails/Details: Switch between a
thumbnail or a detailed list of photos.
The size of thumbnails is controlled by

Configure: Global scanner settings for
color type, resolution, page size, and duplex
scanning (double-sided, if available).

IMPORTS

the slider at the lower right corner of the

Containing individual scans or Binders,

window.

collections of scanned pages. Create or

Delete: Shown as a stop symbol, use this to

access existing binders and scanned pages in

delete selected images from the connected

this section.

device. A warning will be displayed this
action cannot be undone.
Download: Download selected items to the
location set in the To dropdown. Optionally,
you can double-click items to import them.
All: Download all the items on the
connected device.

QUEUE

Document List: A list of thumbnails of
scanned images.
Create new Binder: Create a new empty
binder.
Properties: Change properties of a
selected scan or binder, e.g., where the
scan will be sent, the title, type, tags, and
optionally enabling OCR. You can also add a
Author or Subject for PDF output.

Select the Queue option to display the

Edit: Change the orientation or make

scanning queue where you can pre-define

image modifications of a selected scan.

documents to scan. Define parameters for

Double-click a scanned page to display the

each document, including: Title, Destination,

image modification pane.

Type (PDF or Image), Separator, whether

Play: Play video imported from an iOS

OCR is enabled, and optional Tags for the

device.

finished document. This section can be very

Delete: Delete the selected scan(s).

useful when batch scanning. The following

Save: Sends the selected scans or binders

controls are shown in this view:

to the To set in the Properties for each.

Scanner: Choose an available scanner.

Select a specific binder in the sidebar to

Flatbed/Document Feeder: Choose where

show a thumbnail view of the pages it

you'll be inserting the paper into the

contains. Rearrange the pages by drag-and-

scanner.

drop or drag pages from one document to

Document List: Defined documents and

another. Press the Sort button to use these

their parameters are listed here.

options:

Add/Delete: Add or delete new document
definitions.
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Reverse Order: Reorder all pages from last
to first.
Shuffle Odd/Even Pages: Automatically
switch odd and even pages
Sort and Merge Documents: Choose two
documents to merge their contents. One
document is chosen as the starting odd
page, the other as the starting even page.
The pages are then interleaved into the
current document.
ACCOUNTS AND MAILBOXES
TRASH

The lefthand section of the Email section

Any scans or documents you've deleted from

displays the active accounts and mailboxes of

the scanning interface will appear here. When

Apple Mail or Microsoft Outlook. Select your

you have this selected, empty the trash with

email client, then click the disclosure triangle

the button at the lower right corner of the

to show the accounts then its mailboxes.

window.

Mailbox View: When you select a mailbox in
a specific account, the window will display

SIDEBAR: EMAIL
In addition to scanning, the Import pane also
provides the controls to archive emails from
Apple Mail and Microsoft Outlook. While you
can drag email messages individually from

more controls for filtering and importing
messages from that mailbox. The central view
shows the contents of a chosen mailbox. This
is where you can select individual messages
to import, if desired.

your email client, the Email section of this

This view is separated into columns that can

sidebar also allows you to import individual

be sorted by clicking the column headers.

messages or archive mailboxes directly into

The columns include From, Subject, To, the

your DEVONthink database.

Flagged state. If you are choosing to show

Open the pane pane by choosing View >
Import. Here we discuss the controls used in
this section. For a more practical overview
of the email archiving process, check out
the Archiving Email section of the In & Out
chapter.

already imported messages, there is a special
column showing those items. For emails
marked as high priority, the flagged column
will also show two exclamation points and the
subject, etc. will show in red. Control-click in
the Mailbox view to refresh its contents.
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FILTER AND IMPORT
When a mailbox is selected, the righthand
side of the window shows options for filtering
the messages displayed. It also lets you
choose the location where the messages will
be imported.

times, changing the Destination changes
what messages are displayed when this
option is enabled. If you disable it, already
imported messages will show a checkmark
next to their name
Deleted: Hide messages you've put in the
account's trash.

Destination: Choose the destination for the

Junk: Hide messages moved to the

imported messages or mailboxes.

account's junk mailbox.

Search: Use this search field to search for

The last two items are buttons for importing

messages by the sender or recipient's Name,

selected emails in the Mailbox view or

email address, or the subject line. Note this

archiving the currently selected mailbox. See

only allows for a single term to be used.

also p. 52ff

However, the search is matching substrings,
so a search for jun would match "junk",

SIDEBAR: EXTRAS

"jungle", and "jejune".
The Extras sidebar gives you a place to check
Show: Select options in this section to

for current information from us. It's an easy

further fine-tune the list of importable

way to stay up to date with some of the

messages, if desired. You can use:

goings on at DEVONtechnologies.

Read: Show emails messages have been

Support: Here you will find our recently

read, unread, or either.

published tips, scripts, smart rules, and

Flagged: Show messages that have been

templates.

flagged in the email application.
Priority: Show messages that have an
assigned priority
Date Range: Choose a range of dates to
display messages received between them.
Hide: Use these controls to hide certain items
from the mailbox view. All these options are
enabled by default, but can be selectively
disabled, if needed. However, when these
options are enabled it makes it easy to see
only new messages, ready for import.
Imported: Enabled by default, this hides
messages you've already imported into the
current database. As you can't import the

Tips & Tricks: This shows recent blog posts
of handy tips about all things DEVONthink,

same message into a database multiple
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presented in a RSS feed style. To read the

DOCUMENT WINDOW

full article, click the article's title.
Scripts and Smart Rules: From time to
time, we publish publicly available scripts
and smart rules. You will see a brief
description and a link that allows you to
install the script directly from this section.
Templates: We also offer templates for a
broad audience. This section lists recently
published ones. As with the scripts and
smart rules, a description and installation

You can isolate a document in its own

link is provided.

window, known as a document window. These

If you'd like to quickly mark all items as Read,
⌃-click and select the Mark All as Read from
the contextual menu.

windows are convenient for split screen work.
For any editable file formats, you can open
a document window by double-clicking a
document in any view of a main window.

For a view of all available scripts and

Alternately, you can choose Data > Open or

templates, as well as easy installation and

Open from the contextual menu to open

uninstallation, see the Support Assistant.

any document in a document window. For

DEVONtechnologies: This section provides
a list of blog posts regarding updates and
promotions.

most file types that can't be edited directly
in DEVONthink, double-clicking the file will
open it in the system default application. For
example, double-clicking a Word file will open

Note: For the sake of transparency,

it in the same application that opens if you

DEVONthink does connect to our web

had opened the file in the Finder.

server to bring you this information.
See the Documents chapter for a detailed
description of the various document types
DEVONthink supports.
Note: Command-clicking the window title
shows the document's location including
the database it's stored in.

TOOLBAR ITEMS
Similar to the main window, a document
window has a toolbar at its top. The default
toolbar buttons may vary, depending on
the type of file being viewed in the window.
You can customize the toolbar via View >
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Customize Toolbar, but note there are fewer

A Start/Stop button to enable or disable

options than you have with a main window.

downloads.

A list of available toolbar items is available in

An

Action menu

the Toolbar section of the appendix.
ADDING FILES

DOWNLOAD MANAGER

To download a web site or any other file,

Window > Download Manager opens

simply add it to the Download Manager by

DEVONthink's Download Manager panel.

dragging its URL to the Download Manager

Using the Download Manager, you can

panel. Alternatively, you can click the

download files or complete web sites from

the panel and add the URL manually, as well

the internet, and either store the information

as a referrer, user name, and password. If

in your database or as files on your hard

Automatic is checked, DEVONthink creates

drive. Offline archives stored in DEVONthink

a referrer automatically when downloading

are also used when you visit bookmarks or

whole web sites.

open a link in a new tab and your computer is
currently offline.

in

You can also paste one or more URLs (copied
Safari bookmarks, DEVONthink links,
or copied links from DEVONagent Pro's
Download Manager), or add files to the
Download Manager by using the contextual
menu in web and HTML views in DEVONthink.
Note: You can also copy URLs in the
Download Manager to the clipboard or
drag them to other applications (like the
Finder or Safari's bookmark manager).
The Download Manager also supports
URLs for local files (POSIX path, a file://
localhost/ URL, or a file:/// URL).
ACTION MENU

PANEL ELEMENTS
The Download Manager panel consists of:

Most actions are available through the Action
menu or the contextual menu. Click the
gear button or Control-click an item in the

A list of a items to be downloaded

Download Manager panel to display more

A status bar at the bottom

commands:

A

button for adding items to and a

button for deleting selected items from the

Edit: Edit the parameters of a selected

list
A

Add: Manually add a URL to the list.

reload button

item in the list.
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Retry: Attempts to reload an item that

necessary to display them properly.

failed to download.

Alternative: Create a web archive.

Remove: Removes the selected items from

Subdirectory (Complete): Downloads the

the list. Alternatively, you can press the

files you have added to the Download

⌫ Backspace or ⌦ Delete key.

Manager including all embedded or linked

Enable/Disable: Checks or unchecks the

files. This option set follows all links leading

selected items. Only checked items will be

to (items in) sub-directories. For example,

downloaded.

use this option set to download a complete

Start/Stop Queue: Starts or stops the

web site for offline archiving.

download queue. Same as the play/pause

Subdirectory (Images & Multimedia):

buttons at the bottom of the panel. Note

Same as above, but downloads only

this will only pause queued items. Any in

linked images, linked multimedia files

progress downloads will continue.

including Flash and QuickTime movies,

Purge Queue: Removes all items from the

and embedded images in the item's

list that have been completely downloaded.

directory and all sub-directories. Use this

Only Added Files to Thumbnail Gallery:

set to download a complete web site for

Offers various predefined option sets (see

offline archiving (without all linked Office

below).

documents, PDFs, etc.)

Import Files to Database: Selects which

Thumbnail Gallery: Downloads the files

database the downloaded files shall be

you have added to the Download Manager

stored in. Select Folder to save them

including linked images, embedded images,

directly to the file system.

style sheets, and scripts. Use this option

Options: Opens the options dialog sheet,

set to download a thumbnail gallery

which allows you to specify in detail what

including all full-size images linked to each

to download, which links to follow, and

thumbnail for offline archiving.

where to store the downloaded files (see
below).

Note: Downloaded items are by default
excluded from classification and tagging.

For your convenience, DEVONthink comes
with predefined option sets that you can
directly select from the action menu.

OPTIONS
The options dialog defines which file types

Only Added Files: Downloads only the files

the Download Manager downloads, which

you have manually added to the Download

links it follows, and where it stores the files.

Manager.
Offline Archive: Downloads the files you
have added to the Download Manager
including embedded images, style sheets,
and scripts. Use this option set to archive/
download web pages with everything

Files: Check all file types you want the
Download Manager to download (plain
texts, rich texts, Office documents and
PDF files, style sheets and scripts, images,
embedded images, multimedia files, markup language files, etc.) Use the Follow
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Links pop-up menu to define how far

In Subdirectories: Follows links, but only

DEVONthink should follow links on the

as long as they refer to items in the same

downloaded HTML pages (see below).

directory as the downloaded HTML page or

Check Overwrite existing to update an

its sub-directories.

existing archive.

One Level: Follows all links regardless of

Folder: When you choose Download to >

where they point, but only one level deep.

Folder in the action menu of the Download

Links on pages linked to from the original

Manager panel, DEVONthink stores

page are not downloaded.

all downloaded items in the directory

Two Levels: Follows all links regardless of

you specify. Click Set to choose your

where they point to, but only two levels

preferred location. Use this option to

deep.

use the integrated Download Manager
for downloading software archives or
other files you don't want to store in your

Note: Following links two levels deep can
result in very large downloads.

database. Double-click any part of the
location to reveal it in the Finder.
Download: Define how many connections
the Download Manager opens at the same
time. (Choose fewer connections for
slower Internet connection, more for DSL
or broadband.) Also, check Automatically
purge queue to have previously downloaded
items automatically removed from the
queue.

THE SORTER
The Sorter is a multi-purpose popup that
allows you to quickly add content to your
databases, even when DEVONthink isn't the
active application. Depending on the option
you choose in Preferences > Sorter, it will
appear in the menubar at the top of your
screen or docked to the left or right side
of your screen. When shown as a menu bar

The Follow Links options defines how far

icon, you can choose to display it as the word

DEVONthink follows links on the downloaded

DEVONthink or a space-saving nautilus icon.

HTML pages. This feature allows you to
control what gets downloaded--only the
actual pages or a complete web site.
DEVONthink supports the following options:

It supports several views, each providing
handy shortcuts to getting data into your
databases. Switch between these views by
clicking the icons at the top of the pane.

Off: Does not follow any links.

Below we cover the different views the

On Same Host: Follows links, but only as

Sorter provides for quickly capturing data.

long as they refer to the same web server/
web site. Files on other web servers will not
be downloaded.
In Same Directory: Follows links, but only
as long as they refer to items in the same

NAVIGATION
The Navigation view provides a convenient
list of the databases and groups in
DEVONthink.

directory as the downloaded HTML page.
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Tab: Switch the cursor focus between the
search field and databases list.
Command-Option: Hold these keys when
dragging Finder files or folders to index
them.
Command: Hold this key when dropping an
item to move it into the database, putting
the original in the system trash.
Up/Down Arrows: Navigate up and down
through the database listing.
Left/Right Arrows: Open and close groups
To add files in the Sorter, drag over the
docked tab or menu bar item. The Sorter will
spring open. then drop items into specific
groups to quickly import them. Also equipped

containing subgroups. Hold the ⌥ Option
key while pressing the right or left arrow to
fully expand or collapse all the subgroups,
respectively.

with a handy search field, you can search
for and isolate groups for more targeted

Note: The ⎋ Escape key can be used in all

importing. This view is composed of three

views to quickly close the Sorter.

sections:
CREATING FILES
Search Field: Use the search field to help
quickly locate specific groups. This uses

The remaining views are focused on creating

substring matching, so you can enter

files, whether that's a simple plain text file,

parts of words to find matches. The

a screen capture of an application's window,

view updates while you type for efficient

or some recorded video. Each of the following

searching.

views support the following options:

Favorites: Provides a convenient list of
the groups you've added to the Favorites
section of the global sidebar. Drag items
onto your favorites to import them.
Control-clicking a group or database gives
you the option to Reveal or Open the item.
You can also double-click an item to open it
in a new window.
Databases: Provides a list of open
databases and access to their groups.
Behaves in the same way items in your

Add: Saves the file in the specified format
in the chosen location. You can also press
⌘S to save the current content.
Reset: Displayed as a

backward pointing

circular arrow, click it to clear the view to
its default settings.
Control-Tab/Shift-Control-Tab: Move
the cursor between fields, e.g., between
the body and URL. Hold Shift to cycle
backwards through the fields.

Favorites do.
Hotkeys: The Navigation view supports these
hotkeys:
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TAKE NOTE
The Take Note view is for those times when
you just need to quickly write a note but don't
want to go back into your databases to create
a new file.

Format: Choose the format of the saved
note. Choose from: plain text, rich text,
formatted note, and Markdown.
Location: Choose the location to save your
file from the dropdown list. The location of
the last saved file will be preserved for the
next note you create.
Add: Saves the file in the specified format
in the chosen location.
Take Note Panel: The Take Note panel is
displayed when the Sorter is set to None
in Preferences > Sorter. It has the same
functions as the view in the Sorter and also
will be pinned over any open windows.

VOICE NOTE
Use this view to record a voice note directly
Allowing you to write notes in several

into your database. This creates an AIFF-C

formats, the text will be displayed in the font

file in the location you choose. With simple

defined in Preferences > Editing. Make your

controls, it's easy to record impromptu audio.

note taking a little faster by defining a hotkey
with the Preferences > Sorter > Take Note
Hotkey. This view supports these attributes:
Name: The title of your file. If left as
Automatic DEVONthink will attempt to
create a title from the first sentence of the
body.
Body: Enter your note text here.
URL: If there is a URL you'd like to associate
with the file, perhaps a link back to a
source, enter it here.

This view has a few simple sections:

Info: Add metadata about the file here,

Audio Levels and Timer: At the top is a

including: read status, locked state, flagged

sound meter to help visualize your audio

state, rating, or color labels.

level as you record. The elapsed time

Tags: Enter tags for the file. Tag
suggestions will be made from the tags of
all open databases.
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is shown as it records, convenient for
projects like rehearsing a presentation.
Begin/Stop Recording: Press the red
circular button to begin recording. Press
the black square button to end recording.
When you've stopped recording, you will be
shown:
Playback and Volume: Playback your audio
to ensure it's good before you save it. Press
the Reset button to clear the audio and
record again.
Name: Enter a name for the audio file. If no
name is provided, a date and timestamped
name will be automatically given.

Like the audio note, this is presented in very
simple controls:

Info: Add metadata about the file here,
including: read status, locked state, flagged

Begin/Stop Recording: Press the red

state, rating, or color labels.

circular button to begin recording. Press

Tags: Enter tags for the file. Tag

the black square button to end recording.

suggestions will be made from the tags of

Source: Choose the video and audio

all open databases.

source in the small downward facing caret

Location: Choose the location to save your

next to the record button. Any attached

file from the dropdown list.

compatible audio-visual devices should be
available here.

VIDEO NOTE
Use this view to capture a video from your
Mac's built-in camera. Videos are saved as
MP4 files for convenient compatibility across
platforms and devices.

When you've stopped recording, you will be
shown:
Name: Enter a name for the video file. If no
name is provided, a date and timestamped
name will be automatically given.
Playback and Volume: Playback your video
before you save it. Or press the Reset
button to clear the video and record again.
Trim: Shown as scissors, click this to access
simple editing tools. You can drag the ends
of the yellow frame to change the start
and end of the video. Click and drag inside
the frame and a red line will appear. This
displays the time above the line.
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Info: Add metadata about the file here,

window being captured will be highlighted

including: read status, locked state, flagged

in blue.

state, rating, or color labels.

Selection: Capture a specified area by

Tags: Enter tags for the file. Tag

dragging a bounding box around the

suggestions will be made from the tags of

desired area. To reposition the area, hold

all open databases.

the space bar. To stop the capture action,

Location: Choose the location to save your

press the ⎋ Escape key.

file from the dropdown list.
As with other views, name and information
SCREEN CAPTURE

options will appear after the screen is
captured.

Screen captures are a common way to
quickly gather information about things on
our computers. While the Apple provided
mechanisms still work, the Screen Capture
view allows you to quickly snap a screen
shot, add some metadata, e.g., tags or labels,
then direct it to a specific location in your
databases. The captures will be saved as
JPEG files.

Name: Enter a name for the screen
capture. If no name is provided, a date and
timestamped name will be automatically
given.
Info: Add metadata about the file here,
including: read status, locked state, flagged
state, rating, or color labels.
Tags: Enter tags for the file. Tag
suggestions will be made from the tags of
all open databases.
Location: Choose the location to save your
file from the dropdown list.

WEB CLIP
Use the Web Clip view to quickly clip the
current web page, a URL from your clipboard,
or enter a URL manually.

This view has one simple section with three
options:
Screen: Capture your entire screen.
Window: Capture a specific window by
hovering over a window a clicking once. The
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PREFERENCES
The Preferences window, opened using
DEVONthink > Preferences, contains all
available options, which you can modify to
adapt DEVONthink to your personal needs.
Because the preferences are so important,
we have created a separate chapter for them.

DATABASE PROPERTIES
The Database Properties popup displays
Default Browser: Displaying the icon of

preferences for a specific database. Select

your default browser, click this to capture

a database and open the properties popup

the current page. This shows the same

using File > Database Properties

options as the Clip to DEVONthink browser
extension.
Clipboard URL: If you have copied a URL,
click this option to detect and capture it.
Manual: Click this to manually enter a URL
to capture.
After clipping, you can add other information
to the item:
Name: Enter a name for the screen
capture. If no name is provided, a date and
timestamped name will be automatically
given.
Info: Add metadata about the file here,
including: read status, locked state, flagged
state, rating, or color labels.
Tags: Enter tags for the file. Tag
suggestions will be made from the tags of
all open databases.

GENERAL

Location: Choose the location to save your

Location: Shows the location of the database

file from the dropdown list.

in your filesystem. Note you can double-click
any part of the database location to reveal it
in the Finder.
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Create Spotlight Index: Check to make this

Exclude Groups from Tagging: Excludes all

database available to Spotlight. Checking this

groups in this database from being used as

option lets DEVONthink create a folder in ~/

tags. Ordinary tags can always be added to

Library/Cache/Metadata that Spotlight

items using the Tag bar.

uses for accessing the documents in the
database. If you are having issues finding
DEVONthink documents in a Spotlight

Inherit Tags of Groups: Applies tags added to
a group also to the group's children.

search, you can click the Rebuild button to

Case Insensitive Tagging: Check this option

recreate this folder from scratch.

to disallow tags with different capitalization.

OPTIONS

Protection: To add a layer of protection
when syncing your databases, you can add

Name: Enter a name for your database here.

a username and password to the database.

It will appear in the title bar of every main

Anyone trying to import the database from

window of this database.

a sync location will need to provide these

A database has two names: the displayed
name, set here in the properties, and the
filename, the name of the database file in
the Finder. When you create a database, the
names will be the same. If you change the

credentials. Click on the padlock button to
unlock the entry fields, enter a user name
and password, and then click on the padlock
button again to lock your changes and hide
the password.

displayed name in the database's properties,

Note: For a locally secured database, create

the name of the database file will also

an encrypted database via File > New

change. However, you can close the database

Encrypted Database.

and change the filename in the Finder,
should you choose to. This can be used in

STATISTICS

any situation, including office, health care,
and litigation environments where clients
or cases have a unique number associated
with them. A database could have a filename
of 10459.dtBase2 but the displayed name
of Company A in DEVONthink. When you

This section displays some basic statistics
about the contents of the database, e.g.,
counts of some different file types, total size
of the contents, and number of words in the
index of the database.

close the database, the filename will be
shown in the Recent Databases section of
the Navigate sidebar.

POPOVERS
Popovers are a specialized panel that

Comments: Add comments about this

appears on command and disappears

database. These comments are only used in

after interacting with it. These are usually

DEVONthink, i.e., not exported to the Finder.

used for quickly viewing information about
a selected item but can also be used in
some other ways. For example, Database
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Properties is an information popover you may
already be familiar with. Here are a few more
DEVONthink offers, starting with information
popovers and followed by utility popovers.

INFORMATION POPOVERS

Log: The Log popover displays any
information available in the Log window. This
allows you to quickly glance at any messages
without having to open a separate window.
Open this popover via the

toolbar button.

Note this button will only be enabled if there
are messages available to be viewed. You can
clear the log or press the Save button to save
the log, usually to send to our support team.

UTILITY POPOVERS
The utility popvers provide extra functions
for moving files, navigating databases, or
Info: The Info popover shows information

linking documents. Each popover has a search

about the currently selected item. It displays

field at the top for helping to narrow the

the contents of the Info, Annotations &

results. You can use an abbreviated search

Reminders, and Properties inspectors. Open

syntax matching the beginning of words to

this popover via Tools > Get Info, ⇧⌘I, or

help speed the process. For example, if you

pressing the

are looking for a group named "Household

toolbar button.

Expenses" you could type hou exp to find
matches. After tsearching, double-clicking
a result will move the file to the selected
location. For keyboard navigation, you can
press ⇥ Tab to put the focus in the results list
then navigate with the arrow keys. Pressing ↩
will accept the choice and close the popover
automatically. There is also a plus (+) button
for creating a new group in the current
location when needed.
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Move to: This popover allows you to organize
selected files quickly. Open this popover via

Go to Document: This popover allows you to

Data > Move To or pressing ⌃⌘M.

quickly navigate to a specific file. Open this

The default behavior of this popover is
moving files. However, the behavior can be
changed using command keys. Hold the ⌥
key to duplicate files to a selected location.
Hold ⌘-⌥ to replicate the files to a selected
location within the same database. Note the
text in the popver will change to reflect the
kind of operation will take place.

popover via Go > To Document or ⌃⌘O. Note
this popover does not support abbreviated
syntax, i.e., matching substrings or noncontiguous words, as the fuzzy matching
would lead to far too many results. Given
a filename of DEVONthink sync timing
tests.md, timing tests would match;
DEVONthink timing would not.

Insert Link: Used when editing text-based
Go to Group: This popover allows you to

documents, e.g., rich text, this popover allows

quickly jump to another location. Open this

you to search for and quickly insert a link to

popover via Go > To Group or ⌃⌘G. One

that file in the current document. The type

special property of this popover is the ability

of link inserted will be appropriate to the

to act as a floating pane. Open the popover

current document type, e.g., a Markdown

then click and drag it away from the toolbar.

document will have a properly formatted

It will remain open as a searchable floating

Markdown link. Open this popover via Edit

pane you can use for quick navigation. You

> Insert > Item Link or the Insert > Item Link

can also drag and drop files to it, similar to

command in the contextual menu while

the Navigation view of the Sorter.

editing a compatible document. There is
no shortcut for this command but you can
assign one yourself. See also p. 209ff
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WEB SHARING

SIDEBAR

DEVONthink comes with a built-in server

A condensed version of the Navigate sidebar

for broadcasting your databases on a

found in DEVONthink's main windows, this

network. While the operation is covered

provides access to the contents of any

in the In & Out chapter, here we cover the

shared databases. Some basic contextual

interface shown when accessing shared

menu items, e.g., New Group, New Feed,

databases in a browser window. Also note the

Rename, and Move to Trash, are available

preferences for setting up shared databases,

when Control-clicking in the sidebar.

including setting up users and per-database
permissions are covered in the Preferences >
Server section of the Preferences chapter.

Move files by dragging from the item list over
a group in the sidebar to file them in a new
location. Holding the ⌘ Command key allows
you to copy the file instead of move it.
If you hover over a section in the sidebar, you
can hide the Globals or Shared Databases
section. Also, you'll notice this interface
has been built in a responsive manner. This
causes the sidebar to disappear when the
browser window becomes to narrow for it be
effective. You can still use toolbar buttons to
toggle the visibility, as needed.

The layout of the web sharing should
immediately be familiar to users of
DEVONthink. While not as full featured as
the native application, it behaves in ways
similar to DEVONthink's main window. Here
we will give you an overview of the parts of
this interface.

ITEM LIST
The item list, like it's DEVONthink
counterpart (See also p. 75ff ), shows items
in the current location. Items can be selected
and reorganized by drag-and-drop, to the
sidebar or groups in the same location. Above
the item list is the path bath with active

Note: The permissions given by the

links to parent locations. Click on them to

administrator of the shared databases

quickly jump back to a parent location. To

determine database visibility as well as

navigate back and forth through locations

what actions you can take. Due to this,

you've visited, use the

some actions, e.g., creating new documents

the path bar.

or downloading documents, may not be
available. If you do not have permissions
to modify the database you're browsing,
the cursor will change to show the option is

and

buttons in

Again, taking its example from DEVONthink's
main window, Control-click items in the
item list to show these commands in the
contextual menu:

disallowed.
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New: The submenu allows you to create

URL, it will be active and displayed here. The

new items: plain text, formatted note,

bar also allows you to move back and forth

Markdown, Bookmark, RSS feed, and

through previously viewed files via the

groups.

and

buttons.

Get Info: Shows the Inspector pane for the
selected file.
Label: Apply or remove a color label to a
selected file.
Mark: Toggle the Flagged, Unread, or
Locked state of a selected file.
Rating: Adjust the rating for a selected file.
Upload Document: Use this to upload a new

Of special note are the behavior of formatted
notes. They are displayed with a handy
toolbar providing some editing options, like
adding bold or italic type. You can also select
text and create a hyperlink with it. Lastly,
you can choose an image to insert into the
document.

document to the database.

For the Markdown fans, you will see the

Download Document: Download the

same navigation bar options, showing Edit,

currently selected file(s).

Preview, and Side-by-Side modes.

Move to Trash: Move the selected file(s) to
the database's Trash.

Note: While it is a force of habit — and in
general, a good one to be in — you do not

While you can't reorder the items manually,

need to press ⌘S after editing a file. The

the item list can be sorted by clicking on the

changes are saved automatically.

column headers. Click the header again to
toggle between an ascending or descending

INSPECTORS

sort. Control-click the headers to enable and
disable individual headers.

Info: A simplified view of the Info Inspector
pane found in a main window. Shown by

VIEW/EDIT PANE

clicking the right-most toolbar button or
choosing the Get Info command from the

When an item is selected in the item list, a

Action button, this shows basic metadata

preview of any compatible file will be shown

about the item selected in the item listing.

here. Many non-proprietary text-based

If you have permissions to make changes to

formats commonly can be displayed. Plain

the current database, it is possible to change

and rich text, Markdown, JPEG or PNG files,

some of the metadata, like ratings or labels.

PDF, etc. are easily searchable and viewable.
There is also support for editing plain and

See Also: The second view of the inspector

rich text, formatted notes, and Markdown

shows the See Also pane. This gives you some

documents directly in this pane. Just click in

suggestions about other documents that may

the preview and begin editing.

be related to to the currently selected item.
Clicking on an item in the results will display

Navigation bar: The navigation bar above the

that document in the view/edit pane.

pane varies what it displays, based on the
type of file it's displaying. If an item has a

DEVONthink 3.6 Documentation, page 107

TOOLBAR
There are a handful of toolbar tools in the
web sharing interface. Note a few items will
be discussed separately.

Download Document: Downloads the
selected items in the item list and
downloads them to the downloads location
for the browser you're using. For some
formats, a ZIP file may be created and

Show/Hide Sidebar: Toggles the visibility of

downloaded.

the Globals sidebar.

Language: Switch the interface language

Preview: Toggle between standard and

between English, French, and German.

widescreen view, with the preview on the

Search: Search for files in the open

bottom or right, respectively.

databases by entering search terms.

Action: Displayed with a gear icon, this

Search prefixes can be used and are

shows the same options as the contextual

covered in more detail here: See also p. 78ff

menu in the item list.

Show/Hide Inspectors: Toggle the

Add: The submenu allows you to create

Inspectors panes.

new items: plain text, formatted note,
Markdown, Bookmark, RSS feed, and

SUPPORT ASSISTANT

groups.
Move to Trash: Put the selected item in the
database's trash.
Refresh: Manually refreshes the current
item list.

The integrated Support Assistant combines a
welcome screen with a first launch assistant,
tips, installable extras, and a support page
that guides you through the available support
options.
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WELCOME

GET SUPPORT

This screen welcomes you when you start

The Support screen guides you through the

DEVONthink for the very first time. It offers:

three common steps for troubleshooting

The option to subscribe the free
DEVONtechnologies newsletter, as well as a
number of welcome tips
The tip of the day
The extra of the day
Click the links at the bottom of the window
to access the other Support Assistant
sections. You can also check or uncheck the
Show this window when DEVONthink opens

DEVONthink. In addition, you can update
your details in DEVONtechnologies' customer
database, or buy an upgrade or a second
license.

INSTALL EXTRAS
On the Extras screen, DEVONthink lists all
available extras that you can download and
install from DEVONtechnologies' server:

checkbox at the bottom of the window to set

Scripts

whether to show the Support Assistant each

Templates

time DEVONthink is launched.

Smart Rules

FIRST LAUNCH ASSISTANT

Browse the list of extras and install them
with the Install button. The last line of the

The first launch assistant opens

description shows where in the Scripts or

automatically the very first time you open

Templates menu the extra will show up after

DEVONthink, and guides you through the

installation. Remove installed extras with the

first steps of using the application: creating

Remove button.

a new database, installing the add-ons, and
adjusting the preferences.
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The extras are updated live from

Both tips and tutorials are updated live from

DEVONtechnologies' server so it's a good

DEVONtechnologies' server so it's a good idea

idea to check back from time to time. The

to check back on a regular basis. The latest

latest extra is also always mentioned on the

tip or tutorial is also always mentioned on the

welcome screen. If you check the Install &

welcome screen.

update extras automatically checkbox at the
bottom of the window, any updates to scripts

LOG

or templates you've downloaded here will be
updated as needed.

The Log panel displays messages and
warnings when importing files and folders,

Note: If one of these categories does not

results of performing maintenance routines,

show up in your copy of DEVONthink, there

and AppleScript errors from script actions

might be no extras of this type currently

in smart rules or reminders. The panel shows

available.

the date of the message, any affected
files, and a little information about what

TIPS AND TUTORIALS
Here you can find the latest tips and
tutorials to help you squeeze the best out
of DEVONthink. Tutorials can be slideshows
describing basic tasks in DEVONthink or

happened. If you feel you are having sync
issues, this panel is the first place to look.
Also, when doing any database or sync
location maintenance, this is where the
results are shown.

screencasts.
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ACTIVITY
The Activity panel shows a list of currently
running background processes, e.g.,
converting scans to searchable PDFs,
refreshing news feeds, downloading PDF
documents and web archives via our browser
You can save the list to a text file with the
Save button, and clear the log with the
Clear button. To sort the log, click a column
title to sort on that column, changing from

extension, or sync activity. You can manually
open this pane via Window > Activity. You
can manually stop them to free computer
resources or for other reasons.

ascending to descending each time you click
it. If you Control-click individual log entries
you will be shown options to reveal the
item in its location or move it to the trash.
Alternatively, double-click the entry to reveal

There is also an Activity pane at the bottom

the file.

of the Navigate sidebar. Providing a less
intrusive experience, this pane will appear

Uncheck Show log automatically to prevent

and disappear quietly on its own.

the log popping up automatically. You can
open the Log panel at any time using Window

Note: The Activity window is only used if

> Log. For important notifications, the log

it was opened by the user or if there is no

is always shown automatically, ignoring this

main window to show an Activity pane.

setting.
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INSPECTORS
INFO PANE

IN THIS CHAPTER
Info pane

112

Annotations & Reminders

115

Content

118

Document

119

Concordance

121

See Also & Classify

123

Search

125

the Inspector panes displayed on the right
side of a main window provide an incredible
amount of information and functionality
when working with files in DEVONthink.
Covering a range of options, from basic
metadata to setting reminders to indocument search and replace functions. Each
of the Inspectors is individually covered in
this chapter.
The Info pane, just like its counterpart in the
Finder, displays additional information about
a selected document or group, from icon and
name to comments and other metadata.
Open the Info pane by selecting Tools >
Inspector > Info > ….
Note: When you have multiple items
selected, some editable attributes can be
modified. For example, tags can be applied
to multiple files at once. However, if you
add tags to the same files separately, only
tags common to them will be shown if you
select them together again.
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GENERIC
The Generic view shows additional basic
information about a selected document or
group, similar to what is shown in the Get
Info window in the Finder. Additionally, it
shows some other attributes like ratings,
color labels, and geolocation data. Here are
the attributes shown:

This is a script that is triggered when you
select the item in the database. Click the
down arrow and choose: Select to choose
a triggered script to attach, or Remove to
remove the script from the item. See also
p. 188ff
Added: Displays the date an item was
added to the database. This is not an
editable attribute.

Icon and Name: Displays the name of the

Created/Modified: Displays the date an

selected item. To change the icon of the

item was created or modified. These are

item, select it and paste any image you

editable attributes. Click the calendar icon

want over it. To change the name of the

to choose a date and time. You can also

item, use the Name field below.

select individual parts of the date or time

Name: Displays the name of the selected

and type or modify them with the up and

item. This is an editable attribute.

down arrows. When typing, press the ⇥Tab

Aliases: Displays any aliases for the

key to commit the change.

selected item. Enter one or more words

Size: Displays the size of the item. For

here, separated by semicolons, as

groups and news feeds, this field shows the

alternative targets for Wiki links. Generally,

size of all contained items.

Wiki links refer to the name of contents,

Kind: Displays the kind of the selected

and aliases make this system even more

item. For documents, the file type will be

flexible.

shown, e.g., Markdown.

URL: Displays a URL associated with the

Location: Displays the location of the item

selected item. This is an editable attribute.

in the database. This is an active item;

While it is typically used for web addresses,

hovering over items will display their full

it also may contain other types; e.g., file

names and clicking them will navigate to

URLs, URL with custom schemes, etc. Click

the clicked group.

the down arrow and choose: Launch to

Instances: Displays how many duplicates

open the URL or Copy to copy the URL to

or replicants of the selected item are in

the clipboard.

the database. Click to show a pop-up menu

Path: Displays the item's file's path in the

listing all instances and duplicates and their

Finder. This is not an editable attribute.

enclosing groups. Select any item to reveal

Click the down arrow and choose: Launch

it.

to open the file in the system default

Format: For news feeds you can set the

application; Show in Finder to open a

default format in which new articles are

Finder window with the file selected, and

saved.

Copy to copy the file path to the clipboard.

Color: Allows you to set a color for a tag.

Attached Script: Displays the name of an

Only available when a tag is selected. Click

AppleScript script attached to the object.
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the title Color for options to clear or copy

Tagging: Used with group tags and Tag

the color.

groups, this inhibits the Tag from being

Geolocation: Displays geolocation data

applied to any item.

based on the creation origin of the file;

Wiki Linking: When enabled on any item,

i.e., the geographic location when the file

it will not be detected by automatic

was originally created. This is an editable

WikiLinking, neither by name or alias.

attribute and can be changed if you'd like
the location to be relative to something

CUSTOM

else, e.g., the site of a historic event.
Marks: Displays these attributes for the
selected item: Flagged, Read, Locked,
Rating, and Label.
Tags: Displays the tags applied to the
current item. Click the + button to add a
new tag. Tags will be suggested from the
existing tags in the current database. If the
item is selected from the Inboxes in the
sidebar, suggestions will come from the
tags of all open databases. Click an added
tag to reveal the Tag group, or remove it
from the selected item.

The Custom view displays custom metadata
fields and their values. These custom fields
are defined by you in Preferences > Data. All
available fields you have defined are shown in
this pane. Note some fields may be specified

Exclude From…: These checkboxes allow

as data types that include some extra actions

you to exclude an item from being used in

in this view. For example, if you create a

various ways. For example, you can exclude

custom parameter with an Item Link data

temporary groups from classification to

type, you will have an option to reveal the file.

increase the accuracy of the built-in artificial
intelligence. You can exclude an item from
these operations:

Item Link: Click the down arrow and
choose: Reveal to reveal the item in the
database.

Classification: When enabled on a group,

Single-line Text: Type in a value or click the

this will keep DEVONthink from suggesting

dropdown menu to choose from a list you

or using the group as a possible filing

defined in the preferences .

location.

URL: Click the down arrow and choose:

See Also: When enabled on any file,

Launch to open the URL or Copy to copy

DEVONthink will not include it as an item

the URL to the clipboard.

potentially related to the current file.
Search: When enabled on any item, it will
no longer appear in toolbar search results,
smart groups, or smart rules.
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ANNOTATIONS & REMINDERS

Once: Only trigger an alarm once.
Hourly: Set an hourly reminder, triggering
at the minutes of time you set, e.g, 10:15,
11:15, etc. Set an interval for how many
hours should elapse before the next
reminder, e.g., 4 for every four hours.
Daily: Set a daily reminder, triggering at
the hour and minutes you set, e.g., daily at
9:35 AM. Set an interval for how many days
should elapse before the next reminder,
e.g., 2 for every other day.
Weekly: Set a weekly reminder, triggering
at the hour and minutes you set. Choose
a day of the week the reminder should
trigger on. Set an interval for how many
weeks should elapse before the next
reminder, e.g., 3 for every third week.
Monthly: Set a monthly reminder,

This pane contains Reminders, Finder
Comments and information about
Annotations. It can be shown Tools >
Inspectors > Annotations & Reminders.

triggering at the hour and minutes you set,
e.g., daily at 9:35 AM. Set an interval for
how many months should elapse before
the next reminder, e.g., 1 for every month.
Choose Each and set which days of the

REMINDERS

month you want a reminder, e.g., the 1st
and 15th of the month. Alternately, choose

While there are many reminder applications,

On the … to choose a regular interval like

including Apple's own Reminders, sometimes

the second Thursday of the month.

you just want to set a quick reminder for an

Yearly: Set a yearly reminder, triggering

item, or multiple items, in DEVONthink. The

at the hour and minutes you set, e.g.,

Reminders section allows you set a reminder,

daily at 9:35 AM. Set an interval for how

even a recurring one, as well as an optional

many years should elapse before the next

alarm.

reminder, e.g., 1 for every year. Choose

After choosing a schedule, set a date and
time for the reminder or to begin a recurring
reminder. For recurring alarms, the data or
time you set will be the beginning of the

which months you want a reminder. Also,
choose On the … to choose a regular
interval like the last day of those chosen
month(s).

alarms. Reminders can be set to:
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Alarm: Reminders are most useful when

Add to Reading List: Add the file to

you have an alarm to, well, remind you of

DEVONthink's Reading List.

something. There are several alarms available

Open Externally: Open the document in the

for a reminder:

system default application.

No Alarm: —
Bounce Dock Icon: Bounce the icon in the
dock. This will only occur if DEVONthink is
not the active application.
Display Notification: Displays a notification
using the Notification Center, appearing
at the upper right of your screen. The
message shown can be a combination of
static text and placeholder text. It defaults
to the Name placeholder. Control-click
and choose Insert Placeholder to add
additional placeholders. Note System
Preferences > Notifications > DEVONthink
> must be enabled for this alarm to
display. Notification are also only shown
when DEVONthink is not the frontmost
application.
Display Alert: Displays an alert dialog when

Launch URL: Opens the URL associated
with the document, if present.
Execute External Script: Run a selected
script. External scripts are stored in
~/Library/Application Scripts/
com.devon-technologies.think3/
Reminders. Add your own scripts to this
location to make them available for use
with reminders.
Execute Embedded Script: Run an ad-hoc
script written for the current reminder.
Press the … button to display a popup
prepopulated with a core script. Edit this
and press the compile button at the lower
left. Embedded scripts are only available
to the reminder they are created in. If you
want to use the same script with other
reminders, use an external script instead.

DEVONthink is or becomes the active

Note: When setting a reminder on multiple

application. If it's not frontmost, the dock

items, alarms are delivered individually. For

icon will bounce until you switch to it.

example, an alert notification will show for

Like Display Notification, this contains

each file, even if they were set for the same

static and placeholder text, and defaults to

time.

Name.
Speak Text: Using the Mac's speech
synthesis, this alarm will speak the
specified static and placeholder text.
Play Sound: Choose one of the system
alert sounds found in System Preferences >

If you are interested in the use of scripts in
alarms, please refer to the Reminder Script
chapter of the Automation chapter.

FINDER COMMENTS

Sound > Sound Effects.

Similar to the Comments in the Get Info

Send Mail: Enter email addresses to which

pane in the Finder, the Finder Comments

to send the matching items. This can be

field can be used to store miscellaneous bits

a comma-delimited list of addresses,

of information about the selected objects.

names, or enter the name of a group you've
defined in your contacts.
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When an annotation file is made, the original

file. If no annotation file exists, one will be

item link of the document will be stored here

created with this command.

as the Original URL.

Insert Quote: This inserts both the

Note: These comments will not appear in
the files in the Finder unless the files are
indexed or exported from the database.

ANNOTATIONS
This pane displays or allow you to create
annotation files for a selected document.
Annotation files are separate files where you
can store notes about a specific document.
These files can link back to the original file for
quick access. Commonly used with PDF files,

selected text and a backlink to the page
or paragraph in the original file. If no
annotation file exists, one will be created
with this command. This option is only
supported by PDF, plain text, and rich text
documents.
If an annotation file is detected by
DEVONthink or you've just created one,
an editable preview of the file will appear
here. Clicking the down arrow reveals these
options:

they can actually be used for making notes

Open: Open the annotation file.

with any document in your database.

Reveal: Reveal the annotation file in its

Note: Annotation files are created in an
Annotations group at the root of the
database. However, you can move the file
to another location, if desired.

current location.
Insert Back Link: Insert a link back to
the original document in the current
annotation file. With audio and video
files, the back link will include the current

If an annotation file doesn't exist, you can

playback time. With multi-page PDFs, the

make one with commands from the down

back link will include the current page .

arrow in this section.

Export: Exports the current annotation
file to the Finder in one of these formats:

New from Template: Opens a submenu
containing three options: Create an
Annotation file from the default template,
choose a custom template added to
DEVONthink's internal Annotations folder,

PDF, rich text, plain text, or Word (.doc)
formats.
Remove: Moves the annotation file to
the database's Trash and removes the
reference from the original document.

or open the Annotations folder to access
any custom templates you've added.

Creating an Annotation File: DEVONthink has

New from Clipboard: Choose this option

a built-in default annotation file in rich text

to create an annotation with content from

format, suitable for general use. However, you

the clipboard.

can create your own custom template in plain

Insert Back Link: This inserts a back link

text, rich text, or Markdown formats. These

to the original file into a new annotation

files can be created externally and added
to ~/Library/Application Support/
DEVONthink 3/Annotations.noindex
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or created in DEVONthink and exported

CONTENT

via File > Export > as Template to the
Annotations.noindex folder.
To create backlinks to the original file, there
are two placeholders for use in the body of
your template:
%documentName%: Resolves to the name
of the original document.
%documentLink%: Resolves to the item
link of the original document.
Rich Text: To create the backlink in a rich
text template, use the %documentLink%
placeholder and the document name will be
added as the link's text.
Markdown: To create the backlink in
a Markdown template, use the form:
[%documentName%](%documentLink%).

Navigating PDF documents can sometimes

Plain Text: Since plain text files don't support

through endless pages of documents.

live links, you can use WikiLinks to create a

The Content Inspector shows two views,

backlink. For example, if you are using the

similar to what you see in Apple's Preview

Square Brackets WikiLink syntax, you could

application: Table of Contents and

use [[%documentName%]] in the body of the

Thumbnails.

be difficult when you are just scrolling

plain text.
TABLE OF CONTENTS
The Table of Contents view will display the
outline of a PDF document, provided that
PDF contains one. Click on the disclosure
triangle to show or hide sections within
chapters. Click on any section heading to
jump directly to the beginning of it.
There are two contextual menu items in the
Table of Contents view: Copy Page Link for
use with PDF documents, and Copy Section
Link for use with Markdown documents.
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THUMBNAILS
The Thumbnails view shows a list of
thumbnails, one for each page in the
document. This allows for a more visual
approach to moving through your document.
By default, the thumbnails are shown in a
single column but they can be displayed in
multiple rows if the sidebar is expanded. This
view allows for actions like these:
Jump to or select any page by clicking on it.

removed from the current document. This
item is unavailable when the first page of
the document is selected. Also, note this
action cannot be undone.
Insert Blank Page: Insert a new blank page.
Delete Selected Page(s): Delete the
selected page(s).
Rotate Left/Right: Rotate the selected
pages left or right.
Select/Deselect All: Select or deselect all
pages in the document.

Extend a range of selected pages by holding
the ⇧Shift key to select consecutive pages.
Hold the ⌃ Control key to select non-

DOCUMENT

consecutive pages.
To quickly remove unwanted pages, press
the ⌫ Backspace key.
If you want to reorder some pages, select
the page(s) to move and drag and drop
them within the thumbnails. A blue line
will appear at the place the pages will be
inserted. This will also work if you drag
thumbnails from one PDF to another.
Drag selected pages to another location in
your database and DEVONthink will create
a new PDF containing only those pages.
You also have several options available in the
contextual menu when you Control-click in
the Thumbnails view:
Cut/Copy: Cut or copy the selected
page(s) to be pasted into another PDF.
Copy Page Link: Copies a URL to the
clipboard pointing directly to the current
page of the document.
Reverse Page Order: Reverse the page
order of the document.
Split Document: Splits the document

The Document inspector provides specific
information about the current document.
This information is presented in three
specialized views: a view of RTF and PDF
metadata, a list of annotations in a PDF,
and a list of links found in certain document
types.

at the current page. A new document is
created from the preceding pages and
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PROPERTIES

ANNOTATIONS

The Document Properties section gives you
access to all metadata stored for selected
RTF and PDF documents. This metadata can
include some of the following:
Author
Company
Copyright
Title
Subject
Keywords
Comments
Organization
Depending on the document type, you may
be able to edit or view these properties. More
fields may be available depending on the
document type.
As PDF files are often used in DEVONthink,
There are two parameters supporting extra

annotating these documents is

actions:

commonplace. The Annotations view displays

Click the Title button and select Copy, or
select Set Name As to quickly change the
document's name.
Click Keywords and choose Convert to Tags
to apply the keywords as DEVONthink tags.

a listing of the annotations in the current
document. Each annotation is listed with
the following metadata: page number,
type, content or author, and the date
the annotation was made. In the case of
highlights, text, or note annotations, the
content will be displayed. With graphic
annotations, e.g., rectangle or ovals, the
author will be displayed. The list can be
sorted by clicking the appropriate header.
Select an item in the list to switch to the
proper page. The annotation on the page will
be selected. This makes it easy to navigate
via the document's annotations.
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At the bottom of the view is a Details

Open: Opens the link in an external

section. For Note annotations, this will show

application.

the text of the annotation. Details can be

Open in Tabs: Opens the link in a new tab,

added to other annotation types as well, but

when possible.

only supports plain text entries.

Copy: Copies the URL to the clipboard

Opening the contextual menu in the
Annotations list offers the following options:
Copy: Copies the metadata and any text in
the Details to the clipboard as plain text.
Copy Page Link: Copies a URL to the
clipboard pointing directly to the current
page of the document.

Delete: Deletes the link and the text.
Select/Deselect All: Quickly select or
deselect the items in the list.
In the Incoming Links section, the contextual
menu has an extra command: Copy Name.
Use this to copy the name of a linked file and
paste it into another document as a WikiLink.

Delete: Delete the current annotation.
Select/Deselect All: Quickly select or

CONCORDANCE

deselect the items in the list.

The Concordance pane, opened in the Tools
> Inspectors menu, gives you a tool for

LINKS
For the selected document, DEVONthink will
attempt to determine if it contains links.
These may be web URLs, file URLs, item links,
and even DEVONthink's WikiLinks. (You may
be surprised by the number of links in many
documents.) The top section of the Links
view displays a list of any outgoing links, i.e.,
links to other files, websites, etc. The bottom
Incoming Links view shows incoming links, i.e.,
links in other files to the current document.
Select a link in the list to show it in the view/
edit pane. Double-click a link to open it in a

analyzing the textual contents of documents.
When the inspector is open, selecting
different items will show varying results.
If one or more documents is selected, the
results will be inclusive of the text in all of
them. If there is no selection, the results
will be based on the text of documents in
the current location, whether a group or a
database. This also applies to selecting items
matched in smart groups, both local and
global.
These results are presented in three distinct
views: List, Cloud, and Graph.

document window or an external application.
Option-click or Shift-Option-click a link to
open it in a new tab. Opening the contextual
menu in the Link list offers the following
options:
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Copy: Copies the values for the selected
word to the clipboard.
Exclude/Include Word: Use this to define
stop-words or to include them again.
Select/Deselect All: Quickly select or
deselect the items in the list.
Show/Hide Excluded Words: Select this to
show or hide any excluded terms. Excluded
terms will shown with a strikethrough.

CLOUD

LIST
The List view displays the concordance
results in a list, separated by these
parameters:
Word frequency
Number of groups with items containing a
specific word
Word length
Word weight (relevance, depends on the
contents of the database)
Alphabetical listing
Click the column headers to sort on a
given parameter. Select a word in the list
to highlight all occurrences in the current
document. Double-click a word to open a

The Cloud view present the concordance as
a word cloud. The size of the terms is relative
to the frequency in the selection or database.
Selecting terms highlights the occurrences in
the current document.

database-wide search for the term.
Opening the contextual menu in the results
offers these options:
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RELATED WORDS

SEE ALSO & CLASSIFY

Of special note is the Related Words graph
shown under the List and Cloud views. Select
a word in the list or cloud and it becomes
the central term in a graph of related words.
These are words found throughout your
database. Double-clicking a node initiates
a database-wide search. The contextual
menu provides options for copying the word's
information, as well as excluding the word.

GRAPH

The See Also & Classify inspector is the
main interface to DEVONthink's brain, our
built-in AI engine. This engine is analyzing
the contents and locations of all documents

The frequency graph shows a graph of the

in your database and making connections

word frequency over the rank number of the

between them. These connections can be

word (see above).

seen in this inspector pane.

Note: There are no contextual menu

This inspector will be shown when a

options in this view.

document is selected and you choose Tools
> Inspectors > See Also & Classify. When the
inspector opens, you will be presented with
two sections: Classify and See Also.

GROUPS
Based on analyzing the contents of the
current document, the AI cross-references
the contents and locations of other files
in the database. The results are shown in
the Groups section. This list offers a range
of suggested locations, displaying a heat-
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mapped score of its relevance and the

document and heat mapped score of the

location of the group. The highest ranked

potential relevance. Hovering over a result

suggestion is presented first. Obviously,

shows a tooltip displaying its full title and

you can choose any other them. If there's a

location.

group you'd like to use, double-clicking the
suggested group will file the document for
you. You can also click the Move to button,
press ⌃C, or drag and drop to file it in any of
the suggested groups. Lastly, if a suggested
group is in the same database as the selected
file, you can hold the ⌥ key and the Move to
button changes to a Replicate button.

Select a document in the results to display it
in the view/edit pane. For your convenience,
DEVONthink always lists the original
document near the top of the list. This way
you can select it to go quickly back to the
original document. Double-click a document
to open it in a document window. Drag a
document from the list to move it to another

Directly above the classify results is a

location. When dragging, you can create

search field. If there is another group you're

duplicates by holding the ⌥ Option key.

thinking of that hasn't been suggested, type

You can also create replicants by holding

part of the group name to filter the list of

⌘ Command and ⌥ Option and dragging to

suggestions. Then file into the location of

another location in the database.

your choice.
On a related note, in the Data menu, you will

CONTEXTUAL MENU
find two menu items: Move to … again and

The See Also and the Classify sections host

Classify to…. The first provides you the option

many of the same contextual menu items

to classify the current document in the group

as the item list. A list of these commands is

into which you classified. If you filed into

included in the contextual menu section of

a particular group via the Groups section,

the appendix.

this menu item would remember it and offer
that group as a place to classify the current
document. The second menu item offers
its top ranked suggestion for classifying the
current document, if you'd like to just follow
the AI's suggestions.

DOCUMENTS
Another benefit of the AI's content analysis is
the ability to offer suggestions of documents
that may be related to the current document.
These files are listed in the Documents
section of the inspector. Like the Groups
section, this list shows the location of the
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SEARCH

SEARCH AND REPLACE
The Search and Replace section offers these
simple intuitive controls:
Find: Enter the word(s) you'd like to search
for. Note this matches substrings be
default, so entering "word" would match
"words" and "wording" as well. Use spaces
before or after the word to treat it as a full
word.
Ignore Case: Ignores case-sensitivity when
searching.
Enable Wildcards and Operators: Allows
using wildcards and operators, e.g.,
DEVONthink NEAR sync. If this option
is enabled, the Edit > Find > Find Next/
Previous commands and next/previous
buttons in the inspector are available.

The Search inspector provides in-document

Previous/Next Arrows: Use these arrows

searching. Using the same familiar ⌘F hotkey

to cycle backward and forward through the

you use in most macOS application, you can

highlighted results.

not only search, but replace found words.

Replacement Text: Enter replacement text,

Additionally, DEVONthink provides a list

as desired. Note this field is only enabled

of the found words to help navigate the

when you have editable text in the current

results. The results also show the search hits

document; e.g., rich text or a Markdown

in context, either in a sentence or paragraph,

document in editing mode.

depending on the setting in See also p.

Replace: Replace the currently highlighted

154ff .

word and move to the next search hit in
the document.

Searches match substrings by default. This

All: Replace all occurrences of the found

means a search for "some" would also match

word.

"something" or "worrisome".

In Selection: If you make a selection in the

Something you may find useful is the live
updating when you select other files. If you

text, you can replace all occurrences of the
found word in that selection.

search for a word in the current document
and leave the Search inspector open,

SEARCH RESULTS

DEVONthink will automatically search newly

The results provide a convenient list of the

selected files.

found words. This includes the line number
of each hit and the number of occurrences
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found. It also includes part of the surrounding

a parameter pointing to the selected

text to help give some context to the found

paragraph for rich text files or the page for

words. Additionally, there a some contextual

PDF documents.

menu options available when you Control-

Add to Favorites: Adds the current

click in the results:

document to the Favorites.

Copy: Copies the paragraph fragment
selected. You can optionally drag and drop
this fragment into the database or another
compatible document.

Add to Reading List: Adds the current
document to the Reading List.
Select/Deselect All: Selects all or none of
the items, respectively.

Copy Paragraph/Page Link: Copies a link
to the current document, but appends
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MENUS
IN THIS CHAPTER
The Application Menu

127

The File Menu

129

The Edit Menu

133

The Data Menu

135

The Format menu

138

The Tools menu

140

The View menu

143

The Go menu

145

The Window menu

147

The Scripts menu

147

The Help menu

148

The Dock menu

149

ABOUT & CHECK FOR UPDATES
About DEVONthink: Shows information
about DEVONthink including the version

A complete listing of all the commands

number to whom the software is registered.

available in the menu bar of DEVONthink, the
Services menu, and the contextual menu of

Check for Updates: Checks if updates

the DEVONthink's Dock icon.

for DEVONthink are available. By
default, DEVONthink checks for updates

THE APPLICATION MENU

automatically, however you can change
the update settings in the Preferences >

The DEVONthink menu is a utility menu,

General. If an automatic update is pending

similar to those found in other Mac

choosing this command shows a window with

applications. It has commands that allow you

additional information about the update.

check the version via the splash screen or
check for application updates. You can install
our add-ons, access the preferences, access
the Services menu, empty your databases'
Trash, and quit the application.

Note: When checking for updates no
information is uploaded from your
computer to the DEVONtechnologies
server. DEVONthink only downloads a file
listing the most current versions to your
Mac. This option is not available if you have
purchased DEVONthink from the Mac App
Store. In this case, all updates are handled
by the App Store.
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ADD-ONS
This command allows you to install, or
reinstall, some of our extra support files and
scripts.

windows. Use it to save directly to the
inbox from any application. Note: The name
of the inbox is "Inbox" regardless of your
computer's language preferences.
ABBYY FineReader OCR: Installs the
ABBYY Finereader OCR resources for use
with images and PDFs with no text layer.
Apple Mail Plugin: A plugin for Apple Mail
that allows you to archive messages or
whole mailboxes directly from within
Mail. On Mac OS Mojave you'll have
to manually activate the plugin after
installation. In Apple Mail visit Preferences
> General > Manage Plug-ins and activate
DEVONthink's plugin.
Note: The Safari browser extension is now
installed by default, but you'll need to go

The following options are available.
Google Chrome Extension: Opens the
Chrome Web/Store page in Google
Chrome where you can install the browser
extension. You have to do this manually and
follow Google's rules.
Firefox Extension: Opens the Mozilla AddOns page in Firefox where you can install

into Safari's Preferences > Extensions
and enable it. Also while extensions for
browsers like Opera, Vivaldi, and Brave
are not explicitly available, it is possible to
install them from the Chrome Web Store,
while in those browsers.

PREFERENCES, TRASH, CACHE

the Firefox add-on (similar to the Safari

Preferences: Opens the application

extension). You have to do this manually

Preferences.

and follow Mozilla's rules.
PDF Services: Adds Save PDF to
DEVONthink to the PDF menu of print
dialogs. This allows you to print a PDF

Empty Trash: Moves the contents of all open
databases' trash to your computer's file
system trash.

directly to DEVONthink.

Empty Cache: Empties the web browser

Additional Scripts: Installs the mail rule

cache. This frees up space and makes sure

scripts for Apple Mail, Folder Action scripts

that all, when displaying a web page, all data

, and Menu extra scripts.

is freshly loaded instead of using a cached

Global Inbox in Save Dialogs: Inserts

copy.

DEVONthink's Global Inbox into the
Finder's sidebar and all "Save As" dialog

DEVONthink 3.6 Documentation, page 128

PURCHASE & LICENSES

NEW & OPEN

Purchase: Opens the DEVONthink product

New Database: Creates a new database in

page from where you can put the app

the selected location.

into your shopping cart. If this copy of
DEVONthink is already licensed, you will be
presented with upgrade choices.

New Encrypted Database: Creates an
AES-256 encrypted database file at a userspecified size. Technically this database

Enter License: Enter your purchased license

uses an encrypted disk image but will not

code here. It is best to use copy-and-paste

be visibly mounted in the Finder. Obviously,

for transferring the license code from the

when you enable Spotlight for the database

email message to the appropriate field.

the data that Spotlight needs to store will

Note: Enter License changes into License
and Purchase License into Purchase
License or Upgrade as soon as you have

not be encrypted. The anticipated size of the
database can be specified in megabytes (MB)
or gigabytes (GB).

entered a valid license code (and a paid

Open Database: Opens previously created

upgrade exists). Available options depend

databases. You can select multiple

on whether you have purchased your copy

databases.

from DEVONtechnologies or from the Mac
App Store.

SERVICES
The Services submenu gives your access
to special commands published by other
Mac applications such as TextEdit or
Safari, or by services extensions such as
our own WordService or CalcService. Also,
DEVONthink publishes its own services. See
also p. 129ff

Open Recent: Presents a list of recently used
databases, which gives you quick access to
your frequently used databases. Choose
Clear Menu to remove all items from the
menu.
New Window: Opens a new main window for
the selected database.

IMPORT & EXPORT
Import: The Import submenu contains various
options for importing data, e.g.,selected files,

THE FILE MENU

bookmark, contacts, and some data from
compatible applications. Some options will

The File menu contains commands creating
and deleting databases. There are options

import files into their own special groups at
the root of the database.

for adding or exporting files, as well
synchronizing them. Additionally, if you need

Files and Folders: Imports selected files

to do database maintenance, you will find

or folders. Files will be imported to the

those commands here.
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current location. Finder tags and Spotlight

Images (with OCR): Imports images and

comments will be imported.

applies optical character recognition (OCR)

Bookmarks: Imports bookmarks from

to create a searchable PDF. This makes all

DEVONagent Pro, Firefox, Google Chrome,

written text searchable and available to

or Safari as bookmarks. Bookmarks are

DEVONthink's AI functions. You can change

imported into a newly created group

the setting in Preferences > OCR. See also

bearing the name of the chosen browser.

p. 65ff

Only new bookmarks are imported if you

References from Bookends: Imports

use this command again.

selected collections from the presented

Contacts: Imports Apple Contacts

dialog into a newly created group named

addresses selected in the import dialog

"Bookends". Already imported references

into a newly created group named

are updated. The keywords assigned to

"Addresses". Contacts can be imported as

a Bookends reference are added to the

a sheet, as vcards (.vcf), or as bookmarks.

Document Properties of the created rich

Previously created groups are reused.

text document. Use the optional script

Tip: To import all addresses, select all

Scripts > Tags > Convert keywords to tags

addresses in the group "All" and import

to convert the keywords to tags if needed.

them. Address card bookmarks link to the

Unix Mailbox: Imports Unix mailboxes, like

original card in the Contacts application.

those exported from Thunderbird. See also

Folders & Attachments from Notes:

p. 52ff

Imports your notes from Apple Notes.

Website: Opens the Download Manager

Items from Yojimbo: Imports all items from

and downloads a complete web page/site

Yojimbo into a newly created group named

for archiving and offline viewing. Make sure

"Yojimbo". Imported items retain their

the download options are set correctly,

name, label, flag, URL, comments, tags

especially the options that define which

and creation/modification dates. Items

links DEVONthink should follow (if any).

without a URL link back to the original item

All links within the site are modified so

in Yojimbo.

that they point to the downloaded images

Notes from Evernote: Imports selected

or other embedded objects. This ensures

notebooks from an import dialog into a

that the page/site can be displayed at

newly created group named "Evernote".

any time. By default, groups created by

Tags, dates, and URLs should be preserved.

the Download Manager are excluded from

Notes are stored as formatted notes. This

tagging.

option requires the Evernote application to

Scan from ScanSnap: Scans a paper

be installed.

document using an attached Fujitsu

Note: The import from Evenote command

ScanSnap scanner.
only works with Evernote's "legacy

Note: Groups created when importing

version" as Evernote 10 no longer supports

bookmarks, contacts, email messages, and

AppleScript

items from Evernote or Yojimbo are not
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automatically excluded from classification

Word Document: Exports the selected

and tagging. This makes it easier to classify

items as one large Microsoft Word file.

them later.

PDF Document: Exports the selected items

Export: The Export submenu presents
options for exporting selected documents
or groups to the file system. In addition,
the Export menu provides export methods
based on plugins. DEVONthink comes with
a number of standard plugins for exporting
documents in different formats. For these
formats, the export creates a single merged
document when multiple files are selected.

as a paginated PDF. Hold the ⌥ Option
key to change allow the command to PDF
Document without Annotations.
OPML: Exports the selected items as one
OPML file.
Website: Exports the selected items as
standalone web site that you can upload to
your web server and share with colleagues.
In the presented dialog window, choose
the desired template, text encoding, and

Files and Folders: Exports the selected

whether DEVONthink should convert

documents in their native format. Groups

diacritics and accented characters to

are exported as Finder folders, preserving

HTML entities or not. Check Create Index

the group structure you have built in

Pages to create index.html pages with

DEVONthink. DEVONthink tags are

cross-links to all included documents.

applied as Finder tags to the exported

Markdown and formatted notes are

files. Internal metadata for the items is

rendered to HTML, other file types that

preserved in invisible .DEVONtech_storage

cannot be displayed in a web browser,

files, used for reimporting into

e.g., Pages files, are converted to PDF

DEVONthink. If you will not be reimporting

if possible. Cross-links are converted

the exported files, you can safely delete

correctly. For the export templates are

.DEVONtech_storage files.

used that you can modify yourself.

Document: Exports the currently viewed

Template: Saves the selected documents

document in its native format. For images

as a template, which can then be used

exported from a separately opened

to quickly create new documents using

document window, DEVONthink lets you

Data > New from Template. Export multiple

choose the desired file format or image

documents and/or groups at once to

quality; e.g.,you can export a PNG files as a

create e.g.,a project template. Data & New

JPEG file.

from Template & Open Template Folder;

Text: Exports the selected items as one

can be used to organize templates.

large plain text file.

Database Archive: Creates an optimized

RTF Document: Exports the selected

ZIP file of the current database in the

items as one large rich text file without

selected location. This can be useful as a

embedded images, etc.

secondary backup strategy.

RTFD Document: Exports the selected
items as one large rich text file with
embedded images, etc.

Unix Mailbox: Exports all selected email
messages and saves them as Unix mailbox
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file that can be imported into other email

Note: Indexed groups are excluded from

applications. Note this only applies to

tagging by default. For more information

exporting native email (.eml) files, not

on importing and indexing, please see the

files that have been converted to other

Import and Index section of the In & Out

formats, like plain or rich text.

chapter.

Share: This shows the standard Mac share
menu.

SYNCHRONIZE
Synchronize: Synchronizes the selected

INDEX
Index: Use this command to add external
files and folders from the Finder. This creates
links to the files but leaves them in the
current location. Regarding see-also and
classification, DEVONthink treats these

database with all its locations. Note, this
command will be disabled if the current
database has no active synchronization.
Holding the ⇧Shift key shows the Synchronize
All option to synchronize all actively syncing
databases.

files the same as imported files. To easily

Download Pending Files: Downloads the files

distinguish indexed items, a small Finder icon

of selected documents if they are available

is displayed to the right their name.

through one of the database's locations. Only

Update Indexed Items: Indexed items are
updated when you view them. If you need
to be sure everything is up-to-date use
his command. If nothing is selected, the

necessary of none of the database's locations
is set to synchronize indexed files.

DATABASE PROPERTIES & CLOSE

enclosing group of the current group is used.

Database Properties: Opens the Database

It also reads changes made to the Finder or

Properties popup for the current database.

Spotlight comments of the to-be-updated

This panel presents a few options, statistics

files and applies the changes to the files'

about the database, and allows you to change

counterparts in the database. Finally, this

the displayed name, add comments, and add

command removes indexed items that have

a username and password.

lost their external counterpart. It does not
affect items moved manually to the group.

Close Database: Closes a selected database.
If multiple databases are open, use Close

Use Update Indexed Items to keep indexed

All to close them all at once. If you'd like to

groups and their originating folders in sync

keep the current database open but close the

or to manually update an item that you have

others, use Close All Except. Note that closed

changed directly inside the database package

databases will not reopen on launch. Only

when DEVONthink was not running.

databases that were open when DEVONthink
quits will reopen on the next launch.
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DATABASE MAINTENANCE

PRINT

Like any database, DEVONthink databases

Page Setup: Sets your preferred page size and

need a bit of maintenance from time to time.

printer settings.

All the commands you'll need for this can be
found here.
Verify & Repair: Verifies all database

Print: Prints the current document or view.

THE EDIT MENU

structures and repairs them if necessary.
Use this whenever you feel it is necessary.

The Edit menu contains all commands and

By default, DEVONthink automatically

options relating to editing. You'll find the

verifies the database structure every time

classic Mac cut/copy/paste and find/replace

you open a database. If it finds significant

commands here, as well as many more.

errors, DEVONthink will advise you to run this
command.

UNDO, CUT/COPY/PASTE, …

Optimize Database: Creates an internal

Undo/Redo: Use these commands to undo or

backup of the database and then optimizes

redo the last action, e.g.,to undo deleting a

the database structure. Optimizing removes

file. Undo and Redo work for most actions.

unnecessary internal elements from the
database and rebuilds the internal structure

Cut/Copy/Paste: Do exactly what their
names say.

to optimize performance. DEVONthink
also creates internal backups on a regular

Copy URL: Copies the URL of the selected or

basis. Hold the ⌥ Option key to display the

frontmost document to the clipboard.

Restore Backup option. This allows you to roll
back the metadata to a previous date. This
option would only be used in troubleshooting
situations.

Copy Item/Page Link: Copies a URL to the
clipboard that links to the selected document
or group. These links can be used to create
a back link to the document in applications

Rebuild Database: Completely rebuilds

that support live hyperlinks. For PDFs, hold

the database by exporting all items to a

the ⇧Shift key to reveal the Copy Page Link

temporary folder in the file system, creating

option.

an empty database, and reimporting all
items. This removes any structural problems.
Depending on the size of your database,
this can take from a few seconds to several
hours. This option is typically only used in a

Paste and Match Style: Pastes text from the
clipboard, matching the styles in the current
document.
Delete: Deletes the selected piece of text.

troubleshooting situation.
Complete: Tries to auto-complete the
Delete Database: Closes a selected database

partial word before the insertion caret. This

and moves it to the Finder trash.

standard Mac function uses the currently
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active dictionary, chosen in the language

language used for spell checking, or for

dropdown of the Spelling and Grammar >

auto-completion (see above), open the

Show Spelling and Grammar panel.

spell checker panel with Edit > Spelling and

Select All/Deselect All: Selects or deselects
the complete content of the frontmost
document. Hold the ⇧Shift key to reveal the
Deselect All option.

Grammar > Show Spelling and Grammar and
choose your language of choice from the popup menu.
Substitutions: Shows the standard
Substitutions preference panel and switch
SUMMARIZE, TAGS, SET NAME
Summarize: Summarizes the selected piece
of text. Unlike the Mac's Summarize service,
this command takes advantage of the builtin AI of DEVONthink, and uses the complete
"knowledge" contained in the open databases
for improving the results. The better your
databases, the better the results.
Tags: Use this command to quickly enter tags
for the current document. This displays the
Tag bar, if necessary.

the available options manually on and off:
Smart Copy/Paste, Smart Quotes, Smart
Dashes, Smart Links, Data Detectors, and
Text Replacements. Data Detectors analyze
shown text and make context-sensitive
actions available, e.g., when you hover
the cursor over a phone number or postal
address.
Note: The Spelling and Grammar
and Substitutions commands can be
temporarily applied to the current
document. If you'd like these to be

Set Name As: Applies the selected text as

persistent choices, you can make global

the document's name.

changes in Preferences > Editing.

FIND, SPELLING, INSERT
Find: This submenu contains standard
Mac find commands, like those available in
TextEdit. Searches on the current document
are displayed in the Search Inspector. Two
commands of note are:
In Database: Brings the search field of the
frontmost window into focus.
Scroll To Selection: In long documents, this
command scrolls the current document to
selected text.
Spelling and Grammar: Provides the standard
macOS functionality for checking text for

Transformations: Use this submenu to change
selected text to all lowercase or uppercase, or
to capitalize every word.
Speech: Starts or stops speaking the
selected piece of text.
Insert: Inserts items, like pictures,
checkboxes, bulleted lists, etc. The options
available are dependent on the current file
type.

DICTATION & EMOJIS
Start Dictation: Starts the Mac's dictation
function.

spelling or grammar errors. To choose the

DEVONthink 3.6 Documentation, page 134

Emoji & Symbols: Shows the standard Special

by pressing the ↩ Return key. Name the

Characters panel for inserting characters and

columns and sort the sheets by dragging

emoji that you cannot enter directly with

them with the mouse. Click OK to create

your keyboard.

the new sheet.
Bookmark: Creates a new bookmark. Type

THE DATA MENU

the URL and optionally name it to create a
bookmark, just as any browser does. If you

The Data menu contains all commands that

don't type in a name, DEVONthink will set

deal directly with documents or groups. Here

one automatically.

you'll find commands for creating, labeling,

Feed: Creates a new RSS feed document.

classifying or group new documents, and

The feed behaves like a special type of

more.

group that contains RSS entries published
by the feed's author. Type the URL and

NEW DOCUMENTS & TEMPLATES
New: This submenu provides access to the
built-in items DEVONthink allows you to
create.

optionally enter a name. If you don't type
in a name, DEVONthink will attempt to set
one automatically. You can change the URL
later by selecting the feed document and
changing the URL field in the Info inspector.

With Clipboard: Creates a new document

Twitter Feed: Creates a new RSS feed

based on the contents of the clipboard.

from a specified Twitter account. Enter

Note: Some applications such as Microsoft

the Twitter handle, e.g.,devontech, and

Word put data in multiple formats into

an optional name, to get a feed of recent

the Clipboard. DEVONthink tries to use

tweets from the account. If no name is

the most logical data when creating a new

entered, DEVONthink will attempt to set

document.

one automatically. As with other feeds, you

Plain Text: Creates a new plain text

also can change the URL, if for example, the

document.

feed isn't working as expected.

Rich Text: Creates a new rich text

Group: Create an empty group. This option

document.

appears as Tag if you are currently in the

Formatted Note: Creates a new formatted

Tags group of a database.

note.

Smart Group: Creates a new smart group.

Markdown Text: Creates a new Markdown

This is a special group that shows items

text document.

matching your specified criteria, similar to

HTML Page: Creates a new HTML page.

the Finder's "Saved Search". DEVONthink

You can use the built-in macOS WYSIWYG

opens the Smart Group Editor, which

editor to edit the HTML page or switch to

lets you define your search criteria.

its source code (from the navigation bar)

When saved, the contents are updated

and edit it directly.

every time you display the smart group's

Sheet: Creates a new sheet. Add columns

contents.

to the new sheet by using the + button or
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New from Template: This submenu allows you

Reveal: Reveals the location of the frontmost

to access any installed templates and add

document in either the same main window, if

them to the current group in your database.

possible, or by opening a new one.

There are two other commands to note:
Show in Finder: Opens a new Finder window
Open Templates Folder: Select this to

with the item selected. Note this only works

open ~/Library/Application Support/

for documents and indexed groups.

DEVONthink 3/Templates.noindex in the
Finder. You can add your own documents to
be used as templates here.
More Templates: Opens the Extras section
of the Support Assistant to install any
available DEVONthink templates.

Send by Email: Creates a new message in
the default email application and adds the
selected items as attachments. Supported
email applications are Apple Mail, Airmail
2, Microsoft Outlook, and Postbox, as well
as some legacy email application . If the

Note: For more information on the

selected item is an email message, the sender

pre-installed templates, check out the

is automatically inserted as the recipient and

Templates section of the appendix.

the text of the original message is inserted
instead of an attachment. Notes: Postbox is

OPEN, LAUNCH, REVEAL, SEND
Open: Opens the selected document or
group in a separate document window. This
command opens a second main window
for the selected group. If you have selected
multiple documents, hold the ⌥ Option key

currently only able to send one selected file.
Unsupported email clients (e.g.,Thunderbird)
can only send the plain text of one selected
file.

SAVE, REVERT, DUPLICATE

to display the Open in Tabs command. If

Save/Save All/Revert To Saved: Saves the

the View/Edit pane is visible, this opens the

frontmost document or all documents

selected items in new tabs. If the View/Edit

to disk. Hold the ⇧Shift key to show the

pane isn't visible, a new document window

alternate menu item, Save All.

will open with each selected document in its
own tab in the window.
Open with: Displays a list of applications
compatible with the current file type. Opens
the selected documents in the chosen
application. If your desired application is
not listed in the submenu, choose Other to
browse for it.
Launch URL: Opens the file, folder, or internet

Revert To Saved: Restores the frontmost
document to the last saved version.
Duplicate: Creates a duplicate of the selected
items. The name of the new item ends in
"copy", and because their contents are
identical both items are marked with the
icon for duplicates (or, depending on your
preferences, show their name in bold and
blue).

location indicated by the URL field in the Info
inspector.
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MOVE INDEXED ITEMS IN AND OUT
Note: The following two commands are only
for use with indexed files.

> Properties inspector for PDF or rich text
files, into a DEVONthink tag.
Convert Geolocation to Tags: Converts
geolocation data, if present on the file, into

Move Into Database: Use this command to

DEVONthink tags.

move an indexed file into the database. Use

Add Tags to Images: Adds tags to selected

this command with caution as it moves the

images using Apple's machine learning

file from its current location into the internals

technologies.

of your database. It does not copy the file.

Scan Barcodes: This option will attempt
to detect a barcode in a selected image.

Move To External Folder: Use this command
to move a non-indexed item, e.g.,imported
or created in DEVONthink, out to an indexed

A successfully detected barcode will be
added to the custom metadata for the
document.

folder in the Finder.
Note: The Add Tags to Images and Scan
FAVORITES, READING LIST, METADATA

Barcodes options require macOS 10.13 or
later.

Add To: Commands in this submenu add
the currently selected documents to your

CONVERT, OCR, THUMBNAILS

Favorites or the Reading List.
Convert: This submenu contains commands
Mark: Allows you to mark the item as
flagged/unflagged, locked/unlocked, and
read/unread.

for converting between some file formats,
e.g.,between rich and plain text. Note the
options presented are dependent on the

Rating: Allows you to set a rating, from no

type of the selected document. Also, due to

stars to five stars.

differences in the formats, any formatting
in the source document may not be able to

Label: Allows you to mark the selected groups

be perfectly preserved in the destination

or documents with one of seven labels, just

document.

as in the Finder. You can define the color and
the text of the labels in Preferences > Colors.

OCR: This menu contains options for
choosing an output format when doing

Tags: This submenu offers special commands

OCR on a selected compatible document

for automatically adding some kinds of tags.

(JPEG, PNG, TIFF, PDFs with no text layer).

Convert Keywords to Tags: Converts
keywords, found in the Document >
Properties inspector for PDF or rich text
files, into DEVONthink tags.
Convert Properties to Tags: Converts the
Author property, found in the Document

The currently supported output formats
are: Searchable PDF, RTF, Word , and Web
Archive. Additionally, there are two special
commands: to Comment and to Annotation,
which sets the Finder comment or creates
an Annotation file with the text. Neither
command alters the original file.
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Thumbnails: Use these commands to add,
remove, or update a thumbnail for the
selected files.

GROUP & UNGROUP
Group Items: Creates a new group containing
all the selected items. This is similar to
creating a new group and moving the selected
items into it. The alternate command Group
Similar Items, shown when the ⇧ key is held,
will attempt to file selected items with
similar content in groups.
Ungroup Items: The exact opposite of Group

THE FORMAT MENU
The Format menu contains the commands
and options dealing with all aspects of text
formatting. Here you'll find the standard font,
alignment, and ruler commands, as well as
very special DEVONthink commands.
Note: Many commands in this menu
only work with rich text, Markdown, or
formatted notes. Plain text documents do
not allow formatting. (That's why they're
called "plain" text.) Some formatting
options are also available for editable PDFs
and web archives.

Items. Moves all items in the groups one level
up and deletes the now-deserted groups.

SEE ALSO & CLASSIFY

FONTS, STYLES, ALIGNMENT, RULERS
Font: This submenu is responsible for
controlling the font and the document

The following commands use DEVONthink's

background color (rich text documents only).

built-in AI to suggest good locations for the

Open the fonts panel with Show Fonts, then

selected documents:

increase or decrease the font size of selected
text with Bigger and Smaller, adjust the

Move (to): This command allows you to
quickly move other selected files to the last
destination chosen in the See Also & Classify

text styles and the document background
color. Of special note are these two submenu
commands:

inspector.
Copy Font: Copies the font formatting of a
Classify: Using DEVONthink's AI, this
command will move selected files to the AI
suggested location. This command is disabled
if DEVONthink is not sure enough about

selected piece of rich text.
Paste Font: After using the previous
command, applies the copied font to
another selection of rich text.

possible destinations.
Style: Commands in this submenu apply
MOVE TO TRASH

a certain style, such as italics, bold, or
underlined, to selected text. Also, the

Move to Trash/Move All Instances to Trash:
Moves the selected items to the trash. If

commands give you access to some highend font control like kerning, baseline

you have selected a replicated item, hold the
⌥ Option key and choose Move All Replicants
to Trash to move the selected item and all its
replicants to the database's trash.
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shift, ligatures, and character shape
(only applicable to Asian languages). One
command to take special note of:

LINKS, SPACING, LISTS, TABLES
Make/Remove Link: Converts the selected
text into an active link, or disables the

Styles: The Styles command opens the

link. This command can be used to create

macOS styles editor. With it, you can step

WikiLinks quickly.

through all the styles used in the current
document. If there's one you'd like to reuse,
add them to your favorites. Use the popup menu to select a saved style and, if you
don't need it any more, delete it. You can
use saved styles from the ruler (see below).
Alignment: Align paragraphs left, right,
centered, or justified. Here, Asian or Arabic
users can also change the direction of writing,
if required.

Add/Edit Link: Use this command if you want
to add a specific link to some text. If the text
is already linked, the menu will display Edit
Link, allowing you to change or remove the
URL. The behavior you'll see when clicking
linked text depends on the target of the link:
If the text was a valid URL, the URL will be
the target of the link. Editing the link text
later does not change the target. Use the
Edit Link command of the contextual menu

Ruler: This submenu allows you to display

to edit the link target.

the ruler above the preview of rich text

Otherwise, DEVONthink treats the link as

documents. There are also two special

a Wiki-style link. Clicking the Wiki-style

commands:

link jumps to a document with exactly

Copy Ruler: Copies the current ruler
attributes (tabs stops, indents, etc.) of a
selected piece of rich text.
Paste Ruler: After using the previous
command, applies the copied ruler
attributes to another selection of rich text.

HIGHLIGHTS
Highlight, Highlight Color: In rich text
documents, editable PDFs, and web archives
use Highlight to highlight a selected piece
of text just as you would using with a
colored pen on a piece of paper. To remove
highlighting, select the highlighted piece of

the same name as the linked text (or any
document with a Wiki alias of that name).
If there is no document of that name,
clicking the link creates a new rich text
document named after the linked text and
pre-filled by the template you set in the
Preferences > Editing.
Spacing: This command allows you to adjust
the line spacing of selected text in rich text
documents. You can adjust the line height
to an exact value or define a minimum and
maximum height, adjust inter-line spacing,
and define the space before and after a
paragraph.

text and choose Highlight again. Use the

List: Creates a bulleted list. Select your

Highlight Color submenu to choose your

prefix, bullet style, and suffix in the dialog

favorite highlight color.

sheet and click OK to insert a new list. In the
list, press ↩ Return to insert new items, and
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press ⇥ Tab and ⇧⇥ Shift-Tab to indent/de-

the ruler, and displaying the color picker are

indent items, just as you would in any word

shown. For sheets, tools to add/remove/

processor.

duplicate records, as well as editing columns

Table: Inserts a new table into a rich text

are shown.
document and opens the table inspector

Show Colors: Shows the color panel, e.g., for

panel. Use the table inspector to adjust the

changing the foreground color of selected

number of rows and columns, cell alignments,

text in rich text documents.

cell colors, border widths, and colors. Also,
you can merge and split cells and create
tables within a cell.

PLAIN & RICH TEXT, HYPHENATION,

Show Invisible Characters: Toggles display of
invisible characters such as spaces, tabs, and
line feeds. Shown invisible characters appear
in light gray.

LAYOUT

THE TOOLS MENU
Make Plain/Rich Text: Converts a rich text
document to plain text and vice versa.

The Tools menu provides tools to get more

Converting a rich text to plain text removes

detailed information about your documents,

all formatting, while converting a plain text

as well as some specialized commands.

document to rich text applies default rich
text font settings to the document.

INFO & FILTERS

Allow Hyphenation: Enables or disables

Get Info: Opens an popup containing more

hyphenation for the current rich text

detailed information about the currently

document.

selected file or group. It combines frequently
used elements of the Info inspector and

Make Layout Vertical/Horizontal: Enables

contains three panes:

orienting and editing the document text
vertically or horizontally.

Info: The Generic panel shows basic
information including name, aliases, URLs,

BARS, COLORS, INVISIBLE CHARACTERS

file dates, and kind. The Custom pane
shows metadata specified in Preferences >

Show Formatting Bar: Displays a toolbar of

Data that has been applied to the file.

formatting tools under the toolbar, providing

Annotations & Reminders: Shows a

access to styles, font and paragraph

summary of reminders set for this

attributes, and lists. These tools are only

document, Finder (Spotlight) comments,

used with RTF files.

and Annotations.

Show Editing Bar: Displays tools above the
current preview pane for some file types.
For example, rich text formats display
several common tools including increasing/
decreasing font size, highlighting, toggling

Properties: Shows metadata specific to
PDF and rich text files. This includes things
like keywords, author, and subject that are
sometimes included with these types of
files.
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Inspectors: This submenu provides access to

by frequency, groups, length, or weight.

the inspectors panes.

The data can be viewed in a List, Cloud,

Show/Hide: Shows or hides the inspector
pane.
Info: The Generic view shows basic
information including name, aliases, URLs,

or Graph. Additionally, selected words are
highlighted in the current text and a data
graph showing related words will appear in
the List and Cloud views.

file dates, and kind. The Custom view

Filter: The commands in this submenu

shows metadata specified in Preferences >

filter the list of files in the location you are

Data that has been applied.

currently viewing. As you select options

Annotations & Reminders: This inspector

in these panes, the list of files will change

shows a summary of reminders set for

accordingly. The filters are also covered in the

this file, Finder (Spotlight) comments, and

windows chapter.

annotations.
Content: When viewing PDF files, this
inspector provides a Thumbnails and a
Table of Contents pane. Note that the
Table of Contents panel is only displayed if
the current PDF contains one. DEVONthink
does not generate the table on its own.
Document: Useful when viewing PDF
and RTF files, this inspector displays
Properties, Annotations, and Links.
See Also & Classify: This inspector is
the main interface to DEVONthink's
brain, our built-in AI engine. This engine
is analyzing the contents and locations
of all documents in your database and
making connections between them. These
connections can be seen in this inspector
pane.
Search: This pane allows you to search

Info: Shows a pane with options for
filtering on dates, flagged state, unread
status, rating, or color label. When using
the calendar, you can click Any Date to set
which date you want to filter on: added,
created, modified, opened, or due.
Tags: Shows a tag cloud, with frequencybased sizing, i.e., more frequently used
tags will be larger. Clicking on tags removes
unrelated tags from the cloud, only showing
tags that have been applied with the
current tag.
Maps: Shows a small map showing pins
from geolocation data will be shown.
Clicking on a pin will show you files created
in that location. The behavior of this pane
is similar to Apple Maps, e.g., pinch to zoom
in and out, etc.

the current document, displaying the

Note: When Info or Maps is selected, the

found words in context and on what lines

options will appear at the bottom of the

they occur. Additionally, you can use the

sidebar. When Tags is selected, they will

Replace field to quickly replace selected or

also appear there, but will also show in the

all occurrences of the found words.

information bar above the item list if the

Concordance: The Concordance is a

sidebar is hidden.

specialized view showing data about the
words in a document. This can be sorted
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ANNOTATIONS
Annotate: This submenu provides access to
the PDF annotation tools: Oval, Rectangle,
Line, Note, Text, and Link.
Mode: Use the commands in this submenu to
switch between three modes of interaction
in PDF documents: Move, Text Selection, and
Annotation Selection.

Columns,and Delete Columns. See the
Documents chapter for more information on
sheets.

ROTATE & FLIP
Rotate Left/Right: Choose this to rotate
images, or individual pages in a PDF
document.
Flip Horizontal/Vertical: Choose this to flip

CAPTURE, IMPRINT, EDIT PDFS & SHEETS
Capture: This submenu provides options for
capturing the current document to a new

an image on its horizontal or vertical axis.

CREATE, SUMMARIZE, MERGE, SPLIT

file in a few different formats: Bookmark,

Create Expense Report: Creates a sheet

Plain/Rich Text, Formatted Note, HTML, Web

summarizing custom metadata dates and

Archive, and PDF (One Page/Paginated).

currencies of selected files. Totals for the

Captures are made to the current group.

amounts will also be included.

There is also an option to use the Clip to
DEVONthink command. This allows you to
clip to a chosen location.
Note: The available options in the Capture
menu are dependent on the type of the
current document.

Create Metadata Overview: Creates a sheet
with records for each selected file. The
columns contain data from the generic and
custom metadata of each file.
Create Table of Contents: Opens a submenu
to create a rich text or Markdown document

Imprinter: Choose an imprint you have

with links to the currently selected

defined in Preferences > Imprinter to apply it

documents.

to the current image or PDF.
Summarize Highlights: Creates a document
PDF Document: This submenu provides

with all highlighted text passages of the

options for editing the current PDF

currently selected documents. In case of

document: Insert Blank Page, Delete Selected

items located in multiple databases the

Page, and Reverse Page Order. See the

summary is created in the global inbox. From

Documents chapter for more information on

the submenu, choose to create the summary

PDF documents.

in a rich text or Markdown document.

Sheets: This submenu provides access to

Merge Items: Merge the selected documents

the following tools for editing a sheet: New

into one. This creates a new file, preserving

Record,Duplicate Records,New Column,Edit

the originals. Hold the ⌥ key to choose Merge
& Delete n Documents, removing the original
files after the merged document is created.
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When merging documents, the order of the
merge will be the order shown in the item
list. The topmost selected document will
be the first page with the pages beneath it
following. The order of the documents can be

START SERVER, TAKE NOTES
Start/Stop Server: Use this command to
start and stop the integrated web server. See
also p. 67ff

controlled by the current sort method in the

Take Note: Opens the Sorter to the Take Note

item list. See also p. 144ff

view. If the Sorter is not shown, it opens the

Note: The resulting file type of a Merge

Take Note window.

operation depends on the types of the
selected files. Selecting mixed formats,
e.g., a web archive and an image, usually
results in an RTFD file being created.
Split PDF into Chapters: Used on a PDF

THE VIEW MENU
The View menu contains all the commands
for modifying the way DEVONthink displays
groups and documents.

containing a table of contents, separate perchapter files are created.

SIDEBAR & LAYOUTS

Split Document: Splits the current document

Sidebar: The Sidebar view options allow you

(PDF, plain or rich text) at the insertion mark

to switch between the four different sidebar

position in the document.

views in a main window. You can toggle the
sidebar's visibility by selecting the same

RULES

option again.

These commands allow you to set or run

Navigate: This is the main sidebar view,

smart rule commands

giving you easy access to your databases,
favorites, and global smart groups. See also

Apply Rules: Apply the selected rule on

p. 80ff

selected items that match the rule's

Reading List: Similar to Safari's Reading

criteria, including the location defined in

List, this sidebar view allows you

the smart rule.

to maintain a list of items for later

Perform Rules: Run the selected rule at any

consideration. See also p. 88ff

time or in any location. This is not isolated

Extras: This view gives you access to recent

to the documents in the current location.

updates in tutorials, scripts, and templates.

Batch Process: Use this command to

And if you want to keep up on updates

quickly define and run commands without
specifically defining a rule. This can be
useful to modify multiple selected files.
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from us, it includes links to promotions and

as kind, label, size, word count, creation

release announcements. See also p. 93ff

date, and modification date. Available in all

Import: The Import sidebar view gives you

windows using icon or column views.
access to scanning and email archiving. See

Show Only Documents: When checked, this

also p. 92ff

hides groups and smart groups in List and

View: Choose one of the following options
to switch between different layouts for the
item list in a main window. All these views are
similar to options you find in Finder windows.
Icons: Displays items as icons.
List: Displays items in a list view with userspecified columns shown.
Columns: Displays the item list as a set of

Icons views. Note this is a per-database
setting, i.e., you can enable or disable it for
each open database.

COLUMNS & SORTING
Columns: This submenu lists all columns
available to be displayed as column headers in
the item list.

columns.

Sort: This submenu lists all the attributes

Cover Flow: Displays large thumbnails in a

that can be used to sort the current item

side-scrolling view.

list. Choose Unsorted to manually sort the

Preview: These options allow you to control
the position of the current document's
preview, or dismiss it altogether.

items. DEVONthink remembers sort settings
for every group separately and uses those
settings when the group is displayed in its
own main window

None: This creates a list only view.
Standard: This shows a preview under the
file listing.
Widescreen: This shows the preview to the
left of the file listing.

FULLSCREEN & ZOOM
Full Screen: Displays either the current
document in a full screen mode optimized for
reading and editing, or the frontmost window

Quick Look/Slideshow: Opens the Quick Look

in full screen. There are two options available

panel for the selected items which can be

here:

useful for times when the view/edit pane
isn't displayed. Holding the ⌥ Option key
allows you to display the selected files in a
Quick Look slideshow.

SHOW TAGS & DETAILS
Show/Hide Tags: Shows or hides the tag bar.

Document: Shows the current document in
full screen. Note this is a distraction-free
view, not the standard macOS fullscreen
view.
Window: Shows the current window in a
standard macOS full screen view.
Zoom: Depending on the document type, you

Show/Hide Details: Switches between

can zoom or out of the document's preview

displaying icons only or displaying icons

to your needs:

together with detailed information such
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Actual Size: Displays the document

PDF Display: This submenu lets you adjust

at actual size, calculated using the

the way PDF documents are displayed:

resolution of the screen and the resolution
information of the image or PDF.
All Pixels: Displays the document at a 1:1
ratio so that one pixel of the image equals
one pixel on the screen (PDFs and images
only).
Zoom In/Out: Zooms in or out of the
document.
Zoom to Fit: Displays the document so
that it exactly fits either the height or the
width of the window/preview pane (PDFs
and images only).
Zoom to Width: Displays the document so
that its width fits the width of the window
or view/edit pane (PDFs and images only).

DOCUMENT & PDF OPTIONS
Document Display: This submenu contains

Single Page, Two Pages: Shows a multipage document as single pages or two
pages facing each other (as in a magazine).
Continuous Scroll: When checked, shows
the pages of the PDF as one long scroll.
When unchecked, only one page is shown
at a time.
Book Mode: When checked, facing pages
start with one single page (the title page),
then facing pages. When unchecked, they
start facing.
Page Breaks: When checked, pages are
shown with a small break between the
pages. When unchecked, the pages appear
as a continuous document.
Crop Box, Media Box: Crops the page to
the crop or media box. By default, PDF
pages are cropped to the crop box.

commands for displaying alternate views of
some documents. Note there are alternate
commands shown when used with sheets or
HTML and Markdown files.
Best Alternative/Preview/Table View:
Shows a QuickLook view, or a rendered
view for HTML-based and Markdown files,

TOOLBAR
Hide/Show Toolbar: Hides or shows the
toolbar of the frontmost window.
Customize Toolbar: Lets you configure the
toolbar of the frontmost window.

the Table view for sheets.
Text Alternative/Source/Form View:
Shows a text-only view of some file types,
e.g.,Word or email. Also shows the page
source of HTML-based and Markdown files
or the Form view for sheets.
Side-by-Side: Shows a side-by-side view
of the rendered view and source for HTML
and Markdown files. Note this does not
apply to Formatted Notes.

THE GO MENU
For people who prefer to use the keyboard
for navigation, the Go menu contains all
commands for navigating the hierarchy
of your DEVONthink database, all with
keyboard shortcuts. Use these commands
to go backwards and forwards through your
documents, or to move back to the top level
of the group hierarchy.
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DATABASES
Previous Database: Selects the previous
database in the Navigate sidebar.
Next Database: Selects the next database in
the Navigate sidebar.

GROUPS

Previous/Next Instance: Navigates
backwards and forwards through all instances
of a replicated document. Use these
commands to find out where the other
instances of a replicated item are.
Previous/Next Highlight: Navigates
backwards and forward through all
highlighted passages within a document,

Top Group: Returns you to the top level of the

regardless of whether these passages have

database (also known as the "root").

been highlighted by a search or manually
using Format > Highlight.

Enclosing Group: Changes the view to
the parent folder of the current group or

Next Unread Item: Navigates to the next

document.

item with an unread status in the current
database.

Selected Group: Changes the view to the
currently selected group.

Go to Page/Time: Allows you to jump to a
specified page (PDF documents) or time

To Group: Opens a popup where you can

(supported video and audio files).

search for a group by name. Results are
shown as you type. The chosen group from

Favorites: Displays a menu of items in the

the results will display as the current group.

Favorites section of the Navigate sidebar,
allowing easy access to the items.

DOCUMENTS
WORKSPACES
Back/Forward: Moves backwards and
forwards through all documents/web pages

Workspaces allow you to save the state of

you have visited by following cross-links or

your open databases, as well as the contents

Wiki-style links.

and positions of all open windows, so that
you can restore them later. This is ideal if you

First/Previous/Next/Last Document:
Navigates to the first, previous, next, or last
document of all documents in the current
group. This is useful when you have opened

are working with the same set of windows
over and over again. Save these windows as
a workspace and recall them whenever you
need them again.

a document in a separate window and want
to move to another document in the same

Add: Saves the currently open windows as

group.

a workspace.
Edit: Opens a window that allows you

To Document: Opens a popover to quickly
navigate to a specific document.

to edit saved workspaces. Click on a
workspace name to change it, reorder by
dragging, and delete with the - button.
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Update: Updates an existing workspace

Download Manager: This command opens

to the current state of databases and

the Download Manager panel of DEVONthink.

windows.

Using the Download Manager, you can

Workspaces: Choose a workspace from the

download files or complete web sites from

list of saved workspaces to load it.

the internet and store them directly in your
database.

THE WINDOW MENU

Log: Opens the Log panel. The log lists error

Just like most every macOS application, the

messages and warnings that occurred while

Window menu lists all open windows of the

importing new documents. It also opens

active application and gives you access to

automatically when an error occurs. You can

commands for managing them.

save the log to a text file or clear it.

WINDOWS & TABS

OPEN WINDOWS

Close, Zoom, Minimize: These three

Window List: Select any open window from

commands resemble the red, yellow, and

the menu to bring it to the front.

green buttons of any window title bar, and
consequently close the window, minimize
the window to the Dock, or maximize the
window. No magic here. Hold the ⌥ Option
key to change allow the command to affect
all windows.

THE SCRIPTS MENU
The Scripts menu is located left of the Help
menu and shows a stylized AppleScript
symbol instead of a normal menu title. It
contains a collection of useful, predefined

New, Close, Select Next/Previous Tab: Opens

AppleScripts you can use directly from within

a new tab, closes the active tab, or moves the

DEVONthink.

focus to the next or previous tab.
Note: Tabbed browsing needs to be
enabled for these commands to work.
Bring All to Front: Brings all windows of
DEVONthink to the front. Hold the ⌥ Option
key to change Bring All to Front to Arrange in
Front.

ACTIVITY, DOWNLOADS, LOG
Activity: Opens the Activity panel. This panel
shows all running processes, e.g.,OCR or sync
activity, and allows you to manually stop
them.
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DEVONTHINK
Use these commands to open the integrated
help pages, get directions on installing the
browser extension and bookmarklets, or
access the list of changes to DEVONthink.
Some of the scripts work without having

SUPPORT

selected a document, while others require
you to select the document you want the
script to interact with. In general, the script
will tell you what you have to do when you
select it from the

menu.

Use More Scripts to install additional
scripts and read more about scripts and
DEVONthink's

menu here.

Your Account: Opens the login page for your
DEVONtechnologies account where you can
get information on your licenses and the
devices they're registered to.
Support Assistant: Opens the support
screen of the Welcome to DEVONthink
assistant with more direct links to the
DEVONtechnologies website, tips, and
tutorials. Note this function requires an

THE HELP MENU
The Help menu contains commands
for opening the integrated help pages,
the support assistant, or visiting the
DEVONtechnologies website.

Internet connection.
Tutorials: Opens the Tips and Tutorials
screen of the Welcome to DEVONthink
assistant. The tutorials help get you started
by explaining everyday DEVONthink tasks
in step-by-step detail. Note this function
requires an Internet connection.
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DEVONTECHNOLOGIES
These commands take you directly to the
corresponding pages on our website or send
feedback directly us.

It also contains the generic macOS
commands and an Options menu common to
all macOS applications. DEVONthink-specific
items are listed below:

DEVONtechnologies, User Forum: Quickly
access our home page or our user forum in
your default browser.
Contact Us/Report Bug: Use this to draft a
general email to us. When you need to report
an issue, hold the ⌥ Option key to show the
Report Bug. This creates a new message
in your default email client or Apple Mail
containing the console log and all related
crash logs in a ZIP archive, ready to be sent to
our customer support.

THE DOCK MENU
The Dock menu appears when you click
DEVONthink's icon in the Dock with the
⌃ Control key pressed, when you right-click it,

Recent Databases: Quickly reopen a closed

or when you left-click it and hold the mouse

database from this list.

button for one second or longer. When items
are added to a database, a badge appears
on this icon. Longer tasks, e.g., importing,
indexing, or running scripts, may show a
progress indicator on the dock icon.

Open Windows: Switch to any open window
from this list. The active window is displayed
with a checkmark next to it.
Take Note: Opens the Take Note panel.
Start/Stop Server: Starts or stops the web
server.
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Server
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Sync
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GENERAL

The Preferences window, which you open

Stricter recognition of duplicates: Check to

by selecting Preferences in the application

have DEVONthink mark files as duplicates

menu, is the place to go to change global

consider the file type and size, as well as the

settings for DEVONthink. In addition to

content, when determining duplicate files.

global settings, databases also have separate
settings in their Database Properties

Enable reminder alarms: Enables or disables

window that you open using File > Database

using DEVONthink Reminders. This can be set

Properties.

on a per-machine basis.

There is also a number of hidden preferences,

INTERFACE

intended for customer support, but maybe
useful for you, too. See also p. 232ff

These options control the behavior of
the interface, e.g., when double-clicking
documents.
Double-click opens groups in a new
window: This option allows you to open a
new window when you double-click a group.
If unchecked, the group will be selected
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and its contents will be replace the file list

when revealing an item or opening a group

being currently viewed.

in a new window.

Double-click opens documents externally:

Unify Databases: When enabled,

Check this if you'd like documents to open

navigate the groups of the root of all

in an external application when double-

open databases in the Open Databases

clicked. DEVONthink uses the application

section of the Navigate sidebar. When

set as the default application for the

disabled, the groups of the root of the

file type in the operating system, e.g.,

active database are displayed in an active

TextEdit for RTF documents. If unchecked,

database section in the sidebar. This allows

any document that can be edited in

isolating the groups of a database. The

DEVONthink will be opened in its own

active database will have an asterisk to the

window.

left of the name.

Keep groups on top when sorting: Always

Unify inboxes: Display the inboxes of open

display groups at the top of the item list,

databases only in the Globals section of

independent of the sort method, e.g., by

the Navigate sidebar. When disabled, the

Name, by Date Added, etc.

inbox will be displayed in the item list for

Retain view: When enabled, the view

the current database.

settings in the current main window, e.g.,

Unify tags: Display the Tags group of open

Icons in Widescreen, override the view

databases only in the Globals section of

settings of other groups or databases.

the Navigate sidebar. When disabled, the

If a change is made to the current view,

Tags group will be displayed in the item list

that change will persist when switching.

for the current database

If no changes are made, the previous view

Keyboard Navigation: Enables keyboard

settings will be restored after disabling this

navigation with typing selection, and arrow

option.

key hoisting of groups in the Navigate

Enable tabbed browsing: When checked,

sidebar.

click with ⌘ Command pressed a link in
web, PDF or text views to open it in a new
tab. When unchecked or the ⌘ modifier key
isn't pressed, documents are opened in the
same view, in the default application or in
new windows. Check Always show tab bar
if you'd like to view the document title in a
tab bar when only one document is open.

ALERTS
Click Reset to make DEVONthink show alerts
again that you previously dismissed with
"Don't show again" checked.

CHECK FOR UPDATES
Change the settings in this tab to define

SIDEBAR
Automatically expand & collapse: Check
this to automatically show the sidebar

when you want DEVONthink to check for new
versions: never, on startup, daily, weekly, or
monthly. DEVONthink only performs checks
for updates when the computer is connected
to the Internet.
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Click Check Now to immediately check for a

Show filename extensions: Check this if

new version.

you prefer to see the file type's extension
at the end of filenames.

APPEARANCE

Use dark background for documents: When
enabled, compatible documents, e.g., rich
text, will display white text on a black field
when using macOS' dark mode. When
disabled, documents will display normally.

LABELS
Choose how you would like labels to be shown
in lists.
Classic: Tints the group/document icon
(like on Mac OS 9).
These options define some parts of the visual
appearance.

Modern: Puts the group/document name in
a colored bubble (like on older versions of
OS X).

Alternating row colors in views: Check

Dots: Shows a colored dot in the list (like

to color every second row in item lists

on macOS).

differently.
Display number of items inside groups:

FONTS

Check to show the number of documents
in groups. In the sidebar, the total number
of items in the group is shown. News feeds
will show the number of unread items. In
the item list, this shows the number of

Use Sidebar Text Size to set the font size
DEVONthink uses in the sidebars. Use View
Text Size to set the font size used in the item
list and the contents of sheets in table view.

unread and read documents contained in
a group. For example, "2/10" shows there
are two unread documents out of ten total
documents.
Highlight Internet links in views: Check to
show bookmarks in the file list and links in
documents marked in blue and underlined.
Mark duplicates and replicants in color:
Check to highlight duplicates marked in
blue and replicants marked in red in most
views. When unchecked duplicates and
replicants display an special icon to the
right of a document's name.
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EDITING

Smart links: Detect web addresses and
turn them into clickable links.
Smart dashes: Convert characters, e.g.,
two hyphens into a proper dash.
Data detectors: Detect dates, times or
addresses in text, and show possible
actions when the mouse cursor moves over
them.
Text replacement: Use the system-wide
text replacements when editing text.

AUTHOR, RULER UNITS AND FONTS
Author: Enter your name. It will be used as
The Editing tab defines all options that fine

default for metadata, e.g., for new rich text

tune DEVONthink's text editing behavior,

documents or PDF annotations.

from the ruler units to default font settings

Ruler Units: Select your personal

to summarization options.

preference for ruler units: centimeters,
inches, points, or picas.

GENERAL

Plain Text: Select your preferred font.
This is the font automatically used when

Display PDF attachments of rich texts:
When checked, a PDF inserted into an
RTFD documents will display its first page.
Unchecked, you will see a link and the PDF's
filename.
Scale image attachments: Images added
to rich text files and formatted notes are
scaled to the current width of the view/
edit pane.
Check spelling while typing: Spellcheck

you create new documents. Additionally,
specify the background and text colors to
suit your taste.
Rich Text & Note: Select your preferred
fonts for new rich text formats. This is the
font automatically used when you create
new rich text documents or formatted
notes. It is also the default used for
rendered Markdown documents, if no
default stylesheet is specified.

while you write.
Check grammar with spelling: Check

Note: Hold the ⌥ Option key to restore the

grammar as well as spelling while you write.

default fonts.

Correct spelling automatically: Correct
misspelled words automatically.
Smart quotes: Convert straight quotes
("inch marks") to typographer's quotes
("curly quotes") while you type.

FULL SCREEN
Full Screen: Select your preferred font for
reading and editing plain text files in full

Smart copy/paste: Insert or remove spaces
before and after cut or pasted text.
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screen mode. Rich text documents will
display their user-specified fonts.
Background: Choose a background color for
the full screen mode.
Text: Choose a text color for the full screen

WIKILINKS
To enable WikiLinking, check the Automatic
checkbox and choose from the options shown
here:

mode.

MashedWords: Commonly used to avoid

Width: Choose a width for displaying

creating links from individual words,

documents in full screen mode. This setting

mashed words are document titles of

will apply wider or narrower left and right

joined words. If you type a mashed word,

margins, based on a percentage of the

it will automatically create a link. If a

screen width.

matching document is detected, it will
open when clicking the link. If a matching

SUMMARIZATION
Select whether you wish DEVONthink to
summarize based on sentences or whole
paragraphs.

document isn't detected, DEVONthink
will create a new rich text document,
prepopulated with information defined in
the Template section below.
Square Brackets: WikiLinked text can
be defined using square brackets. Type

WIKILINKS

two opening square brackets and the
beginning of a document name. Then
press ⌥⎋ Option-Escape to show a list of
potential item matches in the database.
Choose a document and press ↩ Return to
complete the link.
Names and Aliases: Matches documents
based on their name or any aliases defined
in the Info Inspector.
All Items/Only Documents/Only Groups:
Choose whether to match only documents,

WikiLinks are a way to create interconnected

groups, or both.

documents in your databases. When enabled,

Case-insensitive Linking: Enable this to

DEVONthink attempts to detect other

ignore capitalization when matching Names

documents matching the terms you've

and Aliases, e.g., GlobalEconomy and

typed. This creates an active hyperlink to the

globaleconomy both would match.

detected document, allowing you to quickly

Open new documents in separate

jump to it by clicking the link. WikiLinked text

windows: When clicking a WikiLink, the

displays with as underlined text.

linked document will open in its own
document window.
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TEMPLATE
Text and items entered here will be used to
create a new WikiLinked document. You can
type any text you want as well as Controlclick and use Insert Placeholder to insert a
token that will be automatically replaced
when the template is created. The default
title contains several of these tokens already.
Check out the placeholders section of the
appendix for information on the available
choices.

Select group: A group selector is shown
that lets you choose the destination. The
group selector appears as a black panel
floating on top of all other windows. Use it
to select the group where you want to file
the items.
Global inbox: The data is stored in the
global inbox.

TEXT ENCODING
Choose the default encoding used for plain
text documents. Select Automatic to let

IMPORT

DEVONthink choose the best encoding.

TAGS
Imported files can have metadata that may
be useful as tags. Choose options to convert
specific types of information to DEVONthink
tags.
Convert keywords to tags: Check this to
convert embedded keywords from PDFs
and RTF(D) files to tags.
Here you can choose options for the location,
encoding, and tagging of files coming from
external sources, including bookmarklets,
DEVONagent Pro, items dropped on the dock
icon, (external) scripts, or services.

Convert properties to tags: Check this to
convert embedded properties from PDF
and RTF(D) files to tags.
Convert geolocation to tags: Check this to
convert proper names of geolocation data
to tags, e.g., "Orlando", "FL", and "United

NEW NOTES

States".

Check Select (and display) automatically to

Convert Hashtags to tags: Check this to

automatically select and display the last note

convert found hashtags to tags.

you have taken.

Add tags to images: Check this to
automatically apply tags to imported

DESTINATION

images.
Scan Barcodes: Check this to allow

Choose the default destination where

DEVONthink to try and detect a barcode in

incoming data is stored.

an imported image. The detected barcode
will be added as custom metadata
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These options are honored by email archiving,
scanning and OCR, importing from Bookends,
Evernote, Apple Notes, and Yojimbo, as well
as documents created via the Sorter and the
web interface (Server edition only).

HOTKEYS
Set system-wide hotkeys for: Take Note, Copy
Selection, Clip to DEVONthink, and Search.
To change the hotkeys, click the Click to
record shortcut button, then press the

SORTER

hotkey that you want to use. Press the
⎋ Escape key to cancel recording a new
shortcut.
Note: On macOS Mojave, you will be asked
to grant Accessibility permissions for Copy
Selection, and Automation permissions for
Clip to DEVONthink.

MEDIA

The Sorter preference allows you to choose
the window's appearance and location, and
assign a hotkeys for capturing data or taking
a new note. See also p. 52ff

APPEARANCE, LOCATION,…
Appearance: Choose to display the Sorter
as a menu extra, a docked tab on the side
of your screen, or not at all.
Position: Choose the onscreen position
of the docked tab. These options will be

In the media preferences, you tell

disabled if Show as Dock Tab isn't selected.

DEVONthink how to display multimedia files,

Menu Extra Title: Choose whether to

images, PDFs and other documents. You can

show the menu extra as text, or a space-

also set options to generate thumbnails for

conserving icon.

certain filetypes.

Screen Capture: Check this to play the
system default screen capture sound.

Media: Check Play automatically to play
audio and video files automatically when
you display them. Check Loop if you want
to play the clips in a loop. You can also
choose a background color for viewing
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movies. Check Automatically resize to

COLORS

toggle the automatic resizing when viewing
PDFs.
Images: Choose a default zoom factor and
a background color for viewing images.
PDF Display: Choose the default display
mode for windowed and full screen modes
and set the background color for viewing
PDFs. Check Automatically resize to
automatically resize PDFs in the view/edit
pane.

Label: Set the name of color for color labels

Markdown: Choose whether you want to

applied to files and groups in your database.

open Markdown documents by default
in editing or preview mode. If you want
to choose a stylesheet used to display
your Markdown documents, click the

Highlight: Set the name and color to be
used for highlighting text in compatible file
formats, like PDFs.

Select button to access stylesheets

Note: These are global settings, i.e., you

stored in ~/Library/Application

can't have per database label or highlight

Support/DEVONthink3/StyleSheets.

colors. Also, following Apple's example,

Check MathJax support, if you need

we only allow setting seven colors in each

mathematical formulae to be rendered

category.

in your Markdown documents. (See the
MathJax site for more information.) Check
Prism support to use syntax highlighting

WEB

with fenced code blocks in rendered
Markdown documents.
Sheets: Select whether to display sheets
in Table View or Form View and set the
background color when viewing the table.
Create Thumbnails: Check all document
types for which you want DEVONthink
to create thumbnails. For images, check
Generate from actual image to ignore
thumbnails embedded into the image
files and let DEVONthink generate the
thumbnails from the actual image.
The web preferences resembles the settings
of most web browsers. Use these preferences
to define how DEVONthink's displays web
documents and "live" web pages.
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WEB CONTENT

ACCEPT COOKIES

These settings define how DEVONthink

Cookies are little text files with information

treats special web contents:

that web pages store on your computer use

Enable ...: Check these options to use
installed third-party plugins, (such as Flash
or RealPlayer plugins), and to run Java
applets or JavaScript scripts contained in,

to recognize you as a returning customer,
among other things. While most cookies are
harmless, you may want to control what is
being stored on your hard disk.

or linked to, a web page.

Always: Accept all cookies.

Block ...: Check Block pop-up windows to

Never: Don't accept any cookies.

block pop-up windows, which are often

Only from sites you navigate to: Accept

advertisements; check Only automatic

cookies, but only from web sites you

JavaScript windows to block only pop-up

navigate to (not from other sites, such as

windows opened by JavaScript. Uncheck

ad trackers).

this option if the web page you're visiting

Delete cookies on quit: Delete all stored

uses pop-up windows for actual content.

cookies when you quit DEVONthink.

(Some web content management systems
do this.) Check Block zooming to keep web
sites from automatically zooming windows
to full size. Check Block advertisement
to block common inline advertisements
provided by some search engines.

FONTS
Set the fonts you want to use for displaying
web pages; set separately for variable-width
and fixed-width text.

Zoom text only: Check to zoom only the

Note: Hold the ⌥ Option key to restore the

text and uncheck to use Safari-4-style

default fonts.

zooming.
STYLE SHEET
IMAGES
You can further control the way DEVONthink
These settings define how DEVONthink

displays web pages by applying a CSS style

displays graphics in web pages:

sheet that changes the rendering on the fly.

Display images when the page opens:

Click Select and choose your style sheet to

Check this option to display web pages

apply it to DEVONthink's integrated web

with images. Just remember, if unchecked,

browser. Note: This is for experts since it

you may miss some information.

modifies how all web pages are displayed and

Animate images, Loop animation: Check

can lead to undesired effects.

these options to run web graphics
animations and to run animated graphics in
a loop.
Scale images to fit: Check this option to
scale (large) images to fit.
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TEXT ENCODING
Select your desired text encoding for
displaying web pages. Automatic tries
to choose the best available encoding. If
this does not work for you, choose a more
appropriate text encoding for your language
group.

Feed Format: Choose a file format for
the downloaded articles. (RSS articles are
presented as HTML files, by default.) Check
Use clutter-free layout to try to remove
unwanted ads, etc. from the article.
Feed Style Sheet: For HTML (Feed Format:
Automatic) articles, DEVONthink comes
with multiple styles for displaying them.
You can use your own RSS stylesheets by

RSS

placing them into ~/Library/Application
Support/DEVONthink 3/StyleSheets.

DATA

DEVONthink comes with built-in RSS
capabilities that enable you to add RSS feeds
to your database and have DEVONthink
update them automatically. Use these
preferences to define how often DEVONthink
checks for new articles, whether to skip
duplicates when updating feeds, when to
remove older articles, and which CSS style
sheet to use for displaying the articles.
Check for updates: Set how often you want

Here you can define custom metadata fields
that can be assigned to your documents.

CUSTOM METADATA

DEVONthink to refresh your feeds.
Convert categories to tags: Some RSS
articles have tag metadata to help people
more easily navigate the publisher's site.
Check this option to convert these to
DEVONthink tags. Note this can add a

The Custom Metadata column contains a
range of built-in fields, ready to use or modify,
as needed. These cover a variety of common
uses and a list of the pre-defined fields can
be found in the Data section of the appendix.

great number of tags to your database.

Enable any field by checking the checkbox

Remove articles: Set how often older

next to it. Use the buttons below the Custom

articles are removed from the feed. Check

Metadata column for extra options:

Also unread articles to remove them, even
if they're unread.
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Add: Click the + to create and name a new

EMAIL

custom field.
Remove: Click the - to remove any field.
Action: Select any field and click

for

more options, including duplicating and
renaming the selected field.
The order of the fields is also the order in
which they appear in the Info inspector.
Note: These options are also available from
the contextual menu.

PROPERTIES

Use these options to define how email is
imported and displayed inside DEVONthink.

Use these controls to modify the properties
of the selected field.

CONVERSATIONS

Identifier: This is a special name used in

Import complete conversations:

automating with AppleScript. The term is

DEVONthink can import not only selected

derived from the field's name, and cannot

email messages, but also other messages

be entered or modified manually.

related to a conversation. Check this box to

Type: This is the specific type of the

let DEVONthink scan your Sent Messages

current field. Choose one of twelve data

folder and import sent messages that

types, such as Date, Boolean, Decimal

belong to the same conversation.

Number, or Languages.

Group conversation threads: Check this

Format: Only displayed with certain data

option to combine all messages belonging

types, you can choose some pre-defined

to a conversation thread into a group. This

formats, like Percent. With the Currency

makes identifying conversations easier

option, you will have an option to enter a

and automatically adds structure to the

currency symbol.

imported messages.

Values: Only displayed with the Singleline Text and Set types, define a list of

Note: These features only work if the email

items to choose from. These choices will be

program maintains references to previous

displayed in a dropdown menu when in use.

messages sent.

Add and remove the items with the + and buttons. Control-click an item to change it.

MESSAGES

Note: Please refer to the Data section for

Previously imported will become

more detailed information on the data

replicants: Check this option to import

types.

previously imported messages again as
replicants. When this option is unchecked,
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DEVONthink skips previously imported

contain tables or footers formatted with

messages.

spaces.

Use alternative view: Check this option to

Color quoted text: Check to mark text

view email messages as text alternative by

quoted from previous recipients in

default.

messages. Click the color buttons to
change the color for first, second, and third

MESSAGE CONTENT
Fallback text encoding: When decoding
an email message, DEVONthink uses
the message's encoding information.
When there is no encoding information,
DEVONthink uses the encoding that you
set in this pop-up menu.

level quotes.
Labels: Select which labels you want to
assign to messages that were flagged
or marked as "high priority". Since items
can only have one label at a time, flagged
messages are treated as more important
than messages marked as "high priority".

Download remote images in HTML

Note: The first two options above only

messages: Check to store the image

modify the display of email messages in

references required by HTML messages

the text view. By default, messages are

in the database. Spammers and other

displayed using QuickLook.

unfriendly agencies may use these images
to track if you have read the message.

OCR

Therefore this is unchecked by default.
Decrypt secure messages: Check this to
decrypt and file secure email messages.
This allows DEVONthink to search or apply
AI-based functions such as Classify or See
Also to them.
Note: The email message will be stored
decrypted in the database package.
Its contents are available from within
DEVONthink and to other applications or
Spotlight.
DEVONthink contains an optical character
FONT, QUOTED TEXT, LABELS

recognition (OCR) module that allows you to
import scanned documents and make them

Use fixed-width font for plain text

searchable. These documents are "read" by

messages: Check to show plain text

the embedded OCR engine and stored as PDF

messages using a fixed-width font such

files that contain an additional (invisible) text

as Courier. This is useful if the messages

layer with the recognized, computer-readable
text. Use these options to fine tune the OCR
process.
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You can import scanned documents, or scan

When checked, the metadata entry dialog

them directly from within DEVONthink.

will appear whenever you scan a document
or import an image file with OCR. You may

CONVERT INCOMING SCANS
Check Convert to searchable PDF to

want to switch this option off when you are
scanning/importing multiple files in a batch.

apply OCR to file that have been sent

Note: Information you enter in this dialog

to DEVONthink from a known scanning

will be available to Spotlight and can

software, e.g., ScanSnap Home. Choose

be changed in the Preview application.

the desired format of the resulting file:

The title field will be used to name the

searchable PDF, RTF document, Word

document, the keywords will go into the

document, or WebArchive.

Comments field, and the creation date will
become the creation date of the document

ORIGINAL DOCUMENT
Check Move to Trash if you want DEVONthink
to move the original documents to the trash

in DEVONthink. You can access this
information in the Document Properties
panel.

after they have been successfully imported

Check Compress PDF to apply compression

using OCR. If files are converted by OCR

to the resulting PDF, creating a smaller

within the database, the original document

file. Compression only applies when

is deleted from the database. If files are

adding metadata post-OCR or preserving

converted at import, the original document is

annotations from an original PDF after OCR.

moved to the Finder's trash. Using this option
is a great way to prevent your incoming
group/folder or database from growing
cluttered after OCR is done.
Note: This option cannot delete files

RESOLUTION
Set the desired resolution for the image layer
in the PDF. Only values between 150 and 300
dpi are allowed.

received from the ScanSnap software.
AUTO CORRECT
SEARCHABLE PDF
Check Enter metadata after text recognition
to metadata entry dialog whenever a PDF is
imported using OCR. Use this dialog window
to enter the preferred document name, the
author of the document, and any keywords
describing the document. You can also adjust

Check Deskew to allow DEVONthink to
attempt to straighten the resulting PDF.
Check Page Orientation to allow DEVONthink
to detect and correct the page orientation.

DICTIONARY AND LANGUAGES

the timestamp of the PDF to the actual date

Custom Dictionary: Check Use Dictionary to

of the paper document. The dialog window

use a custom dictionary of acceptable words.

is shown when OCR processing has been

For example, you may have an unusual spelling

completed.
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of someone's name in some documents. You

IMPRINTER

can enter the name as an acceptable choice
for the OCR engine to choose from.
Click the Configure button to add custom
entries for OCR detection. Note you can
only have one dictionary, specified for the
language chosen in the Language dropdown.
Languages: The Languages section of the
OCR preferences lets you identify the
languages of the documents you scan
in. DEVONthink's OCR engines uses this
information to improve the accuracy of
the text recognition. DEVONthink comes
with more than 150 different language
dictionaries.

Imprints are custom bits of data that can be
stamped onto images or the pages of PDF
documents. Imprints can be used in a variety
of ways, from stamping when an invoice was
paid to adding specialized numbering. With

Select the languages you intend to scan or

the ability to include placeholders, you can

import with OCR. Set a primary language

create many kinds of watermarks for your

and add one or more secondary languages

documents.

using the pop-up menu . Simply select the
languages you want to use from the list
on the right (Available) and move them to
the left side (Selected) using the right-toleft arrow button. To deactivate a selected
secondary language, select it from the list
on the left and move it to the right using the
arrow button. You can select a maximum of
four secondary languages.
Note: The primary language and the
secondary languages are treated equally.

CONFIGURATIONS
This column lists any custom imprints
you've already created. Click an existing
configuration to change its appearance or
location on future documents, or click and
release to change the name. Use the buttons
below the Configurations column for extra
options:
Add: Click the + to create and name a new
custom field.
Action: Select any field and click

for

more options, including duplicating,
renaming, and deleting the selected
configuration. A special item in the menu,

DEVONthink 3.6 Documentation, page 163

New Combined Configuration is discussed

to define sections of the watermark with

below.

placeholders. Any of these items can be

Preview: Click this button to see an

can be reordered easily by dragging and

example of the imprint, as specified by the

dropping.

current settings.

Font: In the Font options, choose the

New Combined Configuration: Found in the
action menu, this option allows you to create
new imprints from your existing ones. This
extends the usefulness of existing imprints.

font, weight, color, and other styling for
the watermark. If you choose the outline
style, you can choose the Thickness of the
outline.
Border Style: Choose and style a pre-

From the action menu, select the New

defined border, if desired. When using a

Combined Configuration option. Two panes

border, you can also specify the border

will be displayed: Combined and a second

Color and Thickness and an optional Fill

Configurations pane. In the righthand pane,

color.

select an existing configuration and click
the < button to add it to the Combined pane
in the center. To remove an item from the
Combined pane, select it and press the >
button. It will reappear in the Configurations
pane on the right. Combined items will be
displayed in the order you add them. To see

Note: There is only one font style for the
watermark. You cannot have mixed styles,
e.g., displaying one word larger or in a
different color.

LOCATION

what the imprint looks like, press the Preview

In the Location tab, choose and fine-tune the

button.

position of the watermark, as well as on what

Note: DEVONthink remembers the location

pages it will appear.
and styling of the individual imprints in a

Position: Choose a general position for the

combined configuration.

imprint to appear on the document.
Offset X/Y: Fine-tune the position of the

GENERAL OPTIONS
Check Duplicate item before imprinting to
duplicate the document before imprinting it.

APPEARANCE

watermark. Negative values are to the left
(X) and down (Y). Positive values are to the
right (X) and up (Y).
Rotate: Set your imprint on an angle, if
desired.
Occurrence: Choose what pages the

Use these controls to define the parts of the

imprint should appear on. Use Custom to

watermark, its font attributes, and the style

have the imprint appear on specific pages.

of a containing box, if desired.
Title: This is the body of the imprint. Type
any static text you want to appear in the
imprint. Right-click > Insert Placeholder
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SERVER

To learn more about using web sharing and
how best to make your database available
from the "outside" internet, please read on
here.

GENERAL
Start on Launch: To automatically start
DEVONthink's web server as soon as you
launch DEVONthink, check this checkbox.
Convert images & PDF documents
to searchable PDF: Check this to
automatically convert all images and nonDEVONthink features a built-in web server
that allows you to share documents on your

OCRed PDF documents added from web
sharing users to searchable PDFs.

local area network, and optionally, over the
internet. As soon as the web server starts,

BONJOUR SETTINGS

other users can use a standard web browser

Use these settings to define your

to search your database, view documents,

DEVONthink server's identity, everything

and download them.

from the name and port, to creating a

Note: In order to operate properly,
DEVONthink needs to be running and will
only serve open databases.

certificate vouching for the "safety" of the
server's activity.
Identity:

Enter all necessary details in the General tab

Bonjour Name: Enter a distinct name for

and define users and permissions in the Users

your computer here that identifies it on

tab. Then click the Start button to start the

the local network using Bonjour. This name

web server available to users whom you have

will be shown in the list of Bonjour services

allowed access.

on other Macs on your network. Switch

As soon as the server starts, DEVONthink
shows the name and two URLs for your
database at the bottom of the window.
Use either the Bonjour services list of the
Bookmarks view in Safari or enter the listed
URLs into the address field of your web
browser to access your database. Use the
numeric address if the Bonjour does not work
for your network.

to the Bookmarks view in Safari or your
preferred browser and select Bonjour in the
sidebar.
Bonjour Domain: Set the Bonjour domain
if necessary. Leave this field empty unless
you know what you're doing.
Port: If left empty, DEVONthink will assign
a random, unused port when the server
launches. If the server will be accessed
regularly, or from outside your network,
setting a static port is suggested. As nonDEVONthink 3.6 Documentation, page 165

standard ports can be prohibited on some

USERS

networks, consult with your IT department.
Security:
TLS Certificate: If you have a TLS
Certificate, select it from this dropdown.
P12 Certificate: If you have been issued a
P12 file, import it by clicking the Load P12
file button.
Self-signed Certificate: If you have neither,
it's possible to generate a self-signed
certificate for the server. When this option
is chosen, users connecting to the server
will be prompted the certificate may be

User List: The Users tab on the left allows you

insecure. Instruct them to accept your

to add and remove individual users, as well as

certificate as valid to allow their browser to

set per database permissions for them.

accept your server's identity.
Allow insecure HTTP connection on
port: DEVONthink's server runs on SSL
connections for secure browsing. If you
have a compelling reason to use the older
http protocol, check this box and enter the

Add: Click the + button to add a new user.
Remove: Click the - button to remove a
user.
Password: Enter a login password for the
selected user in the Password field under
the Databases list.

port to be used.
Note: If you have DEVONagent Pro
Note: When using the server in
administered networks, e.g., public,
corporate, or educational scenarios,
you may need to consult with the IT

installed, it will be added as a default user.
This allows it to search DEVONthink's
databases in the same way it searches
other websites.

department for successful operation.
Database Permissions: The Databases list
on the right allows you to set per-database
permissions for the selected user. All open
databases will be listed in this pane, followed
by the permissions that can be set. When a
user is selected in the Users pane, you can
set specific permissions for that user. The
permissions are as follows:
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Read: Allow the user to access the

SYNC

database. When unchecked the database
will not be visible to the user.
Download: Allow the user to download
documents from the database.
Add: Allow the user to add items to the
database.
Organize: Allow the user to move around
documents and groups in the database.
Delete: Allow the user to delete items in
the database.
Note: Right-click the database's name to
quickly enable or disable all permissions for
that database.

DEVONthink allows you to keep your

Technical Info: If you need more information

databases in sync with multiple Macs and

on the activity of the web server, you can find

iOS devices running DEVONthink To Go. Use

some deeper details here.

these options to control which databases are
synced, how often they're synced, with which

Server Details: The section under the
Databases pane shows some basic
technical data about DEVONthink's server

locations. Learn more about synchronization
and how to set it up in a separate part of this
documentation.

activity.
Log: In cases where deeper technical

LOCATIONS

information about the server's activities is
required, click the Log button in the lower

The first column lists all sync locations you

right corner. The log file will open in macOS'

have set up. In addition it lists available

Console application.

direct connections and templates for quickly
setting up new locations. Active locations
are checked. Disabled, inaccessible, or
unactivated locations are shown in grey.
Locations that have an encryption key
specified show a key icon to the right of the
name.
Check any location to activate it. If it is
not yet set up, DEVONthink will show a
sheet requesting all necessary details. Only
a subset of the following fields is shown,
depending on the nature of the sync location:
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URL: The URL of your WebDAV volume

Use the tools below the locations list for

including path to the folder where the sync

more options:

store is located or shall be created.
User name: The user name for the service.
Password: The password for the service.
Sync Store Name: The name of the sync
store. If you are setting up an already
active sync location, e.g., you've already
synced from another device, click the
dropdown menu to choose from a list of

Add Location: Click the + icon to add
locations not listed by default, e.g., adding
another local sync store.
Remove Location: Select a location and
click - to remove the location.
Show Info: Select a location and click to
show and change the location properties.

existing stores.

Action (Locations): The Locations

Encryption password: The password used

Action menu also is used for information,

to encrypt the sync store with AES 256 bit

troubleshooting, and removing chosen sync

encryption.

locations. In addition to Show Info, and

Synchronize label names & colors: Check

Remove Location, it contains these special

if you want to bidirectionally synchronize

commands:

label names and colors using this location.
Be aware, changes to the colors and names
on any syncing machine will sync to the
others.
Synchronize reading positions: Check if
you want to bidirectionally synchronize
reading and playback positions using this
location. This can help you keep your place
in PDFs you're reading or audio/video you're
playing.
Synchronize content of indexed files:
Check if you want to synchronize the
content of indexed files using this location.

Reveal in Finder: Opens a Finder window
with the chosen sync store selected. This
only applies to local sync stores.
Verify Location: Used in troubleshooting
situations, this quickly verifies the integrity
of the sync data of the chosen sync
location. Hold the ⌥ key to select Verify
Location Thoroughly.
Clean Location: Used in troubleshooting
situations, this removes the sync data for
all databases synced to the chosen sync
location.

If you uncheck this option only the

All the commands listed above are also

metadata about the document will be

available via the contextual menu.

synchronized. This is generally only used in
special circumstances.

Note: You can also add existing local

Verify uploaded items: Check to verify all

sync stores (packages with the file name

uploaded items to make sure that they're

extension .dtCloud) by dragging them into

intact. Usually only necessary on very

the locations list, DEVONthink's Dock icon,

unstable network connections or in case

or by simply double-clicking them.

you experience troubles with defective
files.
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DATABASES

you can double-click a remote database to

The second column lists all currently open
databases as well as all databases available
remotely in the selected location. The
Local section lists all open database and a
message about their sync status, e.g, the
timestamp of the last sync. The Remote

import it.
Synchronize Database: Select a checked
database and click

to manually sync the

database with this location.
Refresh List: Refreshes the list of remote
databases for the selected location.

section lists all databases available for import

Action (Databases): The Databases Action

or databases that are currently not open on

menu also contains commands for importing,

the machine. When attempting to import the

manually synchronzing, troubleshooting, and

latter, the local database will be opened by

removing sync data. In addition to Import

DEVONthink.

Database, Synchronize Database, and Refresh

Check any database that you want to have

List, it also contains these commands:
synchronized using the selected location. If

Import Encrypted Database: Import a

the database is also already available through

database as an encrypted database. You

the location, both versions of the database

will need to specify the maximum database

will be merged and conflicts solved using the

size and an encryption key. See also p. 11ff

chosen conflict solving strategy (see below).

This option can be used when importing

Uncheck databases you want to discontinue

any database, but it will not encrypt an

syncing with the selected location.

unencrypted database on the source.

Note: Unchecking databases does not
remove the sync data from the location.
See the Clean Database command below or
See also p. 174ff

Verify Database: Used in troubleshooting
situations, this quickly verifies the integrity
of the sync data of the chosen database.
Hold the ⌥ key to select Verify Database
Thoroughly.

Use the tools below the locations list for

Clean Database: Used in troubleshooting

more options:

situations, this removes the sync data for
the chosen database in the current sync

Import Database: Select a remote
database and click

location.

to download the data

of the database and save it locally. The

All the commands listed above are also

database will be automatically configured

available via the contextual menu.

to sync with this location. Alternatively,

Note: If you have specific databases you'd
like to remove from a sync location, e.g.,
old, no longer used or test databases, the
Clean Database command can be used on
select databases in the Remote section of
the Databases list.
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OPTIONS

BONJOUR OPTIONS

Change the general sync settings, noting they
affect all locations and databases.
Synchronize: Choose if you want to
synchronize automatically, manually,
or in fixed intervals. Check On Quit or
Deactivation to automatically synchronize
when you quit DEVONthink or when you
switch to another application.
Max. Connections: Choose the maximum
number of connections DEVONthink
should open. The faster your internet
connection the higher you can usually go.

Click the button Bonjour Options to control
if and how other instances of DEVONthink or
DEVONthink To Go can connect to your Mac.
Your Mac becomes the sync host or sync
server, the other devices the clients.

The recommended value is 16.

Enable incoming connections: Check to

Conflicts: Choose how to solve the conflict

let other devices connect to your copy of

if an item was changed both locally and

DEVONthink and synchronize.

remotely. Use latest document preserves

Open databases automatically: Check

the most recently changed document.

to open databases automatically if the

Duplicate documents keeps both versions

connecting side (client) requests it.

of the conflicting item and appends "copy"

Port: If needed you can change the IP port

to the end of one's filename.

number used for incoming connections.

Note: The number of maximum
connections used is controlled by the
service you're using.

Leave empty to let DEVONthink choose the
best port number for you (recommended).
Password: Set the password necessary to
connect to your instance of DEVONthink
(mandatory). This password is also used for
AES-256-bit-encrypting the connection at
all times.

DEVONthink 3.6 Documentation, page 170

TROUBLESHOOTING
IN THIS CHAPTER

Also, while DEVONthink supports importing

Problems importing files

171

Email import does not work as

many different file types, there are
thousands of types and we can't guarantee
trouble-free importing or usefulness with

expected

172

Unlocking a database
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Problems using Services
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Sync Issues
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Repairing a defective database

178

DEVONthink crashes

181

DEVONthink uses Apple's Quick Look

DEVONthink behaves irrationally

181

technology to display previews of many

DEVONthink was created with robustness
in mind. But any computer hardware or
software, regardless of how carefully
developed and built, can write defective data
or destroy files. If you have some general
questions about DEVONthink, sales and
licensing, etc., plase check out our Questions
and Answers section on our site. If you
experience specific technical problems with
DEVONthink or its databases, please check
the following sections.

every type.

WHY DOES DEVONTHINK NOT DISPLAY MY
DOCUMENT CORRECTLY?

file formats. If a document is not properly
displayed, especially if it is a proprietary file
format, it may be you don't have a Quick
Look plugin installed for this file type or
the application that created the file is not
installed on your Mac (and supports Quick
Look). Control-click the file and choose Show
In Finder to reveal it. With the file selected
in the Finder, press the spacebar to open a
Quick Look window to determine if the item
is viewable.

WHY ISN'T MY PDF WORKING?

PROBLEMS IMPORTING FILES
Bad PDFs: PDFs have been around so long,
WHY DOES DEVONTHINK NOT RECOGNIZE

it would seem they'd be easily supported in

MY FILES?

DEVONthink. However, the truth is there are
many bad PDFs out there. If you encounter a

If DEVONthink does not recognize a file, make

bad PDF, try acquiring a new copy of the file.

sure the file has a proper file name extension.
DEVONthink needs a file name extension to

No Text: You will receive a "No Text" log

determine the file type. Add the correct file

message with PDFs having no text layer, i.e.,,

name extension to your files (e.g., .txt for

scans that have not had OCR run on them.

plain text files, .rtf for rich text files, .pdf
for PDFs and .doc for Microsoft Word files)

In order for their text to be searchable, you
must run OCR on them.

and try again.
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Protected PDFs: DEVONthink cannot extract

Importing takes a long time or stalls:

the text part of print- or edit-protected

Importing email is not a trivial process. Not

PDFs. When you import these PDFs, you get a

only does it copy the message into your

log entry that tells you that the file contains

database, but it also reads and analyzes

"no text". When you select these PDFs in

the entire contents of each one. If you are

DEVONthink, the status bar shows Image

importing a large mailbox, the process could

instead of PDF+text.

cause a timeout.

One potential solution for this problem is

To increase the timeout to five minutes,

Michele Balistreri's PDFKey. It allows you to

please enter this in /Applications/

print protected PDFs. Use PDFKey to "print" a

Utilities/Terminal.app (each as a

PDF file into a new PDF that is both printable

separate command) while DEVONthink is not

and editable, which allows DEVONthink to

running:

extract the text for searching and classifying.
Note: There are sometimes questions
regarding the PDF functionality available
in other applications. DEVONthink uses
Apple's PDFKit framework, the same as
found in their Preview application. If you
have an issue with a PDF in DEVONthink,
check to see if you have the same issue

Terminal:
$ defaults write com.devontechnologies.think3
MailImport.FetchTimeout -float 300
$ defaults write com.devontechnologies.think3 MailImport.Timeout float 300

in Preview. Other applications, including

Another possibility is to split the mailbox

those from Adobe where PDFs were

into multiple smaller ones. Lastly, you don't

invented, are using their own frameworks.

have to import the entire mailbox at once.
Importing smaller batches often proves to be

EMAIL IMPORT DOES NOT
WORK AS EXPECTED
Messages aren't imported or can't be filed:
Email messages are imported with a special
identifier (UUID) that helps DEVONthink
keep track of messages that have already
been imported. Since a UUID must be unique,
you can't have more than one file with that
identifier. If you try to import the same
message into a database, you will receive
a logged message stating "n emails already
imported".

less taxing on the machine's resources.
Why can't I import from email application
X?: Inter-application communication,
something at which DEVONthink excels, isn't
universally developed. In order for more true
automation between applications to occur,
the developers need to implement robust
and reliable mechanisms, like AppleScript.
Some apps may provide simple URL schemes
but they are limited in use and capabilities,
often only able to process one file at a time.
Better results can usually be had by merely
dragging and dropping. For email clients with
a good AppleScript dictionary, the potential
for streamlined workflows is increased.
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Note: If you are running macOS Mojave or

other databases, do a Spotlight search for

later, you will need to give permissions for

kind:database dtBase2.

the Apple Mail plugin to access your email.

Select the database file and press ⌘I to

Quit DEVONthink.

show the Info pane.

Quit Apple Mail.

At the bottom, you'll see Sharing &

Enable Full disk access in System

Permissions. Click the lock icon to unlock

Preferences > Security > Privacy for

it. You will be prompted to enter your

DEVONthink.

administrative password. (This is the

Launch DEVONthink and install (or

password you use to log into your account

reinstall) the Mail plugin from the

on your Mac.)

DEVONthink > Install Add-Ons.

Make sure the account marked (Me) is set

Launch Apple Mail and enable the plugin

to Read & Write.

via Apple Mail > Preferences > General >

Click the Action menu and choose Apply to

Manage Plug-ins.

enclosed items, if it is available, then close
the Info pane.

UNLOCKING A DATABASE

Double-click the database file to reopen it
in DEVONthink.

If you open DEVONthink and see an icon of a
crossed pencil to the right of the database's

If this does not resolve the issue, please

name, the database has a file permissions

contact our support team.

issue. This makes the database readable,
but not writeable, so you can't modify the

PROBLEMS USING SERVICES

contents in any way.
A permissions issue like this uncommon
but generally caused by three events, in

WHY DO THE SERVICES MENU COMMANDS
SHOW NO SHORTCUTS?

order from most to least common: restoring

They should; however, the keyboard shortcuts

from Apple's Migration Assistant, restoring

for Services menu commands are only

from Time Machine, or an operating system

requested by the supplying application.

or hardware error. Doing things like using

macOS assigns these shortcuts and has

Migration Assistant will not always cause a

ultimate control over which application

permissions issue, but if you have a crossed

or service gets what. If the DEVONthink

pencil icon and you've recently migrated to a

Services menu items do not have shortcuts

new machine, this would be the likely cause.

assigned, it is likely that macOS assigned

To resolve the issue, do this:
Close the database in DEVONthink.

these shortcuts to another command, or
that they are used by the current active
application.

Locate your database. If it's the Global
Inbox, it's located in ~/Library/
Application Support/DEVONthink 3. For
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WHY DO SPECIFIC SERVICES NOT APPEAR

a remote service, the Sync Store Name

IN THE MENU?

dropdown should list available sync stores

The operating system relies on information
supplied by the current application to
determine which services should be shown
in the Services menu. For some applications,
often those developed for both Mac and
Windows, this information may not be
what's anticipated. When this occurs, certain
services may not be present. For example,
selecting text on a web page in Firefox will

to choose from.
Make sure you're using the correct
encryption key value for the sync location.
See also p. 177ff
Make sure you have sufficient space for
sync data, especially when using cloud
accounts.

VERIFY & CLEAN

display the service DEVONthink: Take Plain

Verifying: If there is an issue reported with

Note. The same text on the same page

syncing, e.g., broken structures or missing

in Safari will show that option as well as

manifests, you can verify the sync data to

DEVONthink: Take Rich Note.

see if it's intact and consistent. Verification
is a good first step in these cases. The results

SYNC ISSUES

of a verification will be reported in the log
window.

DEVONthink's synchronization was designed
to run in self-maintenance mode. If you are

Cleaning: If the verification fails, you can

having issues syncing your DEVONthink

clean the sync location or database to

databases, the first place to look is Windows

remove the sync data in that location. The

> Log. Most sync related errors and reports

results of the clean will be reported in the

will be shown here.

Log window. After a successful clean, you can
upload the database(s) again.

Below we cover some things you can check
for the type of sync method you're using as

Note: To ease anyones' mind, cleaning a

well as some common questions you may

sync location has no effect on the local

have.

databases on your devices. Sync data is
not your database and is separate from the

THINGS TO TRY FIRST

local databases on your devices, Mac and
mobile.

Here are a few general things to try when you
have a sync issue:

To verify or clean sync data, open Preferences
> Sync and…

Check your network connections, including
trying to log into a remote service.

Sync Location: To clean or verify all

Reboot the computer

the sync data from a specific location,

For non-Bonjour and non-iCloud sync

Control-click it and choose the appropriate

locations, make sure you're entering the

command. For a verification you can

correct store name. When logged into

hold the ⌥ Option key and choose Verify
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Location Thoroughly to perform a deeper

Make sure you have entered the same

verification of the sync data. For a remote

password that you have set in the server

sync location, there may be a pause while a

Mac's Bonjour options. See also p. 167ff

connection is established.

Make sure DEVONthink is running on the

Database: To clean or verify the sync data

other Mac or iOS device and both devices

for a specific database, select the sync

are awake.

location to display the databases list.

Make sure only one device is acting as the

Control-click the specific database and

Bonjour server for a given database. You

choose the appropriate command. For a

should not have two devices with incoming

verification you can hold the ⌥ Option key

connections enabled trying to serve the

and choose Verify Database Thoroughly to

same databases.

perform a deeper verification of the sync

Make sure the databases you want to

data. Repeat this with any databases, as

synchronize are open on the other Mac,

needed.

or enable Preferences > Sync > Bonjour

Both these actions can be used at any time,
for preventative purposes or just to get a
fresh start with syncing. Also, you may see
unwanted databases in the Remote section
of the databases list for a sync location.
Cleaning the location will remove these
databases too. But if you want to keep the
sync data for your current databases, you can
Control-click and clean specific databases in
the Remote section.

BONJOUR

Options: Open databases automatically on
the server Mac.
Restart the other Mac, the iOS device, or
both.
Make sure this computer is connected to
the same network as the other syncing
device.
Make sure any firewalls or applications
like Little Snitch are allowing traffic from
DEVONthink.
Check if there are any routers or switches
involved. The more switches and routers
the less reliable the connection due to

Bonjour syncs are generally transparent,

port filtering, conflicts, or other unknown

but it can only be used on a local network

factors.

that allows Bonjour traffic and non-standard

Restart your router.

ports. Many public networks disallow this
kind of traffic to protect their customers.
Also, corporate networks will often disallow
this traffic for security reasons.

If you find yourself on a network that
disallows Bonjour syncing, it is possible to
connect your iOS device to your Mac via your
Lightning cable. This creates a simple ad-

Note: Bonjour connections cannot be used

hoc network that will allow Mac-to-mobile

over VPN. This is technologically infeasible,

syncing. If you are in a corporate situation,

at least at the moment.

please discuss this with your IT department
to ensure you're not violating any security
policies. They may also issue an exception
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for a specific port you could use for Bonjour
syncing. This port would be entered in the
Port section of the Bonjour options.

ICLOUD

WEBDAV
Our support for WebDAV services allows
you to use cloud services that are WebDAVenabled. It also presents some self-hosting
options, even with some NAS devices.

Since your devices are generally signed into

However, they can sometimes be technically

your Apple ID, using iCloud for syncing is

more difficult to implement. Here are some

the easiest to set up. However, it should be

things to check:

understood it can only be used for personal
syncing. Collaborative syncing is not possible
unless all participants are sharing an Apple ID.

Make sure the service or device you're
trying to connect to is reachable. This is
especially true when self-hosting. If you see

Also, syncing to iCloud is done locally first,

errors in the 500 range in the Log window,

the operating system will then upload the

it's a problem with the remote server.

changes to Apple's servers and propagate

Make sure you are using the proper

the information about it to all other devices.

protocol in the URL, http:// or https://.

It generally happens smoothly and in the

Make sure the URL is complete. This will

background but it means you can't expect the

be specific to the device or service you're

changes to be ready on other devices as soon

using. For a Synology NAS, for example,

as DEVONthink has finished synchronizing to

you have to add the target volume to

iCloud.

the path (a valid URL would look like:

Here are a few things to check:

http://diskstation.local:5005/
research). Refer to the service or

Make sure you have enabled DEVONthink in

manufacturer's instructions for the proper

System Preferences > iCloud > iCloud Drive

URL construction.

> Options on each device.

Make sure you have entered your user

Make sure all syncing devices are logged

credentials correctly.

into the same Apple ID.

Note: WebDAV implementations vary so

Note: Be aware iCloud can stall. This is a

it's not possible to guarantee compatibility

sporadic, but documented, issue that can

in all situations. For self-hosting, Apache

cause your devices to get out of sync. This

implementations are the most compatible.

is not under our control, nor can we even
detect it. Please try a thorough verification
of the sync location first. For further help,
contact our support staff for assistance.

DROPBOX
Dropbox is our longest supported sync
method and is generally reliable and a good
performer. However, there are a few things to
consider.
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According to Dropbox' rules, you cannot sync

a key, is stored for that sync location. This

across user accounts. You also can't share

value must be entered on other devices

the Apps folder between accounts. Also, they

syncing with this sync location.

only allow our sync engine to be logged into
one Dropbox account at a time. If you have
a work and a personal account, you can only
sync to one with DEVONthink.

You can't add, remove, or modify the
encryption key value for a sync location
after the first sync. If you want to make a
change, you must clean the sync location

Log into your Dropbox account to make

first. After, the clean, Control-click the sync

sure it's reachable. If you see errors in

location again, choose Show Info, and make

the 500 range in the Log window, it is a

the modification to the key. After the first

problem with the remote server.

sync, this will be the value stored for the

Make sure you are connected to the correct

location. Remember, you must change the

Dropbox account. The active account will

value on the other syncing devices. And no,

be shown under the sync location's name in

you do not need to do the clean on the other

the sync preferences.

devices before changing the value.

Collaborative syncing may be possible using

I am seeing a message about missing

a common Dropbox account, i.e., using the

manifests: Missing manifests are bits of

same username and password for syncing.

transactional sync data that cannot be

But again, you can only sync to one active

located by the sync engine. When this occurs,

Dropbox account at a time.

it can't validate the information about what
has been synced. This is not an issue with the

COMMON QUESTIONS
I enabled the sync and nothing's happening:
Our sync engine will not sync, upload or

databases. See the Verify & Clean section
above regarding verifying and cleaning the
sync data.

download, without being told to. We believe

It's telling me I have a duplicate database

in opt-in processes whenever possible.

UUID: As noted in the glossary, a UUID is

Merely enabling a sync location just sets up a

a unique value given to all DEVONthink

location to be ready to receive and transmit

databases. If you copy and rename a

data. You need to enable individual databases

database file in the Finder, this UUID is

to sync. If you have enabled databases to

preserved and DEVONthink sees two

sync, check Window > Log for errors.

databases with the same UUID. This will not

I'm seeing a message about an invalid
encryption key: When you set up a sync

sync correctly. Please contact our support
team for assistance on resolving this.

location, you have the option of entering an
encryption key. This is used to scramble and
descramble the sync data so it's stored in an
encrypted state. Once you've synced the first
time, this value, even if you aren't specifying
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REPAIRING A DEFECTIVE
DATABASE
DEVONthink databases are packages

case, the path no longer exists as the names
in the path have changed. Changing the name
back will resolve this.

containing of your files and the supporting

The second most common cause of missing

AI-based index. In rare cases this index can

files is people modifying the internal contents

get corrupted or out-of-sync. But as your

of a database. Some Finder replacement

files are stored separately, this is not the

applications, like PathFinder, allow you to

end of the world. If your database starts

access package files like normal folders.

behaving strangely, or if DEVONthink finds

The internals can also be accessed by other

inconsistencies during start-up, it is time for

methods, like the command line or the

some housekeeping.

Finder's contextual menu. If you delete or

First we'll deal with the two common terms
you'll see in a repair process: missing and

reorganize anything, you can easily cause
missing files.

orphaned files. Then we'll give you steps to

Dealing with missing files: Missing files are

try and restore some order in your databases.

reported in DEVONthink's Window > Log. To
deal with these files, Control-click the item

MISSING FILES

in the Log window and choose one of two
options:
Reveal: Reveals the item in the expected
location in the database. If the View/Edit
pane is visible, the expected file path is
shown beneath a document thumbnail.
This path is especially useful when dealing
with missing indexed files as it shows the
path in the Finder from which the file was
indexed. If the path shows the file inside

All documents in a DEVONthink database

a Files.noindex directory, you may use the

have a path the file system where their

following option if the file is of no concern

content file is located. This path is stored

or contact our support team.

for every document, imported or indexed. If

Move to Trash: If the missing file is of no

DEVONthink can't find a file at a path stored

value to you, this command moves the

in its index, it will be reported as missing.

file to the database's Trash. Then choose
the DEVONthink > Empty Trash command

The most common cause of missing files is
indexed files being moved in the Finder, or

to completely remove the file from the
database.

the indexed parent folder being renamed. In
the first case, the file isn't in the location it
was indexed from. Moving the file back into
place will resolve this issue. In the second
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ORPHANED FILES
Just as with any database application,
controlling the data flow in and out is a
critical process. DEVONthink should be the
gatekeeper of the files in its databases. If an
external agent, whether and application or
a user, adds files outside DEVONthink, they
will cause an internal inconsistency and lead

Note: Modifying the internal contents
of a database outside DEVONthink is
unsupported behavior and can lead to
broken or inconsistent databases. You
should only get into a database's internals
when instructed to by our support team.

STEP 1: VERIFY & REPAIR

to orphaned files when following the steps

As a first step, use >File > Verify & Repair

below.

Database to check your database's

The most common cause of orphaned files
is a simple and common one: attempting to
create revisions. Say you open a file, a Word
document, in an external application. As
you are reading it, you decide to make some
changes. You type your edits, and select File
> Save As (or File > Duplicate the file first).
The application most commonly will open
the Save dialog in the location of the original

consistency and allow DEVONthink to take
all necessary steps to repair any discovered
problems. This check will include reporting
any missing files, as discussed above, and
importing any orphaned files. If Verify &
Repair Database was able to repair your
database, use File > Optimize to optimize
your database and have DEVONthink create
an internal copy of the index.

file, in this case, inside the internals of the

Note: Verify & Repair isn't just for

database. You have just created an orphaned

emergencies. Running this command on an

file DEVONthink knows nothing about. So the

occasional basis is not a bad idea. In fact,

question becomes, how do I create a revision

if you're a fairly heavy user of DEVONthink,

without causing this issue?

running it weekly or bi-weekly does no

Duplicate: Duplicate the item in

harm. It's just a routine checkup.
DEVONthink first.

If Verify & Repair was not successful or your

Rename: Rename the duplicated item.

problems are not resolved, proceed with the

This can be quickly done by immediately

next step.

pressing ↩ Return, typing the change, then
pressing ↩ again.
Open and Edit: Now you can open the new
file and make your edits.
The other common cause is the same as
with missing files: getting into the database
package and adding files manually.

STEP 2: RESTORE FROM BACKUP
DEVONthink keeps up to two copies of the
index files in case that the index is damaged
beyond repair.
To restore the index file(s) from a previously
saved internal backup, hold the ⌥ Option key
and select File > Restore Backup. DEVONthink
presents you with a list of all available
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backups. Choose the latest one and click

Time Machine: Restore your database from

Open. This swaps the current set of index

your Time Machine backup or whichever

files with the chosen backup metadata

backup medium you use. If you don't use

(the current set of index files becomes the

Time Machine, we strongly advise you to do

backup, the backup becomes the current set)

so. External hard disks are cheap, and Time

so that data is never overwritten. Run File >

Machine makes backing up your important

Verify & Repair to check the consistency of

files quick and simple.

this index version and if everything is in the
right order use File > Optimize to optimize
your database and have DEVONthink create a
fresh internal copy of the good index.
If the backed-up index files are also defective,
try the other backups, if available. If all
backups are broken or corrupted, proceed
with the next step.

STEP 3: REBUILD YOUR DATABASE

Manual Rebuild: If you find yourself in the
unfortunate situation where you have no
backups, it may be possible to rebuild your
database manually, following these steps:
Locate the database (.dtBase2 file) in the
Finder.
Rename the file by adding, e.g., an xto the
beginning of the name.
Control-click the database and choose
Show Package Contents in the contextual

Since your files and DEVONthink's index

menu.

are stored independently within the

Copy the most recent backup folder where

database package, the index can be rebuilt

your database is located.

at any time without you losing metadata.

Copy the Files.noindex folder into the

However, we generally only suggest this when

copied Backup folder.

troubleshooting a database issue.

Rename the copied Backup folder to the

To rebuild the database from scratch, use
File > Rebuild Database. During the rebuild
process, the index is completely recreated.
Your actual files are not touched. Any
problems that occur during this process are
logged. Also, a new backup metadata set will
be created at the beginning of the rebuild.

STEP 4: RECOVER OR MANUAL REBUILD
If everything above failed, your database is
severely damaged. You have basically two
options:

previously used name and add the file
extension .dtBase2, okaying the extension
when prompted.
Double-click the new database file to open
it in DEVONthink.
Use File > Verify & Repair to ensure that the
database is operating properly.

STEP 5: CONTACT SUPPORT
If none of the above steps helped solving
the problems you have with your database,
please contact us with a precise-as-possible
description of your problem.
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Note: In a worst case scenario, if you do not
have a current backup of your documents
and a manual rebuild didn't work, you can
rescue your files manually, but you will lose
any group structure. To manually copy your
files from the defective database, show the
database package in the Finder, Controlclick it, and choose Show package contents
from the contextual menu. Copy the files
in the Files.noindex subfolder, which are

DEVONTHINK BEHAVES
IRRATIONALLY
No software on this planet is bug-free, and
if an application behaves irrationally there
is a good chance that your have just found a
bug. But there could also be another cause:
The application package could have become
damaged during an update or through a bug
in a totally unrelated piece of software on
your computer.

sorted by kind, to a safe location, e.g., the
desktop. If you want, you can create a new

STRANGE APPLICATION BEHAVIOR

database, re-import the files, but you will
have to rebuild the database's structures,
tags, etc.

If you see odd behavior like
menus disappearing or silently refusing to
do anything,

DEVONTHINK CRASHES
If DEVONthink crashes while it's running,
please hold the ⌥ Option key and choose

windows showing graphical artifacts,
or applications not opening at all or
opening with strange error messages,

Help > Report Bug.

the first step is to reboot the machine.

If DEVONthink crashes on startup, there is no

If that doesn't resolve the issue, try deleting

opportunity for you to use our bug reporting

DEVONthink's preferences files. Please quit

mechanism. However, you can manually

DEVONthink, launch Terminal app, and enter

retrieve the crash logs:

this:

In the Finder, hold the ⌥ Option key and

Terminal:

select Go > Library.
Open the Logs/DiagnosticReports folder
and locate the most recent crash report for

$ defaults delete com.devontechnologies.think3

DEVONthink. (The date and time is in the

Note: Rebooting a machine can often

filename.)

cure a host of issues, closing down rogue

Attach the crash log when you start a

processes, releasing memory, etc. We

support ticket.

suggest rebooting your devices at least

In either case, please try to reproduce the
crash before reporting it. Also provide enough

once a week, just to mitigate potential
issues.

detail about what you were doing at the time
of the crash.
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STRANGE BEHAVIOR RELATED TO

If you have checked the appropriate sections

DOCUMENTS

and didn't find your issue or a resolution,

If the strange behavior only happens with
a particular document, it is possible the
document is damaged, was created in a very
old or extremely new file format that is no
longer or not yet properly supported, or uses

please do the following: Hold the ⌥ Option
key and choose Help > Report Bug. This
creates a draft email, ready to send to us,
containing troubleshooting information and
logs.

a damaged or malfunctioning Quick Look

Note: The industry standard turnaround

plugin.

in software development is 48 business

Please file a support ticket and attach
the document in question, packaged as
a .zip archive, so that we check to see if the

hours, i.e., weekends excluded. However,
we usually respond earlier. Thanks for your
patience and understanding.

problem lies with DEVONthink or if it the file
itself.
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AUTOMATION
IN THIS CHAPTER

extraordinary. This mature but easy to learn
technology is the one we will focus on. See

AppleScript

184

Basic AppleScript Terminology

185

Internal Scripts

188

Smart Rules: DEVONthink also offers

Triggered Scripts

188

a technology for those with little to no

Reminder Scripts

189

programming experience: smart rules. Smart

Toolbar Scripts

189

rules are conceptually similar to smart groups

Smart Templates

190

but allow you to choose pre-defined actions

Smart Rules

192

to take on matched items. This makes them

Smart Rule Scripts

193

accessible to all users, while still providing

Apple Mail Rules

195

AppleScript execution in the smart rules.

Application Scripts

196

They also allow automation based on events.

Folder Actions

197

See also p. 192ff

Automator

198

Item links

199

URL Commands

200

also p. 184ff

Item Links: While not an automation
technology in itself, item links are itemspecific identifiers in DEVONthink that can

Automation. No matter how efficient we

be used in automation. Providing a way to

are, there is always some process that could

refer to files by a unique and unchanging

be done more quickly, and sometimes more

value, they can help avoid automation

accurately. This may be as simple as renaming

problems when items are moved or renamed

a file, or as complex as filing, emailing, and

in your databases. See also p. 199ff

archiving. While not everything can be
automated, and careful thought should go
into your automation plans, DEVONthink
offers a level of automation capabilities rarely
rivaled in other Mac applications.

JavaScript: In addition to AppleScript,
JavaScript for Automation (JXA) is
supported. However, it is bridged by the
operating system from AppleScript,
not specifically coded for. We advocate

AppleScript: Most of DEVONthink is built

AppleScript for its ease of use by new and

on a solid foundation of AppleScript. Not

less-experienced programmers.

only used in the scripts you can install from
DEVONthink > Install Add-Ons, they are
also at the core of several pre-installed
templates. Additionally, in conjunction with
other AppleScript-enabled applications,
the potential for automation on your Mac is

On a side note, our AppleScript dictionary
has a do JavaScript command you can use
to interact with web content viewed in a
DEVONthink window. With a bit of creativity,
some pretty amazing things can be done!

DEVONthink 3.6 Documentation, page 183

AppleScript Objective-C: This is supported,

by choosing DEVONthink > Install Add-Ons.

for those who are inclined that direction.

The scripts from this panel are installed in a

Terminal: For those who are into other

number of locations:
technologies, like Python, bash, Ruby, etc.,

Script Menu Extra Scripts: These scripts

the question arises: Is there a command line

are accessed from the global Script menu

interface (CLI) for DEVONthink? The answer

when you are in specific applications, e.g.,

is no. However, you can still use a do shell

Safari. They are installed in an application-

script command in AppleScript when needed.

specific subfolder of ~/Library/Scripts/

Actually, the combination of the shell and

Applications. See also p. 196ff

AppleScript creates even more opportunities,

Folder Action Scripts: These scripts are

as their individual strengths compensate for

used to created hot folders in the Finder.

the other's weaknesses.

They are installed in ~/Library/Scripts/
Folder Action Scripts. See also p.

APPLESCRIPT

197ff
Apple Mail Rule Scripts: These scripts

AppleScript is an automation technology

for use with Apple Mail Rules. They are

introduced by Apple in 1993. Over the years it

installed in ~/Library/Application

has matured and become the friend of many

Scripts/com.apple.mail. See also p.

Mac users wanting to exert more control over

195ff

their computing experience. Written in an
easy to learn, almost conversational language,

DEVONthink Scripts: The internal scripts

it offers a tremendous amount of power with

found in DEVONthink's Scripts menu are

less effort than many languages. DEVONthink

installed in ~/Library/Application

has very robust AppleScript support and

Scripts/com.devon-technologies.think3.

comes with many built-in scripts. These, and

The scripts will be found in one of four

those you write or obtain, make it possible

directories:

to automate nearly every aspect of the
application, and to integrate the application
with almost every other macOS application
that supports AppleScript.

Menu: These are the scripts found in
DEVONthink's Script menu. See also p.
188ff
Toolbar: These scripts are available to add
as toolbar buttons. See also p. 189ff

INSTALLATION

Reminders: These scripts will be executed

Add-On Scripts: All add-on scripts that

when a reminder is triggered with an alarm

come with DEVONthink are automatically

of Execute External Script. See also p.

installed or updated when you open a new

189ff

version of DEVONthink for the first time.

Smart Rules: These scripts are used as

You can, however, manually (re-)install them

External Scripts in the actions of smart
rules. See also p. 192ff
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Additional scripts, like those you write
yourself, can be put into any of these
folders to be used in these contexts. Other
scripts that may include integration with
DEVONthink can be located wherever it's
convenient.

SCRIPT SHORTCUTS

LEARNING APPLESCRIPT
While this documentation is not an
AppleScript language guide, all the scripts
that come with DEVONthink are editable
and can be explored or modified as you see
fit. The separate sections in this chapter
provide any required terminology and a
simple example script or two. Additionally,

Many people like mousing around their

there are some great resources available

applications, while others like to use their

online and in print. For the official archived

keyboards. If you want to add keyboard

documentation, refer to Apple's AppleScript

shortcuts to scripts in this menu, you have

web site. Some additional resources are listed

two options:

below:

System Preferences: Open System
Preferences > Keyboard > Shortcuts > App
Shortcuts. Add a shortcut for DEVONthink,
enter the exact name of the menu item,
and assign a hotkey.
Append Filename: Locate the script in
the Finder and append three underscores

Online:
DEVONtechnologies Community
MacScripter
AppleScript, the Language of Automation
TECsoft Hands-On Trainings
Books:

followed by abbreviated command keys and
characters. For example, eMail Current
URL___Cmd-Alt-F2.scpt. The command

AppleScript: The Missing Manual
AppleScript: The Definitive Guide

key abbreviations are as follows: Cmd
stands for the ⌘ Command, Alt or Opt for
the ⌥ Option, Ctrl for the ⌃ Control, and

BASIC APPLESCRIPT
TERMINOLOGY

Shift for the ⇧ Shift keys.

AppleScript is not a difficult language

Note: When using macOS Mojave, you

to learn. Its plain English approach of

will often be prompted by the operating

"talking" to applications and elements is

system to allow applications to "control" on

easily understandable. However, like any

another. These permissions are stored in

language, there are some variations in the

System Preferences > Security & Privacy >

words you can use; dialects, if you will.

Security > Automation. Please make sure to

AppleScript is implemented by the developer

allow any requests of these kind regarding

of an application, so the commands and

DEVONthink's control of other applications

parameters may be conceptually the

or your automation attempts will fail for

same as another application's, but using a

obvious reasons.

different term. This is certainly not meant
to be a complete guide to AppleScripting
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DEVONthink, but what follows are some

Note: The use of the is almost always

common terms or concepts you're likely to

optional, but including it can make the script

encounter. The examples here and in this

seem a bit less robotic. For example, both

chapter are meant to give you basic ideas

lines in this script are functionally the same:

about scripting DEVONthink.

TALKING TO DEVONTHINK

Example:
tell application id "DNtp"
set state of children of current group to

In AppleScript you "talk" to programs like

true

DEVONthink using a tell statement,

current group to true

typically referring to an application
either by its name, "DEVONthink 3",
or its bundle identifier, "com.devontechnologies.think3". While these forms
will work, they might become incompatible
with a future version, e.g., DEVONthink

set the state of the children of the
end tell

As noted above, the dictionary is the best
place to find specific terminology to be used
with DEVONthink. However, here are two
things to understand:

4, so we strongly recommend to talk to

Records: Every item in a DEVONthink

DEVONthink using the application ID DNtp,

database is a record, a record with

like in the following statement:

properties. Do a search for "record" in the

Example:

dictionary and you'll see it's a fundamental

tell application id "DNtp"

unit with a wide range of properties

close current database

associated with it. This means you won't be

end tell

writing code like, get the second rich
text file…. You will be dealing with records

DEVONTHINK'S DICTIONARY

with a particular type, in this case rtf.

AppleScript-capable applications have their

There are many commands specifically for

commands, elements, and properties listed

use with records: create record with,

in an AppleScript dictionary. DEVONthink

exists record with…, etc. Also note there

includes a large dictionary as a great

are some commands that require the term

reference for you. To view the dictionary,

record. For example: move, delete, and

open the Script Editor application, select File

convert. You will see a dictionary listing move

> Open Dictionary and choose DEVONthink

record, so you can see the command isn't

in the appearing window. You can also add

merely move, it's move record.

DEVONthink to your Script Editor library.
Select Window > Library, click the + button
and choose DEVONthink. This way you keep
DEVONthink's dictionary at hand.

Parents and Children: Another concept to
understand is parents & children. Generally
speaking, these classes deal with the
container or the contents of some object.
The parent of an object is the group
containing it. The children of a group are
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the immediate contents of that group, i.e.,

with a forward slash denoting the root of

it does not list the children of sub-groups.

the database.

Children can be documents or groups;

get record with UUID…: When using an

parents will only be groups.

item link, you can use the alpha-numeric

Example:
tell application id "DNtp"
set thisGroup to current group

string from the reference URL to point to
a specific item. (This command works with
both groups and documents.) This form is

name of (the children of thisGroup whose

very useful since it doesn't change when an

(type is XML))

item's name or location changes.

end tell

Example:

USING LOCATIONS

tell application id "DNtp"

One of the common tasks people want to

Files"

perform with AppleScript is importing files

import "~/Desktop/001.txt" to myGroup

to a specific group. In order to direct the files
to a given location, you need to reference it
properly. Below are three general options for

set myGroup to get record at "/Inbox/New

set groupTwo to get record with uuid
"98BBF96D-7743-46C6-9EB4-51C6EF68373C"
import "~/Desktop/002.txt" to groupTwo
end tell

choosing a location:
WORKING WITH A SELECTION
incoming group: This targets the Global
Inbox, or the inbox of a database when

Many times you want to process items

using incoming group of current

you have selected in DEVONthink. Perhaps

database.

you want to generate a list of names and

current group: This targets the currently

dates for use in a document you're working

selected group in the current database.

on. Below is a handler commonly seen in

display group selector: This shows the

DEVONthink scripts:

group selector so you can choose a location
on demand.

repeat with thisRecord in (selection as
list) … end repeat: This is a very common

There are many times you want to direct files

handler, used when processing a selection,

into a specific group. That group may not

single or multiple items.

be the current group you're in and you may
not want to choose a destination each time.
Here are two common ways of specifying
a particular group in your database to be a
destination group in your script:
get record at…: This command allows you

Example:
tell application id "DNtp"
if selection is not {} then
set nameList to {}
repeat with thisRecord in (selection as
list)
copy ((name of thisRecord) & ": " &

to set a variable by specifying a group's

(creation date of thisRecord as string) &

location in your group structure. The

return) to end of nameList

location is a text string, always beginning

end repeat
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create record with {name:"Files",

ATTACHING A TRIGGERED SCRIPT

type:text, content: (nameList as string)}
in incoming group

While it's possible to write a script that

end if

specifies a triggered script for an item in

end tell

DEVONthink, the usual method is manually
attaching one.

INTERNAL SCRIPTS

Select the item you want to attach a script

The Scripts menu of DEVONthink, located to

to.

the left of the Help menu, gives you access

Select Tools > Get Info or Tools > Inspectors

to a large number of pre-made scripts, with

> Generic.

more scripts available. These scripts are not

Click the down arrow next to Script

only useful for every day use, but are also

and choose Select. Note the script

great for learning how to script DEVONthink.

can be located anywhere, but it must

All the scripts we provide are editable
using the Apple's Script Editor, though
we do suggest making copies to work
on. They are located in ~/Library/
Application Scripts/com.devontechnologies.think3/Menu. Open this
folder in the Finder with Scripts > Open

remain in that location for the script
to trigger. For convenience, you can
create a folder for them in ~/Library/
Application Scripts/com.devontechnologies.think3/Menus.
REMOVING A TRIGGERED SCRIPT

Scripts Folder command. Add your own

Since a triggered script runs when you

scripts to the menu by adding them to the

interact with the item, it can sometimes

appropriate subfolder in this directory, even

be difficult to detach the script, e.g., if

creating subfolders of your own.

a script switches to another application

A complete listing of the installed scripts can
be found here: See also p. 229ff

TRIGGERED SCRIPTS

when triggered. For instances like this, to
remove a triggered script from an item do the
following:
Control-click the item you want to remove
the triggered script from and choose Get

Triggered scripts are AppleScripts that you

Info.

attach to an item in DEVONthink (a group

Click the down arrow next to Script and

or document) and that are executed each

choose Remove.

time you select the item. Items with attached
triggered scripts show an AppleScript icon

TERMINOLOGY

behind their name.
Triggered scripts are defined by a specific
Using triggered scripts, you can add your
own custom behaviors when interacting with
items in your database.

handler: on triggered(var), where var is
the variable representing the item the script
is attached to.
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Example:

To write an embedded script for a reminder,

on triggered(theRecord)

choose Execute Embedded Script as the

tell application id "DNtp"

alarm. Click the … button and a popup will

display alert "" & (name of theRecord as
string)
end tell
end triggered

appear with a pre-built handler in place.
Add your code as necessary, then press the
compile button, the one with the stylized eye,
to make sure it compiles correctly. If it does,

REMINDER SCRIPTS

you will see the code format itself subtly. If
not, you will hear a system alert. Click outside

Reminders have several pre-built alarms

the popup to dismiss it. When the alarm goes

available for notifications. However, you

off, the script will be executed.

can only specify one alarm per reminder.
Reminder scripts are AppleScripts run by an
alarm set on a specific reminder for an item.
By using or writing your own, you can extend
notification possibilities of your reminders.

Note: When a reminder is set to Once, the
reminder is removed and the embedded
script lost after the alarm goes off. If you
have code you'd like to potentially use
again, put it in an external script.

ADDING AN EXTERNAL SCRIPT
TERMINOLOGY
To add an external script as an alarm
for a reminder, choose Execute External
Script. The next dropdown lists any
available AppleScripts in the ~/Library/
Application Scripts/com.devon-

Triggered scripts are defined by a specific
handler: on performReminder(var), where
var is the variable representing the item the
alarm is set for.

technologies.think3/Reminders directory.

Example:

Add any of your own scripts to this directory

on performReminder(theRecord)

to make them available for any alarm you set.

tell application id "DNtp"
set label of theRecord to 1

Currently, there is only one example script

say (name of theRecord as string)

pre-installed:

end tell
end performReminder

Open Document: Opens the document in a
new window when the alarm triggers.

ADDING AN EMBEDDED SCRIPT
Sometimes you only need to add a script for
a specific purpose, not general use with all
reminders. DEVONthink allows you to quickly
write an ad-hoc AppleScript specifically for

TOOLBAR SCRIPTS
Scripts can also be added to the toolbar
of any DEVONthink window. While there
is a limited amount of space available in
a window's toolbar, this is a handy way to
launch commonly used scripts with one click.

the current reminder.
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To add a toolbar script place the

one or multiple .lproj folders, one for

script into the folder ~/Library/

each supported language. Depending on the

Application Scripts/com.devon-

system language, you can let DEVONthink

technologies.think3/Toolbar. In order

import the files in the correct language.

for the script to be available for use in

If you inspect the contents of a template

the toolbar, you must quit and relaunch

package, e.g., Classifications > Decimal Filing

DEVONthink. Then Control-click the toolbar

System.dtTemplate, you will see the project

of a DEVONthink window and choose

folders and their assets as a great example of

Customize Toolbar. Drag your script into the

this type of template.

toolbar and it's ready for use.
SMART TEMPLATES
TERMINOLOGY
The more advanced type of automated
Unlike some other script types, there are no

templates are smart templates. These are

special handlers required for a toolbar script.

not simple files, but actually AppleScript

You only need valid AppleScript talking to

packages containing script code, and often

DEVONthink.

including related assets that can be inserted

Example:
tell application id "DNtp"
open tab for record (content record)
end tell

into your database. This allows for some very
powerful actions like:
The script can add information to the builtin template, e.g., the current date and time
or data from the web.

SMART TEMPLATES
Some of the DEVONthink provided templates
are "template packages" (.dtTemplate) and
"smart templates" (.templatescriptd). Both
templates provide a great deal of flexibility
and power, like allowing for inclusion of
language resources. With some creativity
and scripting know-how, you can set up

The script can act intelligently on data
on the clipboard: If it's a simple text, it
adds the text; if it's a URL, it adds it to a
different area of the document and makes
it clickable.
The script can check if a certain application
is installed, e.g., OpenOffice, before adding
a document.

everything from commonly used group
hierarchies to daily journal entries and much
more.

CREATING TEMPLATES
Template Packages: To create your own
template package, you can duplicate an

TEMPLATE PACKAGES
The simpler type of automated templates
DEVONthink supports are: template
packages. These are folders with the file
name extension .dtTemplate that contain

existing template, Control-click it, choose
Show Package Contents and edit the
internals as needed. Also note exporting
multiple selected files will yield a template
package.
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Smart Templates: To make your own

%author%: The author entered in

smart templates, have a look at the

Preferences > Editing > Author

prefabricated smart templates. Duplicate

%username%: The user's name

a .templatescriptd file, like the "Note"

%fullUsername%: The user's full name

template. Control-click it, and choose

%organization%: The user's organization

Show Package Contents. You can inspect

from Contacts

and modify the supporting assets and the

%emailAddress%: The user's email

main.scpt file to fit your needs.

addresses from Contacts

TEMPLATE PLACEHOLDERS

%host%: The host name
%databaseName%: The database name

Placeholders in templates are simple control

%databasePath%: The database's path

codes that are replaced by DEVONthink

%groupName%: The name of the parent

when a template file is imported. These

group

placeholders can be used in your files,

%topGroupName%: The name of the top

including simple templates, or folder

group

names of your templates packages. When

%clipboard%: The clipboard contents as

used in files, they are typed in the text of

plain text

DEVONthink-native files; e.g., plain or rich

%styledClipboard%: The clipboard

text, Markdown, etc. These can be manually

contents as rich text

typed or you can Control-click in the text and

%clipboardLink%: The clipboard contents

choose Insert Placeholder. Below is a list of

as a clickable rich text link if the clipboard

valid placeholders:

contains a valid URL

%time%: The current time

Note: There are more placeholders from

%date%: The current date

the contextual menu than can be used in

%shortDate%: The current date in short

a template. For example, the placeholder

format

%record_locality% relates to an existing

%longDate%: The current date in long

record, so this placeholder will not be used

format

when creating a file from a template.

%monthname%: The month name of the
current date
%weekday%: The week day name of the
current date
%day%: The day number of the current
date
%month%: The month number of the
current date
%year%: The year number of the current
date

Custom Placeholders: One more powerful
feature of smart templates is the ability
to define custom placeholders, extending
the possibilities beyond the list shown here.
This allows you to add a custom placeholder
in the text of a template, then define the
replacement value for that placeholder in the
main.scpt. As a great example, check out the
use of the custom %project% placeholder in
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the Project smart template. Notice the use of

An action: This is the action the smart rule

the placeholder in the enclosed rich text file

performs when the event occurs.

and the script.

An event: This is an event that causes an
action to occur, e.g., an "On Quit" event.

TERMINOLOGY
With the internal script of a smart template,
there are no special handlers required.
However, the internal script must be located

If used in a smart rule, a specified action
would run when you quit DEVONthink.

CREATE A SMART RULE

in the Contents/Resources/Scripts folder

Smart rules can be created in one of two

inside the package, and it must remain

ways:

named main.scpt. Beyond that, you only
need valid AppleScript.

Click the + button at the bottom of the
sidebar and choose New Smart Rule. The
Search in dropdown will target the current

SMART RULES

location.

Smart rules are smart groups‚ evolved. Built

Control-click an item in the sidebar

in the same style as smart groups, smart

and choose New Smart Rule from the

rules don't just show items matching criteria,

contextual menu. This will specifically

they can act on them! From something

target that item in the Search in dropdown.

as simple as adding (or changing) a color
label, to modifying a filename then filing
a document in another location, smart

Note in either case you can change the
Search in parameter to target other
locations, including all open databases.

rules provide some powerful automation
possibilities. And they're not just for the

Note: Smart rules are considered global

technically inclined. No programming

objects and can be created only in the

experience is needed for almost every action

Navigate sidebar of a main window. If you

available.

want to create a smart rule for a group
in the item list, choose Data > Reveal to

Smart rules are conceptually simple and can

display it in the sidebar.

be summed up as follows: When this event
occurs > do this action > on items matched >

When you create a new smart rule, you will be

in this location. Smart rules are made of four

shown the predicate editor, just as you see

parts:

with smart groups. Just follow these simple
steps to define the parameters of the rule

A location: This is where the smart rule will

(with an example):

look for matching items.
Matching criteria: Like a smart group, you

Name: Give the rule a name, like Label

can specify criteria to be matched. The

Edited Screencaptures.

smart rule will only act on the matched

Location: Set the Search in dropdown to

items.

target your desired location, like a group
you add screen captures to. The more
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specific the better; a good idea is to use
e.g., a database's inbox.
Matching: Add any criteria to be matched,
e.g., Name begins with screen and Kind is
Image.
Event: Choose an event to trigger the
smart rule, like specifying On Save to run
the smart rule when matched items are
saved in DEVONthink
Action: Choose an action for the smart

IMPORTING AND EXPORTING
Smart rules can be exported to the Finder,
sent by email, and e.g., reimported to
DEVONthink on another Mac. Drag a smart
rule to the desktop to save it to a file or
Control-click it and choose Export. Doubleclick a saved smart rule to import it, drag
it into the sidebar, or Control-click into the
sidebar and choose Import.

rule, perhaps Change Name to add
"_edited" to the name.

SMART RULE SCRIPTS

This rule shown above would add "_edited"

Smart Rule scripts are AppleScripts run by an

as a suffix to the name of any edited images

Execute Script action in a smart rule. These

whose name begins with "screen".

scripts allow you to extend the possibilities
beyond the already powerful pre-defined

One step further‚ chained actions: If you

actions.

hadn't noticed, there's a + button to the
right of the action you specified. And yes,

Note: Smart rule scripts will be executed

that means you can chain multiple actions

based on the event handler in the specific

in a smart rule! For example, we could add

rule. For testing, it can be useful to set the

an action to open the edited imaged in the

event to On Demand. This way you can select

system default application after it has been

the rule to see its matches, then Control-click

renamed.

it and choose Apply Rule to run it and see the
effects on the matched items.

Note: Bear in mind, smart rule actions run
in series, i.e., the actions run from top to

Also be aware the effects of smart rules

bottom, first to last. This means the order

are very broad, i.e., they affect all the items

of the actions affects the outcome. Think

they match. While you are testing, it's a good

carefully about this if you decide to create

idea to put some limiting criterion in place.

chained actions.

For example, instead of matching all images
in all databases, try matching images in a

We hope this has given you a good overview

specific group or only images that begin with

of creating a smart rule. Please see the

"Screen".

appendix for a complete list of available
Events and Actions.

ADDING AN EXTERNAL SCRIPT

For those interested in the Execute Script

To add an external script to a smart rule,

action, continue to the next section…

add an Execute Script action and choose
External. The next dropdown lists any
available AppleScripts in the ~/Library/
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Application Scripts/com.devon-

with HTML-based files, e.g., web archives,

technologies.think3/Smart Rules

etc.

directory. Add any of your own scripts to

Downloads - Add Podcasts: Add detected

this directory to make them available for any

podcast links images to the Download

smart rule you define. Here is a list of the pre-

Manager. Used with podcast RSS feeds

installed scripts, for everyday use and your

containing download links.

education:
Check Links: Check if bookmarks are valid.

ADDING AN EMBEDDED SCRIPT
Close All Databases: Closes all databases

There are times you may need to add some

but the Global Inbox.

code for a specific situation. Similar to

Download Bibliographic Metadata:

some other macOS utility applications,

Attempts to retrieve the digital object

DEVONthink allows you to write an

identifier (DOI) of the document and set

AppleScript directly in the smart rule's editor.

the title and metadata.
Move Into Database: Moves indexed files
into the database.
Move to External Folder: Moves imported
files out to the Finder when they're located
in an indexed group.
Reminders - Next Week: Set a reminder for
a week from the current time and date.
Reminders - Remove: Remove an applied
reminder from the matched item(s).
Reminders - Tomorrow: Set a reminder for
the same time tomorrow.

To write an embedded script for a smart
rule, add or specify an Execute Script action
and choose Embedded. Click the Edit Script
button and a popup will appear with a prebuilt handler in place. Add your code as
necessary, then press the compile button,
the one with the stylized eye, to make sure it
compiles correctly. If it does, you will see the
code format itself subtly. If not, you will hear
a system alert. When done, click outside the
popup to dismiss it

Tags - Add Keywords: Automatically adds

Note: For those learning AppleScript, the

Tags from the concordance of the matched

repeat loop in the pre-built handler is a

file.

very common (and useful) code snippet for

Tags - Assign: Automatically adds tags,

processing all files returned by a smart rule.

based on Apple's machine learning

Take note of it.

technology for images or hashtags and
known tags in titles and content.

TERMINOLOGY

Downloads - Add Embedded Images:

Smart Rule scripts are defined by a specific

Add embedded images to the Download

handler: on performSmartRule(var),

Manager. Used with HTML-based files, e.g.,

where var is the variable representing items

web archives, etc.

matched by the smart rule.

Downloads - Add Linked Images: Add linked
images to the Download Manager. Used

Example:
on performSmartRule(theRecords)
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tell application id "DNtp"

message it acts on as separate documents

repeat with theRecord in theRecords

to DEVONthink.

if (name of theRecord as string) contains
"Piglet" then
set state of theRecord to true

Mail Rule - Add links to DEVONthink: Adds
detected links in the messages as individual

end if

bookmarks in DEVONthink

end repeat

Mail Rule - Add messages to DEVONthink:

end tell

Adds the messages it acts on to

end performSmartRule

DEVONthink.
Mail Rule - File messages & attachments:

APPLE MAIL RULES
When considering importing emails into your
DEVONthink databases, the question of
"automatic" email importing invariably comes
up. While this isn't fully possible yet, there is
a mechanism in Apple Mail that can provide
some level of "automatic": Mail Rules.
Found in Apple Mail's Preferences > Rules,
these are a rules consisting of criteria to be
matched and an associated action (similar
to smart rules). As incoming emails are
detected, Mail will check for matches in a rule

Adds the messages it acts on including all
attachments to DEVONthink.
Mail Rule - File messages & attachments
hierarchically: Adds the messages it
acts on including all attachments to
DEVONthink, recreating the mailbox
structure.

TERMINOLOGY
A full lesson on writing scripts for Mail Rules
is beyond the scope of this help, but you can
open and explore the installed scripts.

and execute any actions you've specified in

Do note there are two required handlers:

the rule.

using terms from application "Mail"

One of the actions available is Run
AppleScript. Selecting this option shows a
dropdown with any installed Mail Rule scripts.
These scripts are installed in ~/Library/
Application Scripts/com.apple.mail

and on perform mail action with
messages theMessages for rule theRule,
where theMessages is a variable representing
the items matched by the rule. Here's a
simple example:

folder. If you write or obtain other scripts for

Example:

use with Mail Rules, they can also be placed

using terms from application "Mail"

in this directory. The scripts provided by

on perform mail action with messages

DEVONthink are:

theMessages for rule theRule
tell application "Mail"

Mail Rule - Add attachments to

repeat with thisMessage in theMessages

DEVONthink: Adds the attachment of the

display alert "" & (subject of
thisMessage)
end repeat
end tell
end perform mail action with messages
end using terms from
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Note: Mail Rules are controlled by Apple

a supported email application and choose the

Mail, not DEVONthink. While they generally

desired script from the global scripts menu.

behave as expected, we can't control

DEVONthink provides the following scripts:

whether the rules will be triggered in Apple
Mail.

Add attachment(s) to DEVONthink: Adds
the attachments of selected emails to
DEVONthink.

APPLICATION SCRIPTS

Add mailbox(es) to DEVONthink: Adds the

AppleScript is perfectly suited for integrating

selected mailboxes to DEVONthink.

different applications, interchanging

Add mailbox(es) & attachments to

information, and creating workflows.

DEVONthink: Adds the selected mailboxes

DEVONthink comes with a number of

to DEVONthink. Attachments are imported

scripts that exchange information between

separately.

DEVONthink and other AppleScript

Add message(s) to DEVONthink: Adds the

supporting applications, like Safari or Mail.

selected mailboxes to DEVONthink.
Add message(s) & attachments to

The Script Menu Extra Scripts provided by

DEVONthink: Adds the selected mailboxes

DEVONthink are installed in an application-

to DEVONthink. Attachments are imported

specific folder in ~/Library/Scripts/

separately.

Applications, e.g., ~/Library/Scripts/
Applications/Safari. These scripts are

Note: The import of entire mailboxes via

accessible from the global scripts menu in

AppleScript can be a resource-intensive

the menu bar at the top of your screen while

process. Use the Apple Mail plugin for

you're in the specific application.

a more robust experience importing
mailboxes.

MAIL SCRIPTS
WEB BROWSERS
Importing email into your DEVONthink
databases is a possible use of AppleScript.

Depending on the capabilities of the web

Using AppleScript-enabled email

browser you're using, you may be able to

applications, especially those with a robust

use application scripts. We have included

scripting dictionary, increases the potential

a handful of simple scripts that can be run

for processing emails. This can help you

while browsing in Safari or DEVONagent.

quickly file those emails directly into
DEVONthink.
DEVONthink comes with scripts for Apple

Add abstracts to DEVONthink: Creates a
sheet containing information about items
in a DEVONagent search. This includes

Mail, Microsoft Entourage, and Microsoft
Outlook. Just select a message or mailbox in
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the title, score, summary, and URL of each

The actions supplied by DEVONthink are

result. (DEVONagent only)

installed in ~/Library/Scripts/Folder

Add linked images to DEVONthink: Detects

Action Scripts, and you can add your

images on the current page and adds them

own scripts to this directory, as needed.

to your database.

For everyday use and exploration, here

Add tabs to DEVONthink: Adds bookmarks

are the folder action scripts provided by

for active tabs the browser.

DEVONthink:

Add linked images to DEVONthink's

DEVONthink - Import: Imports files into

downloads: Detects images on the current

your databases.

page and adds them to DEVONthink's

DEVONthink - Import & Delete: Imports

Download Manager.

files into your database, and moves the

Add links to DEVONthink's downloads:

files to the trash afterwards.

Detects URLs on the current page and adds

DEVONthink - Import to selected group:

them to DEVONthink's Download Manager.

Imports files to the currently selected
group.

OTHER APPLICATIONS
Obviously we haven't covered all the possible
applications or scenarios on your machine,
and we are sure you have ideas we haven't
thought of. If you have an application you'd
like to integrate with DEVONthink, check if

DEVONthink - Index: Index files to your
database, creating links to the original
items in the Finder.
DEVONthink - Index to selected group:
Index files to the currently selected group
in your database.

it has an AppleScript dictionary. If it does,

DEVONthink - Import, OCR & Delete:

the potential exists to communicate between

Imports files into your database, converts

the applications. But also be aware the

them to searchable PDFs if necessary, and

commands, elements, and properties you

moves the files to the trash afterwards.

can work with are coded by the developer of
those applications.

ATTACHING A FOLDER ACTION
To attach a folder action script to a folder, do

FOLDER ACTIONS
Folder actions are scripts that you can attach
to folders in the Finder. These act on all items
you add to these "hot folders." When you
add items, the operating system detects
the added files and runs any folder actions

the following:
Control-click a folder in the Finder.
Select Services > Folder Actions Setup
from the contextual menu.
From the list of available actions, select
the folder action script click Attach.

attached to the folder.
Manage folder actions: To manage all your
folder actions, Control-click a folder and
choose Services > Folder Actions Setup from
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the contextual menu. Use the Folder Actions
Setup utility to see which folders have scripts
attached, and to remove folder actions from
folders.

AUTOMATOR
Apple's Automator application was created
mainly to help non-programmers take some
control of their machines. It allows you to

Note: If you are running macOS Mojave,

visually string together simple steps in an

you will be prompted to allow the Folder

automated process. While much more limited

Actions Setup application to run. This

due to its linear nature, it may still be useful

notification is controlled by the operating

for some routines. Additionally, Automator

system, not DEVONthink.

offers creation of other types of items like
Services (or Quick Actions).

TERMINOLOGY

While DEVONthink does not provide

While we can't provide specific training

Automator actions, using the Run

on how to create folder actions, check out

AppleScript action in Automator makes it

Apple's documentation. However, the on

possible to have some degree of integration

adding folder items to folderVariable

with our application.

after receiving filesVariable is the
handler most commonly used in our folder

TERMINOLOGY

action scripts. Here is a simple example:
Example:
on adding folder items to theFolder after
receiving theFiles
repeat with thisFile in theFiles
tell application id "DNtp"
set newRecord to import thisFile to
incoming group
if exists newRecord then tell application
"Finder" to delete thisFile
end tell
end repeat
end adding folder items to

Note: Folder actions, like any computer
processes, are treated very literally. When
processing files with a folder action, it's
best to move or delete the files from the
watched folder. This keeps the action from
trying to reprocess files.

Finder to DEVONthink: Since DEVONthink
doesn't provide specific actions for
Automator, you can't merely detect things
like a selection. The key to integration with
DEVONthink is passing file paths, specifically
POSIX paths. For example, if you used a Get
Selected Finder Items action, you could use
a Run AppleScript action like this to import
selected files in the Finder into DEVONthink :
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Example:

Immediately following this action, use

on run {input}

a Get Specified Finder Items action to

tell application id "DNtp"

pass the paths to subsequent actions. Be

repeat with thisFile in input
import (POSIX path of thisFile) to
incoming group

very cautious when using the paths from
DEVONthink. Actions like moving, deleting,

end repeat

renaming etc. would compromise your

end tell

database. It is advisable to use a Copy Finder
Items command if you are going to do such
operations.
Note: While we may investigate
DEVONthink-specific questions regarding
Automator, we do not offer support
specifically for it.

ITEM LINKS
Every database, group, or document in your
DEVONthink database has a URL (uniform
resource locator) associated with it. While
web URLs typically begin with http:// or
https://, DEVONthink's URLs take the form
of x-devonthink-item:// followed by a
DEVONthink to Finder: Passing paths from
DEVONthink can be done by processing
the paths of files. Here is an example Run
AppleScript action placed at the beginning of
the workflow:

long alphanumeric ID. For PDFs, the link can
contain a reference to a specific page. For
audio and video, a reference to the current
playback time. And for RTFs, you can get
a reference to a specific paragraph in the
document. These links can be used in any

Example:

file type or application that supports live

on run {}

hyperlinks, e.g., the notes fields of OmniFocus

tell application id "DNtp"
set fileList to {}
if selection ≠ {} then
repeat with thisRecord in (selection as
list)
copy (path of thisRecord as string) to end

tasks. This allows you to access DEVONthink
documents as easily as clicking a link in a web
browser.
You can get this item link manually by

of fileList

selecting a document or group and choosing

end repeat

Edit > Copy Link. In addition you can manually

end if

extend the copied URL with the following

return fileList

parameters:

end tell
end run
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page: Opens a PDF to the specified page.

Example:

Usage: page=<integer>.

tell application "DNtp"

reveal: Reveals an item in the item list

set recordName to name of content record

instead of opening it in a new window.

set recordURL to reference URL of content

Usage: reveal=1.

set the clipboard to ("[" & recordName &

search: Directly jumps to the first
occurrence of the search string in
the specified document. Usage:
search=<string>.
time: Directly jumps to the specified time
in seconds in a video or audio document.
Usage: time=<float>.
Example:
x-devonthink-item://<recordID>?reveal=1
x-devonthink-item://<pdfID>?page=5
x-devonthink-item://<textFileID>?
search=iPad%20Pro
x-devonthink-item://<movieID>?time=43.5

record
"](" & recordURL & ")")
end tell

The terminology for using item links can
depend on the capabilities of the application
you're scripting. Here is an example, using a
hard-coded URL, with an application that can
open URLs:
Example:
tell application "Opera"
tell window 1
make new tab with properties {URL:"xdevonthink-item://929D101B-35AC-474C-801CD8818C48DB80?line=125"}

Note: The first parameter after the ID is

end tell

always added after a question mark (?),

end tell

additional ones after an ampersand (&),

P.S.: For the shell scripters, the URLs can be

and any values must be percent-encoded.

used with an open command.

TERMINOLOGY
Manually getting item links can be useful
for some hard-coded cases, but there
are many times you want to get them
programmatically. There are two AppleScript
properties for a record related to item links:
reference URL: This is the item link as

URL COMMANDS
URL commands are a type of item link
that don't merely point to an existing file,
they issue some special commands to
DEVONthink. Though not as powerful as
AppleScript, these commands can be used in
special circumstances.

described above.
UUID: This is the unique identifier of the
item, i.e., the long alpha-numeric string in
the reference URL.
Here is an example of getting and using an
item link to create a Markdown compliant link
on the clipboard:

TERMINOLOGY
The URLs are constructed from a single
command and optional parameters, with the
following format:
x-devonthink://<command>?
<parameter=value&parameter=value&...>
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Note: The first parameter after the ID is
always added after a question mark (?),
additional ones after an ampersand (&),
and any values must be percent-encoded.

Parameters:
title: The title of the item to be created
(string).
comment: A Comment to be added

Listed below are the commands and

(string).

parameters available:

location: The URL linking to the content,

Commands:

e.g., the URL of the website for the
bookmark (URL).

createFormattedNote: Creates a

tags: Tags to be added (comma separated

formatted note.

strings).

createHTML: Creates a new HTML

destination: The UUID of a group where the

document.

item shall be created (string).

createMarkdown: Creates a Markdown

source: The HTML content for

document.

HTML documents (string, only used

createPDF: Creates a PDF.

by createText, createHTML, and

createRTF: Creates a rich text document.

createFormattedNotes).

createWebArchive: Creates a web archive.

text: The text content for text documents

Note: If you use the location parameter
pointing to a web page with the commands
above, the page will be downloaded in the
specified format and the text parameter
will be ignored. Not including the location
will yield a file in the specified format
using the text parameter for the new file's
content.

(string, used by createText and
createMarkdown).
width: The page width (integer, only used
by createPDF).
paginated: Paginate the created PDF
(boolean, only used by createPDF).
hide: Hide and deactivate application after
executing the comment (boolean).
noselector: Skip group selector (boolean).

createBookmark: Creates a new bookmark

query: The query to search for (string, only

using the location parameter.

used by search).

createGroup: Creates a group.

reader: Post-process the page (integer, 0 =

createText: Creates a new plain text

no post-processing, any other value = post-

document.

process).

clip: Opens the Clip to DEVONthink panel.

referrer: The URL that referred to the item

note: Opens the Take Note panel.

(URL).

search: Initiates a search in the open

selection: The selected text (string, only

databases.

used by createRTF).
Example:
x-devonthink://createText?title=New
%20;bookmark&location=http%3A%2F
%2Fwww.devontechnologies.com&noselector=1
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Note: These are not x-callback-urls. An
x-callback-url is a specific type of URL
scheme that returns a value to the calling
application.
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APPENDIX
⇧ The Shift key.

IN THIS CHAPTER

⎋ The Escape key (usually labeled with

Glossary

203

Iconology

206

Toolbar Items

206

Keyboard Shortcuts

209

Contextual Menu Items

210

Search operators

213

Search Prefixes

216

Bars: Smaller sections of a window

Templates

219

providing specialized information or

Metadata

222

controls, e.g., the Information Bar found

Placeholders

224

just above the item listing. It shows

Smart Rule Events and Actions

225

information about the selection as well as

Scripts

229

buttons to sort or change the view.

Web site export templates

232

Contextual menu: The menu that appears

Hidden preferences

232

when you right-click (or Control-click)

In the appendices you will find additional
information that helps you getting familiar
with DEVONthink, such as a glossary of
commonly used terms, a listing of the
Boolean operators used in searches,
commonly found contextual menu items, and
much more.

"esc").
⇥ The Tab key.
↩ The Return key.

INTERFACE ELEMENTS

something. The contextual menu gives
you access to frequently used commands
that deal directly with the clicked object.
Specific contextual menu items are
discussed in their respective sections, but
there is a list of commonly seen commands
in the Contextual Menu Items section of
this appendix.
Inspectors: Specialized panes at the right

GLOSSARY
Become familiar with these terms to get the
most out of working with DEVONthink.

of a main window, providing information
about the current selection as well as
functions like See Also & Classify.
Item list: The list of items in the current

KEYBOARD SYMBOLS

location, viewable as a list, icons, columns,
or Cover Flow. Items can be documents,

⌘ The Command key, usually next to the

groups, or smart groups.

Space bar.

Sidebar: The panes found at the left side of

⌥ The Option key.

a main window, comprised of the Navigate,

⌃ The Control key (usually labeled with

Reading List, Import, and Extras panes.

"ctrl").

DEVONthink 3.6 Documentation, page 203

View/Edit pane: A pane of the

is started and accessible through the

DEVONthink main and document windows

sidebar. The Global Inbox can be set as

that lets you view a document or, when

the default destination in Preferences >

possible, edit it. The view/edit pane

Import.

displays the content of your documents

Inbox: A special group for data coming in

depending on their type. See also p. 74ff

to a database. Every database has an Inbox

View: The layout for a DEVONthink main

group.

window. You can change the layout using

News feed: Also referred to as RSS, a

the commands found in the View menu.

news feed is like a web page, but split

Window: DEVONthink uses three different

into multiple articles. A feed reader or

types of windows: main, document, and

web browser can split the feed "page"

other. Main windows show lists of items

into its parts and show each of them as

and, in some views, also the contents of

a separate news item and/or store it in a

the selected document, whereas document

local database. DEVONthink stores feeds in

windows can be opened for individual

a database and displays them like a group.

documents.

The contents are updated live from the
internet as the connected feed changes.

DOCUMENTS & GROUPS
Database: A collection of all documents
stored in DEVONthink. You can create and
open as many databases as you like.
Document: A file in the database; for
example, a plain or RTF text, a PDF, or an
image (.jpg, .tiff, .png, etc.). Technically a
document is an entry in a database with
text, RTF, or image content, sometimes
simply referred to as "content".
Default destination: The default
destination group for incoming data. Set in
Preferences > Import.
Duplicate: A copy of a file, either explicitly
created or detected by DEVONthink's AI.
Group: A collection of documents or other
groups inside the database. Similar in
appearance and behavior to a folder in the
Finder. See also p. 135ff
Global Inbox: A special database serving as
a destination for incoming data. The Global
Inbox is always opened when DEVONthink

Older news bits are kept, while fresh news
bits are added and marked as unread.
When you add a bookmark that points
a feed, DEVONthink tries to add it as a
proper feed document if possible.
Replicant: A document or a group that
appears in more than one place in the
database. Unlike an alias in the file system,
a replicant is not a real document pointing
to another file (usually the original);
rather it is a second entry in the table of
contents for the very same document.
Consequently, there is no original; when
you replicate a document you'll end up with
two replicants.
Sheet: A collection of records or structured
sets of data, presented in a spreadsheet
style, similar to data viewed in Apple
Numbers or Microsoft Excel. Alternatively,
the data can be displayed in form view,
similar to browsing records in, e.g.,
FileMaker.
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Smart group: A special type of group with

deleted (groups, documents) or modified

a set of search criteria saved with it. This

(documents).

is similar to "Saved Search" folders in the

Read/Unread: Items can be marked read

Finder. Every time you visit this smart

or unread, which is useful for captured or

group, DEVONthink runs the attached

automatically downloaded news items or

search and displays it as the content of the

documents that you want to read later.

group. DEVONthink creates a number of

Both unread items and groups containing

pre-defined smart groups when you create

unread items are shown in bold.

a new database.

UUID: Each database, group, or document

Trash: A temporary location in a database

in DEVONthink receives a unique identifier

for deleted files. Similar to the Trash in

(UUID) when it's created. This is a read-

the Finder, all trashed items are stored

only alphanumeric string that refers only to

until you explicitly delete them using

the particular item. The UUID allows you to

DEVONthink > Empty Trash.

reference an item regardless if its location
or name changes, and is usually found in

TAGS

item links.

Group tag: Groups within a database that

See the Iconology section for icons specific to

apply their name as tags to their contents.

the flagged, locked, or unread states.

Items moved out of these groups will not
retain the group tags. Group tags appear
grey in all tag lists.
Ordinary tag: Tags created through the
Tag bar or other means are created in a
special top-level Tags group. They are called
"ordinary tags" and appear blue in all tag
lists.

SYNCHRONIZATION
Sync location: Sync locations are used to
keep your databases on all your devices in
sync. They summarize all information about
which databases to sync through what kind
of connection (e.g., direct connections to
DEVONthink on a Mac, WebDAV, CloudMe,

See the Iconology section for icons specific to

Dropbox etc.) and with which sync store.

these two items.

Bonjour (Direct connection): A sync
method for syncing one device to another

ITEM PROPERTIES
Flagged/Unflagged: Items can be checked
or unchecked for your personal use, e.g.,
for creating a to-do list, maintaining a
shopping list, or writing a list of project
tasks.
Locked/Unlocked: Items can be locked
to keep them from being unintentionally

Mac or mobile device running DEVONthink
or DEVONthink To Go, respectively.
Unlike other sync methods, there is no
intermediary storage location for the sync
data. It is direct - device to device.
Sync store: A sync store is a special folder
containing sync data. These can be direct,
local, e.g., on your Mac or a thumb drive, or
remote, as used with cloud services.
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Encryption key: A user-defined word used

Item has been flagged.

to "scramble" or "unscramble" your sync

Item is indexed, not imported.

data when syncing. When used, your sync

Item is locked.

data is stored in an encrypted state in the

Item has a comment.

sync store.

Item has an annotation.

Local database: A database that exists and

Item has a reminder set.

is open on this device.

Item has outgoing item links.

Remote database: A database that is not

Item has incoming item links.

open on this device, or exists at the sync

Item has a script attached.

location, e.g., on Dropbox, but has not been

Group is a tag, too.

downloaded to this device.

Item has an attachment (email messages

Pending document: A document for which

only).

only the metadata is locally available.

Item is synced but its content is not (yet)

This happens when you choose not to

downloaded.

synchronize indexed files for the sync
location.
WebDAV: A type of web server used
by some cloud services, some network
attached storage devices, or running

Item is a duplicate
Item has one or more replicant(s)
Item is a duplicate, but also has one or
more replicant(s)

locally. It can usually be used by
DEVONthink for syncing.

TOOLBAR ITEMS
DEVONthink provides a wide variety of

ICONOLOGY
Additional icons behind item names, e.g., in
main windows, indicate that the item has
been indexed instead of imported, is locked,

toolbar items, giving you quick "push-button"
access to many everyday tools.

DEFAULT ITEMS

has a comment or annotation attached,

The following toolbar buttons are available in

is encrypted, e.g., PDFs or encrypted

the default set you see when you first launch

databases, or has a triggered script attached.

DEVONthink:

Groups also serving as tags show a tag icon.
Depending on your preferences, replicants,
duplicates, or replicated duplicates are
indicated with a little grey icon instead of
appearing in color.

Sidebar: Show and hide the global sidebar.
Preview: None: Hides the document
preview.
Preview: Standard: Shows the document
preview below the item listing.

Item has encryption applied, e.g.,

Preview: Widescreen: Shows the

encrypted PDFs, and encrypted database,

document preview besides the item listing.

or an encryption key has been specified for

Actions: Contains the contextual menu for

a sync location in Preferences > Sync.

items selected in the item listing..

Item is unread.
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New: Adds documents in DEVONthinknative formats. Similar to Data > New.
Open: Opens the current item in a
DEVONthink window if possible.
Open externally: Open the current
document in the system default

ADDITIONAL ITEMS
In addition to the default set, there are many
other specific buttons available, shown in the
essential order found in View > Customize
Toolbar:

application.

Scripts: Provides access to the contents of

Share: Opens the macOS Share menu for

the Scripts menu.

the selected items. This does not apply to

Quick Look: Opens a Quick Look preview

groups.

for the selected document.

Mark: Flagged: Changes the flagged state

Zoom In: Zooms into the current item.

of the selected item.

Actual Size: Zooms the current item to the

Mark: Read: Changes the read statue of

default zoom level.

the selected item.

Zoom Out: Zooms out of the current item.

Mark: Locked: Changes the locked state of

Zoom to Fit: Sets the magnification of the

the selected item.

current item to fit the bounds of the view/

Label: Changes the label color of the

edit pane.

selected item.

Zoom to Width: Sets the magnification of

Search: This is the main search bar,

the current item to the width of the view/

accessing all or specific groups and

edit pane.

databases.

Full Screen: Displays the current document

Synchronize: Initiates a manual sync of the

in DEVONthink's full screen mode.

current database. See also p. 167ff

Groups: Group: Creates a new group in the

Get Info: Opens a popup from the button

current location.

displaying a number of commonly used

Groups: Smart Group: Creates a new smart

inspectors.

group in the current location.

Show/Hide Inspectors: Shows or hides the

Group: Groups the selected items into a

Inspector panes.

new group.

Show/Hide Tags: Shows or hides the Tags

Ungroup: Ungroups the selected group and

bar under a document's preview.

deletes the now-deserted empty group.

Note: The items for showing or hiding the
document preview as well as for marking
items flagged, read, or locked are also
available as a combined toolbar item.

Classify: Attempts to classify the current
item.
Plain Text: Creates a plain text file in the
current location.
Rich Text: Creates a rich text file in the
current location.
Markdown Text: Creates a Markdown file in
the current location.
Formatted Note: Creates a formatted note
in the current location.
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Sheet: Creates a sheet in the current

Synchronize All: Initiates a manual sync of

location.

all open and actively syncing databases.

Bookmark: Create a bookmark in the

Take Note: Opens the Take Note view,

current location.

either in the Sorter or a Take Note panel.

Launch URL: Opens a URL associated with
the current item in the system default
browser.
Save: Explicitly save changes to a
document.
Delete: Moves the current item to the

Imprinter: Provides access to any imprints
available in the Tools > Imprinter menu.
OCR: Runs OCR on a compatible file, e.g.,
PDFs or images, producing the selected
output type.

database's trash.

Note:

Print: Prints the selected document. If

Reveal: Be cautious with this button. When

a document cannot be printed, the item

used on imported files, it will reveal them

listing will be printed.

in the internals of the database. You do not

Import: Imports files into the current

want to modify these internal files in the

location.

Finder. This option is best used on indexed

Export: Provides access to the contents of

files.

the File > Export menu.
Update: Manually updates indexed items in
a database.
Show in Finder: Reveals a file in its location

Verify & Repair: Please refer to the
troubleshooting chapter for information on
database maintenance and repairs.

in the Finder.

Send by Email: The ability to add the

Reveal: Reveals a file in smart groups or

attachments depends on the inter-

search results in its current location.

application capabilities of the email

Merge: Merges multiple files into one,

application. If it doesn't provide support

leaving the originals intact.

for this, you may be able to drag

Merge and Delete: Merge multiple files into

documents into draft messages or the

one, putting the originals in the database's

email application's dock icon.

trash.
Optimize: Does an internal optimization

Some items are also available as a

and backup of a database's metadata.

compound toolbar icon.

Verify: Checks the integrity of the
database and repairs items it can.
Log: Opens a popover showing available
messages from the Log window.
Send by Email: Creates a new message
in your default email app and attaches
selected items.

CUSTOM ITEMS
If you are creating scripts and saving them
to the ~/Library/Application Scripts/
com.devon-technologies.think3/Toolbar
folder, these will be shown in the Customize
Toolbar options as individual buttons with a
script icon.
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KEYBOARD SHORTCUTS

Selecting items:

Keyboard shortcuts make using DEVONthink

Shift-click: Selects consecutive items.

much more efficient. Some of the following

Shift-arrow: Extends the next consecutive

shortcuts are common to most Mac

item to the current selection.

applications; others are only available

Command-click: Adds a non-consecutive

in DEVONthink. In addition, many menu

item to the selection.

commands have keyboard shortcuts. These
are shown directly in the menu.
Note: You can change the shortcuts for
menu commands in System Preferences >
Keyboard > Shortcuts > App Shortcuts.

Manipulating items:
Return: Renames documents.
Backspace: Deletes selected items.
Command-Drag: When dragging items from
the Finder, this moves, not copies, the file

WINDOWS

into the database.
Option-drag: Duplicates items to the drag

Control-Tab: Cycles focus between the

destination instead of moving it.

item list, view/edit pane, and the Tags bar

Command-Option-drag: Creates replicants

or Inspectors (if visible).

for the items at the drag destination.

Escape: Cancels processes, closes dialogs

Dragging items from the Finder to

or Quick Look previews, etc., depending on

DEVONthink with ⌥⌘ pressed indexes the

the context.

item. Dragging items into documents with

Command-}: Cycles to the next tab.

⌥⌘ held inserts a link to the item.

Command-{: Cycles to the previous tab.
Item List:
Note: Hold ⇧ to cycle in reverse order.
Command-Shift-O: Opens a selected
DOCUMENT LISTS

document in the system default
application.

Navigating items:
Up/Down arrow: Navigates up and down in
all views. Use ⇧ to select multiple entries.
Left/Right arrow: Expands or collapses the
selected groups in horizontal split, vertical
split or List views, or navigates to previous/
next item in other views.
Option-click (the triangle in front of a
group): Expands or collapses all groups that
are contained within this group as well.

Tab: Jumps to the first or next editable
column when using View > List.
Space: Opens the standard Quick Look
panel showing a preview of the selected
items.
Option-Space: Opens a full screen Quick
Look slideshow.
Option-bracket: Using [ and ], goes
backwards and forwards through the
visited locations.

Option-Left/Right arrow: Expands or
collapses the selected groups and all their
children the item list.
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VIEW/EDIT PANE
Home/End: Goes to beginning of, or end of,
any view.
Page up/down: Scrolls one page up and

Arrows: Moves the editing selection.
Escape: Stops editing.

PDFS

down in any view.

+: Zooms in.

Space/Shift-Space: Scrolls one page down

-: Zooms out.

or up in non-editable views, e.g., web pages,

Command-drag: Scrolls the visible area

images, or PDF documents.

with the mouse.

Command-click: Opens the target of a link
in a new tab or separate window.
Command-Option-drag: Inserts a crosslink for groups or documents dropped
into a rich text document. Dragging files

IMAGES
+: Zooms in.
-: Zooms out.

or folders from the Finder to a rich text
document with ⌥⌘ pressed creates links to
them.
Command-Shift-click: Opens a link in a new
tab and activates it. This requires enabling
tabbed browsing in Preferences > General.
Option-bracket: Using [ and ], goes
backwards and forwards through the
documents or visited web pages .
Option-drag: Selects text using a

CONTEXTUAL MENU ITEMS
DEVONthink also provides many commands
in contextual menu items, shown when you
Control-click on elements in the application.
Many of the contextual menu items are also
found in DEVONthink's menus. Below is a
list of common menu items you'll find in
the contextual menus for documents and
windows.

rectangular selection ribbon.
Option-click (a link): For HTML-based files,

DOCUMENT CONTENTS

adds the clicked URL to the Download
Manager panel.

When you Control-click in the contents of

Option-click (a word): Initiates a search

documents, you will see a contextual menu

with the clicked word as the search term.

with commands and options. The items

Shift-arrow: Expands or contracts the

shown are related to the file type and if you're

current text selection.

interacting with a selection in the document.
Specific items, e.g., commands relating only

SHEETS

to PDFs, are covered in their respective
sections.

Return: Moves one cell down for editing.
Shift-Return: Moves one cell up for editing.
Tab: Moves one cell to the right for editing.
Shift-Tab: Moves one cell to the left for
editing.
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In editable documents:
Add to Favorites: Adds the current
document to the Favorites.
Add to Reading List: Adds the current
document to the Reading List.
Services: Displays the macOS Services
menu.
Text or links in text:

WikiLink is a document with the same
name as the selected text. If no document
with that name exists, clicking the created
link creates it using the template you have
set in the Preferences.
Open Link in Browser: Opens the selected
link in the default browser or application.
Open Link in DEVONagent: Opens the
selected link in a DEVONagent Pro browser
window.

Add Link to Reading List: Adds a link to the
Reading List.
Add Link: Allows you to enter a URL for the
selected text, converting the text to an
active link.
Add tag [word]: Tags the document with
the selected word (only available if the
word is not already a tag of the document).
Copy Link: Copies a clicked link to the
clipboard (only available for selected links).
Edit Link: Edits the destination of a
selected link. Selecting this option allows
you to remove the link as well.
Insert Link To: Inserts a link to an item you
select in the submenu (only available when
no text is selected).
Insert Placeholder: Inserts a predefined
placeholder or one specified as custom
metadata in Preferences > Data.

Open Link in New Tab: Opens the selected
link in a new tab in DEVONthink.
Open Link in PhotoStickies: Opens a link in
PhotoStickies.
Open Link: Opens the selected link.
Remove Link: Use this to remove the link
status of selected text.
Search with Google: Searches for the
selected text in Google.
Search [word]/Selected Phrase: Searches
for the selected word or phrase in your
open databases.
See Related Text: Displayed like search
results, this shows a list of documents
related to the selected text passage. This
option is only available when more than
one word is selected.
See [word]: Opens a drawer with
documents related to the selected word.

Highlight: Highlights the selection with
the current highlight color. Using this
command on a selection again removes the
highlighting.
Link To: Makes the selected piece of text a
cross-link and links it directly to the group
or document you select in the submenu.
Look Up [word]: Looks the selected text up
in macOS's Dictionary.
Make Link: Makes the selected piece of
text a WikiLink. The destination of the
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Set Name As: Sets the name of the

Convert: This submenu displays options for

document to the selected piece of text

converting from one file type to another.

(needs to be less than 256 characters).

The options shown here are dependent on

Share: Shares selected text via the

the type of file selected.

available sharing extensions.

Copy Item Link: Copies a link to the current

Add Link to Downloads: Adds a link to the
Download Manager.
Images and PDF documents:

item.
Copy URL: Copies the URL of the selected
document to the clipboard. This only
appears when one document is selected.
Duplicate To: Duplicates the selected item
Actual Size: Displays the document at
its actual size. Uses also the resolution
information contained in the file.
All Pixels: Zooms the image so that one
image pixel equals one pixel on the screen.
Zoom In/Out: Zooms in or out of the
document, or displays it in its actual size.
Zoom To Fit: Zooms the image so that
it fits into the view/edit pane or the
document window.
Zoom To Width: Zooms the image to fit
the width of the view/edit pane or the
document window.

to the group you select from the submenu.
Get Info: Opens an popup containing more
detailed information about the currently
selected file or group.
Group Items: Groups multiple selected
items in an item list.
Label: Changes the label of the selected
item.
Launch URL: Opens the URL in the selected
item's URL field. Hold the ⌥ Option key to
choose Launch URL in Background. This
keeps DEVONthink in the foreground.
Mark: Changes the flagged, locked, or read
status of the selected item.

ITEM LIST

Move Into Database: Moves an indexed

These contextual menu items are commonly

item into the database. Use this command

shown when you ⌃-click items in a main

with caution as it moves the file from its

window's item lists. In items lists, the

current location into the internals of your

commands are also often available in the

database. It does not copy the file.

Actions toolbar button. Some of these

Move To External Folder: Moves a non-

commands are also seen in the See Also &

indexed item, e.g., imported or created in

Classify Inspector pane.

DEVONthink, out to an indexed folder in
the Finder.

Add To: Commands in this submenu add

Move To: Moves the selected item to the

the currently selected documents to your

group you select from the submenu.

Favorites or the Reading List.

Move to Trash: Moves the clicked item to

Apply Rules: Runs a chosen smart rule on

the Trash. Hold the ⌥ Option key to shows

selected items matching the location and

Move All Instances to Trash when used in

criteria of the rule.

items lists.
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New: This submenu allows you to quickly

Show in Finder: Shows the selected item in

create several built-in file types. See the

the Finder.

Data menu for more information on these

Tags: This submenu offers special

file types.

commands for automatically adding some

New from Template: This submenu allows

kinds of tags. See the Data menu for more

you to create new documents from any of

information.

the installed templates.

Thumbnails: This submenu allows you to

Open: Opens the selected item in a

Create, Update, or Remove the thumbnail

separate main window or document

for a file.

window.

Ungroup Items: Ungroups a group, leaving

Open in Tabs: Hold the ⌥ Option key and

its contents behind. The group is not

Open changes to Open in Tabs. If the View/

preserved.

Edit pane is visible, this opens the selected
items in new tabs. If the View/Edit pane
isn't visible, a new document window will
open with each selected document in its
own tab in the window.
Open With: Opens the selected item in an

Imprinter: Choose an imprint you've
defined in Preferences > Imprinter to apply
it to the current image or PDF.
OCR: Choose the output file type and
convert a compatible file via OCR.

external application.

Note:

Rating: Allows you to set a rating, from no

Send by Email: The ability to add the

stars to five stars.

attachments depends on the inter-

Replicate To: Replicates the selected item

application capabilities of the email

to the group you select from the submenu.

application. If it doesn't provide support

Reveal: Shows and selects the selected

for this, you may be able to drag files into

item in its location in DEVONthink.

draft message or the email application's

Send by Email: Sends the selected item by

dock icon.

email.

SEARCH OPERATORS
Searching in DEVONthink already is a powerful function. The addition of Boolean operators,
parentheses, and wildcards extend the power to fine-tune your search even further.
Note: The syntax of the operators is compatible to DEVONagent and EasyFind, the Finder,
Spotlight, common search engines as well as common programming languages such as C, C++,
Objective-C, Java, and JavaScript. The complexity of the query is unlimited.

CASE
All terms are case-insensitive. You may, if you wish, use capitalization for proper names in a query,
but DEVONthink will ignore case in interpreting the query.
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PRECEDENCE OF TERMS
Search terms and associated operators will be interpreted from left to right, except as modified
by including portions of the query within parentheses.

WILDCARDS
You can replace parts of words with wildcards matching one, multiple, or a range of characters:
?: Matches exactly one character.
*: Matches none, one, or multiple characters.
[a-b]: Matches one character of the range a through b.
[abc...] or [a|b|c|...]: Matches one character out of the given list of characters.
[^...]: Matches one character that is not contained in the given list or range.

BOOLEAN OPERATORS
The operators (often called Boolean operators) are words or symbols that establish logical rules
for the terms in the search query. If no operator is given, DEVONthink infers AND. The available
Boolean operators are:
term1 AND term2: Contains term1 AND term2
term1 BUT term2: Contains term1 AND term2
term1 OR term2: Contains term1 OR term2
term1 XOR term2: Contains term1 or term2, but not both
term1 EOR term2: Contains term1 or term2, but not both
NOT term: Does not contain term
"term1": Contains the string of words term1, in exactly this form
Besides the classic Boolean operators, DEVONthink uses a number of operators that usually are
found in high-end databases. Use these operators as a replacement for AND and "quotes" to fine
tune your query.
term1 OPT term2: term1 is required, term2 is optional. If term2 is also found, the found
document ranks higher in the search results.
term1 NEAR term2: term1 occurs 10 words or less before or after term2
term1 NEAR/n term2: term1 occurs n or less words before or after term2
term1 BEFORE term2: term1 occurs before term2
term1 BEFORE/n term2: term1 occurs n or less words before term2
term1 NEXT term2: term1 occurs right before term2 (shortcut for BEFORE/1)
term1 NEXT/n term2: term1 occurs n or less words before term2 (synonym for BEFORE/n)
term1 AFTER term2: term1 occurs after term2
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term1 AFTER/n term2: term1 occurs n or less words after term2
~term1: Contains term1, also as part of a word
For convenience, some of these operators can also be abbreviated using commonly used symbols:
AND: &, &&, +
OR: |, ||
XOR: ^, ^^
NOT: !, Operators are evaluated in the following priority: parenthesis > phrase/hyphens > (NOT)
BEFORE/AFTER/NEAR/NEXT > NOT > AND/OR/XOR/EOR. Terms with same priority but without
parenthesis are evaluated from left to right.

WHITE SPACE HANDLING
Words linked by non-white separators (e.g., page-index or page_id) are treated like phrases put
into "quotes". Words separated by hyphens are handled like word1word2 OR "word1 word2".
Characters separated by dots are considered to be abbreviations and therefore handled like
words separated by hyphens, e.g., the term t.a.t.u is equal to "t a t u" OR tatu.
EXAMPLES
By using any or all of the operators and rules laid out above you can create complex queries that
find the exact information you're looking for. Here are some example queries that show how the
operators are used.
Example: Devonian Dinosaurs
This query looks for all documents that contain the words "devonian" and "dinosaurs".
Example: (Steve NEAR Jobs) AND iMac BUT NOT MacBook OPT Pro
This query looks for documents that contain the words "Steve" and "Jobs" no farther ten words
away from each other, as well as the word "iMac" (no specific position relative to Steve and Jobs),
but not the word "MacBook". The word "Pro" does not need to occur, but if it does, the document
is ranked higher in the list of search results.
Example: Paracetamol NEAR (~effect OR impact) AND ((side OR second*) NEAR/2
~effect)
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This query looks for documents containing the word "Paracetamol" near (within 10 words) to
words either starting with "effect" (and so also "effects") or "impact". In addition, the document
needs to contain the word "side" or any word starting with "second" located within two words
range of any word starting with "effect".

SEARCH PREFIXES
DEVONthink supports a wide variety of
searchable attributes. These include common
attributes, like names or tags, but also
include document or DEVONthink-specific
items, like word counts or custom metadata
you've defined.

docRecipients: The name of a recipient of
an email.
docRecipientEmailAddresses: The email
address of a recipient of an email.
docTitle: The title of a file. The title may be
distinct from its name, e.g., a song title for
an MP3 file.
docComment: The RTF-specific comments

Similar to searching with Spotlight or some

for a file.

other applications, the use of search prefixes

docHeadline: A headline applied to some

is supported. These take the form of a

files. Rare.

prefix and a prefix operator, e.g., name:,

docSubject: The subject line from an email.

followed by the search term. These prefixes

docDescription: The description found on

are automatically applied when you choose

some files, typically images.

criteria in an advanced search but they can

docKeywords: The PDF or RTF specific

also be manually entered in the search field.

keywords for a file.
docOrganization: The company specified in

SEARCH PREFIXES

imported links or vCards from the Contacts
application.

Below is a list of the available search field
prefixes as you would manually type into the
search field or a script:

docCopyright: Copyright information in the
metadata of a file.
docAlbum: The album information from

text: Text contents in a file.

media metadata, e.g., MP3 files.

metadata: The metadata for a file.

docComposer: The composer information

name: The name of a file. This is distinct

from media metadata, e.g., MP3 files.

from the filename and does not include the

docCreator: The process or application

file extension.

used to create a file.

url: The associated URL.

docProducer: The producer of a file, usually

comment: Spotlight Comments.

applied to media files.

docAuthors: The name of the sender of an

aliases: Aliases applied to a file.

email.

tags: Tags applied to a file.

docAuthorEmailAddresses: The email
address of the sender of an email.
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label: The color label of a file, from 0 (no

openingDate: The date the file was last

label) though 7 or by name, e.g., Important.

opened.

rating: The star rating of a file, from 0

dueDate: The due date set in a Reminder

(unrated) through 5.

for a file.

width: The width of a document in points,
i.e., the width multiplied by 72.
height: The height of a document in points,
i.e., the height multiplied by 72.
length: The number of pages in a file or
length of a media file in seconds.
size: The size of a file in bytes, KB, MB, or
GB, e.g., size >= 50 MB.
wordcount: The number of words in the
contents of a file.
charactercount: The number of characters
in the contents of a file.
hits: The number of times a file has been
viewed or opened.
filename: The name of the file in the file
system, including the file extension.
extension: The extension of a file, e.g., txt.
This also supports an Any Extension option
to filter filenames having or lacking an
extension.
kind: Supports any, group, smartgroup,
tag, ordinarytag, grouptag, text,
rtf, formattednote, markdown, html,
webarchive, xmlfile, propertylist,
image, pdf, quicktime, video, audio,
bookmark, feed, news, script, sheet,
email, and other.

md_attachments: The number of
attachments in an email or the number of
resources added to an RTFD file.
md_annotationcount: The number of
annotations set in a PDF file.
md_encrypted: The encrypted state of
a PDF. This is a Boolean value denoted
numerically, e.g., md_encrypted==1 when a
file is encrypted.
md_incomingItemLinkCount: The number
of item links to a document from other
documents in DEVONthink.
md_outgoingItemLinkCount: The number
of item links to other documents present in
a document.
md_language: An abbreviation of the
detected language in the contents of a file.
For a list of values, select a language in the
criteria and note the abbreviation to use.
md_country: An abbreviation of the
country in the geolocation data for a file.
For a list of values, select a country in the
criteria and note the abbreviation to use.
md_zipcode: The postal code detected in
the geolocation data for a file.
md_area: The state, province, or region
detected in the geolocation data for a file.

additionDate: The date the file was added

md_locality: The city detected in the

to the database.

geolocation data for a file.

creationDate: The date the file was
created.
modificationDate: The date the file was
last modified.

Item prefixes: These special prefixes are
for state-based queries, like the locked or
indexed state of items. They all follow the
form of item:<specified state>, e.g.,
item:locked.
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Flag: The flag state of a file. Supports
flagged or unflagged.
Unread: The unread state of a file.
Supports read or unread.
Locking: The locking state of a file.
Supports locked or unlocked.
Item: A special item supporting instance
states: replicated, duplicated, indexed,
pending, or tagged.
There are also two special prefixes you can
use:
scope: This limits where you are searching.
It supports selection (the current group
or database), referring to a database by
name (in quotes), and inboxes. If no scope
is specified, the search applies to all open

PREFIX OPERATORS
Many times prefixes end with a colon, e.g.,
tags: but some use other forms, depending
on the available options in the criterion.
For example, words can "begin with" some
characters, but a size is greater or less than a
value. If you select a criterion you would see
what options apply. Use the keys below to
map the option to its operator.
Matches, Is, Is Not:
: is equal to the term matches. With stringsbased queries, it allows for wildcards to
be used. It is also used for state-based
queries, like Kind. The negated form, :! is also
supported.

databases. When used, scope: should be

== is equal to the term is. This must be an

the last parameter in the query.

exact match of the search term. These can

any: When used, this allows you to specify

be used in strings and number-based queries.

whether to return results matching any of

The negated form, != is also supported.

the criteria. This can only be used when
specifying more than one search prefix,
e.g., tags and filename.
Example:
additionDate>=2019-03-10
scope:selection
tags:sync; methods scope:"Tech
Stuff"
any: name:test OR imprint {any:
tags:blue; red}
Sub-criteria searches: Yes, you may have
noticed in the last example a tags search in
curly braces. This creates sub-criteria for the
search. This obviously extends the search
options to allow creating even more complex
forms.

Example:
Kind is Group → kind:group
Item is indexed → item:indexed
Item is not Replicated → item:!
replicated
Extension is XML Document →
extension==XML
Language is not English → language!=en
String Matching: These are operators that are
used with string-based queries, like names or
text content. These queries also support:
:< is equal to begins with.
:> is equal to ends with.
:~ is equal to contains. (The tilde is the
second key down on the top left of an English
keyboard.)
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Example:
Subject begins with party →
docSubject:<party
Locality ends with field →
md_locality:>field
Name contains tech → name:~tech
Number Matching: In addition to the == and
!= operators, numbers can also use these
operators:
< is equal to the term is less than.
<= is equal to the term is less than or equal
to.
> is equal to the term is greater than.
>= is equal to the term is greater than or
equal to.
Example:
Word Count is less than 1000 →
wordcount<1000
Size is greater than 10MB → size>10 MB
Hits is greater than or equal to 1 → hits>=1
Date Operators: These are operators used
with date-based queries, like the creation
date of files.
< is equal to the term before.
<= is equal to the term before or on.

> is equal to the term later.
>= is equal to the term later or on.
:# is equal to the term within last number
of days. The negated form, :!# is also
supported.
: is equal to the term is for date-based
queries. Supported date options are Today,
Yesterday, This Week, Last Week, This Month,
Last Month, This Quarter, Last Quarter, This
Year, and Last Year. The negated form, :! is
also supported.
Example:
Date Created is after January 31, 2019 →
creationDate>=2019-01-31
Date opened is not within last 5 days →
openingDate:!#5days
Date Due is not Today → dueDate:!Today
Date searching allows for some flexibility in
formats. Time is not a required parameter,
but can be specified. These searches are all
equivalent:
Example:
additionDate>10 march, 2019
additionDate>March 10, 19
additionDate>2019-03-10 08:30:00
-0500

TEMPLATES
DEVONthink comes with a number of built-in templates for general use. Use these templates to
add a task list, a quote, or whole group structure for project management to your database.
Templates are stored in the ~/Library/Application Support/DEVONthink 3/
Templates.noindex folder. In order to manage your templates, rename them, organize them
in subfolders, or delete them, you can quickly access this folder by selecting Data > New from
Template > Open Templates Folders. More templates are available by selecting Data > New from
Template > More Templates, or as extras in the Support Assistant or in the Extras sidebar.
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A very useful thing you can do is add your own files to this folder, even if the files aren't directly
editable in DEVONthink. For example, you may have a specific Pages template you often use.
Open the template in Pages and save it into DEVONthink's Templates folder. Now you can add
documents to your database even more efficiently.

BUILT-IN TEMPLATES
DEVONthink comes with the following built-in templates, which serve as great examples of the
template feature.
Accounts & Passwords:
Email Accounts: Adds a sheet to record technical details of an email account details.
Online Account: Adds a sheet for storing website account details.
Serial Number: Adds a sheet for storing product serial numbers.
Classifications:
Decimal Filing System: Adds ten groups for the decimal filing system used by many European
companies for filing (scanned) paper documents.
Dewey Decimal Classification: Inserts a group with sub-groups that builds the first levels of the
Dewey Decimal Classification. Use this feature for databases that contain knowledge spanning
many subjects.
Library of Congress Classification: Inserts a group with sub-groups that builds the first
levels of the Library of Congress Classification. Use this feature for databases that contain
knowledge spanning many subjects.
Education:
Cornell Notes: Adds a document that allows you to write notes in Cornell style on a topic of
interest. Available as Markdown or rich text documents.
Cornell Notes (Education): Adds a document that allows you to write notes in Cornell style for
a particular course and topic. Available as Markdown or rich text documents.
Lab Notes: Adds a document that allows you to create lab reports. Available as Markdown or
rich text documents.
References: Adds a sheet for recording citation information such a DOI, authors, journal,
publication year, etc.
Reference (from Bookends): Adds the reference selected in Bookends to your database.
Reference (from Endnote): Adds the reference selected in Endnote to your database.
Quotes: Adds a sheet for recording quotes along with the author, source, comments, etc.
Quote (from clipboard): Adds a rich text document for a quotation or citation. The clipboard
content is automatically inserted and, if it's an Internet address (URL), it is automatically made
clickable.
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Articles: Adds a sheet for keeping track of articles.
Booklets: Adds a sheet for keeping track of booklets.
Books: Adds a sheet for keeping track of books.
Manuals: Adds a sheet for keeping track of manuals.
Proceedings: Adds a sheet for keeping track of proceedings.
Technical Reports: Adds a sheet for keeping track of technical reports.
Theses: Adds a sheet for keeping track of theses.
PubMed: Runs a query in PubMed and adds the resulting documents formatted as rich text
documents to your database.
Productivity:
Daily Journal: Adds Journal group with month and day subgroups, containing a file with a
daily quote, some news headlines, and space to write your thoughts. This template is a good
example of smart templates. The journal is available in two separate templates: Text (rich text)
and Markdown.
Note: Adds a new note. If the clipboard contains text, it is automatically inserted.
Phone Note: Adds a new phone note, automatically inserting the current date and time.
Project: Adds a simple project group structure including an "About this project" document. The
smart template asks for a project name; retrieves your name, department, email address, and
phone number from your contact card; and adds this information to the "About this project"
document.
Task List: Adds a simple task list.
Weekly Review: Adds a formatted note displaying checklist items and space to review the
week.
Registers:
1--31: Adds 31 groups, numbered 1 through 31.
A--Z: Adds 26 groups, named A through Z.
Days of the Week: Adds groups for the days of the week.
Months: Adds groups for the twelve Christian months.
Smart Groups:
Email ... Videos: Adds smart groups displaying documents of a given kind.
Due or Flagged: Adds a smart group displaying flagged items or items with a due date this
week.
Last ...: Adds smart groups displaying documents modified within a given period.
Documents with Annotations: Adds a smart group displaying files with annotations, e.g.,
highlights.
Large Documents: Add a smart group displaying documents larger than 5 MB.
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PDF (not searchable): Add a smart group displaying all PDF documents that don't contain
machine-readable text.
Star Ratings (1-5): Add a smart group displaying items with a rating of one or five stars.
Toolbar: By default this contains no templates. Add your own templates to ~/Library/
Application Support/DEVONthink 3/Templates.noindex/Toolbar. These can be added to
the DEVONthink windows using View > Customize Toolbar.
Note: Some of the included templates are just simple files. Others are smart templates,
packages that contain assets and scripts that provide powerful template generation. See the
Automation chapter for more information on them.

METADATA

RTF Metadata:

DEVONthink stores a large number of

Author

metadata fields internally when importing

Title

documents from the file system, e.g., from

Comment

PDF, RTF, MP3, EXIF/IPTC, HTML, and email

Subject

messages as well as from all files that deliver

URL

metadata through the Spotlight metadata

Keywords

importer. Here's a partial list of theoretically

Organization

supported fields:

Copyright

FILE METADATA
General Metadata:

Email Metadata:
Authors
Author email addresses

Title

Recipients

Headline

Recipient email addresses

Subject

Email addresses

Creator
Producer
PDF Metadata:

Media and Publication Metadata:
Album
Composer

Author

Contributors

Title

Publishers

Subject

Editors

URL

Organizations

Keywords
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CUSTOM METADATA
Another powerful feature of DEVONthink
is custom metadata fields. Specified in the
Preferences > Data, you can define fields that
are meaningful to you, your company, your
research group, or even your family!

Multi-line Text: Enter a small paragraph of
text. Line breaks can be typed by pressing
Option-Return.
Rich Text: Same as Multi-line text but
supports basic formatting, e.g., bold or
italic text.
Set: Similar to the Single-line text, this

When you create a custom metadata

shows a dropdown with values pre-defined

field, you give it a name. DEVONthink uses

for the field in the Data preferences.

this name to create an identifier for use

However, new values can't be entered

in automated processes. This identifier

outside the preferences.

is created automatically and cannot be

URL: Accepts any valid URL, including

changed.

filesystem URLs.
Link: A special dropdown that allows you to

Data Types: When you define a custom field,
you choose a data type for it. So what's a

choose an item in your databases. a link for
the chosen item is used.

"data type"? It's simply a kind of a value; like
"a" is a character and "42" is a (the!) number.

Note: The Countries and Languages lists

The following data types are supported,

are lengthy, but not necessarily exhaustive.

including any interface items associated with

For Multi-line Text and Rich Text, only one

them, e.g., checkboxes or dropdown menus:

line will be displayed in its column in the
item list.

Boolean: This is a true or false value.
Displayed as a checkbox.

Predefined Custom Metadata: In Preferences

Countries: A dropdown menu providing a

> Data, we have provided some custom

list of country names.

metadata fields to get you started. These are

Languages: A dropdown menu providing a

ready to use and explore and serve as great

list of languages.

examples of the data types discussed above:

Integer: A whole number, e.g., with no
fractional part, like 17.
Decimal Number: A fractional number,
represented with a decimal point.
Date: Can be specified as Date & Time or
Date.
Identifier: Any alphanumeric value,
specified as needed, e.g., a customer or
patient number.
Single-line Text: A dropdown providing a
list of terms you defined for the field in the
Data preferences. You can also type in a
new value.

Date
Company
Author
Abstract
Status
Serial Number
ISSN/ISBN
Digital Object Identifier (DOI)
PubMed ID
PMC ID
Barcode
Format
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Category

File Name: The filename in the file system.

Subcategory

File Extension: The extension of the file.

Genre

Kind: The kind of the file, e.g., group or rich

Country

text document.

Language

URL: The URL in the Info pane.

Price

Location: The location in the database; e.g.,

Tax

/Inbox/Research.

Tip

Tags: Tags applied to the file.

Decimal

Digital Object Identifier: The unique digital
object identifier of the file, if available.

PLACEHOLDERS

Index: This is a number that increments

One of the most powerful features of

based on the number of items being

DEVONthink is the ability to insert data

processed by a smart rule.

dynamically. A placeholder is a bit of code

Counter: Similar to the Index, this is a zero-

DEVONthink interprets when used in these

padded incrementing number.

scenarios, replacing it with a specific value.

Document Amount: This is an amount

You may have an imprint with a Name

detected in the name or content of

placeholder defined in the title. When the

documents, like receipts or invoices. Often

imprint is used on a PDF, the placeholder is

used with smart rules.

converted to the name of the file!

Document String: This is a string detected
in the name or content of documents.

To extend the possibilities even further,

Typically used with smart rules.

you can combine static text and multiple

Bates Number: Inserts a Bates number.

placeholders to achieve truly custom results.

Page Count: The total number of pages in

You can use these in smart rules and the

the document.

command Tools > Batch Process, in alarms on
Reminders, custom imprints on images and

Group Name: The name of the group

PDFs, and in templates for creating WikiLinks

containing the document, e.g., /001/a/b/

documents.

myfile.txt would report b as the group
name.

Below is a list of placeholders currently

Top Group Name: The name of the top level

available:

group in the root of the database, e.g.,

Name: The name or title of the file.
Proposed Name: A suggested name derived
from a document's title or from the first
line of the document if no title is present.
Aliases: Any aliases applied to the file.
Finder Comment: Any Finder comments
applied to the file.

/001/a/b/myfile.txt would report 001 as
the top group name.
Database Name: The name of the database
containing the document.
Database Path: The filesystem path of the
database.
Attachments: The number of attachments
in a file.
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Language: An abbreviation of language

of data and the file the data is inserted

detected in the document's indexed

into.

contents.

Predefined Author: This is the Author

Country: The country in the geolocation

specified in DEVONthink's Preferences >

data for a file.

Editing.

Postal Code: The postal code derived from

Username: The shortname of the current

the geolocation data for a file.

macOS account.

Administrative Area: This is state, province,

Full Username: The longname of the

or region in the geolocation data for a file.

current macOS account.

Locality: The city in the geolocation data

Organization: This is the company name, if

for a file.

defined by the (Me) contact card in macOS

Tab: A tab character.
Line Break: A line break (return) character
for multi-line text.
Current Date: Today's date.
Addition Date: The date the file added to
the database.
Creation Date: The date the file was
created.
Modification Date: The date the document

Contacts.
Email Address: The primary email address,
as defined by the (Me) contact card in
macOS Contacts.
Host: The hostname of the machine.
Properties: These are potential metadata
properties found in the current file. A more
extensive listing of these can be found in the
Metadata section.

was last modified.

Custom Metadata: This menu lists any

Document Date: This is a date detected in

custom metadata fields applied to the file.

the document's contents, e.g., in a receipt.
For PDFs only the first four pages are used.
Newest/Oldest Document Date: The

SMART RULE EVENTS AND
ACTIONS

newest or oldest date detected in the
document. For PDFs, only the first four

Smart rules in DEVONthink provide many

pages are used.

powerful actions and events that can trigger
these actions. Below is a list of the available

When using dates, you can choose the format

options for both.

as defined in System Preferences > Language
& Region > Advanced > Dates. The default

EVENTS

is the medium format, but you may choose
short or long formats as well. You can also

When an action is triggered is almost as

choose specific parts of the date or time, e.g.,

important as the action itself. Actions can be

the month, year, or hour only.

triggered when any of these events occur:

Clipboard: Inserts content currently on the
clipboard. It can be inserted as rich text,
plain text, or a link, depending on the type
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On Demand: Run only when Apply Rule is

On Download: Runs when items are

selected in a contextual menu or Tools >

downloaded via DEVONthink's Download

Apply Rules.

Manager.

On Startup: Runs when DEVONthink

On Scan: Runs after a scanning operation

launches.

has completed.

Before Synchronization: Runs all actions

On OCR: Runs after an OCR operation has

before DEVONthink begins synchronizing

completed.

to any sync location.

On News: Runs when an RSS feed refreshes

After Synchronization: Runs all actions

and receives new articles.

after DEVONthink completes synchronizing
to any sync location, i.e. all uploads,
downloads, and changes are committed.
On Quit: Runs when DEVONthink quits.
Every Minute: Runs the specified actions
every minute.
Hourly/Daily/Weekly: Runs the specified
actions on an hourly, daily, or weekly
schedule.
On Workdays: Runs on Monday through
Fridays.
On Weekends: Runs on Saturday or Sunday.
On Creation: Runs when a new document
is created in the specified location. To
trigger actions when taking notes or screen
captures with the Sorter, choose Via
Sorter.
Before Saving: Runs before saving a
matched document.
After Saving: Runs after saving a matched
document.
On Imprinting: Runs when any matched
document has been imprinted.

On Upload: Runs when an item is uploaded
through DEVONthink's web server.
On Open: Runs when a matching item is
opened in a new document window or
viewed in a main window.
On Open Externally: Runs when a matching
file is opened in an external application.
On Launch URL: Runs when the URL
associated with the item is launched.
On Reminder: Runs when an alarm set on a
matching item's Reminder comes due.
On Renaming: Runs after matched items
are manually renamed.
On Moving: Runs when matched items are
moved to the specified location.
On Classifying: Runs when matching items
are classified by DEVONthink.
On Tagging: Runs when matched items are
tagged
On Replicating: Runs when matched items
are replicated.
On Duplicating: Runs when matched items
are duplicated.

On Import: Runs when documents are

On Moving into Database: Runs when

added to the specified location.

indexed items are moved into the

On Clipping: Runs when documents

database, becoming imported items.

are added via clipping, e.g., via menu

On Moving to External Folder: Runs when

commands, the Sorter, DEVONagent,

imported or created items in a database

bookmarklets, or AppleScript.

DEVONthink 3.6 Documentation, page 226

are moved to external locations, becoming

the name of a group you've defined in your

indexed items.

contacts.

You can and and remove multiple event
triggers by pressing the + or - buttons. Fox

Add to Reading List: Add the matched
items to the Reading List.

example, you could use an On Import and

Open Externally: Open the matched file in

an On Moving event trigger to act on files

the system default application.

imported or moved into it.

Launch URL: Open the URL associated
shown in the Info Inspector & URL.

ACTIONS
The power in smart rules is the actions.
DEVONthink provides actions that cover
simple tasks, e.g., prefixing a filename, all the
way to ultra-powerful AppleScript injection
via external or embedded scripts. Since you
can chain multiple actions together, the
possibilities are nearly endless. Here's a list of
available actions:
Bounce Dock Icon: Causes DEVONthink's
dock icon to bounce. This will only trigger
when DEVONthink isn't the active
application.
Display Notification: Shows a message
via the Mac's Notification Center.
Notifications need to be enabled in System
Preferences > Notifications for Display
Notification to operate correctly.
Display Alert: Shows a message in an alert
window.
Speak Text: Using your computer's voice
synthesis, it will speak the message you

Check Bookmarks: Checks the URL of the
matched items. Any issues with the URL
are reported in the Log window or the Log
popover.
Execute Script: Execute External or
Embedded scripts. Embedded scripts are
created in a popup menu and only available
to the smart rule they are created in. See
also p. 193ff
Item scanning: The next two actions allow
you to scan the name or text of a document
and use the results when found. Each of the
actions also has a parameter you specify
for the type of data you're scanning for.
These actions and parameters can be used
with subsequent actions that support
placeholders, e.g., Scan Text: Date →
Document Date with Change Modification
Date. If the action returns no results, actions
using the results will not be executed.
However, unrelated actions in the smart rule
chain will be executed normally.

specify.

Scan Name: Scans the name of the file.

Play Sound: Plays a selected system alert

Scan Text: Scans the contents of the file.

sound.
The following four parameters are used with
Send Mail: Enter email addresses to send

the Scan Name and Scan Text actions. With ,

the matching items. This can be a comma-

, and , a prefix and/or suffix before/after the

delimited list of addresses, names, or enter

wildcard has to be specified.
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String: An asterisk (*) wildcard specifies

the matched file. For items with an existing

data to be captured. Other terms added

attribute, e.g., a comment, a placeholder

will be used to help located the desired

will preserve the existing value.

string. In subsequent actions, use the

Mark: Toggle the state of read/unread,

Document String placeholder to represent

flagged/unflagged, and locked/unlocked.

the captured string.

Note you change more than one of these

Date: Similar to String parameter, use the

attributes with one action, but you can

desired format of the Document Date

chain more than one Mark action in the

placeholder to represent the captured

smart rule.

string in subsequent actions.

Change Creation/Modification Date:

Amount: Similar to String parameter,

Change the creation or modification date

use the desired format of the Document

of matched files to: current, addition,

Amount placeholder to represent the

creation, modification, or the document

captured string in subsequent actions.

date.

Regular Expression: Items in parentheses
are captured; items outside parentheses
are ignored. You can specify multiple
captures in an expression. Using the
captured text in subsequent actions is
specified by using backslash, \, and the
number of the capture, starting at 1. Note
we use Apple's NSRegularExpression which
supports the ICU regular expression syntax.

Add Tags: Add tags to the matched files.
As you type, tags from all open databases
will be suggested. Press the comma key to
commit the tag.
Add Tags from Document: Adds existing
tags if they are detected in the matched
document's contents.
Remove Tags: Removes specific tags you
enter.

Example:

Remove All Tags: Removes all tags from the

Using the String parameter, Invoice *

items.

would capture 0012345 in a file named

Tags: Adds or converts tags to matched

Invoice 0012345..

documents from these commands:

Using the Date parameter, * would

Convert HashTags, Convert Keywords,

capture the date in a file named

Convert Properties, Convert Geolocation,

2020-01-01.

Add Tags to Images, and Scan Barcodes.

Using the Amount parameter, $* would

(See the View menu for more information

capture the dollar amount detected.

on these options.)

Using the Regular Expression parameter,
Bill To: ([A-Za-z0-9 ,]+) would
capture the name of the person or
company billed. \1 would be used in the
subsequent action.
Change Name/Aliases/Comment/Label/

Move/Replicate/Duplicate: Move, replicate,
or duplicate a matched file to a chosen
location.
Duplicate & Continue: Duplicates matched
files and applies subsequent actions to the
copies.

Rating: Change the specific attribute of
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File: Allows you to file items into a group.

set this field to true when the action is

Specify subgroups using a forward slash,

triggered.

e.g., 2019/DEVONtech would create or file
into the DEVONtech subgroup of a 2019
group in the current group. You can use
placeholders to define the location.
Classify: Using our AI, this will attempt
to move any matched files to an apropos
location. Failures to classify files are noted
in the Log window.

Move to Trash: Move the item to the
database's trash. The items are not
removed from the database until the trash
is emptied.
Delete: Be very cautious with this option.
Delete truly deletes a file. It is not sent to
the database's trash. It is not sent to the
Finder's trash. It is completely deleted.

Move Into Database: Moves indexed items
into the database, essentially importing

SCRIPTS

them. Note this removes the file from the
original location in the filesystem.

Below is a list of the DEVONthink supplied

Move To External Folder: For an item

scripts, segregated by the menu items in the

located in an indexed group, this moves the

Script menu:

file to the indexed folder in the Finder.
Convert: Attempts to convert files
into plain/rich text, formatted notes,
Markdown, HTML, web archive, or PDF.
Convert & Continue: Converts files and
applies subsequent actions to the copies.
Imprint: Apply the selected imprint to any
matching files, if possible.

Comments:
Append Selected Text: Adds the selected
text to the comments of the current
document.
Assemble: Collects the comments of the
selected documents and creates a new
document listing them.
Convert to Tags: Converts the tag

OCR: This will perform OCR on a file, if

contained in the comments field to real

possible. Choose a format to generate

tags if the comments field of the selected

a new file in the selected file type. Note

document contains tags separated by

the file type selected will override the

commas.

option set in Preferences > OCR > Convert

Speak: Speaks the comments of the

incoming scans to. Choose Apply to

selected documents.

convert a matched file directly to a PDF

Data:

with OCR. This action does not generate
new files.

Move Duplicates to Trash: Moves all
duplicates of the selected document to the

Custom Metadata: If you have specified
custom metadata fields, you will have
options to change values with an action.

trash.
Find & Remove Similar Contents: Finds and
removes similar documents.

For example, if you had a Boolean field
named "Done", you could have the action
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Group With Duplicates: Creates a group

database in ~/Backup. All backups are

with duplicates of the selected documents.

include a datestamp in the filename for

Group With Replicants: Creates a group

easy tracking and identification. These can

with replicants of the selected documents.

be useful for copying to external media or

Verify & Optimize Databases: Runs a

uploading to a cloud service as a secondary

verification on all open databases and

backup strategy.

optimizes them if they verify successfully.
Errors are alerted and logged to Window >
Log.
Download:

Feeds:
Nature -- Hubble News: Downloads the
latest Hubble news.
iTMS -- Added Albums: Downloads covers

Linked Images of Page: Adds linked images

of albums recently added to the iTunes

of a displayed web page to the database.

Music Store.

Images of Page: Adds the images of a
displayed web page to the database.

Format:

Links of Page: Adds links contained on a

Body Normal: Formats selected text as

displayed web page to the database.

"Body Normal".

Download as…: Converts bookmarks to

Body Small: Formats selected text as

one of these formats: Formatted Notes,

"Body Small".

HTML Pages, PDF Documents (One Page or

Header Capitalized: Formats selected text

Paginated), and Web Archives

as "Header Capitalized".

Edit:

Header Main: Formats selected text as
"Header Main".

Count Characters: Counts the characters

Header Secondary: Formats selected text

in the current selection.

as "Header Secondary".

Count Words: Counts the words in the

Source: Formats selected text as "Source".

current selection.

Reset Spacing: Resets the line and

Execute:
AppleScript: Executes an AppleScript

paragraph spacing of selected rich text.
Images:
script.

Copy Info to Comment: Copies basic image

Perl: Executes a Perl script.

info to the comment field.

Shell: Executes a shell script.

Flip Horizontal / Vertical: Flips the image

Export:

horizontally/vertically.
Rotate Left / Right: Rotates the image

Listing: Saves a UTF-8 text file containing

left/right.

a text listing of the names of all contents/

Landscape to Portrait: Rotates only

groups of the current database.

landscape images to portrait.

Daily Backup Archive: Creates a

Portrait to Landscape: Rotates only

compressed backup (.Zip) of the current

portrait images to landscape.
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Scale to 1024 pixels: Scales the image to
1,024 pixels.
Scale to 200%: Scales the image to 200
percent.
Scale to 50%: Scales the image to 50
percent.
Import:
Del.icio.us: Imports your del.icio.us
bookmarks. The descriptions are used to
name the imported bookmarks; the notes
and the tags are added to the comments.
If the keychain does not contain a key for
del.icio.us, dialogs pop up allowing you to
enter the user name and password.
Man Page: Imports a UNIX manual page as
a PDF document.
Perldoc: Imports the documentation of Perl
pages, modules, functions, or programs.
Reminders:
Add as Event to Calendar: Adds a new
event to Calendar linking back to the
selected item in DEVONthink.
Add as To Do to OmniFocus: Adds
the selected item as a to-do item to
OmniFocus.
Add as To Do to Reminders: Adds
the selected item as a to-do item to
Reminders.
Add as To Do to The Hit List: Adds the
selected item as a to-do item to The Hit

Rename:
Append Selected Text: Appends the
selected text to the title of the currently
selected item.
Replace Text: Replaces a text passage in
the titles of selected documents.
To Webpage Title: Sets the titles of the
selected documents to the names of the
web pages pointed to by their URL fields.
To Subject: Sets the titles of the selected
documents to the subject lines of the email
messages if the selected documents are
email messages.
Sheets:
Add Multiple Records: Adds up to 999
empty records to a sheet.
Column Sum&Mean Value: Calculates the
sum and average of a table column.
Row Sum&Mean Value: Calculates the sum
and average of a table row.
Check sums in last column: Checks the
sums in the last column on validity.
Tabs:
Open Bing: Open a new tab for the Bing
search engine.
Open Google: Open a new tab for the
Google search engine.
Open Location: Open a new tab for a
location you specify.

List.

Note: The last script does no URL

Add as To Do to Things: Adds the selected

validation, though DEVONthink's dictionary

item as a to-do item to Things.

makes it possible to script this too.

Note: These are scripts for integrating with
external applications. For scripting internal
reminder scripts, see the Reminder Scripts
section of the chapter about automation.
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Thumbnails:
Flip Horizontal / Vertical: Flips the
thumbnails of selected documents
horizontally/vertically.
Rotate Left / Right: Rotates the
thumbnails of selected documents left/
right.

%content%
%databasePlusLocation%
%modification%
%stylesheet%
%title%
%url%
%tags%

Landscape to Portrait: Rotates only

These placeholders will be replaced with

landscape thumbnails to portrait.

actual information during the export.

Portrait to Landscape: Rotates only

The placeholders will only be replaced in

portrait thumbnails to landscape.

documents that are converted to HTML

Note: While these scripts work with all
image formats including PDF, they should
not be used for PDF documents. They will

during export, namely plain text, rich text,
Microsoft Office/OpenOffice documents,
scripts, chat logs, and sheets.

only work on the first page of the PDF and
destroy all embedded metadata.
Caching: All scripts in the Scripts menu
are cached, meaning their properties are
persistent until you quit and relaunch the
application or DEVONthink automatically
updates the menu, e.g., after adding or
removing scripts.

HIDDEN PREFERENCES
There are a few settings in DEVONthink that
you cannot set through the Preferences
window. Most of them are intended to
facilitate customer support but they might
be interesting for you as well.
Note: These hidden preferences are not an
official feature and could be changed or

WEB SITE EXPORT TEMPLATES
For exporting selected groups or files as
a web site, DEVONthink uses templates
available in ~/Library/Application

removed with any update.

HOW TO ACCESS THE HIDDEN
PREFERENCES

Support/DEVONthink 3/Websites/ to

All hidden preferences are simple on/off

create HTML files from documents. You

switches. You set and unset them using the

can choose the template in the save dialog

"defaults" command in the Terminal. To set

that appears when you use File > Export > as

preferences via the Terminal DEVONthink

Website.

must not be running or it will overwrite your

In the markup of HTML templates, the
following placeholders can be used:
%charset%
%comment%

changes when you close it.
To set a preference using the Terminal, noting
the commands are case-senstive, they are
written like this:

DEVONthink 3.6 Documentation, page 232

Terminal:

AVAILABLE HIDDEN PREFERENCES KEYS

$ defaults write com.devon-

AdditionalPlainTextExtensions: Adds

technologies.think3

additional plain text extensions, separated

ShouldScaleAttachedImages -bool TRUE

by dots.

The above command activates the preference

AdditionalXMLExtensions: Adds additional

with the key "ShouldScaleAttachedImages".

XML file name extensions, separated by

Change TRUE to FALSE to deactivate it. Use

dots.

any of the preferences keys below to activate

BatesNumberDigits: Specifies the number

or deactivate them.

of digits used for the placeholder.
CounterDigits: Specifies the number of

There is a special preference to
allow DEVONthink to detect other
plain text formats as plain text:
"AdditionalPlainTextExtensions". As it
replaces the list of additional plain text
extensions we recommend that you read the
current list first (empty by default) before
adding your own to the end of the list.
Terminal:
$ defaults read com.devontechnologies.think3
AdditionalPlainTextExtensions

digits used for the placeholder.
DisableActivityWindow: Disables
automatically showing/hiding of the
Activity window.
DisableAutomaticDeconsolidation:
Inhibits items added to indexed groups in
DEVONthink from automatically moving
out to the indexed Finder folder.
DisableAutomaticUpdatingOfIndexedItems:
Disables automatic updating of indexed
items.
DisableBadgeLabel: Disable the badge label
on DEVONthink's Dock icon.

2014-07-31 08:25:27.101

DisableFileSystemEvents: DEVONthink no

defaults[21950:3312262] The domain/

longer listens to file system events.

default pair of (/Users/eb/Library/
Preferences/com.devon-technologies.think3

DisableFinderTags: DEVONthink no longer

AdditionalPlainTextExtensions) does not

imports or exports Finder tags.

exist

DisplayGroupsInPreviewPane: DEVONthink

# This "error" shows there are no
additional formats specified.
$ defaults write com.devontechnologies.think3
AdditionalPlainTextExtensions string .otl.todotxt
$ defaults read com.devontechnologies.think3
AdditionalPlainTextExtensions

will display the contents of selected
groups, smart groups, and feeds in the
view/edit pane of main windows. The
preview only displays files, not groups.
EnableApplicationFiles: Applications can
be imported/indexed.
EnablePDFDrawing: Enables DEVONthink's
own drawing of PDF pages. This was
a workaround for macOS Sierra and is
incompatible to macOS High Sierra.

.otl.todotxt
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MonospacedSidebarFont: Use a

RichNotesWithoutAttachments: Services

monospaced system font in the sidebars of

create RTF instead of RTFD.

main windows.

ShowAdditionalInfoInPathBar: Shows

MonospacedViewFont: Use a monospaced

some details about the selected item in the

system font in the item list of main

Information Bar.

windows.

SyncDebugLog: Enable additional sync

PlainTextIsMarkdown: Treat all plain text

logging for debugging.

files as markdown.
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VERSION HISTORY
New

Improved

Fixed

Removed

VERSION 3.6
This release brings compatibility for macOS 11 Big Sur, with both cosmetic and technological
improvements. Also, document links are a focus in this version. Databases are scanned for link
relationships between documents: either outgoing links or incoming Links ("back links"). The
numbers of incoming and outgoing links can also be used to search, as smart criteria, or to sort
the item list.
Other enhancements include better in-document searching via the Search inspector which now
allows wildcards and operators, e.g., DEVONthink NEAR support. We have added more Markdown
support including a new Daily Journal template and creating a table of contents file in Markdown.
There is now the ability to duplicate and replicate via the Move to popover when modifier keys
are held. PDFs with a table of contents can be split by chapters into separate documents. The
AppleScript dictionary also received several additions and improvements, including faster
processing of selected items. Lastly, there are performance and reliability improvements for
DEVONthink and its synchronization.
Added support for scanning documents for links to and from other documents. This is
supported for all newly created files in DEVONthink's native formats. Existing databases will
be scanned the first time they're opened.
Added File > Close > All Except command to leave the current database open.
Added an Enable Operators & Wildcards option to the Search inspector allowing use of
operators and wildcards for in-document searches. If disabled, the search terms will be
treated as substrings. The Edit > Find > Find Next/Previous commands and next/previous
buttons in the inspector are available when this option is enabled.
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Added Tools > Split PDF into Chapters command to split one or more selected PDF documents
having multiple pages and a table of contents with multiple entries into the separate chapter
documents.
Added Go > To Document to quickly open a document in the current main window if the View/
Edit pane is visible or a new document window, if not.
Added Copy Section Link and Copy Page Link to the contextual menu of the Table of Contents
inspector, for Markdown and PDF documents.
Added an Incoming Links pane to the Document > Links inspector showing incoming links
("back links") from other documents. This includes WikiLinks from plain and rich texts, as
well as Markdown documents. Clicking on an incoming link displays the backlinked document.
Dragging incoming links to Markdown or rich text documents with Command-Option held is
also supported.
Added support for querying or sorting on the number of incoming or outgoing links to many
sections of the interface, including smart groups, smart rules, advanced searching, sorting the
item list, etc.
Added property icons to the item list denoting items have incoming or outgoing links.
Added Daily Journal — Markdown template to Data > New from Template > Productivity. Also,
updated and renamed the original Daily Journal template to Daily Journal - Text.
Added two new services to capture bookmarks, DEVONthink 3: Capture Bookmark, and to
add links to the Reading List, DEVONthink 3: Add to Reading List. Both require having a URL
selected.
Added a File Location pop-up menu to the Tools > Filters > Info pane to filter imported or
indexed items in the current location.
Added a submenu to Tools > Create Table of Contents to create a table of contents as rich
text or Markdown document.
Added Copy Section Link to the contextual menu of the Markdown editor.
Added Any Extension criterion for use with smart groups, smart rules, and searches. This
can be used to check for filenames with or without an extension, e.g., Extension is not Any
Extension.
Added AppleScript terms incoming references and outgoing references to get explicit
link relationships between records.
Added AppleScript terms incoming Wiki references and outgoing Wiki references to
get automatic WikiLink relationships between records.
Added AppleScript term selected records for application and main windows. Contrary
to the still supported selection property this supports bulk retrieval of properties of the
selection. Queries like name of selected records or UUID of selected records are up to
100 times faster.
Added a generic UUID for the global inbox for use with item links, smart groups, and smart
rules.
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Added hidden preference DisableHighlightColorMapping to use the same highlight colors
for web documents in both light and dark mode on macOS Mojave and later.
Added hidden preference ExcludeOpenedDatabasesFromTimeMachine. This option is off by
default.
The Data > Move To command can now be used with files open in document windows.
Opening favorite documents via Go > Favorites tries to open them in the current main window
if the View/Edit pane is visible.
The sidebar header of main windows now shows the number of unread items in the Reading
List.
Tooltips of results, e.g., search results or See Also & Classify results, are shown if the location
of the item is abbreviated.
The Database Properties popover no longer requires selecting only the root of the database in
the Navigate sidebar.
Items newly added to the Reading List are shown at the top.
The Info inspector now shows the total duration when multiple multimedia files are selected.
Added a Copy Name command to the contextual menu of the Document > Links inspector.
The Table of Contents inspector now detects the alternate heading syntax in Markdown
documents.
Insert Back Link and Insert Quote commands of the Annotations & Reminders inspector now
support plain text and Markdown annotation.
Relative links in HTML-based documents and item links referencing web-based documents now
support anchors, e.g., [001](001.md#conclusion) in Markdown.
Added shortcut ⌃⌘E to Edit > Insert > Item Link.
Changed shortcut of Data > Launch URL to ⌃⌘U and Data > Launch URL in Background to
⌃⌥⌘U.
Holding the Option or Command-Option modifier keys can be used to duplicate or replicate
items via the Data > Move To popover. The title of the popover is updated according to the
current modifier keys.
Both Data > Move to external folder and automatic moving to external folder, e.g., after
adding/moving items to indexed groups, tries to retain the original filenames of the
documents.
Groups created by File > Import > Notes from Evernotenow retain the creation or modification
date of the imported notes. Note: This command only works with Evernote's "legacy version"
as Evernote 10 no longer supports AppleScript.
Animated GIFs now animate when displayed. However, they can no longer be modified.
Added Delete Page and Insert Blank Page commands to the contextual menu of the View/Edit
pane when viewing PDFs.
The Editing bar used with PDFs now supports inserting blank pages, deleting the current page,
and reversing the page order without the Thumbnails inspector being visible.
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Sheet templates now support placeholders.
Dragging audio or video files in a database into a Markdown document now inserts video or
audio HTML tags.
The sharing extension uses URLs provided by source application for files, images, and movies,
if a URL is available. The extension also supports more input types, improves reliability, and is
more compatible with macOS Big Sur.
More efficient updating and reloading of sidebars in main windows.
Improved parsing of toolbar searches using the search prefix tags: now strips unnecessary
white spaces.
The summaries in the Search inspector now use the Summarize setting in Preferences >
Editing.
Improved performance of the Search inspector for web documents and views.
Renamed Move All Instances to Trash to Move All Replicants to Trash.
Scanning text of documents, e.g., via smart rule actions or date or amount placeholders, now
scans the first eight pages of PDF documents and up to 40k of text.
Improved escaping characters while converting documents to Markdown.
Improved conversion of rich text to Markdown now retains bold, italics, underlining, and links.
In addition, lines containing only bold text are converted to headers.
Conversion of hashtags to tags now ignores the content of certain types of files, e.g., CSS
stylesheets, source code, code blocks in Markdown files, etc. as they can generate a large
number of unwanted tags.
Relative paths to video or audio files in the same database are now supported in Markdown or
HTML documents.
More reliable indexing of third-party file formats requiring Spotlight metadata importers.
Improved updating indexed files with Finder comments, especially in folders containing many
files with comments.
Improved recognition of document dates using MM/DD/YY format.
More consistent handling of file coordination to improve opening or editing imported
documents externally.
Revised user-agent while downloading RSS feeds to improve the compatibility with certain
feeds, e.g., some Atom feeds.
Improved HTML parser makes the AppleScript command get embedded images of more
compatible to websites loading images dynamically.
Exporting templates no longer replaces % in the name of exported items.
The Add to Reading List service now automatically names the added item.
Improved checking free disk space before optimizing, rebuilding, or adding files to databases.
Updated scripts of Scripts > Execute menu.
Files added to the Global Inbox folder in the Finder are no longer processed by DEVONthink
while smart rules or scripts are running.

DEVONthink 3.6 Documentation, page 238

Invalid arguments of AppleScript commands now report an error.
The Filename criterion in smart groups, smart rules, and searches now support is not and
does not contain/begin/end forms.
More efficient storing of internal and custom metadata.
The Support Assistant now uses SSL/TLS.
More background activities now block the synchronization of a database until complete to
avoid unnecessary or outdated transfers.
Improved timeout handling of background tasks.
Improved reliability and performance, including handling filesystem events.
Pro — The Apple Mail plugin is now compatible to Big Sur and is included by default. Newer
plugins will be downloaded from our servers if available and necessary. In addition, old plugins
used by former macOS versions are automatically removed.
Pro — Improved compatibility when downloading multimedia files via the Download Manager.
Pro — OCR jobs in queue are cancelled after a crash of the OCR helper.
Server — Updated web interface fixes the display of scores in search view and improves
rendering Markdown documents.
Server — video and audio HTML tags in Markdown documents are now supported in the web
interface. They are also supported in File > Export > as Website command in all editions.
Sync — Dropbox connections try to alleviate timeouts or rate limiting by the service.
Sync — Reduced CPU and memory usage of the iCloud upload monitor.
Sync — Improved the overall reliability of WebDAV sync stores.
Sync — Improved the efficiency and speed of uploads, especially with smaller databases.
After canceling mounting encrypted databases or entering the wrong password multiple
times, the extension wasn't reverted to .dtSparse on macOS Catalina and later. Fixed.
Encrypted databases added to Favorites didn't work. Fixed.
Favorite encrypted databases were disabled while opened. Fixed.
Recent encrypted databases were disabled after closing them. Fixed.
After saving edited Markdown documents in both side-by-side and fullscreen document mode,
the source view lost the keyboard focus. Fixed.
Edit > Set Name As did not work in case of Markdown and HTML documents viewed in side-byside mode. Fixed.
Minor issues of the Table of Contents inspector with Markdown documents. Fixed.
MultiMarkdown metadata headers could be processed incorrectly by automatic Wiki linking.
Fixed.
Tab-indented lists in Markdown weren't parsed correctly. Fixed.
Go > Complete News was not disabled while the Support Assistant or a document window
showing a web document or Markdown preview was the frontmost window. Fixed.
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Backward and forward handling after clicking on a link in RSS news or using Go > Complete
News wasn't working properly. Fixed.
Tags based on hashtags were updated when RSS feeds updated or after using the Append
Plain Note or Append Rich Note services. Fixed.
The RSS parser could affect the rendering of the Extras sidebar. Fixed.
Reordering of Reading List items via drag-and-drop shouldn't have been possible when
showing only unread items. Fixed.
macOS data detectors and filenames containing the same word multiple times could cause
issues with automatic WikiLinks. Fixed.
Website exports didn't resolve automatic Wiki links based on the square bracket syntax in
Markdown documents. Fixed.
Page links copied by the Document > Annotations inspector incorrectly referenced the next
page. Fixed.
Empty toolbar queries like aliases!= didn't work. Fixed.
Searching, e.g., only for tags could return items in groups excluded from searching. Fixed
.applescript files showed an empty preview. Fixed.
.scpt and .scptd were incorrectly editable. Fixed.
Web archives without an internal URL were not rendered and could not be converted to HTML
or formatted notes. Fixed.
The Reveal command wasn't available in contextual menus when viewing files in ordinary tags.
Fixed.
The Recent Destinations section in the Move To, Replicate To, or Duplicate To submenus
incorrectly could contain ordinary tags. Fixed.
The Highlight submenu of the contextual menu when viewing PDF documents was disabled on
macOS Catalina and later if the current text selection was already highlighted. Fixed.
Glitch of Label menus in dark mode. Fixed.
Property icons, e.g., of indexed items, were not always shown in icon view with files having very
short names (one or two characters). Fixed.
The height of the headers of the List view was incorrect after enabling the second column.
Fixed.
The Length column in List view reported "1 pages" for single-page PDFs. Fixed.
Smart group and smart rule editors with too many conditions or actions couldn't be resized to
accommodate them. Fixed.
Border of Quick-Look-based standard preview of emails on Mojave and later was incorrect.
Fixed.
The Search inspector didn't show when searching web pages navigated to, i.e., not a bookmark
in the database. Fixed.
The Sorter could display incorrect colors when run as a menu extra on macOS Big Sur. Fixed.
Document windows were not always automatically closed after emptying the trash. Fixed.
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The Mount Volume button of the view/edit pane locked the application while mounting
unmounted volumes. Fixed.
Certain reminder alarm actions didn't work properly with groups, smart groups, and RSS feeds.
Fixed.
The number of hits of accessed groups were incremented by 2 each time it was accessed. Also
the hits of feeds was incorrectly incremented when the feeds were refreshed. Fixed.
Filesystem events, e.g., after deleting file A in a folder and renaming file B as file A immediately
afterwards, could cause duplicate items. Fixed.
Document dates with unknown file types could be incorrectly detected or missed. Fixed.
Tag issues when moving items to a group having the same tags in a different database not
using group tags. Fixed.
Scripts > Data > Verify & Optimize Databases could fail while databases were synchronizing.
Fixed.
The search AppleScript command returned incomplete results when providing an invalid in
parameter. Fixed.
A rare AppKit exception could occur while processing images. Fixed.
Pro — In Apple Mail, the command Mailbox > Add to DEVONthink 3 didn't support importing
the inbox if there was only one email account active. Fixed.
Pro — Retrieval of message IDs while email archiving could fail in case of not fully downloaded
emails and could lead to duplicate imports. Fixed.
Pro — Data > Tags > Convert Properties and Preferences > Import > Convert properties to tags
didn't convert the recipient's email addresses from imported emails. Fixed.
Pro — DEVONthink would sometimes crash on quit after using email archiving. Fixed.
Pro — Some OCR output had incorrectly rotated pages or unselectable text. Fixed.
Pro — OCR on PDFs containing multiple page sizes would output unexpected results. Fixed.
Pro — Non-specific smart rule actions, e.g., playing a sound or displaying a notification with
static text, were performed for each item after an OCR action instead of only once. Fixed.
Pro — Results in the See Also inspector could include groups or tags having custom metadata.
Fixed.
Pro — Automatic grouping of images didn't work. Fixed.
Server — Empty Markdown documents couldn't be edited or viewed in the web interface.
Fixed.
Server — Deleting the complete content of a plain text or Markdown document in the web
interface wasn't possible. Fixed.
Pro — Removed unsupported OCR languages from Preferences > OCR: Old English, French,
German, Spanish, Italian, Slovian, Thai, Thai, Latvian language written in Gothic.
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VERSION 3.5.2
This release brings the first steps toward compatibility with the upcoming macOS Big Sur
release, ARM support, as well as improvements and fixes beyond the beta. While the operations
of DEVONthink are working as expected so far in the Big Sur betas, we made the first round
of necessary cosmetic changes. We have improved the efficiency of the sync engine, including
more reliable resuming of interrupted syncs. Also, DEVONthink preserves the hierarchy of nested
tags when moving or duplicating tagged items between databases. If you use WikiLinks, you
can now specify more than one type to use, e.g., "Names & Aliases" and "MashedWords". HTML
exports, including exporting to websites and the conversion of Markdown documents to HTML,
behave more reliably now. Encrypted databases have seen improvements in reliablity too. We've
also added support for importing bookmarks from the Brave browser. And improvements to the
general speed and reliability of DEVONthink continue to be made.
DEVONthink runs natively on Intel- and ARM-based Macs.
Added support for importing bookmarks from the Brave web browser.
Added a New Window submenu to the contextual menu of the Dock icon.
Added a new Check Bookmarks smart rule action for checking if the URL of the item is valid.
Any issues or detected changes are shown in the Log window. This action replaces the "Check
Links" smart rule script, though the already installed script will not be not removed so existing
smart rules remain functional.
Prism support includes now Python, Perl, and PHP.
Added hidden preferences MonospacedViewFont and MonospacedSidebarFont to toggle using
a monospaced system font in the views or sidebar. This requires macOS 10.15 or later.
Updated some interface elements for the upcoming macOS Big Sur.
Items can be directly dragged from a database to the desired position in the Favorites
section of the Navigate sidebar. In addition, smart group (.dtSmartGroup) and smart rule
(.dtSmartRule) files and local smart groups can be also directly dragged to the desired
position in the sidebar.
Items expanded during drag and drop in the Navigate sidebar are now only collapsed again if
the option Automatically expand & collapse is enabled in Preferences > General.
The Reading List is now automatically updated after renaming an item or changing its icon or
thumbnail.
Markdown documents support Bold and Italic in the Format > Style menu and the Editing bar.
Clicking file links in indexed web or Markdown documents no longer launches the default
application if the linked file is part of the database.
Automatic Wiki linking supports text in parenthesis in Markdown documents.
Improved support for PDF Note annotations created by PSPDFKit.
Improved clipping of PDF documents from Google Chrome by ignoring the browser's HTML
source code to display the document.
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In Preferences > WikiLinks, MashedWords, Square brackets, and Names and Aliases can be
used concurrently.
Added tooltips and accessibility help to the Rating menu.
File > Close Database > Close All skips databases which can't be immediately closed, e.g., when
they're actively synchronizing.
If a warning about major errors is shown when opening a database, synchronization will be
automatically disabled internally.
On startup, a message is now logged to the Log window if the Flash Player plugin is detected.
A notification is added to the system's notification center each hour during the last 12 hours of
the trial.
Moving or duplicating items tagged with ordinary tags to other databases tries now to retain
the hierarchy of nested tags in the receiving database's Tags group. It also will retain the
properties of the original tags, e.g., a user-specified color.
Documents automatically created by clicking WikiLinks are now always stored in the same
location as the original document, including replicants. The new documents also inherit the
tags of the original file.
Default smart rule "Automatic Locking" gets now the condition "Marked as Read" too.
The table of contents created by merging multiple images and/or PDF documents or File >
Export> As PDF document is now more precise.
Conversion of duplicates to replicants no longer adds multiple replicants to the same group.
More precise See Also & Classify results in case of items having metadata or properties but no
text content, e.g., emails containing only images.
Fuzzy recognition of document dates now supports dates from the year 1900 up to 2100
(instead of 1950-2050).
Indexed application-specific iCloud Drive data is no longer read-only.
Improved support for files and folders exported by ELO Office.
Improved memory management and reliability of website exports and the conversion to HTML
or formatted notes, e.g., from Markdown documents.
Improved and faster Markdown indexing.
Improved reliability of background downloads, e.g., while converting a large number of
bookmarks to web archives, PDF, formatted notes, etc.
Background tasks support automatic graphics switching. This might increase the battery life
on some MacBooks.
Updated the SkimNotes framework.
Pro — Installation of the Mail plugin asks now for full disk access, if necessary.
Pro — Improved memory usage and the detection of CJK fonts and languages in the OCR
engine and application.
Sync — Resuming interrupted syncs is now more reliable.
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Sync — More efficient chunking of small items not modified or opened within the last year
while uploading to sync stores. This can speed up uploading and maintenance of sync stores
and reduce the cloud and disk space usage.
Sync — More reliable synchronization of tags, for example after replicating ordinary tags.
Sync — Increased the number of retries in case of rate limiting Dropbox errors.
Sync — Increased the Dropbox timeout to reduce the likelihood of unnecessary timeouts.
Sync — Slightly reduced CPU and battery usage of Dropbox syncs.
Sync — Faster sorting of records before uploading.
After removing all tags of an item, the Finder tags of its Spotlight metadata file were not
always removed. Fixed.
Certain VCards crashing Quick Look could subsequently crash the application. Fixed.
Changes to global smart group and smart rule sorting were not persistent without making
other changes. Fixed.
Choosing a filter in Tools > Filters did not automatically show the Navigate sidebar. Fixed.
Custom icons of items in the Reading List sometimes incorrectly displayed a border. Fixed.
Custom metadata placeholders in rich text annotation templates didn't work. Fixed.
Disabling unified inboxes and tags in Preferences > General didn't fully reload the main view of
main windows showing them. Fixed.
Document dates with certain month names weren't detected. Fixed.
Emoji placeholders used in links in Markdown documents could break the links. Fixed.
Encrypted databases were unmounted by macOS Catalina when using Time Machine with
networked drives. Fixed. This change also ensures the encrypted databases will continue to be
backed up by Time Machine.
Global smart groups and smart rules were not always updated, e.g., after printing a selected
document to DEVONthink. Fixed.
Hashtags in Markdown documents couldn't be converted to tags. Fixed.
Information shown in the Editing bar, e.g., word counts, wasn't updated after typing or
changing the selection. Fixed.
Item links having a trailing slash, e.g., added by Microsoft Outlook, didn't work. Fixed.
Logging while updating the Reading List during sync could crash the application. Fixed.
Long custom metadata names were not always truncated in the pop-ups of the Info > Custom
inspector. Fixed.
Moving a replicated item from the unified inboxes to the trash moved all replicants. Fixed.
Opening a workspace containing the Tags filter without the Navigate sidebar being visible
could crash the application. Fixed.
Reminders sending emails or reminders triggering smart rules which are executing scripts
could freeze the application. Fixed.
Renaming groups in the Navigate sidebar had issues. Fixed.
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Saving modified Markdown documents when automatic Wiki links were enabled could crash
the application. Fixed.
Smart group, smart rule, and search criteria querying document properties, e.g., creator, did
not work when using is, begins with or does not begin with. Fixed.
Smart rules were sometimes performed by the On Import event trigger before background
indexing, e.g., of PDF documents, was complete. Fixed.
The Open tab for URL AppleScript command always returned a missing value. Fixed.
The Clip to DEVONthink section of the Sorter had layout issues after using the browser
extension. Fixed.
The to argument of the compare content AppleScript command wasn't used. Fixed.
The PDF annotations panel didn't retain the border width when it was previously set to 0.
Fixed.
The sort order of groups by name wasn't always correct when Keep groups on top when
sorting was enabled in the preferences. Fixed.
The toolbar search didn't accept item:tagged and item!:tagged. Fixed.
The widths and order of List view columns in global smart groups or smart rules were not
always saved or restored. Fixed.
Updating of RSS feeds not using the automatic format and other actions could cause
unnecessary notifications in the user notification center. Fixed.
Volumes already unmounted by Time Machine were tried again to be unmounted. Fixed.
Pro — The number of OCR runs was limited due to an issue with the license expiring. Fixed.
Pro — Cancelling an OCR operation wasn't stopping the process. Fixed.
Pro — PDFs generated by OCR could show existing annotation in the image layer. Fixed.
Pro — PDFs generated by OCR did not retain the creation date. Fixed.
Pro — Some text in PDFs generated by OCR wasn't editable. Fixed.
Pro — The OCR had a memory leak and a font cache issue. Fixed.
Pro — The OCR had issues when specifying secondary languages. Fixed.
Pro — The page size of PDFs generated by OCR was reported incorrectly. Fixed.
Pro — Trying to OCR PDFs without print permission created blank PDFs. Fixed.
Pro — An overview scan was not displayed on macOS High Sierra and below. Fixed.
Pro — Archiving email via the View > Import sidebar could crash the application. Fixed.
Pro — Indexing attachments of email messages could add the word "null" to the index and
concordance. Fixed. This would also adversely affect See Also & Classify results.
Sync — The Bonjour network browser could crash the application. Fixed.
Sync — The garbage collection of sync stores had issues after moving indexed items into the
database. Fixed.
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VERSION 3.5.1
This maintenance release brings many improvements and fixes. For example, the Navigate sidebar
is better usable and more reliable with non-unified databases. The Go To and Move To popovers
now allow using quoted text to reduce the number of matches, and the Reading List can be
sorted via drag-and-drop. If you are using custom metadata and annotation files, your custom
annotation templates now support metadata placeholders. And finally, we have included some
AppleScript improvements and smart rule changes for the automators out there.
Added optional record parameter to the log message AppleScript command to log records
which can be easily revealed via the contextual menu in the Log window.
Added a new AppleScript command get favicon of to retrieve the favicon from HTML input.
Added a new smart rule script Add Favicons to add the favicon to bookmarks and RSS feeds.
The size of text in the Table of Contents inspector, the Comments field of the Annotations &
Reminders inspector, and the Details field of the Document > Annotations inspector now use
Preferences > General > Appearance > View Text Size.
Custom annotation templates in the Tools > Inspectors > Annotations & Reminders inspector
now support placeholders, e.g., %recordURL% or %mdlanguage%. This allows the annotation file
to contain metadata from the original file, when present.
Improved the dark mode appearance of links in sheets.
Edit > Copy Item Link now supports multiple items.
Clicking on groups, local smart groups, or feeds in the Favorites section of the Navigate
sidebar now updates the active database section of the sidebar. Pressing Shift-Return on a
selected favorite document also can be used to switch the active database.
Switching databases via the Navigate sidebar restores the previous main view selection.
You can again close databases via Control-clicking the Inbox or Tags groups in the Navigate
sidebar when using unified inboxes or tags.
The Reading List now can be sorted via drag-and-drop.
More consistent appearance of the tabs of the Sorter.
The Take Note tab of the Sorter now uses the spelling, grammar checking, and substitution
options of Preferences > Editing.
Quoting input, e.g,. "test", in the Go > Go To and Data > Move To utility popovers can be used
to disable the fuzzy search and search for items containing the substring
After showing the Tags filter, the filter field gets the focus to easily type the desired tags.
A warning is now logged to the Log window or Log popover after opening a database having
a UUID that is identical to the one of an already opened database, e.g., after duplicating
databases in the Finder.
The tooltip of the toolbar button for the Log popover shows the number of new or all
messages.
Faster updating of Spotlight index and Finder tags.
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Improved VoiceOver support of the sidebar and List view.
With Markdown documents, non-rendered words are no longer indexed. For existing
documents, this requires reimporting the files or rebuilding the database to ensure the index is
accurate.
Improved handling of pending indexed files located on unmounted volumes.
Inactive windows displaying web content aren't updated anymore to improve the performance
and reduce battery usage.
A warning is now logged on startup if an incompatible AdobePDFViewer.plugin or
ClickToFlash.webplugin is detected.
Improved reliability of the Clip to DEVONthink background task which is now automatically
stopped if it no longer responds, e.g., due to WebKit issues.
Improved the performance of thumbnailing.
Improved RSS handling can be faster, reduce bandwidth, and is now more compatible to
certain feeds, e.g., Google Alerts.
Updated Prism support includes bash.
Updated the Check Links and Download Bibliographic Metadata smart rule scripts to use the
extended log message AppleScript command. In addition, the Check Links script doesn't
replicate the items anymore as they now can be found and revealed via the Log window.
Retrieving all properties of a record via AppleScript doesn't include dynamically calculated
properties, e.g., document dates, amount, name or digital object identifier, or contents, e.g.,
the source, plain or rich text, cells or columns, image, thumbnail, etc. These properties can be
retrieved separately. This improves performance when getting the base properties of a record.
Improved overall reliability and performance.
Pro — Improved OCR performance for faster document loading. Also Preferences > OCR now
has a Resolution setting to set the DPI of the image layer (between 150 and 300 dpi) in the
resulting PDF.
Pro — Improved error handling when archiving email.
Sync — Improved multi-threading and automatic Dropbox retry handling in case of rate limiting
errors (HTTP 429).
Sync — Improved handling of sync host identifier.
In main windows, interacting with PDFs having a table of contents while the Table of Contents
inspector was visible could cause a crash in macOS El Capitan. Fixed.
Certain links, e.g., email addresses weren't retained when a sheet was converted to PDF. Fixed.
Fixed a Table of Contents inspector issue with Markdown documents beginning or ending with
a code block.
The state of the active database pane when using non-unified databases wasn't restored after
switching to other sidebar tabs and back. Fixed.
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Selecting a favorite group in the Navigate sidebar could not be used to update the current
search scope. Fixed.
The current selection wasn't always visible after changing the sorting of List or Columns view.
Fixed.
Highlights of PDF documents in the Document > Annotations inspector displayed incorrectly in
macOS Catalina. Fixed.
Changing the search scope from the current group to the current databases via the search bar
no longer worked. Fixed.
Automatic thumbnailing replaced custom icons of some file types, e.g., formatted notes and
movies. Fixed.
Clicking on links in web views, e.g., bookmarks or web archives always opened in the system
default browser. Fixed.
Clipping our Discourse forums could cause the print dialog to automatically appear when the
clipped files were accessed. Fixed.
When using facing pages with PDFs, the contextual menu commands Rotate Right, Rotate
Left, and Copy Page Link did not always use the selected page. Fixed.
The menu item Tools > Inspectors > Info > Generic was always disabled in the Standard edition.
Fixed.
The title of the group selector showed an incorrect format when clipping from DEVONagent to
DEVONthink. Fixed.
New groups created via the Navigate sidebar's action or contextual menus were not always
immediately renamable. Fixed.
Conversion of rich text to HTML, including website export and the web interface (Pro), didn't
always retain the text color. Fixed.
An anchored search in PDF documents didn't work property, e.g., after opening item links using
the search parameter and a string starting or ending with separators. Fixed.
Clicking on the inbox in the Location section of the Info inspector didn't work when using
unified inboxes. Fixed.
Empty folders were not deleted on import when moving the files into the database, e.g., after
Command-drop or enabling the Move to Trash option in File > Import > Files and Folders. Fixed.
Excluding an ordinary tag from searching also excluded the tagged files from search. Only
groups now inherit the exclusion. Fixed.
Using the search prefix Aliases in the toolbar search field, e.g., aliases==test, didn't work.
Fixed.
The Search inspector had a few minor glitches. Fixed.
Toggling the Unify Inboxes and Unify Tags preferences didn't immediately update the active
database section of the sidebar. Fixed.
Notifications after clipping web pages weren't added to macOS' notification center anymore.
Fixed.
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The Width and Height columns in the List view were sometimes truncated. Fixed.
After adding many actions to a smart rule, the size of the smart rule editor wasn't limited to
the current screen. Fixed.
The automatic installation from the disk image could temporarily freeze and show a Finder
alert on macOS Catalina. Fixed.
Handling of the .dtSparse extension of encrypted databases was case-sensitive in some
cases. Fixed.
Encrypted databases may be unmounted by macOS Catalina when backing up to a networked
volume. Encrypted databases are now excluded from Time Machine while in use.
Trying to retrieve the digital object identifier (DOI) from items without text, e.g., bookmarks
or groups, caused an exception. Fixed.
Auto-classification used with very large documents or databases caused a delay of the
contextual and action menus. Fixed.
The On Creation smart rule event wasn't triggered when creating files via templates. Fixed.
Exporting only one item as a template didn't export URL, tags, comments, or custom
metadata. Fixed.
The AppleScript commands to create, update, or delete thumbnails were also applied
incorrectly to the children of groups or feeds. Fixed.
Retrieving all properties of a database via AppleScript doesn't always create an annotations
group anymore.
Retrieving all properties of the application via AppleScript doesn't display the group selector
anymore.
Pro — Rich text custom metadata fields in the Info > Custom inspector appeared incorrectly in
macOS Mojave and Catalina. Fixed.
Pro — The window title and pre-filled entries of the Metadata panel after OCR didn't show the
correct data. Fixed.
Pro — OCR didn't retain the URL of the original item. Fixed.
Pro — Broken mailboxes without a name in Apple Mail or Microsoft Outlook sometimes caused
a rare crash in the Import > Email sidebar. Fixed.
Sync — Dropbox connections sometimes stalled. Fixed.
Sync — Rare freeze of Bonjour sync after network issues, e.g., dropped connections. Fixed.

VERSION 3.5
The 3.5 release brings many new features, fixes, and improvements. Here are a few highlights: The
Navigate sidebar now features an active database section allowing an isolated view of a single
database's groups. We have added several smart rule actions including two which allow you to
parse a document's name or contents and retrieve strings, dates, amounts, and even arbitrary
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data using regular expressions. Use the results to change attributes like a documents' dates or
custom metadata. New event triggers activate smart rules on events like duplicating, or tagging
documents. You can also now specify more than one trigger per rule.
For office use we have updated the OCR engine and added with two new OCR options which
allow OCR without changing the original document. DEVONthink records voice notes in a more
compatible format and you can view Markdown documents with syntax highlighting. The web
interface lets its users upload files easier and features a custom metadata inspector pane. And,
as always, we have improved the overall reliability and performance, too.
Added a new active database section in the Navigate sidebar, allowing an isolated view of one
database's content at a time. This option becomes available by disabling Unify databases in
Preferences > General > Sidebar.
Added commands Go > Previous/Next Database to access the previous or next database in
the Navigate sidebar.
Added Go > Favorites menu, allowing access to the favorites when there is no main window
open, the Navigate sidebar is hidden, or the Favorites section is collapsed. Also, hovering on
the menu items shows the path or location of databases and items in a tooltip.
Added Edit Table, Edit List, Edit Spacing, and Make Link items to the Editing bar with rich text
files.
Added View > Sort > by Character Count and View > Columns > Character Count. Character
Count is also available in smart groups, smart rules, and advanced searches. Additionally, the
character count is shown in the Editing bar for a documents.
Added the option Prism support to Preferences > Media > Markdown, adding syntax coloring.
Currently AppleScript, Objective-C, Swift, C, C++, Java, and JavaScript are supported.
Added optional New Group and New Smart Group toolbar items for use with the toolbar of
main windows.
Added a Log toolbar button to open a detachable Log popover when the Log window isn't
open. If the Log window is open, it will come to the front when this button is pressed.
Added to PDF (Single Page) to the Data > Convert menu. Also renamed "to PDF" to to PDF
(Paginated). These options are also supported by smart rules and AppleScript.
Smart rules can now be triggered by multiple event triggers.
Added smart rule events On Duplicating, On Replicating, On Tagging, On Imprinting, and Every
Minute.
Added Scan Text and Scan Name actions to smart rules and batch processing. These actions
can be used to parse the name or text of items for certain strings or numbers and used with
subsequent actions, e.g., Change Comment or Change Modification Date. These actions
can be specified with String, Date, Amount, and Regular Expression parameters for more
targeted parsing.
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Added new Mail Rule - Add links to DEVONthink mail rule script for Apple Mail. This adds the
web links of the email messages to DEVONthink.
Added smart rule actions for converting hashtags, keywords, properties, geolocation to tags,
as well as Add Tags to Images and Scan Barcodes actions.
Added action Add Tags From Document to smart rules and batch processing. This action is
similar to the Add Tags action but adds only existing tags which are found in the document's
text or title.
Added new %documentString% placeholder for use with the the Scan Name and Scan Text
smart rule actions.
Added placeholder for seconds in the date placeholders.
Added clutter-free scripts to the Scripts > Download menu for web archives, PDFs, and
formatted notes.
Added optional trigger parameter to perform smart rule AppleScript command which can
be used do things like trigger only smart rules which should be performed after importing.
Pro — Added commands to Comment and to Annotation to the Data > OCR menu to add
the OCR text to the Finder comments or create an Annotation file, leaving the original file
unmodified. These commands are also available as smart rule actions, in Preferences > OCR,
File > Import > Images (with OCR), and in AppleScript.
Pro — Added an Export command to the contextual menu of Cloud view of the Tools >
Inspectors > Concordance inspector, allowing the export of the current cloud as a PDF
document.
Improved the contextual and action menus for items in the Navigate sidebar including opening
new windows, moving/duplicating/replicating item, setting marks and labels, and URL
interactions.
You can now select multiple groups in the sidebar, displaying a union of the contents in the
item list. Multiple selected smart groups and rules will not show a union of their contents but
they can be dragged and dropped, e.g, for export.
Items in the Favorites section of the Navigate sidebar can now be renamed. This does not
affect the name of the original item in the database. The Sorter, contextual menus, and
destination popups will show the name shown in the Favorites section of the sidebar.
Updated format conversions: PDF to HTML, formatted notes and bookmarks to plain text.
Improved Tools > Summarize Highlights when used with PDF documents highlighted by
PSPDFKit, e.g., DEVONthink To Go.
File > Database Properties now shows the remaining disk space for encrypted databases.
Slightly revised totals in File > Database Properties to be more consistent with the Info
inspector.
The Format menu now has icons for some items.
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Most toolbar items, excluding Search, Preview, Marks, and Zoom, now have the same priority.
The order from left to right determines which items are removed if there's not enough space
to display them.
The Search inspector now uses the Preferences > General > Appearance > View Font Size.
Recipients of imported email messages are now ordered, e.g., in List view or the Document >
Properties inspector.
A read-only icon for locked documents is displayed in the Editing bar.
The Schedule popup of the Annotations & Reminder inspector now includes items for today,
tomorrow, in two days, and in one week to simplify setup of one-shot reminders.
The Show log automatically option of the Log window is now strictly honored. Errors with RSS
feeds and automated AppleScripts are now logged here, too.
Improved the clutter-free web capture mechanism to support larger pages, ignore empty
anchors and zero-dimension images, more reliably detects page encodings, and more reliably
follows redirections. Also, the page source is sent to our decluttering service to improve
the results, when possible. Clip to DEVONthink ignores the titles of browser windows if it's
identical to the URL. We also added special handling for capturing webpages from our user
forum.
Improved drag-and-drop support for third-party applications.
Improved preserving the attributes of PDF annotations, e.g., the arrow settings for lines.
Improved sending email with Postbox.
Improved support for indexed Scrivener files.
You can now also drop items onto databases in the Favorites section and the items will be put
into the root of the database.
Pressing Return in the search results of Sorter's Navigation tab now reveals the selected group.
Pressing Escape while renaming an item in the Navigate sidebar while in fullscreen mode
doesn't leave fullscreen.
Tabbing in Inspectors now scrolls the view to the active field, if necessary.
Hash tags can be applied by the new Tags > Convert Hashtags to Tags action.
The smart rule and batch processing actions Add Tags, Add Tags from Document, and Remove
Tags now support placeholders for more dynamic tagging.
The create record with {} AppleScript command now supports specifying geolocation
data via longitude, latitude, and altitude parameters.
The column parameter of the get/set cell at … AppleScript commands now supports
specifying the name, e.g., in set strName to get cell at column "Name".
Improved dark mode appearance of the Content > Table of Contents inspector.
Improved dark mode appearance of the embedded scripts editor and buttons in the smart rule
editor (macOS Catalina).
The Sorter now creates voice notes in MPEG-4 format for better compatibility, including in the
web interface.
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Grouping items now selects the new group in the Navigate sidebar if View > Show Only
Documents is enabled. Improved revealing of groups, e.g., in search results, when this option or
View > Cover Flow is used in the item's location.
Control-Tab now supports the search field of the Tags filter. Also keyboard navigation in the
filter has been improved.
Reports created by Tools > Create Metadata Overview now account for custom metadata
applied to groups, smart groups, and feeds.
Updated the default Annotation file template to improve compatibility with DEVONthink To
Go.
Renamed "Copy Smart Group/Rule Link" to Copy Item Link in the contextual and action menu
of the Navigate sidebar.
Renamed "Enable MathJax support" to MathJax support in Preferences > Media > Markdown.
Renamed "Amount" in the "Insert Placeholder" contextual menu to Document Amount to be
more consistent with Document Date and Document String.
Improved RSS feed handling is more compatible to certain feeds, e.g., Daring Fireball.
Invalid URLs of feeds are now automatically corrected and logged if a valid feed URL can be
found in the HTML code. Otherwise a message that the feed is invalid is logged to the Log
window or popover.
Importing and indexing HTML files, formatted notes, and web archives now supports HTML
geolocation metadata "geo.position" and "icbm" when available in the page source.
Annotations of PDF documents and PDF packages annotated by Skim are now indexed and
searchable.
Thumbnailing of audio files now uses the artwork as the thumbnail, if available.
.sml files are now imported as plain text.
Closing an encrypted database now empties the disk image's trash to conserve space.
Databases are automatically verified after opening them if they weren't closed properly.
File > Verify & Repair Database now checks and repairs for invalid characters in filenames. The
items with an invalid filename are logged to the Log window.
Improved handling of items when the hidden preference DisableAutomaticDeconsolidation
is active.
Plain text files larger than 256 MB are now skipped as they can crash the foundation
framework of macOS in case of insufficient memory.
Aliases or symbolic links in ~Library/Metadata/com.devon-technologies.think3 are now
resolved.
Merging documents now triggers the On Creation smart rule event.
Automatic creation of tags, e.g., entered in the tags bar or hashtags inside documents, now
triggers an On Creation event in smart rules.
Updated scripts for Apple Mail and Microsoft Outlook to trigger smart rules using the on
import trigger to make this more consistent with our other email archiving methods.
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The "Tags - Assign" smart rule script now applies only existing tags found in the document.
Hashtags are now applied after documents were edited in external applications.
Improved recognition of document dates and amounts.
Improved handling of the extension of JPEG images, e.g. created via AppleScript.
Improved detecting and skipping of already imported messages after dragging them from
Apple Mail. Depending on the size of the messages and the speed of the Internet connection
this can speed up the import 2 to 100 times.
Unsupported URL schemes are now forwarded to the approprate application when possible.
Improved overall performance and reliability, including reduced resource consumption for
smart rules, caching custom icons in the Navigate sidebar, and improved email archiving.
Pro — Updated OCR engine, processes very large PDFs faster, improves the support for CJK,
and creates smaller files. Fixes also issues with rotated images and with text quality in PDF
output.
Pro — File > Import > Unix Mailbox now supports .mbox packages exported by Apple Mail
without having to choose the MBOX file inside the package.
Pro — Added Today, Tomorrow, In Two Days, and In One Week options in a popup on the label
for date-based fields in the Custom Metadata inspector or the form view of sheets.
Pro — Improved dark mode support of rich text fields in form views of sheets and the Info >
Custom inspector.
Pro — Tabbing in the form view of sheets or the Custom Metadata inspector now scrolls the
view to the active field, if necessary.
Pro — Improved performance in the Concordance inspector.
Pro — Scans produced via the Import sidebar can now trigger both the On Scan and On OCR
smart rule events.
Pro — Updated web interface, improves: file uploads with drag-and-drop to the upload control,
viewing and editing custom metadata in the Info inspector, and updated context menus in the
toolbar. Also moving, replicating, duplicating, tagging, renaming, and editing items in browser
now triggers smart rule events. Additionally, we improved compatibility of audio and video
media to Google Chrome and Microsoft Edge.
Sync — Indexed items located on external volumes are now handled like indexed items located
in cloud folders as the volume might be a shared network volume.
Sync — Improved syncing when Scrivener's files are in a database.
Sync — Improved the reliability of Bonjour sync.
Sync — Improved reliability of duplication and logging in case of sync conflicts.
Sync — Improved error message in cases of an invalid database UUID.
Sync — Improved multi-threading, fixes rare crashes.
Sync — Improved host identification to avoid minor issues like inefficient garbage collection of
sync stores or unnecessary clearing of cached files.
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Fixed a crash related to the AppKit framework.
Fixed a crash related to the Acrobat PDF browser plugin being installed on the computer.
Fixed a rare crash related to certain EPUB files.
Fixed a rare crash related to the Navigate sidebar.
Fixed an intermittent crash related to video notes in the Sorter.
Fixed an issue where Data > Launch URL used the local file URL instead of the remote URL in
case of web documents, e.g., clipped formatted notes.
Fixed an issue where Edit > Copy URL was incorrectly available with document windows
displaying files without a remote URL.
Fixed an issue where a toolbar search wasn't updated with the same term after pressing
Return if the databases were modified since performing the search.
Fixed an issue where accessing the font and color options in the Editing bar temporarily
consumed too much memory.
Fixed an issue where Apple's PDFKit framework could freeze while creating thumbnails of PDF
documents.
Fixed an issue where changes in the Info popover were not always saved, e.g. after pressing ⌃S.
Fixed an issue where changing an annotation or Finder comment in the Annotations &
Reminders inspector caused glitches when setting a label in the toolbar.
Fixed an issue where changing the selection didn't update the Quick Look panel.
Fixed an issue where changing the sorting of a column in column view also affected the top
level object of the window.
Fixed an issue where commands to create new feeds and groups weren't disabled when the
Reading List was visible.
Fixed an issue where documents in the Favorites section of the Navigate sidebar didn't honor
the Preferences > General > Double-click opens documents externally setting.
Fixed an issue where dragging items to locations in the Navigate sidebar didn't honor the
Preferences > General > Sidebar: Automatically expand & collapse setting.
Fixed an issue where dragging text from web pages into DEVONthink could have the wrong
URL.
Fixed an issue where duplicating a global smart group or smart rule in the Navigate sidebar
didn't set a new identifier on the duplicated item.
Fixed an issue where encrypted databases couldn't be reopened after an application crash.
Fixed an issue where Finder comments were sometimes not imported.
Fixed an issue where imprinting multiple PDFs added a wrong identifer value.
Fixed an issue where indexing and thumbnailing PDF packages (.pdfd, .lpdf) didn't work.
Fixed an issue where integers didn't work as percentages in custom metadata and in sheets.
Fixed an issue where it was possible to close a database while items were being moved into it
in the background from another database.
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Fixed an issue where item links pasted into an embedded script in smart rules or reminders
pasted the item's name, not the link. The format of rich text content pasted in is also now
ignored.
Fixed an issue where items moved via smart rules immediately after importing them didn't
always remove the original item.
Fixed an issue where links in the Tools > Inspectors > Document > Links inspector could be
renamed.
Fixed an issue where long custom metadata labels caused layout problems in popups.
Fixed an issue where main windows showing global smart groups and smart rules were not
restored by workspaces and when DEVONthink launched.
Fixed an issue where pressing Escape in a popover, e.g., the Info popover, closed the search
instead of the popover.
Fixed an issue where rebuilding a database wrongfully showed a warning that the database
would be in use.
Fixed an issue where saving PDF documents in the background could happen multiple times
concurrently.
Fixed an issue where sheets were not editable after modifying the sheet's columns.
Fixed an issue where tab characters in titles of emails were not replaced.
Fixed an issue where the Tags bar was sometimes shown when switching databases using
different view or preview settings.
Fixed an issue where the Table of Contents inspector wasn't always immediately updated, e.g.,
while editing Markdown documents in side-by-side view in main windows.
Fixed an issue where the Welcome Assistant showed no icon when running the standard
edition.
Fixed an issue where the Table of Contents inspector didn't scroll to the headings of Markdown
documents in preview mode.
Fixed an issue where the Table of Contents inspector incorrectly listed hashtags.
Fixed an issue where the Annotations & Reminder inspector wasn't always updated after
creating or removing an annotation.
Fixed an issue where the Navigate sidebar didn't scroll to the selected item, e.g., after using Go
> Go to Group.
Fixed an issue where the Open With and Label menus of the See Also & Classify inspector
applied to the currently visible document, not the selected one.
Fixed an issue where the active filter pane didn't immediately apply to search results.
Fixed an issue where the AppleScript application property reading list conflicted with the
alarm parameter of reminders with the same name. The alarm parameter option has been
renamed to add to reading list.
Fixed an issue where the status in the Information bar was displayed incorrectly in macOS El
Capitan.
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Fixed an issue where the tags autocompletion popup would increase its width as tags were
added.
Fixed an issue where the toolbar search popup did not immediately include recent searches.
Fixed an issue where the tooltips of icon view were not always updated after changes.
Fixed an issue where the URL of documents wasn't shown in the Navigation bar after certain
actions, e.g., locking or unlocking an item.
Fixed an issue where the wrong encoding was used for some EPUB documents.
Fixed an issue where the wrong file path was logged to the Log window after importing files
and folders exported from another database.
Fixed an issue where, e.g., Markdown previews, formatted notes, HTML pages, news, etc.
caused artifacts in dark mode.
Fixed an issue with cached counts of smart groups showing out of date numbers.
Fixed an issue with some inspectors scrolling after pressing the Tab key.
Fixed an issue with the alignment of items in Tools > Annotate and Tools > Mode.
Fixed an issue with the text color of the item counts of selected groups in sidebar.
Fixed an issue with undo handling after certain import operations if automatic tagging in
Preferences > Import was enabled.
Fixed issues of the tab order of interface elements with disabled controls.
Fixed issues of undo handling after merging items, especially via AppleScript.
Fixed issues with bookmarks where links to items in a database were marked as having an
annotation file and removing an annotation file from a bookmark would change the URL.
Fixed issues with the Log window.
Fixed issues with the Sorter including: the search field didn't receive focus when opening,
double-clicking groups in the Sorter didn't always switch the sidebar to the Navigate view,
clipping web pages could have the contents or URL of the previous clipped page, the Finder
comment of plain text was set to the clipped text, some appearance issues in the destination
popups, corrected the color of the menu extra in dark mode, and an issue with its position on
a second monitor.
Fixed issues with the clutter-free capture option when handling certain URLs. Also fixed some
layout issues with images in the captured page.
Fixed issues with WebKit crashes.
Fixed issues with WikiLinks, including: an issue where automatic Wiki linking in plain and rich
text documents could create separate links from a single WikiLink, an exception caused by
square bracket WikiLinks after removing all the content from the document, square bracket
links not functioning when inside parentheses.
Pro — Fixed a crash related to archiving emails.
Pro — Fixed a crash related to scanning.
Pro — Fixed an issue where a selection of multiple UNIX mailboxes couldn't be imported.
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Pro — Fixed an issue where corrupt PDFs caused a memory leak.
Pro — Fixed an issue where Danish was being shown as Esperanto in Preferences > OCR.
Pro — Fixed an issue where dragging messages from Apple Mail could freeze both Mail and
DEVONthink.
Pro — Fixed an issue where Microsoft Outlook wasn't automatically launched by the Import
sidebar.
Pro — Fixed an issue where reporting corrupt PDFs did not always work as expected.
Pro — Fixed an issue where scanning input only went to the Global Inbox when using the
Metadata panel post-OCR. Also reinstated the ability to resize the Metadata panel.
Pro — Fixed an issue where switching to Import sidebar didn't always work.
Pro — Fixed an issue where the text color of custom metadata in Preferences > Data wasn't
updated after toggling the checkbox.
Pro — Fixed an issue where the color of linked text in rich text content in the Info > Custom
inspector was wrong when using dark mode and smart links.
Pro — Fixed an issue where the text color of imported Bookends references wasn't correct in
dark mode.
Pro — Fixed an issue where item links of emails containing / didn't work.
Pro — Fixed issues of the web sharing, including some localization issues, and disabling
dragging while renaming items.
Pro — Fixed issues with the Concordance inspector, including: an issue where double-clicking
on a word in the inspector in document windows caused an exception and artifacts with Greek
characters.
Sync — Fixed a rare crash related to broken status files.
Sync — Fixed an issue where Bonjour syncs could cause intermittent freezes.
Sync — Fixed an issue where resolving conflicts or when synchronizing indexed cloud folders or
network volumes could cause duplication.
Sync — Fixed an issue where sync locations could appear to be constantly busy.
Sync — Fixed an issue where temporary Dropbox server issues could cause synchronization to
be endlessly retried.
Removed obsolete scripts for Microsoft Entourage.

VERSION 3.0.4 ... 1.0.1
Skipped.

VERSION 1.0
Initial release.
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LICENSE AGREEMENT
PLEASE READ THIS LICENSE CAREFULLY
BEFORE USING THIS SOFTWARE. BY USING
THIS SOFTWARE, YOU ARE AGREEING TO
BE BOUND BY THE TERMS OF THIS LICENSE
AGREEMENT. IF YOU DO NOT AGREE TO

3. Disclaimer of Warranty on Software:
You expressly acknowledge and agree that
use of the Software is at your sole risk. The
Software and related documentation is
provided "AS IS" and without warranty of any
kind.

THE TERMS OF THIS LICENSE, DELETE THE

4. Limitation of Liability: UNDER NO

SOFTWARE OR RETURN THE SOFTWARE

CIRCUMSTANCES INCLUDING NEGLIGENCE,

AND RELATED DOCUMENTATION TO

SHALL DEVONTECHNOLOGIES BE LIABLE

DEVONTECHNOLOGIES, LLC.

FOR ANY INCIDENTAL, SPECIAL OR

1. License: The application and other
components (sound and graphics)
accompanying this License, whether
on disk, in read only memory, or on any
other media (the "Software"), and the
related documentation are licensed
to you by DEVONtechnologies. You
own the disk on which the Software is

CONSEQUENTIAL DAMAGES THAT RESULT
FROM THE USE OR INABILITY TO USE THE
SOFTWARE OR RELATED DOCUMENTATION.
In no event shall DEVONtechnologies' total
liability to you for all damages, losses and
causes of action (whether in contract, tort
(including negligence) or otherwise) exceed
the amount paid by you for the Software.

recorded but DEVONtechnologies and/or

Apple, Cocoa, ColorSync, Darwin, macOS,

DEVONtechnologies' Licensor(s) retain title

QuickTime, Quartz and all other registered

to the Software and related documentation.

names are trademarks of their respective

This License allows you to non-simultaneously

owners.

use the Software on multiple computers by
the same person.

CREDITS

2. Restrictions: The Software contains
copyrighted material, trade secrets and
other proprietary material and in order
to protect them you may not decompile,
reverse engineer, disassemble or otherwise

ABBYY FINEREADER ENGINE
ABBYY FineReader 11.x Engine Copyright
© ABBYY Software Ltd. OCR by ABBYY
Software House.

reduce the Software to a human-perceivable
form. You may not sub-license, modify, rent,

MULTIMARKDOWN

lease, or create derivative works based upon
the Software in whole or in part. You may
not distribute the Software in any form,
including, but not limited to, electronic
information service distribution, bulletin
board distribution, and magnetic or optical

Copyright © 2016-2018 Fletcher T. Penney.
MultiMarkdown is released under both the
GPL and MIT licenses. You may pick the
license that best fits your needs.

medium distribution.
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Modifications to remove reliance on Glib2:

of the Software, and to permit persons to

Copyright © 2011 Daniel Jalkut, licensed

whom the Software is furnished to do so,

explicitly MIT.

subject to the following conditions: The

LyX export code © 2013-2014 Charles R.

above copyright notice and this permission

Cowan, licensed under both GPL and MIT

notice shall be included in all copies or

licenses.

substantial portions of the Software. THE

Portions based on: peg-markdown.

SOFTWARE IS PROVIDED "AS IS", WITHOUT

Copyright © 2008-2011 John MacFarlane.

WARRANTY OF ANY KIND, EXPRESS OR

ODF output code © 2011-2013 Fletcher T.

IMPLIED, INCLUDING BUT NOT LIMITED TO

Penney. peg-markdown is released under

THE WARRANTIES OF MERCHANTABILITY,

both the GPL and MIT licenses. You may

FITNESS FOR A PARTICULAR PURPOSE AND

pick the license that best fits your needs.

NONINFRINGEMENT. IN NO EVENT SHALL

Original Markdown specification by John

THE AUTHORS OR COPYRIGHT HOLDERS

Gruber.

BE LIABLE FOR ANY CLAIM, DAMAGES OR

The GPL: This program is free software;
you can redistribute it and/or modify it
under the terms of the GNU General Public
License as published by the Free Software
Foundation; either version 2 of the License,
or (at your option) any later version. This
program is distributed in the hope that it will
be useful, but WITHOUT ANY WARRANTY;

OTHER LIABILITY, WHETHER IN AN ACTION
OF CONTRACT, TORT OR OTHERWISE,
ARISING FROM, OUT OF OR IN CONNECTION
WITH THE SOFTWARE OR THE USE OR
OTHER DEALINGS IN THE SOFTWARE.

PANTOMIME
Copyright © 2001-2009 Ludovic Marcotte.

without even the implied warranty of
MERCHANTABILITY or FITNESS FOR A
PARTICULAR PURPOSE. See the GNU General
Public License for more details. You should
have received a copy of the GNU General
Public License along with this program; if

SHORTCUTRECORDER
Copyright © 2006, contributors to
ShortcutRecorder. (See the contributors
listed in detail later in the file.)

not, write to the Free Software Foundation,

All rights reserved. Redistribution and use

Inc., 51 Franklin St, Fifth Floor, Boston, MA

in source and binary forms, with or without

02110-1301 USA

modification, are permitted provided that

The MIT License: Permission is hereby

the following conditions are met:

granted, free of charge, to any person

Redistributions of source code must retain

obtaining a copy of this software and

the above copyright notice, this list of

associated documentation files (the

conditions and the following disclaimer.

"Software"), to deal in the Software without

Redistributions in binary form must

restriction, including without limitation the

reproduce the above copyright notice,

rights to use, copy, modify, merge, publish,

this list of conditions and the following

distribute, sublicense, and/or sell copies

disclaimer in the documentation and/
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or other materials provided with the

Ilya Kulakov. ShortcutRecorder 2.0 and

distribution.

further support.

The name of the contributors may not

Alexander Ljungberg. Graphics for

be used to endorse or promote products

ShortcutRecorder 2.0

derived from this software without specific
prior written permission.
THIS SOFTWARE IS PROVIDED BY THE
CONTRIBUTORS "AS IS" AND ANY EXPRESS
OR IMPLIED WARRANTIES, INCLUDING, BUT
NOT LIMITED TO, THE IMPLIED WARRANTIES
OF MERCHANTABILITY AND FITNESS FOR
A PARTICULAR PURPOSE ARE DISCLAIMED.
IN NO EVENT SHALL THE CONTRIBUTORS
BE LIABLE FOR ANY DIRECT, INDIRECT,
INCIDENTAL, SPECIAL, EXEMPLARY, OR
CONSEQUENTIAL DAMAGES (INCLUDING,
BUT NOT LIMITED TO, PROCUREMENT OF
SUBSTITUTE GOODS OR SERVICES; LOSS

SPARKLE
Copyright © 2006-2013 Andy Matuschak
Permission is hereby granted, free of charge,
to any person obtaining a copy of this
software and associated documentation
files (the "Software"), to deal in the Software
without restriction, including without
limitation the rights to use, copy, modify,
merge, publish, distribute, sublicense, and/
or sell copies of the Software, and to permit
persons to whom the Software is furnished
to do so, subject to the following conditions:

OF USE, DATA, OR PROFITS; OR BUSINESS

The above copyright notice and this

INTERRUPTION) HOWEVER CAUSED AND

permission notice shall be included in

ON ANY THEORY OF LIABILITY, WHETHER

all copies or substantial portions of the

IN CONTRACT, STRICT LIABILITY, OR TORT

Software.

(INCLUDING NEGLIGENCE OR OTHERWISE)
ARISING IN ANY WAY OUT OF THE USE OF
THIS SOFTWARE, EVEN IF ADVISED OF THE
POSSIBILITY OF SUCH DAMAGE.

THE SOFTWARE IS PROVIDED "AS IS",
WITHOUT WARRANTY OF ANY KIND,
EXPRESS OR IMPLIED, INCLUDING BUT
NOT LIMITED TO THE WARRANTIES

Contributors to Shortcut Recorder, in no

OF MERCHANTABILITY, FITNESS

order in particular:

FOR A PARTICULAR PURPOSE AND

Jesper, waffle software. Initial idea and
concept, first shot at implementation
using NSView.
David Dauer. Refinement, cleaner
reimplementation, documentation, IB
Palette.
Jamie Kirkpatrick, Kirk Consulting Ltd.
Further modularisation and re-factoring,

NONINFRINGEMENT. IN NO EVENT SHALL
THE AUTHORS OR COPYRIGHT HOLDERS
BE LIABLE FOR ANY CLAIM, DAMAGES OR
OTHER LIABILITY, WHETHER IN AN ACTION
OF CONTRACT, TORT OR OTHERWISE,
ARISING FROM, OUT OF OR IN CONNECTION
WITH THE SOFTWARE OR THE USE OR
OTHER DEALINGS IN THE SOFTWARE.

and general bug fixes.
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SKIM
Copyright © 2008-2018, Christiaan Hofman
and contributors All rights reserved.

NEGLIGENCE OR OTHERWISE) ARISING
IN ANY WAY OUT OF THE USE OF THIS
SOFTWARE, EVEN IF ADVISED OF THE
POSSIBILITY OF SUCH DAMAGE.

Redistribution and use in source and binary
forms, with or without modification, are
permitted provided that the following
conditions are met:

LETSMOVE
Public domain. More information can be
found atLetsMove.

Redistributions of source code must retain
the above copyright notice, this list of

ZIPZAP

conditions and the following disclaimer.

Copyright © 2012, Pixelglow Software. All

Redistributions in binary form must
reproduce the above copyright notice, this

rights reserved.

list of conditions and the following disclaimer

Redistribution and use in source and binary

in the documentation and/or other materials

forms, with or without modification, are

provided with the distribution. Neither the

permitted provided that the following

name of Christiaan Hofman nor the names

conditions are met:

of any other contributors may be used to
endorse or promote products derived from
this software without specific prior written
permission.

Redistributions of source code must retain
the above copyright notice, this list of
conditions and the following disclaimer.
Redistributions in binary form must

THIS SOFTWARE IS PROVIDED BY THE

reproduce the above copyright notice,

COPYRIGHT HOLDERS AND CONTRIBUTORS

this list of conditions and the following

"AS IS" AND ANY EXPRESS OR IMPLIED

disclaimer in the documentation and/

WARRANTIES, INCLUDING, BUT NOT

or other materials provided with the

LIMITED TO, THE IMPLIED WARRANTIES OF

distribution.

MERCHANTABILITY AND FITNESS FOR A
PARTICULAR PURPOSE ARE DISCLAIMED.
IN NO EVENT SHALL THE COPYRIGHT
OWNER OR CONTRIBUTORS BE LIABLE
FOR ANY DIRECT, INDIRECT, INCIDENTAL,
SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
DAMAGES (INCLUDING, BUT NOT LIMITED
TO, PROCUREMENT OF SUBSTITUTE GOODS
OR SERVICES; LOSS OF USE, DATA, OR
PROFITS; OR BUSINESS INTERRUPTION)
HOWEVER CAUSED AND ON ANY THEORY
OF LIABILITY, WHETHER IN CONTRACT,
STRICT LIABILITY, OR TORT (INCLUDING

THIS SOFTWARE IS PROVIDED BY THE
COPYRIGHT HOLDERS AND CONTRIBUTORS
"AS IS" AND ANY EXPRESS OR IMPLIED
WARRANTIES, INCLUDING, BUT NOT
LIMITED TO, THE IMPLIED WARRANTIES OF
MERCHANTABILITY AND FITNESS FOR A
PARTICULAR PURPOSE ARE DISCLAIMED.
IN NO EVENT SHALL THE COPYRIGHT
HOLDER OR CONTRIBUTORS BE LIABLE
FOR ANY DIRECT, INDIRECT, INCIDENTAL,
SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
DAMAGES (INCLUDING, BUT NOT LIMITED
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TO, PROCUREMENT OF SUBSTITUTE GOODS

STRICT LIABILITY, OR TORT (INCLUDING

OR SERVICES; LOSS OF USE, DATA, OR

NEGLIGENCE OR OTHERWISE) ARISING

PROFITS; OR BUSINESS INTERRUPTION)

IN ANY WAY OUT OF THE USE OF THIS

HOWEVER CAUSED AND ON ANY THEORY

SOFTWARE, EVEN IF ADVISED OF THE

OF LIABILITY, WHETHER IN CONTRACT,

POSSIBILITY OF SUCH DAMAGE.
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TECHNOLOGY
FEATURES

IN THIS CHAPTER
General Concept

264

The DEVONtechnology is a rock-solid

Features

264

foundation suitable for a variety of

Structure

264

completely independent applications.

Applications

265

Therefore it is ideal for the rapid
development of a huge range of new

All commercial DEVONtechnologies
applications are based on a proprietary
AI technology, with rock-solid database
foundation that allow them to manage large

database-, signal-processing- and languageanalysis-driven applications. The ability to
deal with any kind of digital data makes it
extremely flexible.

numbers of documents or knowledge bits
while analyzing them almost instantly at the

The size of DEVONtechnology-based

same time.

databases can, depending on the type of
data stored, grow logarithmically and make

GENERAL CONCEPT

indexing is completely unnecessary. Also,

DEVONtechnology, on which all

improve themselves continuously (the more

DEVONtechnologies' applications are built, is

data they handle, the better the results),

a new technology at the very beginning of its

are language-independent and iron out any

development. DEVONtechnologies constantly

irregularities by applying fuzzy logic.

applications based on the DEVONtechnology

improves the technology and enhances it for
more functionality, efficiency, robustness and
flexibility.

STRUCTURE
The DEVONtechnology consists of a kernel

Development of the DEVONtechnology is a
battle on two main forefronts of information
processing technology. DEVONtechnologies is

and several layers. Together they perform all
the underlying computing, from 'simple' data
handling to complex signal processing.

working hard on unifying both the top-down
and the bottom-up AI concepts by imitating

Kernel: The kernel is the foundation for all

high-level functions and simulating the basic

layers and applications and is responsible

functionality of natural systems. This leads

for data handling, semantic and associative

to highly functional, fast and efficient AI

data processing, signal processing, fast

systems that can be used in a great variety

statistic analyses and all fuzzy algorithms.

of information processing contexts, such as

It has to be as fast, flexible, and extensible

pattern recognition, signal processing and

as possible; it is 64-bit aware and uses a

information storage and retrieval.

generic, proprietary file format (see above)
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allowing it to verify and repair low level data
consistency, featuring logarithmic growth
of the database and logarithmic speed
decrease with increasing database size. The
DEVONtechnology kernel is Unicode-aware,
completely language-independent and selfoptimizing and self-organizing.

APPLICATIONS
Some of the most likely applications for
the DEVONtechnology are databases
(knowledge bases, expert systems, search
engines, table-of-content-generators,
instant data-mining), intelligent agents,
encryption, compression and archiving.

Layers: The layers form a shell around the

Other uses for DEVONtechnology may be

kernel and provide high-level functions

chat-bots, context-sensitive help, optical

for the applications built on top of them.

character recognition (OCR), speech analysis,

The database layer, for example, is used to

recognition and synthesis, staticstics,

store and organize data and supports all

thesauri and automatic translations.

kinds of relations (1:n, n:1, n:n), hierarchies
and freeform databases. No indexing or
primary keys are required, strings can be
unlimited in size and it's possible at any time
to extend the range of pre-defined data
types (Boolean, character, float, double,
signed, unsigned, string, date, time, blob,
color, size, and point). Another layer, the

In particular, applications dependant on
processing human language, either written or
spoken, benefit from the flexible technology
foundation. So, DEVONtechnologies' main
focus in the development of new applications
is in these areas: databases, 'intelligent'
agents, text and speech analysis, statistics.

XML layer, makes it easy to handle XML code

Look forward to see a great range of different

within the DEVONtechnology; it has a very

applications based on the DEVONtechnology.

small overhead, compared to DOM parsers or

A few have already been announced

available XML databases, requires no indexing

on the DEVONtechnologies web site:

and supports the tight integration of other

www.devontechnologies.com.

databases (and vice versa).
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OTHER PRODUCTS
IN THIS CHAPTER

If you have a moment feel free to visit our

Overview

266

DEVONthink

266

DEVONagent

266

DEVONsphere

267

Needful Things

267

lively user community. Here users of all skill
levels meet to discuss our applications, talk
about our technology, and exchange tips and
tricks for DEVONthink & Co.

DEVONTHINK
Besides DEVONthink, DEVONtechnologies
publishes a number of other commercial,
shareware, and freeware applications and
services that might be helpful for you.

Organize and work with all your documents,
bookmarks, email messages, text files,
images, PDFs, in one place, regardless where
they originated. Quickly capture data without

OVERVIEW
DEVONtechnologies is focused on developing
innovative applications for finding, storing,
and organizing information. Our main
objective is to make complex yet flexible
technology that is both easy to use and

interrupting your workflow. DEVONthink's
unique AI assists you in getting the most out
of your data collection.
Learn more about DEVONthink
Check your upgrade options if you want to
upgrade to a higher edition

lightning fast. All applications are based on
the DEVONtechnology, a powerful and solid

DEVONAGENT

core unique to DEVONtechnologies.

DEVONagent Pro helps you search more

DEVONthink
DEVONagent
DEVONsphere

efficiently on the web. It searches multiple
sources, frees you from hunting for the really
relevant results, and gives you power tools
for your research. DEVONagent Express and

We also publish some freeware apps and

DEVONagent Lite (free) make searching

services for your everyday work with your

the web as easy as using Spotlight. Search

Mac.

Google, Bing, YouTube, Facebook, Twitter,
even the Mac App Store, right from the menu

NEWSLETTER & COMMUNITY

bar.

Would you like us to keep you informed about

Learn more about DEVONagent Pro.

updates and new product releases? Visit our
blog and subscribe to our free newsletter.
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DEVONSPHERE
Make your Mac smarter: Let DEVONsphere
Express keep track of related emails, articles
on the same subject, and similar web pages.
Discover the hidden connection between
seemingly unrelated files.
Learn more about DEVONsphere Express.

NEEDFUL THINGS
Search files on your hard disk, watch web
cams, create thumbnails, or access all your
files and apps from the menu bar. Reformat
paragraphs in your favorite word processor or
do little calculations anywhere you can type
in text. All for free.
Learn more about our freeware apps and
services.
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