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Getting Started
Welcome to DEVONthink, a powerful assistant in your quest to organize many kinds of information. From recipes to your dissertation, hobbies to health, for work or home, DEVONthink can help you gather, organize, and connect your data. This manual will help get you familiarized with DEVONthink's concepts, interface, and options. We begin with simple overviews, move into descriptions of the essential controls, then conclude with the deepest details in the appendix.
Note this manual is meant as a handy reference, not as a series of mandates on how you must use it. DEVONthink can be used very simply or in very complex ways and each person brings their own personal approach to using it. To that end, this document can't be an exhaustive guide to everything you could ever do with it. With the flexibility and capabilities built-in, that would be an impossible task. We hope you find this guide helpful.
Note:
Text in blue color (besides hyperlinks that might get colored in blue by your ebook reader) refers to functionality only available in higher editions. You can find a list of the editions and their features online.
Warmest Regards, The DEVONtechnologies Team
Now let's get into it…
Installing, Updating, Uninstalling
Note:
The following procedures do not apply when you have purchased DEVONthink on the Mac App Store. Installing, updating, and uninstalling are handled by the App Store application in this case.
Installing
If you haven't already installed DEVONthink, here are the easy steps to accomplish that:
Note:
Please note that macOS Services and the connection to DEVONagent work only for applications installed into the Applications folder, and that logout and login or a restart is suggested after installation to make all parts of macOS aware of the additional services that come with DEVONthink.
Updating
Updates to DEVONthink are done per the schedule set in Preferences > General > Check for Updates.
If you need to manually update the software, follow the previous installation instructions, but allow the Finder to overwrite the old version. Your database(s) will not be affected. To avoid any potential problems, do not use a third-party uninstaller utility. Just replace the current version, as directed.
App Store to Free-World Conversion: If you purchased DEVONthink in the Mac App Store you can also download the update from the Download page. It will retrieve the existing receipt and accept it as valid license.
Uninstalling
If for some reason you need to fully uninstall DEVONthink from your Mac, trash the following files and folders (~ stands for your account's home folder):
Note:
In troubleshooting situations, please do not uninstall the software without talking to our support team beforehand. Most issues can be resolved without uninstalling the software.
DEVONthink Simplified
DEVONthink is a very flexible application, appealing to a broad range of people and accommodating many different working styles. Since people use it in such diverse ways, it often leads people to believe there is a "steep learning curve" associated with it. The truth of the matter is DEVONthink is a powerful application built on simple, and often familiar components and concepts. Here we'll cover the basics.
Interface
At its core, DEVONthink is a multi-window, document-based application. Multi-window merely means you can have more than one window open. Document-based means it supports viewing, and in some cases editing, documents. Apple Notes is an example of a document-based application without multi-window support.
DEVONthink has two main window types: a main window (seen immediately when the software opens), and document windows. These windows are used in already familiar ways, supporting drag and drop, sorting on different attributes, full screen views, etc. Whether you are working (or playing) in DEVONthink, you will be using one or both window types.
DEVONthink supports different ways of viewing your items, e.g., in lists or as icons. You can show or hide many details in the window, allowing you to work in very simple or complex views of your data. Specifics about windows and their component panes and bars are discussed in more detail in the Windows and Inspectors chapters.
DEVONthink also has a powerful array of tools found in its menus. Many of these are also found in the contextual menus when Control-clicking items in the software. And to fine-tune some of the options, it also has extensive preferences.
Databases
Beyond the interface, DEVONthink has only a few core working components: databases and items. Items are comprised of two essential components: groups and documents.
Note:
Throughout the documentation, we use item to represent both groups and documents. Things that only apply to one or the other will use the appropriate term.
Displayed as and shown only in the Navigate sidebar, databases are the fundamental unit in DEVONthink, filled with items. No matter if your content is grouped, ungrouped, or a mix, it is all housed in a database. You add, remove, organize, and search for files within DEVONthink, just as you've done in the Finder forever. Simple.
When you create a database, it is made as a self-contained package in the Finder. Packages are technically folders that are handled like single files by the Finder.
DEVONthink databases are not merely a series of files and folders in the Finder, but are isolated from each other and function a bit more like disks. When you plug in an external drive, it appears in the Finder's sidebar isolated from other disks, but still capable of moving and organizing data on it. In a similar fashion, open databases appear in DEVONthink's sidebar and behave in much the same way.
Global Inbox: Displayed as , when you launch DEVONthink, you will immediately see a database called Inbox. This is a special database and a core component of the software. As a core database, you can't delete or close it, as it provides an always open database for quickly storing unfiled or transient data.
Imagine you are reading about fission reactions and someone sends a link about a vacation place in Bali. You jump to the website and quickly clip a webarchive of the page. But instead of putting it in your research database, you add it to the Global Inbox and get back to work. You can go back later and read or sort things to other databases. If you are familiar with Getting Things Done you'll recognize the concept.
The Global Inbox is also special as it is the only database you can add a shortcut to in the Finder's sidebar. This allows you to save a file into the Global Inbox from other applications.
All databases also have an Inbox group with the same purpose as the Global Inbox. It just allows you to save unfiled data to a more specific database, as needed.
One of the two basic items are groups. No different than the folders and groups found in many other applications, they merely serve as ways to keep certain bits of data together. But within the DEVONthink groups are a few variations. They are all simple to recognize and understand, but they bear being introduced.
Ordinary Groups: Displayed as , these are analogous to folders in the Finder. Except for underlying technology, groups operate in the same fashion. Creating, adding and removing contents, and deleting are all essentially the same. Just as in the Finder, you can create subgroups to suit your needs.
Looking and behaving like folders you've used in the Finder, groups are the simplest way to segregate data. DEVONthink allows you to create deeply nested hierarchies or simple top level groups, whatever you need to keep things organized in a way that makes sense to you.
New empty groups can be made with the Data > New > Group command. Groups of selected items can be easily made and unmade via the Group Items and Ungroup Items commands in the Data menu. These commands are also in the contextual menu.
Groups are also the target of DEVONthink's classify function. The AI compares document contents and locations and offers suggestions for where items may best be filed. As documents are filed, manually or taking the AI's suggestions, it becomes more and more adept at helping you file more efficiently.
Group Tags: Displayed as , these are created and operate like ordinary groups, with one extra function: the name of a group tag is applied as a tag to its contents (sometimes referred to as "children"). By unchecking Exclude Groups from Tagging in a database's properties, any group you create will function this way. For individual groups, you have the option of choosing Exclude from Tagging from the contextual menu or Info inspector.
As you add items to a group tag, they are automatically tagged with the parent folders' name. Similarly, removing items from a group tag will remove the parent tags. Also, if you create sub-groups, these will also be created as group tags. This can be useful if you're using a group for staging purposes, e.g., a groups for unassigned, in progress, and done items. Moving files between these groups would change the tag to its current parent group.
Smart Groups: Displayed as , smart groups should be familiar to anyone using saved searches in the Finder. Similar to them, smart groups don't actually contain anything. They merely show you items matching the criteria you specify. Sometimes broadly used in situations where deeply nested groups are not used, you can create as many as you'd like no matter your approach.
These special groups allow you to create virtual groups based on any number of matching criteria. These can be simple, e.g., "all PDF files in a database", or complex, like "all unread documents with a specific color label added in the last week but excluding HTML files". If you like to use a looser filing method, using smart groups allows you to file your items with less concern about where they're located in the database. With smart groups you can also have items appear in more than one smart group without replicating or duplicating files explicitly. For example, a smart group could show items tagged with "taxes". You could then create another smart group with items tagged with "taxes","business", and "2018".
Local smart groups, i.e., ones applied to a specific database, can be created and edited via the Data > New > Smart Group command. You can also find this command in the contextual menu when Control-clicking in the item list. Smart groups can also be created when doing an Advanced search.
When you create a new database, DEVONthink automatically adds a few of predefined smart groups for your convenience:
Note:
Smart groups filtering on dates or unread status are shown with special icons.
Smart Rules: Displayed as and found only in the Navigate sidebar, smart rules are a type of smart group with an extra function: they not only match items by the criteria you specify, they can also act on them. These actions can even trigger when certain events happen. For example, you could have a smart rule matching PDFs in the Global Inbox and have newly added PDFs be added to the Reading List.
The second basic item in DEVONthink are documents. No different than the Finder, documents are any files you add or create in your databases. Perhaps you are importing spreadsheets for work, or PDFs for your thesis. Maybe some photos from your vacation you want to link to in a Markdown document you're working on. They're all just documents.
DEVONthink supports adding many kinds of files to your databases, but note the type of file determines its usefulness in the database. For example, images can easily be added but searching for them is limited to searching by attributes like file type or filename. Remember DEVONthink excels at text-based operations, so files like rich text or PDFs are very well supported.
Note:
More information on the types of files you can create or import can be found in the Documents chapter.
While not types of document per se, there are two variations on documents available to you: duplicates and replicants.
Duplicates: Displayed with to the right of a document's name or the name optionally shown in blue type, there are two ways to get a duplicate in your database. Firstly, just as you'd expect in the Finder, select a file and press ⌘D: a duplicate is made. Secondly, if DEVONthink examines the contents and determines it has another file with the same content, it will mark them as duplicates. Duplicates are separate files, and changes to the content of one should remove its duplicate status.
Replicants: Displayed with to the right of a document's name or the name optionally shown in red type, replicants are conceptually similar to aliases in the Finder or a second phone book entry for the very same person. Replicants are one file showing up in more than one location. However, they consume no more space than a single file. Since they are clones, changes made to any instance of a document apply to all instances. This makes them useful when you want to file a document in more than one location, but don't want to have to update each document individually. It can also be useful if you have larger files you want filed in more than one group. A 10 MB PDF, replicated in ten different groups, would only use 10 MB of space in the database.
There is also the possibility of having a document that is both replicated and a duplicate. This will display this icon to the right of the name:
It's important that you understand how replicants work before you begin making changes to documents. Any changes to a replicant are carried over to all replicants; as you might imagine, this means that you can to do some very powerful (and potentially negative) things with your database's contents via replicants. Duplicates, on the other hand, allow you to change the files without modifying the original document or group. Duplicates are less powerful than replicants, but no less important in the grand scheme of database organization.
On a technical side note, when you add an ordinary tag to a file, a replicant is made in the appropriate tag group.
Note:
Replicants cannot be created in the same location as the originating file, nor can they be made across databases.
The Details
We hope this has given you some insight into the basics of DEVONthink. DEVONthink is deep and powerful, but understanding these basic concepts and seeing parts you are already familiar with will hopefully dispel some of the "fear" that it's complicated and hard to learn.
That being said, we also have more in-depth information for you. From simple overviews of menu commands to details in the appendix can be found in the remainder of this guide.
Building Your Database
The first step in starting your own custom database is to create a new database with File > New Database. Give your database an easily recognizable name, and choose where you want to save your database. We advocate putting them in a folder in your home directory, like ~/Databases. With your new database created, you are ready to add information.
Encrypted Databases: If you have databases containing sensitive or private information, you can create an encrypted database. This is specialized AES-256 encrypted disk image that will not appear in the Finder or your desktop when it's open. In the Navigate sidebar, you will see a key icon to the right of the database's name, denoting it is an encrypted database. Quitting DEVONthink or closing the database unmounts the disk, so you are always required to enter the password to access it.
Choose File > New Encrypted Database and enter a password that will be used to unlock it. Enter a reasonable anticipated size for the database, in megabytes or gigabytes. This is how large you think the database will get. Since the encrypted database functions like a connected drive, you define how large it is and "fill it up". You can choose to let Spotlight index the contents, but bear in mind the Spotlight index is stored locally and isn't encrypted. This means someone could find a document in the database exists via a Spotlight search. However, they wouldn't be able to open and access the database without the proper password.
Note:
You cannot create or store a database in a cloud-synced folder, e.g., iCloud Drive or Dropbox. This is not data-safe so the behavior is explicitly disallowed. The advocated location is a folder in your home directory, like ~/Databases. If you try to open a database in one of these locations, you will be prompted to let DEVONthink move the database, or reveal it so you can manually relocate it.
Adding your files
After you've created your database, you'll add your files to it. Often it's a simple matter of dragging and dropping files into your database, but we've covered several additional methods in the In and Out chapter. Also, please take a moment to review the Import and Index section to familiarize yourself with these two options.
While you may be tempted to dump every file on your hard drive into DEVONthink and sort it out later, you're best off being more selective in what you add (especially in the beginning). Having a large, "dump it all in" database can contain a lot of files that will do you no practical good (for example, DEVONthink can't read your Microsoft Office user profile files), and weeding these files out after-the-fact can be both time-consuming and frustrating. Also remember, DEVONthink has to index metadata and contents of any compatible files. This will be less productive if you add files you'd never want to use or search for.
Here's a practical example: Your iTunes database runs over 22 gigabytes. There's nothing to be gained by simply copying that into a DEVONthink database. Copying the iTunes database into DEVONthink would result in a large, inefficient, and slow DEVONthink database, and would cripple DEVONthink's ability to manage and use content in a well-designed manner (much less perform simple search and organizational tasks).
As your growing databases use RAM, processor time, etc., smaller, more focused databases are often a more effective approach than using singular, monolithic databases. Separate databases generally perform better, sync faster, and in the rare case of a catastrophe, can help avoid data loss since you're not keeping "all your eggs in one basket". Another benefit of this approach is the ability to conserve some machine resources. With a single, large database all the information is always using resources, even files unrelated to what you're working on at the moment. With separate databases, you can close and open specific databases as the need dictates.
One way to effectively create separate databases is to use a topical database approach. Create multiple databases, with each holding only related information: a bird watching database full of birding articles and newsletters; a quantum physics research database with research briefs and email. This method can improve the effectiveness of DEVONthink's artificial intelligence (AI) features with each database. The AI work best within a database that contains contextual relationships among many documents; clogging your new database with everything from A (apple pie recipes) to Z (Zengobi user documents) will only hamper the AI's ability to work effectively.
Having topical databases can help down the road as well. You may be collaborating on a database, syncing between machines in a group. Imagine having just one database: You decide to share your painstakingly researched academic articles with colleagues, only to find that you've mistakenly also shared personal financial records and chats. Not hard to imagine how that has the potential to be both dangerous and embarrassing. Having multiple, topical databases will allow you to keep your data separate and private.
Organizing
Database organization depends on the parties involved. For collaborative work, you'll want to organize it in a manner that's understandable to all parties using it. This is especially important as our sync technology is a mirroring sync, meaning changes to one copy of the database gets synced to the other copies. For personal work, just set up your database in a manner that makes sense to you. There is no right or wrong way to organize it. This is something you've likely already been doing in the Finder, making folders and filing things in them. Apply the same personal choices to DEVONthink. You can also use smart groups to create virtual groups.
Remember that creating databases isn't an inviolable commitment. Create and destroy them as you see fit. Start with one way of organization and decide later to re-organize your databases. With DEVONthink you can keep multiple databases open simultaneously, easily moving documents from one database to the other at any time. As you work with your databases, new ideas may spark new approaches which can easily be tried and adopted or discarded.
Case study: Bill's Database Farm
Bill DeVille, formerly DEVONtechnologies' Evangelist, worked in a number of scientific areas. Bill's main database covered environmental science and technology topics, with related interests in science and technology exchanges with developing nations. The database even contained some projects dealing with graduate education in environmental sciences and engineering. There's a broad topical relationship among these subjects and the database covers disciplines ranging from chemistry, toxicology, statistics, risk assessment, and engineering to economics, legal, regulatory, and policy issues. These disciplines fit together and combinations of these topics are necessary in many real-world cases.
As you can imagine from the above description, Bill's main database was quite large, containing about 20,000 documents and over 20,000,000 total words. Because of the relationships knitting together all these scientific, technical, legal, and policy issues, the artificial intelligence features of DEVONthink worked very well for Bill in researching the database and contextualizing the information.
In addition to his main database, Bill had seven additional databases (so, eight total). For example, he had one database for Apple Newton literature he has accumulated over the years. It's almost as big as his main database, but the topical coverage has no practical relationship to the main database, so Bill kept the Apple Newton literature in its own domain. If he were to keep this unrelated information in his main research database, the result would be a larger, slower database, with poorer performance by the artificial intelligence.
Occasionally, Bill added topical materials to it that are not related to its main purpose. However, when those "unrelated" topics grew large enough in volume, he spun them off into to a new database in order to preserve AI accuracy and relevance.
If you'd like to follow Bill's method, start by creating a database with some collections of files that interest you, but don't be afraid to create other databases that contain "different" material as your interests, and main your database, grow. And if you need to search across databases, simply open all of them at the same time. DEVONthink searches all of them almost simultaneously.
Tagging
Tagging is a common method of creating contextual relationships between documents. For example, you can apply a "hobby" tag to a woodworking article and a sewing machine PDF manual. You would then find both documents when searching for the "hobby" tag. Used in the Finder and many other applications, DEVONthink also supports tagging in your databases (including preserving Finder tags on imported and indexed items). Tags are either ordinary tags or group tags, each discussed below.
Similar to tagging methods used in other applications, ordinary tags are added to items by you.
Creating tags: When you add a tag to an item for the first time, a tag group is automatically created in the Tags section for the current database. However, if you want to proactively create tags to be used later, you can select the Tags section for the database and choose the Data > New > Tag command. You can also choose New Tag from the contextual menu when Control-clicking the Tags for the database.
Applying tags: When you apply a tag to an item, a replicant of that item is created in the Tags section for the current database. For each tag you apply, you will have a replicant in each tag group. These are not the original items, but only instances of the items. If you delete a tag group, the group and the replicants it contains are removed. The original items in the database remain intact.
When applying tags to indexed items, the tags are immediately written to the indexed files as macOS Tags. If you tag imported items, tags are handled internally, but will be applied to the files when you export them or drag and drop them from DEVONthink to the Finder. However, you can still search for them with a Spotlight search of tag:myTag if you have enabled Create Spotlight Index in a database's Database Properties.
Ordinary tags are most commonly applied to items by these methods:
In the case of multiple selected items, any tags common to all the items will be shown in the Info inspector and Info popup. Tags unique to specific files aren't displayed. However, you can add tags common to all the selected items using these views.
Tags can also be applied by more automated means, e.g., scripting and smart rules. see the Automation chapter for more information.
Nested Tags
Sometimes referred to as "hierarchical tags", nested tags are a series of related ordinary tags, combined under a parent tag. When you add a child tag, the item automatically inherits the parent tags. In the example shown below, adding a tag of "Casper" to an item would automatically add the "Wyoming" and "US" tags.
Note:
If you are having trouble deleting a tag from an item, check to see if you are adding a nested tag.
Caution: Tags for a database can have the same name. This may seem illogical, but it's something more commonly seen that you may expect. For example, say you have a travel database with points of interest like restaurants tagged in different locations. You may find yourself with a tag structure like this…
Example:
US
Wyoming
Casper
Restaurant
Minnesota
St. Paul
Restaurant
If you added a tag Restaurant to an item, what tag would it go to? It actually would go to the most recently entered instance of the Restaurant tag.
So how is this resolved? Tags are meant to be unique, so eliminating redundant tags is first priority. Restaurants aren't specific to a geographic location. Create the Restaurant tag as a top level tag. If you had a need for hierarchy with the tag, perhaps for tax purposes, you could move it into a parent Tag of Entertainment. Then you would get both tags when you added Restaurant. But again, if you anticipate wanting to use the tag without the parent tag, you should make it a top level tag.
Also, you shouldn't view the tags as a group structure in and of itself. Nested tags are just meant to group tags specifically related to each other, so they can be applied en masse.
Note:
Tagging methods and philosophy is full of strong opinions. Many people feel tagging should always be flat; only top level tags and no hierarchies. DEVONthink accommodates both approaches. However, if you want to used nested tags, we hope you carefully consider the caution we've presented and use a hybrid method to avoid unexpected behavior.
Group Tags
Previously discussed in the Groups section earlier in this chapter, group tags allow you to dynamically assign tags based on their location. As you add files to a group, they have tags of the parent groups' name assigned to them. Similarly, if you move the items to a new group, the tags are removed and new ones applied relative to the new location. Whether used statically or dynamically, group tags can be used creatively. They also work in conjunction with ordinary tags, so you can employ both methods in one database.
Example:
Imagine you have a work database with groups for different stages of a project: Unreviewed, Assigned, In Progress, On Hold, and Done. At the beginning of the process, you'd put the item in the Unreviewed group and it would be tagged as such. After reviewing, you could move the file into the Assigned group and the previous tag would be removed and replaced with Assigned. As the project moves through the staging groups, the tag would change.
And of course you can use ordinary tags, e.g., Reviewed or a client identifier, on these items. Those tags would be preserved no matter where you move them in the databases.
Groups tags are applied by DEVONthink automatically. But you can also use do some automatic filing by entering existing group tags manually. If you enter the name of an existing group that is not excluded from tagging into the Tag bar or an Info panel or popover, the item will be replicated to the appropriate group. You can also drag an item to a group tag in the Tag Cloud at the bottom of the Navigate sidebar.
Considerations: When you enable using group tags for a database, it starts as an all-or-nothing situation. All groups in the database function as group tags.
If you want to use group tags for most groups in a database, you can Control-click specific groups and choose Exclude from Tagging. You can also choose this option in the Exclude from… section of the Info inspector or Info popup for a specific group. However, note you must change this setting on all individual groups you'd like to exclude.
If you only want a limited number of tags, it would be advisable to exclude groups from tagging for the database and use ordinary tags instead.
Autocompletion
When you are typing tags, an autocompletion list will appear. In the Global Inbox, tags from any open databases are shown as potential tags. In other databases, the items displayed are only from the tags of the current database.
While group tags aren't added to the Tags group for a database, they are displayed in autocompletion suggestions.
Tags and Aliases: DEVONthink also honors aliases added to groups. You can add "alternative names" to a group using Info popup or inspector and later use these alternative names as a tag. Continuing the previous example, you could add an alias of IP to the In Progress group. Now, type IP as a tag and it will be replicated to the In Progress group. When you view the file, you will see the proper group tag was automatically added.
Search and Gather
Finally, tags have two main functions: segregating data and searching for data. You use tags to gather items together in certain contexts. You also use tags to search for those items.
Searching for items by their tags is easily done in a few ways:
Gathering similarly tagged items is powerfully achieved with Smart Groups. Smart groups allow you to use the smart group editor controls to set criteria to be matched. Included and excluded tags can be added as criteria. Files matching the parameters of the smart group are shown, regardless of their location in the database. This way you can leave your files where they are and create virtual folders for specific purposes.
A Word About Backups
For many users, the value of the data is much greater than the value of the computer that hosts it. There are many things that could go wrong. Your notebook computer could be dropped, lost, or stolen. Your hard drive will fail (it's not a matter if, but when). A power outage could corrupt the files on your hard drive. For the truly paranoid (remember, paranoia is sometimes justified), how significant would the loss of your database be if your house or office were to burn down? Avoid insomnia and back up your database(s) frequently. Your data stored in DEVONthink is valuable, so back it up.
Internal Backups
DEVONthink backs up its database index every week, either immediately after opening the database (if the backup is overdue) or during the day when appropriate.
Note:
The internal backups are mainly a troubleshooting mechanism for use in the application. Backing up your files, including your DEVONthink databases, is up to you.
Full Backups
We strongly recommend you get in the habit of triggering backups whenever you have invested substantial time and effort into modifying the database. Apple's Time Machine and an external drive is an easy way to do this. Simply connect the drive and let Time Machine do its thing. With the low cost of portable external drives, it's even feasible to take a 1 TB drive that can fit in a shirt pocket for backups when you're out and about. Online backups such as Arq Backup are an alternative if you don't want to own another piece of hardware to care about.
As a secondary backup option, you can create an optimized and compressed copy of the whole database that you can then save on a server or other media. Use File > Export > Database Archive or Scripts > Export > Daily Backup Archive to create a ZIP file of the database. The former option allows you to choose specific place; the latter creates it in a Backup folder in your home folder.
Lastly, as events such as house fires and natural disaster frequently prove, valuable data should probably be kept at more than one location. Consider saving a copy of your backed up information at a secure, off-site location such as a bank safe, or put the exported ZIP files of your database in your cloud account.
Note:
As noted in our FAQ, sync is not a backup, neither advertised nor advocated as such. While database restoration may be possible with sync data, it is not meant to be relied upon or used in lieu of proper primary backups.
Tutorials, Screen Casts, and More
In addition to this help resource, explore tutorials and install pre-made scripts and templates that extend DEVONthink's functionality in the Support Assistant. Also new tutorials are shown in the Extras sidebar.
For a great resource of tips, promotions, and release announcements, check out our company blog.
And if you feel like talking to other people using our applications, you'll find discussion, camaraderie, and well over a decade's worth of information at our Forums.
Take time to learn how to work with the software — and to decide how you want the software to work. You'll be rewarded with a powerful assistant for all your information organization needs.
Tasks
The number of possible uses for DEVONthink is nearly endless. In this chapter we've tried to outline a few typical use cases that show how you can use DEVONthink in your daily life and work.
Analyze Text Documents
With its built-in artificial intelligence (AI) functions, DEVONthink can be used to analyze the documents in your databases.
The Concordance function allows you to view a list of all the words contained in a document or database. Selecting a word highlights the word in the current document. Additionally, a graph of related words is shown at the bottom of the Concordance. Right-click a word in the list or graph to exclude them. And if you're wondering about other documents containing a word, double-click one to start a search for that term.
Other functions of the AI's analyses include the Classify function. This examines the text content and locations of other documents in your database and makes suggestions for filing the current document. Additionally, See Also lists documents with a similar content to help find connections you may not have found otherwise.
Possible uses:
Continue to read here:
Archive Your Messages
DEVONthink is the repository for emails you want to save.
Its hierarchical groups structure, automatic classification function, and powerful search engine are perfectly suited to adding, sorting, and finding emails in your databases. DEVONthink comes with advanced email archiving functions that transfer selected messages or mailboxes from Apple Mail, Microsoft Outlook, and any email applications using standard Unix mailboxes, e.g., Thunderbird, to a DEVONthink database. The original structure of the message, as well as all attachments, are preserved when possible. You even can reply to messages directly from DEVONthink's contextual menu commands!
Possible uses:
Continue to read here:
Archive Printed Documents
DEVONthink is the "paperless office" solution for the Mac, a central hub for all your paper and electronic documents.
Using the integrated scanner support you can directly scan documents, make them searchable through OCR (optical character recognition),and file them in a database. Of course, you can also make existing scanned documents searchable. If you own a Fujitsu ScanSnap or other compatible document scanner, you can use the fast auto-feeder to scan batches of sheets in one go.
When you are working in a team, use the embedded web server to give your colleagues access to your data using an interactive web interface. Even friends using Windows are invited.
Possible uses:
Continue to read here:
Browse the Internet
Besides being a knowledge and information database, DEVONthink has built-in web browsing capabilities. This allows you to browse and capture online information directly in a database.
DEVONthink enables you to treat web pages the same way as you treat documents. Whenever you select a bookmark, DEVONthink immediately loads and displays its content live from the internet in the View/Edit pane. You can also open a page in a separate document window. Archive the complete page for offline viewing, add a new bookmark, or drag elements from the page into your database.
DEVONthink also handles RSS, RDF, Atom, and JSON news feeds, either through feed documents or by simply displaying them via the built-in web browser. Stay up-to-date with your subject and clip important information right away.
Possible uses:
Continue to read here:
Capture Data From the Web
Increasingly, information is provided not on paper but directly through web sites, blogs, online news sites, social media, and user forums. DEVONthink offers a variety of options for conveniently capturing data from the web:
All of these options, except the bookmark, capture the text content of the page (or a selected area of it) and hyperlinks if present, and preserve the text information for searches in DEVONthink.
Note:
There are a number of web sites that prohibit use of some of the capture options described above. A secure banking site or a university portal to journals may direct a bookmarklet or script capture option to the login page, which will be captured instead of the desired content. A capture option that requires re-download of the page on such sites will capture only the login page. The page always can be selected and captured as rich or plain text. The viewed page can be captured by "printing" it as PDF to the database.
Possible uses:
Continue to read here:
Catalog Your SD Cards or DVDs
By using the Index function, you can use DEVONthink to set up a catalog for your data DVDs, SD cards, or other removable volumes. Create a group for each disk by using the index function, and organize your disks/groups in any way you like. When you need a specific file, search for it in DEVONthink, insert the volume, Control-click the file in DEVONthink, and select Open With to open the original file on the removable volume.
Note you will only see a thumbnail if the disk or volume is not available. A message to Mount Volume will be shown if a server volume is unavailable. Clicking this button should remount the volume, if possible. For removable disks, DVDs, etc., you will have to reinsert the media.
Possible uses:
Continue to read here:
Catalog Your Photos and Media Files
Besides storing text documents and PDF files, DEVONthink can also contain multimedia data such as photos, illustrations, music, or movies in your databases.
While not designed to replace Photos or Music, DEVONthink can be used as a repository for images you frequently use or as an interface to your music library (if you don't like other music software). If you do not want to import these files, leave them where they are in the file system. You can index the files instead and access them from within DEVONthink [Read more...]
Possible uses:
Continue to read here:
Collect Text Snippets and Other Valuable Data
Use macOS's handy Services menu for collecting and organizing information bits and snippets to DEVONthink.
Select any piece of data and capture it to the currently open database with a keystroke or a quick visit to the Services menu. Most true macOS applications such as TextEdit, Safari, or DEVONthink itself support this mechanism.
DEVONthink automatically sets the title of the newly created snippet to the first line of text, so there's a good chance that you won't even need to rename it. New snippets are created in the global inbox or the location you choose. Also, DEVONthink can help classify and file the items using its built-in artificial intelligence.
Possible uses:
Continue to read here:
Index Files on Your Hard Drive
Besides importing documents, DEVONthink can also index files. When indexing files, DEVONthink reads the contents of the file and stores it for internal reference, but leaves the files in place in the Finder. Use indexing for easily accessing information stored on removable volumes, creating a library of all important documents regardless where they are physically stored, or integrating files stored elsewhere with your documents in DEVONthink. [Read more...]
Possible uses:
Continue to read here:
Manage Your Bookmarks
With its integrated, document-based web browser, DEVONthink can be used as a bookmark manager. Organize all your bookmarks as bookmark documents and visit the web sites by simply selecting them with a preview visible. DEVONthink loads the page and displays it in the View/Edit pane.
If you want to open the web page in your default browser, simply Control-click the bookmark and choose Launch URL from the contextual menu.
Possible uses:
Continue to read here:
Share Project Data
With its built-in synchronization, DEVONthink allows you to have your databases on multiple Apple devices. Changes made on one machine propagate to the others, keeping them in sync. It can also be used to manage a shared project workspace.
Keep all your project-related data in an easy to structure database and share it with your team members. Use a shared WebDAV volume, a shared cloud account, a local file server, or direct connections to propagate new data to the team automatically.
And if your coworkers don't use a Mac give them access via DEVONthink's built-in web server. You can set up web users and fine-tune the access permissions so that visitors only gets access to what they should see. SSL/TLS encrypts all data in transit.
Possible uses:
Continue to read here:
Read News Feeds
DEVONthink comes with built-in support for RSS, RDF, Atom, and JSON news feeds, which makes it a reliable basic news reader. In addition, its integrated web browser supports news feeds and displays them like any other web page. Use its document-oriented structure to organize bookmarks and store news feeds like internet-updated smart groups.
Mix live news feeds with static documents, e.g., in your project materials.
Possible uses:
Continue to read here:
Take notes
DEVONthink is perfectly suited for taking notes and organizing them.
Quickly create new notes and file them in your database using DEVONthink's Tools > Take Note command to open the Sorter (or an independent Take Note panel, if the Sorter is hidden). Alternatively, use the Take Note command in the Dock menu. Notes can be created in plain or rich text, Markdown, or formatted note formats.
Possible uses:
Continue to read here:
Write Texts and Outline Projects
With its hierarchical group structure, organization, and navigation functions, as well as its advanced text editing capabilities and full screen mode, DEVONthink is perfectly suited for writing many kinds of documents, from notes to whole books.
Create new documents with just one click, find related documents in your database, and connect them with Wiki-style or static cross-links. Working these documents in your databases, you can switch from one document to another with just one click, and manage even large projects with ease.
Utilize markers, like flags or color labels to help visually distinguish items, by importance or other criteria using label names. And similar to the Finder, you can create groups, as deeply (or shallowly) nested as you'd like.
Possible uses:
Continue to read here:
Documents
As DEVONthink is an information and document management application, it supports importing many different file types. While not all formats are editable, if a QuickLook plugin is installed on the machine, the files should be viewable. Also, if a Spotlight importer for these files is installed, the files should be indexed by DEVONthink and searchable. In addition, DEVONthink supports creating some common types directly in the application.
In the General section of this chapter, we will discuss the essential window components you'll use when viewing or editing these documents. Following that are chapters for the types of files DEVONthink supports.
General
When working with files in DEVONthink, they can be viewed in the view/edit pane of a main window or in a separate document window. When viewing a document, there are two essential components visible: the view/edit area and the navigation bar. These will always be available when working with a selected file. Additionally, there are a few optional components available: the editing bar (for compatible formats), the tag bar, and the contextual menu.
View/Edit Pane
The view/edit pane is where you can see or edit the current document (with compatible files). Each file type you view has its own tools, contextual menu commands, and keyboard shortcuts.
At the top of the view/edit pane, DEVONthink shows a navigation bar that gives you access to some additional tools that deal directly with the contents of the document. Which tools are available depends on the type of the document you are viewing. The options below are shown in the navigation bar for most file types. Specific options are shown in the separate sections:
For some formats, e.g., rich text or sheets, there is another bar available: the Editing bar. If you click this icon , the editing bar will appear in place of the Navigation bar. This offers quick access to some editing tools related to the file type you're working on. See the appropriate file type section for more info.
The tag bar, which can be shown or hidden, shows all tags associated with the document. Click the tag bar and type to add tags; select a tag and press the ⌫ Backspace or ⌦ Delete key to remove it. [Read more...]
When you type the name of a tag, DEVONthink offers automatic completion. Choose the right option with the mouse or the arrow keys and press ↩ Return or ⌤ Enter to accept it. Press ⎋ Escape to use whatever you entered. Auto-completion prefers ordinary tags (tags represented in the Tags group) over groups used as tags, and also matches sub-strings. Press ⇥ Tab to enter another tag.
Note:
The tag bar is also visible for multiple selected documents when all the documents have the same tags attached. Use it to change the tags on multiple documents.
If you Control-click in many types of documents in DEVONthink, you are presented with a contextual menu showing many options. The options displayed depend on what you're clicking; e.g., selected text, and in whether you're in an editing or preview mode. As many of these commands are the same for most formats, we have provided a list in the appendix. Items specific to a format are listed in their respective sections in this chapter.
Toolbar & Shortcuts
DEVONthink can display documents in separate windows when you double-click the documents in a main window. Depending on the type of document, the tools in the toolbar can change. Even though not all tools are always present in the default toolbar for a particular type, you can easily add some by choosing View > Customize Toolbar. Changes made to the toolbar will be persistent for that file type, but are independent of the toolbars of other types.
Please find a list of toolbar items and shortcuts in the appendix.
Note:
Documents are automatically saved every five minutes after the last modification, when deactivating the window, or when quitting DEVONthink.
Document Linking
Documents in DEVONthink are independent items but often have contextual relationships with other documents in your databases. Here are a few ways to make links in the text of editable documents and establish those connections:
Of the methods listed above, the ones utilizing item links are of special note.
Incoming and Outgoing Item Links
Incoming and outgoing links are item links DEVONthink has detected. The two types of links function as sides of one operation. If you create an item link to an image, the file will have an outgoing link detected. The image you have linked to will have an incoming link detected since the file has a link pointing to it.
Documents with incoming or outgoing links will have a special property icon displayed to the right of the filename in the item list. [Read more...]. You can display a sortable Incoming Item Links and Outgoing Item Links column in the headers of the item list in List view. There also are incoming and outgoing item link criteria usable in toolbar searches, smart groups, smart rules, and AppleScript.
Viewing Links
See the Document > Links section of the Inspectors chapter for information on viewing the links of a document.
Plain and Rich Texts
Plain Text
Plain text files may seem too simple to be truly useful. No styling. No images. Nothing but text. But the reality is these simple files are underlying a lot of your daily experience. From the HTML code instructing your browser how to display a web site, to the code DEVONthink is written in, plain text is very powerful. DEVONthink supports plain text files as a native, editable format.
Plain text files can be imported or created via Data > New > Plain Text.
Word processing applications brought us text with flair. Need some bold and italic text? How about adding a photo to the page? And color? These applications were providing it all. But their formats are proprietary so if you don't have the creator application, you can't open the file or you'll have to convert it first. The rich text format provides a useful text format that supports formatted text. These files are generally cross-platform compatible and editable in many applications. DEVONthink uses the same text engine found in Apple TextEdit, so it's an easy transition if you're already familiar with it.
You can attach other documents to rich text documents simply by dragging them into the text. Technically the rich text document becomes an .rtfd package and the dragged file is saved as part of the package. Using the contextual menu, you can show an attachment's content in a Quick Look preview. Also, if you double-click an attachment, it will open in the system default application.
Rich text files can be imported or created via Data > New > Rich Text.
The navigation bar for rich text files includes the Editing Bar. Click this icon and the editing bar will appear in place of the navigation bar. The tools available here consist of:
In addition to formatting options in the Format menu and the simple controls in the editing bar, DEVONthink provides another toolbar just for rich text editing. Select Format > Show Format Bar to display a set of rich text controls under the toolbar in main or document windows. Similar to TextEdit, it provides the following options:
Note:
The built-in "mini outliner" is a nice feature of the macOS rich text editor. On any blank line in a rich text document, type ⌥⇥ Option-Tab to create a bullet point (macOS shows dashes instead of bullets). Press ↩ Return for the next item, and so on. Additional ⌥⇥ will increase the indentation; a ↩ on a blank list line will decrease it. The mini outliner uses hyphens to indicate list items by default.
Contextual menu
In addition to the contextual menu items available with text selections, rich text files also feature these specific commands:
PDFs
PDFs are a very common format, from academia and online bill payments to equipment manuals. Fortunately, they are first-class citizens can be viewed and annotated within DEVONthink. The annotation tools should be familiar and include options like arrows, text, and link annotations. While DEVONthink may not have some options found in specialized PDF applications, it is still a very capable PDF tool.
PDFs often come directly from text sources, like word processing or page layout applications. The content of these files should be indexed and searchable on import. You can also acquire PDFs from scanned documents. These files will only have a text layer if OCR is done on them.
For scanned PDFs, you can do OCR directly in DEVONthink when needed.
In the Tools menu there are several PDF related commands, including access to Annotation tools (also found in the Navigation bar). Additionally, there are commands for changing the display, e.g., single to two pages, in View > PDF Display.
PDF files can be imported. They can also be created by capturing web content, directly in DEVONthink or via our browser extension, Clip to DEVONthink. You can also use the PDF Service Save PDF to DEVONthink 3 in the PDF dropdown of the print dialogs of most macOS applications. This will print a paginated PDF to your database.
Inspector Panes: There are two inspector panes with information specifically pertaining to PDF documents: the Content Inspector and the Document Inspector. The Content Inspector allows you to see a list of thumbnails or an available table of contents. When this inspector displays the thumbnails, Tools > Split Document and the same contextual menu command becomes available to split the PDF before the current page. The Document Inspector gives you a view of PDF metadata, e.g., keywords, a list of annotations, and a list of links detected in the document. Please refer to the Inspectors chapter for more specifics.
Navigation Bar
In the navigation bar for PDFs, the number of pages in the document is displayed. Clicking on this navigation bar item opens a Go to page function so you can quickly jump to a specific page. In addition, there are options to move to the first, previous, next, or last page.
Editing Bar and Annotations
The navigation bar for PDF files includes the Editing Bar, providing access to editing and annotation tools. Click this and the editing bar will replace the navigation bar. The tools available here consist of:
The annotation tools in the editing bar are also available in the Tools > Annotate menu.
Contextual menu
In addition to many common contextual menu items there are also a few PDF-specific options:
Markdown Documents
Markdown is a simple formatting language invented by John Gruber that has gained in popularity over the past few years. It allows you to write in plain text, using some easily learned control characters, to produce nicely rendered HTML output. With some styling and ingenuity, you can create a wide variety of documents.
Markdown files can be imported or created via Data > New > Markdown text.
Writing Markdown is essentially the same as writing plain text documents. As you're writing you can switch easily between a plain text editor and the rendered view or even view both simultaneously using the side-by-side view.
Styling: Styling your Markdown documents can be done with internal styling or externally referenced stylesheets. If you have a specific stylesheet you'd like to use globally, you can specify one in Preferences > Media > Style Sheet.. Here are the options:
Note:
If no specific styling is applied, the font choice in Preferences > Editing > Rich Text & Note Font will be used when previewing Markdown documents.
Linking: You can reference local images, scripts, and other resources using item links, downward-relative (traveling subgroups; it's not possible to travel up with '..' as documents can have multiple parents) or absolute (start with a forward slash) paths. Here are examples of linking an image:
If you have enabled automatic WikiLinks > Names & Aliases, documents can be detected as you write your Markdown. These WikiLinks are active when previewing the file and are also preserved in a website export or conversion to other formats.
Drag and drop items into a Markdown document to add the appropriate links. Drag and drop documents while holding ⌘-⌥ will create a URL with an item link. Dropping an image with create a properly formatted Markdown image link. Drop .mp3 or .mp4 files to insert a playable multimedia link.
Another option for inserting links into Markdown documents, Control-click while editing and choose Insert Link To from the contextual menu. A Markdown formatted link will be automatically inserted for you. For images, just add an exclamation point before the link if you want it to display in the rendered document.
You can learn more about Markdown and its syntax on Gruber's Markdown pages or the MultiMarkdown syntax guide.
Metadata: One of the features of MultiMarkdown is metadata headers. These allow you to add non-displaying information about the document, like authors, dates, and even linked stylesheets. To use the feature, format the first line of the document with a colon, e.g., Author: DEVONtechnologies. This must be the first line of the document. Other metadata fields you wish to add must follow immediately after this first line.
However, if you would like the first line of your document to contain a colon, perhaps adding notes like Developer: A. Edwards and Re: OCR, just add a single blank line at the top of the document and the subsequent lines will be treated as normal paragraphs.
Emoji: For a little extra personalization, you can type Slack-style emoji, like :grinning:, directly in the Markdown document.
Note:
DEVONthink supports many features of MultiMarkdown 6, but not all of them (e.g., no file transclusion).
Navigation Bar
When working with Markdown documents, you can switch between Preview and Source modes. There also is a special icon present in the navigation bar. This switches to Side-by-Side mode, allowing you to edit and preview the current document in two side-by-side panes.
Contextual menu
In addition to the contextual menu items available with text selections in the document source, Markdown documents have a special command: Copy Section Link. This copies a link to the current document, but appends a pointer to the selected paragraph.
HTML-Based Formats
HTML-based files in DEVONthink include bookmarks, web archives, formatted notes, and RSS articles. These are formats that are viewable in web browsers and are also mobile-native.
Bookmarks
Bookmarks are exactly the same as the ones found in your web browser. With DEVONthink's ability to act as a browser, bookmarks can be a valuable part of your experience. When using File > Import > Bookmarks, you can bring your bookmarks into DEVONthink easily. Though this depends on the capability of the individual browser, you may be able to drag links directly into your database. You can also capture them with DEVONthink's browser extension, Clip to DEVONthink.
Note:
If you import your bookmarks from a browser, this is a copy operation not a sync, i.e., if you modify bookmarks in your browser, this will have no effect on DEVONthink's contents. However, you can do another import to add the new bookmarks to your database without duplicating the previous ones.
In addition to importing bookmark files, they can be created via Data > New > Bookmark. Just provide a URL and title. If you don't enter a title, DEVONthink will attempt to detect and use the page title.
Formatted Notes: allow to write simple formatted text including embedded images that can be viewed on any system with just a web browser. While the range of formatting options is smaller that that of rich text they are much more compatible to today's standards. You can find all available formatting commands in the Edit and Format menus. When creating new formatted notes, DEVONthink will use the font set in Preferences > Editing > Rich Text & Note Font. Captured or imported formatted notes, e.g., from Evernote, use the font set in Preferences > Web > Standard Font
Technically formatted notes are based on HTML, the language of the world-wide web. Images are embedded directly into the HTML code so that formatted notes are completely self-contained. The HTML code is also cleaned from unnecessary tags and an identifying meta tag is inserted that lets DEVONthink distinguish formatted notes from normal HTML pages. Form tags, e.g., for checkboxes and input fields are not removed and the status of checkboxes and form fields is retained.
Bear in mind, the underlying markup in formatted notes can't be edited in DEVONthink. However, you can open the files in a compatible external editor, if you'd like.
Note:
Since images are completely embedded in the documents, the resulting file size can grow large very quickly. Resizing images before adding them is encouraged.
HTML Files: are similar to formatted notes, but they do not preserve the state of checkboxes and form fields. You also cannot add images by dragging them into the live editing view. However, you can edit the underlying HTML code using the Source and Side-by-Side modes found in the navigation bar.
Formatted notes can be imported or created via Data > New > Formatted note. When using the Notes from Evernote or Folders & Attachments from Notes options in the File > Import menu, the imported notes are formatted notes. HTML files can be imported or created via Data > New > HTML page.
Web Archives
Web archives are a special HTML file format intended to create offline archives of individual web pages. The downloaded data preserves the look and feel of the page very closely. It is often a more useful capture option when a PDF would generate a very long page since web archives always view at the size determined by the browsing area.
They function in a similar fashion as formatted notes, so you can actually edit the captured contents and save your changes. This can be very handy for highlighting passages or removing unwanted elements, e.g., ads, in a captured web page. Also, since they are HTML files the underlying markup can be edited using the Source and Side-by-Side modes found in the navigation bar.
Note:
Web archives can be very useful with web pages using statically linked content. However, some popular and monetized sites get their contents dynamically from other sources, so the actual data is not in the underlying HTML. These pages may have missing content due to this, require an internet connection to display content, and run JavaScript. If you encounter this, a PDF may be a better archiving option.
Web archives files can't be directly made. They are the result of capturing web content, either in DEVONthink or using our browser extension.
Note:
Web archives made on macOS Mojave aren't necessarily compatible with earlier versions of macOS.
RSS feeds are special "web pages" that don't show as pages but as a stream of news articles. DEVONthink allows you to keep that news flowing directly into your databases. Supporting RSS, RDF, Atom, and JSON feeds, DEVONthink functions as a basic newsreader.
RSS feeds are treated as a special type of file that functions as a group. Feed articles are downloaded to the feed and saved in a format you specify in DEVONthink's Preferences > RSS > Feed Format. The default is Automatic and saves summary files as HTML. The styling of the HTML articles is controlled by an internal CSS stylesheet specified in Preferences > RSS > Feed Style Sheet. Other formats will get their styling from the source they're downloaded from.
Note:
When using an option other than Automatic as the feed format, DEVONthink must download the linked content and convert it to the appropriate format.
RSS feeds can be created via Data > New > Feed. Provide a URL and title. If you don't enter a title, DEVONthink will attempt to detect and use the feed's title. You will also notice a special feed in this menu: Twitter Feed. This can be used to import feed articles from a specific Twitter account.
Editing Bar
Like rich text files, editing HTML-based files (excluding bookmarks) includes the Editing Bar. Click this icon and the editing bar will appear in place of the navigation bar. The tools available here consist of:
Contextual menu
In addition to the contextual menu commands available with text selections in a document, HTML based files often include these items:
Sheets
Sheets contain text in a table and can be used to store any kind of tabular data from an address book to recording health statistics to employee timesheets. They are made up of records, defined by parameters displayed as a form or columns. For example, a simple sheet could contain a table of peoples' name, title, and department.
When you create a sheet or make changes to the sheet columns via the Column Editor, you will specify the column names and their types. An explanation of the data types can be found in the Data section of the appendix.
Sheets can be displayed as a table or a form via the View > Document Display menu or using the and
buttons in the navigation bar. The table view is similar to standard spreadsheet views. Form view is similar to the record view e.g., in FileMaker.
Use sheets like any other document. Add new rows using Tools > Sheets > Add Record, delete rows by selecting them and using Edit > Delete. Alternatively, use the contextual menu. Click a cell to edit its content, press the ⎋ Escape key to stop editing, and use the ⇥ Tab or ↩ Return keys to navigate from cell to cell. Hold the ⌘ Command key to activate a link in a cell.
If you import tab or comma-delimited files, e.g., CSV or TSV files, they will be imported and displayed as sheets. Sheets can also be created via Data > New > Sheet. You will just need to provide starting column headings, which you can certainly add or take away from later.
Navigation Bar
The Navigation bar displays the current record and the total number of records in the sheet. Clicking on this information opens a Go to record function so you can quickly jump to a specific record in the sheet. In addition, there are options to go to the first, previous, next, or last records.
Editing Bar
To make working with sheets even more efficient, DEVONthink includes the editing bar with some basic tools:
In Text Alternative, there is one more option in the editing bar: Delete Selected Column allows you to delete a column. Just click on the column header you want to delete, then this option is enabled.
Contextual menu
There are a few sheet-specific contextual menu items available when you're Control-clicking in a sheet.
Note:
Despite any visual or behavior similarities with Microsoft Excel, sheets are not spreadsheets and therefore do not provide functions and formulae.
Images, Audio, and Video
DEVONthink uses macOS core technologies to display images and videos, and also play audio. Interacting with images uses the same controls you are used to, like pinch to zoom in and out, two-finger tap to zoom to width, and even two-finger rotation in 90 degree increments. Audio and video files display the familiar macOS controls.
Images, audio, and video files can be imported. Also in DEVONthink's Sorter you can capture the screen to an image, as well as record audio and video notes.
When working with images, double-clicking opens an edit panel with three tabs. The Adjust tab allows you to do some basic image editing, like adjust exposure, saturation, adding a sepia tone, etc. The Effects tab provides some simple pre-defined image effects. The Details tab displays metadata about the image, including EXIF metadata and a map of the geolocated origin of the file.
Navigation Bar
For audio and video files, there is a special option available in the navigation bar: the playback time. This displays the current time of playback (audio and video only). Also, if you click the time it shows a Go to time function so you can quickly jump to another time in the playback.
Contextual menu
There are a few media-specific contextual menu items available, excluding common ones related to magnifying the image. In addition to the standard controls, e.g., volume, playback position, etc., some of the same contextual menu options are found in the action menu for these files.
Note:
Edits to or copying an image via contextual menu items produces an uncompressed TIFF file. These files can be quite sizable, but are also saved in a lossless format.
Office Documents, Email, and Others
DEVONthink is the central hub for many environments, from home to office, and you are likely using several other applications along side it. As often mentioned, DEVONthink supports importing many file types; some editable, some not. If a format is text-based, like XML files, they may be directly editable. But even if a file is not editable, it may be searchable. This section is obviously not exhaustive in what kind of files can be added to DEVONthink, but if you have a format we haven't discussed, the easiest thing to do is just try importing it. Any failures will be reported in Window > Log.
EPUB
EPUB files (.epub)are popular format, commonly used for digital books (including our manual). While they can't be edited in DEVONthink, their contents are fully indexed and searchable, making them a viable resource in your databases.
Office Documents
Word processing, spreadsheet, and presentation applications are common in many situations. When using the proprietary formats from these applications, like Microsoft Word documents (.doc, .docx) instead of rich text files, these formats aren't directly editable in DEVONthink. However, it does support importing and indexing these particular document types:
These formats can only be imported, however it is possible to add template files of these formats. For example, you may have a boilerplate Pages document you often use. This could be added as a template to quickly add to your database, then opened and edited in Pages. See the appendix for a bit more information.
Imported email messages have their contents indexed (excluding the contents of attachments). This makes them searchable and a valuable asset, whether you're archiving email for personal or professional reasons.
Text and Best Alternative
For some document formats, e.g., email messages or Word documents, DEVONthink only allows you to select and copy text in the Text Alternative view. If DEVONthink is able to interpret and convert the document format, you can use the and
buttons in the navigation bar to switch between a view that allows you to select, copy, and drag text or the Quick Look view showing a more "accurate" view of a file.
Also note you will have text-related contextual menu items available when you can make text selections in the Text Alternative view of a file.
Note:
For uneditable formats, DEVONthink uses Quick Look to display the file, provided an appropriate Quick Look plugin or application providing one is installed. If a document you want to view in DEVONthink does not show a Quick Look preview, you may need to contact the maker of the source application and ask them to add Quick Look support.
Contextual Menu Items
Contextual menu items aren't available in Quick Look views, e.g., Control-clicking in a PowerPoint file. Also, when using the Text Alternative mode for these files, some but not all contextual items related to text selections are available. [Read more...]
Linked Files
On occasion we get an inquiry about importing files with linked assets, like Adobe Illustrator or InDesign files. While it's certainly possible to import these, the links will be broken if you try to import a folder structure containing the links. Groups in DEVONthink do not exist in the file system, so the groups that are created when you import a folder structure from the Finder don't exist as real folders in the database. The files inside the folders are imported into the internal structure of the database, so their paths are not pointing to the groups in the database.
If you want to include these kinds of files in your databases, you could keep the linked files external and only import the documents. You could also index the complete folder structure containing your files into the database, leaving them where they are in the Finder. Since the paths aren't changing, the links would be preserved when you open the documents.
In & Out
DEVONthink is not an island. It integrates with the rest of your Mac and iOS devices in a variety of ways to make it easy for you to add data to DEVONthink. There are even some options that allow you to share your data with friends and colleagues.
Importing & Indexing
When it comes to getting data into your databases, there are two fundamental methods to consider: importing and indexing.
Import
Importing copies files into the internal structure of the database. This creates a portable, self-contained database that can be moved as a single file. This is the default behavior of DEVONthink.
When you drag-and-drop files or choose File > Import > Files and Folders, files are copied. This does leave the originals in the Finder, which you can choose to keep or delete. But note there is no connection between the files any longer. Editing the file in the Finder after importing has no effect on the file in the database, as the database has a copy of it. If you want to access and edit the files, do so from inside DEVONthink.
If you hold the ⌘ Command key when you drag into DEVONthink, the file will be moved, not copied, into the database. If you are using File > Import > Files and Folders, you can click the Options button and enable Move Originals to Trash.
Creates links to files outside the database. This allows more direct access to the files in the Finder by other applications or people. A common example is people using a cloud service like Dropbox and indexing folders in the local Dropbox folders. DEVONthink indexes the content and metadata for use with classification and other content-related functions, just as it does with imported items. Do note while indexing doesn't copy the contents of the files, the full text of text-based is stored. This can still take up a considerable amount of space.
Finder files and folders can be indexed using File > Index. You can also hold ⌥⌘ while dragging and dropping into your database. When you do, you will see a curved arrow on the cursor while dragging, indicating the items will be indexed. Indexed items with have a small square Finder icon to the right of the item's name.
Indexing and the Filesystem
Indexing is not the default option for getting files into your databases. This is not only because importing creates a singular, portable database, but also due to some technical things that must be considered when indexing. Here are a few behaviors you should know and understand before indexing.
With indexing, the integration with the filesystem is very tight. When you rename a file in DEVONthink, the file's name changes in the Finder. If you rename in the Finder, the change should be automatically reflected in the database. DEVONthink tries to keep the group in the database and the folder in the Finder in the same state.
When indexing items into DEVONthink, you can index a file, an individual folder, or a parent folder, i.e., one containing subfolders. In the image shown, the "DEVONtechnologies" folder is the parent folder and could be indexed with all its contents included. You could also index an individual folder, e.g., the "Data" folder, which would be treated as a parent folder for its contents. And you could also index individual files within or outside of any folders. Each of these options has specific behaviors you should be aware of, covered below.
Moving Indexed Items: DEVONthink stores individually indexed items by its absolute path in the filesystem. If you move an individually indexed file or folder, it will disappear when the database updates or be reported as missing. This is because the item no longer exists in the indexed location, so the absolute path points to nothing. If you move a file or subfolder inside an indexed parent group, the change should be reflected in the database or the Finder. The parent folder still exists in the same location and DEVONthink can adjust for the changed relative paths within it.
Deleting Indexed Items: When deleting indexed items, you will see one of two warnings when you empty the database's trash, depending on how you've indexed the item. With individually indexed files, an indexed folder, or a parent folder, you will see a warning prompting you to choose whether to delete the item from the filesystem or just the reference in the database. In this instance, DEVONthink is prompting you to make sure you aware of the potential removal of a top level indexed item.
If you delete a subgroup or a file in an indexed group and empty the database's trash, you will be shown the standard trash warning shown here. If you accept this, the item will be moved to the system Trash from its location in the Finder. In this situation, DEVONthink is modifying the content of the indexed parent to ensure both the Finder and database's contents match.
Duplicating Indexed Items: When you duplicate an indexed item, the behavior depends on if you're duplicating with a database or across databases. if you duplicate the item in the same database, a copy will be created in the Finder in anticipation of potential changes. If you duplicate the item into another database, no copy will be created in the Finder. However, changes made to the item - in either database - will affect both databases as the indexed item is pointing at the same item in the Finder.
Note:
While you cannot replicate files across database, the duplication of an indexed file across databases can provide you with a similar behavior. However, the files will not be marked as duplicates since duplicates are not detected across databases.
Replicating Indexed Files: Replicating indexed files within a database, individually or within parent folders, has no effect on the files in the Finder. Replicating only adds a record of another instance of the file. However, if you delete a replicant of an indexed file and empty the database's trash, this will have no effect on the files in the Finder. They will remain intact.
Indexing Cloud-synced Folders: One of the common uses of indexing is to keep a local folder in a cloud-synced location, e.g., Dropbox, and have access to the files within DEVONthink. While this is certainly supported, be aware that changes made to the local folder, especially when the cloud service syncs changes to the local folder, the changes may not always be detected by DEVONthink. In that instance, you can manually update the indexed group by selecting and hoisting it via the disclosure triangle or choosing the File > Update Indexed Items command. Also, you should only index local data, e.g., on the local hard drive or connected drives. DEVONthink doesn't support indexing data that resides only in the cloud.
Lastly, if you are indexing content and want to sync the databases between devices, please review the Indexing and Sync section.
Due to the flexibility of DEVONthink, it's possible to have a database containing both imported and indexed files.
Note:
While DEVONthink can handle large amounts of data, it is inadvisable to import or index uncurated data, like entire hard drives or your Home directory. You should be judicious in what you put into your databases.
Drag & Drop
The Mac has always been an an environment with rich drag-and-drop support. DEVONthink is a well-behaved citizen in this regard. Here are some ideas:
In
The easiest way to add data to DEVONthink, other than creating the documents directly inside the application, is to drag files or selected data, e.g., text, images, etc., into a DEVONthink window.
Note:
With the last two options, you may be able to drag-and-drop content between files.
Out
DEVONthink isn't just a receiver; it also allows drag-and-drop of its files too.
Inside
And obviously DEVONthink allows dragging database items inside itself for reorganization.
Sorter
The Sorter is a multi-purpose utility built into DEVONthink providing options for adding files and creating various types of notes. When enabled in Preferences > Sorter, it is found in the menubar at the top of your screen — displayed as DEVONthink or the nautilus icon — or docked to the side of your window. Details about the views and controls of the Sorter are covered in the Sorter section of the Windows chapter.
The first view of the Sorter is the Navigation view. Access your favorites, or browse and search for groups in the open databases. Double-clicking a found group will open it in a new DEVONthink window. Drag and drop files on the Sorter to quickly file them in a favorited group, an inbox, or a location you've found in a search. When docked, the Sorter will lock open during a search so you can easily drop files into the desired location.
The Sorter's other views allow for quick and easy note creation. It supports these note types:
The Sorter allows you to clip web content as well. It also functions as the interface to the Clip to DEVONthink browser extension.
All these methods give you the option of capturing the content in a variety of formats, with or without extra metadata, directly into your DEVONthink databases.
Archiving Email
Email is an important item in many situations, both professional and personal. DEVONthink allows you to import email messages directly from supported email applications. It also allows you to import UNIX mailboxes (.mbox files) that can be exported from some other email clients.
Beyond dragging and dropping emails from an email client, you can select the View > Import command to show the Import sidebar. DEVONthink currently supports the following email applications:
The imported email messages are saved in their original file format (.eml) and are displayed using QuickLook. MailTags metadata on the messages is preserved as tags. In addition, the "read" and "flagged" status of email messages are transferred from Microsoft Entourage and Microsoft Outlook independently from your settings in Preferences > Email.
DEVONthink communicates with your email application using either AppleScript or, if you are using Apple Mail, through a special plugin that implements a direct link between Mail and DEVONthink. If the plugin is not automatically installed select DEVONthink > Install Add-Ons to install it.
In addition to speeding up the transfer of email messages from Apple Mail to DEVONthink, the plugin adds an Add to DEVONthink 3 command to the Mailbox and Message menus of Apple Mail. This allows you to directly archive selected messages or mailboxes to your DEVONthink database while inside Mail. When accessing a supported mail application via AppleScript, automatic fetching of new mail is disabled. This does not happen when you use Apple Mail with the DEVONthink plugin installed.
Note:
We highly recommend you install the Apple Mail plugin as the AppleScript implementation in Apple Mail is slow. Also, due to limitations in the AppleScript interface of Mail it's not possible to archive complete conversations from Apple Mail without the plugin installed.
Import or Archive
When it comes to archiving email, the question arises: "Do I use import or archive?" Here's the simple way to understand it:
Depending on the settings in Preferences > Email > Conversations, DEVONthink can attempt to import complete conversations and optionally group them.
Note:
Email threading is not an exact process. There has also been no standard defining relationships between messages for a very long time. DEVONthink will attempt to thread the conversations, but cannot guarantee all related emails will be detected.
Importing UNIX Mailboxes
UNIX mailboxes (.mbox files) exported from some email applications, e.g., Thunderbird or Postbox, can be imported into your database. There is no mailbox structure in these exported files so multiple mailboxes have to be exported and imported separately. They can be imported into DEVONthink in one of two ways:
Problems Importing or Moving Emails
Briefly discussed in the Appendix, the UUID is a value given to each item in DEVONthink. It is unique to each item and more than one item can't have the same UUID. When email messages are imported, they are given such an identifier based on metadata from the actual email. This means you can't import the same message into a database more than once, as that would result in more than one file having the same UUID. This will be shown in DEVONthink's Window > Log. It can also cause issues when moving messages between databases. If you already imported messages into a database and forgot you did, trying to move the same email into it will fail.
In Preferences > Email you can enable Previously imported will become replicants to import the messages into the same database as replicants. However, this still will not allow moving messages into databases already containing those emails.
Replying and Sending
To reply to an archived email message, Control-click it in the item list and choose Send Reply. A draft message will be composed in your default email application.
Choose Send by Email to email a selected document from the item list.
Note:
The inter-application communication capabilities of the email client you are using determine how well these two commands work. If the commands aren't producing the expected results, check with the developer about what kind of interactions they allow between applications.
Sync
Before we discuss particular details of sync methods, take a moment to check out the Preferences > Sync section. This gives you an overview of the preference pane where syncs are set up. Additionally, you will find a short glossary of sync-related terminology in the Appendix.
Sync Simplified
Sync is an incredibly simple concept. You have a database on one machine. You want that database on another machine. From the machine with the database, you upload the database to a sync location accessible from both machines. On the machine without the database, you'd access the same sync location and import the database. This way, every device, Mac or mobile, has a local copy of a database. Changes are made locally then synced through the sync location to the connected devices.
The only variations are:
What is a sync store?: A sync store is a folder on a server or service (the 'sync location') that DEVONthink uses to keep syncable copies of databases. Sync stores can contain multiple databases. Some people use one sync store for all databases. Some use one store per database. Some use one store for a group of databases, and another store for another group. It's up to you and your specific use case.
What is a 'copy of the database'?: One detail to understand about syncing: Only true copies of a database will sync together. Two databases having the same name but created independently are not the same database. These databases will never sync together. This is also why you shouldn't create a database on the receiving machine, hoping to "fill it up" with data from the source database.
If you copy the database (.dtBase2 file) between machines, that is clearly a true copy of the database. Also, importing a database via sync logically yields a true copy of the database. True copies are databases that have the same internal identifier (UUID).
Security: Regarding the privacy of your synced data, all sync methods allow you to specify an optional (but recommended) encryption key for a sync location. This key is used to "scramble" or "descramble" the sync data using AES-256 encryption and the data is stored in an encrypted state. All databases synced to this location will sync encrypted data. Note you must use the same encryption key when setting up the same sync location on other devices running DEVONthink or DEVONthink To Go.
Note:
Bonjour syncs don't allow you to explicitly specify a key, but the sync data is encrypted by default.
Sync pattern: That's it. Every sync is conceptually the same. The differences you find are the requirements of the particular sync method, e.g., Dropbox, and are covered below. Bonjour and local sync stores show a few more specific (but simple) steps, but they all follow the same essential pattern:
Often people index content from the local repository of a cloud service like Dropbox. The question then arises: "If I have my data on Dropbox' servers and I sync to Dropbox via DEVONthink, aren't I just using twice the space?" The answer is practically, yes. In the Show Info for a sync location in Preferences > Sync there is an option Synchronize contents of indexed items. Unchecking this will sync only the metadata for the files, not the contents. However, you should only disable this option if:
For the most flexibility, it is advisable to ensure you have enough storage space for syncing.
Bonjour (also called a direct connection) is technology you are almost certainly already acquainted with. If you have a wireless printer or scanner and notice how your Macs and mobile devices can see those devices by name with no setup by you, they are using Bonjour. Bonjour is a way for devices, or services like DEVONthink's sync, to broadcast its presence on a network without requiring technical know-how by the user.
When it comes to syncing, a Bonjour sync deals directly between devices. One device acts as a server, the other a client to that server. The participating devices must be on, running DEVONthink or DEVONthink To Go, and on the same network. There is no intermediary location where data is stored. This is much faster than uploading all data to some server on the internet and downloading it again on another device. But, when you leave your office and you haven't synchronized your databases, you'll need to wait until you come back another day.
Note:
Bonjour does not function over VPNs. This is a technical limitation of the technology, not DEVONthink.
Bonjour Setup:
The Mac with Bonjour enabled should now be visible as a sync location to other devices on your local network. On the other devices, enable it, enter the password, and you can import databases or sync existing databases directly with it.
Note:
You should never use more than one device as a Bonjour server for a given database.
A local sync store is a specialized folder containing sync data on your local machine or connected drives and servers. This is a very fast and reliable sync method for Mac-to-Mac syncing. You can use one sync store to sync multiple databases or create more than one, e.g., one for a particular group of databases.
Setup a new local Sync store:
Setup an existing local sync store:
Note:
Due to technical limitations, a local sync store currently cannot be used for Mac-to-mobile syncing. iOS doesn't have the ability to mount file servers.
iCloud
As most Apple devices are logged into your Apple ID, iCloud is the simplest method to set up and sync with. Since it's logged into your personal account, it can only be used for syncing with your own devices. If you want to keep your databases in sync but not share them with others this is a great choice. We strongly recommend an iCloud plan with enough storage. Here are the simple instructions to set it up.
iCloud Setup:
One thing to realize with iCloud syncing, the sync is done locally. After sync is finished, iCloud uploads to Apple's servers, then to devices using your Apple ID. This means databases may not be immediately available to sync on the other devices. The initial sync requires patience, as DEVONthink has no control over the speed and reliability of iCloud's process. It syncs to the iCloud folder, iCloud does the rest.
Dropbox
If you have a Dropbox account you can use it just like you'd use WebDAV. DEVONthink creates a private folder for its sync stores and so keeps its data separate from your photos and other documents. Of course it does not get access to anything except its own files. Dropbox and DEVONtechnologies respect your privacy.
The setup for a Dropbox sync location is essentially the same as for iCloud. However, there are two differences of which to take note:
If you are using a Dropbox sync and also the Dropbox application, it is advisable to exclude the DEVONthink Packet Sync folder inside the Apps folder from being synchronized with your Mac. This keeps the Dropbox app from wasting valuable disk space and bandwidth by re-downloading all changes you've made to your databases, and from spamming you with notifications.
Note:
Due to Dropbox' API restrictions, you cannot sync between Dropbox accounts, .e.g., between yours and a colleague's account. Also it is not possible to connect DEVONthink to more than one Dropbox account at a time.
WebDAV
If you run your own WebDAV server, your ISP offers it as a service, or you have subscribed to an online service such as CloudMe, this might be for you. Generally, if you can access the WebDAV server with Go > Connect to Server in the Finder, you should be able to connect DEVONthink to it.
Your data is stored in encrypted sync stores on the server. You can keep all your devices in sync at any time as long as you have internet access.
Setting up a WebDAV connection follows the same simple pattern and allows you to specify a sync store name. But there are a few parameters that must be entered to make the connection:
Note:
A typical complete path would be similar to: https://myWebDAV.com/WebDAVvolume/WebDAVFolder. The volume and folder are generally case-sensitive. Specifying a WebDAV folder may be required if the server doesn't allow you to write to the root of the volume. Check with the manufacturer or provider.
CloudMe: A European cloud service offering WebDAV services, there is a built-in template for syncing with it. Just enter the username and password you use to log into the service, enter a store name, and DEVONthink with connect with a proper WebDAV URL for you.
Other cloud services: If you are interested in other cloud services to sync with, services offering WebDAV connections should be supported. Check the FAQ or Support pages to see if it's supported.
Rolling your own: It is possible to run a WebDAV server on your own. Some NAS drives, e.g., Synology, have WebDAV capabilities and you can run a WebDAV server by repurposing an older Mac. Even some more full-featured packages like OwnCloud or NextCloud can be set up for WebDAV services. However, these options can provide more technical challenges in setup and administration beyond the scope of our support.
Note:
With Dropbox and WebDAV connections, if you are connecting to a location you've already synced to, a list of existing sync stores is displayed in the Sync Store Name dropdown. This way you can quickly add the proper sync store instead of trying to remember the exact name you gave it.
Q & A
I'll just put my databases in (name your cloud service): This is not data-safe and never has been. The mechanisms used by cloud services are not compatible with package files, like our databases. Due to the number of broken databases we've seen over the years, DEVONthink will neither sync nor open databases stored in these locations. We suggest keeping them in a folder in your home folder, like ~/Databases.
I want to access my databases from one location: Along with the previous note, this is not possible. Databases are stored locally and must be imported to the current machine.
I want to find my files in the sync location: Your databases do not "live in the cloud". Sync does not copy your databases and files into any sync location. It transmits raw, chunked, and optionally encrypted DEVONthink-specific data, only useful to DEVONthink and DEVONthink To Go. You cannot go into a sync location and retrieve a specific file, and neither could anyone else, friend or foe.
Should I use one sync store per database: This is either a personal choice or a requirement of your specific situation. A sync location can be used with one, several, or all databases. However, if you'd like to use one sync store per database, it may lessen the time in troubleshooting in case of a sync issue. In situations where you need to sync certain databases to certain individuals, you can use one sync store for each subset of databases.
I want to sync a database with multiple sync locations.: While using a Bonjour or a local sync store sync as a secondary option should work, this is not suggested generally when using a remote sync option like iCloud or Dropbox. Multiple sync stores are best used only for different databases and/or different devices, e.g., to synchronize specific databases via one sync store for personal use and sync others via a second sync store for business purposes. Otherwise unnecessary duplicates might be caused, especially if the Conflicts setting in sync preferences is set to Duplicate documents. Each sync location is updated independently so changes may not be received on one before it syncs. Also, syncing a database to multiple remote locations can waste space and bandwidth.
Troubleshooting
Generally, syncing is a transparent and reliable process. However, poor network conditions, unreliable servers, etc. may cause unexpected issues. Please refer to the Sync section of the Troubleshooting chapter for some possible fixes.
Capturing Paper (Image Capture)
DEVONthink comes with built-in support for Image Capture compliant scanners, as well as for the Fujitsu ScanSnap.
OCR: DEVONthink optionally makes scanned documents searchable by using optical character recognition (OCR). OCR adds an invisible text layer to the scanned file that is computer-readable and searchable; a layer that is recognized by DEVONthink's AI engine. OCR on scans is generally enabled by default. For best results we recommend scanning at 200 dpi in color and with 100 percent quality.
Note:
If you are using a Fujitsu ScanSnap, see the next section.
To capture paper using an Image Capture compliant scanner open the Import sidebar using View > Import or selecting the icon over the sidebar. It is divided into a sidebar and a main pane, which changes depending on your selection in the sidebar. The options in the sidebar are arranged from top to bottom according to a typical scan workflow: Scan, check the scanned pages, arrange the pages in a document, and save them to the database.
If you are using a scanner with an automatic document feeder (ADF), you can also use a Queue to prepare a pile of sheets for batch processing and scan them in one go.
Devices
Select your connected scanner or camera in the Devices section of the sidebar to run a scan or download images from a connected iOS device or camera. The main pane shows an interface similar to what Apple Image Capture uses.
Choose the scan destination in the To pop-up menu. Either send the scan directly to any of your databases, add them as single files to the Imports section, or choose any binder that you have created there.
Scanners: DEVONthink generates an overview scan of the current page in the scanner, and allows you to select which parts of the page you want to capture and set the scan options. Click Scan to capture the page.
Cameras: DEVONthink shows the available images. Select the images you want to import, rotate them if necessary, and click Download or Download All to download the images to your computer. You can also delete images from your camera with the Delete button.
The Imports section contains scanned pages or binders of collected scans. Create empty binders here to which you add your scanned pages. Alternatively, use the Create new Binder button at the bottom of the sidebar.
Add pages by dragging them from to the desired binder, in the current view or the sidebar. Rearrange added pages if desired and set the document properties by clicking the Properties button. Use the Sort button to reverse the sort order or shuffle pages, e.g., when scanning all front pages first, then the back pages. Choose Sort and Merge Documents to merge two documents where one contains all the odd pages and the other all even pages.
Note:
You cannot save multi-page documents as images; therefore, PDF is the only option for the file type here.
Trash
This is where you find images that you have deleted from Scans & Images or Imports. Empty the trash using the Empty button at the bottom of the window or right-click or Control-click images to add them to an existing or new document using the contextual menu.
If you are using a document scanner with automatic document feeder, you can use the queue to add multiple pages or even multi-page documents to the feeder and scan them in one go.
Choose your scanner in the pop-up menu above the list. Then use the Add and Delete buttons to add or delete steps and rearrange them by dragging. Edit the fields to set a title or tags, or to change the document type or destination. Check OCR to convert a scan to a searchable PDF after import.
To scan a batch of paper, set the Separator either to Page Count and the number of pages in the document or to Blank Page to begin a new document every time a blank page is encountered.
Before starting the batch run, adjust your scan settings by clicking the Configure button. If you want to convert the scans to searchable PDFs, you should choose a resolution of minimum 300 dpi. Then click the Start button to start scanning. Finished steps are marked as "Sent". To remove finished items from the list, select the ones to remove and press the minus button at the bottom of the window. Alternatively, click the dropdown button and choose Remove Sent or Remove All.
Capturing Paper (Other Options)
DEVONthink works with the Fujitsu ScanSnap, ExactCode ExactScan, and other scanners that are not directly supported.
In addition, you can add already scanned pages to your DEVONthink database and manually convert them to searchable PDFs.
DEVONthink recognizes scans sent to it from the Fujitsu ScanSnap Home application or the older ScanSnap Manager software. To send scans automatically to your databases, simply add DEVONthink to ScanSnap Home or ScanSnap Manager as the application to use for opening completed scans. The scanner app will send the created PDFs to DEVONthink which in turn will import the document.
ScanSnap's scanning software can provide already OCR'd PDFs. However, if you don't enable this option, DEVONthink can perform the OCR on the incoming scans if you've enabled Preferences > OCR > Convert Incoming Scans.
Using an Unsupported Scanner
You can also capture paper using an unsupported scanner and import the finished scans into DEVONthink. To do this, use the scan application that came with your scanner or a third-party scan application. Check the scan application's preferences and look out for an option that allows you to open the finished scan with another application, e.g., an image editor. Change the default application for the scan to DEVONthink.
DEVONthink knows the identifiers of many scan applications and will convert the incoming scan to a searchable PDF if possible. If DEVONthink does not recognize your scan application, please create a Zip archive of the application and send it to us so that we can add its identifier to a future release of DEVONthink.
Note:
In the settings for the scanning application you're using, it is best to leave the default location for the output path, often ~/Pictures. Do not set the path to DEVONthink's Global Inbox, as this can lead to errors when DEVONthink tries to import a scan that is not completed yet.
Importing Existing Files with OCR
If you already have an archive of documents that have been scanned without OCR, or if you cannot use the capture function for whatever reason, you can import image files while applying OCR.
To import an image file while applying OCR, choose File > Import > Image with OCR. Click the Options button to choose the output format and whether to send the original to the system trash after importing. The image will be processed with DEVONthink's OCR engine and be imported to the database in the format chosen. If you have enabled Searchable PDF: Set metadata after text recognition in the OCR preferences, DEVONthink will show the metadata entry window when the OCR process is completed (before the file is actually imported to the database).
The date of the created document is set to the date of the original file. Thus, for archival purposes, the searchable document is identical to the original one. The modification date is set to the current date and time to reflect the addition of the searchable text layer. If you're importing a PDF, any keywords in the original file are retained and used as tags.
Extensions and Bookmarklets
DEVONthink provides a sharing extension (requires OS X Yosemite or later), a web browser extension, as well as bookmarklets, for conveniently clipping information from other applications into your DEVONthink database.
Sharing Extensions
Sharing extensions let you "share" data with other applications or web services such as Twitter and Facebook. Extensions are mainly intended for the sandboxed App Store environment where applications can no longer easily communicate with each other. When you access the Share menu in a compatible application, you should see an option, Add to DEVONthink that allows you to send data from the application to DEVONthink.
Installation: Just as other sharing extensions are installed, open System Preferences > Extensions > Share Menu and enable the option for DEVONthink. It should now be available in any sharing-enabled application's Share menu.
Note:
The data being sent is controlled by the sending application, not DEVONthink. If there are issues with the data received in your database, please contact the developer of the application to report your findings.
Browser extensions add functionality to your favorite web browser. DEVONthink's Clip to DEVONthink extension usually appears as a nautilus icon in the web browser's toolbar. When clicked, the Clip to DEVONthink will identify data about the current page in the browser and open the Web Clip section of the Sorter. Here you can simply select the location to clip the content or add optional metadata, like tags, label color, etc.
Installing: The Clip to DEVONthink for Safari extension is installed by DEVONthink by default. The extensions for Firefox and Chrome can be installed from our Extras download page. You can also access these pages via the DEVONthink > Install Add-Ons panel.
Note:
While there is no direct support for other browsers, some allow you to install Chrome extensions. This may allow you to install our browser extension in those browsers as well.
Bookmarklets
Similar in function to a browser extension, but much simpler, bookmarklets are special bookmarks that execute some JavaScript to capture the current page or selection in the browser. To use one of the bookmarklets, load the page you wish to archive or clip text from in your web browser. When the page is fully shown, select the bookmarklet in your bookmarks bar. Instead of loading another page as normal bookmarks do, the bookmarklet adds the selected text or the whole page as text, bookmark, HTML code, web archive, or PDF to DEVONthink's default destination.
Installing: Bookmarklets can be installed from our Extras download page. Typically, the bookmarklet can just be dragged and dropped to the browser's bookmarks toolbar. However, you may need to Control-click the bookmarklet and copy the code to add it manually, if the browser requires it. We have provided separate bookmarklets, one for each type, currently supporting capturing: bookmark, web archive, HTML, PDF (paginated or single page), plain text, or the selection as plain text.
Note:
Due to increased security in macOS, Apple Safari will prompt you to allow launching DEVONthink when using the browser extension or bookmarklets. Other browsers allow you to make a persistent choice about this behavior.
Web sharing
DEVONthink allows you to give others on the local network access to your databases using a standard web browser on any operating system (including Windows and Linux). The embedded web server provides an interactive web interface that allows defined users to interact with the shared databases. Here are the first steps to getting started using this powerful feature.
Securing Your Shared Databases
Before you start sharing your data it's a good idea to check the security settings.
To enhance the security for the databases you broadcast, you define users and give them per-database permissions. You will also set a certificate for the server, so the connecting users can validate they are connecting to a safe server. These items are set in Preferences > Server. Users will only be able to interact with the databases based on the permissions you give them, including disallowing them even to see certain databases.
Note:
Depending on the certificate settings specified in the preferences, a warning about an invalid certificate may be shown when users access the web sharing. This is especially true when using a self-signed certificate. While this warning is something to be suspicious of when browsing in general, you and your users can accept it in this case.
Sharing a Database
Start and stop the server: Once the certificate and users have been set up to your liking, press the Start button to start the server. You can also select the Tools > Start Server command or choose the Start Server option in DEVONthink's dock icon. If the server is running, these will display Stop instead.
Share your server's address: Once the web server is started, you will see links at the bottom of the preference pane. These are the active links you will share to individuals you have defined as users. One option is to Control-click the link, select Share from the contextual menu, and share it via your preferred method. You can also use Copy Link and paste it where you need to. Lastly, you can click and drag the link directly to many applications, like Apple Messages.
The person who receives your link will open the page, login with the username and mandatory password you've defined for them, and have access to the databases you want them to see. If you have specified a port in the preferences, your users may be able to add a bookmark to their browser for quick access.
Note:
We believe in data privacy and hope you do too. Browsers may present options to save login credentials. Some may even save the credentials by default. We are cautious of the first and not a fan of the second. If the user is on a shared computer, consider what access other users could have if using these options to save credentials.
Using the Web Interface
The interactive web interface imitates the look-and-feel of DEVONthink in many ways, but in a condensed form. Contrary to a static web site, it only loads once; clicking buttons or links does not reload the whole page but dynamically updates it. This also means you should use the Back and Forward controls in the user interface instead of the ones in your browser's toolbar.
Similar to the DEVONthink, the web interface is divided into panes: toolbar, sidebar, item list, and view/edit pane. But note some operations, e.g., deleting or organizing items, are dependent on the permissions you've been given for the specific databases.
Sidebar: The sidebar is where you can navigate the databases' inboxes, groups, tags, and trashes in the sidebar. You can even drag items from the item list to reorganize things.
Item List: Selecting items in the sidebar will display the contents in the item list. When using the standard preview position, the list can be sorted by clicking the column headers. There are options to enable or disable them in the contextual menu. Items can be dragged, handily for filing loose documents into groups. Double-click groups to display their contents in the item list. For quick navigation, press the < and > arrows to go back and forward to visited locations in the databases. You can also click the locations in the path bar above the item list to jump to a parent location.
View/Edit pane: Displayed below the item list or to the right, depending on the preview choice made in the toolbar, this pane will attempt to display the contents of the selected file. Clicking and dragging the divider bar allows you to resize the pane, relative to the item list. A select number of file types, e.g., plain text, formatted notes, and Markdown files can be viewed and edited in this pane. When the Info inspector is shown it will display as a pane on the right side of the view/edit pane.
Note:
Due to the limitations of browser technologies, some file types cannot be displayed.
Toolbar: Some handy options are available in the toolbar, including switching the position of the view/edit pane, adding some metadata, e.g label or rating, to a selected item, and creating groups and a few document types. It also has controls for uploading new documents and downloading currently selected ones. A user menu allows you to switch between English and German language and also provides a Log Out option for more security when allowing others access to the computer. Lastly, it gives you access to two powerful options: the See Also pane and the search field.
See Also: When you show the inspector pane, the second view is a See Also view. This displays potentially related files in the current database you are viewing.
Search: Searching the viewable databases can be done in the search field. Enter search terms, including using search prefixes to focus the searches. For example, you can do a search for text:housing tags:government. If you want to restrict where you're searching, select All Databases or a specific database to search in.
Descriptions of the controls in the user interface can be found in the Web Sharing section of the Windows chapter.
Accessing Your Data Over the Internet
Web sharing is best used on a local area network (LAN). But there may be situations where you want to share the database to users that aren't on your network. While we can't provide specific support due to the differences in equipment and environments, we have provided a simple guide you can try.
To access your database from outside your network, you need to make your Mac "visible" to the outside world. In general, when you a using a DSL or cable modem, you are also using a router. Routers create an intranet that your Mac is connected to and "route" traffic between the internet and your personal intranet. Now, you need to create a route from the outside leading to the Mac sharing your database. This offers a port on the outside that is directly connected to the port on which DEVONthink is publishing.
If everything goes well, you will be able to access your database using an address like: http://xxx.xxx.xxx.xxx:port, where xxx.xxx.xxx.xxx is your current public IP address. (Note: This is your router's address on the internet, not your Mac's.) Next, port is the outside port number leading to your published database.
Port forwarding done manually: The following is only a rough outline of the steps needed to configure port forwarding manually. The precise way to do it varies from router to router. You will need to consult the manual for your router in order to determine exactly how to set things up. To configure port forwarding, follow these steps:
Setting up port forwarding can be tricky, but the difficult part is mainly in determining how to configure your particular router. If you are in doubt, search online for your router's name and combine it with a search for "port forwarding" or "port mapping."
Services
The DEVONthink > Services menu gives you access to special commands provided either by other applications, such as TextEdit or Safari, or by services extensions such as DEVONtechnologies' WordService or CalcService. Also, DEVONthink publishes its own services in the Services menu.
DEVONthink services
DEVONthink installs several services for copying or summarizing selected text, capturing a web page, or searching for documents in your databases.
If you want to assign hotkeys to services, go to System Preferences > Keyboard > Keyboard Shortcuts > Services. Do note that application hotkeys can override hotkeys set here. Try to make sure to specify unused key combinations in your shortcuts. Also, due to the way macOS loads menus, you may need to show the DEVONthink > Services menu once before the hotkey will become active.
PDF Services
Another way to get files into DEVONthink is using PDF services. Installing DEVONthink's service adds a Save PDF to DEVONthink option to the PDF button of the print dialog in any Mac application. This allows you to print a paginated PDF directly to your database.
To install the PDF service, select DEVONthink > Install Add-ons and check PDF Services in the dialog window. Then click Install and the option should now be available.
Printing to your database: To "print" (save) a document to DEVONthink as a PDF, open it in its creator application (this could even be DEVONthink itself). Then, do the following:
Note:
This requires an installed printer to work properly.
Third-Party Applications
DEVONthink offers many standard ways to integrate with third-party apps including drag-and-drop of common data formats, copy-and-paste, and AppleScript. In addition DEVONthink comes with special arrangements for applications often used together with it.
Windows
DEVONthink uses a number of windows to present information. These windows are used for displaying and manipulating groups and documents, finding information, editing metadata, analyzing text, and changing the properties of your database.
Main Window
The main window is split into simple sections, some of which will be familiar from other applications. In fact, as we introduce the components of the window you'll see DEVONthink has many familiar elements in it. We start off with the fundamental panes you'll use.
When You launch DEVONthink you will see an empty pane at the bottom of the window reading Nothing Selected. This is the View/Edit pane, a preview pane displaying the currently selected document. This pane gives you a view of the content of compatible documents. It also allows you to work on compatible files directly in the main window when the pane is shown. Or you can hide the preview, perhaps if you want to concentrate on information about a group of documents.
You can can toggle the pane's visibility in the View > Preview menu or via a toolbar button.
Layouts:
As noted above, DEVONthink allows displaying and editing, and even creating, some file types. Please refer to the Documents chapter for more information on this and other components related to the View/Edit pane.
When you open a Finder window, you are presented with a list of files in a certain location. The view may be icons or a list, etc. but you are still just viewing the contents of a folder, hard drive, etc.
DEVONthink is no different in this respect. When you open a main window, you will see a list of groups and documents in the current location. Clicking on or opening other groups shows their contents. Smart groups, just like the Finder's smart folders, also display their contents in an item list. The item list also supports familiar operations like drag-and-drop between groups, copy and paste, group and ungroup, contextual menu items when you Control-click, etc., just as you've done in the Finder.
Views: Again, taking a cue from the Finder, the item list allows you to display your documents in some familiar views:
All these views can be easily changed in the View > View options, as well as the quartet of icons
on the right-hand side of the Information bar.
Sort: In addition to sorting the item list by clicking column headers or using the View > Sort menu, you can also choose a sort method in the Sort dropdown menu in the information bar. By default it reads by Name. Also, notice there is a Customize Metadata command in the Tools > Columns menu, the contextual menu, and this menu. Select it to fine tune what columns are available to display, including any custom sets you've created yourself.
Visual Cues: DEVONthink provides a few visual cues applied to items in an item list.
The Flag column shows the state, flagged or unflagged, or the
unread status of items. Clicking in the flag column toggles the flagged state. If an item is unread, a circle will appear in this column. If you have a group containing a mix of flagged and unflagged items, a dash will appear in this column, showing an indeterminate state.
Additionally, DEVONthink displays special icons to the right of item names for attributes like Spotlight comments, reminders, etc. A key of the item icons can be found in the Iconology section of the appendix
Contextual menu items: When you Control-click in a Finder window, a contextual menu appears with a host of commands for you to choose from. DEVONthink's item list also has a contextual menu available. The commands shown depend on what is selected and in what pane you're using. A list of the commands can be found in the Contextual Menu Items section of the appendix.
Note:
To keep visual consistency and make some functions more broadly accessible, item lists are used throughout DEVONthink's interface, so you'll see them in some other panes. But note some functions, like specific contextual menu items, may change, depending on the specific pane you're using.
Toolbar
At the top of most Mac applications you encounter, including the Finder, you will see the toolbar. For people who prefer working with tracking devices, e.g., mice, trackpads, etc., the toolbar allows you to have quick access to some functions without having to go through the menus. DEVONthink also provides a toolbar in main and document windows.
The toolbar comes pre-installed with a handy default set of buttons, including the search field (see below). It can be customized via the Tools > Customize Toolbar command. You can also Control-click the toolbar and choose this command from the contextual menu. Add, remove, and reorder these items to suit your particular needs. On a side note, if you want to quickly reorganize items on the toolbar, hold the ⌘ Command key and drag the item to its desired location, or off the toolbar to remove it.
If you're looking for a little more space for your toolbar, or even a little less, you can choose to display the toolbar as Icon and Text, Icons Only, or Text Only. Do bear in mind, the Icon Only view will not show the current document's title or icon.
A list of the available toolbar items is available in the Toolbar section of the appendix.
Seen in scores of applications for many years, a sidebar is a top level organizational structure, typically found on the left side of an application window. The Finder or Apple Mail sidebars are perfect examples of this. Looking at them, you should see the immediate similarities with DEVONthink. However, unlike most other apps, DEVONthink has multiple sidebars, each with their own special functions covered a bit later in this chapter.
Inspectors
In some applications, extra information about files is shown in a pane on the right side of a window. DEVONthink also provides such a pane in its main windows with individual sub-panes called Inspectors. For example, data about the name, tags, type, etc. of a selected file are available in the Info Inspector. Unlike other applications, it gives you multiple inspectors presenting more information and functions, all docked in the inspectors panes. This gives you quick access to all the inspectors in one unified window, especially helpful on smaller screens.
The inspectors are individually discussed in the Inspectors chapter.
Storing information is a useful thing, but it's more useful when you can find things too. DEVONthink offers a strong search function for finding items in your databases, all integrated into a main window.
In the toolbar is a search field for entering your search terms. Type in a word and the search pane appears showing any matched items — and yes, it's another item list supporting the different views and sort methods discussed above. Additionally, the View/Edit pane can be shown to display selected results. For contents-based searches, the search terms will be highlighted in the preview, whenever possible.
Search options: In the search field, you will notice a magnifying glass icon. Click this icon to see where to search, list the ten most recent search queries, one choose among the following options:
Search prefixes: Anything you type into the search field will be treated as searching in all possible attributes. However, if you want to focus on specific attributes, e.g., file types or tags, the search field supports prefix operator searches, similar to Spotlight. Common examples are searches like name:DEVON or tags:tech;sync, separating multi-valued attributes like tags with a comma. There are a wide variety of prefixes available, as well as different prefix operators. A complete list of these items is included in the Search Prefixes section of the appendix.
In addition to search prefixes, DEVONthink supports Boolean operators, parenthesis for grouping terms, and quotes to match specific terms. Read more about operators and how to use them in the Search Operators section of the appendix.
Search scopes: After you've done a search, you will also see a bar above the search results allowing you to choose the scope of the search. The scope is the "where" you're searching. You will be shown All Databases, Inboxes, the name of the current database, and the name of the current group, if you're currently viewing one. Choose one to expand or limit where DEVONthink is searching.
Advanced and save: To the right of the search scopes, you will see two buttons. Clicking the Advanced button displays the criteria of the current search. You can modify the search with the same kind of controls used in the Finder's smart folders, as well as some other applications with advanced search methods. Note these controls are also used in creating smart groups and smart rules.
If you have done a search you'd like to use again, press the Save button. Enter a name and DEVONthink will create a smart group for you. If your search scope is in a group, the smart group will be created there. If you are searching a specific database, the smart group is created in the root of the database. Searching inboxes or all databases creates a global smart group, shown in the Smart Groups section of theNavigate sidebar.
Note:
The search index contains alphanumeric characters as well as the following symbols: $€£¥%§
Path bar
On the left side of the main window, just below the toolbar, is the Path Bar. This is a specialized bar displaying a crumb trail of your current location in a database. For example, if you are in a nested group, it will show something like Coding > AppleScript > WWDC > 416, beginning with the current database.
Each item in the crumb trail is a live link, so you can click it to jump to any parent folder or back to the top level of the database. This bar also has < and > buttons so you can navigate back and forth between locations you've visited in this window. As an added feature, click and hold one of these buttons to be shown a list of previous locations you've visited, just like in a web browser.
Another specialized bar, the Information Bar displays the number of items selected and the total number of items in the current location. As mentioned previously, this bar also hosts the Sort dropdown and the
view icons.
Sidebar: Navigate
The Navigate pane is the default sidebar where you will access to your databases, tags, items located in Favorites, etc. Additionally, you have access to some specialized items: global smart groups and smart rules.
Each section in the Navigate sidebar has its own specific purpose: giving you access to frequently used files, navigating database groups, or viewing a list of similar files. The sidebar will only show databases and groups. Selecting one of these items will display its groups and files in the item list. This allows a clear view of the group structure in the sidebar, while still allowing you to interact with the contents in the item list. Alternatively, you can view the group hierarchies directly in the sidebar. Excluding smart groups and smart rules, selecting multiple items will show a union of their contents in the item list.
The sections in the Navigate sidebar can be dragged to reorganize them as desired. Sections you don't need to use as often can be collapsed to reclaim the space or to provide a bit of privacy.
By default, specific parts of databases are shown gathered in specific sections, similar to how Apple Mail displays the inboxes of all accounts in the same section.
Globals: The Globals section provides quick access to three locations common to all databases: the Inbox, Tags, and the Trash. If you click a top level section, e.g., Inboxes, you will see a combined view of items in the inboxes of all open databases. This can be especially handy if you want a view of all the tags you're using in your databases. Click the disclosure triangle next to each section to show the locations for each open database, allowing you to access the locations on an individual database level.
Inboxes: The inbox of a database, like the real-world counterpart on an office desk, is where incoming, unfiled items are kept. Every database has one by default and you can see the name of the database each inbox belongs to. The Global Inbox, shown just as Inbox, is a special, always-open database present in every installation of DEVONthink. This is highly useful when quickly capturing data, e.g., web clipping, screen captures, etc., without stopping to file things. You can then go back later and file these items at your leisure.
Tags: The Tags section provides quick access to all the tags you are using or tags within individual databases. If you click the top level tags, the item list will display all the tags you've created. Open this group and click on a database's name to show its tags. If you like to create nested or hierarchical tags, you can drag and drop existing tags in the sidebar or the item list.
Typically you will use the Tags bar in the View/Edit pane or the Info Inspector or Info popup to apply or create tags. You can also drag items in your database to the individual tags. When you create a tag it will automatically appear in the Tags group of the database you're in. If you want to create new tags to be used later, select the Tags group for the database and choose Data > New > Tag. Or from the contextual menu, Control-click the database's top level Tags group or an existing tag and select New Tag.
If you find yourself in a situation with multiple tags you'd like to merge, select the Tags group for the current database to view the tags in the item list. You can then select the tags there and choose Tools > Merge Items.
Removing entire tag groups can be done by dragging and dropping to the sidebar's trash. From the contextual menu, you can choose Move to Trash. You can delete tags in the item list as well. One thing to note: When you delete a tag, the original file in the database is preserved. What you see in the database's trash is the replicant that was created in the tag group when you added the tag.
Trash: Every database has its own individual trash. This allows you to see, and potentially retrieve, items you've deleted from your individual databases. Just as with the real-world trash bin, we do suggest you empty your databases' trash regularly. It is not meant as another filing location, and items marked as missing will still register as a problem for a database. Select the trash, the top level or individual database's trash, and choose DEVONthink > Empty Trash. The command is also available in the contextual menu, when Control-clicking a trash. Trashed files are not deleted completely from the machine but are put into the system trash.
Open Databases: This section is where you see and access any databases you have currently open. Click the database's name to display items in the root of the database. Clicking the disclosure triangle allows you to show groups, and subsequently sub-groups in the database. As mentioned above, selecting a database or group will display its subgroups and files in the item list.
Non-Unified Elements
As the unified views may be less comfortable for some people, DEVONthink allows you to decide what database elements you want to unify. Controlled by options in Preferences > General > Sidebar, you can enable or disable unifying: Inboxes, Tags, or Databases.
Inboxes: If you disable unifying the inboxes, only the Global Inbox will be shown in the Globals section. The inboxes of individual databases will be shown in the item list when the database is selected.
Tags: Similar to the inboxes, disabling this option will display the Tags group with other elements in the selected database.
Note:
With Unify Inboxes and Tags both disabled, the database's contents will appear similar to how DEVONthink 2 displayed databases.
Databases: When disabled, DEVONthink displays a database's name in the Open Databases section of the sidebar but the contents will be shown in a separate section. The current database will be marked on the left by an asterisk (*) and its groups will be shown in a separate active database section in the sidebar. This creates an isolated view of that database regardless of the number of databases that are open. Interacting with elements in the active database section displays contents in the item list, similar to the Three Pane view from DEVONthink 2.
For switching between active databases, select another database and the active database section will display only the groups and smart groups of that database. Also, there are Previous Database and Next Database commands in the Go menu.
When using the keyboard, hold the Command key and press the up and down arrows to view the contents of another open database in the item list while showing the contents of the previously active database in the active database section. Press ⇧-↩ to change the active databases section to the currently selected database.
Contextual Menu
There are a few specific contextual menu items found in these sections of the Navigate sidebar. These commands are also found in the File or Data menus:
Any section-specific contextual menu items that may require explanation are discussed in their respective sections below.
There are many times we have specific databases, groups, or documents we return to, again and again. Shown at the top of the sidebar by default, the Favorites section allows you to create shortcuts to quickly access any of these kind of items. Drag a group or a document to this section's header and you'll see a curved arrow on the cursor. Drop the file and you have a new favorite. An option to Add to Favorites is available in the contextual menu commands of most items in DEVONthink. Use Remove from Favorites when Control-clicking on already favorited items to remove them.
Select an item in Favorites to quickly access it. If an item was last viewed without a preview, it will be displayed in its own window. If you see a favorite is greyed out, it means the containing database isn't open. Double-clicking the item will open the database, if possible, and display the item.
Drag items in the section to reorder them. Groups in Favorites behave as normal groups, so you can drag items into a favorited group for quick filing. This includes using ⌥ and ⌘⌥ to duplicate or replicate items while dragging and dropping to them.
Note:
Favorites only support one level of content, so you can't group or nest items here.
The Recent Databases section provides quick access to reopen closed databases. This will list the last ten recently closed databases. Double-click any databases you'd like to open.
The global smart groups function the same as local smart groups, i.e., the ones in your individual databases, but generally their scope is all open databases. This allows you to have reusable searches targeting all your open databases, e.g., all Markdown documents in all databases created in the last month. These global smart groups can be modified to target more specific locations, but such a smart group would be better suited as a local smart group, i.e., in the particular database. DEVONthink comes with some pre-installed global smart groups:
You can create a smart group from the contextual menu or the + button at the bottom of the sidebar. By default all open databases will be targeted. However, if you have an item selected in the Globals or Open Databases sections, the smart rule will use that location for the matching.
Control-click a smart group to Edit, Rename, Duplicate, or Remove it. You can also copy a link to a smart group, export it to the Finder, or import previously exported ones. If you'd like to convert an existing smart group into a smart rule, ⌃-click the desired smart group, hold the ⌥ key, and choose Duplicate as smart rule.
If you have exported smart groups in the Finder, double-clicking them will import them. You can also drag them to the smart rules section of the sidebar.
For more information on editing smart group properties, global or local, see the Smart Group Editor section of this chapter.
Similar to smart groups, smart rules are created, edited, and behave in a similar fashion. However, they have one distinct difference: they can act on the items matched. The smart rule matches items just as a smart group does but they perform actions when certain events take place. This makes them a very powerful way to add automation to your DEVONthink life.
DEVONthink provides a few useful example smart rules to get you started:
If you Control-click a smart rule and choose Edit, you will see the criteria, event trigger, and actions for that rule. Like smart groups, you can create a smart rule from the contextual menu or the + button at the bottom of the sidebar. The target of the smart rule also follows the same behavior as a smart group: all databases are targeted unless you have an item selected in the Globals or the Open Databases section of this sidebar.
Control-click a smart rule to Edit, Rename, Duplicate, or Remove it. You can also copy a link to a smart rule, export it to the Finder, or import previously exported ones. Double-clicking exported smart rules imports them, and so does dragging them to the sidebar.
In the contextual menu for a smart rule, notice there is also a smart rule-specific command: Apply Rule. This runs the clicked command on any matching files. This means it will performs its actions, even if the event trigger is not set to On Demand. Be cautious about using this command unless you are certain you want to affect all matched items. There is also an option to copy the item link for a smart rule by choosing Copy Rule Link.
There are two commands in the Tools menu related to smart rules:
Drag and Drop: Lastly, you can drag and drop items onto smart rules to apply their actions to them. Dropped items will be acted on, ignoring the location and criteria specified in the smart rule. For example, you may have a smart rule to add the date to the beginning of the name of images imported into your Global Inbox. However, you could drag and drop a rich text file from a separate database on to the smart rule and the date would be prefixed to the name, even though the location and file type do not match the rule.
For more information on editing smart rules, see the Smart Rules section of the Automation chapter.
Sidebar: Filters
Providing yet another way to isolate files in the item list, the Filters pane allows you to only show files that share common attributes. This pane, displayed at the bottom of the Navigate sidebar an be shown or hidden via the Tools > Filter menu or the trio of icons at the bottom of the Navigate sidebar. The pane can be resized by moving the divider at the top of the pane.
Info
Displayed by selecting Tools > Filter > Info, the Info filters pane let you shows only files that share common dates, ratings, color labels, etc.
Dates: Click the Date dropdown to choose the type of date you want to filter on: Added, Created, Modified, Opened, or Due. Click on a date in the calendar display to only show files related to the day and type of date you selected. Use the small arrows to move backward and forward through time, and click the circle between them to quickly return to the last selected date.
Marks: Choose the type of mark, or a combination of them, on which you want to filter. For example, you can click the flag and a rating of 3 to show only those files. You can filter on these attributes:
File Location: Click the dropdown to choose whether to display Imported, Indexed, or both with Any.
Choosing the Tags filter via Tools > Filter > Tags displays a tag cloud derived from the tags on the current list of files. The cloud shows the tags in varying sizes depending on the number of occurrences of each tag on these documents. The more files with a given tag, the larger it displays. This makes it easy to identify commonly used tags. If there are no tags on the files in the current item list, No Tags will be displayed. Additionally, Control-click in this pane to sort the tags by Name or by Count.
To filter the files, click any tag. You will immediately see the tag cloud reduce in number and only related tags are shown. This allows you to drill down into files that share common tags, but also exposes tags that have been used with the previously selected tags.
Note:
The tags you choose will also be shown in the Information bar above the item list. Hovering over one of these tags displays aclose button at the right side of the tag. Click it to stop filtering on that tag. You can also press the Reset button to clear all filtered tags.
Control-clicking a tag in the tag cloud shows these options:
Map
Utilizing geolocation data from your files, the Maps filter shows documents related by location. Show this filter pane by selecting Tools > Filter > Maps. By default, the pins on the map show the place a document was created. However, the geolocation data can be manually changed to a relative location, like the site of a historic event. (See the Info Inspector for more information on this.)
The map functions similar to Apple or Google Maps, allowing you to use familiar pinch gestures or double-click or Option-double-click to zoom in and out, panning, etc. The map shows pins for all documents with geolocation data in the selected location in the Navigate sidebar. Selecting a pin in the map displays the files with that geolocation data in the item list.
Sidebar: Smart Group and Rule Editor
When you create or edit a smart group or smart rule, a sheet appears with options for specifying options, like the criteria to match or from where to match items.
Options
The top section of the sheet contains a mandatory name and search location, as well as a few optional items.
In the Comparison section, you will see these options:
Predicates
The second section of the editor shows the search predicates. These define criteria you want to match. Criteria may be content- or attribute-related, e.g., documents containing a specific word or groups added this week.
Note:
The predicate editor is also shown when using the Advanced options when searching your databases. It is also shown in a similar sheet when you run the Tools > Batch Process command.
The list of predicates consists of a list of blocks, each beginning with All or Any, defining whether all (Boolean AND) or any (Boolean OR) of the contained predicates need to be true for the document to be returned as a result. Predicates themselves consist of the field to search (like "Content" or "Tag"), and the condition and the data that needs to be matched.
Add as many criteria as you need. Use the + and - buttons to add more predicates to your smart group or to delete them. Predicates can be rearranged with drag-and-drop. Hold the ⌥ Option key and click a ... button to create a "compound predicate" also called "branch". Each branch also has its own All or Any option as well. This allows you to create very targeted searches.
Example:
To find all Microsoft Excel files use the condition Filename ... ends in ... xslx. To find items created in the last 7 days use the condition Date created ... is ... Last Week.
Note:
In some predicates you can use wildcards, Boolean operators, phrases, and parenthesis, too. [Read more...]
Sidebar: Reading List
Similar to the section found in Safari (and now many other browsers), the Reading List provides a place to access documents and groups you've "set aside" for later consideration. The items are listed in All and Unread views. Newly added items are displayed at the top of the list.
Add files from the item list via drag and drop when this pane is visible. Alternately, choose the Data > Add to > Reading List menu item. This command may also be available when Control-clicking in an item list or in images and PDFs.
Items added to this pane will automatically appear in the Unread view. Selecting an item with the View/Edit pane visible will treat the item as read and the item will only be shown in the All view.
Items in the Reading List can be moved to other locations by dragging them to any item list in a main window. The drag operations also allow you to duplicate or replicate the files, holding ⌥ or ⌥⌘, respectively.
Contextual menu
The contextual menu (which appears when you Control-click an item) offers these commands:
Note:
The last two options cannot be undone.
Sidebar: Image Capture
The Import sidebar pane gives you access to two common sources of external data: scanning and email. Each section in this sidebar provides controls to import from any supported scanner or a compatible email client, e.g., Apple Mail or Outlook. This makes DEVONthink a reliable companion at home, in an office, in the hands of an archivist, and many other scenarios. We will cover the scanning controls in this section. We have also provided a more practical overview in Capturing Paper section of the In & Out chapter.
Archiving documents is an important function in many situations. The Image Capture section of this sidebar allows you to control compatible scanners or import images from connected cameras or iOS devices.
Devices
The Devices section allows you to choose an input device. Choosing a scanner offers different controls and options than selecting a connected iOS device or camera.
Selected Scanner: If you select a scanner you will be presented with controls and settings to scan your documents. This allows you to use your scanner directly in DEVONthink very efficiently. This interface should be familiar to anyone using Apple's Image Capture application or scanning in Preview.
Camera or Mobile Device: Clicking on a connected camera or mobile device displays an item list of photos to import. These items can be imported for a variety of uses. Additionally, for documents you've photographed, the images can be added to a scanning document (described below) and OCR can be done to create searchable PDFs. This can be very useful for everyday things like receipts to archiving historical documents.
Queue
Select the Queue option to display the scanning queue where you can pre-define documents to scan. Define parameters for each document, including: Title, Destination, Type (PDF or Image), Separator, whether OCR is enabled, and optional Tags for the finished document. This section can be very useful when batch scanning. The following controls are shown in this view:
Imports
Containing individual scans or Binders, collections of scanned pages. Create or access existing binders and scanned pages in this section.
Select a specific binder in the sidebar to show a thumbnail view of the pages it contains. Rearrange the pages by drag-and-drop or drag pages from one document to another. Press the Sort button to use these options:
Trash
Any scans or documents you've deleted from the scanning interface will appear here. When you have this selected, empty the trash with the button at the lower right corner of the window.
Sidebar: Email
In addition to scanning, the Import pane also provides the controls to archive emails from Apple Mail and Microsoft Outlook. While you can drag email messages individually from your email client, the Email section of this sidebar also allows you to import individual messages or archive mailboxes directly into your DEVONthink database.
Open the pane pane by choosing View > Import. Here we discuss the controls used in this section. For a more practical overview of the email archiving process, check out the Archiving Email section of the In & Out chapter.
Accounts and mailboxes
The lefthand section of the Email section displays the active accounts and mailboxes of Apple Mail or Microsoft Outlook. Select your email client, then click the disclosure triangle to show the accounts then its mailboxes.
Mailbox View: When you select a mailbox in a specific account, the window will display more controls for filtering and importing messages from that mailbox. The central view shows the contents of a chosen mailbox. This is where you can select individual messages to import, if desired.
This view is separated into columns that can be sorted by clicking the column headers. The columns include From, Subject, To, the Flagged state. If you are choosing to show already imported messages, there is a special column showing those items. For emails marked as high priority, the flagged column will also show two exclamation points and the subject, etc. will show in red. Control-click in the Mailbox view to refresh its contents.
Filter and import
When a mailbox is selected, the righthand side of the window shows options for filtering the messages displayed. It also lets you choose the location where the messages will be imported.
Destination: Choose the destination for the imported messages or mailboxes.
Search: Use this search field to search for messages by the sender or recipient's Name, email address, or the subject line. Note this only allows for a single term to be used. However, the search is matching substrings, so a search for jun would match "junk", "jungle", and "jejune".
Show: Select options in this section to further fine-tune the list of importable messages, if desired. You can use:
Hide: Use these controls to hide certain items from the mailbox view. All these options are enabled by default, but can be selectively disabled, if needed. However, when these options are enabled it makes it easy to see only new messages, ready for import.
The last two items are buttons for importing selected emails in the Mailbox view or archiving the currently selected mailbox. [Read more...]
Sidebar: Extras
The Extras sidebar gives you a place to check for current information from us. It's an easy way to stay up to date with some of the goings on at DEVONtechnologies.
Support: Here you will find our recently published tips, scripts, smart rules, and templates.
If you'd like to quickly mark all items as Read, ⌃-click and select the Mark All as Read from the contextual menu.
For a view of all available scripts and templates, as well as easy installation and uninstallation, see the Support Assistant.
DEVONtechnologies: This section provides a list of blog posts regarding updates and promotions.
Note:
For the sake of transparency, DEVONthink does connect to our web server to bring you this information.
Document Window
You can isolate a document in its own window, known as a document window. These windows are convenient for split screen work. For any editable file formats, you can open a document window by double-clicking a document in any view of a main window. Alternately, you can choose Data > Open or Open from the contextual menu to open any document in a document window. For most file types that can't be edited directly in DEVONthink, double-clicking the file will open it in the system default application. For example, double-clicking a Word file will open it in the same application that opens if you had opened the file in the Finder.
See the Documents chapter for a detailed description of the various document types DEVONthink supports.
Note:
Command-clicking the window title shows the document's location including the database it's stored in.
Toolbar Items
Similar to the main window, a document window has a toolbar at its top. The default toolbar buttons may vary, depending on the type of file being viewed in the window. You can customize the toolbar via View > Customize Toolbar, but note there are fewer options than you have with a main window. A list of available toolbar items is available in the Toolbar section of the appendix.
Download Manager
Window > Download Manager opens DEVONthink's Download Manager panel. Using the Download Manager, you can download files or complete web sites from the internet, and either store the information in your database or as files on your hard drive. Offline archives stored in DEVONthink are also used when you visit bookmarks or open a link in a new tab and your computer is currently offline.
Panel elements
The Download Manager panel consists of:
Adding Files
To download a web site or any other file, simply add it to the Download Manager by dragging its URL to the Download Manager panel. Alternatively, you can click the in the panel and add the URL manually, as well as a referrer, user name, and password. If Automatic is checked, DEVONthink creates a referrer automatically when downloading whole web sites.
You can also paste one or more URLs (copied Safari bookmarks, DEVONthink links, or copied links from DEVONagent Pro's Download Manager), or add files to the Download Manager by using the contextual menu in web and HTML views in DEVONthink.
Note:
You can also copy URLs in the Download Manager to the clipboard or drag them to other applications (like the Finder or Safari's bookmark manager). The Download Manager also supports URLs for local files (POSIX path, a file://localhost/ URL, or a file:/// URL).
Action Menu
Most actions are available through the Action menu or the contextual menu. Click the gear button or Control-click an item in the Download Manager panel to display more commands:
For your convenience, DEVONthink comes with predefined option sets that you can directly select from the action menu.
Note:
Downloaded items are by default excluded from classification and tagging.
The options dialog defines which file types the Download Manager downloads, which links it follows, and where it stores the files.
The Follow Links options defines how far DEVONthink follows links on the downloaded HTML pages. This feature allows you to control what gets downloaded--only the actual pages or a complete web site. DEVONthink supports the following options:
Note:
Following links two levels deep can result in very large downloads.
The Sorter
The Sorter is a multi-purpose popup that allows you to quickly add content to your databases, even when DEVONthink isn't the active application. Depending on the option you choose in Preferences > Sorter, it will appear in the menubar at the top of your screen or docked to the left or right side of your screen. When shown as a menu bar icon, you can choose to display it as the word DEVONthink or a space-saving nautilus icon.
It supports several views, each providing handy shortcuts to getting data into your databases. Switch between these views by clicking the icons at the top of the pane. Below we cover the different views the Sorter provides for quickly capturing data.
Navigation
The Navigation view provides a convenient list of the databases and groups in DEVONthink.
To add files in the Sorter, drag over the docked tab or menu bar item. The Sorter will spring open. then drop items into specific groups to quickly import them. Also equipped with a handy search field, you can search for and isolate groups for more targeted importing. This view is composed of three sections:
Hotkeys: The Navigation view supports these hotkeys:
Note:
The ⎋ Escape key can be used in all views to quickly close the Sorter.
Creating Files
The remaining views are focused on creating files, whether that's a simple plain text file, a screen capture of an application's window, or some recorded video. Each of the following views support the following options:
The Take Note view is for those times when you just need to quickly write a note but don't want to go back into your databases to create a new file.
Allowing you to write notes in several formats, the text will be displayed in the font defined in Preferences > Editing. Make your note taking a little faster by defining a hotkey with the Preferences > Sorter > Take Note Hotkey. This view supports these attributes:
Take Note Panel: The Take Note panel is displayed when the Sorter is set to None in Preferences > Sorter. It has the same functions as the view in the Sorter and also will be pinned over any open windows.
Voice Note
Use this view to record a voice note directly into your database. This creates an AIFF-C file in the location you choose. With simple controls, it's easy to record impromptu audio.
This view has a few simple sections:
When you've stopped recording, you will be shown:
Video Note
Use this view to capture a video from your Mac's built-in camera. Videos are saved as MP4 files for convenient compatibility across platforms and devices.
Like the audio note, this is presented in very simple controls:
When you've stopped recording, you will be shown:
Screen capture
Screen captures are a common way to quickly gather information about things on our computers. While the Apple provided mechanisms still work, the Screen Capture view allows you to quickly snap a screen shot, add some metadata, e.g., tags or labels, then direct it to a specific location in your databases. The captures will be saved as JPEG files.
This view has one simple section with three options:
As with other views, name and information options will appear after the screen is captured.
Use the Web Clip view to quickly clip the current web page, a URL from your clipboard, or enter a URL manually.
After clipping, you can add other information to the item:
Preferences
The Preferences window, opened using DEVONthink > Preferences, contains all available options, which you can modify to adapt DEVONthink to your personal needs.
Because the preferences are so important, we have created a separate chapter for them.
Database Properties
The Database Properties popup displays preferences for a specific database. Select a database and open the properties popup using File > Database Properties
General
Location: Shows the location of the database in your filesystem. Note you can double-click any part of the database location to reveal it in the Finder.
Create Spotlight Index: Check to make this database available to Spotlight. Checking this option lets DEVONthink create a folder in ~/Library/Cache/Metadata that Spotlight uses for accessing the documents in the database. If you are having issues finding DEVONthink documents in a Spotlight search, you can click the Rebuild button to recreate this folder from scratch.
Options
Name: Enter a name for your database here. It will appear in the title bar of every main window of this database.
A database has two names: the displayed name, set here in the properties, and the filename, the name of the database file in the Finder. When you create a database, the names will be the same. If you change the displayed name in the database's properties, the name of the database file will also change. However, you can close the database and change the filename in the Finder, should you choose to. This can be used in any situation, including office, health care, and litigation environments where clients or cases have a unique number associated with them. A database could have a filename of 10459.dtBase2 but the displayed name of Company A in DEVONthink. When you close the database, the filename will be shown in the Recent Databases section of the Navigate sidebar.
Comments: Add comments about this database. These comments are only used in DEVONthink, i.e., not exported to the Finder.
Exclude Groups from Tagging: Excludes all groups in this database from being used as tags. Ordinary tags can always be added to items using the Tag bar.
Inherit Tags of Groups: Applies tags added to a group also to the group's children.
Case Insensitive Tagging: Check this option to disallow tags with different capitalization.
Protection: To add a layer of protection when syncing your databases, you can add a username and password to the database. Anyone trying to import the database from a sync location will need to provide these credentials. Click on the padlock button to unlock the entry fields, enter a user name and password, and then click on the padlock button again to lock your changes and hide the password.
Note:
For a locally secured database, create an encrypted database via File > New Encrypted Database.
Statistics
This section displays some basic statistics about the contents of the database, e.g., counts of some different file types, total size of the contents, and number of words in the index of the database.
Popovers
Popovers are a specialized panel that appears on command and disappears after interacting with it. These are usually used for quickly viewing information about a selected item but can also be used in some other ways. For example, Database Properties is an information popover you may already be familiar with. Here are a few more DEVONthink offers, starting with information popovers and followed by utility popovers.
Info: The Info popover shows information about the currently selected item. It displays the contents of the Info, Annotations & Reminders, and Properties inspectors. Open this popover via Tools > Get Info, ⇧⌘I, or pressing the toolbar button.
Log: The Log popover displays any information available in the Log window. This allows you to quickly glance at any messages without having to open a separate window. Open this popover via the toolbar button. Note this button will only be enabled if there are messages available to be viewed. You can clear the log or press the Save button to save the log, usually to send to our support team.
The utility popvers provide extra functions for moving files, navigating databases, or linking documents. Each popover has a search field at the top for helping to narrow the results. You can use an abbreviated search syntax matching the beginning of words to help speed the process. For example, if you are looking for a group named "Household Expenses" you could type hou exp to find matches. After tsearching, double-clicking a result will move the file to the selected location. For keyboard navigation, you can press ⇥ Tab to put the focus in the results list then navigate with the arrow keys. Pressing ↩ will accept the choice and close the popover automatically. There is also a plus (+) button for creating a new group in the current location when needed.
Move to: This popover allows you to organize selected files quickly. Open this popover via Data > Move To or pressing ⌃⌘M.
The default behavior of this popover is moving files. However, the behavior can be changed using command keys. Hold the ⌥ key to duplicate files to a selected location. Hold ⌘-⌥ to replicate the files to a selected location within the same database. Note the text in the popver will change to reflect the kind of operation will take place.
Go to Group: This popover allows you to quickly jump to another location. Open this popover via Go > To Group or ⌃⌘G. One special property of this popover is the ability to act as a floating pane. Open the popover then click and drag it away from the toolbar. It will remain open as a searchable floating pane you can use for quick navigation. You can also drag and drop files to it, similar to the Navigation view of the Sorter.
Go to Document: This popover allows you to quickly navigate to a specific file. Open this popover via Go > To Document or ⌃⌘O. Note this popover does not support abbreviated syntax, i.e., matching substrings or non-contiguous words, as the fuzzy matching would lead to far too many results. Given a filename of DEVONthink sync timing tests.md, timing tests would match; DEVONthink timing would not.
Insert Link: Used when editing text-based documents, e.g., rich text, this popover allows you to search for and quickly insert a link to that file in the current document. The type of link inserted will be appropriate to the current document type, e.g., a Markdown document will have a properly formatted Markdown link. Open this popover via Edit > Insert > Item Link or the Insert > Item Link command in the contextual menu while editing a compatible document. There is no shortcut for this command but you can assign one yourself. [Read more...]
Web Sharing
DEVONthink comes with a built-in server for broadcasting your databases on a network. While the operation is covered in the In & Out chapter, here we cover the interface shown when accessing shared databases in a browser window. Also note the preferences for setting up shared databases, including setting up users and per-database permissions are covered in the Preferences > Server section of the Preferences chapter.
The layout of the web sharing should immediately be familiar to users of DEVONthink. While not as full featured as the native application, it behaves in ways similar to DEVONthink's main window. Here we will give you an overview of the parts of this interface.
Note:
The permissions given by the administrator of the shared databases determine database visibility as well as what actions you can take. Due to this, some actions, e.g., creating new documents or downloading documents, may not be available. If you do not have permissions to modify the database you're browsing, the cursor will change to show the option is disallowed.
Sidebar
A condensed version of the Navigate sidebar found in DEVONthink's main windows, this provides access to the contents of any shared databases. Some basic contextual menu items, e.g., New Group, New Feed, Rename, and Move to Trash, are available when Control-clicking in the sidebar.
Move files by dragging from the item list over a group in the sidebar to file them in a new location. Holding the ⌘ Command key allows you to copy the file instead of move it.
If you hover over a section in the sidebar, you can hide the Globals or Shared Databases section. Also, you'll notice this interface has been built in a responsive manner. This causes the sidebar to disappear when the browser window becomes to narrow for it be effective. You can still use toolbar buttons to toggle the visibility, as needed.
The item list, like it's DEVONthink counterpart ([Read more...]), shows items in the current location. Items can be selected and reorganized by drag-and-drop, to the sidebar or groups in the same location. Above the item list is the path bath with active links to parent locations. Click on them to quickly jump back to a parent location. To navigate back and forth through locations you've visited, use the and
buttons in the path bar.
Again, taking its example from DEVONthink's main window, Control-click items in the item list to show these commands in the contextual menu:
While you can't reorder the items manually, the item list can be sorted by clicking on the column headers. Click the header again to toggle between an ascending or descending sort. Control-click the headers to enable and disable individual headers.
View/Edit Pane
When an item is selected in the item list, a preview of any compatible file will be shown here. Many non-proprietary text-based formats commonly can be displayed. Plain and rich text, Markdown, JPEG or PNG files, PDF, etc. are easily searchable and viewable. There is also support for editing plain and rich text, formatted notes, and Markdown documents directly in this pane. Just click in the preview and begin editing.
Navigation bar: The navigation bar above the pane varies what it displays, based on the type of file it's displaying. If an item has a URL, it will be active and displayed here. The bar also allows you to move back and forth through previously viewed files via the and
buttons.
Of special note are the behavior of formatted notes. They are displayed with a handy toolbar providing some editing options, like adding bold or italic type. You can also select text and create a hyperlink with it. Lastly, you can choose an image to insert into the document.
For the Markdown fans, you will see the same navigation bar options, showing Edit, Preview, and Side-by-Side modes.
Note:
While it is a force of habit — and in general, a good one to be in — you do not need to press ⌘S after editing a file. The changes are saved automatically.
Info: A simplified view of the Info Inspector pane found in a main window. Shown by clicking the right-most toolbar button or choosing the Get Info command from the Action button, this shows basic metadata about the item selected in the item listing. If you have permissions to make changes to the current database, it is possible to change some of the metadata, like ratings or labels.
See Also: The second view of the inspector shows the See Also pane. This gives you some suggestions about other documents that may be related to to the currently selected item. Clicking on an item in the results will display that document in the view/edit pane.
There are a handful of toolbar tools in the web sharing interface. Note a few items will be discussed separately.
Support Assistant
The integrated Support Assistant combines a welcome screen with a first launch assistant, tips, installable extras, and a support page that guides you through the available support options.
Welcome
This screen welcomes you when you start DEVONthink for the very first time. It offers:
Click the links at the bottom of the window to access the other Support Assistant sections. You can also check or uncheck the Show this window when DEVONthink opens checkbox at the bottom of the window to set whether to show the Support Assistant each time DEVONthink is launched.
First Launch Assistant
The first launch assistant opens automatically the very first time you open DEVONthink, and guides you through the first steps of using the application: creating a new database, installing the add-ons, and adjusting the preferences.
Get Support
The Support screen guides you through the three common steps for troubleshooting DEVONthink. In addition, you can update your details in DEVONtechnologies' customer database, or buy an upgrade or a second license.
On the Extras screen, DEVONthink lists all available extras that you can download and install from DEVONtechnologies' server:
Browse the list of extras and install them with the Install button. The last line of the description shows where in the Scripts or Templates menu the extra will show up after installation. Remove installed extras with the Remove button.
The extras are updated live from DEVONtechnologies' server so it's a good idea to check back from time to time. The latest extra is also always mentioned on the welcome screen. If you check the Install & update extras automatically checkbox at the bottom of the window, any updates to scripts or templates you've downloaded here will be updated as needed.
Note:
If one of these categories does not show up in your copy of DEVONthink, there might be no extras of this type currently available.
Tips and tutorials
Here you can find the latest tips and tutorials to help you squeeze the best out of DEVONthink. Tutorials can be slideshows describing basic tasks in DEVONthink or screencasts.
Both tips and tutorials are updated live from DEVONtechnologies' server so it's a good idea to check back on a regular basis. The latest tip or tutorial is also always mentioned on the welcome screen.
Log
The Log panel displays messages and warnings when importing files and folders, results of performing maintenance routines, and AppleScript errors from script actions in smart rules or reminders. The panel shows the date of the message, any affected files, and a little information about what happened. If you feel you are having sync issues, this panel is the first place to look. Also, when doing any database or sync location maintenance, this is where the results are shown.
You can save the list to a text file with the Save button, and clear the log with the Clear button. To sort the log, click a column title to sort on that column, changing from ascending to descending each time you click it. If you Control-click individual log entries you will be shown options to reveal the item in its location or move it to the trash. Alternatively, double-click the entry to reveal the file.
Uncheck Show log automatically to prevent the log popping up automatically. You can open the Log panel at any time using Window > Log. For important notifications, the log is always shown automatically, ignoring this setting.
Activity
The Activity panel shows a list of currently running background processes, e.g., converting scans to searchable PDFs, refreshing news feeds, downloading PDF documents and web archives via our browser extension, or sync activity. You can manually open this pane via Window > Activity. You can manually stop them to free computer resources or for other reasons.
There is also an Activity pane at the bottom of the Navigate sidebar. Providing a less intrusive experience, this pane will appear and disappear quietly on its own.
Note:
The Activity window is only used if it was opened by the user or if there is no main window to show an Activity pane.
Inspectors
the Inspector panes displayed on the right side of a main window provide an incredible amount of information and functionality when working with files in DEVONthink. Covering a range of options, from basic metadata to setting reminders to in-document search and replace functions. Each of the Inspectors is individually covered in this chapter.
Info pane
The Info pane, just like its counterpart in the Finder, displays additional information about a selected document or group, from icon and name to comments and other metadata. Open the Info pane by selecting Tools > Inspector > Info > ….
Note:
When you have multiple items selected, some editable attributes can be modified. For example, tags can be applied to multiple files at once. However, if you add tags to the same files separately, only tags common to them will be shown if you select them together again.
The Generic view shows additional basic information about a selected document or group, similar to what is shown in the Get Info window in the Finder. Additionally, it shows some other attributes like ratings, color labels, and geolocation data. Here are the attributes shown:
Exclude From…: These checkboxes allow you to exclude an item from being used in various ways. For example, you can exclude temporary groups from classification to increase the accuracy of the built-in artificial intelligence. You can exclude an item from these operations:
The Custom view displays custom metadata fields and their values. These custom fields are defined by you in Preferences > Data. All available fields you have defined are shown in this pane. Note some fields may be specified as data types that include some extra actions in this view. For example, if you create a custom parameter with an Item Link data type, you will have an option to reveal the file.
Annotations & Reminders
This pane contains Reminders, Finder Comments and information about Annotations. It can be shown Tools > Inspectors > Annotations & Reminders.
While there are many reminder applications, including Apple's own Reminders, sometimes you just want to set a quick reminder for an item, or multiple items, in DEVONthink. The Reminders section allows you set a reminder, even a recurring one, as well as an optional alarm.
After choosing a schedule, set a date and time for the reminder or to begin a recurring reminder. For recurring alarms, the data or time you set will be the beginning of the alarms. Reminders can be set to:
Alarm: Reminders are most useful when you have an alarm to, well, remind you of something. There are several alarms available for a reminder:
Note:
When setting a reminder on multiple items, alarms are delivered individually. For example, an alert notification will show for each file, even if they were set for the same time.
If you are interested in the use of scripts in alarms, please refer to the Reminder Script chapter of the Automation chapter.
Similar to the Comments in the Get Info pane in the Finder, the Finder Comments field can be used to store miscellaneous bits of information about the selected objects. When an annotation file is made, the original item link of the document will be stored here as the Original URL.
Note:
These comments will not appear in the files in the Finder unless the files are indexed or exported from the database.
This pane displays or allow you to create annotation files for a selected document. Annotation files are separate files where you can store notes about a specific document. These files can link back to the original file for quick access. Commonly used with PDF files, they can actually be used for making notes with any document in your database.
Note:
Annotation files are created in an Annotations group at the root of the database. However, you can move the file to another location, if desired.
If an annotation file doesn't exist, you can make one with commands from the down arrow in this section.
If an annotation file is detected by DEVONthink or you've just created one, an editable preview of the file will appear here. Clicking the down arrow reveals these options:
Creating an Annotation File: DEVONthink has a built-in default annotation file in rich text format, suitable for general use. However, you can create your own custom template in plain text, rich text, or Markdown formats. These files can be created externally and added to ~/Library/Application Support/DEVONthink 3/Annotations.noindex or created in DEVONthink and exported via File > Export > as Template to the Annotations.noindex folder.
To create backlinks to the original file, there are two placeholders for use in the body of your template:
Rich Text: To create the backlink in a rich text template, use the %documentLink% placeholder and the document name will be added as the link's text.
Markdown: To create the backlink in a Markdown template, use the form: [%documentName%](%documentLink%).
Plain Text: Since plain text files don't support live links, you can use WikiLinks to create a backlink. For example, if you are using the Square Brackets WikiLink syntax, you could use [[%documentName%]] in the body of the plain text.
Content
Navigating PDF documents can sometimes be difficult when you are just scrolling through endless pages of documents. The Content Inspector shows two views, similar to what you see in Apple's Preview application: Table of Contents and Thumbnails.
The Table of Contents view will display the outline of a PDF document, provided that PDF contains one. Click on the disclosure triangle to show or hide sections within chapters. Click on any section heading to jump directly to the beginning of it.
There are two contextual menu items in the Table of Contents view: Copy Page Link for use with PDF documents, and Copy Section Link for use with Markdown documents.
The Thumbnails view shows a list of thumbnails, one for each page in the document. This allows for a more visual approach to moving through your document. By default, the thumbnails are shown in a single column but they can be displayed in multiple rows if the sidebar is expanded. This view allows for actions like these:
You also have several options available in the contextual menu when you Control-click in the Thumbnails view:
Document
The Document inspector provides specific information about the current document. This information is presented in three specialized views: a view of RTF and PDF metadata, a list of annotations in a PDF, and a list of links found in certain document types.
The Document Properties section gives you access to all metadata stored for selected RTF and PDF documents. This metadata can include some of the following:
Depending on the document type, you may be able to edit or view these properties. More fields may be available depending on the document type.
There are two parameters supporting extra actions:
As PDF files are often used in DEVONthink, annotating these documents is commonplace. The Annotations view displays a listing of the annotations in the current document. Each annotation is listed with the following metadata: page number, type, content or author, and the date the annotation was made. In the case of highlights, text, or note annotations, the content will be displayed. With graphic annotations, e.g., rectangle or ovals, the author will be displayed. The list can be sorted by clicking the appropriate header. Select an item in the list to switch to the proper page. The annotation on the page will be selected. This makes it easy to navigate via the document's annotations.
At the bottom of the view is a Details section. For Note annotations, this will show the text of the annotation. Details can be added to other annotation types as well, but only supports plain text entries.
Opening the contextual menu in the Annotations list offers the following options:
For the selected document, DEVONthink will attempt to determine if it contains links. These may be web URLs, file URLs, item links, and even DEVONthink's WikiLinks. (You may be surprised by the number of links in many documents.) The top section of the Links view displays a list of any outgoing links, i.e., links to other files, websites, etc. The bottom Incoming Links view shows incoming links, i.e., links in other files to the current document.
Select a link in the list to show it in the view/edit pane. Double-click a link to open it in a document window or an external application. Option-click or Shift-Option-click a link to open it in a new tab. Opening the contextual menu in the Link list offers the following options:
In the Incoming Links section, the contextual menu has an extra command: Copy Name. Use this to copy the name of a linked file and paste it into another document as a WikiLink.
Concordance
The Concordance pane, opened in the Tools > Inspectors menu, gives you a tool for analyzing the textual contents of documents. When the inspector is open, selecting different items will show varying results. If one or more documents is selected, the results will be inclusive of the text in all of them. If there is no selection, the results will be based on the text of documents in the current location, whether a group or a database. This also applies to selecting items matched in smart groups, both local and global.
These results are presented in three distinct views: List, Cloud, and Graph.
List
The List view displays the concordance results in a list, separated by these parameters:
Click the column headers to sort on a given parameter. Select a word in the list to highlight all occurrences in the current document. Double-click a word to open a database-wide search for the term.
Opening the contextual menu in the results offers these options:
Cloud
The Cloud view present the concordance as a word cloud. The size of the terms is relative to the frequency in the selection or database. Selecting terms highlights the occurrences in the current document.
Related Words
Of special note is the Related Words graph shown under the List and Cloud views. Select a word in the list or cloud and it becomes the central term in a graph of related words. These are words found throughout your database. Double-clicking a node initiates a database-wide search. The contextual menu provides options for copying the word's information, as well as excluding the word.
Graph
The frequency graph shows a graph of the word frequency over the rank number of the word (see above).
Note:
There are no contextual menu options in this view.
See Also & Classify
The See Also & Classify inspector is the main interface to DEVONthink's brain, our built-in AI engine. This engine is analyzing the contents and locations of all documents in your database and making connections between them. These connections can be seen in this inspector pane.
This inspector will be shown when a document is selected and you choose Tools > Inspectors > See Also & Classify. When the inspector opens, you will be presented with two sections: Classify and See Also.
Based on analyzing the contents of the current document, the AI cross-references the contents and locations of other files in the database. The results are shown in the Groups section. This list offers a range of suggested locations, displaying a heat-mapped score of its relevance and the location of the group. The highest ranked suggestion is presented first. Obviously, you can choose any other them. If there's a group you'd like to use, double-clicking the suggested group will file the document for you. You can also click the Move to button, press ⌃C, or drag and drop to file it in any of the suggested groups. Lastly, if a suggested group is in the same database as the selected file, you can hold the ⌥ key and the Move to button changes to a Replicate button.
Directly above the classify results is a search field. If there is another group you're thinking of that hasn't been suggested, type part of the group name to filter the list of suggestions. Then file into the location of your choice.
On a related note, in the Data menu, you will find two menu items: Move to … again and Classify to…. The first provides you the option to classify the current document in the group into which you classified. If you filed into a particular group via the Groups section, this menu item would remember it and offer that group as a place to classify the current document. The second menu item offers its top ranked suggestion for classifying the current document, if you'd like to just follow the AI's suggestions.
Another benefit of the AI's content analysis is the ability to offer suggestions of documents that may be related to the current document. These files are listed in the Documents section of the inspector. Like the Groups section, this list shows the location of the document and heat mapped score of the potential relevance. Hovering over a result shows a tooltip displaying its full title and location.
Select a document in the results to display it in the view/edit pane. For your convenience, DEVONthink always lists the original document near the top of the list. This way you can select it to go quickly back to the original document. Double-click a document to open it in a document window. Drag a document from the list to move it to another location. When dragging, you can create duplicates by holding the ⌥ Option key. You can also create replicants by holding ⌘ Command and ⌥ Option and dragging to another location in the database.
Contextual menu
The See Also and the Classify sections host many of the same contextual menu items as the item list. A list of these commands is included in the contextual menu section of the appendix.
Search
The Search inspector provides in-document searching. Using the same familiar ⌘F hotkey you use in most macOS application, you can not only search, but replace found words. Additionally, DEVONthink provides a list of the found words to help navigate the results. The results also show the search hits in context, either in a sentence or paragraph, depending on the setting in [Read more...].
Searches match substrings by default. This means a search for "some" would also match "something" or "worrisome".
Something you may find useful is the live updating when you select other files. If you search for a word in the current document and leave the Search inspector open, DEVONthink will automatically search newly selected files.
Search and Replace
The Search and Replace section offers these simple intuitive controls:
Search Results
The results provide a convenient list of the found words. This includes the line number of each hit and the number of occurrences found. It also includes part of the surrounding text to help give some context to the found words. Additionally, there a some contextual menu options available when you Control-click in the results:
Menus
A complete listing of all the commands available in the menu bar of DEVONthink, the Services menu, and the contextual menu of the DEVONthink's Dock icon.
The Application Menu
The DEVONthink menu is a utility menu, similar to those found in other Mac applications. It has commands that allow you check the version via the splash screen or check for application updates. You can install our add-ons, access the preferences, access the Services menu, empty your databases' Trash, and quit the application.
About & Check for Updates
About DEVONthink: Shows information about DEVONthink including the version number to whom the software is registered.
Check for Updates: Checks if updates for DEVONthink are available. By default, DEVONthink checks for updates automatically, however you can change the update settings in the Preferences > General. If an automatic update is pending choosing this command shows a window with additional information about the update.
Note:
When checking for updates no information is uploaded from your computer to the DEVONtechnologies server. DEVONthink only downloads a file listing the most current versions to your Mac. This option is not available if you have purchased DEVONthink from the Mac App Store. In this case, all updates are handled by the App Store.
This command allows you to install, or reinstall, some of our extra support files and scripts.
The following options are available.
Note:
The Safari browser extension is now installed by default, but you'll need to go into Safari's Preferences > Extensions and enable it. Also while extensions for browsers like Opera, Vivaldi, and Brave are not explicitly available, it is possible to install them from the Chrome Web Store, while in those browsers.
Preferences: Opens the application Preferences.
Empty Trash: Moves the contents of all open databases' trash to your computer's file system trash.
Empty Cache: Empties the web browser cache. This frees up space and makes sure that all, when displaying a web page, all data is freshly loaded instead of using a cached copy.
Purchase & Licenses
Purchase: Opens the DEVONthink product page from where you can put the app into your shopping cart. If this copy of DEVONthink is already licensed, you will be presented with upgrade choices.
Enter License: Enter your purchased license code here. It is best to use copy-and-paste for transferring the license code from the email message to the appropriate field.
Note:
Enter License changes into License and Purchase License into Purchase License or Upgrade as soon as you have entered a valid license code (and a paid upgrade exists). Available options depend on whether you have purchased your copy from DEVONtechnologies or from the Mac App Store.
The Services submenu gives your access to special commands published by other Mac applications such as TextEdit or Safari, or by services extensions such as our own WordService or CalcService. Also, DEVONthink publishes its own services. [Read more...]
The File Menu
The File menu contains commands creating and deleting databases. There are options for adding or exporting files, as well synchronizing them. Additionally, if you need to do database maintenance, you will find those commands here.
New Database: Creates a new database in the selected location.
New Encrypted Database: Creates an AES-256 encrypted database file at a user-specified size. Technically this database uses an encrypted disk image but will not be visibly mounted in the Finder. Obviously, when you enable Spotlight for the database the data that Spotlight needs to store will not be encrypted. The anticipated size of the database can be specified in megabytes (MB) or gigabytes (GB).
Open Database: Opens previously created databases. You can select multiple databases.
Open Recent: Presents a list of recently used databases, which gives you quick access to your frequently used databases. Choose Clear Menu to remove all items from the menu.
New Window: Opens a new main window for the selected database.
Import: The Import submenu contains various options for importing data, e.g.,selected files, bookmark, contacts, and some data from compatible applications. Some options will import files into their own special groups at the root of the database.
Note:
The import from Evenote command only works with Evernote's "legacy version" as Evernote 10 no longer supports AppleScript
Note:
Groups created when importing bookmarks, contacts, email messages, and items from Evernote or Yojimbo are not automatically excluded from classification and tagging. This makes it easier to classify them later.
Export: The Export submenu presents options for exporting selected documents or groups to the file system. In addition, the Export menu provides export methods based on plugins. DEVONthink comes with a number of standard plugins for exporting documents in different formats. For these formats, the export creates a single merged document when multiple files are selected.
Share: This shows the standard Mac share menu.
Index
Index: Use this command to add external files and folders from the Finder. This creates links to the files but leaves them in the current location. Regarding see-also and classification, DEVONthink treats these files the same as imported files. To easily distinguish indexed items, a small Finder icon is displayed to the right their name.
Update Indexed Items: Indexed items are updated when you view them. If you need to be sure everything is up-to-date use his command. If nothing is selected, the enclosing group of the current group is used. It also reads changes made to the Finder or Spotlight comments of the to-be-updated files and applies the changes to the files' counterparts in the database. Finally, this command removes indexed items that have lost their external counterpart. It does not affect items moved manually to the group.
Use Update Indexed Items to keep indexed groups and their originating folders in sync or to manually update an item that you have changed directly inside the database package when DEVONthink was not running.
Note:
Indexed groups are excluded from tagging by default. For more information on importing and indexing, please see the Import and Index section of the In & Out chapter.
Synchronize
Synchronize: Synchronizes the selected database with all its locations. Note, this command will be disabled if the current database has no active synchronization. Holding the ⇧Shift key shows the Synchronize All option to synchronize all actively syncing databases.
Download Pending Files: Downloads the files of selected documents if they are available through one of the database's locations. Only necessary of none of the database's locations is set to synchronize indexed files.
Database Properties: Opens the Database Properties popup for the current database. This panel presents a few options, statistics about the database, and allows you to change the displayed name, add comments, and add a username and password.
Close Database: Closes a selected database. If multiple databases are open, use Close All to close them all at once. If you'd like to keep the current database open but close the others, use Close All Except. Note that closed databases will not reopen on launch. Only databases that were open when DEVONthink quits will reopen on the next launch.
Like any database, DEVONthink databases need a bit of maintenance from time to time. All the commands you'll need for this can be found here.
Verify & Repair: Verifies all database structures and repairs them if necessary. Use this whenever you feel it is necessary. By default, DEVONthink automatically verifies the database structure every time you open a database. If it finds significant errors, DEVONthink will advise you to run this command.
Optimize Database: Creates an internal backup of the database and then optimizes the database structure. Optimizing removes unnecessary internal elements from the database and rebuilds the internal structure to optimize performance. DEVONthink also creates internal backups on a regular basis. Hold the ⌥ Option key to display the Restore Backup option. This allows you to roll back the metadata to a previous date. This option would only be used in troubleshooting situations.
Rebuild Database: Completely rebuilds the database by exporting all items to a temporary folder in the file system, creating an empty database, and reimporting all items. This removes any structural problems. Depending on the size of your database, this can take from a few seconds to several hours. This option is typically only used in a troubleshooting situation.
Delete Database: Closes a selected database and moves it to the Finder trash.
Page Setup: Sets your preferred page size and printer settings.
Print: Prints the current document or view.
The Edit Menu
The Edit menu contains all commands and options relating to editing. You'll find the classic Mac cut/copy/paste and find/replace commands here, as well as many more.
Undo/Redo: Use these commands to undo or redo the last action, e.g.,to undo deleting a file. Undo and Redo work for most actions.
Cut/Copy/Paste: Do exactly what their names say.
Copy URL: Copies the URL of the selected or frontmost document to the clipboard.
Copy Item/Page Link: Copies a URL to the clipboard that links to the selected document or group. These links can be used to create a back link to the document in applications that support live hyperlinks. For PDFs, hold the ⇧Shift key to reveal the Copy Page Link option.
Paste and Match Style: Pastes text from the clipboard, matching the styles in the current document.
Delete: Deletes the selected piece of text.
Complete: Tries to auto-complete the partial word before the insertion caret. This standard Mac function uses the currently active dictionary, chosen in the language dropdown of the Spelling and Grammar > Show Spelling and Grammar panel.
Select All/Deselect All: Selects or deselects the complete content of the frontmost document. Hold the ⇧Shift key to reveal the Deselect All option.
Summarize, Tags, Set Name
Summarize: Summarizes the selected piece of text. Unlike the Mac's Summarize service, this command takes advantage of the built-in AI of DEVONthink, and uses the complete "knowledge" contained in the open databases for improving the results. The better your databases, the better the results.
Tags: Use this command to quickly enter tags for the current document. This displays the Tag bar, if necessary.
Set Name As: Applies the selected text as the document's name.
Find, Spelling, Insert
Find: This submenu contains standard Mac find commands, like those available in TextEdit. Searches on the current document are displayed in the Search Inspector. Two commands of note are:
Spelling and Grammar: Provides the standard macOS functionality for checking text for spelling or grammar errors. To choose the language used for spell checking, or for auto-completion (see above), open the spell checker panel with Edit > Spelling and Grammar > Show Spelling and Grammar and choose your language of choice from the pop-up menu.
Substitutions: Shows the standard Substitutions preference panel and switch the available options manually on and off: Smart Copy/Paste, Smart Quotes, Smart Dashes, Smart Links, Data Detectors, and Text Replacements. Data Detectors analyze shown text and make context-sensitive actions available, e.g., when you hover the cursor over a phone number or postal address.
Note:
The Spelling and Grammar and Substitutions commands can be temporarily applied to the current document. If you'd like these to be persistent choices, you can make global changes in Preferences > Editing.
Transformations: Use this submenu to change selected text to all lowercase or uppercase, or to capitalize every word.
Speech: Starts or stops speaking the selected piece of text.
Insert: Inserts items, like pictures, checkboxes, bulleted lists, etc. The options available are dependent on the current file type.
Dictation & Emojis
Start Dictation: Starts the Mac's dictation function.
Emoji & Symbols: Shows the standard Special Characters panel for inserting characters and emoji that you cannot enter directly with your keyboard.
The Data Menu
The Data menu contains all commands that deal directly with documents or groups. Here you'll find commands for creating, labeling, classifying or group new documents, and more.
New: This submenu provides access to the built-in items DEVONthink allows you to create.
New from Template: This submenu allows you to access any installed templates and add them to the current group in your database. There are two other commands to note:
Note:
For more information on the pre-installed templates, check out the Templates section of the appendix.
Open: Opens the selected document or group in a separate document window. This command opens a second main window for the selected group. If you have selected multiple documents, hold the ⌥ Option key to display the Open in Tabs command. If the View/Edit pane is visible, this opens the selected items in new tabs. If the View/Edit pane isn't visible, a new document window will open with each selected document in its own tab in the window.
Open with: Displays a list of applications compatible with the current file type. Opens the selected documents in the chosen application. If your desired application is not listed in the submenu, choose Other to browse for it.
Launch URL: Opens the file, folder, or internet location indicated by the URL field in the Info inspector.
Reveal: Reveals the location of the frontmost document in either the same main window, if possible, or by opening a new one.
Show in Finder: Opens a new Finder window with the item selected. Note this only works for documents and indexed groups.
Send by Email: Creates a new message in the default email application and adds the selected items as attachments. Supported email applications are Apple Mail, Airmail 2, Microsoft Outlook, and Postbox, as well as some legacy email application . If the selected item is an email message, the sender is automatically inserted as the recipient and the text of the original message is inserted instead of an attachment. Notes: Postbox is currently only able to send one selected file. Unsupported email clients (e.g.,Thunderbird) can only send the plain text of one selected file.
Save, Revert, Duplicate
Save/Save All/Revert To Saved: Saves the frontmost document or all documents to disk. Hold the ⇧Shift key to show the alternate menu item, Save All.
Revert To Saved: Restores the frontmost document to the last saved version.
Duplicate: Creates a duplicate of the selected items. The name of the new item ends in "copy", and because their contents are identical both items are marked with the icon for duplicates (or, depending on your preferences, show their name in bold and blue).
Move Indexed Items In and Out
Note:
The following two commands are only for use with indexed files.
Move Into Database: Use this command to move an indexed file into the database. Use this command with caution as it moves the file from its current location into the internals of your database. It does not copy the file.
Move To External Folder: Use this command to move a non-indexed item, e.g.,imported or created in DEVONthink, out to an indexed folder in the Finder.
Favorites, Reading List, Metadata
Add To: Commands in this submenu add the currently selected documents to your Favorites or the Reading List.
Mark: Allows you to mark the item as flagged/unflagged, locked/unlocked, and read/unread.
Rating: Allows you to set a rating, from no stars to five stars.
Label: Allows you to mark the selected groups or documents with one of seven labels, just as in the Finder. You can define the color and the text of the labels in Preferences > Colors.
Tags: This submenu offers special commands for automatically adding some kinds of tags.
Note:
The Add Tags to Images and Scan Barcodes options require macOS 10.13 or later.
Convert: This submenu contains commands for converting between some file formats, e.g.,between rich and plain text. Note the options presented are dependent on the type of the selected document. Also, due to differences in the formats, any formatting in the source document may not be able to be perfectly preserved in the destination document.
OCR: This menu contains options for choosing an output format when doing OCR on a selected compatible document (JPEG, PNG, TIFF, PDFs with no text layer). The currently supported output formats are: Searchable PDF, RTF, Word , and Web Archive. Additionally, there are two special commands: to Comment and to Annotation, which sets the Finder comment or creates an Annotation file with the text. Neither command alters the original file.
Thumbnails: Use these commands to add, remove, or update a thumbnail for the selected files.
Group & Ungroup
Group Items: Creates a new group containing all the selected items. This is similar to creating a new group and moving the selected items into it. The alternate command Group Similar Items, shown when the ⇧ key is held, will attempt to file selected items with similar content in groups.
Ungroup Items: The exact opposite of Group Items. Moves all items in the groups one level up and deletes the now-deserted groups.
See Also & Classify
The following commands use DEVONthink's built-in AI to suggest good locations for the selected documents:
Move (to): This command allows you to quickly move other selected files to the last destination chosen in the See Also & Classify inspector.
Classify: Using DEVONthink's AI, this command will move selected files to the AI suggested location. This command is disabled if DEVONthink is not sure enough about possible destinations.
Move to Trash
Move to Trash/Move All Instances to Trash: Moves the selected items to the trash. If you have selected a replicated item, hold the ⌥ Option key and choose Move All Replicants to Trash to move the selected item and all its replicants to the database's trash.
The Format menu
The Format menu contains the commands and options dealing with all aspects of text formatting. Here you'll find the standard font, alignment, and ruler commands, as well as very special DEVONthink commands.
Note:
Many commands in this menu only work with rich text, Markdown, or formatted notes. Plain text documents do not allow formatting. (That's why they're called "plain" text.) Some formatting options are also available for editable PDFs and web archives.
Fonts, Styles, Alignment, Rulers
Font: This submenu is responsible for controlling the font and the document background color (rich text documents only). Open the fonts panel with Show Fonts, then increase or decrease the font size of selected text with Bigger and Smaller, adjust the text styles and the document background color. Of special note are these two submenu commands:
Style: Commands in this submenu apply a certain style, such as italics, bold, or underlined, to selected text. Also, the commands give you access to some high-end font control like kerning, baseline shift, ligatures, and character shape (only applicable to Asian languages). One command to take special note of:
Alignment: Align paragraphs left, right, centered, or justified. Here, Asian or Arabic users can also change the direction of writing, if required.
Ruler: This submenu allows you to display the ruler above the preview of rich text documents. There are also two special commands:
Highlight, Highlight Color: In rich text documents, editable PDFs, and web archives use Highlight to highlight a selected piece of text just as you would using with a colored pen on a piece of paper. To remove highlighting, select the highlighted piece of text and choose Highlight again. Use the Highlight Color submenu to choose your favorite highlight color.
Links, Spacing, Lists, Tables
Make/Remove Link: Converts the selected text into an active link, or disables the link. This command can be used to create WikiLinks quickly.
Add/Edit Link: Use this command if you want to add a specific link to some text. If the text is already linked, the menu will display Edit Link, allowing you to change or remove the URL. The behavior you'll see when clicking linked text depends on the target of the link:
Spacing: This command allows you to adjust the line spacing of selected text in rich text documents. You can adjust the line height to an exact value or define a minimum and maximum height, adjust inter-line spacing, and define the space before and after a paragraph.
List: Creates a bulleted list. Select your prefix, bullet style, and suffix in the dialog sheet and click OK to insert a new list. In the list, press ↩ Return to insert new items, and press ⇥ Tab and ⇧⇥ Shift-Tab to indent/de-indent items, just as you would in any word processor.
Table: Inserts a new table into a rich text document and opens the table inspector panel. Use the table inspector to adjust the number of rows and columns, cell alignments, cell colors, border widths, and colors. Also, you can merge and split cells and create tables within a cell.
Plain & Rich Text, Hyphenation, Layout
Make Plain/Rich Text: Converts a rich text document to plain text and vice versa. Converting a rich text to plain text removes all formatting, while converting a plain text document to rich text applies default rich text font settings to the document.
Allow Hyphenation: Enables or disables hyphenation for the current rich text document.
Make Layout Vertical/Horizontal: Enables orienting and editing the document text vertically or horizontally.
Bars, Colors, Invisible Characters
Show Formatting Bar: Displays a toolbar of formatting tools under the toolbar, providing access to styles, font and paragraph attributes, and lists. These tools are only used with RTF files.
Show Editing Bar: Displays tools above the current preview pane for some file types. For example, rich text formats display several common tools including increasing/decreasing font size, highlighting, toggling the ruler, and displaying the color picker are shown. For sheets, tools to add/remove/duplicate records, as well as editing columns are shown.
Show Colors: Shows the color panel, e.g., for changing the foreground color of selected text in rich text documents.
Show Invisible Characters: Toggles display of invisible characters such as spaces, tabs, and line feeds. Shown invisible characters appear in light gray.
The Tools menu
The Tools menu provides tools to get more detailed information about your documents, as well as some specialized commands.
Get Info: Opens an popup containing more detailed information about the currently selected file or group. It combines frequently used elements of the Info inspector and contains three panes:
Inspectors: This submenu provides access to the inspectors panes.
Filter: The commands in this submenu filter the list of files in the location you are currently viewing. As you select options in these panes, the list of files will change accordingly. The filters are also covered in the windows chapter.
Note:
When Info or Maps is selected, the options will appear at the bottom of the sidebar. When Tags is selected, they will also appear there, but will also show in the information bar above the item list if the sidebar is hidden.
Annotate: This submenu provides access to the PDF annotation tools: Oval, Rectangle, Line, Note, Text, and Link.
Mode: Use the commands in this submenu to switch between three modes of interaction in PDF documents: Move, Text Selection, and Annotation Selection.
Capture, Imprint, Edit PDFs & Sheets
Capture: This submenu provides options for capturing the current document to a new file in a few different formats: Bookmark, Plain/Rich Text, Formatted Note, HTML, Web Archive, and PDF (One Page/Paginated). Captures are made to the current group. There is also an option to use the Clip to DEVONthink command. This allows you to clip to a chosen location.
Note:
The available options in the Capture menu are dependent on the type of the current document.
Imprinter: Choose an imprint you have defined in Preferences > Imprinter to apply it to the current image or PDF.
PDF Document: This submenu provides options for editing the current PDF document: Insert Blank Page, Delete Selected Page, and Reverse Page Order. See the Documents chapter for more information on PDF documents.
Sheets: This submenu provides access to the following tools for editing a sheet: New Record,Duplicate Records,New Column,Edit Columns,and Delete Columns. See the Documents chapter for more information on sheets.
Rotate & Flip
Rotate Left/Right: Choose this to rotate images, or individual pages in a PDF document.
Flip Horizontal/Vertical: Choose this to flip an image on its horizontal or vertical axis.
Create, Summarize, Merge, Split
Create Expense Report: Creates a sheet summarizing custom metadata dates and currencies of selected files. Totals for the amounts will also be included.
Create Metadata Overview: Creates a sheet with records for each selected file. The columns contain data from the generic and custom metadata of each file.
Create Table of Contents: Opens a submenu to create a rich text or Markdown document with links to the currently selected documents.
Summarize Highlights: Creates a document with all highlighted text passages of the currently selected documents. In case of items located in multiple databases the summary is created in the global inbox. From the submenu, choose to create the summary in a rich text or Markdown document.
Merge Items: Merge the selected documents into one. This creates a new file, preserving the originals. Hold the ⌥ key to choose Merge & Delete n Documents, removing the original files after the merged document is created.
When merging documents, the order of the merge will be the order shown in the item list. The topmost selected document will be the first page with the pages beneath it following. The order of the documents can be controlled by the current sort method in the item list. [Read more...]
Note:
The resulting file type of a Merge operation depends on the types of the selected files. Selecting mixed formats, e.g., a web archive and an image, usually results in an RTFD file being created.
Split PDF into Chapters: Used on a PDF containing a table of contents, separate per-chapter files are created.
Split Document: Splits the current document (PDF, plain or rich text) at the insertion mark position in the document.
Rules
These commands allow you to set or run smart rule commands
Start Server, Take Notes
Start/Stop Server: Use this command to start and stop the integrated web server. [Read more...]
Take Note: Opens the Sorter to the Take Note view. If the Sorter is not shown, it opens the Take Note window.
The View menu
The View menu contains all the commands for modifying the way DEVONthink displays groups and documents.
Sidebar: The Sidebar view options allow you to switch between the four different sidebar views in a main window. You can toggle the sidebar's visibility by selecting the same option again.
View: Choose one of the following options to switch between different layouts for the item list in a main window. All these views are similar to options you find in Finder windows.
Preview: These options allow you to control the position of the current document's preview, or dismiss it altogether.
Quick Look/Slideshow: Opens the Quick Look panel for the selected items which can be useful for times when the view/edit pane isn't displayed. Holding the ⌥ Option key allows you to display the selected files in a Quick Look slideshow.
Show/Hide Tags: Shows or hides the tag bar.
Show/Hide Details: Switches between displaying icons only or displaying icons together with detailed information such as kind, label, size, word count, creation date, and modification date. Available in all windows using icon or column views.
Show Only Documents: When checked, this hides groups and smart groups in List and Icons views. Note this is a per-database setting, i.e., you can enable or disable it for each open database.
Columns: This submenu lists all columns available to be displayed as column headers in the item list.
Sort: This submenu lists all the attributes that can be used to sort the current item list. Choose Unsorted to manually sort the items. DEVONthink remembers sort settings for every group separately and uses those settings when the group is displayed in its own main window
Fullscreen & Zoom
Full Screen: Displays either the current document in a full screen mode optimized for reading and editing, or the frontmost window in full screen. There are two options available here:
Zoom: Depending on the document type, you can zoom or out of the document's preview to your needs:
Document Display: This submenu contains commands for displaying alternate views of some documents. Note there are alternate commands shown when used with sheets or HTML and Markdown files.
PDF Display: This submenu lets you adjust the way PDF documents are displayed:
Hide/Show Toolbar: Hides or shows the toolbar of the frontmost window.
Customize Toolbar: Lets you configure the toolbar of the frontmost window.
The Go menu
For people who prefer to use the keyboard for navigation, the Go menu contains all commands for navigating the hierarchy of your DEVONthink database, all with keyboard shortcuts. Use these commands to go backwards and forwards through your documents, or to move back to the top level of the group hierarchy.
Databases
Previous Database: Selects the previous database in the Navigate sidebar.
Next Database: Selects the next database in the Navigate sidebar.
Groups
Top Group: Returns you to the top level of the database (also known as the "root").
Enclosing Group: Changes the view to the parent folder of the current group or document.
Selected Group: Changes the view to the currently selected group.
To Group: Opens a popup where you can search for a group by name. Results are shown as you type. The chosen group from the results will display as the current group.
Documents
Back/Forward: Moves backwards and forwards through all documents/web pages you have visited by following cross-links or Wiki-style links.
First/Previous/Next/Last Document: Navigates to the first, previous, next, or last document of all documents in the current group. This is useful when you have opened a document in a separate window and want to move to another document in the same group.
To Document: Opens a popover to quickly navigate to a specific document.
Previous/Next Instance: Navigates backwards and forwards through all instances of a replicated document. Use these commands to find out where the other instances of a replicated item are.
Previous/Next Highlight: Navigates backwards and forward through all highlighted passages within a document, regardless of whether these passages have been highlighted by a search or manually using Format > Highlight.
Next Unread Item: Navigates to the next item with an unread status in the current database.
Go to Page/Time: Allows you to jump to a specified page (PDF documents) or time (supported video and audio files).
Favorites: Displays a menu of items in the Favorites section of the Navigate sidebar, allowing easy access to the items.
Workspaces allow you to save the state of your open databases, as well as the contents and positions of all open windows, so that you can restore them later. This is ideal if you are working with the same set of windows over and over again. Save these windows as a workspace and recall them whenever you need them again.
The Window menu
Just like most every macOS application, the Window menu lists all open windows of the active application and gives you access to commands for managing them.
Windows & Tabs
Close, Zoom, Minimize: These three commands resemble the red, yellow, and green buttons of any window title bar, and consequently close the window, minimize the window to the Dock, or maximize the window. No magic here. Hold the ⌥ Option key to change allow the command to affect all windows.
New, Close, Select Next/Previous Tab: Opens a new tab, closes the active tab, or moves the focus to the next or previous tab.
Note:
Tabbed browsing needs to be enabled for these commands to work.
Bring All to Front: Brings all windows of DEVONthink to the front. Hold the ⌥ Option key to change Bring All to Front to Arrange in Front.
Activity: Opens the Activity panel. This panel shows all running processes, e.g.,OCR or sync activity, and allows you to manually stop them.
Download Manager: This command opens the Download Manager panel of DEVONthink. Using the Download Manager, you can download files or complete web sites from the internet and store them directly in your database.
Log: Opens the Log panel. The log lists error messages and warnings that occurred while importing new documents. It also opens automatically when an error occurs. You can save the log to a text file or clear it.
Open Windows
Window List: Select any open window from the menu to bring it to the front.
The Scripts menu
The Scripts menu is located left of the Help menu and shows a stylized AppleScript symbol instead of a normal menu title. It contains a collection of useful, predefined AppleScripts you can use directly from within DEVONthink.
Some of the scripts work without having selected a document, while others require you to select the document you want the script to interact with. In general, the script will tell you what you have to do when you select it from the menu.
Use More Scripts to install additional scripts and read more about scripts and DEVONthink's menu here.
The Help menu
The Help menu contains commands for opening the integrated help pages, the support assistant, or visiting the DEVONtechnologies website.
DEVONthink
Use these commands to open the integrated help pages, get directions on installing the browser extension and bookmarklets, or access the list of changes to DEVONthink.
Support
Your Account: Opens the login page for your DEVONtechnologies account where you can get information on your licenses and the devices they're registered to.
Support Assistant: Opens the support screen of the Welcome to DEVONthink assistant with more direct links to the DEVONtechnologies website, tips, and tutorials. Note this function requires an Internet connection.
Tutorials: Opens the Tips and Tutorials screen of the Welcome to DEVONthink assistant. The tutorials help get you started by explaining everyday DEVONthink tasks in step-by-step detail. Note this function requires an Internet connection.
DEVONtechnologies
These commands take you directly to the corresponding pages on our website or send feedback directly us.
DEVONtechnologies, User Forum: Quickly access our home page or our user forum in your default browser.
Contact Us/Report Bug: Use this to draft a general email to us. When you need to report an issue, hold the ⌥ Option key to show the Report Bug. This creates a new message in your default email client or Apple Mail containing the console log and all related crash logs in a ZIP archive, ready to be sent to our customer support.
The Dock menu
The Dock menu appears when you click DEVONthink's icon in the Dock with the ⌃ Control key pressed, when you right-click it, or when you left-click it and hold the mouse button for one second or longer. When items are added to a database, a badge appears on this icon. Longer tasks, e.g., importing, indexing, or running scripts, may show a progress indicator on the dock icon.
It also contains the generic macOS commands and an Options menu common to all macOS applications. DEVONthink-specific items are listed below:
Recent Databases: Quickly reopen a closed database from this list.
Open Windows: Switch to any open window from this list. The active window is displayed with a checkmark next to it.
Take Note: Opens the Take Note panel.
Start/Stop Server: Starts or stops the web server.
Preferences
The Preferences window, which you open by selecting Preferences in the application menu, is the place to go to change global settings for DEVONthink. In addition to global settings, databases also have separate settings in their Database Properties window that you open using File > Database Properties.
There is also a number of hidden preferences, intended for customer support, but maybe useful for you, too. [Read more...]
General
Use the General tab to set the general settings for the user interface.
General
Stricter recognition of duplicates: Check to have DEVONthink mark files as duplicates consider the file type and size, as well as the content, when determining duplicate files.
Enable reminder alarms: Enables or disables using DEVONthink Reminders. This can be set on a per-machine basis.
These options control the behavior of the interface, e.g., when double-clicking documents.
Alerts
Click Reset to make DEVONthink show alerts again that you previously dismissed with "Don't show again" checked.
Check for Updates
Change the settings in this tab to define when you want DEVONthink to check for new versions: never, on startup, daily, weekly, or monthly. DEVONthink only performs checks for updates when the computer is connected to the Internet.
Click Check Now to immediately check for a new version.
These options define some parts of the visual appearance.
Labels
Choose how you would like labels to be shown in lists.
Fonts
Use Sidebar Text Size to set the font size DEVONthink uses in the sidebars. Use View Text Size to set the font size used in the item list and the contents of sheets in table view.
Editing
The Editing tab defines all options that fine tune DEVONthink's text editing behavior, from the ruler units to default font settings to summarization options.
General
Note:
Hold the ⌥ Option key to restore the default fonts.
Full Screen
Select whether you wish DEVONthink to summarize based on sentences or whole paragraphs.
WikiLinks
WikiLinks are a way to create interconnected documents in your databases. When enabled, DEVONthink attempts to detect other documents matching the terms you've typed. This creates an active hyperlink to the detected document, allowing you to quickly jump to it by clicking the link. WikiLinked text displays with as underlined text.
WikiLinks
To enable WikiLinking, check the Automatic checkbox and choose from the options shown here:
Template
Text and items entered here will be used to create a new WikiLinked document. You can type any text you want as well as Control-click and use Insert Placeholder to insert a token that will be automatically replaced when the template is created. The default title contains several of these tokens already. Check out the placeholders section of the appendix for information on the available choices.
Import
Here you can choose options for the location, encoding, and tagging of files coming from external sources, including bookmarklets, DEVONagent Pro, items dropped on the dock icon, (external) scripts, or services.
New notes
Check Select (and display) automatically to automatically select and display the last note you have taken.
Choose the default destination where incoming data is stored.
Text Encoding
Choose the default encoding used for plain text documents. Select Automatic to let DEVONthink choose the best encoding.
Tags
Imported files can have metadata that may be useful as tags. Choose options to convert specific types of information to DEVONthink tags.
These options are honored by email archiving, scanning and OCR, importing from Bookends, Evernote, Apple Notes, and Yojimbo, as well as documents created via the Sorter and the web interface (Server edition only).
Sorter
The Sorter preference allows you to choose the window's appearance and location, and assign a hotkeys for capturing data or taking a new note. [Read more...]
Appearance, Location,…
Hotkeys
Set system-wide hotkeys for: Take Note, Copy Selection, Clip to DEVONthink, and Search.
To change the hotkeys, click the Click to record shortcut button, then press the hotkey that you want to use. Press the ⎋ Escape key to cancel recording a new shortcut.
Note:
On macOS Mojave, you will be asked to grant Accessibility permissions for Copy Selection, and Automation permissions for Clip to DEVONthink.
Media
In the media preferences, you tell DEVONthink how to display multimedia files, images, PDFs and other documents. You can also set options to generate thumbnails for certain filetypes.
Colors
Label: Set the name of color for color labels applied to files and groups in your database.
Highlight: Set the name and color to be used for highlighting text in compatible file formats, like PDFs.
Note:
These are global settings, i.e., you can't have per database label or highlight colors. Also, following Apple's example, we only allow setting seven colors in each category.
Web
The web preferences resembles the settings of most web browsers. Use these preferences to define how DEVONthink's displays web documents and "live" web pages.
Web Content
These settings define how DEVONthink treats special web contents:
Images
These settings define how DEVONthink displays graphics in web pages:
Accept Cookies
Cookies are little text files with information that web pages store on your computer use to recognize you as a returning customer, among other things. While most cookies are harmless, you may want to control what is being stored on your hard disk.
Fonts
Set the fonts you want to use for displaying web pages; set separately for variable-width and fixed-width text.
Note:
Hold the ⌥ Option key to restore the default fonts.
Style Sheet
You can further control the way DEVONthink displays web pages by applying a CSS style sheet that changes the rendering on the fly.
Click Select and choose your style sheet to apply it to DEVONthink's integrated web browser. Note: This is for experts since it modifies how all web pages are displayed and can lead to undesired effects.
Text Encoding
Select your desired text encoding for displaying web pages. Automatic tries to choose the best available encoding. If this does not work for you, choose a more appropriate text encoding for your language group.
RSS
DEVONthink comes with built-in RSS capabilities that enable you to add RSS feeds to your database and have DEVONthink update them automatically. Use these preferences to define how often DEVONthink checks for new articles, whether to skip duplicates when updating feeds, when to remove older articles, and which CSS style sheet to use for displaying the articles.
Data
Here you can define custom metadata fields that can be assigned to your documents.
Custom Metadata
The Custom Metadata column contains a range of built-in fields, ready to use or modify, as needed. These cover a variety of common uses and a list of the pre-defined fields can be found in the Data section of the appendix.
Enable any field by checking the checkbox next to it. Use the buttons below the Custom Metadata column for extra options:
The order of the fields is also the order in which they appear in the Info inspector.
Note:
These options are also available from the contextual menu.
Properties
Use these controls to modify the properties of the selected field.
Note:
Please refer to the Data section for more detailed information on the data types.
Use these options to define how email is imported and displayed inside DEVONthink.
Conversations
Note:
These features only work if the email program maintains references to previous messages sent.
Messages
Message Content
Note:
The email message will be stored decrypted in the database package. Its contents are available from within DEVONthink and to other applications or Spotlight.
Note:
The first two options above only modify the display of email messages in the text view. By default, messages are displayed using QuickLook.
OCR
DEVONthink contains an optical character recognition (OCR) module that allows you to import scanned documents and make them searchable. These documents are "read" by the embedded OCR engine and stored as PDF files that contain an additional (invisible) text layer with the recognized, computer-readable text. Use these options to fine tune the OCR process.
You can import scanned documents, or scan them directly from within DEVONthink.
Convert Incoming Scans
Check Convert to searchable PDF to apply OCR to file that have been sent to DEVONthink from a known scanning software, e.g., ScanSnap Home. Choose the desired format of the resulting file: searchable PDF, RTF document, Word document, or WebArchive.
Original Document
Check Move to Trash if you want DEVONthink to move the original documents to the trash after they have been successfully imported using OCR. If files are converted by OCR within the database, the original document is deleted from the database. If files are converted at import, the original document is moved to the Finder's trash. Using this option is a great way to prevent your incoming group/folder or database from growing cluttered after OCR is done.
Note:
This option cannot delete files received from the ScanSnap software.
Check Enter metadata after text recognition to metadata entry dialog whenever a PDF is imported using OCR. Use this dialog window to enter the preferred document name, the author of the document, and any keywords describing the document. You can also adjust the timestamp of the PDF to the actual date of the paper document. The dialog window is shown when OCR processing has been completed.
When checked, the metadata entry dialog will appear whenever you scan a document or import an image file with OCR. You may want to switch this option off when you are scanning/importing multiple files in a batch.
Note:
Information you enter in this dialog will be available to Spotlight and can be changed in the Preview application. The title field will be used to name the document, the keywords will go into the Comments field, and the creation date will become the creation date of the document in DEVONthink. You can access this information in the Document Properties panel.
Check Compress PDF to apply compression to the resulting PDF, creating a smaller file. Compression only applies when adding metadata post-OCR or preserving annotations from an original PDF after OCR.
Resolution
Set the desired resolution for the image layer in the PDF. Only values between 150 and 300 dpi are allowed.
Auto correct
Check Deskew to allow DEVONthink to attempt to straighten the resulting PDF.
Check Page Orientation to allow DEVONthink to detect and correct the page orientation.
Dictionary and Languages
Custom Dictionary: Check Use Dictionary to use a custom dictionary of acceptable words. For example, you may have an unusual spelling of someone's name in some documents. You can enter the name as an acceptable choice for the OCR engine to choose from.
Click the Configure button to add custom entries for OCR detection. Note you can only have one dictionary, specified for the language chosen in the Language dropdown.
Languages: The Languages section of the OCR preferences lets you identify the languages of the documents you scan in. DEVONthink's OCR engines uses this information to improve the accuracy of the text recognition. DEVONthink comes with more than 150 different language dictionaries.
Select the languages you intend to scan or import with OCR. Set a primary language and add one or more secondary languages using the pop-up menu . Simply select the languages you want to use from the list on the right (Available) and move them to the left side (Selected) using the right-to-left arrow button. To deactivate a selected secondary language, select it from the list on the left and move it to the right using the arrow button. You can select a maximum of four secondary languages.
Note:
The primary language and the secondary languages are treated equally.
Imprinter
Imprints are custom bits of data that can be stamped onto images or the pages of PDF documents. Imprints can be used in a variety of ways, from stamping when an invoice was paid to adding specialized numbering. With the ability to include placeholders, you can create many kinds of watermarks for your documents.
Configurations
This column lists any custom imprints you've already created. Click an existing configuration to change its appearance or location on future documents, or click and release to change the name. Use the buttons below the Configurations column for extra options:
New Combined Configuration: Found in the action menu, this option allows you to create new imprints from your existing ones. This extends the usefulness of existing imprints.
From the action menu, select the New Combined Configuration option. Two panes will be displayed: Combined and a second Configurations pane. In the righthand pane, select an existing configuration and click the < button to add it to the Combined pane in the center. To remove an item from the Combined pane, select it and press the > button. It will reappear in the Configurations pane on the right. Combined items will be displayed in the order you add them. To see what the imprint looks like, press the Preview button.
Note:
DEVONthink remembers the location and styling of the individual imprints in a combined configuration.
General Options
Check Duplicate item before imprinting to duplicate the document before imprinting it.
Appearance
Use these controls to define the parts of the watermark, its font attributes, and the style of a containing box, if desired.
Note:
There is only one font style for the watermark. You cannot have mixed styles, e.g., displaying one word larger or in a different color.
Location
In the Location tab, choose and fine-tune the position of the watermark, as well as on what pages it will appear.
Server
DEVONthink features a built-in web server that allows you to share documents on your local area network, and optionally, over the internet. As soon as the web server starts, other users can use a standard web browser to search your database, view documents, and download them.
Note:
In order to operate properly, DEVONthink needs to be running and will only serve open databases.
Enter all necessary details in the General tab and define users and permissions in the Users tab. Then click the Start button to start the web server available to users whom you have allowed access.
As soon as the server starts, DEVONthink shows the name and two URLs for your database at the bottom of the window. Use either the Bonjour services list of the Bookmarks view in Safari or enter the listed URLs into the address field of your web browser to access your database. Use the numeric address if the Bonjour does not work for your network.
To learn more about using web sharing and how best to make your database available from the "outside" internet, please read on here.
General
Bonjour Settings
Use these settings to define your DEVONthink server's identity, everything from the name and port, to creating a certificate vouching for the "safety" of the server's activity.
Identity:
Security:
Note:
When using the server in administered networks, e.g., public, corporate, or educational scenarios, you may need to consult with the IT department for successful operation.
Users
User List: The Users tab on the left allows you to add and remove individual users, as well as set per database permissions for them.
Note:
If you have DEVONagent Pro installed, it will be added as a default user. This allows it to search DEVONthink's databases in the same way it searches other websites.
Database Permissions: The Databases list on the right allows you to set per-database permissions for the selected user. All open databases will be listed in this pane, followed by the permissions that can be set. When a user is selected in the Users pane, you can set specific permissions for that user. The permissions are as follows:
Note:
Right-click the database's name to quickly enable or disable all permissions for that database.
Technical Info: If you need more information on the activity of the web server, you can find some deeper details here.
Sync
DEVONthink allows you to keep your databases in sync with multiple Macs and iOS devices running DEVONthink To Go. Use these options to control which databases are synced, how often they're synced, with which locations. Learn more about synchronization and how to set it up in a separate part of this documentation.
Locations
The first column lists all sync locations you have set up. In addition it lists available direct connections and templates for quickly setting up new locations. Active locations are checked. Disabled, inaccessible, or unactivated locations are shown in grey. Locations that have an encryption key specified show a key icon to the right of the name.
Check any location to activate it. If it is not yet set up, DEVONthink will show a sheet requesting all necessary details. Only a subset of the following fields is shown, depending on the nature of the sync location:
Use the tools below the locations list for more options:
Action (Locations): The Locations Action menu also is used for information, troubleshooting, and removing chosen sync locations. In addition to Show Info, and Remove Location, it contains these special commands:
All the commands listed above are also available via the contextual menu.
Note:
You can also add existing local sync stores (packages with the file name extension .dtCloud) by dragging them into the locations list, DEVONthink's Dock icon, or by simply double-clicking them.
Databases
The second column lists all currently open databases as well as all databases available remotely in the selected location. The Local section lists all open database and a message about their sync status, e.g, the timestamp of the last sync. The Remote section lists all databases available for import or databases that are currently not open on the machine. When attempting to import the latter, the local database will be opened by DEVONthink.
Check any database that you want to have synchronized using the selected location. If the database is also already available through the location, both versions of the database will be merged and conflicts solved using the chosen conflict solving strategy (see below). Uncheck databases you want to discontinue syncing with the selected location.
Note:
Unchecking databases does not remove the sync data from the location. See the Clean Database command below or [Read more...]
Use the tools below the locations list for more options:
Action (Databases): The Databases Action menu also contains commands for importing, manually synchronzing, troubleshooting, and removing sync data. In addition to Import Database, Synchronize Database, and Refresh List, it also contains these commands:
All the commands listed above are also available via the contextual menu.
Note:
If you have specific databases you'd like to remove from a sync location, e.g., old, no longer used or test databases, the Clean Database command can be used on select databases in the Remote section of the Databases list.
Change the general sync settings, noting they affect all locations and databases.
Note:
The number of maximum connections used is controlled by the service you're using.
Click the button Bonjour Options to control if and how other instances of DEVONthink or DEVONthink To Go can connect to your Mac. Your Mac becomes the sync host or sync server, the other devices the clients.
Troubleshooting
DEVONthink was created with robustness in mind. But any computer hardware or software, regardless of how carefully developed and built, can write defective data or destroy files. If you have some general questions about DEVONthink, sales and licensing, etc., plase check out our Questions and Answers section on our site. If you experience specific technical problems with DEVONthink or its databases, please check the following sections.
If you have checked the appropriate sections and didn't find your issue or a resolution, please do the following: Hold the ⌥ Option key and choose Help > Report Bug. This creates a draft email, ready to send to us, containing troubleshooting information and logs.
Note:
The industry standard turnaround in software development is 48 business hours, i.e., weekends excluded. However, we usually respond earlier. Thanks for your patience and understanding.
Problems importing files
Why does DEVONthink not recognize my files?
If DEVONthink does not recognize a file, make sure the file has a proper file name extension. DEVONthink needs a file name extension to determine the file type. Add the correct file name extension to your files (e.g., .txt for plain text files, .rtf for rich text files, .pdf for PDFs and .doc for Microsoft Word files) and try again.
Also, while DEVONthink supports importing many different file types, there are thousands of types and we can't guarantee trouble-free importing or usefulness with every type.
Why does DEVONthink not display my document correctly?
DEVONthink uses Apple's Quick Look technology to display previews of many file formats. If a document is not properly displayed, especially if it is a proprietary file format, it may be you don't have a Quick Look plugin installed for this file type or the application that created the file is not installed on your Mac (and supports Quick Look). Control-click the file and choose Show In Finder to reveal it. With the file selected in the Finder, press the spacebar to open a Quick Look window to determine if the item is viewable.
Why isn't my PDF working?
Bad PDFs: PDFs have been around so long, it would seem they'd be easily supported in DEVONthink. However, the truth is there are many bad PDFs out there. If you encounter a bad PDF, try acquiring a new copy of the file.
No Text: You will receive a "No Text" log message with PDFs having no text layer, i.e.,, scans that have not had OCR run on them. In order for their text to be searchable, you must run OCR on them.
Protected PDFs: DEVONthink cannot extract the text part of print- or edit-protected PDFs. When you import these PDFs, you get a log entry that tells you that the file contains "no text". When you select these PDFs in DEVONthink, the status bar shows Image instead of PDF+text.
One potential solution for this problem is Michele Balistreri's PDFKey. It allows you to print protected PDFs. Use PDFKey to "print" a PDF file into a new PDF that is both printable and editable, which allows DEVONthink to extract the text for searching and classifying.
Note:
There are sometimes questions regarding the PDF functionality available in other applications. DEVONthink uses Apple's PDFKit framework, the same as found in their Preview application. If you have an issue with a PDF in DEVONthink, check to see if you have the same issue in Preview. Other applications, including those from Adobe where PDFs were invented, are using their own frameworks.
Email import does not work as expected
Messages aren't imported or can't be filed: Email messages are imported with a special identifier (UUID) that helps DEVONthink keep track of messages that have already been imported. Since a UUID must be unique, you can't have more than one file with that identifier. If you try to import the same message into a database, you will receive a logged message stating "n emails already imported".
Importing takes a long time or stalls: Importing email is not a trivial process. Not only does it copy the message into your database, but it also reads and analyzes the entire contents of each one. If you are importing a large mailbox, the process could cause a timeout.
To increase the timeout to five minutes, please enter this in /Applications/Utilities/Terminal.app (each as a separate command) while DEVONthink is not running:
Terminal:
$ defaults write com.devon-technologies.think3 MailImport.FetchTimeout -float 300
$ defaults write com.devon-technologies.think3 MailImport.Timeout -float 300
Another possibility is to split the mailbox into multiple smaller ones. Lastly, you don't have to import the entire mailbox at once. Importing smaller batches often proves to be less taxing on the machine's resources.
Why can't I import from email application X?: Inter-application communication, something at which DEVONthink excels, isn't universally developed. In order for more true automation between applications to occur, the developers need to implement robust and reliable mechanisms, like AppleScript. Some apps may provide simple URL schemes but they are limited in use and capabilities, often only able to process one file at a time. Better results can usually be had by merely dragging and dropping. For email clients with a good AppleScript dictionary, the potential for streamlined workflows is increased.
Note:
If you are running macOS Mojave or later, you will need to give permissions for the Apple Mail plugin to access your email.
Unlocking a database
If you open DEVONthink and see an icon of a crossed pencil to the right of the database's name, the database has a file permissions issue. This makes the database readable, but not writeable, so you can't modify the contents in any way.
A permissions issue like this uncommon but generally caused by three events, in order from most to least common: restoring from Apple's Migration Assistant, restoring from Time Machine, or an operating system or hardware error. Doing things like using Migration Assistant will not always cause a permissions issue, but if you have a crossed pencil icon and you've recently migrated to a new machine, this would be the likely cause.
To resolve the issue, do this:
If this does not resolve the issue, please contact our support team.
Problems using Services
Why do the Services menu commands show no shortcuts?
They should; however, the keyboard shortcuts for Services menu commands are only requested by the supplying application. macOS assigns these shortcuts and has ultimate control over which application or service gets what. If the DEVONthink Services menu items do not have shortcuts assigned, it is likely that macOS assigned these shortcuts to another command, or that they are used by the current active application.
Why do specific services not appear in the menu?
The operating system relies on information supplied by the current application to determine which services should be shown in the Services menu. For some applications, often those developed for both Mac and Windows, this information may not be what's anticipated. When this occurs, certain services may not be present. For example, selecting text on a web page in Firefox will display the service DEVONthink: Take Plain Note. The same text on the same page in Safari will show that option as well as DEVONthink: Take Rich Note.
Sync Issues
DEVONthink's synchronization was designed to run in self-maintenance mode. If you are having issues syncing your DEVONthink databases, the first place to look is Windows > Log. Most sync related errors and reports will be shown here.
Below we cover some things you can check for the type of sync method you're using as well as some common questions you may have.
Things to Try First
Here are a few general things to try when you have a sync issue:
Verifying: If there is an issue reported with syncing, e.g., broken structures or missing manifests, you can verify the sync data to see if it's intact and consistent. Verification is a good first step in these cases. The results of a verification will be reported in the log window.
Cleaning: If the verification fails, you can clean the sync location or database to remove the sync data in that location. The results of the clean will be reported in the Log window. After a successful clean, you can upload the database(s) again.
Note:
To ease anyones' mind, cleaning a sync location has no effect on the local databases on your devices. Sync data is not your database and is separate from the local databases on your devices, Mac and mobile.
To verify or clean sync data, open Preferences > Sync and…
Both these actions can be used at any time, for preventative purposes or just to get a fresh start with syncing. Also, you may see unwanted databases in the Remote section of the databases list for a sync location. Cleaning the location will remove these databases too. But if you want to keep the sync data for your current databases, you can Control-click and clean specific databases in the Remote section.
Bonjour
Bonjour syncs are generally transparent, but it can only be used on a local network that allows Bonjour traffic and non-standard ports. Many public networks disallow this kind of traffic to protect their customers. Also, corporate networks will often disallow this traffic for security reasons.
Note:
Bonjour connections cannot be used over VPN. This is technologically infeasible, at least at the moment.
If you find yourself on a network that disallows Bonjour syncing, it is possible to connect your iOS device to your Mac via your Lightning cable. This creates a simple ad-hoc network that will allow Mac-to-mobile syncing. If you are in a corporate situation, please discuss this with your IT department to ensure you're not violating any security policies. They may also issue an exception for a specific port you could use for Bonjour syncing. This port would be entered in the Port section of the Bonjour options.
iCloud
Since your devices are generally signed into your Apple ID, using iCloud for syncing is the easiest to set up. However, it should be understood it can only be used for personal syncing. Collaborative syncing is not possible unless all participants are sharing an Apple ID.
Also, syncing to iCloud is done locally first, the operating system will then upload the changes to Apple's servers and propagate the information about it to all other devices. It generally happens smoothly and in the background but it means you can't expect the changes to be ready on other devices as soon as DEVONthink has finished synchronizing to iCloud.
Here are a few things to check:
Note:
Be aware iCloud can stall. This is a sporadic, but documented, issue that can cause your devices to get out of sync. This is not under our control, nor can we even detect it. Please try a thorough verification of the sync location first. For further help, contact our support staff for assistance.
WebDAV
Our support for WebDAV services allows you to use cloud services that are WebDAV-enabled. It also presents some self-hosting options, even with some NAS devices. However, they can sometimes be technically more difficult to implement. Here are some things to check:
Note:
WebDAV implementations vary so it's not possible to guarantee compatibility in all situations. For self-hosting, Apache implementations are the most compatible.
Dropbox
Dropbox is our longest supported sync method and is generally reliable and a good performer. However, there are a few things to consider.
According to Dropbox' rules, you cannot sync across user accounts. You also can't share the Apps folder between accounts. Also, they only allow our sync engine to be logged into one Dropbox account at a time. If you have a work and a personal account, you can only sync to one with DEVONthink.
Collaborative syncing may be possible using a common Dropbox account, i.e., using the same username and password for syncing. But again, you can only sync to one active Dropbox account at a time.
I enabled the sync and nothing's happening: Our sync engine will not sync, upload or download, without being told to. We believe in opt-in processes whenever possible. Merely enabling a sync location just sets up a location to be ready to receive and transmit data. You need to enable individual databases to sync. If you have enabled databases to sync, check Window > Log for errors.
I'm seeing a message about an invalid encryption key: When you set up a sync location, you have the option of entering an encryption key. This is used to scramble and descramble the sync data so it's stored in an encrypted state. Once you've synced the first time, this value, even if you aren't specifying a key, is stored for that sync location. This value must be entered on other devices syncing with this sync location.
You can't add, remove, or modify the encryption key value for a sync location after the first sync. If you want to make a change, you must clean the sync location first. After, the clean, Control-click the sync location again, choose Show Info, and make the modification to the key. After the first sync, this will be the value stored for the location. Remember, you must change the value on the other syncing devices. And no, you do not need to do the clean on the other devices before changing the value.
I am seeing a message about missing manifests: Missing manifests are bits of transactional sync data that cannot be located by the sync engine. When this occurs, it can't validate the information about what has been synced. This is not an issue with the databases. See the Verify & Clean section above regarding verifying and cleaning the sync data.
It's telling me I have a duplicate database UUID: As noted in the glossary, a UUID is a unique value given to all DEVONthink databases. If you copy and rename a database file in the Finder, this UUID is preserved and DEVONthink sees two databases with the same UUID. This will not sync correctly. Please contact our support team for assistance on resolving this.
Repairing a defective database
DEVONthink databases are packages containing of your files and the supporting AI-based index. In rare cases this index can get corrupted or out-of-sync. But as your files are stored separately, this is not the end of the world. If your database starts behaving strangely, or if DEVONthink finds inconsistencies during start-up, it is time for some housekeeping.
First we'll deal with the two common terms you'll see in a repair process: missing and orphaned files. Then we'll give you steps to try and restore some order in your databases.
Missing Files
All documents in a DEVONthink database have a path the file system where their content file is located. This path is stored for every document, imported or indexed. If DEVONthink can't find a file at a path stored in its index, it will be reported as missing.
The most common cause of missing files is indexed files being moved in the Finder, or the indexed parent folder being renamed. In the first case, the file isn't in the location it was indexed from. Moving the file back into place will resolve this issue. In the second case, the path no longer exists as the names in the path have changed. Changing the name back will resolve this.
The second most common cause of missing files is people modifying the internal contents of a database. Some Finder replacement applications, like PathFinder, allow you to access package files like normal folders. The internals can also be accessed by other methods, like the command line or the Finder's contextual menu. If you delete or reorganize anything, you can easily cause missing files.
Dealing with missing files: Missing files are reported in DEVONthink's Window > Log. To deal with these files, Control-click the item in the Log window and choose one of two options:
Orphaned Files
Just as with any database application, controlling the data flow in and out is a critical process. DEVONthink should be the gatekeeper of the files in its databases. If an external agent, whether and application or a user, adds files outside DEVONthink, they will cause an internal inconsistency and lead to orphaned files when following the steps below.
The most common cause of orphaned files is a simple and common one: attempting to create revisions. Say you open a file, a Word document, in an external application. As you are reading it, you decide to make some changes. You type your edits, and select File > Save As (or File > Duplicate the file first). The application most commonly will open the Save dialog in the location of the original file, in this case, inside the internals of the database. You have just created an orphaned file DEVONthink knows nothing about. So the question becomes, how do I create a revision without causing this issue?
The other common cause is the same as with missing files: getting into the database package and adding files manually.
Note:
Modifying the internal contents of a database outside DEVONthink is unsupported behavior and can lead to broken or inconsistent databases. You should only get into a database's internals when instructed to by our support team.
Step 1: Verify & Repair
As a first step, use >File > Verify & Repair Database to check your database's consistency and allow DEVONthink to take all necessary steps to repair any discovered problems. This check will include reporting any missing files, as discussed above, and importing any orphaned files. If Verify & Repair Database was able to repair your database, use File > Optimize to optimize your database and have DEVONthink create an internal copy of the index.
Note:
Verify & Repair isn't just for emergencies. Running this command on an occasional basis is not a bad idea. In fact, if you're a fairly heavy user of DEVONthink, running it weekly or bi-weekly does no harm. It's just a routine checkup.
If Verify & Repair was not successful or your problems are not resolved, proceed with the next step.
Step 2: Restore from Backup
DEVONthink keeps up to two copies of the index files in case that the index is damaged beyond repair.
To restore the index file(s) from a previously saved internal backup, hold the ⌥ Option key and select File > Restore Backup. DEVONthink presents you with a list of all available backups. Choose the latest one and click Open. This swaps the current set of index files with the chosen backup metadata (the current set of index files becomes the backup, the backup becomes the current set) so that data is never overwritten. Run File > Verify & Repair to check the consistency of this index version and if everything is in the right order use File > Optimize to optimize your database and have DEVONthink create a fresh internal copy of the good index.
If the backed-up index files are also defective, try the other backups, if available. If all backups are broken or corrupted, proceed with the next step.
Step 3: Rebuild Your Database
Since your files and DEVONthink's index are stored independently within the database package, the index can be rebuilt at any time without you losing metadata. However, we generally only suggest this when troubleshooting a database issue.
To rebuild the database from scratch, use File > Rebuild Database. During the rebuild process, the index is completely recreated. Your actual files are not touched. Any problems that occur during this process are logged. Also, a new backup metadata set will be created at the beginning of the rebuild.
Step 4: Recover or Manual Rebuild
If everything above failed, your database is severely damaged. You have basically two options:
Time Machine: Restore your database from your Time Machine backup or whichever backup medium you use. If you don't use Time Machine, we strongly advise you to do so. External hard disks are cheap, and Time Machine makes backing up your important files quick and simple.
Manual Rebuild: If you find yourself in the unfortunate situation where you have no backups, it may be possible to rebuild your database manually, following these steps:
Step 5: Contact Support
If none of the above steps helped solving the problems you have with your database, please contact us with a precise-as-possible description of your problem.
Note:
In a worst case scenario, if you do not have a current backup of your documents and a manual rebuild didn't work, you can rescue your files manually, but you will lose any group structure. To manually copy your files from the defective database, show the database package in the Finder, Control-click it, and choose Show package contents from the contextual menu. Copy the files in the Files.noindex subfolder, which are sorted by kind, to a safe location, e.g., the desktop. If you want, you can create a new database, re-import the files, but you will have to rebuild the database's structures, tags, etc.
DEVONthink crashes
If DEVONthink crashes while it's running, please hold the ⌥ Option key and choose Help > Report Bug.
If DEVONthink crashes on startup, there is no opportunity for you to use our bug reporting mechanism. However, you can manually retrieve the crash logs:
In either case, please try to reproduce the crash before reporting it. Also provide enough detail about what you were doing at the time of the crash.
DEVONthink behaves irrationally
No software on this planet is bug-free, and if an application behaves irrationally there is a good chance that your have just found a bug. But there could also be another cause: The application package could have become damaged during an update or through a bug in a totally unrelated piece of software on your computer.
Strange Application Behavior
If you see odd behavior like
the first step is to reboot the machine.
If that doesn't resolve the issue, try deleting DEVONthink's preferences files. Please quit DEVONthink, launch Terminal app, and enter this:
Terminal:
$ defaults delete com.devon-technologies.think3
Note:
Rebooting a machine can often cure a host of issues, closing down rogue processes, releasing memory, etc. We suggest rebooting your devices at least once a week, just to mitigate potential issues.
Strange behavior related to documents
If the strange behavior only happens with a particular document, it is possible the document is damaged, was created in a very old or extremely new file format that is no longer or not yet properly supported, or uses a damaged or malfunctioning Quick Look plugin.
Please file a support ticket and attach the document in question, packaged as a .zip archive, so that we check to see if the problem lies with DEVONthink or if it the file itself.
Automation
Automation. No matter how efficient we are, there is always some process that could be done more quickly, and sometimes more accurately. This may be as simple as renaming a file, or as complex as filing, emailing, and archiving. While not everything can be automated, and careful thought should go into your automation plans, DEVONthink offers a level of automation capabilities rarely rivaled in other Mac applications.
AppleScript: Most of DEVONthink is built on a solid foundation of AppleScript. Not only used in the scripts you can install from DEVONthink > Install Add-Ons, they are also at the core of several pre-installed templates. Additionally, in conjunction with other AppleScript-enabled applications, the potential for automation on your Mac is extraordinary. This mature but easy to learn technology is the one we will focus on. [Read more...]
Smart Rules: DEVONthink also offers a technology for those with little to no programming experience: smart rules. Smart rules are conceptually similar to smart groups but allow you to choose pre-defined actions to take on matched items. This makes them accessible to all users, while still providing AppleScript execution in the smart rules. They also allow automation based on events. [Read more...]
Item Links: While not an automation technology in itself, item links are item-specific identifiers in DEVONthink that can be used in automation. Providing a way to refer to files by a unique and unchanging value, they can help avoid automation problems when items are moved or renamed in your databases. [Read more...]
JavaScript: In addition to AppleScript, JavaScript for Automation (JXA) is supported. However, it is bridged by the operating system from AppleScript, not specifically coded for. We advocate AppleScript for its ease of use by new and less-experienced programmers.
On a side note, our AppleScript dictionary has a do JavaScript command you can use to interact with web content viewed in a DEVONthink window. With a bit of creativity, some pretty amazing things can be done!
AppleScript Objective-C: This is supported, for those who are inclined that direction.
Terminal: For those who are into other technologies, like Python, bash, Ruby, etc., the question arises: Is there a command line interface (CLI) for DEVONthink? The answer is no. However, you can still use a do shell script command in AppleScript when needed. Actually, the combination of the shell and AppleScript creates even more opportunities, as their individual strengths compensate for the other's weaknesses.
AppleScript
AppleScript is an automation technology introduced by Apple in 1993. Over the years it has matured and become the friend of many Mac users wanting to exert more control over their computing experience. Written in an easy to learn, almost conversational language, it offers a tremendous amount of power with less effort than many languages. DEVONthink has very robust AppleScript support and comes with many built-in scripts. These, and those you write or obtain, make it possible to automate nearly every aspect of the application, and to integrate the application with almost every other macOS application that supports AppleScript.
Add-On Scripts: All add-on scripts that come with DEVONthink are automatically installed or updated when you open a new version of DEVONthink for the first time. You can, however, manually (re-)install them by choosing DEVONthink > Install Add-Ons. The scripts from this panel are installed in a number of locations:
DEVONthink Scripts: The internal scripts found in DEVONthink's Scripts menu are installed in ~/Library/Application Scripts/com.devon-technologies.think3. The scripts will be found in one of four directories:
Additional scripts, like those you write yourself, can be put into any of these folders to be used in these contexts. Other scripts that may include integration with DEVONthink can be located wherever it's convenient.
Script Shortcuts
Many people like mousing around their applications, while others like to use their keyboards. If you want to add keyboard shortcuts to scripts in this menu, you have two options:
Note:
When using macOS Mojave, you will often be prompted by the operating system to allow applications to "control" on another. These permissions are stored in System Preferences > Security & Privacy > Security > Automation. Please make sure to allow any requests of these kind regarding DEVONthink's control of other applications or your automation attempts will fail for obvious reasons.
Learning AppleScript
While this documentation is not an AppleScript language guide, all the scripts that come with DEVONthink are editable and can be explored or modified as you see fit. The separate sections in this chapter provide any required terminology and a simple example script or two. Additionally, there are some great resources available online and in print. For the official archived documentation, refer to Apple's AppleScript web site. Some additional resources are listed below:
Online:
Books:
Basic AppleScript Terminology
AppleScript is not a difficult language to learn. Its plain English approach of "talking" to applications and elements is easily understandable. However, like any language, there are some variations in the words you can use; dialects, if you will. AppleScript is implemented by the developer of an application, so the commands and parameters may be conceptually the same as another application's, but using a different term. This is certainly not meant to be a complete guide to AppleScripting DEVONthink, but what follows are some common terms or concepts you're likely to encounter. The examples here and in this chapter are meant to give you basic ideas about scripting DEVONthink.
Talking to DEVONthink
In AppleScript you "talk" to programs like DEVONthink using a tell statement, typically referring to an application either by its name, "DEVONthink 3", or its bundle identifier, "com.devon-technologies.think3". While these forms will work, they might become incompatible with a future version, e.g., DEVONthink 4, so we strongly recommend to talk to DEVONthink using the application ID DNtp, like in the following statement:
Example:
tell application id "DNtp"
close current database
end tell
AppleScript-capable applications have their commands, elements, and properties listed in an AppleScript dictionary. DEVONthink includes a large dictionary as a great reference for you. To view the dictionary, open the Script Editor application, select File > Open Dictionary and choose DEVONthink in the appearing window. You can also add DEVONthink to your Script Editor library. Select Window > Library, click the + button and choose DEVONthink. This way you keep DEVONthink's dictionary at hand.
Note: The use of the is almost always optional, but including it can make the script seem a bit less robotic. For example, both lines in this script are functionally the same:
Example:
tell application id "DNtp"
set state of children of current group to true
set the state of the children of the current group to true
end tell
As noted above, the dictionary is the best place to find specific terminology to be used with DEVONthink. However, here are two things to understand:
Records: Every item in a DEVONthink database is a record, a record with properties. Do a search for "record" in the dictionary and you'll see it's a fundamental unit with a wide range of properties associated with it. This means you won't be writing code like, get the second rich text file…. You will be dealing with records with a particular type, in this case rtf.
There are many commands specifically for use with records: create record with, exists record with…, etc. Also note there are some commands that require the term record. For example: move, delete, and convert. You will see a dictionary listing move record, so you can see the command isn't merely move, it's move record.
Parents and Children: Another concept to understand is parents & children. Generally speaking, these classes deal with the container or the contents of some object. The parent of an object is the group containing it. The children of a group are the immediate contents of that group, i.e., it does not list the children of sub-groups. Children can be documents or groups; parents will only be groups.
Example:
tell application id "DNtp"
set thisGroup to current group
name of (the children of thisGroup whose (type is XML))
end tell
Using Locations
One of the common tasks people want to perform with AppleScript is importing files to a specific group. In order to direct the files to a given location, you need to reference it properly. Below are three general options for choosing a location:
There are many times you want to direct files into a specific group. That group may not be the current group you're in and you may not want to choose a destination each time. Here are two common ways of specifying a particular group in your database to be a destination group in your script:
Example:
tell application id "DNtp"
set myGroup to get record at "/Inbox/New Files"
import "~/Desktop/001.txt" to myGroup
set groupTwo to get record with uuid "98BBF96D-7743-46C6-9EB4-51C6EF68373C"
import "~/Desktop/002.txt" to groupTwo
end tell
Working with a selection
Many times you want to process items you have selected in DEVONthink. Perhaps you want to generate a list of names and dates for use in a document you're working on. Below is a handler commonly seen in DEVONthink scripts:
Example:
tell application id "DNtp"
if selection is not {} then
set nameList to {}
repeat with thisRecord in (selection as list)
copy ((name of thisRecord) & ": " & (creation date of thisRecord as string) & return) to end of nameList
end repeat
create record with {name:"Files", type:text, content: (nameList as string)} in incoming group
end if
end tell
Internal Scripts
The Scripts menu of DEVONthink, located to the left of the Help menu, gives you access to a large number of pre-made scripts, with more scripts available. These scripts are not only useful for every day use, but are also great for learning how to script DEVONthink.
All the scripts we provide are editable using the Apple's Script Editor, though we do suggest making copies to work on. They are located in ~/Library/Application Scripts/com.devon-technologies.think3/Menu. Open this folder in the Finder with Scripts > Open Scripts Folder command. Add your own scripts to the menu by adding them to the appropriate subfolder in this directory, even creating subfolders of your own.
A complete listing of the installed scripts can be found here: [Read more...]
Triggered Scripts
Triggered scripts are AppleScripts that you attach to an item in DEVONthink (a group or document) and that are executed each time you select the item. Items with attached triggered scripts show an AppleScript icon behind their name.
Using triggered scripts, you can add your own custom behaviors when interacting with items in your database.
Attaching a triggered script
While it's possible to write a script that specifies a triggered script for an item in DEVONthink, the usual method is manually attaching one.
Removing a triggered script
Since a triggered script runs when you interact with the item, it can sometimes be difficult to detach the script, e.g., if a script switches to another application when triggered. For instances like this, to remove a triggered script from an item do the following:
Terminology
Triggered scripts are defined by a specific handler: on triggered(var), where var is the variable representing the item the script is attached to.
Example:
on triggered(theRecord)
tell application id "DNtp"
display alert "" & (name of theRecord as string)
end tell
end triggered
Reminder Scripts
Reminders have several pre-built alarms available for notifications. However, you can only specify one alarm per reminder. Reminder scripts are AppleScripts run by an alarm set on a specific reminder for an item. By using or writing your own, you can extend notification possibilities of your reminders.
To add an external script as an alarm for a reminder, choose Execute External Script. The next dropdown lists any available AppleScripts in the ~/Library/Application Scripts/com.devon-technologies.think3/Reminders directory. Add any of your own scripts to this directory to make them available for any alarm you set.
Currently, there is only one example script pre-installed:
Adding an Embedded Script
Sometimes you only need to add a script for a specific purpose, not general use with all reminders. DEVONthink allows you to quickly write an ad-hoc AppleScript specifically for the current reminder.
To write an embedded script for a reminder, choose Execute Embedded Script as the alarm. Click the … button and a popup will appear with a pre-built handler in place. Add your code as necessary, then press the compile button, the one with the stylized eye, to make sure it compiles correctly. If it does, you will see the code format itself subtly. If not, you will hear a system alert. Click outside the popup to dismiss it. When the alarm goes off, the script will be executed.
Note:
When a reminder is set to Once, the reminder is removed and the embedded script lost after the alarm goes off. If you have code you'd like to potentially use again, put it in an external script.
Terminology
Triggered scripts are defined by a specific handler: on performReminder(var), where var is the variable representing the item the alarm is set for.
Example:
on performReminder(theRecord)
tell application id "DNtp"
set label of theRecord to 1
say (name of theRecord as string)
end tell
end performReminder
Toolbar Scripts
Scripts can also be added to the toolbar of any DEVONthink window. While there is a limited amount of space available in a window's toolbar, this is a handy way to launch commonly used scripts with one click.
To add a toolbar script place the script into the folder ~/Library/Application Scripts/com.devon-technologies.think3/Toolbar. In order for the script to be available for use in the toolbar, you must quit and relaunch DEVONthink. Then Control-click the toolbar of a DEVONthink window and choose Customize Toolbar. Drag your script into the toolbar and it's ready for use.
Terminology
Unlike some other script types, there are no special handlers required for a toolbar script. You only need valid AppleScript talking to DEVONthink.
Example:
tell application id "DNtp"
open tab for record (content record)
end tell
Smart Templates
Some of the DEVONthink provided templates are "template packages" (.dtTemplate) and "smart templates" (.templatescriptd). Both templates provide a great deal of flexibility and power, like allowing for inclusion of language resources. With some creativity and scripting know-how, you can set up everything from commonly used group hierarchies to daily journal entries and much more.
Template packages
The simpler type of automated templates DEVONthink supports are: template packages. These are folders with the file name extension .dtTemplate that contain one or multiple .lproj folders, one for each supported language. Depending on the system language, you can let DEVONthink import the files in the correct language. If you inspect the contents of a template package, e.g., Classifications > Decimal Filing System.dtTemplate, you will see the project folders and their assets as a great example of this type of template.
Smart templates
The more advanced type of automated templates are smart templates. These are not simple files, but actually AppleScript packages containing script code, and often including related assets that can be inserted into your database. This allows for some very powerful actions like:
Creating Templates
Template Packages: To create your own template package, you can duplicate an existing template, Control-click it, choose Show Package Contents and edit the internals as needed. Also note exporting multiple selected files will yield a template package.
Smart Templates: To make your own smart templates, have a look at the prefabricated smart templates. Duplicate a .templatescriptd file, like the "Note" template. Control-click it, and choose Show Package Contents. You can inspect and modify the supporting assets and the main.scpt file to fit your needs.
Template Placeholders
Placeholders in templates are simple control codes that are replaced by DEVONthink when a template file is imported. These placeholders can be used in your files, including simple templates, or folder names of your templates packages. When used in files, they are typed in the text of DEVONthink-native files; e.g., plain or rich text, Markdown, etc. These can be manually typed or you can Control-click in the text and choose Insert Placeholder. Below is a list of valid placeholders:
Note:
There are more placeholders from the contextual menu than can be used in a template. For example, the placeholder %record_locality% relates to an existing record, so this placeholder will not be used when creating a file from a template.
Custom Placeholders: One more powerful feature of smart templates is the ability to define custom placeholders, extending the possibilities beyond the list shown here. This allows you to add a custom placeholder in the text of a template, then define the replacement value for that placeholder in the main.scpt. As a great example, check out the use of the custom %project% placeholder in the Project smart template. Notice the use of the placeholder in the enclosed rich text file and the script.
Terminology
With the internal script of a smart template, there are no special handlers required. However, the internal script must be located in the Contents/Resources/Scripts folder inside the package, and it must remain named main.scpt. Beyond that, you only need valid AppleScript.
Smart Rules
Smart rules are smart groups‚ evolved. Built in the same style as smart groups, smart rules don't just show items matching criteria, they can act on them! From something as simple as adding (or changing) a color label, to modifying a filename then filing a document in another location, smart rules provide some powerful automation possibilities. And they're not just for the technically inclined. No programming experience is needed for almost every action available.
Smart rules are conceptually simple and can be summed up as follows: When this event occurs > do this action > on items matched > in this location. Smart rules are made of four parts:
Create a Smart Rule
Smart rules can be created in one of two ways:
Note in either case you can change the Search in parameter to target other locations, including all open databases.
Note:
Smart rules are considered global objects and can be created only in the Navigate sidebar of a main window. If you want to create a smart rule for a group in the item list, choose Data > Reveal to display it in the sidebar.
When you create a new smart rule, you will be shown the predicate editor, just as you see with smart groups. Just follow these simple steps to define the parameters of the rule (with an example):
This rule shown above would add "_edited" as a suffix to the name of any edited images whose name begins with "screen".
One step further‚ chained actions: If you hadn't noticed, there's a + button to the right of the action you specified. And yes, that means you can chain multiple actions in a smart rule! For example, we could add an action to open the edited imaged in the system default application after it has been renamed.
Note:
Bear in mind, smart rule actions run in series, i.e., the actions run from top to bottom, first to last. This means the order of the actions affects the outcome. Think carefully about this if you decide to create chained actions.
We hope this has given you a good overview of creating a smart rule. Please see the appendix for a complete list of available Events and Actions.
For those interested in the Execute Script action, continue to the next section…
Importing and Exporting
Smart rules can be exported to the Finder, sent by email, and e.g., reimported to DEVONthink on another Mac. Drag a smart rule to the desktop to save it to a file or Control-click it and choose Export. Double-click a saved smart rule to import it, drag it into the sidebar, or Control-click into the sidebar and choose Import.
Smart Rule Scripts
Smart Rule scripts are AppleScripts run by an Execute Script action in a smart rule. These scripts allow you to extend the possibilities beyond the already powerful pre-defined actions.
Note: Smart rule scripts will be executed based on the event handler in the specific rule. For testing, it can be useful to set the event to On Demand. This way you can select the rule to see its matches, then Control-click it and choose Apply Rule to run it and see the effects on the matched items.
Also be aware the effects of smart rules are very broad, i.e., they affect all the items they match. While you are testing, it's a good idea to put some limiting criterion in place. For example, instead of matching all images in all databases, try matching images in a specific group or only images that begin with "Screen".
Adding an External Script
To add an external script to a smart rule, add an Execute Script action and choose External. The next dropdown lists any available AppleScripts in the ~/Library/Application Scripts/com.devon-technologies.think3/Smart Rules directory. Add any of your own scripts to this directory to make them available for any smart rule you define. Here is a list of the pre-installed scripts, for everyday use and your education:
Adding an Embedded Script
There are times you may need to add some code for a specific situation. Similar to some other macOS utility applications, DEVONthink allows you to write an AppleScript directly in the smart rule's editor.
To write an embedded script for a smart rule, add or specify an Execute Script action and choose Embedded. Click the Edit Script button and a popup will appear with a pre-built handler in place. Add your code as necessary, then press the compile button, the one with the stylized eye, to make sure it compiles correctly. If it does, you will see the code format itself subtly. If not, you will hear a system alert. When done, click outside the popup to dismiss it
Note:
For those learning AppleScript, the repeat loop in the pre-built handler is a very common (and useful) code snippet for processing all files returned by a smart rule. Take note of it.
Terminology
Smart Rule scripts are defined by a specific handler: on performSmartRule(var), where var is the variable representing items matched by the smart rule.
Example:
on performSmartRule(theRecords)
tell application id "DNtp"
repeat with theRecord in theRecords
if (name of theRecord as string) contains "Piglet" then
set state of theRecord to true
end if
end repeat
end tell
end performSmartRule
Apple Mail Rules
When considering importing emails into your DEVONthink databases, the question of "automatic" email importing invariably comes up. While this isn't fully possible yet, there is a mechanism in Apple Mail that can provide some level of "automatic": Mail Rules.
Found in Apple Mail's Preferences > Rules, these are a rules consisting of criteria to be matched and an associated action (similar to smart rules). As incoming emails are detected, Mail will check for matches in a rule and execute any actions you've specified in the rule.
One of the actions available is Run AppleScript. Selecting this option shows a dropdown with any installed Mail Rule scripts. These scripts are installed in ~/Library/Application Scripts/com.apple.mail folder. If you write or obtain other scripts for use with Mail Rules, they can also be placed in this directory. The scripts provided by DEVONthink are:
Terminology
A full lesson on writing scripts for Mail Rules is beyond the scope of this help, but you can open and explore the installed scripts.
Do note there are two required handlers: using terms from application "Mail" and on perform mail action with messages theMessages for rule theRule, where theMessages is a variable representing the items matched by the rule. Here's a simple example:
Example:
using terms from application "Mail"
on perform mail action with messages theMessages for rule theRule
tell application "Mail"
repeat with thisMessage in theMessages
display alert "" & (subject of thisMessage)
end repeat
end tell
end perform mail action with messages
end using terms from
Note:
Mail Rules are controlled by Apple Mail, not DEVONthink. While they generally behave as expected, we can't control whether the rules will be triggered in Apple Mail.
Application Scripts
AppleScript is perfectly suited for integrating different applications, interchanging information, and creating workflows. DEVONthink comes with a number of scripts that exchange information between DEVONthink and other AppleScript supporting applications, like Safari or Mail.
The Script Menu Extra Scripts provided by DEVONthink are installed in an application-specific folder in ~/Library/Scripts/Applications, e.g., ~/Library/Scripts/Applications/Safari. These scripts are accessible from the global scripts menu in the menu bar at the top of your screen while you're in the specific application.
Mail Scripts
Importing email into your DEVONthink databases is a possible use of AppleScript. Using AppleScript-enabled email applications, especially those with a robust scripting dictionary, increases the potential for processing emails. This can help you quickly file those emails directly into DEVONthink.
DEVONthink comes with scripts for Apple Mail, Microsoft Entourage, and Microsoft Outlook. Just select a message or mailbox in a supported email application and choose the desired script from the global scripts menu. DEVONthink provides the following scripts:
Note:
The import of entire mailboxes via AppleScript can be a resource-intensive process. Use the Apple Mail plugin for a more robust experience importing mailboxes.
Depending on the capabilities of the web browser you're using, you may be able to use application scripts. We have included a handful of simple scripts that can be run while browsing in Safari or DEVONagent.
Other Applications
Obviously we haven't covered all the possible applications or scenarios on your machine, and we are sure you have ideas we haven't thought of. If you have an application you'd like to integrate with DEVONthink, check if it has an AppleScript dictionary. If it does, the potential exists to communicate between the applications. But also be aware the commands, elements, and properties you can work with are coded by the developer of those applications.
Folder Actions
Folder actions are scripts that you can attach to folders in the Finder. These act on all items you add to these "hot folders." When you add items, the operating system detects the added files and runs any folder actions attached to the folder.
The actions supplied by DEVONthink are installed in ~/Library/Scripts/Folder Action Scripts, and you can add your own scripts to this directory, as needed. For everyday use and exploration, here are the folder action scripts provided by DEVONthink:
Attaching a folder action
To attach a folder action script to a folder, do the following:
Manage folder actions: To manage all your folder actions, Control-click a folder and choose Services > Folder Actions Setup from the contextual menu. Use the Folder Actions Setup utility to see which folders have scripts attached, and to remove folder actions from folders.
Note:
If you are running macOS Mojave, you will be prompted to allow the Folder Actions Setup application to run. This notification is controlled by the operating system, not DEVONthink.
Terminology
While we can't provide specific training on how to create folder actions, check out Apple's documentation. However, the on adding folder items to folderVariable after receiving filesVariable is the handler most commonly used in our folder action scripts. Here is a simple example:
Example:
on adding folder items to theFolder after receiving theFiles
repeat with thisFile in theFiles
tell application id "DNtp"
set newRecord to import thisFile to incoming group
if exists newRecord then tell application "Finder" to delete thisFile
end tell
end repeat
end adding folder items to
Note:
Folder actions, like any computer processes, are treated very literally. When processing files with a folder action, it's best to move or delete the files from the watched folder. This keeps the action from trying to reprocess files.
Automator
Apple's Automator application was created mainly to help non-programmers take some control of their machines. It allows you to visually string together simple steps in an automated process. While much more limited due to its linear nature, it may still be useful for some routines. Additionally, Automator offers creation of other types of items like Services (or Quick Actions).
While DEVONthink does not provide Automator actions, using the Run AppleScript action in Automator makes it possible to have some degree of integration with our application.
Terminology
Finder to DEVONthink: Since DEVONthink doesn't provide specific actions for Automator, you can't merely detect things like a selection. The key to integration with DEVONthink is passing file paths, specifically POSIX paths. For example, if you used a Get Selected Finder Items action, you could use a Run AppleScript action like this to import selected files in the Finder into DEVONthink :
Example:
on run {input}
tell application id "DNtp"
repeat with thisFile in input
import (POSIX path of thisFile) to incoming group
end repeat
end tell
DEVONthink to Finder: Passing paths from DEVONthink can be done by processing the paths of files. Here is an example Run AppleScript action placed at the beginning of the workflow:
Example:
on run {}
tell application id "DNtp"
set fileList to {}
if selection ≠ {} then
repeat with thisRecord in (selection as list)
copy (path of thisRecord as string) to end of fileList
end repeat
end if
return fileList
end tell
end run
Immediately following this action, use a Get Specified Finder Items action to pass the paths to subsequent actions. Be very cautious when using the paths from DEVONthink. Actions like moving, deleting, renaming etc. would compromise your database. It is advisable to use a Copy Finder Items command if you are going to do such operations.
Note:
While we may investigate DEVONthink-specific questions regarding Automator, we do not offer support specifically for it.
Item links
Every database, group, or document in your DEVONthink database has a URL (uniform resource locator) associated with it. While web URLs typically begin with http:// or https://, DEVONthink's URLs take the form of x-devonthink-item:// followed by a long alphanumeric ID. For PDFs, the link can contain a reference to a specific page. For audio and video, a reference to the current playback time. And for RTFs, you can get a reference to a specific paragraph in the document. These links can be used in any file type or application that supports live hyperlinks, e.g., the notes fields of OmniFocus tasks. This allows you to access DEVONthink documents as easily as clicking a link in a web browser.
You can get this item link manually by selecting a document or group and choosing Edit > Copy Link. In addition you can manually extend the copied URL with the following parameters:
Example:
x-devonthink-item://<recordID>?reveal=1
x-devonthink-item://<pdfID>?page=5
x-devonthink-item://<textFileID>?search=iPad%20Pro
x-devonthink-item://<movieID>?time=43.5
Note:
The first parameter after the ID is always added after a question mark (?), additional ones after an ampersand (&), and any values must be percent-encoded.
Terminology
Manually getting item links can be useful for some hard-coded cases, but there are many times you want to get them programmatically. There are two AppleScript properties for a record related to item links:
Here is an example of getting and using an item link to create a Markdown compliant link on the clipboard:
Example:
tell application "DNtp"
set recordName to name of content record
set recordURL to reference URL of content record
set the clipboard to ("[" & recordName & "](" & recordURL & ")")
end tell
The terminology for using item links can depend on the capabilities of the application you're scripting. Here is an example, using a hard-coded URL, with an application that can open URLs:
Example:
tell application "Opera"
tell window 1
make new tab with properties {URL:"x-devonthink-item://929D101B-35AC-474C-801C-D8818C48DB80?line=125"}
end tell
end tell
P.S.: For the shell scripters, the URLs can be used with an open command.
URL Commands
URL commands are a type of item link that don't merely point to an existing file, they issue some special commands to DEVONthink. Though not as powerful as AppleScript, these commands can be used in special circumstances.
Terminology
The URLs are constructed from a single command and optional parameters, with the following format:
x-devonthink://<command>?<parameter=value¶meter=value&...>
Note:
The first parameter after the ID is always added after a question mark (?), additional ones after an ampersand (&), and any values must be percent-encoded.
Listed below are the commands and parameters available:
Commands:
Note:
If you use the location parameter pointing to a web page with the commands above, the page will be downloaded in the specified format and the text parameter will be ignored. Not including the location will yield a file in the specified format using the text parameter for the new file's content.
Parameters:
Example:
x-devonthink://createText?title=New%20;bookmark&location=http%3A%2F%2Fwww.devontechnologies.com&noselector=1
Note:
These are not x-callback-urls. An x-callback-url is a specific type of URL scheme that returns a value to the calling application.
Appendix
In the appendices you will find additional information that helps you getting familiar with DEVONthink, such as a glossary of commonly used terms, a listing of the Boolean operators used in searches, commonly found contextual menu items, and much more.
Glossary
Become familiar with these terms to get the most out of working with DEVONthink.
Keyboard Symbols
Interface Elements
Tags
See the Iconology section for icons specific to these two items.
See the Iconology section for icons specific to the flagged, locked, or unread states.
Iconology
Additional icons behind item names, e.g., in main windows, indicate that the item has been indexed instead of imported, is locked, has a comment or annotation attached, is encrypted, e.g., PDFs or encrypted databases, or has a triggered script attached. Groups also serving as tags show a tag icon. Depending on your preferences, replicants, duplicates, or replicated duplicates are indicated with a little grey icon instead of appearing in color.
Toolbar Items
DEVONthink provides a wide variety of toolbar items, giving you quick "push-button" access to many everyday tools.
Default Items
The following toolbar buttons are available in the default set you see when you first launch DEVONthink:
Note:
The items for showing or hiding the document preview as well as for marking items flagged, read, or locked are also available as a combined toolbar item.
Additional Items
In addition to the default set, there are many other specific buttons available, shown in the essential order found in View > Customize Toolbar:
Note:
Reveal: Be cautious with this button. When used on imported files, it will reveal them in the internals of the database. You do not want to modify these internal files in the Finder. This option is best used on indexed files.
Verify & Repair: Please refer to the troubleshooting chapter for information on database maintenance and repairs.
Send by Email: The ability to add the attachments depends on the inter-application capabilities of the email application. If it doesn't provide support for this, you may be able to drag documents into draft messages or the email application's dock icon.
Some items are also available as a compound toolbar icon.
Custom Items
If you are creating scripts and saving them to the ~/Library/Application Scripts/com.devon-technologies.think3/Toolbar folder, these will be shown in the Customize Toolbar options as individual buttons with a script icon.
Keyboard Shortcuts
Keyboard shortcuts make using DEVONthink much more efficient. Some of the following shortcuts are common to most Mac applications; others are only available in DEVONthink. In addition, many menu commands have keyboard shortcuts. These are shown directly in the menu.
Note:
You can change the shortcuts for menu commands in System Preferences > Keyboard > Shortcuts > App Shortcuts.
Windows
Note:
Hold ⇧ to cycle in reverse order.
Document Lists
Navigating items:
Selecting items:
Manipulating items:
Item List:
PDFs
Images
Contextual Menu Items
DEVONthink also provides many commands in contextual menu items, shown when you Control-click on elements in the application. Many of the contextual menu items are also found in DEVONthink's menus. Below is a list of common menu items you'll find in the contextual menus for documents and windows.
Document Contents
When you Control-click in the contents of documents, you will see a contextual menu with commands and options. The items shown are related to the file type and if you're interacting with a selection in the document. Specific items, e.g., commands relating only to PDFs, are covered in their respective sections.
In editable documents:
Text or links in text:
Images and PDF documents:
These contextual menu items are commonly shown when you ⌃-click items in a main window's item lists. In items lists, the commands are also often available in the Actions toolbar button. Some of these commands are also seen in the See Also & Classify Inspector pane.
Note:
Send by Email: The ability to add the attachments depends on the inter-application capabilities of the email application. If it doesn't provide support for this, you may be able to drag files into draft message or the email application's dock icon.
Search operators
Searching in DEVONthink already is a powerful function. The addition of Boolean operators, parentheses, and wildcards extend the power to fine-tune your search even further.
Note:
The syntax of the operators is compatible to DEVONagent and EasyFind, the Finder, Spotlight, common search engines as well as common programming languages such as C, C++, Objective-C, Java, and JavaScript. The complexity of the query is unlimited.
Case
All terms are case-insensitive. You may, if you wish, use capitalization for proper names in a query, but DEVONthink will ignore case in interpreting the query.
Precedence of terms
Search terms and associated operators will be interpreted from left to right, except as modified by including portions of the query within parentheses.
Wildcards
You can replace parts of words with wildcards matching one, multiple, or a range of characters:
Boolean Operators
The operators (often called Boolean operators) are words or symbols that establish logical rules for the terms in the search query. If no operator is given, DEVONthink infers AND. The available Boolean operators are:
Besides the classic Boolean operators, DEVONthink uses a number of operators that usually are found in high-end databases. Use these operators as a replacement for AND and "quotes" to fine tune your query.
For convenience, some of these operators can also be abbreviated using commonly used symbols:
Operators are evaluated in the following priority: parenthesis > phrase/hyphens > (NOT) BEFORE/AFTER/NEAR/NEXT > NOT > AND/OR/XOR/EOR. Terms with same priority but without parenthesis are evaluated from left to right.
White Space Handling
Words linked by non-white separators (e.g., page-index or page_id) are treated like phrases put into "quotes". Words separated by hyphens are handled like word1word2 OR "word1 word2". Characters separated by dots are considered to be abbreviations and therefore handled like words separated by hyphens, e.g., the term t.a.t.u is equal to "t a t u" OR tatu.
Examples
By using any or all of the operators and rules laid out above you can create complex queries that find the exact information you're looking for. Here are some example queries that show how the operators are used.
Example:
Devonian Dinosaurs
This query looks for all documents that contain the words "devonian" and "dinosaurs".
Example:
(Steve NEAR Jobs) AND iMac BUT NOT MacBook OPT Pro
This query looks for documents that contain the words "Steve" and "Jobs" no farther ten words away from each other, as well as the word "iMac" (no specific position relative to Steve and Jobs), but not the word "MacBook". The word "Pro" does not need to occur, but if it does, the document is ranked higher in the list of search results.
Example:
Paracetamol NEAR (~effect OR impact) AND ((side OR second*) NEAR/2 ~effect)
This query looks for documents containing the word "Paracetamol" near (within 10 words) to words either starting with "effect" (and so also "effects") or "impact". In addition, the document needs to contain the word "side" or any word starting with "second" located within two words range of any word starting with "effect".
Search Prefixes
DEVONthink supports a wide variety of searchable attributes. These include common attributes, like names or tags, but also include document or DEVONthink-specific items, like word counts or custom metadata you've defined.
Similar to searching with Spotlight or some other applications, the use of search prefixes is supported. These take the form of a prefix and a prefix operator, e.g., name:, followed by the search term. These prefixes are automatically applied when you choose criteria in an advanced search but they can also be manually entered in the search field.
Search prefixes
Below is a list of the available search field prefixes as you would manually type into the search field or a script:
Item prefixes: These special prefixes are for state-based queries, like the locked or indexed state of items. They all follow the form of item:<specified state>, e.g., item:locked.
There are also two special prefixes you can use:
Example:
additionDate>=2019-03-10 scope:selection
tags:sync; methods scope:"Tech Stuff"
any: name:test OR imprint {any: tags:blue; red}
Sub-criteria searches: Yes, you may have noticed in the last example a tags search in curly braces. This creates sub-criteria for the search. This obviously extends the search options to allow creating even more complex forms.
Prefix Operators
Many times prefixes end with a colon, e.g., tags: but some use other forms, depending on the available options in the criterion. For example, words can "begin with" some characters, but a size is greater or less than a value. If you select a criterion you would see what options apply. Use the keys below to map the option to its operator.
Matches, Is, Is Not:
: is equal to the term matches. With strings-based queries, it allows for wildcards to be used. It is also used for state-based queries, like Kind. The negated form, :! is also supported.
== is equal to the term is. This must be an exact match of the search term. These can be used in strings and number-based queries. The negated form, != is also supported.
Example:
Kind is Group → kind:group
Item is indexed → item:indexed
Item is not Replicated → item:!replicated
Extension is XML Document → extension==XML
Language is not English → language!=en
String Matching: These are operators that are used with string-based queries, like names or text content. These queries also support:
:< is equal to begins with.
:> is equal to ends with.
:~ is equal to contains. (The tilde is the second key down on the top left of an English keyboard.)
Example:
Subject begins with party → docSubject:<party
Locality ends with field → md_locality:>field
Name contains tech → name:~tech
Number Matching: In addition to the == and != operators, numbers can also use these operators:
< is equal to the term is less than.
<= is equal to the term is less than or equal to.
> is equal to the term is greater than.
>= is equal to the term is greater than or equal to.
Example:
Word Count is less than 1000 → wordcount<1000
Size is greater than 10MB → size>10 MB
Hits is greater than or equal to 1 → hits>=1
Date Operators: These are operators used with date-based queries, like the creation date of files.
< is equal to the term before.
<= is equal to the term before or on.
> is equal to the term later.
>= is equal to the term later or on.
:# is equal to the term within last number of days. The negated form, :!# is also supported.
: is equal to the term is for date-based queries. Supported date options are Today, Yesterday, This Week, Last Week, This Month, Last Month, This Quarter, Last Quarter, This Year, and Last Year. The negated form, :! is also supported.
Example:
Date Created is after January 31, 2019 → creationDate>=2019-01-31
Date opened is not within last 5 days → openingDate:!#5days
Date Due is not Today → dueDate:!Today
Date searching allows for some flexibility in formats. Time is not a required parameter, but can be specified. These searches are all equivalent:
Example:
additionDate>10 march, 2019
additionDate>March 10, 19
additionDate>2019-03-10 08:30:00 -0500
Templates
DEVONthink comes with a number of built-in templates for general use. Use these templates to add a task list, a quote, or whole group structure for project management to your database.
Templates are stored in the ~/Library/Application Support/DEVONthink 3/Templates.noindex folder. In order to manage your templates, rename them, organize them in subfolders, or delete them, you can quickly access this folder by selecting Data > New from Template > Open Templates Folders. More templates are available by selecting Data > New from Template > More Templates, or as extras in the Support Assistant or in the Extras sidebar.
A very useful thing you can do is add your own files to this folder, even if the files aren't directly editable in DEVONthink. For example, you may have a specific Pages template you often use. Open the template in Pages and save it into DEVONthink's Templates folder. Now you can add documents to your database even more efficiently.
Built-in Templates
DEVONthink comes with the following built-in templates, which serve as great examples of the template feature.
Accounts & Passwords:
Classifications:
Education:
Productivity:
Registers:
Smart Groups:
Toolbar: By default this contains no templates. Add your own templates to ~/Library/Application Support/DEVONthink 3/Templates.noindex/Toolbar. These can be added to the DEVONthink windows using View > Customize Toolbar.
Note:
Some of the included templates are just simple files. Others are smart templates, packages that contain assets and scripts that provide powerful template generation. See the Automation chapter for more information on them.
Metadata
DEVONthink stores a large number of metadata fields internally when importing documents from the file system, e.g., from PDF, RTF, MP3, EXIF/IPTC, HTML, and email messages as well as from all files that deliver metadata through the Spotlight metadata importer. Here's a partial list of theoretically supported fields:
File Metadata
General Metadata:
PDF Metadata:
RTF Metadata:
Email Metadata:
Media and Publication Metadata:
Another powerful feature of DEVONthink is custom metadata fields. Specified in the Preferences > Data, you can define fields that are meaningful to you, your company, your research group, or even your family!
When you create a custom metadata field, you give it a name. DEVONthink uses this name to create an identifier for use in automated processes. This identifier is created automatically and cannot be changed.
Data Types: When you define a custom field, you choose a data type for it. So what's a "data type"? It's simply a kind of a value; like "a" is a character and "42" is a (the!) number. The following data types are supported, including any interface items associated with them, e.g., checkboxes or dropdown menus:
Note:
The Countries and Languages lists are lengthy, but not necessarily exhaustive. For Multi-line Text and Rich Text, only one line will be displayed in its column in the item list.
Predefined Custom Metadata: In Preferences > Data, we have provided some custom metadata fields to get you started. These are ready to use and explore and serve as great examples of the data types discussed above:
Placeholders
One of the most powerful features of DEVONthink is the ability to insert data dynamically. A placeholder is a bit of code DEVONthink interprets when used in these scenarios, replacing it with a specific value. You may have an imprint with a Name placeholder defined in the title. When the imprint is used on a PDF, the placeholder is converted to the name of the file!
To extend the possibilities even further, you can combine static text and multiple placeholders to achieve truly custom results. You can use these in smart rules and the command Tools > Batch Process, in alarms on Reminders, custom imprints on images and PDFs, and in templates for creating WikiLinks documents.
Below is a list of placeholders currently available:
When using dates, you can choose the format as defined in System Preferences > Language & Region > Advanced > Dates. The default is the medium format, but you may choose short or long formats as well. You can also choose specific parts of the date or time, e.g., the month, year, or hour only.
Properties: These are potential metadata properties found in the current file. A more extensive listing of these can be found in the Metadata section.
Custom Metadata: This menu lists any custom metadata fields applied to the file.
Smart Rule Events and Actions
Smart rules in DEVONthink provide many powerful actions and events that can trigger these actions. Below is a list of the available options for both.
When an action is triggered is almost as important as the action itself. Actions can be triggered when any of these events occur:
You can and and remove multiple event triggers by pressing the + or - buttons. Fox example, you could use an On Import and an On Moving event trigger to act on files imported or moved into it.
The power in smart rules is the actions. DEVONthink provides actions that cover simple tasks, e.g., prefixing a filename, all the way to ultra-powerful AppleScript injection via external or embedded scripts. Since you can chain multiple actions together, the possibilities are nearly endless. Here's a list of available actions:
Item scanning: The next two actions allow you to scan the name or text of a document and use the results when found. Each of the actions also has a parameter you specify for the type of data you're scanning for. These actions and parameters can be used with subsequent actions that support placeholders, e.g., Scan Text: Date → Document Date with Change Modification Date. If the action returns no results, actions using the results will not be executed. However, unrelated actions in the smart rule chain will be executed normally.
The following four parameters are used with the Scan Name and Scan Text actions. With , , and , a prefix and/or suffix before/after the wildcard has to be specified.
Example:
Using the String parameter, Invoice * would capture 0012345 in a file named Invoice 0012345..
Using the Date parameter, * would capture the date in a file named 2020-01-01.
Using the Amount parameter, $* would capture the dollar amount detected.
Using the Regular Expression parameter, Bill To: ([A-Za-z0-9 ,]+) would capture the name of the person or company billed. \1 would be used in the subsequent action.
Scripts
Below is a list of the DEVONthink supplied scripts, segregated by the menu items in the Script menu:
Comments:
Data:
Download:
Edit:
Execute:
Export:
Feeds:
Format:
Images:
Import:
Reminders:
Note:
These are scripts for integrating with external applications. For scripting internal reminder scripts, see the Reminder Scripts section of the chapter about automation.
Rename:
Sheets:
Tabs:
Note:
The last script does no URL validation, though DEVONthink's dictionary makes it possible to script this too.
Thumbnails:
Note:
While these scripts work with all image formats including PDF, they should not be used for PDF documents. They will only work on the first page of the PDF and destroy all embedded metadata.
Caching: All scripts in the Scripts menu are cached, meaning their properties are persistent until you quit and relaunch the application or DEVONthink automatically updates the menu, e.g., after adding or removing scripts.
Web site export templates
For exporting selected groups or files as a web site, DEVONthink uses templates available in ~/Library/Application Support/DEVONthink 3/Websites/ to create HTML files from documents. You can choose the template in the save dialog that appears when you use File > Export > as Website.
In the markup of HTML templates, the following placeholders can be used:
These placeholders will be replaced with actual information during the export. The placeholders will only be replaced in documents that are converted to HTML during export, namely plain text, rich text, Microsoft Office/OpenOffice documents, scripts, chat logs, and sheets.
Hidden preferences
There are a few settings in DEVONthink that you cannot set through the Preferences window. Most of them are intended to facilitate customer support but they might be interesting for you as well.
Note:
These hidden preferences are not an official feature and could be changed or removed with any update.
How to access the hidden preferences
All hidden preferences are simple on/off switches. You set and unset them using the "defaults" command in the Terminal. To set preferences via the Terminal DEVONthink must not be running or it will overwrite your changes when you close it.
To set a preference using the Terminal, noting the commands are case-senstive, they are written like this:
Terminal:
$ defaults write com.devon-technologies.think3 ShouldScaleAttachedImages -bool TRUE
The above command activates the preference with the key "ShouldScaleAttachedImages". Change TRUE to FALSE to deactivate it. Use any of the preferences keys below to activate or deactivate them.
There is a special preference to allow DEVONthink to detect other plain text formats as plain text: "AdditionalPlainTextExtensions". As it replaces the list of additional plain text extensions we recommend that you read the current list first (empty by default) before adding your own to the end of the list.
Terminal:
$ defaults read com.devon-technologies.think3 AdditionalPlainTextExtensions
2014-07-31 08:25:27.101 defaults[21950:3312262] The domain/default pair of (/Users/eb/Library/Preferences/com.devon-technologies.think3 AdditionalPlainTextExtensions) does not exist
# This "error" shows there are no additional formats specified.
$ defaults write com.devon-technologies.think3 AdditionalPlainTextExtensions -string .otl.todotxt
$ defaults read com.devon-technologies.think3 AdditionalPlainTextExtensions
.otl.todotxt
Available hidden preferences keys
Read Me
This chapter contains the version history of DEVONthink, our end user license agreement (EULA), and credits.
Version History
New
Improved
Fixed
Removed
Version 3.6
This release brings compatibility for macOS 11 Big Sur, with both cosmetic and technological improvements. Also, document links are a focus in this version. Databases are scanned for link relationships between documents: either outgoing links or incoming Links ("back links"). The numbers of incoming and outgoing links can also be used to search, as smart criteria, or to sort the item list.
Other enhancements include better in-document searching via the Search inspector which now allows wildcards and operators, e.g., DEVONthink NEAR support. We have added more Markdown support including a new Daily Journal template and creating a table of contents file in Markdown. There is now the ability to duplicate and replicate via the Move to popover when modifier keys are held. PDFs with a table of contents can be split by chapters into separate documents. The AppleScript dictionary also received several additions and improvements, including faster processing of selected items. Lastly, there are performance and reliability improvements for DEVONthink and its synchronization.
Version 3.5.2
This release brings the first steps toward compatibility with the upcoming macOS Big Sur release, ARM support, as well as improvements and fixes beyond the beta. While the operations of DEVONthink are working as expected so far in the Big Sur betas, we made the first round of necessary cosmetic changes. We have improved the efficiency of the sync engine, including more reliable resuming of interrupted syncs. Also, DEVONthink preserves the hierarchy of nested tags when moving or duplicating tagged items between databases. If you use WikiLinks, you can now specify more than one type to use, e.g., "Names & Aliases" and "MashedWords". HTML exports, including exporting to websites and the conversion of Markdown documents to HTML, behave more reliably now. Encrypted databases have seen improvements in reliablity too. We've also added support for importing bookmarks from the Brave browser. And improvements to the general speed and reliability of DEVONthink continue to be made.
Version 3.5.1
This maintenance release brings many improvements and fixes. For example, the Navigate sidebar is better usable and more reliable with non-unified databases. The Go To and Move To popovers now allow using quoted text to reduce the number of matches, and the Reading List can be sorted via drag-and-drop. If you are using custom metadata and annotation files, your custom annotation templates now support metadata placeholders. And finally, we have included some AppleScript improvements and smart rule changes for the automators out there.
Version 3.5
The 3.5 release brings many new features, fixes, and improvements. Here are a few highlights: The Navigate sidebar now features an active database section allowing an isolated view of a single database's groups. We have added several smart rule actions including two which allow you to parse a document's name or contents and retrieve strings, dates, amounts, and even arbitrary data using regular expressions. Use the results to change attributes like a documents' dates or custom metadata. New event triggers activate smart rules on events like duplicating, or tagging documents. You can also now specify more than one trigger per rule.
For office use we have updated the OCR engine and added with two new OCR options which allow OCR without changing the original document. DEVONthink records voice notes in a more compatible format and you can view Markdown documents with syntax highlighting. The web interface lets its users upload files easier and features a custom metadata inspector pane. And, as always, we have improved the overall reliability and performance, too.
Version 3.0.4 ... 1.0.1
Skipped.
Version 1.0
Initial release.
License Agreement
PLEASE READ THIS LICENSE CAREFULLY BEFORE USING THIS SOFTWARE. BY USING THIS SOFTWARE, YOU ARE AGREEING TO BE BOUND BY THE TERMS OF THIS LICENSE AGREEMENT. IF YOU DO NOT AGREE TO THE TERMS OF THIS LICENSE, DELETE THE SOFTWARE OR RETURN THE SOFTWARE AND RELATED DOCUMENTATION TO DEVONTECHNOLOGIES, LLC.
1. License: The application and other components (sound and graphics) accompanying this License, whether on disk, in read only memory, or on any other media (the "Software"), and the related documentation are licensed to you by DEVONtechnologies. You own the disk on which the Software is recorded but DEVONtechnologies and/or DEVONtechnologies' Licensor(s) retain title to the Software and related documentation. This License allows you to non-simultaneously use the Software on multiple computers by the same person.
2. Restrictions: The Software contains copyrighted material, trade secrets and other proprietary material and in order to protect them you may not decompile, reverse engineer, disassemble or otherwise reduce the Software to a human-perceivable form. You may not sub-license, modify, rent, lease, or create derivative works based upon the Software in whole or in part. You may not distribute the Software in any form, including, but not limited to, electronic information service distribution, bulletin board distribution, and magnetic or optical medium distribution.
3. Disclaimer of Warranty on Software: You expressly acknowledge and agree that use of the Software is at your sole risk. The Software and related documentation is provided "AS IS" and without warranty of any kind.
4. Limitation of Liability: UNDER NO CIRCUMSTANCES INCLUDING NEGLIGENCE, SHALL DEVONTECHNOLOGIES BE LIABLE FOR ANY INCIDENTAL, SPECIAL OR CONSEQUENTIAL DAMAGES THAT RESULT FROM THE USE OR INABILITY TO USE THE SOFTWARE OR RELATED DOCUMENTATION. In no event shall DEVONtechnologies' total liability to you for all damages, losses and causes of action (whether in contract, tort (including negligence) or otherwise) exceed the amount paid by you for the Software.
Apple, Cocoa, ColorSync, Darwin, macOS, QuickTime, Quartz and all other registered names are trademarks of their respective owners.
Credits
ABBYY FineReader Engine
ABBYY FineReader 11.x Engine Copyright © ABBYY Software Ltd. OCR by ABBYY Software House.
MultiMarkdown
Copyright © 2016-2018 Fletcher T. Penney.
MultiMarkdown is released under both the GPL and MIT licenses. You may pick the license that best fits your needs.
The GPL: This program is free software; you can redistribute it and/or modify it under the terms of the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version. This program is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License for more details. You should have received a copy of the GNU General Public License along with this program; if not, write to the Free Software Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
The MIT License: Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the "Software"), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, subject to the following conditions: The above copyright notice and this permission notice shall be included in all copies or substantial portions of the Software. THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
Pantomime
Copyright © 2001-2009 Ludovic Marcotte.
ShortcutRecorder
Copyright © 2006, contributors to ShortcutRecorder. (See the contributors listed in detail later in the file.)
All rights reserved. Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:
THIS SOFTWARE IS PROVIDED BY THE CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
Contributors to Shortcut Recorder, in no order in particular:
Sparkle
Copyright © 2006-2013 Andy Matuschak
Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the "Software"), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, subject to the following conditions:
The above copyright notice and this permission notice shall be included in all copies or substantial portions of the Software.
THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
Skim
Copyright © 2008-2018, Christiaan Hofman and contributors All rights reserved.
Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:
Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution. Neither the name of Christiaan Hofman nor the names of any other contributors may be used to endorse or promote products derived from this software without specific prior written permission.
THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
LetsMove
Public domain. More information can be found atLetsMove.
ZipZap
Copyright © 2012, Pixelglow Software. All rights reserved.
Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:
THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
Technology
All commercial DEVONtechnologies applications are based on a proprietary AI technology, with rock-solid database foundation that allow them to manage large numbers of documents or knowledge bits while analyzing them almost instantly at the same time.
General Concept
DEVONtechnology, on which all DEVONtechnologies' applications are built, is a new technology at the very beginning of its development. DEVONtechnologies constantly improves the technology and enhances it for more functionality, efficiency, robustness and flexibility.
Development of the DEVONtechnology is a battle on two main forefronts of information processing technology. DEVONtechnologies is working hard on unifying both the top-down and the bottom-up AI concepts by imitating high-level functions and simulating the basic functionality of natural systems. This leads to highly functional, fast and efficient AI systems that can be used in a great variety of information processing contexts, such as pattern recognition, signal processing and information storage and retrieval.
Features
The DEVONtechnology is a rock-solid foundation suitable for a variety of completely independent applications. Therefore it is ideal for the rapid development of a huge range of new database-, signal-processing- and language-analysis-driven applications. The ability to deal with any kind of digital data makes it extremely flexible.
The size of DEVONtechnology-based databases can, depending on the type of data stored, grow logarithmically and make indexing is completely unnecessary. Also, applications based on the DEVONtechnology improve themselves continuously (the more data they handle, the better the results), are language-independent and iron out any irregularities by applying fuzzy logic.
Structure
The DEVONtechnology consists of a kernel and several layers. Together they perform all the underlying computing, from 'simple' data handling to complex signal processing.
Kernel: The kernel is the foundation for all layers and applications and is responsible for data handling, semantic and associative data processing, signal processing, fast statistic analyses and all fuzzy algorithms. It has to be as fast, flexible, and extensible as possible; it is 64-bit aware and uses a generic, proprietary file format (see above) allowing it to verify and repair low level data consistency, featuring logarithmic growth of the database and logarithmic speed decrease with increasing database size. The DEVONtechnology kernel is Unicode-aware, completely language-independent and self-optimizing and self-organizing.
Layers: The layers form a shell around the kernel and provide high-level functions for the applications built on top of them. The database layer, for example, is used to store and organize data and supports all kinds of relations (1:n, n:1, n:n), hierarchies and freeform databases. No indexing or primary keys are required, strings can be unlimited in size and it's possible at any time to extend the range of pre-defined data types (Boolean, character, float, double, signed, unsigned, string, date, time, blob, color, size, and point). Another layer, the XML layer, makes it easy to handle XML code within the DEVONtechnology; it has a very small overhead, compared to DOM parsers or available XML databases, requires no indexing and supports the tight integration of other databases (and vice versa).
Applications
Some of the most likely applications for the DEVONtechnology are databases (knowledge bases, expert systems, search engines, table-of-content-generators, instant data-mining), intelligent agents, encryption, compression and archiving. Other uses for DEVONtechnology may be chat-bots, context-sensitive help, optical character recognition (OCR), speech analysis, recognition and synthesis, staticstics, thesauri and automatic translations.
In particular, applications dependant on processing human language, either written or spoken, benefit from the flexible technology foundation. So, DEVONtechnologies' main focus in the development of new applications is in these areas: databases, 'intelligent' agents, text and speech analysis, statistics.
Look forward to see a great range of different applications based on the DEVONtechnology. A few have already been announced on the DEVONtechnologies web site: www.devontechnologies.com.
Other Products
Besides DEVONthink, DEVONtechnologies publishes a number of other commercial, shareware, and freeware applications and services that might be helpful for you.
Overview
DEVONtechnologies is focused on developing innovative applications for finding, storing, and organizing information. Our main objective is to make complex yet flexible technology that is both easy to use and lightning fast. All applications are based on the DEVONtechnology, a powerful and solid core unique to DEVONtechnologies.
We also publish some freeware apps and services for your everyday work with your Mac.
Newsletter & Community
Would you like us to keep you informed about updates and new product releases? Visit our blog and subscribe to our free newsletter.
If you have a moment feel free to visit our lively user community. Here users of all skill levels meet to discuss our applications, talk about our technology, and exchange tips and tricks for DEVONthink & Co.
DEVONthink
Organize and work with all your documents, bookmarks, email messages, text files, images, PDFs, in one place, regardless where they originated. Quickly capture data without interrupting your workflow. DEVONthink's unique AI assists you in getting the most out of your data collection.
DEVONagent
DEVONagent Pro helps you search more efficiently on the web. It searches multiple sources, frees you from hunting for the really relevant results, and gives you power tools for your research. DEVONagent Express and DEVONagent Lite (free) make searching the web as easy as using Spotlight. Search Google, Bing, YouTube, Facebook, Twitter, even the Mac App Store, right from the menu bar.
Learn more about DEVONagent Pro.
DEVONsphere
Make your Mac smarter: Let DEVONsphere Express keep track of related emails, articles on the same subject, and similar web pages. Discover the hidden connection between seemingly unrelated files.
Learn more about DEVONsphere Express.
Needful Things
Search files on your hard disk, watch web cams, create thumbnails, or access all your files and apps from the menu bar. Reformat paragraphs in your favorite word processor or do little calculations anywhere you can type in text. All for free.
Learn more about our freeware apps and services.
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