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that return loads of useless links? Using
advanced search techniques, DEVONagent
Pro takes on all those tedious search-andreview tasks, releasing you to concentrate on
relevant results.
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THE DEVONAGENT PRO ADVANTAGE

WHY DEVONAGENT PRO?

WHAT DEVONAGENT PRO DOES FOR YOU

Using advanced search techniques,

Using both standard and specialized search

DEVONagent Pro takes on all those tedious

engines, DEVONagent Pro intelligently

search-and-review tasks, releasing you to

summarizes the results -- fast!

concentrate on relevant results. It assists you

Alternatively, DEVONagent Pro shows you

in

an even larger number of search results
finding,
collecting, and
organizing

using its unique graphical topic map.
DEVONagent Pro support your research
while browsing the Web, e.g., by listing all
objects such as images, linked documents,

information from the Web or your

or outgoing links embedded into a viewed

DEVONthink Pro Office databases with a

page.

powerful and flexible search architecture. It

DEVONagent Pro archives your search

also features a powerful, research-oriented

results with a single click or sends them to

web browser and simple built-in archive, and

your DEVONthink database.

tightly integrates with DEVONthink.

Instead of making you repeat actions,
DEVONagent Pro performs those actions
for you. Combine search sets, schedule
searches, etc., to create your very own
personalized search assistant.
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PERFECT INTEGRATION
DEVONagent Pro integrates seamlessly
with DEVONthink. With just one click,
archive your search results, webpages, and
other information grabbed from the Web

To update an existing version of DEVONagent
Pro, simply copy the application package from
the disk image to your Applications folder,
replacing the old version. Your database(s)
will not be affected.

to your DEVONthink database.

If you would like to switch from the Mac

Select text in any application and use

App Store variant of DEVONagent Pro

DEVONagent Pro's Services menu or a

to one directly downloaded from the

contextual menu item to search for it. The

DEVONtechnologies website, you can do so

Menu Extra keeps DEVONagent Pro at your

at any time. The official version will accept

fingertips.

your Mac App Store receipt as a valid license.

Use various actions, including notifications

Copies not downloaded from the Mac App

and AppleScript, to inform you of

Store also allow you to buy an upgrade to a

search results, then send them to either

higher edition or version (if available).

DEVONthink or the application of your
choice to process them any way you wish.
Learn more about why you should use
DEVONagent Pro, when you should use it,
and how to run your first query: See also p.
15ff

SYSTEM REQUIREMENTS

To remove DEVONagent Pro traces from your
computer, trash the following files and folders
(~ represents your home folder):
DEVONagent Pro
~/Library/Application Support/
DEVONagent Pro
~/Library/Contextual Menu Items/
DEVONagent Pro CM.plugin

Every Mac running OS X Yosemite or later. In

~/Library/Preferences/com.devon-

addition, a fast Internet connection is highly

technologies.agent.*

recommended.

Depending on whether you have installed the
following extras or not, remove them, too:

INSTALLING, UPDATING,
REMOVING

The product-specific scripts in ~/Library/

Just move the DEVONagent Pro application

The contextual menu plugin in ~/Library/

package to the Applications folder or any

Contextual Menu Items/

other directory you have access to. Please

The legacy Dashboard widget

Scripts/ and ~/Library/Workflows/

note that OS X Services and the connection
to DEVONthink work only for applications
installed into one of the Applications folders,
and that logout and login or a restart is

Note: Depending the version of macOS you
are using, some files may or may not be
installed on your machine.

required after installation.

DEVONagent Pro 3.11.3 Documentation, page 6

TRIAL RESTRICTIONS

the clock from ticking and re-open later to

Unregistered DEVONagent Pro runs for 60
hours of non-continous runtime or 30 days,
whichever is later. Close the app to stop

continue your evaluation. The menu extra is
restricted to 100 searches until DEVONagent
Pro is registered.

VERSION HISTORY
New

Improved

Fixed

Removed

VERSION 3.11.3
This maintenance release improves date parsing while searching, updates Clinial Trials and Apple
Listserv searches, and fixes a crash with PDFs on macOS Mojave and later.
Improved parsing dates in searches.
Smart dashes, smart quotes, grammar and spell checking are now disabled by default in the
plugin editor.
Updated the Clinical Trials plugin.
Fixed a crash related to highlighting occurrences in PDF documents (macOS Mojave and later).
Fixed issues with WebKit (macOS Mojave and later).
Fixed an issue with searching the Apple Listserv.

VERSION 3.11.2
This maintenance update for DEVONagent Pro brings optimizations, fixes, and macOS Catalina
compatibility. Some changes made in searching, parsing content, and generating summaries now
provide better results. Performance and reliability have been improved with several bug fixes.
Lastly, some changes relative to DEVONthink 3 have been made, including support for searching
the web sharing of DEVONthink Server 3.
Added AppleScript command download JSON from.
Updated the DEVONthink Server plugin for compatibility with DEVONthink 3.
Updated the toolbar icons to the new icons for DEVONthink 3 and its databases.
The Default stylesheet for RSS feeds has been modernized, including dark mode support.
The available RSS stylesheets in Preferences > Web are now sorted.
Long menu item titles now are more accurately shortened.
Displayed sizes, e.g., in the Download Manager, are now based on 1000 instead of 1024. This is
similar to sizes reported in the the Finder and other applications.
After adding a new workspace, the command Go > Workspace > Update now updates the last
added workspace, not the most recently used one.
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Renamed action script "File results in DEVONthink Pro" to File results in DEVONthink.
An alert is displayed after trying to import Safari bookmarks or history without enabling
System Preferences > Security & Privacy > Full Disk Access: DEVONagent Pro (macOS Mojave
or later).
Summaries and digest results are more precise due to being based on characters.
Optimized object scanning in browser windows when the Objects inspector is visible.
Improved date parsing.
Improved fuzzy searching.
Improved the Video scanner.
Improved filtering of ads and Captchas.
Improved the HTML parser.
Improved the display of RSS feeds having only a date but no time.
Improved scrolling speed in the browser (macOS Mojave or later).
Improved Accessibility using modern macOS features.
Replaced Buy button in the License dialog with Your Account.
Added menu item Help > Your Account.
The trial version now runs up to 30 days from the initial application launch and up to 60 nonconsecutive hours of use.
DEVONagent Pro is now notarized.
Improved overall performance and reliability.
Fixed a crash caused by the Adobe Acrobat PDF viewer plugin.
Fixed crashes related to WebKit, including one involving Touch Bar support.
Fixed an issue where images of 1×1 pixels found by the Image scanner were marked as
corrupted in the Inspector of DEVONagent Pro browser windows.
Fixed an issue where the application licensing could fail on some machines, e.g., ones with a
replaced logic board.
Fixed an issue with a stall on launch (macOS Catalina).
Fixed an issue with a visual artifact in browser windows when toggling the Inspector or
navigation panes.
Fixed an issue with font selection in DEVONagent Pro's Preferences.
Fixed an issue with memory management after importing .opml files.
Fixed an issue with proximity operators in a search being incorrectly applied.
Fixed an issue with scanners returning too many or invalid objects in browser windows when
viewing pages with frames having invalid URLs.
Fixed an issue with the background color of the Properties inspector.
Fixed issues with the Download Manager (macOS Catalina).
Fixed a memory leak of the Support Assistant.
Removed DEVONtech Forum plugin.
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VERSION 3.11.1
This maintenance release addresses a sporadic crash some users had when accessing the
Preferences panel on macOS Mojave, as well as some visual artifacts in the interface. We have
also added support for JSON RSS feeds and improved handling of RSS feeds in general. Overall
reliability has been the primary focus of this release.
Added support for JSON RSS feeds.
Updated plugins: Government > USA.gov, References > SEC.
Renamed the search option Atom, RSS, RSD & RDF feeds to Atom, RSS & JSON feeds.
Improved handling of untitled RSS feed items.
Improved overall performance and reliability.
Fixed various visual artifacts including ones affecting tabs on search windows (macOS
Mojave).
Fixed an issue where opening the License panel could stall the application when a network
connection was not available or reliable.
Fixed an issue where an alert was not displayed after entering an incorrect license code.
Fixed a crash and incomplete display of the window when accessing the Preferences panel
(macOS Mojave).

VERSION 3.11
This release features fixes, including greater compatibility with macOS Mojave, as well as other
improvements. We have reorganized the search sets and updated a number of plugins as well
as the thumbnail galleries scanner. A new option allows you to group search sets for more
easily managing your sets. You can now choose to install and update extras automatically in
the Support Assistant. A change to parsing a web page's rendered HTML allows for better See
Also, translation, and automation via AppleScript. VoiceOver support in the interface has been
enhanced too.
You can now create search set groups in Windows > Search Sets. The action menu in the
Search Sets panel now has New Group and New Set options.
Search sets can now be installed via Help > Support Assistant.
Added an option to the Support Assistant for installing and updating extras automatically.
Plugins updated: Qwant, Yandex, Blogs > Google Blog Search, News > BBC News, News >
Google News, News > Topix, News > World News Network, Patents > Google Patents
Search sets updated: Marketing, Mac > Latest News, and Mac > Latest Software.
Scanners updated: Thumbnail Galleries.
Renamed, merged, and reorganized the default search sets.
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Merged the Advanced and Exclude tabs of the Search Sets panel.
Improved automatic selection of content of web pages after choosing Remember Selection
from the contextual menu.
The toolbar button Share > Email in a browser window uses the current website's title as the
subject line.
Improved adding URLs via drag-and-drop in the Downloads window and the Sites tab of a
search set.
Improved keyboard navigation in outline views of windows like Archive and Search Sets.
Renamed Go > Workspace > Update... to Update. The last used workspace is now updated.
Added tooltips to the buttons on the Downloads window.
Tooltips in the menu extra results now update more quickly.
Minor cosmetic adjustments made in Search windows and Properties inspector of browser
windows.
Improved VoiceOver support.
Increased efficiency in handling of RSS feeds.
Improved filtering and retrieval of links, especially in Express mode.
Results from adsabs.harvard.edu and adsbit.harvard.edu aren't filtered as advertisements any
longer.
DEVONagent Pro now uses the rendered web page, instead of the underlying HTML code, as
the source for See Also, translation, and the "text" AppleScript property.
Improved support for search engines allowing parentheses.
Improved support for filtering Cyrillic language results.
Improved support for "robots.txt".
Moved to HTTPS for Web > Translate as well as all URLs linking to our site.
Much faster updating of Finder comments of files and folders (macOS El Capitan and later).
Generating web page thumbnails uses a new service as Thumbshots will shut down November
15, 2018.
Improved overall reliability, including greater compatibility with macOS Mojave.
Fixed visual artifacts in menus and the Preferences window (macOS Mojave).
Fixed an issue in Express mode, where adding a resource to DEVONthink didn't work correctly.
Fixed an issue where error pages in browser windows didn't show the correct icon.
Fixed an issue where importing or searching the Safari history didn't work (macOS Sierra and
later).
Fixed an issue where playing a video in the Support Assistant would continue playing audio
after the window was closed.
Fixed an issue where Scripts > Window > Open Last Safari Session didn't work correctly.
Fixed an issue with automatically updating to the latest version.
Fixed an issue with the English localization of Edit > Speech > Start and Stop Speaking.
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Fixed a rare issue with the HTML parser.
Fixed a crash if the option to install extras automatically was enabled.
Fixed a crash after closing a browser tab or window (macOS High Sierra).
Fixed a rare crash caused by memory management.
Plugins removed: IEEE Xplore, Technorati, Lucky Guess.
Removed the option to subscribe to welcome tips.
The download manager no longer sets Finder comments as it caused automation alerts on
macOS Mojave.

VERSION 3.10
This release adds a new Google Scholar (Case Law) plugin and updates several other plugins
and search sets. For quick queries, it now supports DuckDuckgo Bangs in the internal browser.
We've enhanced the support for live streams with the webcam and video scanners and made it
a bit easier to create a custom search plugin, pasting in code you may find on our forums. And as
always, we have improved the performance and stability of DEVONagent Pro.
Note: Starting with version 3.10 DEVONagent Pro requires macOS 10.10 Yosemite or later.
Plugins added: Legal > Google Scholar (Case Law) plugin.
Added support for DuckDuckgo Bangs in the browser's address bar.
Added Markdown and Formatted Notes options to Window > Search Sets > Actions > Add
results to DEVONthink > Format.
Added Clutter-free layout option to Window > Search Sets > Actions > Add results to
DEVONthink. Requires at least DEVONthink 2.9.17.
Added support for XML with custom plugins.
Added "DatesKeyPath" key (JSON and XML) to retrieve the date of the result.
Added optional "method" AppleScript parameter to specify the HTTP method when
downloading documents.
Added "last downloaded response" AppleScript property to retrieve the last HTTP-Status
code and more.
Plugins updated: Patents > Google Patent Search, References > British Library plugins, News >
BBC News, News > Reuters, News > RocketNews, Legal > FindLaw, References > SEC.
Search sets updated: Marketing, Apple (Feeds), Blogs.
Video and webcam scanners work better with live streams.
Creating a new plugin no longer requires a URL, making it easier to create a plugin with code
copied from our forum.
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If you have selected to download updates automatically, Update On Quit will be displayed
depending on the current progress of DEVONagent. Choosing this menu item will display a
window about the pending update.
In the plugin editor, changing the default keywords of a plugin now resets the user customized
keywords as well.
The "paginated PDF" AppleScript property uses the last used print settings and sets the title.
Fonts of Preferences > General can be reset by holding the ⌥ Option key.
Improved script Scripts > E-mail > Current URL.
Improved performance of scanner objects, browser window, search windows, and the
Download Manager.
Improved character encoding support.
Improved filtering of social bookmarking links.
Using Help > Report Bug with the ⌥ Option key held creates an extended bug report including
the installation path and startup volume format.
Fixed an issue where an Express search didn't always return all results.
Fixed an issue where exporting a report required a .pdf extension, regardless of the previously
selected format.
Fixed an issue where Preferences > Menu Extra mounted volumes added to the user's startup
items.
Fixed an issue where selecting a different scanner in browser and search windows caused an
exception (macOS 10.9 through 10.12)
Fixed an issue where the Express option of search sets was disabled when the secondary
query was "*".
Fixed an issue where the number of scanner objects for a search result was not always
identical to the number of scanner objects shown in the scanner bar.
Fixed an issue with sending formatted notes or Markdown documents to DEVONthink.
Fixed some minor cosmetic issues with the user interface.
Fixed a rare crash caused by background processes.
Disabled Twitter plugin on macOS High Sierra as access to system-wide social accounts is no
longer possible.
Removed script Scripts > E-mail > Current URL (Mail).
Removed plugins Info (News), Info (Images), and Info (Video).

VERSION 3.9.8 ... 1.1
…
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VERSION 1.0
Initial release.
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LICENSE AGREEMENT
PLEASE READ THIS LICENSE CAREFULLY
BEFORE USING THIS SOFTWARE. BY USING
THIS SOFTWARE, YOU ARE AGREEING TO
BE BOUND BY THE TERMS OF THIS LICENSE
AGREEMENT. IF YOU DO NOT AGREE TO

3. Disclaimer of Warranty on Software:
You expressly acknowledge and agree that
use of the Software is at your sole risk. The
Software and related documentation is
provided "AS IS" and without warranty of any
kind.

THE TERMS OF THIS LICENSE, DELETE THE

4. Limitation of Liability: UNDER NO

SOFTWARE OR RETURN THE SOFTWARE

CIRCUMSTANCES INCLUDING NEGLIGENCE,

AND RELATED DOCUMENTATION TO

SHALL DEVONTECHNOLOGIES BE LIABLE

DEVONTECHNOLOGIES, LLC.

FOR ANY INCIDENTAL, SPECIAL OR

1. License: The application and other
components (sound and graphics)
accompanying this License, whether
on disk, in read only memory, or on any
other media (the "Software"), and the
related documentation are licensed
to you by DEVONtechnologies. You
own the disk on which the Software is

CONSEQUENTIAL DAMAGES THAT RESULT
FROM THE USE OR INABILITY TO USE THE
SOFTWARE OR RELATED DOCUMENTATION.
In no event shall DEVONtechnologies' total
liability to you for all damages, losses and
causes of action (whether in contract, tort
(including negligence) or otherwise) exceed
the amount paid by you for the Software.

recorded but DEVONtechnologies and/or

Apple, Carbon, Classic, Cocoa, ColorSync,

DEVONtechnologies' Licensor(s) retain title

Darwin, OS X, QuickTime, Quartz and all

to the Software and related documentation.

other registered names are trademarks of

This License allows you to non-simultaneously

their respective owners.

use the Software on multiple computers by
the same person.

CREDITS

2. Restrictions: The Software contains
copyrighted material, trade secrets and
other proprietary material and in order

SMTPMAILDELIVERY
Dante Palacios

to protect them you may not decompile,
reverse engineer, disassemble or otherwise

The SMTPMailDelivery library is used

reduce the Software to a human-perceivable

according to the MIT License.

form. You may not sub-license, modify, rent,
lease, or create derivative works based upon

VIDEO JS

the Software in whole or in part. You may

Copyright © 2010 Zencoder, Inc.

not distribute the Software in any form,
including, but not limited to, electronic

The Video JS player is used according to the

information service distribution, bulletin

LGPL v3.

board distribution, and magnetic or optical
medium distribution.
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GETTING STARTED
IN THIS CHAPTER

Reasons for using DEVONagent Pro include:

Why use DEVONagent Pro?

15

You get much better search results.

When to use DEVONagent Pro?

15

You don't have to do all the tedious,

DEVONagent Pro at a Glance

16

repetitive tasks involved in a search;

First steps with DEVONagent Pro

17

DEVONagent Pro does them for you,
freeing you to spend more time on

This chapter helps you get started with
DEVONagent Pro. It explains why and when
to use DEVONagent Pro, and gives you stepby-step instruction in how to run a first
query.

meaningful, more important tasks.
You can search more specifically using
DEVONagent Pro's advanced operators and
search sets.
You get the results in a much more natural
presentation in the Digest.

WHY USE DEVONAGENT PRO?
A common misconception is that
DEVONagent Pro is a simple front-end to
Google or Bing. This is far from the truth.
DEVONagent Pro is a very capable Internet
research assistant that handles tedious
research tasks such as weeding out bad
search results, spotting linked documents,
and finding information on a webpage.

You can archive interesting searches
and review or expand those searches on
another day.
You use a specialized web browser with
research-centric additions, e.g., the
sidebar.
You can use DEVONagent Pro to run
regular searches when you are not at the
computer, and it will present the results, if
any, when it has finished.

Searches with DEVONagent Pro take longer
than quick searches on a Web search engine
because DEVONagent Pro downloads each

WHEN TO USE DEVONAGENT
PRO?

resulting page instead of only presenting you
with a link to it. DEVONagent Pro searches

DEVONagent Pro outperforms other Web

also return fewer results since DEVONagent

search engine, especially for research

Pro filters broken links, advertisements, and

purposes, but it is not necessarily a useful

outdated pages. This feature actually saves

tool for simple, every-day searches. Because

time because you do not have to do all this

DEVONagent Pro downloads all results to

manually.

your Mac to analyse and post-process, a
search run takes between a few seconds and
several minutes.
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Use DEVONagent Pro for:

SEARCH WINDOWS

Getting answers to a question
Finding all available data about a subject
Searching multiple search engines and
websites with just one click
Scraping objects from webpages, e.g.,
images, email addresses, or Atom/RSS/
JSON feeds
Keeping up-to-date on a subject, e.g., with
scheduled searches
Don't use DEVONagent Pro for:

You use search windows to enter your query
(search term), start the search, and view the

Finding the webpage of company X or

results. See also p. 50ff

product Y
Finding a very specific image or video

WEB BROWSER WINDOWS

Finding the definition for a word quickly,
e.g., on Wikipedia

DEVONAGENT PRO AT A
GLANCE
DEVONagent Pro hides complex functionality
but makes it available when you need it.
Here's a quick overview over the three main
windows DEVONagent Pro uses and what

You use web browser windows like any

window elements they offer.

other web browser plus DEVONagent Pro's
research-centric additions. See also p.
57ff

THE ARCHIVE WINDOW

You use the archive to save search results and
recall them later. See also p. 64ff
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FIRST STEPS WITH
DEVONAGENT PRO
A first search: While DEVONagent Pro is a
real power tool, searches do not need to be
overly complex. Running a simple search using
DEVONagent Pro is no more complicated
than using Google or Bing.
Run a first search with a few simple steps

More common tasks
How to formulate a good query
How to create your own search sets
Customize DEVONagent Pro to your
preferences
Create your own plugin if your search
engine is not supported
Finally, DEVONagent Pro and the
DEVONtechnologies website offer additional

The next steps: Now that you know how to

information and assistance:

run a first search you can take the next steps
unaided. Here are a few chapters for you to
continue exploring DEVONagent Pro:

Open the Support Assistant for on-screen
tutorials and regularly updated tips
Read the FAQ
Visit our lively user forum
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COMMON TASKS
IN THIS CHAPTER
How to find on the Internet

18

How to search beyond Google

19

How to customize DEVONagent Pro

19

How to set up a search set to crawl
feeds

20

How to run a search automatically

21

How to archive search results

21

This chapter explains common tasks in
DEVONagent Pro in a step-by-step way and
points you to related topics.

Step by step: You are trying to find
information about the WikiLeaks disclosure
of diplomatic cables.
Step 1: Open a new search window with File
> New Search.
Step 2: Choose the search set you want
to use in the magnifying glass

pop-up

menu: Web (Fast)

HOW TO FIND ON THE
INTERNET
DEVONagent Pro's main objective is to find
stuff on the Internet. It does so by sending
a query (search term) to a selected set of

Step 3: Enter your query (search term):
wikileaks AND "diplomatic cables"
Step 4: Click Start.
Click here to make DEVONagent Pro run
the search.

search engines, e.g., Google, collecting the
results, analyzing them, and presenting them

The best choice for a simple but

to you.

comprehensive search is the pre-fab Web
(Fast) search set. It is a multi-purpose search

You tell DEVONagent Pro which search
engines to use by selecting a plugin (contains
instructions telling DEVONagent Pro how to
communicate with a search engine) or search
set (combinations of multiple plugins and

set that sends your query to the three major
search engines: Google, Bing, and Yahoo.
Alternatively, you can choose plugins directly,
e.g., the one for Google, in the magnifying
glass pop-up menu.

other options). DEVONagent Pro comes with
a large number of pre-fab plugins and search

DEVONagent Pro Advantage: You can use

sets already installed. See also p. 104ff

advanced Boolean operators. Doing so
returns a pre-processed summary including
extracted topics rather than just a simple
list of links. In addition, DEVONagent Pro
queries multiple search engines for you with
one single click.
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Next steps:

Step 3: Enter your query (search term): "zu

Fine tune your search with the Settings tab
Design a good query

Guttenberg" plagiarism
Step 4: Click Start.

Learn more about the advanced Boolean

DEVONagent Pro sends the results to the

operators

Highbeam article search engine and presents

Create your own search sets

you with the results.

Related topics:

Click here to make DEVONagent Pro run
this search for you.

The search window explained
List of pre-fab search sets

Next steps:

List of built-in search engine plugins
Design a good query
Learn more about the advanced Boolean

HOW TO SEARCH BEYOND
GOOGLE

operators
Related topics:

DEVONagent Pro can not only run queries
on Google and Bing, but comes with a large

The search window explained

number of plugins that let it use less common

List of pre-fab search sets

search engines such as FindLaw, PubMed, or

List of built-in search engine plugins

Highbeam.
Just choose the right plugin before you start
your search from the magnifying glass

pop-

up menu in the search field.

HOW TO CUSTOMIZE
DEVONAGENT PRO
Like most other Mac applications,
DEVONagent Pro can be customized to
better fit your needs. You adjust all of
DEVONagent Pro's setting in its Preferences.

Step by step: You are trying to find
newspaper articles about the former German
defence minister who had to resign because
he copied large parts of his doctor thesis.
Step 1: Open a new search window with File
> New Search.
Step 2: Choose the plugin to use in
the magnifying glass

pop-up menu:

Step by step: You want to exclude all links to
eBay from the results.

References > Highbeam
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Step 1: Open the Preferences, Search tab.

Step 1:

Step 2: Click into the Exclude Domains

Sets window. Open it manually using

field.

Window > Search Sets.

Step 3: Add 'ebay.' (with the dot, but

Step 2: Click the + button to create a new

without the single quotes) to the list.

set. Name it, e.g., "New York Times".

This filters all results with addresses
containing the string 'ebay.'
Next steps:

Click here to open the Search

Step 3: Switch to the Sites tab.
Step 4:

Click here to open the New York

Times RSS page in a new web browser
window.
Step 5: Show the Inspectors tab using Web

Set the other preferences to your needs
Learn more about the other options in the
DEVONagent Pro menu
Learn more about the other options in the
action menu

> Inspectors > Show and switch to the
tab.
Step 6: Copy the address of any RSS feed
of interest by right-clicking it and choosing
Copy from the contextual menu.
Step 7: Switch to the Search Sets window

HOW TO SET UP A SEARCH SET
TO CRAWL FEEDS

and paste it, e.g., by pressing ⌘V. or using
Edit > Paste.

DEVONagent Pro not only queries search

Repeat Steps 6 and 7 for any feeds that you

engines for you, it can also search on its own

want to add to your "New York Times" search

by "crawling" a specified list of webpages or

set. You can now use this set like any other

news feeds and scanning them for the search

search set or plugin. Instead of querying any

term. This feature is handy when you have a

search engines, it will download the current

number resources you want to watch, e.g.,

state of all the feeds you have added and

subject-specific news sites or feeds.

search them for occurences of your search
term.
Next steps:
Run a first query
Design a good query
Learn more about the advanced Boolean
operators
Run your search automatically

Step by step: You want to search one of the
New York Times news feeds.
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Related topics:
More about search sets

HOW TO RUN A SEARCH
AUTOMATICALLY

"Marketing" set. When it is finished, it will
send a summary email to the specified email
address.
Note: Your Mac needs to be on at the
time the search set is scheduled to run.
DEVONagent Pro is not able to wake your

Search sets are not only collections of rules

Mac up from sleep mode.

about how to run a search, they are also the
key to research automation in DEVONagent
Pro. Add a default query to a search set and
set its scheduler to make DEVONagent Pro

Next steps:
Learn more about actions
Learn more about the schedule options

run the search when you're not around, e.g., in
the middle of the night, and execute chosen
actions when the search is completed.

Related topics:
Learn more about search sets

HOW TO ARCHIVE SEARCH
RESULTS
After you have found good data on the
Internet, it is likely you're only halfway to your
desired outcome. You will want to keep the
Step by step: You want to run the "Marketing"

best results for future reference. For this

search set automatically once every day and

reason, DEVONagent Pro comes with a built-

send the results to you by email.

in archive.

Step 1:

Click here to have the Search

Sets window opened and the "Marketing"
search set selected for you.
Step 2: Switch to the Actions tab.
Step 3: Check Send mail to and enter your
email address.
Step 4: Switch to the Schedule tab.
Step 5: Select Daily and set the time to,
e.g., 9 a.m.
As the "Marketing" search set contains
a default query on the General tab, you
are done. Tomorrow morning at 9 a.m.

Step by step: You want to archive all results

DEVONagent Pro will automagically activate

of a search run.

and run a search for the default query of the
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Step 1: Run a search, e.g., with the Bing or

Step 4: Choose Data > Add To Archive.

Google plugin.

Step 5: The results have been saved to the

Step 2: Choose Data > Add All To Archive.

archive in a group named after your query.

Step 3: The results have been saved to the
archive in a group named after your query.

As an alternative to using Data > Add To
Archive, Data > Add All To Archive, and

Step by step: You want to archive results

Window > Archive, you can use the Add, Add

from a search run.

All, and Archive toolbar icons of the search

Step 1: Run a search, e.g. with the Bing or
Google plugin.
Step 2: Switch to the Results tab, e.g., by
pressing ⌘2.
Step 3: Select the results you want to
archive.

window. You may need to add the tools to the
toolbar using View > Customize Toolbar.
Next steps:
Work with the archive
Related topics:
Adding results to DEVONthink
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QUERIES
IN THIS CHAPTER

PRECEDENCE OF TERMS

Operators

23

Search terms and associated operators will

Designing a search query

25

be interpreted from left to right, except as

DEVONagent Pro provides powerful Boolean
operators that allow users to precisely define
a search query.
Queries can range from uncomplicated oneword search terms to complex multi-term
queries. The rules for formulating queries are
simple. By studying the rules and the Boolean
operators, and with a little practice, users can

modified by including portions of the query
within parentheses.

BOOLEAN OPERATORS
The operators (often called Boolean
operators) are words or symbols that
establish logical rules for the terms in the
search query. These are:

'tell' DEVONagent Pro exactly what to look for

term1 AND term2: Contains term1 AND

in a search.

term2
term1 BUT term2: Contains term1 AND

OPERATORS

term2
term1 OR term2: Contains term1 OR term2

PLUGIN/SET SELECTION

term1 XOR term2: Contains term1 or term2,
but not both

To quickly select which plugin or search

term1 EOR term2: Contains term1 or term2,

set DEVONagent Pro uses, start the query

but not both

with the name of the plugin or search set or

NOT term: Does not contain term

keyword followed by a colon.

"term1": Contains the string term1, in

Example: google:devonthink

exactly this form; uses fuzzy matching (e.g.
"DEVON tech" matches also "DEVON-tech"

CASE

or "DEVON++++tech"); accepts also the '*'
operator, like 'BEFORE' but more precise.

Terms are NOT case sensitive. You may use
capitalization for proper names in a query,
but DEVONagent Pro will ignore case in
interpreting the query.

Besides the classic Boolean operators,
DEVONagent Pro features a number of
operators usually only found in high-end
databases. Use them as a replacement for
AND and "quotes" to fine tune your query.
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term1 NEAR term2: term1 occurs 10 words

OR operator by pressing ⇧7, ⇧\ or the

or less before or after term2

appropriate keyboard combination for your

term1 NEAR/n term2: term1 occurs n or

keyboard layout.

less words before or after term2
term1 BEFORE term2: term1 occurs before
term2
term1 BEFORE/n term2: term1 occurs n or
less words before term2
term1 NEXT term2: term1 occurs right

WILDCARDS
You can replace parts of words with wildcards
matching one, multiple, or a range of
characters:

before term2 (shortcut for BEFORE/1)

?: Matches exactly one character.

term1 NEXT/n term2: term 1 occurs n or

*: Matches none, one, or multiple

less words before term2 (synonym for

characters.

BEFORE/n)

[a-b]: Matches one character of the range

term1 AFTER term2: term1 occurs after

'a' through 'b'.

term2

[abc...] or [a|b|c|...]: Matches one character

term1 AFTER/n term2: term1 occurs n or

out of the given list of characters.

less words after term2

[^...]: Matches one character that is not

term1 OPT term2: term1 is mandatory but

contained in the given list or range.

term2 is optional. If term2 is also found the
result is ranked higher.
~term1: Contains all words that begin or
end with term1 (words containing term1 as

Note: Primary queries only support
wildcards for sites, not for plugins or search
engines.

a part of the word; depends on the queried
search engine)
Note: See chapter Designing a Search
Query for examples on how to use all these
operators effectively.

SPECIAL RULES
To search for a word that is also the name of
an operator, put the word inside quotation
marks. The following example searches all
four terms including the word "near":

For convenience, some of these operators
can also be abbreviated using commonly used
symbols:
AND: &, &&, +
OR: #, ##
XOR: #, ##
NOT: !, -

Example: Beach "near" Los Angeles
Existing "site:<domain.com>" operators in
primary queries are removed before matching
to facilitate searching sites using the Google,
Bing, and Web plugins or search sets using
them.

Note: The symbols above also are used
by the Finder and Spotlight for searches.
Enter the vertical ruler character for the
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DESIGNING A SEARCH QUERY
Writing your query as simply and as precisely
as possible is the key to good search results.
Following are some tips on how to write a
good query.

OR operator. We have now covered all three
variants of common names used for the
environmental agency. DEVONagent Pro will
look for pages containing any one of those
names.
Another potential ambiguity is created

DESIGNING A GOOD QUERY
Suppose you want to search for information
about the mercury contamination of fish,
and to focus on information released by or
referring to the United States Environmental
Protection Agency.

because it's possible that a large reference
source might contain the word 'fish' in one
section dealing with fishery resources, and
contain the word 'mercury' in another section
dealing with the history of barometers. We're
simply not interested in that item. But if we
use the NEAR operator between 'fish' and

One problem with trying a simple AND

'mercury' it's likely that we will get useful

search for a group of words is that the

results, since this query places the space

Environmental Protection Agency is referred

between the two terms at 10 words or less.

to in various ways: Environmental Protection
Agency, EPA and E.P.A.
If we tried the search string
Example: Environmental AND Protection
AND Agency AND EPA AND E.P.A. AND fish
AND mercury

The refined query now becomes:
Example: ("Environmental Protection
Agency" OR EPA OR "E.P.A.") AND (fish
NEAR mercury)
Notice that a second set of parentheses
was used so that DEVONagent Pro doesn't

we would probably get no results at all, as

wrongly interpret the query as requiring that

no single article would use all three terms

both the environmental agency name and

for the environmental agency. And even if

'fish' must be NEAR 'mercury'. That confusion

we were to get search results, we would get

would be created if we wrote the query as:

irrelevant results stemming from the terms
environmental, protection and agency.
Here's a better way to design the query:

Example: ("Environmental Protection
Agency" OR EPA OR "E.P.A." AND fish)
NEAR mercury

Example: ("Environmental Protection

Indeed, the refined search returned highly

Agency" OR EPA OR "E.P.A.")

relevant pages. Of course, this search focused
on literature about mercury contamination

which will pick up the variants in naming the
agency in articles. Note that the two strings
enclosed in quotation marks will now be
treated as phrases. This reduces ambiguity.
Also note the use of parentheses and the

of fish in the United States. To change
the geographical focus, one would simply
replace the search strings in the first set of
parentheses with, e.g., ("European Union" OR
EU).
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IMPROVING YOUR QUERY
Besides the typical Boolean operators AND,
OR and NOT, DEVONagent Pro provides much
more powerful NEAR, BEFORE and AFTER

Use the proprietary NEAR, BEFORE and
AFTER operators when AND delivers too
many results and quote marks delivers too
few. Another example:

operators. Typically, only scientific high-

Example: document AND management

end databases feature these operators, but

AND mac

DEVONagent Pro makes them available for
Web research.

This query run with the Web (Fast) search
set deliveres good results. But, many are not

Note: Because almost none of the Web

what we are looking for. Among good pages,

search engines support these operators,

it also presents the Wikipedia article about

DEVONagent Pro sends the simpler AND

OS X because it contains all three words.

query to them and applies the more

But, of course, this article is not at all about

sophisticated operators to the resulting

document management on the Mac. We can

pages.

refine this query, however, using the special

All three operators connect two search terms

DEVONagent Pro operators:
closer together than AND, but not as tightly

Example: document NEAR/2 management

as the phrase operator (double quotes).

NEAR mac

With the additional distance parameter (e.g.,
NEAR/5) you can fine tune search results until
you get only the results you are looking for.

This time, DEVONagent Pro returns fewer
results, all of them dealing exactly with our
search subject, document management for

Example: (steve NEAR/2 jobs) BEFORE

the Macintosh, because the three words

(intel NEAR (imac OR macbook)) AND "San

must appear near each other in the text. In

Francisco"

most cases, NEAR delivers more accurate

Connecting 'steve' and 'jobs' with NEAR/2
prevents getting result pages of some Steve
looking for a job in his page footer. BEFORE

results than AND.

FIRST PRINCIPLE OF A SUCCESSFUL QUERY

makes sure it is a page that mentions Steve

Make the query precise and unambiguous.

Jobs first, followed by the Intel Macs. Finally,

DEVONagent Pro's tools for clarifying your

the quotes around 'San Francisco' find only

query are clear and simple and will help you

pages dealing with the city of San Francisco,

obtain a high percentage of useful results.

not the city San Jose or a Brother Francisco
mentioned elsewhere on the page.
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SEARCH SETS
IN THIS CHAPTER

Using these settings, you can create search
sets specifically tailored for your research

What are search sets?

27

Choosing a search set

27

Creating and managing sets

28

Sharing sets

29

Querying the U.S. Patent Office and WIPO

General tab

29

databases, along with scanning some

Advanced tab

31

important websites related to patents

Sites tab

32

Looking for articles related to

Plugins tab

33

DEVONtechnologies on Google, as

Actions tab

34

well as some Mac news sites, with the

Schedule tab

35

search scheduled every three hours and

The quality of a query relies not only on the
entered search term, it also relies heavily
on the selected settings. Search sets are
collections of all the parameters (settings)
related to a search run. Use search sets to
quickly tweak your settings, depending on
what you are searching for on the Internet.
This ensures that you always get the best
results.

WHAT ARE SEARCH SETS?
Search sets basically are collections of all the
parameters related to a search run:

needs. For example, you could create your
own sets for:

programmed to send a summary to your
email address
Searching the most important medical
databases, e.g., PubMed, Medscape and
FDA, in a single search run
Querying a number of general search
engines like Google, MSN and Yahoo, but
filtering out everything except pages with
links to Office documents

CHOOSING A SEARCH SET
Choosing the search set that you want to use
for a search run is easy: Click the magnifying
glass icon

in a DEVONagent Pro search

A default query

field and choose a search set from the pop-

Follow links settings

up menu.

Filters and associated scanners
Sites to scan or search
Pluginsto use
Actions to run when the search run is

DEVONagent Pro comes with a number of
predefined search sets, but you can easily
create your own.

completed
A schedule
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CREATING AND MANAGING SETS

Search sets can be edited, rearranged,

To change the settings defined in a set, select

exported, imported or deleted. DEVONagent

it in the list and change the parameters in the

Pro comes with a couple of useful predefined

right-hand pane. Switch between the areas,

sets, which you can tweak to your needs. Or

General, Advanced, Sites, Plugins, Actions,

you can add new ones. Use Window > Search

and Schedule by using the tabs above the

Sets to open the search set editor.

parameter area.

Note: Some of the settings can also be
adjusted on-the-fly in the Settings and
Advanced tabs.
The search set editor shows a list of all
defined search sets and allows you to add
new sets or delete the selected set using
the + and - buttons, just like in other Mac
applications. Rearrange your search sets
using drag-and-drop, and single-click the
name of any set to change its name. Add

SHORTCUT
To create a new search set with exactly the
same settings as the current search run, click
the + button next to the Stop button in the
search window. This creates a new search set
with exactly the same settings including the
query as the default query.

ACTION MENU

groups via the Action or contextual menu to

The Action menu, available from the gear

organize your search sets.

button below the search set list, gives you

Note: Some items can be dragged from one
search set to another set, e.g., URLs from

access to additional commands. See also p.
29ff

the sites tab.
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CONTEXTUAL MENU

GENERAL TAB

The contextual menu gives you direct access

On the General tab, you define the main

to frequently used commands.

parameters for this search set such as the
default query, which filter and which scanner

New Set: Creates a new, empty search set.

to use.

New Group: Creates a new group for
organizing your search sets.
Duplicate: Duplicates the selected search
set.
Delete: Deletes the selected search set.
Attention: There is NO undo!
Import: Creates new search sets based on
imported files. You can import previously
exported sets, as well as OPML files,
Camino, Firefox, Chrome, OmniWebor
Safari bookmarks or the Safari history file.
For OPML, bookmarks and history files,

QUERIES

DEVONagent Pro creates a new search set
with all URLs imported to the Sites list.

Default Query: Define a default query

Export: Exports the selected search sets

for this search set. DEVONagent Pro will

as separate files. Exported sets get the

automatically fill the query field with the

file name extension '.agentSet' and are

default query when you select this search

XML/plist files. You can import them into

set. This is especially useful if you are using

DEVONagent Pro by double-clicking them

either the same query every time you use this

in the Finder.

search set or if you are running this set on a
schedule.

SHARING SETS
You can easily share search sets with other

Example: esa AND (mission NEAR "venus
express")

DEVONagent Pro users. Export sets using

Read more about formulating a query here:

either the contextual menu, the File > Sets

See also p. 23ff

menu command, or by simply dragging
them e.g. to the Desktop. You can email

Secondary Query: When you enter something

exported sets and import them again into

here, the primary term (the one entered or

DEVONagent Pro simply by double-clicking

the default query) is only used for querying

them in the Finder.

the search engines, not for accepting or
rejecting pages. Without a secondary query,
DEVONagent Pro uses the primary query
for both querying search engines and postfiltering results.
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You can use secondary queries for different

On the right-hand side of the pop-up menu

terms for querying the search engines and

select how many levels deep you want

accepting/rejecting pages. Although the

DEVONagent Pro to follow links. One or two

primary query is restricted to 10 words, the

levels generally make sense, more is often

secondary query is not restricted.

overkill.

Example: Use the asterisk '*' as your default

Use the text field below the slider to provide

query to match everything, e.g, when

an additional search query that defines

scanning a list of websites or Atom/RSS/

which links DEVONagent Pro follows. Use this

JSON feeds; this option is not applicable

option to fine tune your settings if you find

with search engine plugins, only with the

that DEVONagent Pro follows meanlingless

Sites list. To accept all pages delivered by

links due to the construction of the result

a primary query, use the asterisk '*' as the

pages. Generally, you should leave this field

secondary query.

blank and let DEVONagent Pro follow all links
matching the entered or default query; the

FOLLOW LINKS
These options tell DEVONagent Pro to follow

automatically chosen term is displayed in this
case.

promising links on HTML pages and in news

Example: Enter '*' to let DEVONagent Pro

feeds. Links are considered 'promising' if they

follow all links, regardless whether or not

match the entered or default query. If you

their text description matches the query.

enter an additional query into the text field
below the pop-up menu instead, this query is
used to indentify promising links.

EXPRESS SEARCH
Check Express Search to enable 'express'

Example: The query 'Devonian Period -

mode. In 'express' mode DEVONagent Pro

County' follows links containing 'Devonian'

returns results fast, but does not filter the

or 'Period' but not containing 'County'.

results. If unchecked, DEVONagent Pro

In the pop-up menu choose which links you
want DEVONagent Pro to follow:
Off: Follows no links.
All: Follows all promising links.
On Same Host: Follows all promising links
leading to the same server (domain).
In Same Directory: Follows all promising
links leading to pages in the same directory.

operates in 'agent' mode, which is slower but
returns post-filtered results and is a more
precise and powerful tool.
Note: Scanners and secondary search
terms, the similar pages filter, and following
links require 'agent' mode. Some plugins
may also require 'agent' mode; others may
not support 'express' mode.

In Subdirectories: Follows all promising
links leading to pages in the same directory
or its sub-directories.
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LANGUAGE
Language: Use this pop-up menu to filter
out all pages that do not match the selected
language (Dutch, German, English,...) or script
system (Arabic, Greek, Hebrew,...) Instead of
simply looking for language tags, this filter
actually analyzes the page itself.
Ignore Diacritics: Check this option to
automatically convert diacritics for analysis
into a normalized form. This also finds
pages that contain German umlauts, French

Example: Use this powerful feature
unique to DEVONagent Pro to filter, for
example, all pages except those containing
a thumbnail gallery, linking to Office
documents, or containing email addresses.

COMMENTS
Enter a brief description for a search set
here. This description is shown in the tooltips
of the magnifier pop-up menu in a search
window.

or Czech accents, or other diacritical
characters.
Example: Uncheck Ignore Diacritics to
search for a word with accented characters
when you definitely don't want to find the
unaccented variant.

ADVANCED TAB
On the Advanced tab, you define in which
parts of webpages DEVONagent Pro
searches, which type of files it searches,
and whether it accepts all pages or only new
results.

Fuzzy: Check to search 'fuzzy'. This also finds
words with similar but not identical spelling,
e.g., 'gray' instead of 'grey'.

FILTERS, SCANNERS,...
Filters: Check the following filters to
automatically filter out special pages you
don't want to include in the results list:
Similar Pages: Filters out pages similar to
results previously found in the search run.
Archived Pages: Filters out all pages already

SEARCH IN

stored in the archive. DEVONagent Pro
compares only the URLs in this case, not
the actual page content.

Choose which parts of a document
DEVONagent Pro searches for the query. Not
all file types have all characteristics.

Scanner: Scanner plugins post process
and filter the list of found pages by formal
criteria. Read more about scanners in the
appendix.

Title
Text
URL
Keywords
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Description
Objects

FILES

SITES TAB
The Sites tab allows you to define a list
of webpages that DEVONagent Pro scans
(crawls) or searches when you use this search

Choose which file types DEVONagent Pro

set. DEVONagent Pro downloads each of

searches and accepts as results.

these pages and tests whether it matches
your query, just like a private little Google.

HTML & XHTML pages
Atom, RSS & JSON feeds
Plain text documents
PDF & PostScript documents

Alternatively it runs a site search on it using
common search engines. Use it together with
the default query to scan your frequently
visited pages for important keywords.

OpenOffice & StarOffice documents
Rich text documents
Microsoft Word documents

RESULTS
Choose if you want DEVONagent Pro to
accept results only from new pages or from
all found pages.
All pages: Always accept all matching
pages.
Only new pages: Accept only new matching
pages.

MANAGING THE SITES LIST
To add a page to the list, enter the URL
into the location field at the bottom of the

DEVONagent Pro keeps an internal log of

window. If the page requires a user name and

found results to recognize which are new. It

password, enter them into the appropriate

also lists the number of results stored in the

fields. Click the + button to add the page. To

log. To clear the internal log, click the Reset

remove a page, select it in the list and click

button.

the - button.

EXCLUDE

You can also use drag-and-drop or copy/
paste to add URLs to the sites list, and use

The Exclude Domains and Exclude Links fields

the contextual menu to open the page in a

allow you to explicitly exclude domains and

browser window or copy the URL. This also

links from being used or followed when you

adds the title of the page to the Info column

use this search set. Add the domains or links

when possible. You can copy URLs in this

that you want to be excluded into the text

list to the clipboard or drag them to other

fields. You can use asterisk (*) wildcards to

applications, too.

include e.g. all subdomains or partial links.
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You can use ranges like [01-31] or [1-31] to

Open: Opens the selected sites in separate

quickly add whole ranges of URLs. Add

web browser windows.

"https://www.classicfm.nl/playlist/per-

Open In Tabs: Opens the selected sites

dag/201202[01-29]" to add all playlist

in separate tabs in a new web browser

from .../20120201 through .../20120229.

window.

Uncheck a page to exclude it temporarily
from being scanned; check the page to
include it in the next search run.

CRAWL VS. SEARCH MODE

Launch URL: Opens the website in your
default web browser.
Enable/Disable: Checks or unchecks an
item. Unchecked (disabled) websites are
not scanned when using this search set.
Copy: Copy the URL of the selected

DEVONagent Pro can either crawl (scan) or

website to the clipboard.

search sites added to the list. You can set this

Paste: Pastes a URL from the clipboard to

option individually for each site.

the list, effectively creating a new item.
Delete: Deletes a selected item.

Crawl: Downloads the page and adds it to
results when it matches the query.
Search: Searches the site using common

PLUGINS TAB

search engines. The found results are

The Plugins tab defines which plugins

downloaded and added to the results when

(interfaces to search engines) DEVONagent

they match the query.

Pro uses when you use this search set in the

Depending on your settings, promising links

search window.

are followed.

TAKING OVER URLS
To take over bookmarks from other
applications and create new search sets from
them, use drag-and-drop or copy/paste,
or import bookmarks or OPML files. Open
the settings editor and use File > Import or
the Action menu to import bookmarks from

PLUGIN LIST

Camino, Firefox, OmniWeb or Safari, as well
as OPML files generated by news readers or

Plugins are grouped. Expand or collapse

DEVONthink.

groups by clicking the grey triangle in front
of the group name, like in the Finder. Check

CONTEXTUAL MENU

all plugins that you want DEVONagent
Pro to use for this search set; uncheck all

The contextual menu allows you to work with
website addresses selected in the sites list.
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others. Check or uncheck a group to check or
uncheck plugins contained within the group.
Select a plugin to display a short description.
To find out which search engines a plugin
uses to get results, use Window > Plugins &
Scanners or see the appendix.
Example: Check "Images", "Info (Pictures)"
and "Picsearch (Images)" to search all major
picture search engines.

RESULTS PER PLUGIN

INTERFACE
Bounce Dock icon: Bounces DEVONagent
Pro's Dock icon once when the search run is

This value defines the number of results

completed.

delivered by every plugin. It limits the results

Zoom and bring to front: Zooms the

pool to the most relevant <n> results. Adjust

search window and makes it the frontmost

this to whatever suits your requirements; the

window.

default value is 100.

Use Notifications: Posts a notification on
OS X 10.8 "Mountain Lion" or later.

ACTIONS TAB

Play sound: Plays a sound. Select the sound
to be played from the pop-up menu; all

The Actions tab lets you attach additional
actions to a search set that DEVONagent Pro
executes after finishing a search run using
this search set.

systemwide alarm sounds are available.
Speak text: Speaks entered text. Use
the escape sequence "%d" in the text to
announce the number of found items.

RESULTS
Archive results: Adds all found pages to the
internal archive.
Add results to DEVONthink: Adds all found
pages to the currently opened DEVONthink
database. Choose the desired format and
destination from the popup menus below
this option.
Send mail to: Sends a summary of the
found information to an entered email
address. This is especially useful when used
with a schedule.
Execute script: Executes an AppleScript.
Use this to do whatever you like with
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the found information, e.g., feed it into a
local workflow or post automatically to a
website.

FREQUENCY, ...
Frequency: Define if you want DEVONagent
Pro to run the search set hourly, daily,

Note: The email function uses the email

or weekly, or select Never to switch the

account defined in Preferences, Email tab.

scheduler off.
Time of Day: Define at which time of the

SCHEDULE TAB

day DEVONagent Pro runs the search set.
Day of Week: Define on which day of the

The Schedule tab is what makes DEVONagent

week DEVONagent Pro runs the search set.

Pro a bona fide information agent. It lets you
schedule automatic query runs hourly, daily

OPTIONS

or weekly, and return the results by email,
archive them internally, or add them to your

Quit when done: Quits DEVONagent Pro

DEVONthink database.

after the search run is completed.
Close window: Closes the search window
when the search run is completed.
Ignore cache: Ignores the cache and always
load all pages from the Internet. Uncheck
to use DEVONagent Pro's cache and to
reduce network traffic.
Next run: Checks when this search set will
run next (informative only).

Note: A scheduled search set uses the
default query you enter on the "General"
tab and runs this query at the scheduled
time. Make sure to enter a default query
when you use the scheduler.
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MENUS
IN THIS CHAPTER

including the version number and licensing
information.

The DEVONagent Pro menu

36

The File menu

37

The Edit menu

39

The Data menu

39

The Sort menu

41

The View menu

41

The Web menu

42

Note: No information from your computer

The History menu

43

is uploaded to the DEVONtechnologies

The Go menu

44

server during the check for updates.

The Window menu

45

DEVONagent Pro only downloads a file

The Services menu

45

listing the most current versions to your

The Scripts menu

46

Mac.

The Help menu

46

The Dock menu

47

Check for Updates: Checks if updates for
DEVONagent Pro are available. By default,
DEVONagent Pro checks for updates
automatically; change your update settings
in the Preferences, Update pane.

PREFERENCES, ...

A complete listing of all commands

Preferences: Opens the Preferences.

DEVONagent Pro offers in the menu bar, the

Private Browsing: Select this command

global Services menu, and the handy Dock

to check or uncheck the private browsing

menu.

mode. If this menu item is checked,
DEVONagent Pro clears all caches, history

THE DEVONAGENT PRO MENU

files, and the find pasteboard after
quitting, so that anyone using this user

The DEVONagent Pro menu is similar to the

account on this computer cannot later

application menu in any Mac application.

discover your search history. This option

It contains commands for displaying the

also prevents DEVONagent Pro from

splash screen, opening the preferences

storing previous search terms in the Recent

window,accessing the Services menu,

Searches sub-menu of the magnifying glass

hiding and showing windows, and, of course,

pop-up menu of search windows.

quitting the application.

Empty Cache: Empties the disk cache that
is used to speed up browsing. Use this if

ABOUT DEVONAGENT PRO, ...
About DEVONagent Pro: Shows
information about DEVONagent Pro

you are running out of disk space or when
you feel that pages or elements are not upto-date. Emptying the cache effectively
forces DEVONagent Pro to download from
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the Internet all files in their most recent
versions.

PURCHASE, ...

NEW SEARCH, ...
New Search: Opens a new search window.
You use search windows to send queries
to a predefined search set or a selected

Purchase: Opens the DEVONtechnologies

plugin, that then queries one or multiple

website and places DEVONagent Pro

search engines and presents the weighted

into your shopping cart. If this copy of

results. Search windows are what give

DEVONagent Pro is already licensed, you

DEVONagent Pro its name and purpose.

will be presented with the choice of buying

New Plugin: Opens the Plugins & Scanners

an upgrade for your existing license or

window and lets you create a new custom

buying another full license.

plugin. Use this function to easily create a

Enter License: Use this command to enter

plugin for your favorite yet-to-be search

your licence code. Make sure you enter

engine.

ALL the details EXACTLY as they appear
in the licence code email. It is best to use
copy-and-paste for transferring name,
organization, and licence code from the
email message to the appropriate fields.
Make sure not to highlight any spaces
before or after the required information.

NEW BROWSER, ...
New Browser: Opens a new web
browser window.Use this function to
use DEVONagent Pro as a standard web
browser that is optimized for research. The
web browser is based on the same WebKit

Note: Enter License changes into License

engine used by Safari.

as soon as you enter a valid license code.

New Tab: Creates a new tab in the
frontmost web browser window.If the

SERVICES
The Services sub-menu gives you access
to special commands published by other
Mac applications such as TextEdit or
Safari, or by services extensions such
as our own WordService or CalcService.
Also, DEVONagent Pro publishes its own
services. See also p. 45ff

THE FILE MENU

frontmost window is a search window
rather than a web browser window, this
command opens a new web browser
window instead.
Open Location: Brings the address field of
the frontmost web browser window into
focus. If no web browser window is open,
DEVONagent Pro opens a new one, equal to
File > New Browser.

OPEN FILE, ...

The "File" menu contains all commands that

Open File: Opens a local file for viewing in a

create new windows, open or save files or

new web browser window or in a previsouly

settings, and print.
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saved search. Alternatively, drag the file

frontmost, the bookmarks will be added to

onto DEVONagent Pro's icon in the Dock.

DEVONagent Pro's own bookmark list.

Open Recent: Lists the recently used saved

Safari History: Imports the Safari history

searches so that you can quickly open

file and creates a new search setwith all

them.

imported URLs in the Sites tab.

SAVE AS, ...

EXPORT

Save, Save As: Saves the content of

Digest: Exports the digest as plain or rich

the frontmost web browser window in

text file. This command can also export

its original format or a search run for

the topics map as a PDF document or

future reference. Webpages are saved

OPML for outliners and mind-mapping

as pure HTML code or webarchives (see

applications.

below), images, movies, and PDFs in their

Report: Exports a search report as PDF,

respective formats. Search runs are saved

CSV (comma-separated values), HTML, or

as '.agentSearch' files that can be double-

OPML file. Use the CSV or OPML formats

clicked in the Finder or opened via File &

to export all results in a structured way

Open. They include the term, the used set

in order to re-import them into other

or plugin, the settings, the results and their

applications such as Microsoft Excel or

sortings, the digest, the log, and a Quick

Apple Numbers.

Look preview.

Results: Exports selected search results
in their original formats, or as bookmarks,

IMPORT
Sets: Imports saved search setsand adds
them to the list of available search sets.
You also can import saved search sets by
double-clicking them in the Finder or by
dragging them to DEVONagent Pro's Dock
icon.
OPML: Imports all URLs contained in
an OPML file and creates a new search
setwith the URLs in the Sites tab. Use this

plain text files or rich text files.
Sets: Exports one or more selected search
sets and saves them as files. These files
can be re-imported using File > Import
> Sets or by double-clicking them in the
Finder. Use exported sets to shared them
with other DEVONagent Pro users or
between computers.

PAGE SETUP, PRINT

to import RSS feeds exported as OPML

Page Setup: Opens the standard page

from a news reader.

setup dialog.

<Application> Bookmarks: Imports Camino,

Print: Prints the contents of the frontmost

Firefox, Chrome, OmniWeb, or Safari

window.

bookmarks and creates a new search set
with all imported URLs in the Sites tab.
Both site and news feed bookmarks are
supported. If a web browser window is
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THE EDIT MENU

FIND

The "Edit" menu contains all commands and

This sub-menu contains commands for

options related to editing. You'll find the

finding and replacing text. In most ways it

classic Mac cut/copy/paste and find/replace

is similar to the Find command in most Mac

commands here, as well as many more.

application, but it also contains DEVONagent
Pro-specific items.

UNDO, REDO
In Internet: Opens a new search window.
Undo: Takes your changes back one step.

In Results:

Undo mainly works for text edits, but will

Find...: Opens the standard find panel.

not bring back deleted documents.

Find Next/Previous: Jumps to the next or

Redo: Redo re-does the last undone edit.

previous occurrence of the find term.
Use Selection for Find: Copies the selected

CUT, COPY, PASTE
Cut: Cuts the selected items or text
passages.
Copy: Copies the selected items or text
passages to the clipboard.
Copy URL: Copies the URL of the selected
page or frontmost web browser window to

piece of text to the find clipboard or into
the search field of the find panel if it is
open.
Scroll To Selection: Scrolls the displayed
documents to the current selection.

SPELLING, ...

the Clipboard.

Spelling and Grammar: The spell and

Paste: Pastes whatever is on the Clipboard.

grammar checker. Useful for checking text,

Clear: Deletes the selected item or piece of

e.g., when filling out form fields.

text.

Speech: Speaks a selected piece of text.

Complete: Auto-completes a word in text

Special Characters...: Shows the standard

and search fields as well as in text views.

special characters panel for inserting

This OS X standard function relies on

characters that you cannot enter directly

the dictionary you have selected in the

with your keyboard, such as accented or

spellchecker (see below).

umlauted characters.

Select all: Selects all contents of the
frontmost window.
Deselect all: Deselects all contents of the

THE DATA MENU

frontmost window. Hold the ⌥Option key

The Data menu provides commands for

to show this menu item.

opening search results, exporting them to
DEVONthink, archiving them, or organzing
them in the built-in archive.
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NEW GROUP, ...
New Group: Creates a new group in the
archive. To create a sub-group, select an
archive group first, then use this command.
Open: Opens the selected search results
in new web browser windows. Same as
double-clicking the results.
Open In Tabs: Opens the selected search

archiving webpages that you may want to
print later.
Web Archive: Saves webpages as
webarchives. Webarchives are selfcontained files that include one webpage
that includes all additional files necessary
for displaying, e.g., embedded images or
movies. Only available in the web browser.

results in separate tabs in a new web

DEVONagent Pro adds 'DEVONagent Pro plus

browser window.

the name of the plugin used to find the page

Launch URL: Opens selected search

and its version to the comments when adding

results in your default web browser. If

to DEVONthink.

DEVONagent Pro is your default browser,
this command is equal to "Data > Open..."

ADD TO DEVONTHINK, ...
via Clip to DEVONthink:
Resource: Adds the selected page or
document as-is to DEVONthink.
Bookmark: Saves links to the selected
pages as bookmarks.
Rich Text: Saves selected text as a new
text document.
Summary: Saves the whole digest as text
document. Available on the Digest and
Results tabs of Search windows as well as
in the archive.
Formatted Note: Saves the selected page
as new formatted note.
Markdown: Saves the selected page as new
Markdown document.
PDF (one page): Saves the selected
pages as PDFs without page breaks. A
long webpage will be saved as one, very
long page, making this function ideal
for archiving. Only available in the web
browser.
PDF (paginated): Saves the selected pages

Note: These items are only available when
DEVONthink is installed on your Mac.

ADD TO SET, ...
Add To Set: Adds selected pages, e.g.,
search results, to the "Sites" listof a search
setyou select from the sub-menu. These
pages will be scanned for an entered query
the next time you use this search set and
can be useful to include in future searches.
Select "New Set..." from the sub-menu
to create a new search with the selected
pages.
Add To Archive: Adds the selected results
to the archive,creating a new group for
current search run. If a group for this
search run already exists, any subsequently
added page from same search run will be
added to this archive group.
Add All To Archive: Appears insteat of Add
To Archive when you hold the ⌥Option key
down. Adds all results of a search run to
the archive,creating a new group for them.
Use this command to archive all results of a
search run with one click.

as PDFs with page breaks. Use this for
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MARK ALL READ, ...
Mark All Read: Marks the selected results
as read or unread.
Delete: Deletes search results from a
results list in a search window,as well as

Top Level Domain: List results sorted by
their top level domain.
Relevance: List results sorted by relevance.
Number of Objects: List results sorted by
the number of found objects.

groups or items from the archive.

Top Level Domain means the last part of a

Delete Domain: Deletes all results from the

website address. Usually it is defined by the

selected domains from the current results

country the website is located in, e.g., '.de'

list.

for Germany or '.cz' for the Czech Republic, or

Delete & Exclude Domain: Deletes the

by function, such as '.com' for a world-wide

selected search results from a results list in

commercial site or '.mil' for a US military site.

a search window and adds the domains of
the pages to the list of excluded domains.
All other search results matching the
exluded domains are removed. Use this
function to quickly exclude an unwanted

Relevance is the relevance of a result
compared to all collected results in respect to
the query. This is the default sorting order.
Ascending, Descending:

domain without having to block it via the
Preferences. Alternative menu item to
Delete Domains.

Ascending: Sorts items ascending.
Descending: Sorts items descending.

Clear Log: Clears the Log tab of the
frontmost Search window.

THE VIEW MENU

Note: Use Delete and Delete & Exclude

The View menu allows you to switch between

Domain with care. You cannot undo these

the various tabs of a Search window,

commands.

to switch Cover Flow on and off, and to
customize how objects are presented in web

THE SORT MENU

browser windows.

The Sort menu sorts search results in a

DIGEST, ...

variety of ways.
Digest: Switches to the "Digest" tab. The
Unsorted, By Name, ...:
Unsorted: List results in their natural order.
Useful after opening a saved search to
easily view new results.
Name: List results sorted by name.
Date: List results sorted by date.

digest shows a summary of the found
information (not the pages), sorted by
relevance. In addition, it visualizes topics
in a topics map that lets you navigate
the results graphically. Use the digest
and the topics map to work with the

Size: List results sorted by size.
URL: List results sorted by URLs.
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information itself instead of manually

tab the Inspectors pane of web browser

visiting webpages.

windows and the archive.

Results: Switches to the "Pages" tab. The

Use Small Icons: When checked, objects

"Pages" tab lists all found pages, sorted by

are shown with small icons and more

relevance (or any sorting order you choose

information in the sidebar of web browser

in the "Sort"menu). A preview pane displays

windows. When unchecked, objects are

the relevant text parts of a selected result.

shown with large icons and no details.

Log: Switches to the "Log" tab. The log lists
all webpages that DEVONagent Pro has
filtered out as being irrelevant to the query
or outdated. View a selected page in the
preview page. Use the log to see how many
pages you DON'T have to look at because
you're using DEVONagent Pro instead of
Google or other search engines.
Settings:
Advanced:

SHOW TOOLBAR, ...
Hide/Show Toolbar: Hides or shows the
toolbar of the frontmost window.
Customize Toolbar: Lets you configure the
toolbar of the frontmost window.
Enter/Exit Full Screen: Puts the frontmost
window into full screen or back into
windowed mode. Press ⎋ to return to
windowed mode.

SUMMARY, OBJECTS

THE WEB MENU
Summary: Selects the Summary tab of the
Pages tab of Search windows.

The Web menu contains all commands that

Objects: Selects the Objects tab of the

are directly related to web browsing, from

Pages tab of Search windows.

quickly turning Java on or off to switching
between views and reloading a webpage. All

COVER FLOW, ...

commands in this menu act on the frontmost
web browser window.

Cover Flow: Switches between the regular
display of results or tabs and Cover Flow.

ENABLE PLUGINS, ...

Cover Flow lets you browse graphically and
quickly through results or the pages opened

Plugins: Enables or disables plugins.

in multiple browser tabs.

Java: Enables or disables Java.

Inverse Appearance: Inverts the colors

JavaScript: Enables or disables JavaScript.

of the results list in search and browser
windows to match it with Cover Flow.
Uncheck to return to the regular black-on-

Use these options to quickly switch plugins,
Java, or JavaScript on and off without
visiting the Preferences.

white appearance.
Show Icon Preview: Shows or hides the

STOP LOADING, ...

icon previews in Results tab of search
windows, Sidebar drawer and See Also

Stop Loading: Stops loading a the
webpage. This is equal to clicking the

DEVONagent Pro 3.11.3 Documentation, page 42

reload/stop button on the address bar

These three options switch the mode of the

of a web browser window when a page is

frontmost web browser window between

loading.

different modes. Use these modes to view

Reload Page: Reloads the webpage. This is

only the raw text of a layout-intensive

equal to clicking the reload/stop button on

webpage, or to switch to the source code to

the address bar of a web browser window

find information that is hidden in the code

when a page is completely loaded.

but not visible in the layout. DEVONagent Pro

Actual Size: Zooms the page to its actual

displays the source code with syntax coloring.

size.

The text only mode is also useful for copying/

Zoom In: Zooms in.

extracting information from pages with a

Zoom Out: Zooms out.

complex table layout.

Zoom Text Only: When this option is
checked, only the text of the page is made
larger and smaller. When unchecked,
DEVONagent Pro uses Safari-4-style
zooming.
Translate: Translates the displayed
page using the Google language tools to
your system's preferred language. This
command is unavailable if the recognized
language of the displayed page is the same

SIDEBAR
Show: Shows or hides the sidebar.
Bookmarks: Switches to the bookmarks
pane of the sidebar.
Results: Switches to the results pane of the
sidebar.

INSPECTORS

as the preferred language of your system.

Show: Shows or hides the Inspectors tab of

Text Encoding: Changes the text encoding

the frontmost web browser window.

used for displaying a webpage. Use this

Properties: Switches to the properties tab.

sub-menu to manually adjust the text

Objects: Switches to the objects tab.

encoding if DEVONagent Pro displays

See Also: Switches to the See also tab.

accented characters, umlauts or East Asian
characters incorrectly. Generally, websites

ADDRESS BAR

publish their encoding and DEVONagent
Pro reads this metadata for adjusting the
encoding automatically.

Address Bar: Shows or hides the address
bar. Hiding the address bar gives you more
useable screen space for the displayed

VIEW, ...
Source Code: Shows the source code of the
webpage.

webpage.

THE HISTORY MENU

Text: Shows only the pure text of the

As with any web browser, the History menu

webpage.

lists all webpages previously visited, divided

Layout: Shows the webpage rendered

into subfolders for each day, and marked with

(normal).

the date and time you last viewed them.
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BACK, FORWARD, CLEAR HISTORY

BOOKMARKS

Back, Forward: Moves back and forth

Besides the commands mentioned above, the

between the visited pages. These

Go menu gives you access to the bookmarks

commands are equal to the back and

of Safari, Camino, Firefox, or OmniWeb,

forward buttons in the address bar of web

or DEVONagent Pro's own bookmarks list.

browser windows. Since there is no history

Select which bookmarks DEVONagent Pro

when private browsing is active, these

shows in the Go menu in the preferences.

commands are not available when private
browsing is switched on.
Clear History: Clears the history.

VISITED WEBPAGES

Add: Adds a bookmark for the currently
shown webpage.
Add Folder: Adds an empty folder to the
bookmarks list.
Edit: Opens an edit sheet for the currently

The rest of the History menu lists the

selected bookmark. This function is

previously visited webpages, sorted from the

unavailable when two or more bookmarks

top by age.

are selected.
Delete: Deletes the selected bookmarks.

THE GO MENU

<Bookmarks>: Opens any selected
bookmark; use Open in Tabs in any

The Go menu contains commands for

bookmark folder to open all bookmarks in

navigating back and forth through a results

the folder in separate tabs.

list in a search window or occurrences
of a search word, as well as for using and

For these commands to work, a web browser

managing bookmarks.

window needs to be active and DEVONagent
Pro use its own bookmarks. You cannot

NEXT/PREVIOUS RESULT/OCCURRENCE

yet edit Safari's bookmarks from within
DEVONagent Pro.

Next/Previous Result: Navigates back
and forth through the results lists to

BONJOUR

which the displayed webpage belongs. Use
these commands to go through the pages

The Bonjour part of the Go menu lists web

resulting from a search run.

services advertised on the local network via

Next/Previous Occurrence: Jumps to the

Bonjour, e.g., printers with web interfaces or

next or previous occurrence of the search

shared DEVONthink Pro Office databases.

term, e.g., in the digest or pages tabs of
search windows.

WORKSPACES
Workspaces save the content and positions
of all open windows so that you can restore
them later. This is ideal if you are working
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with the same set of windows over and over
again. Save the windows as a workspace and
recall them whenever needed.

Archive ... Downloads:
Archive: Opens the Archive window.
Search Sets: Opens the Search Sets panel,

Add: Saves the currently open windows as

which allows you to edit the available

a workspace.

search sets.

Edit: Opens a window that allows you

Plugins & Scanners: Opens the Plugins

to edit saved workspaces. Click on a

& Scanners panel that lists all installed

workspace name to change it, reorder it by

plugins and scanner modules. Use

dragging, and delete it with the . button.

this panel to see which plugins or

Update: Updates the last used workspace

scanner modules are available, get more

to the currently open windows.

information about them, and activate and

Workspaces: Restores to a previously saved

deactivate them.

workspace.

Downloads: This command opens the
Downloads panel. Use it to download files

THE WINDOW MENU
As with any Mac application, the Window
menu lists all open windows of DEVONagent

from the Internet to your computer.

THE SERVICES MENU

Pro and gives you access to commands for

The Application > Services menu (where

managing them.

'Application' is the name of the frontmost

Window Commands:

application) allows access to special
commands published by other applications,

Close/Zoom/Minimize: These three

such as TextEdit or Safari, or by services

commands resemble the red, yellow and

extensions such as DEVONtechnologies'

green buttons of any window title bar and

WordService or CalcService. Also,

consequently close the window, maximize

DEVONagent Pro publishes its own services

it or create an icon on the dock. No magic

in the Services menu.

here.
Bring All to Front: Brings all windows of
DEVONagent Pro to the front.
<Window name>: Brings a selected window
to the front.
Tab Commands:
Close Tab: Closes the current tab of the
frontmost web browser window.
Select Next/Previous Tab: Switches to the
next or previous tab of the frontmost web
browser window.

The Services menu is a sub-menu of every
application's application menu, the menu
named after the application itself and
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carrying the About X, Hide ... and Quit

Some of the scripts work without a selected

commands. Services usually act on a

document; others require you to select the

selection, e.g., selected text or files.

document you want the script to interact

Services provided by DEVONagent Pro:
Lookup: Opens a new search window in
DEVONagent Pro with the query field
pre-filled with the selected text. Use this

with. In general, the script will tell you what
you have to do when you select it from the
Scripts menu.
See also p. 83ff

command to quickly search for a selected
piece of text.

THE HELP MENU

Open URL: Opens a selected piece of text

The Help menu contains commands for

as a URL in DEVONagent Pro. Use this

opening the integrated help pages or

to quickly select a URL, e.g., in an email

the support assistant, or for visiting the

message, and open it in a DEVONagent Pro

DEVONtechnologies website.

web browser window.
Use Application > Services > Services

DEVONAGENT PRO HELP

Preferences to change keyboard shortcuts

These commands open the integrated help

or hide selected commands to clean up the

pages that are equal to the document you

Services menu.

reading or open the release notes.

Note: After installing DEVONagent Pro you
may need to log out and back in again for

SUPPORT ASSISTANT, TUTORIALS

the Finder to recognize the new Services

Your Account: Opens your customer account

menu commands and shortcuts. If one

page where you can look up your details and

or more DEVONagent Pro Services menu

licenses.

commands does not have a keyboard
shortcut assigned to them, perhaps

Support Assistant: Opens the support

another application grabbed it. OS X

assistant where you can, for example, read

automatically assigns the correct shortcut

the FAQ, visit the user forum, download

when no other application asks for the

this documentation as printable or screen-

same key combination.

readable PDFs, retrieve your license code, or
log in to your customer account.

THE SCRIPTS MENU
The Scripts menu is located left of the Help
menu and shows a graphic AppleScript 'S'

Tutorials: Opens the assistant on the Tips &
Tutorials page.
Click here to open the support assistant.

symbol instead of a normal menu title. It
contains a collection of useful predefined
AppleScripts you can use directly from within
DEVONagent Pro.
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Note: If you purchased DEVONagent Pro
from the Mac App Store, not all options
dealing with licenses or upgrades are
available.

DEVONTECHNOLOGIES
Visit the DEVONtechnologies website
and ask questions or meet your fellow
users in the lively user forum. Contact the
DEVONtechnologies team and provide
feedback directly to the development team.
You can also send a bug report including the
most recent crash logs. This is an alternative
menu item to Contact us.

THE DOCK MENU

For all Mac applications, the Dock menu

The Dock menu appears when you ⌃-click

provides a selection of the commands of the

or right-click DEVONagent Pro's icon in the

application menu.

Dock. In addition, DEVONagent Pro's icon
shows a badge with the number of found
results.

<Window Name>: Brings any open window
of DEVONagent Pro to the front.
Options > ...: Keeps DEVONagent Pro in
the Dock or removes it, adds DEVONagent
Pro to your login items, or reveals the
DEVONagent Pro application package in
the Finder.
Hide: Hides all windows of DEVONagent
Pro.
Quit: Quits DEVONagent Pro.
Besides these standard commands,
DEVONagent Pro adds a number of its own
commands to the Dock menu to make them
easily accessible whenever the application is
running.
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New Search...: Opens a new DEVONagent

depending on your settings in Preferences

Pro search window. Same as File > New

> Bookmarks, Bonjour services, and

Search

workspaces. Equals the Bookmarks,

New Browser...: Opens a new DEVONagent

Bonjour, and Workspaces parts of the Go

Pro web browser window. Same as File >

menu.

New Browser"
Bookmarks, Bonjour, Workspaces:
Gives you access to your bookmarks,
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WINDOWS AND PANELS
IN THIS CHAPTER

DEVONagent Pro uses a number of different

Search window

50

Web browser

57

Archive window

64

Search sets

66

Plugins and scanners

66

Downloads

69

Preferences

70

Assistant

70

windows for running search queries,
displaying webpages, setting up search sets,
and downloading files.
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SEARCH WINDOW

The search window is where you start search

search run has finished (or you have clicked

runs and work with the results. You open a

the Stop button), DEVONagent Pro expands

new search window with File > New Search

the search window, if necessary, and presents

In its minimized form, the search window

the results in either the Digest or the Results

consists only of an entry field for the query, a

tab, depending on your preferences.

pop-up menu for selecting the search sets to
be used, a Start/Stop button, and an Append
button. In maximized form, it is divided into
four tabs: Digest, Results, Log, and Settings.
You can switch between minimized and
maximized form by clicking the green window

If you have already performed a search run,
you can also use the Append button instead
of Start to append the search results to the
previously collected ones instead of replacing
them.

gadget. Also, you can choose whether you

Note: DEVONagent Pro limits search runs

want to open new search windows as either

to 500.000 result pages and 32 GB of data.

minimized or maximized in the preferences,

This prevents flooding your hard disk when

"General" tab.

your search query or your Follow Links

To start a search run, select the correct
search set from the magnifier pop-up menu in
the entry field, enter your query and click the

settings are too broad.

MAGNIFYING GLASS POP-UP MENU

Start button. DEVONagent Pro then queries

The magnifying glass pop-up menu

all search engines and scans all webpages

you select the search set you want to use

defined by the search set. As soon as the

for your search. For a general search, use the

lets
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search set Web (Fast). You can define your
own search sets in the Search Sets window,
which you can open by selecting Edit Search
Sets from the magnifier pop-up menu.
User-defined plugins are listed in bold.
Note: You can easily create a new search
set by using the + button left of the search

DIGEST TAB
DEVONagent Pro's search window is divided
into three views, each presenting different
aspects of the information that has been
collected in a search run. You switch between
the views by clicking the tabs separating the
search field from the rest of the window.

term field. Use this to run the same query

The digest differs from what traditional

with exactly the same settings again in the

search engines and applications display.

future.

This is what makes DEVONagent Pro unique.

Plugins: In addition, this pop-up menu gives
you direct access to every installed plugin.
This way, you don't have to define a search
set just for querying a special search engine
once. You can simply pick the one you want to
use, enter the query and hit the Start button.
Tool tips give you more information about
each plugin.

Instead of simply listing the URLs of found
pages, the digest shows a list of topic words
and two- and three-word expressions that
DEVONagent Pro has extracted from the
collected data. This list not only includes the
entered search words, but also many other
words that the artifical intelligence core of
DEVONagent Pro found to be important and
related to the query. You can sort this list

Recent searches: The magnifying glass pop-

by topic or relevance by clicking the column

up remembers the last 25 search terms

headers. The number of sentences with

(when private browsing is not enabled). You

occurences is shown for each topic word.

recall the terms simply by selecting them
from the Recent Searches part of the menu.
Remember to select the correct search set or
plugin. Clearing the recent serarches empties
the system-wide find pasteboard too.
Recently used: Finally, find here the most
recently used plugins or search sets for quick
access.

Topics map: In the right-hand side pane,
DEVONagent Pro shows short paragraphs
from every found webpage until you select

STATUS BAR

one or more topic words. DEVONagent Pro

The status bar below the search field shows

shows an AI-generated visual representation

information about the number and size of the

of the selected topic and its relations to

downloaded files, found results and objects,

other topics in a mind-map style. Two-and

as well as unread results.

three-word word expressions do not show a
topics map; for multiple selected topic words
DEVONagent Pro always picks the top one.
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The selected topic becomes a big blob in

interested in. You can also click words in the

the center of the map with related topics

summary with ⌥ held to refocus the topics

arranged around it. The larger a blob, and the

map on the clicked word.

more orange or red it is, the more important
it is. Topics that are related to the selected
word but are not part of the topics list
on the left, are shown in blue. Light grey
lines indicate closer relationships between
topics. Move the mouse over the topic
blobs to highlight the connetions to other
topics in the graph; click a blob to select it.
Double-click a topic in the map to make it
the center of the graph. DEVONagent Pro
will recalculate the map accordingly. This is

Note: You can also select multiple topics
with the ⇧ and ⌘ keys, or enter your own
keywords separated by spaces, into the
text field below the topics list. For the
topics map, DEVONagent Pro will only
use the first selected topic word. It does
not work with words you enter into the
keyword text field.

RESULTS TAB

similar to selecting another topic word from

List or Cover Flow: The Pages tab is similar

the list on the left.

to what most search engines deliver: a list

Use the arrow buttons in the bottom bar of
the topics map area to navigate back and
forth through the results in the digest.

of all found URLs including the name of the
webpage and a two lines excerpt from where
the search terms are found on the page. Sort
the list by all the criteria that you can find in

Summary: Finally, below the topics map,

the Sort menu. You can also drag results to

DEVONagent Pro shows a summary of the

DEVONthink to quickly archive them in your

extracted information, sorted by relevance.

database.

At the end of each extract, you'll find a link
to the original source where DEVONagent
Pro extracted the data from (click the link
with ⌘ held to open it on a new tab instead
of in a new window). The summary delivers
the actual answer to your query, effectively
eliminating the need to go through a long
list of links or visit hundreds of webpages
manually.
The summary dynamically changes with
whatever topic word or words you select in
either the left-hand side pane or the topics
map. This way, you can use the topics map
to navigate through the found information
and refocus the summary to whatever you are
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LOG TAB
The Log tab lists all pages that DEVONagent
Pro has skipped.
DEVONagent Pro skipped them because they:
Did not match the query
Delivers an error message, e.g., the famous
error 404 (file not found)
Are an advertisement
Are index spam created for fooling Google
and other search engines
You can browse the results also with Cover
Flow. Double-click a page in Cover Flow to

You can find a complete list of all codes used
in the log in the appendix.

open it in a new web browser window; hold
the ⌘ key to open the new window in the

Effectively, the log lists all pages you did not

background.

have to look at yourself because DEVONagent
Pro did that job for you.

All pages that you haven't checked yet
show a dot in front of them, similar to
unread messages in Apple Mail. You can
also select results and drag them to other
applications, such as an open TextEdit
window, DEVONthink, or the Finder, or delete
pages from the list that you have found to be
unrelated to your research. A badge shows
the number of found scanner objects.
Preview area: In the lower pane of the Pages
tab, DEVONagent Pro displays either a text

You can sort the list by date, address, or

preview of the relevant text passages for

error message by clicking the respective

pages selected in the list above, or all objects

column headers. Click them again to reverse

found by the automatically applied scanners.

the sorting order. Use copy-and-paste or

Switch between the text preview and the

drag-and-drop to move or copy URLs to

objects returned by the scanners using the

the Downloads panel, to a search set, to

navigation bar above the preview.

DEVONthink, or other applications, e.g.,
Safari.

In addition, you switch between small
and large icons, download all or selected
objects, and access the action menu from the
navigation bar.
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SETTINGS TAB
The Settings tab contains some of the
options from the General and Advanced of

of these are simply shortcuts for menu bar
commands. Here's a short list of the available
tools:

search sets and TEMPORARILY overrides

Open: Opens the selected page(s) in a

these settings.

separate web browser window.
Launch URL: Opens the selected page(s) in
your default web browser.
Export: Exports the selected page(s) as
pure text, RTF(D) or HTML.
DEVONthink: Adds the selected page(s) to
the currently open DEVONthink database
in the format you choose from the popup menu. Only available if DEVONthink is
installed on your Mac.
Add: Adds the selected page(s) to the
internal archive.
Add All: Adds all found pages to the
internal archive.

The Settings tabs offers the following

Archive: Opens a window for the internal

options:

archive.

Follow Links
Language
Filter & Scanner
Secondary Query

Delete: Deletes the selected page(s) from
the results list.
Print: Prints the results list.
Search: Searches the results on the Results
tab. Use the magnifying glass pop-up menu

Search In

to adjust your search options.

Files

View: Enables or disables Cover Flow and
shows or hides icon previews.

Use the Settings tab to temporarily enable or
disable options, e.g., to switch on a scanner

Note: Not all of these commands are

without permanently messing up the search

always available. You can customize the

set.

toolbar by selecting Viiew > Customize
Toolbar or by Control- or right-clicking

TOOLBAR

the toolbar background and selecting
Customize Toolbar from the contextual

The toolbar of DEVONagent Pro's main

menu.

windows carries many commands for
manipulating the way it displays information
and for manipulating selected items. Many
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SHORTCUTS & MODIFIER KEYS
Like any Mac application, DEVONagent Pro
uses modifier keys or shortcuts to access
frequently used functions or modify a
standard behavior.

in a variety of formats. Same as Data
> Add to DEVONthink. Only available if
DEVONthink is installed on your Mac.
Add to Set > ...: Adds the addresses of
the selected page(s) to the sites list of a
search set.Select "New Set..." to create a

Command-click: Adds an item to the

new search set with the selected page(s).

current selection of items.

Add to Archive: Adds the selected page(s)

Shift-click: Selects a range of items.

to the internal archive.

Space, Shift-Space: Scrolls down or up in

Add All to Archive: Adds all pages in the

non-editable text views, e.g., the summary.

results list to the internal archive.
Export: Exports the selected page(s).

CONTEXTUAL MENU

Mark As Read: Marks the selected pages as
read or unread.

The contextual menu, which appears when
you click something with the right mouse
button or when you click while holding
the ⌃ Control key down, offers a range of
commands tailored to what you can do with
the clicked object.

Delete: Deletes the selected page(s) from
the results list.
Delete Domain: Deletes all pages from the
selected domains from the results list.
Delete & Exclude Domain: Deletes the
selected search page(s) from the results

Most of the commands offered by the

list and adds the domain(s) of the page(s)

contextual menu have counterparts in a main

to the list of excluded domains. Use

menu, so you'll recognize them immediately.

this to quickly exclude an unwanted

However, to save menu bar real estate,

domain, without having to block it via the

DEVONagent Pro gives you access to some

preferences.

options only via the contextual menu.

Sort by > ...: Sorts the results list by the
criteria listed in the sub-menu. Alternative

Open: Opens the selected pages in

menu item to Delete Domains.

separate web browser windows.

Clear Log: Clears the log for the search run.

Open In Tabs: Opens the selected pages

Same as Data > Clear Log.

in separate tabs in a new web browser

Sort By: Sorts the results list by the

window.

selected sort key. See also p. 41ff

Copy URL: Copies the selected URL to the
clipboard.

In text areas, e.g., the text preview on the

Launch URL: Opens the selected page(s) in

"Pages" tab, DEVONagent Pro also offers the

your default web browser.

standard contextual menu commands for

Reveal in Finder: Reveals an externally

text views:

archived page in the Finder.
Add to DEVONthink: Adds the pages to
your currently open DEVONthinkdatabase
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Search with Spotlight: Searches for the

Spelling > ...: OS X's integrated spell

selected text using Spotlight.

checker. Choose "Spelling..." to open the

Search in Google: Opens your default

spellchecker panel, and "Check Spelling" to

browser and searches for the selected text

run the spell checker on the text. "Check

in Google.

Spelling as You Type" is not available in

Look Up in Dictionary: Looks up the

read-only text views.

selected piece of text in the system

Speech > ...: "Start Speaking" speaks

dictionary.

selected text, "Stop Speaking" stops

Cut/Copy/Paste: Same as "Edit > Cut/

speaking, which is useful when speaking a

Copy/Paste".

very long piece of text.
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WEB BROWSER

Besides being a research tool, DEVONagent

engine specific to the system language.

Pro is a full-fledged web browser, based on

Another option is to use DuckDuckgo Bangs

the Safari engine (a.k.a. 'WebKit'). Open a

in the address field.

new web browser window by choosing File >
New Browser, clicking a link, or by choosing
File > Open Location when no web browser
window is frontmost.

Example: Enter 'google devonthink' to
query Google for 'devonthink'; enter '!nws
saginaw,mi' to ask the National Weather
Service for the weather of Saginaw, MI.

To visit a website, enter its address into
the address field of the toolbar and press
↩ or Enter. Alternatively, drag a URL to
DEVONagent Pro's application icon in the
Finder or in the Dock, or into an open browser
window.

TAB BAR
The tab bar below the toolbar lists all tabs of
the web browser window. Each tab contains a
different webpage. Use tabs to open multiple
webpages without cluttering your screen with

Instead of a URL, you can use keywords to

dozens of separate windows. Switch between

directly send a simple query to a search

tabs by simply clicking the tab you want to

engine. This effectively replaces the Google

bring to the foreground. If all tabs do not fit

search field found in Safari and other

into the available space, DEVONagent Pro

browsers. The keywords are defined by the

shows an optional pop-up menu at the right-

plugins, but can be edited individually. If the

hand side of the tab bar listing all available

plugin supports it, keywords use a search

tabs.
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Point to a tab for one second without clicking

Address: Type in the URL to load here, or

to show a tooltip with a thumbnail preview

type in a keyword and a simple query. Read

of the webpage displayed on the tab. This

more about keywords here. Select the

is useful when you cannot remember which

whole address in the address field and drag

page you opened on which tab. Right- or

it to other windows or applications, e.g.,

⌃Control-click a tab to show a contextual

the Finder.

menu.

Translate: Shows the language of

Inactive tabs show a close button instead
of the webpage icon. Also, after the last
tab, DEVONagent Pro shows a "+" button for
creating new, empty tabs.

TOOLBAR

the displayed page as recognized by
DEVONagent Pro as a flag. If your system's
preferred language is different, clicking
the flag translates the page using Google
language tools.
See Also: Opens a drawer with pages
similar to the current one, sorted by

The toolbar of a web browser window can be

relevance. Select a page in the drawer to

customized like any other toolbar using View

display it. The originating page is always

> Customize Toolbar. The following tools are

listed on the top of the list. Use See Also

available:

for finding related pages in the results pool.
See also p. 58ff

Window: Shows or hides the sidebar;
switches Cover Flow mode on and off;
switches to full screen mode; hides or

Share: Shares the page via services like
iMessage, Mail, Twitter, Facebook, and
AirDrop, or adds it to Safari's Reading List.

shows the Inspectors pane.
View: Switches between source code, text,

If a bookmark for the current page exists in

and layout views. Use the source code view

the open DEVONthink Pro databases, a small

to inspect how a page is constructed and

DEVONthink icon is shown on the right-hand

the text mode to see the raw text without

side of the address field.

any distractions.
Action Menu: Access frequently used
commands directly from the toolbar. See
also p. 61ff
Back/Forward: Navigates back and forth
through the visited pages, like a standard
web browser. Similar to "History > Back/
Forward".
Smaller/Bigger: Makes the text smaller or

INSPECTORS
The Inspectors pane presents additional
information about the displayed web
page, e.g. metadata or extracted objects.
Depending on the displayed page, none, one,
or multiple of the following tabs, can be
available:

bigger.

Properties

Reload/Stop: Reloads the current page

See Also

(circle arrow icon) or stops loading a page
('X' icon).

AppleScript scripts
Audio
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Code

associated with them are also shown with

Downloadable archives

a single click; results without URLs open in

Electronic business cards (.vcard)

DEVONthink on a double-click.

Email addresses
Twitter posts
Images
LaTeX files
Links
News feed (Atom, RSS, JSON)
Office documents
Spreadsheet documents

Objects: Which, if any, of the other above
tabs are available depends on the web page
shown in the window. DEVONagent Pro
collects all objects from the page using the
available scanners and lists them in separate
tabs in the sidebar. Click any found object
to display it (double-click to open it in a new
tab, if tabbed browsing is enabled, or a new

Thumbnail galleries

browser window). Click with ⌘ pressed to

Cooking recipes

open the result in a new tab. The Back button

Video (live)

brings you back to the original page.

Videos
Wallpapers, desktop pictures
Webcams

Botttom bar: The bar at the bottom of the
sidebar gives you access to commonly used
commands, depending on which tab is active.

Properties tab: The Properties tab shows
metadata about the displayed web page.

List: Shows objects in a list with small
icons. See also p. 42ff

See Also tab: The See Also tab lists other

Icons: Shows objects as large icons. See

pages related to the displayed page from

also p. 42ff

three sources:

Download: Adds the selected objects

Search: The results of the search run to
which the page belongs.
Archive: Pages in the internal archive.
DEVONthink Pro: The currently open

to the Download Manager. If no item is
selected all items will be added.
Action: Gives access to the same options
as the contextual menu (see below).

DEVONthink databases.

Contextual menu: The contextual menu gives

Web: Related pages from the Web, either

you direct access to commands acting on the

provided by plugins or common search

selected items. Commands are only available

engines.

when applicable.

Click any item in the pane to display it;

Open in New Window: Opens the selected

double-clicking opens it in a new tab or

items in a new web browser window.

window. The original page stays at the top of

Open in New Tab: Opens the selected items

the list so that you can easily go back to it.

in a new tab.

Results from DEVONthink that have a URL

Open in PhotoStickies: Opens a selected
items in PhotoStickies.
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Open in DEVONthink: Opens a document

DEVONthink Pro bookmarks, or workspaces,

located in DEVONthink.

are listed on the Bookmarks pane. If you are

Reveal in DEVONthink: Reveals a document

using DEVONagent Pro for your bookmark

located in DEVONthink.

management, use cut/copy/paste, drag-and-

Add Link to DEVONthink: Adds a link to the

drop, or the contextual menu (see below) to

result to DEVONthink.

edit your bookmarks.

Copy: Copies the selected items to the
clipboard.
Download: Downloads the selected items
(or the items referred to by links).
Select/Deselect All: Selects or deselects all
items in the list.

Results: The Results pane lists all results
of the search run that the shown webpage
belongs to. This pane is unavailable if the
page does not belong to a currently open
search run.

Use Small Icons: When checked (default),

Bottom bar: The bar at the bottom of the

DEVONagent Pro displays small icons in the

sidebar gives you access to commonly used

drawer, including the name and the link to

commands, depending on which tab is active.

or of the item; when unchecked, it displays
large icons, 160 pixels wide, and shows no
links.
Open Video in Tab: Opens an HTML 5 video
in a new tab.
Open Video in New Window: Opens an
HTML 5 video in a new window
Download Video: Downloads an HTML 5
video.

+: Adds the current page to the bookmarks.
-: Removes the current page from the
bookmarks.
Back: Selects the previous search results
from the current results set.
Forward: Selects the next search results
from the current results set.
Delete: Deletes the current page from the
current results set.

SIDEBAR

Action: Gives access to the same options
as the contextual menu (see below).

The sidebar is the place in a web browser
window where all additional information
is presented, from bookmarks to the list
of search results (if the page is part of the
results of a current search run) to extracted

Contextual menu: The contextual menu gives
you direct access to commands acting on the
selected items. Commands are only available
when applicable.

objects. The sidebar is divided into several

Next/previous result: Navigates back and

sub-tabs:

forth through the list of results. Same as

Bookmarks
Results

Go > Next/Previous Result.
Mark as Read/Unread: Marks the selected
results as read/unread.

Bookmarks: Use the Preferences to choose

Delete: Deletes the result from the results

what bookmarks and additional elements,

of the search run it was opened from.

e.g., Web servers announced via Bonjour,
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Delete & Exclude Domain: Deletes the

Add to DEVONthink: Adds the pages to

result from the results of the search run

your currently open DEVONthinkdatabase

it was opened from and adds it to the

in a variety of formats. Same as Data

exclude list in the Preferences.

> Add to DEVONthink. Only available if

Sort: Changes the sorting of the result list.

DEVONthink is installed on your Mac.

Cut: Copies the selected items to the

Add to Set > ...: Adds the URL of the page

clipboard and removes it from the list.

to the "Sites" tabof the search set you

Copy: Copies the selected items to the

select from the sub-menu. Select "New

clipboard.

Set..." to create a new search set with the

Paste: Pastes bookmarks on the clipboard.

selected page(s).

Add Bookmark: Adds the current page to

Add to Archive: Adds the page to the

the bookmarks.

internal archive.

Add Bookmark Folder: Adds a new folder to

Save As: Saves the the selected pages as

the bookmarks.

pure text, RTF(D) or HTML.

Import: Imports bookmarks. See also p.

Translate: Translates the displayed

38ff

page using the Google language tools to

Edit: Opens an editing sheet for the

your system's preferred language. This

selected bookmark.

command is unavailable if the recognized

Delete: Deletes the selected items.

language of the displayed page is the same

Show Icon Preview: When checked,

as the preferred language of your system.

DEVONagent Pro shows a preview icon for

Inverse Appearance: Inverts the colors

bookmarks.

of the results list to match it with Cover

Add Link to DEVONthink: Adds the link of
the selected items to the currently open
DEVONthink database. Only available if
DEVONthink is installed on your Mac.

Flow. Uncheck to return to regular blackon-white appearance.

SHORTCUTS & MODIFIER KEYS

Copy Link: Copies the selected links to the

Command-click: Opens a link or an item in

clipboard.

the objects drawer in a new tab, if tabbed
browsingis enabled. Otherwise, ⌘-click

ACTION MENU
The action menu (labeled with a gear
icon) makes frequently used commands
conveniently accessible from the toolbar.

opens the clicked link in a new window.
Option-click: Downloads an item on a
webpage, a linked item or an item in the
objects drawer via the download manager.
Space, Shift-Space: Scrolls down or up in

Copy URL: Copies the address of the

non-editable text views, e.g., the source

current page to the Clipboard.

code or text-only view.

Launch URL: Opens the selected pages in
your default web browser.
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CONTEXTUAL MENU
The contextual menu, which appears when
you click something with the right mouse
button or when you click while holding
the ⌃ Control key down, offers a range of
commands tailored to what you can do
with the clicked object, for example a text
passage.

Copy Image Address: Copies the address or
the selected image to the clipboard.
Add Image to DEVONthink: Adds the
selected image to the currently open
DEVONthink database. Only available if
DEVONthink is installed on your Mac.
Add Image to Archive: Adds the selected
image to the archive.
Save Image As...: Saves the selected image

Most of the commands offered by the

to your computer.

contextual menu have counterparts in a main

Save Image to Downloads: Saves the

menu, so you'll recognize them immediately.

selected image to the default download

However, to save menu bar real estate,

folder.

DEVONagent Pro gives you access to some

Use Image as Desktop Picture: Saves the

options only via the contextual menu.

selected image and sets it as the desktop
picture.

Back/Forward: Navigates back and forth
through previously visited pages, similar to
the Back and Forward toolbar buttons or
History > Back/Forward.
Reload: Reload the item or page.
Search in Spotlight: Searches selected text
with Spotlight.
See Related Text: Opens the inspector with
archived results related to the selected
text passage.
Look Up in Dictionary: Looks up selected
text in the system dictionary.
Stop Loading: Stops loading the item or
page.
Open Image in New Window: Opens the
selected image in a new web browser
window.
Open Image in New Tab: Opens the
selected image in a new tab of the current
web browser window.
Open Image in PhotoStickies: Opens the
selected image in PhotoStickies.
Copy Image: Copies the selected image to
the clipboard.

Open Link in New Window: Opens the
selected link in a new web browser window.
Open Link in New Tab: Opens the selected
link in a new tab.
Open Link in PhotoStickies: Opens the
selected link in PhotoStickies.
Copy Link: Copies the selected link to the
clipboard.
Download Linked File: Downloads the file
referred to by the selected link via the
Download Manager.
Share: Shares the selected item using OS
X's standard share mechanism (requires at
least OS X Mountain Lion).
Add Selection to DEVONthink: Adds
the selected text to the currently open
DEVONthinkdatabase. Only available if
DEVONthink is installed on your Mac.
Add Link to DEVONthink: Adds the
selected link to the currently open
DEVONthinkdatabase. Only available if
DEVONthink is installed on your Mac.
Add Link to Set > ...: Adds the selected link
to the sites list of a search set.
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Add PDF to DEVONthink: Adds the

Add Web Archive to DEVONthink

displayed PDF to the currently open

(Pro): Adds an webarchive (including all

DEVONthink database. Only available if

embedded images needed for correctly

DEVONthink is installed on your Mac.

displaying it) of the page to the currently

Add page address to DEVONthink: Adds

open DEVONthink (Pro)database. Only

the address of the page to the currently

available if DEVONthink is installed on your

open DEVONthink database. Only available

Mac.

if DEVONthink is installed on your Mac.

Add Page/Frame to Set > ...: Adds the

Add frame address to DEVONthink: Adds

page or frame address to the sites list of a

the address of the selected frame to the

search set.

currently open DEVONthink database. Only

Add All Links to Set > ...: Adds all links

available if DEVONthink is installed on your

found on the page to the sites list of a

Mac.

search set.

Remember Selection: Remembers the
current selection and re-applies it when
you open the same page again.

For PDF pages, different options become
available:

Forget Selection: Forgets the last saved

Add PDF to DEVONthink: Adds the PDF to

selection.

the currently open DEVONthinkdatabase.

If the WebKit developer extras are enabled
more options are available.

Only available if DEVONthink is installed on
your Mac.
Open with Preview: Opens the PDF in

When you ⌃-click or right-click the

Preview.

background of the page instead of a item,

Automatically Resize: When checked, the

additional options can be available:

zoom factor adjusts to the width resp.

Open Page/Frame in New Window: Opens
the page or frame in a new web browser
window.
Open Page in New Tab: Opens the page in a
new tab.
Copy Page/Frame Address: Copies the
address of the page or frame to the
Clipboard.
Add Page/Frame to Archive: Adds the page
or frame to the internal archive.
Add Page to DEVONthink (Pro): Adds the

height of the browser window.
Zoom Out, Zoom In, Actual Size: Zooms in
or out of the document, or displays it in its
actual size.
Single Page, ...: Displays the PDF as single
or double pages and either page by page
(use the 'Next Page' and 'Previous Page'
to skim through the pages forward and
backwards) or continously.
Next Page, Previous Page: Skims through
the pages forwards or backwards.

HTML code of the page to the currently

On the Results pane of the sidebar, the

open DEVONthink (Pro)database. Only

following additional options are available:

available if DEVONthink is installed on your
Mac.

Mark As Read: Marks the selected pages as
read or unread.
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ARCHIVE WINDOW

The integrated archive is where you can store

Note: Pages not related to a previous

found pages for later reference. Open the

search run are archived in sub-groups of a

Archive window with Window > Archive.

top-level group named 'Incoming'. The sub-

The archive resembles the three panes view

groups are named with the current date.
of Apple Mail or DEVONthink: The left pane

Create new groups by using the toolbar,

shows a list of groups, the right top pane

the contextual menu or Data > New Group.

displays page titles and URLs in a selected

Rename a group by clicking it once and

group, and the right bottom pane displays

waiting a second (like the Finder), or by

textual information related to the query that

selecting it and pressing the ↩ or Enter key.

was used for finding a selected page. A search

Delete a group by selecting it and pressing

field in the toolbar allows you to search the

Backspace, using the toolbar, the contextual

archive by content, name or URL.

menu or Data > Delete. To make a group a
sub-group, drag it with the mouse or use the

GROUPS

contextual menu.

All archived pages are stored in groups.

Sort the groups by name or date with

Groups are automatically created when you

Sort > by Name or Sort > by Date. Reverse

archive pages from the search window and

the sorting order with Sort > Ascending/

are named after the search query. You can

Descending.

change group names at any time, delete
groups or manually create new ones. You can
also create sub-groups by selecting a group
and then creating a new one. The number
of items contained in a group is shown as a
badge.

PAGES
Like DEVONthink or Apple Mail, DEVONagent
Pro shows the pages filed in a group when
you select the group in the left pane. Select
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a page and DEVONagent Pro also shows a

(Pro) database. Only available if

text preview in the lower right pane with the

DEVONthink is installed on your Mac.

original search words highlighted.

DEVONthink (Pro) pop-up: Adds the

Rename a page by single-clicking it and
waiting a second (like the Finder), or by
selecting it and pressing the ↩ or Enter
key. Delete an item by selecting it and
pressing Backspace, using the toolbar, the
contextual menu or Data > Delete. To move
an item to another group, drag it or use the
contextual menu. Items can also be dragged
to DEVONthink.

selected page(s) to the currently open
DEVONthink (Pro) database, but allows you
to select as HTML code or as a link via a
pop-up menu. Only available if DEVONthink
is installed on your Mac.
Delete: Deletes the selected page(s) from
the results list.
Search: Searches the archive for entered
text. Select whether you want to search
the contents, the names or the URLs of

To sort the pages list, click the relevant

the stored pages with the magnifying glass

(first), title, URL or date column header.

pop-up menu. Also choose whether to

Click again to reverse the sorting order. The

ignore diacritics or to search fuzzy. This

relevance column is only used when you

search field also supports all operators and

search the archive using the toolbar search

wildcards.

field.

Print: Prints the results list.

TOOLBAR

Note: Not all of these commands are
always available. You can customize the

The toolbar of DEVONagent Pro archive

toolbar by selecting View > Customize

windows carries many commands for

Toolbar or by ⌃-clicking or right-clicking

manipulating the way it displays information

the toolbar background and selecting

and for manipulating selected items. Many

Customize Toolbar from the contextual

of them are simply shortcuts for menu bar

menu.

commands. Here's a short list of the available
tools:

SHORTCUTS & MODIFIER KEYS

Group +: Adds new groups to the archive.

Like any Mac application, DEVONagent Pro

To create a sub-group, select the parent-to-

uses modifier keys or shortcuts to quickly

be group first, then use this tool.

access frequently used functions or modify a

Open: Opens the selected page(s) in a

standard behavior.

separate web browser window.
Launch URL: Opens the selected page(s) in
your default web browser.
Export: Exports the selected page(s) as

Command-click: Adds an item to the
current selection of items.
Shift-click: Selects a range of items.

pure text, RTF(D) or HTML.
DEVONthink (Pro): Adds the selected
page(s) to the currently open DEVONthink
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CONTEXTUAL MENU
The contextual menu, which appears when
you click something with the right mouse
button or when you click while holding
the ⌃ Control key down, offers a range of
commands tailored for what you can do with
the clicked object.

Delete: Deletes the selected pages from
the results list.
Delete Domain: Deletes all pages from the
selected domains from the result list.
Delete & Exclude Domain: Deletes the
selected search pages from the results list
and adds the domains of the pages to the
list of excluded domains. Use this to quickly

Most of the commands offered by the

exclude an unwanted domain without

contextual menu have counterparts in a main

having to block it via the preferences.

menu, so you'll recognize them immediately.

Alternative menu item to Delete Domains.

However, to save menu bar real estate,

Sort by > ...: Sorts the results list by the

DEVONagent Pro gives you access to some

criteria listed in the sub-menu.

options only via the contextual menu.
New Group: Adds a new group to the

SEARCH SETS

archive. To create a sub-group, select the

The Search Set window is available via

parent-to-be group first, then use this

Window > Search Sets. Use it to modify the

command. (Only available in the left pane)

existing search sets or to create new ones

Open: Opens the selected pages in

specifically tailored for your needs.

separate web browser windows.
Open In Tabs: Opens the selected pages
in separate tabs in a new web browser
window.
Launch URL: Opens the selected pages in

Because search sets are so important, we
have created a separate chapter about the
search sets and the search sets editor. See
also p. 27ff

your default web browser.
Copy URL: Copies the selected URL to the
clipboard.
Reveal in Finder: Reveals an externally
archived page in the Finder.
Add to DEVONthink: Adds the selected
pages to DEVONthink. Only available if
DEVONthink is installed on your Mac.
Add to Set...: Adds the URLs of selected
pages to the sites list of a search set so

PLUGINS AND SCANNERS
The Plugins & Scanners panel, available
via Window > Plugins & Scanners, lists all
installed plugins and scanners and shows
additional information about them, e.g.,
their type, version and purpose. In addition,
it allows you to create new plugins for your
favorite websites and search engines.

that it will get scanned when you use that
search set in the future.
Move To > ...: Moves the item to the group
you select from the sub-menu.
Export: Exports the selected pages.
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Name, info, identifier, description, and
keywords of self-made XML plugins can be
edited. User-defined plugins, as well as the
groups Browser, DEVONsphere, and Scanner
are shown in bold.
Note: The group hierarchy is predefined
and cannot be manually altered. If you have
installed your own plugins, they appear
in the top level of the hierarchy or are
mirrored-in following the folder structure
in '~/Library/Application Support/
Also, you can enable or disable plugins or

DEVONagent/Plugins/'.

whole groups of plugins by checking or
unchecking them. Use this to simplify the
magnifying glass pop-up menu in the search
window or the plugin list in the Search Sets
window.

PLUGINS & SCANNERS
All plugins and scanners are arranged in
groups. Click the grey triangle in front of a
group to expand it; click it again to close it.
Select a plugin or scanner to show additional
information:
Name: Plugin name.
Info: Additional information, e.g., copyright.
Identifier: Internal and identification string.
Keywords: Shortcuts for the plugin. See
also p. 67ff
Description: Textual description of the
plugin.

KEYWORDS
Keywords are shortcuts that you can use
to query the search engines defined by the
plugin from the address bar of a web browser
window.
Example: The Bing plugin comes with the
predefined keyword 'bing'. To send a query
to Bing, type e.g., 'bing devonthink' into
the address bar of a DEVONagent Pro web
browser window and press ↩ or Enter.
This effectively replaces the search engine
field that is found in other web browsers,
such as Safari, with a far more flexible
approach. You can add your own keyword(s)
to most plugins, separated by spaces, to
make them quickly accessable from any open
DEVONagent Pro browser window.

Operators: List of supported operators. For

In addition, the plugin's name is automatically

plugins that you created yourself, you can

used as a keyword.

check and uncheck them to adjust which
operators are supported by the search

CREATING & TESTING

engine.
Using DEVONagent Pro's built-in plugin
assistant, you can easily create your own
XML-based search plugin for your favorite
DEVONagent Pro 3.11.3 Documentation, page 67

search engine. To create your own plugin,

To edit an existing XML- or JSON-based

choose File > New Plugin or use the New

plugin, double-click it or use the Edit toolbar

toolbar icon.

icon. DEVONagent Pro shows an XML text

In the sheet enter:

editor with error checking that allows you
directly edit the source code of the plugin.

Name for the plugin

Switch between XML and JSON format using

Short description

the button at the bottom of the editing

Website or search engine URL

sheet. See also p. 87ff

To get the URL for your search engine, run a

TOOLBAR

search in your web browser, copy the URL,
and paste it into the URL field of the to-

The toolbar of the Plugins & Scanners

be-created plugin. Then look for the URL

windows lets you easily create new plugins,

parameter that transports the query, e.g.,

edit, test, and delete them.

something like '&query=xxx'. Replace 'xxx'
with '_agentQuery_'. This tells DEVONagent
Pro where to enter the search term. The
'_agentNumber_' and '_agentOffset_'
placeholders are automatically inserted if
necessary and possible. See also p. 87ff

New: Opens a sheet for creating a new
XML-based plugin.
Edit: Opens a sheet for editing the XML
code of the selected plugin.
Test: Runs a test on the selected plugin and
displays the results.

Alternatively, if you want to create a plugin

Delete: Deletes the selected plugins. Built-

that simply searches a website, enter just the

in plugins cannot be deleted.

URL of the website. DEVONagent Pro will use

Show In Finder: Opens a new Finder

standard search engines such as Google to

window for the folder containing the

run a site-specific search when you use this

selected plugin.

plugin.
CONTEXTUAL MENU
DEVONagent Pro selects the Website or
Search Engine radio buttons automatically,

The contextual menu, which appears when

depending on the entered URL.

you click something with the right mouse
button or when you click while holding

To test a build-in or self-created plugin use
the Test toolbar icon. DEVONagent Pro will
send 'Test' as the standard search term to

the ⌃ Control key down, offers a range of
commands tailored for what you can do with
the clicked object, forexample a text passage.

the plugin and present you with the list of
returned pages. Double-click results to view

New: Opens a sheet for creating a new

them in a new web browser window. Only

XML-based plugin.

XML and JSON plugins using 'EngineUrl'

Edit: Opens a sheet for editing the XML

can be tested since testing XML and JSON

code of the selected plugin.

plugins using 'EngineSite' is unnecessary.

Duplicate: Duplicates the selected plugins.
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Show In Finder: Opens a new Finder
window for the folder containing the
selected plugin.
Test: Runs a test on the selected plugin and
displays the results.
Delete: Deletes the selected plugins. Builtin plugins cannot be deleted.
The test sheet also presents the following
options in the contuextual menu:
For URLs that require authentication,
Open: Opens the selected URLs in
DEVONagent Pro's built-in web browser.
Open In Tabs: Opens the selected URLs in
separate tabs in DEVONagent Pro's built-in

DEVONagent Pro asks for a username and
password. It also uses the systemwide
cookies, and can start and stop downloads at
any time.

web browser.
Launch URL: Opens the selected URLs in

ADDING, RESUMING, RETRYING

the default application for their types.
Exclude URL: Adds the selected URLs to

To add files to the Download Manager, drag

the plugin's internal exclude list. Use Retry

a link to the item from any DEVONagent Pro

to re-run the test after exluding a URL.

web browser window or any other application

Exclude Domain: Adds the domains of

to the Download Manager window, paste a

the selected URLs to the plugin's internal

copied URL or ⌃-click a link in a DEVONagent

exclude list. Use Retry to re-run the test

Pro web browser window and choose "Add

after exluding a domain.

to Download Manager". ⌥-clicking links in

Include URL: Adds the URL to the

the web browser or the objects drawer adds

"LinksMatching" key.

items to the Download Manager, too. Also,

Include Domain: Adds the domain to the

DEVONagent Pro automatically puts files it

"LinksMatching" key.

cannot display into the Download Manager, if

Copy: Copies the selected URLs to the

you double-click them, e.g., .zip archive files.

clipboard.

DEVONagent Pro downloads files added
to the Download Manager immediately. To

DOWNLOADS

remove a file, select it and click the - button

Window > Downloads opens the Downloads

at the bottom of the window. To temporarily

window. Use it to download files from the

prevent an item from being downloaded,

Internet to your computer. The download

uncheck the checkbox in front of it. Check

URL is automatically placed into the Finder

the checkbox to download the item. Use this

comment of the downloaded file, as well as

to add items to the download queue, but

in the 'kMDItemWhereFroms' extended file

download them later.

system attribute.
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To resume or retry a failed download, select

Enable/Disable: Enables or disables the

the file and click the back arrow button. Use

selected item(s). Disabled (unchecked)

the start/stop button (resembles the start/

items are not downloaded but kept in the

pause button of a VCR or tape player), to

download queue.

start or stop the entire queue.

Reload: Reloads the selected items.

You can also drag items from the Download
Manager to other windows or to the Finder,
or copy it to the Clipboard. Drag-and-drop
will send the URL of the item to the target
window or application.

Remove: Removes the selected items from
the queue.
Start/Stop Queue: Starts or stops the
download queue.
Purge Queue: Purges all completed items
from the queue.

DEVONagent Pro puts the web address

Automatically Purge Queue: When

where the file was downloaded from into the

checked, completed items are

Spotlight comments of the file (not available

automatically purged from the queue.

if DEVONagent Pro was purchased in the Mac
App Store).

ACTION MENU

PREFERENCES
The Preferences window is available via
DEVONagent Pro > Preferences. It contains

The action menu provides the same options

all available options that you can modify to

as the contextual menu.

adapt DEVONagent Pro to your personal
needs.

CONTEXTUAL MENU
Because the preferences are so important,
The contextual menu, which appears when

we have created a chapter just for them. See

you click something with the right mouse

also p. 73ff

button or when you click while holding
the ⌃ Control key down, offers a range of
commands tailored to what you can do with
the clicked object.

ASSISTANT
The integrated Assistant combines a
welcome screen with tips, tricks, and

Cut: Copies the selected link to the
Clipboard and removes it from the queue.
Copy: Copies the selected link to the

tutorials, installable extras, and a suppport
page that guides you through the available
support options.

Clipboard.
Paste: Adds a link that is copied to

Click here to directly open the assistant.

Clipboard to the download manager queue.
Retry: Retries a stopped or stalled
download.
Show In Finder: Opens a Finder window for
the enclosing folders of the selected items.
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Both tips and tutorials are updated live from
DEVONtechnologies' server, so it's a good
idea to check back from time to time. The
latest tip or tutorial is always mentioned on
the welcome screen.

INSTALL EXTRAS

WELCOME
This screen welcomes you when you start
DEVONagent Pro for the very first time. It
offers:
The option to subscribe to the free
DEVONtechnologies newsletter
The tip of the day

On the extras screen, DEVONagent Pro lists

The extra of the day

available extras that you can download and

You can access all other screens of the
assistant from here, too.

install from DEVONtechnologies' server:
Scripts
Plugins
GET SUPPORT

Search Sets

The support screen guides you through the

Browse the list of extras and install them

three common steps for troubleshooting

with the Install button. The last line of the

DEVONagent Pro. In addition you can

description shows where in the Scripts menu

have your license code resent, request

or Plugins hierarchy the extra will show up

a trial extension, update your details in

after installation. Remove installed extras

DEVONtechnologies' customer database, or

with the Remove button. Check Install and

buy an upgrade or a second license.

update extras automatically to receive all
new extras and have them updated without

TIPS AND TUTORIALS

visiting the window regularly yourself.

Here you can always find the latest tips

The extras are updated live from

sand tutorials that help you squeeze the

DEVONtechnologies' server so it's a good idea

best out of DEVONagent Pro. Tutorials can

to check back from time to time. The latest

be slideshows describing basic tasks in

extra is always mentioned on the welcome

DEVONagent Pro or videos (as they become

screen.

available).
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Note: If one of these categories does not
show up in your copy of DEVONagent
Pro, there may not be extras of this type
available yet for DEVONagent Pro.
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PREFERENCES
GENERAL

IN THIS CHAPTER
General
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Search

75

Menu extra

76

Web

77

Tabs

79

Bookmarks

79

Email

80

Update

80

The preferences window, which you open by
selecting Preferences in the DEVONagent Pro
menu, is the place where you change all global
settings of DEVONagent Pro. Click here to
open the Preferences window.
For your convenience, the preference

This tab contains all options modifying the
user interface and the summarization of
search results.

panel is divided into tabs, just like System
preferences. Use the icons at the top of the
preferences window to select the tab you
want to check or modify.

INTERFACE
These options define some parts of
DEVONagent Pro's visual appearance.
Highlight occurences in HTML pages: Check
to highlight occurences of search words in
web browser windowsor views.
Automatically zoom search panel: Check to
open new search windowssimplified.
Floating simplified search panel: Makes the
simplified search windowfloat above all
other windows. Use this to have the search
window always handy.
Alternating rows colors in views: When
checked, DEVONagent Pro colors lines in
lists differently to make them easier to
read.
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ALERTS
Click Reset to make DEVONagent Pro show
alerts again that you previously dismissed
with "Don't show again" checked.

SEARCH PANEL

Open new query: Opens a new,
empty search window when you open
DEVONagent Pro.
Open new browser: Opens a new
web browser window when you open
DEVONagent Pro.
Open browsers that were open on quit:

This option defines which tab DEVONagent

Opens the web browser windows that were

Pro shows when a search run is done.

open on quit.
Do nothing: Does nothing when you open

Digest: Switches to the Digest tab when

DEVONagent Pro.

DEVONagent Pro has finished a search run.
Results: Switches to the Results tab when

HOME PAGE, ...

DEVONagent Pro has finished a search run.
Log: Switches to the Log tab when

These options define the default home page

DEVONagent Pro has finished a search run.

and the folder for downloaded files.

Settings: Switches to the Settings tab
when DEVONagent Pro has finished a
search run.

SUMMARIZATION
These options define how DEVONagent Pro

Home page: Sets the home page that is
loaded automatically each time you open a
new web browser window.
Save downloaded files to: Sets the
folder into which DEVONagent Pro saves
downloaded files. See also p. 69ff

creates summaries.
FONTS
Based on sentences: Creates summaries
based on sentences. These are generally

Define the fonts you want to use for

shorter summaries, so you may miss

searching and reading texts. Click the Select

information that DEVONagent Pro

buttons to open the standard font panel.

classifies as not important.

Hold the ⌥ Option key to reveal options for

Based on paragraphs: Creates summaries

resetting the fonts to the defaults.

based on whole paragraphs. These are
longer summaries that are not clipped.

STARTUP

Source font: Changes the font used for
displaying source code. A monospaced
font, such as Courier or Monaco, gives you
the best results.

These options let you define what

Text font: Changes the font used for

DEVONagent Pro does when you open it.

displaying plain text, e.g., text extracted
from webpages.
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SEARCH
Contains all options dealing with the cache,
the number of connections, and domains
excluded from searching.

in the Finder or select another folder for
DEVONagent Pro to use.

CREATE PREVIEWS
Choose whether DEVONagent Pro should
create previews of visited or found pages
immediately or on demand, and set how
DEVONagent Pro generates thumbnails of
webpages.
Immediately: Previews are created and
cached immediately.
On demand: Previews are created and
cached only when needed (default).
Directly: DEVONagent Pro generates
thumbnails itself (higher quality).
Via DEVONtechnologies.com: Generates
web page thumbnails via web service
(faster).

GENERAL

Note: DEVONagent Pro never sends

Ignore instructions for robots: Ignores

more than just the URLs of the

instructions embedded into the HTML

to-be-thumbnailed webpages to

code of webpages that tell robots (like

Thumbshots.com.

DEVONagent Pro) to not index a page. If
unchecked (default setting), DEVONagent
Pro tries to honor the wishes of the
webpages creator.
Cache downloaded pages: Check if
you want DEVONagent Pro to store

MAX. CONNECTIONS
Use this parameter to adjust the number
of connections DEVONagent Pro uses
concurrently so as to match the speed of
your Internet connection and your computer.

downloaded pages in its cache. This
consumes disk space, but leads to much

MAX. DOWNLOAD SIZE

faster searches when DEVONagent Pro
scans an already cached page.

Choose how large files can be that

Clear on quit: When checked, DEVONagent

DEVONagent Pro downloads in search runs.

Pro clears the cache upon quit.

Adjust this to your Internet connection

Cache Directory: Shows the path to the

speed. Files skipped due to file size are

folder used by DEVONagent Pro for its

marked as "Too big" in the log tab of the

cache. Double-click an item to reveal it

search window.
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EXCLUDE DOMAINS, ...
Exclude Domains: Enter all domains you
want to exclude from searching in this text
field, separated by returns. Use this to
exclude domains blocking automatic bots like
DEVONagent Pro, e.g., 'sciencemag.org' or
'slashdot.org', or to ignore sites you don't like
(for example 'google.com'). Domains skipped
because they match one or more entries in

GENERAL

this list are marked as 'Skipped' in the Log tab
of the Search window.

Start at login: The menu extra is started
automatically when you log in.

Exclude Links: Enter URLs you want to
exclude from being searched.

Show icon preview: Shows preview icons of
the found pages in the menu.

Note: Both fields also accept the '*'

Show text summary in menu: Shows a

wildcards at the beginning or end of lines.

short summary directly in the menu.
Uncheck this option to keep the menu

MENU EXTRA

less crowded; you can always read the full
summary in the tooltip.

The options in this tab determine

Cancel search after opening a result: Stops

if DEVONagent Pro's menu extra is

the search run as soon as you double-

automatically started when you log into

click a result to view it. This option has

your account, if the menu should show icon

no effect when you open the result in the

previews, how results are opened when

background.

selected, and what hotkey to use to call the
menu.

SEARCH
Agent: Downloads each result page and
filter e.g. error pages.
Express: Returns the results unfiltered.
In both cases DEVONagent Pro uses its
unique artificial intelligence technology to
rank the results, in Express mode only based
on title, address, and a short summary, in
Agent mode based on the full text of the
page.
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OPEN RESULTS
In DEVONagent Pro: Results you select in
the menu extra's menu are opened using
DEVONagent Pro's browser.
In default web browser: Results you select
in the menu extra's menuThe results are
opened using your default web browser.

HOTKEY

Enable plugins: Check this option to use
installed third-party plugins, e.g., Flash or
RealPlayer.
Enable Java: Check this option to run Java
applets contained in or linked to webpages.
Enable JavaScript: Check this option to run
JavaScript scripts contained in webpages.
Block pop-up windows: Check this option
to block pop-up windows, which are often
advertisements. Uncheck this option if

Click the button to record any key

the webpage you're visiting uses pop-up

combination you like to call the menu extra.

windows for actual content (which ome

Using the hotkey will open the menu extra in

Web content management systems do).

OS X 10.7 Lion's fullscreen mode, too.

Only automatic JavaScript windows: Check
this option to block only pop-up windows

WEB

opened by JavaScript, instead of all popups.

The options in this tab resemble the settings

Block zooming: Check this option to keep

of most web browsers. They define how

JavaScript from zooming the web browser

DEVONagent Pro's built-in web browser

window to full screen.

windows displays HTML documents and live

Block advertisment: Check this option

webpages.

to block common inline advertisements
provided by major search engines.
Zoom text only: Check to scale only the
text when zooming in and out of webpages.
If unchecked, DEVONagent Pro uses
Safari-4-style zooming.

IMAGES
Use these otions to define how DEVONagent
Pro displays graphics in webpages.
Display images when the page opens:
Check this option to diplay webpages with
images or uncheck to load them without

WEB CONTENT
These settings define how DEVONagent Pro
treats special Web contents.
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images. If unchecked, you may miss some
information on graphic-oriented pages.
Animate images: Check this option to run
animated graphics; uncheck it to show the
items statically.
Loop animations of images: Check this to
run animated graphics in a loop.

(FEED) STYLE SHEET
You can further control the way DEVONagent
Pro displays webpages by applying a CSS
style sheed for changing the rendering onthe-fly.
Style Sheet: Click Select and choose your
own style sheet to apply it.

ACCEPT COOKIES
Cookies are little text files with information
that webpages store on your computer to
recognize you as a returning customer. While
most cookies are harmless, you may want
to control what is being stored on your hard
disk.
Always: Accepts all cookies.
Never: Doesn't accept any cookies
Only from sites you navigate to: Accepts
cookies, but only from websites you
navigate to, not from other sites, e.g., ad
trackers.
Delete cookies on quit: Deletes all stored
cookies when you quit DEVONagent Pro.
Note: Delete cookies on quit deletes the
cookies for all WebKit-based web browsers
including Safari. All these browsers use the
same single cookie file.

STANDARD/FIXED-WIDTH FONT
Set the font you want to use for displaying
webpages separately for variable-width and
fixed-width text. Holding the ⌥Option key
changes the Select buttons to Reset for
resetting the font to the factory default.

Feed Style Sheet: DEVONagent Pro comes
with a number of different style sheets
for Atom/RSS/JSON news feeds. Choose
your preferred style. You can use your
own CSS styles for news feeds by placing
them in '~/Library/Application Support/
DEVONagent/StyleSheets' (restart
DEVONagent Pro if necessary).
Note: Applying an external CSS style sheet
to webpages is an expert option. It heavily
affects the rendering of all webpages
in DEVONagent Pro, though it does not
interfere with the search functionality of
DEVONagent Pro.

TEXT ENCODING
Select your desired text encoding for
displaying webpages. Generally the default
setting, Automatic should work fine. If not,
choose a more appropriate text encoding for
your language.

WEBKIT DEVELOPER EXTRAS
Enable to use the standard WebKit
developers extras in web browser, e.g., the
element inspector or the JavaScript console.
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TABS
Like many modern web browsers,
DEVONagent Pro features tabbed browsing.

tabs, similar to Apple Safari. The keyboard
commands may change with the options
you select above.

This enables you to display multiple webpages
in one web browser window and switch
between them with tabs.

BOOKMARKS
DEVONagent Pro makes the bookmarks
defined in your favorite web browser available
both in the Go menu and in a bookmark
drawer in web browser windows.

Use the following settings to activate tabbed
browsing and define additional options. They
resemble those available in Apple Safari.
Open links from applications: Defines
whether DEVONagent Pro shows pages

BOOKMARKS

requested by other applications, such as
the Finder, in a new window or in a new tab

Select your favorite browser:

in the current web browser window.

Camino

Enable Tabbed Browsing: Switches tabbed

DEVONagent Pro

browsing on or off. You can always create

Firefox

new tabs manually, but DEVONagent Pro

Chrome

will not open new tabs automatically or

OmniWeb

when you ⌘-click a link.

Safari

Select new tabs as they are created: When
checked, DEVONagent Pro automatically

DEVONagent Pro comes with its own

switches to a newly generated tab.

bookmark management. Choose

Always show tab bar: When checked, the

DEVONagent Pro in the list to use the

tab bar is always visible; when unchecked,

integrated bookmark management. See also

DEVONagent Pro only shows the tab bar

p. 60ff

when at least two tabs are open.
BOOKMARKS BAR
Note: The lower part of the preference
window shows the keyboard commands for

Select whether DEVONagent Pro

creating new tabs and opening links in new

automatically mirrors Web servers
announced via Bonjour, bookmarks stored
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in DEVONthink Pro, and workspaces in the
bookmarks pane in a web browser windows
sidebar or the Go menu.
Include Bonjour: List Web server
announced via Bonjour.
Include DEVONthink: List bookmarks
from open DEVONthink databases.
The bookmarks are retrieved when
DEVONagent Pro starts up. Since they are
cached, they remain available even when
DEVONthink isn't open.
Include Workspaces: List workspaces.

BOOKMARKS MENU
Select if you want to include Bonjour services
in the Go menu.

SEND EMAIL
Choose if you want DEVONagent Pro to send
you email using Apple Mail or using the builtin email function. If you don't use Apple Mail,
add your email account details:
Server Name: Your SMTP server address
User: Your SMTP user name

Include Bonjour: List Web servers

Password: Your SMTP password

announced via Bonjour in Go menu.

Port: The port to use; usually the default
port should work

EMAIL

SSL: Check if you want to use a secure
connection

DEVONagent Pro can send you reports
of schedules search runs by email. Tell

EMAIL FONT

DEVONagent Pro how it shall send you
messages on this tab.

Set the font used for styled emails (rich
text). Check Send styled emails to let
DEVONagent Pro send summary emails as
RTF text. Read more about sending summary
email messages here.

UPDATE
Change the settings on this tab to choose
when you want DEVONagent Pro to check for
new versions: never, on startup, daily, weekly
or monthly. DEVONagent Pro only checks for
updates when the computer is connected to
the Internet.
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Note: This feature is not available when
DEVONagent Pro was purchased through
the Mac App Store.

Click Check Now to immediately check for a
new version.
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MENU EXTRA
IN THIS CHAPTER

DEVONagent Pro runs the query and shows
the results in the menu.

DEVONagent Pro adds a

menu extra to the

right-hand side of the menu bar that allows
you to enter a query and search run at any
time from the menu bar.

A colored bar in the search field shows
search progress.
Point with the mouse at any result to
show a tooltip with a preview and a text
summary.
Click the result to open it in DEVONagent
Pro or your default browser. See also p. 76ff
Hold the ⌥ or ⌘ modifier key to open
results in the background.
Drag results to the Desktop or other
applications. Dragging to the Desktop

It looks similar to the Spotlight menu and

creates bookmarks (.webloc); dragging to

works pretty much the same way:

other applications inserts the web address.
Navigate through the list with the Up and

Choose a search set or plugin from the
magnifying glass pop-up menu.
Enter your query.
Hit ↩ or Enter.

Down keys, press ↩ or Enter to open the
result in your browser.
Recall recent searches or recently used
plugins or search sets from the magnifying
glass

pop-up menu.

Click the

to clear your search.
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SCRIPTS
IN THIS CHAPTER

INTEGRATING OTHER APPLICATIONS

Introduction

83

In addition to the scripts that you use inside

DEVONagent Pro's Scripts menu

84

DEVONagent Pro, OS X features a global

Automator

86

script menu that allows you to access certain

DEVONagent Pro comes with a fully
loaded AppleScript dictionary and several
Automator actions that help you automate
almost every aspect of your DEVONagent Pro
workflow. Use the included scripts to perform
regular tasks and as templates for creating
your own scripts and Automator workflows.

scripts from any application on your Mac,
e.g., your web browser or Apple Mail. When
activated, the global script icon appears at
the right side of the menu bar (like other
menu extras such as the AirPort signal
strength or the Spotlight icon). It appears
with a black stylized S icon.
Note: By using folders named after

INTRODUCTION

applications inside the '~/Library/Scripts/
Applications' directory, it is also possible

DEVONagent Pro features an AppleScript

to make scripts application-specific. Such

dictionary and Automator actions that

scripts will appear at the top level of the

automate the application and integrate

global script menu when the application

it with almost every other application

they belong to is frontmost. This removes

supporting AppleScript and Automator.

clutter and shows only scripts that make
sense in the current application.

EXAMPLE SCRIPTS
DEVONagent Pro does not come with scripts
To make it easier for you to start using and

for other applications, but you can use the

writing scripts, we deliver a slew of scripts

global script menu for creating application-

with DEVONagent Pro that you can access

specific scripts.

in the Scripts menu (which shows a stylized
S symbol as its title instead of the word

To activate the global script menu, do the

Scripts). These scripts interact directly

following:

with selected items, the currently displayed
webpage or a window. All scripts delivered
with DEVONagent Pro are useable in your
daily work and don't require modification.

Open the AppleScript Utility (located in '/
Applications/AppleScript').
Check Show Script Menu in menu bar.
Uncheck Show Library scripts if you only
want to see the scripts you have installed
yourself.
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To install your own scripts, copy them into
the folder '~/Library/Scripts'. You can use
subfolders to structure them in any way you
like.

DEVONAGENT PRO'S SCRIPTS
MENU
The internal scripts menu of DEVONagent
Pro, located to the left of the Help menu,
gives you access to pre-made scripts that

DEVONAGENT PRO'S DICTIONARY

extend DEVONagent Pro with additional,

DEVONagent Pro includes a large dictionary

more specialized commands and functions.

with commands, objects, and methods you

They are only visible from inside DEVONagent

can use for writing scripts that interact

Pro.

or extend DEVONagent Pro. To view the
dictionary, open the Script Editor application
(by default located in '/Applications/
AppleScript'), select File > Open Dictionary
and choose DEVONagent Pro in the window.
You can also add DEVONagent Pro to your
Script Editor library. Select Window > Library,
click the + button and choose DEVONagent
Pro. This way you keep DEVONagent Pro's
dictionary at hand.

Of course, you can easily modify all these
scripts using AppleScript Editor, and the
workflows using Automator. And you can add
your own scripts and workflows--located in

LEARNING APPLESCRIPT

'~/Library/Application Support/DEVONagent

This documentation is not an AppleScript

Pro/Scripts'--to the menu. You can open

language guide. Please refer to Apple's

this folder in the Finder using Scripts > Open

AppleScript website, other online resources,

Scripts Folder.

or introductory and reference books for more
information on the AppleScript language.
Here are some links for you:

Keyboard shortcuts: If you want to add
keyboard shortcuts to scripts in this menu,
either use the System Preferences or add

The Ultimate Beginner's Guide to

the shortcut description to the file name

AppleScript

of the script in "~/Library/Application

MacScripter

Support/DEVONagent Pro/Scripts" or "~/

ScriptWeb

Library/Scripts". Example: "eMail Current

Scripting Matters Trainings

URL (Mail)___Cmd-Alt-M.scpt". The naming
convention is three underline characters

AppleScript for Absolute Starters (free

followed by the shortcut description. "Cmd"

PDF book)

stands for the ⌘Command, "Alt" for the

AppleScript: The Missing Manual

⌥Option, "Ctrl" for the ⌃Control, and "Shift"

AppleScript: The Definitive Guide

for the ⇧Shift keys.
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Caching: All scripts in this menu are cached
and therefore their properties are persistent
until you quit and relaunch the application or
DEVONagent Pro automatically updates the
menu, e.g. after adding or removing scripts.

SCRIPTS WORKING WITH IMAGES
Download Embedded JPEG Images:
Downloads all JPEG images embedded into
the currently displayed page to the default
download location via the download

Note: If you have modified the contents

manager.

of the script menu and want to go back

Download Linked JPEG Images: Downloads

to the default set, delete the Scripts

all JPEG images linked from the currently

folder in "~/Library/Application Support/

displayed page to the default download

DEVONagent/". DEVONagent Pro will

location via the download manager.

recreate this folder, including it's content,

Open Linked JPEG Images in Tabs: Opens

the next time you launch the application.

all JPEG images linked from the currently
displayed page in separate tabs, then

SCRIPTS INTERACTING WITH OTHER

closes the current tab.

APPLICATIONS

Open Linked JPEG Images: Opens all JPEG

Email Current Page (Mail): Creates a
new message in Apple Mail with the
currently displayed webpage attached
as webarchive. Webarchives contain
the HTML code of the page including all
embedded elements that are necessary to

images linked form from the currently
displayed page in separate web browser
windows.

SCRIPTS WORKING WITH PAGES AND
RESULTS

display them.

Download Objects of Results: Downloads

Email Current URL: Asks for an email

all found objects of the frontmost search

address and sends the URL of the currently

window. The search needs to be run with

displayed webpage by email to this

an active scanner returning objects, e.g.

address. This script does not use Apple

Embedded Images.

Mail, but sends the message directly via

Convert Results to RSS: Creates an

the messaging framework of OS X. It

RSS feed file for the found or selected

requires that you have set up at least one

results and puts it into ~/Sites/rss.

email account correctly in Apple Mail.

Enable web sharing to easily view your

Email Results (Mail): Creates a new email in

feeds locally using your web browser by

Apple Mail with the abstracts of all results

browsing to, e.g., http://127.0.0.1/rss/

in its body.

mysearchset.rss.

Post to del.icio.us: Posts the selected

File Results in DEVONthink: Files new

items as bookmarks to del.icio.us.

results in DEVONthink. One group is

Post to Twitter: Posts the selected items

created for each search set/query. This

to Twitter.

script can is used as a search set action.
Speak Titles of Results: Speaks the titles of
the found or selected pages.
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SCRIPTS FOR THE TOOLBAR

AUTOMATOR

By default this contains no scripts. Add your

DEVONagent Pro also comes with a bundle of

own scripts here and also add them to the

integrated Automator actions you can use to

toolbar of search and browser windows using

create your own Automator workflows.

View > Customize Toolbar.

SCRIPTS ARRANGING WINDOWS

To see which actions DEVONagent Pro
provides, open Automator and select
DEVONagent Pro in the applications list

Open last Safari session: Opens the last

on the left hand side. If you do not see

Safari session in DEVONagent Pro.

DEVONagent Pro in the Library list, use View

Browsers Side-by-Side: Arranges the

> Arrange Actions by > Application. Select

currently open web browser windows side-

any action to show a short description about

by-side.

what the action does, and have a look at

Tile Browsers: Arranges the currently open

Automator's built-in help to learn more about

web browser windows tiled to 800 pixel

how to create a workflow.

width.
Combine Windows: Combines the currently
open web browser windows as separate
tabs in one window.

Note: Cannot find the Automator action
you need for your workflow? We're open to
suggestions!

Windows to Full Screen: Resizes all web
browser windows to full screen.
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PLUGIN DEVELOPMENT
IN THIS CHAPTER

DEVONagent Pro comes with an integrated

Creating Your Own Plugins

87

XML and JSON Keys

90

DEVONagent Pro comes with a long list

plugin assistant that makes creating your
own XML-based plugin convenient and easy.
Let's create a simple plugin from scratch in six
steps.

of ready-to-use plugins for popular search
engines. However, you easily can write your
own plugins to query your favorite search
engine. Here is all what you need. The tutorial
gives you a jump-start on how to write
your own plugins for DEVONagent Pro, e.g.,
for integrating a search engine we haven't
thought of yet. And the XML and JSON keys
descriptions explain all the XML tags/JSON
keys you can use in developing the perfect
plugin.

STEP 1
Open a web browser window for www.ipl.org
in DEVONagent Pro or any other web
browser. Then search for 'Test' and copy the
'Next >>' link leading to the second results
page.

STEP 2
Choose File > New Plugin, paste the copied
link, and replace 'Test' with '_agentQuery_'.

CREATING YOUR OWN
PLUGINS
Do you have one or more favorite websites
you would like to search using DEVONagent
Pro? This document shows you how to create
an XML plugin for DEVONagent Pro. It is a
step-by-step tutorial that guides you through
a real, practical example--one that is found in

Enter a name and description (useful but not

the list of plugins of the application.

necessary). The Search Engine radio button is
automatically selected by DEVONagent Pro.

It would be good to also have a look at the
Keys sectionof this chapter. This describes

The '_agentQuery_' placeholder is where

the XML keywords in nitty-gritty detail.

DEVONagent Pro inserts the search term
when using the plugin. The '_agentOffset_'
placeholder, which is used by DEVONagent
Pro to jump from result page to result page,
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is automatically inserted instead of the '10' of

www.ischool.pitt.edu

the '&next=' parameter after clicking the Add

www.ischool.utexas.edu

button.

www.myspace.com/internetpubliclibrary
www.youtube.com/iplcommunity

STEP 3
Or we could have a closer look at the results
Let's test the plugin. In this case, the created

page and its HTML source. Just double-

plugin is fully functional but is causing

click on the results page in the log to open a

unnecessary traffic and might return

browser window, then switch to the HTML

unexpected results. Therefore, select any

source. All unncessary links are part of the

'www.ipl.org' URL in the log and choose

footer, right after "Connect With Us On".

Exlude Domain in the contextual menu. This

Therefore it's sufficient to add this snippet to

excludes all pages on ipl.org from becoming

the plugin's code:

possible results.

<key>LinksEnd</key> <string>Connect With
Us On</string>

Retry the test once again. Finally
DEVONagent Pro uses 10 links per page as
expected.

STEP 4
Retry the test. In the log you can see that
DEVONagent Pro uses now 27 links per page
returned by IPL. But not all of them are actual
results, therefore we could exclude additional,
static URLs like:
ischool.syr.edu
ischool.uw.edu

STEP 5
Finally, uncheck all operators since IPL does
not support them.

theipl.wordpress.com
theipl2blog.wordpress.com
twitter.com/theipl
www.delicious.com/
TheInternetPublicLibrary
www.diigo.com/user/Theipl2
www.facebook.com/pages/InternetPublic-Library
www.ipl.org
www.ischool.drexel.edu
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from the result list pages, you can use the
following keys to tell the software what
constitutes a result link and what doesn't.
1. TitleStart and TitleEnd: Extract the title
of the article.
2. TextStart and TextEnd: Extract the
article text.
3. DateStart and DateEnd: Extract the
article's date.
That's it!

4. NoTopics: Suppress common topics that
always occur for any search on a site.

In other cases, you might also want to look

5. PostScan: Scan the results for the string

at the source of the plugin and validate

you where searching for.

the values for 'Start', 'OffsetPerPage', and
'ResultsPerPage', or add 'LinksMatching'

To determine values for these parameters,

definitions etc. Site-specific search engines

you will need to look at the source code of

may also require 'TitleStart'/'TitleEnd',

a couple of articles, and try to find strings

'TextStart'/'TextEnd', 'DateStart'/'DateEnd',

that can be used for these keys. When

'NoTopics', or 'CrawlDelay' definitions. See

looking at the topics in the digest pane after

also p. 90ff

you've done your searches, you can set the
'NoTopics' list. Any word that should not be

In addition, DEVONagent Pro may not always

included as a topic can be added to this list.

be able to insert the '_agentOffset_' and
'_agentNumber_' placeholders automatically.

CONGRATULATIONS

You might have to do this on your own;
otherwise, only the first results page is used.

With the steps described in this tutorial,
you should be able to go through the steps

FINETUNING

of writing a plugin yourself. With a bit of
practice, it is possible to write an optimized

We now have a working plugin for IPL. While

plugin that will deliver good results for

we might have received links, we didn't

DEVONagent Pro to work with. It might help

necessarily get good data. You can check

to look at the additional plugins that already

both the pages and digest panes in the

come with DEVONagent Pro before designing

search window to fine tune your plugin. If

your own plugin.

DEVONagent Pro extracts too much data
And remember: If you think your plugin is
great for others, please share it with us!
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XML AND JSON KEYS
XML-based plugins use Apple's ".plist" file format; therefore, it's possible to edit them using
Property List Editor or any text editor like TextEdit, SubEthaEdit or Xcode/ProjectBuilder. JSONbased plugins are simple text files that you can also edit using any plain text editor.
DEVONagent Pro loads all plugins inside its application package or stored in the folder "~/Library/
Application Support/DEVONagent Pro/Plugins". If DEVONagent Pro is not able to load a plugin,
the file is logged to the console. You can also place aliases or symbolic links to plugins here.

LOCALIZATION
The following XML and JSON plugin keys can be suffixed with a language identifier to use
language-specific search engines: EngineUrl, EngineNextUrl, KeywordsUrl, and NextLinkName.
Language identifiers are: DE, DA, NL, ES, HU, FR, IT, CS, PT, PL, SV, FI, EN, NO, RU, EL, AR, and HE.
Example: A URL in the key EngineUrl_DE is used to target the German variant of a search
engine.

NECESSARY KEYS
Name: [string or dict] The name of the plugin. Example: "BBC News".
Info: [string or dict] Information containing name, version and copyright. Example: "BBC News
Plugin 1.0 © 2003--2005 DEVONtechnologies".
Description: [string or dict] Describes the functionality of the plugin. Example: "Queries the
BBC news archive."
Version: [string] The version number (format major.minor). Example: "1.0".
Identifier: [string] Unique identifier (format domain.name.plugin). Example: "com.devontechnologies.bbcnews.plugin".
EngineUrl: [string or array of strings] The Internet address(es) of the search engine. The strings
"_agentQuery_", "_agentNumber_" and "_agentOffset_" are replaced by the search term, the
number of results and the offset of the current page. "_agentNumber_" and "_agentOffset_"
are optional. '_agentLanguage_' is replaced by the language used by the plugin (ISO 639
two-letter codes). Can contain the placeholders "_agentUser_" and "_agent_Password_"
for HTTP authentification. Example: "http://www.bbc.co.uk/cgi-bin/search/results.pl?
tab=news&amp;start=_agentOffset_& go=homepage&amp;q=_agentQuery_".
Note: Name, Info and Description can be localized. Specify a dictionary containing key/string
pairs for multiple languages. The key contains the name of the language, e.g., German or
English.
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ADDITIONAL KEYS
CrawlDelay: [float] Minimal delay between two requests sent to the same server.
DateEnd: [string or array of strings] String marking the end of the range of the HTML source
code containing the date of a page.
DateStart: [string or array of strings] String marking the beginning of the range of the HTML
source code containing the date of a page. Note that "DateEnd" is optional if "DateStart" is
specified. Useful if server provides no dates or the wrong dates (for example a Usenet query
using Google).
EncodingPage: [string] Default character encoding for result pages (default: Latin-1). Examples:
"ISO-8859-1", "UTF-8", "ISO-8859-2", "Shift-JIS".
EncodingUrl: [string] Character encoding for search term "_agentQuery_" (default: Latin-1).
Examples: "ISO-8859-1", "UTF-8", "ISO-8859-2", "Shift-JIS".
EngineNextUrl: [string or array of strings] The Internet address(es) of the search engine(s)
used for subsequent pages (if not identical to the address of the first page). The strings
"_agentQuery_", "_agentNumber_" and "_agentOffset_" are replaced by the search term, the
number of results and the offset of the current page. "_agentNumber_" is optional.
EngineRelated: [string] Defines a URL for a 'see also' function of the search engine.
EngineSite: [string or array of strings] Defines (a) (sub)domain(s) with or without a path to
search. DEVONagent Pro uses an appropriate common search engine to perform the search.
Example: 'devontechnologies.com/products/'.
ExcludeLinksNamed: [array of strings] Defines an array of names of links which should be
skipped.
FileTypes: [string] List of all supported file types: html, feed/rss, text, pdf, OpenOffice,
Microsoft/Word, RTF or all. Default is 'all'.
FilterLanguage: [Boolean] Enable or disable filtering by language.
FilterSimilarPages: [Boolean] Enable or disable DEVONagent Pro's Similar Pages filter (default:
true).
FollowLinks: [Boolean] Enable or disable DEVONagent Pro's Follow Links option (default: true).
GoogleTags: [Boolean] Defines whether 'googleon'/'googleoff' tags should be supported.
HTTPShouldHandleCookies: [Boolean] Defines whether cookies should be handled by HTTP or
not.
Keyword: [string or array] One or more unique keywords used for quick searching (like "Mozilla
Keywords") by entering the keyword followed by the search term in the URL field of the
browser window.
KeywordsUrl: [string] Defines an alternate URL used for the Mozilla-like keywords in the
browser's address bar.
LinksEnd: [string or array of strings] String marking the end of the range of the HTML source
code containing the links to use (any position after the last link to use but before the next link).
Example: "-- Footer Area --".
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LinksMatching: [string or array] Only links of result pages matching this string or these strings
are used (prefix/suffix * wildcards are supported). Examples: "*news.bbc.co.uk/*".
LinksNotMatching: [string or array] Only links of result pages not matching this string or these
strings are used (prefix/suffix "*" wildcards are are supported).
LinksStart: [string or array of strings] String marking the beginning of the range of the HTML
source code containing the links to use (any position before the first link to use and after the
last link to ignore). Note that "LinksEnd" is optional if "LinksStart" is specified. Example: "search
results for".
LoginPost: [string] Defines the optional HTTP POST parameters. Usage like "Post". Can contain
the placeholders "_agentUser_" and "_agent_Password_".
LoginURL: [string] The address used to log into a website. Usage similar to "EngineUrl". Can
contain the placeholders "_agentUser_" and "_agent_Password_".
NextLinkStart: [string] Defines the start of the range for the 'next results page' link.
NextLinkEnd: [string] Defines the end of the range for the 'next results page' link.
NextLinkName: [string] Defines the name of the link for the 'next results page' (instead of
having to use NextLinkStart/End).
NoTopics: [array or string] Array of strings or string containing separated words to ignore in the
topics list. Add site specific words here.
OffsetPerPage: [integer] Increase for "_agentOffset_" after every page (default: 1).
Operators: [integer] Bitmap describing the possibilities of the search engine and the required
syntax (see below). The default value is 59 (1+2+8+16+32), meaning that AND, OR, NOT, phrases
and parenthesis are supported.
OperatorsDictionary: [dict] A dictionary containing key-string pairs to convert the name
of operators to a different name required by the search engine. Possible keys are "AND",
"ANDNOT", "OR", "NOT", "XOR", "NEAR", "BEFORE", "AFTER", "-".
ParseLinks: [Boolean] Parse and unify links of common search engines (Google, Yahoo,
Alltheweb, Altavista & Ask Jeeves) (default: false).
Post: [dict or string] Send a HTTP POST instead of a HTTP GET action using this form
data. Note: The strings of the form data can contain "_agentQuery_" and "_agentNumber_"
placeholders.
PostScan: [Boolean] Tell DEVONagent Pro to check if the retrieved pages match the search
term (true), or to accept all (false) pages (default: true).
ResultsPerPage: [integer] Number of results per page and maximal value for
"_agentNumber_" (default: 10).
RequiresCrawling: [Boolean] Marks this plugin as needing crawling.
RequiresThumbnails: [Boolean] Marks this plugin as using only thumbnailed links. Crawling
needs to be skipped.
RoundResultsPerPage: [integer] Always round number of results per page ("_agentNumber_") to
multiples of this value (default: 10).
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ScanTerm: [string] String specifiying a term used to filter results (e.g. instead of or in addition
to the secondary query defined by the user).
SkipsCrawling: [Boolean] Marks this plugin as skipping crawling.
Start: [integer] The initial value for "_agentOffset_" (default: 0).
StripTags: [array] Array of strings marking HTML tags defining blocks to strip.
TextEnd: [string or array of strings] String marking the end of the range of the HTML source
code containing the relevant text of a page. "TextStart" is optional if "TextEnd" is specified.
TextStart: [string or array of strings] String marking the beginning of the range of the
HTML source code containing the relevant text of a page. Note that "TextEnd" is optional
if "TextStart" is specified. Useful if you're querying a specific site (all results have the same
layout) to skip headers, footers or navigation of a page. This improves plain text display, digest
and summarization.
TextTags: [array] Array of strings marking HTML tags defining blocks to convert to text.
Timeout: [integer] Sets the timeout for requests; default is 60 seconds.
TitleEnd: [string or array of strings] String marking the end of the range of the HTML source
code containing the title of a page.
TitleStart: [string or array of strings] String marking the beginning of the range of the HTML
source code containing the title of a page. Note that "TitleEnd" is optional if "TitleStart" is
specified. Only useful if all results have identical or no titles (for example a Usenet query).
UseListingResults: [Boolean] Treat the returned pages as results (and not as pages linking to
the results). All "Links..." keys are unused in that case.
UserAgent: [string] Custom HTTP user agent string.

JSON AND XML-SPECIFIC KEYS
ResultsKeyPath: [string] The JSON key path to the results in the JSON output.
DatesKeyPath: [string] The JSON key path to the result dates relative to ResultsKeyPath.
LinksKeyPath: [string] The JSON key path to the links relative to ResultsKeyPath.
TitlesKeyPath: [string] The JSON key path to the titles relative to ResultsKeyPath.
DescriptionsKeyPath: [string] The JSON key path to the descriptions relative to
ResultsKeyPath.
ContentsKeyPath: [string] The JSON key path to the contents relative to ResultsKeyPath.
ThumbnailsKeyPath: [string] The JSON key path to the thumbnails relative to ResultsKeyPath.

NOTES
Operator Bitmap: The following table gives you the necessary values for calculating the operator
bitmap for the "Operators" key (see above):
0 [value: 1]: Supports AND operator
1 [value: 2]: Supports OR operator
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2 [value: 4]: Supports XOR operator
3 [value: 8]: Supports NOT operator
4 [value: 16]: Supports "" phrases
5 [value: 32]: Supports () parenthesis
6 [value: 64]: Supports NEAR operator
7 [value: 128]: Supports AFTER operator
8 [value: 256]: Supports BEFORE operator
9 [value: 512]: Supports NEXT operator
11 [value: 2048]: Use ANDNOT instead of NOT or '-'
12 [value: 4096]: Convert search term to lower case
13 [value: 8192]: Convert search term to upper case
14 [value: 16384]: Engine scans for any word by default (not for all words) without an explicit
operator
15 [value: 32768]: Use AND/NOT instead of '+'/'-'
16 [value: 65536]: Use # instead of OR
17 [value: 131072]: Supports OPT operator
LinksStart, et al.: 'LinksStart', 'LinksEnd', 'LinksMatching', and 'LinksNotMatching' are three
different ways to specify interesting links of a page. Specify none, some, or all of them depending
on the search engine you are accessing. The more you specifiy, the higher the chances are
that the plugin will still work after the structure of the HTML code or the links changed.
First DEVONagent Pro retrieves links using 'LinksStart'/'LinksEnd', then it filters them using
'LinksNotMatching', and finally it matches them against 'LinksMatching'.
Links vs. Results: 'LinksStart'/'LinksEnd, 'LinksMatching', and 'LinksNotMatching' are used for
pages listing the results, 'TextStart'/'TextEnd', 'TitleStart'/'TitleEnd', and 'DateStart'/'DateEnd' are
used for the result pages.
FollowLinks: 'FollowLinks' applies to result pages only; the links of pages listing results are always
used!
No case: All string values are case insensitive.
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please try to trash the application package.

DEVONagent Pro behaves irrationally

95

Problems interacting with DEVONthink

95

DEVONagent Pro was created with
robustness in mind. But any computer
hardware and software can write defective
data or destroy files. If you have trouble with
this application, please refer to the methods
below, and also have a look at our FAQ.

Then empty your web brower's cache, redownload the software in question, and
re-install it. In many cases this cures the
problem.
If this does not help, try deleting
DEVONagent Pro's preferences files located
in '~/Library/Preferences' and starting with
'com.devon-technologies.agent'. Access your
LIbrary folder by visiting the Go menu in the
Finder with the ⌥ key held down.

DEVONAGENT PRO BEHAVES
IRRATIONALLY

STRANGE BEHAVIOR OF TABS

No software on this planet is bug-free. If an

With Zooom/2 installed, tabs in tabbed

application behaves irrationally, there is a

windows behave stragely, e.g., close by just

good chance that your have just found a bug.

hovering the cursor over the tab. Another

But there may be another: The application

effect of Zooom/2 are scrolling problems.

package could have become damaged,

Disabling Zooom/2 solves the problem.

e.g, during an update or through a bug in
an unrelated piece of software on your
computer.
If DEVONagent Pro crashes or you have found
a bug, please send us a bug report.

STRANGE APPLICATION BEHAVIOR
If something happens like the following

PROBLEMS INTERACTING
WITH DEVONTHINK
DEVONagent Pro uses OS X's Services
internally to transfer data to DEVONthink.
If DEVONagent Pro beeps when you try to
transfer data to DEVONthink, the most
likely reason for this problem is that there's
something wrong with the Services.

menus disappearing or silently refusing to
do anything,

You can use the third party application

windows showing graphical artifacts,

Service Scrubber to try and modify this

or applications not opening or opening with

behavior; Service Scrubber should allow

strange error messages,

you to enable/disable services, rename
them, or give them new keyboard shortcuts.
Some of these modifications, however,
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can lead to communication problems

between DEVONthink and DEVONagent Pro.
Restore to the default settings to enable the
DEVONagent Pro/DEVONthink link again.
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General Concept

97

The DEVONtechnology is a rock-solid

Features

97

foundation suitable for a variety of

Structure

97

completely independent applications.

Applications

98

Therefore it is ideal for the rapid
development of a huge range of new

All commercial DEVONtechnologies
applications are based on a proprietary
AI technology, with rock-solid database
foundation that allow them to manage large

database-, signal-processing- and languageanalysis-driven applications. The ability to
deal with any kind of digital data makes it
extremely flexible.

numbers of documents or knowledge bits
while analyzing them almost instantly at the

The size of DEVONtechnology-based

same time.

databases can, depending on the type of
data stored, grow logarithmically and make

GENERAL CONCEPT

indexing is completely unnecessary. Also,

DEVONtechnology, on which all

improve themselves continuously (the more

DEVONtechnologies' applications are built, is

data they handle, the better the results),

a new technology at the very beginning of its

are language-independent and iron out any

development. DEVONtechnologies constantly

irregularities by applying fuzzy logic.

applications based on the DEVONtechnology

improves the technology and enhances it for
more functionality, efficiency, robustness and
flexibility.

STRUCTURE
The DEVONtechnology consists of a kernel

Development of the DEVONtechnology is a
battle on two main forefronts of information
processing technology. DEVONtechnologies is

and several layers. Together they perform all
the underlying computing, from 'simple' data
handling to complex signal processing.

working hard on unifying both the top-down
and the bottom-up AI concepts by imitating

Kernel: The kernel is the foundation for all

high-level functions and simulating the basic

layers and applications and is responsible

functionality of natural systems. This leads

for data handling, semantic and associative

to highly functional, fast and efficient AI

data processing, signal processing, fast

systems that can be used in a great variety

statistic analyses and all fuzzy algorithms.

of information processing contexts, such as

It has to be as fast, flexible, and extensible

pattern recognition, signal processing and

as possible; it is 64-bit aware and uses a

information storage and retrieval.

generic, proprietary file format (see above)
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allowing it to verify and repair low level data
consistency, featuring logarithmic growth
of the database and logarithmic speed
decrease with increasing database size. The
DEVONtechnology kernel is Unicode-aware,
completely language-independent and selfoptimizing and self-organizing.

APPLICATIONS
Some of the most likely applications for
the DEVONtechnology are databases
(knowledge bases, expert systems, search
engines, table-of-content-generators,
instant data-mining), intelligent agents,
encryption, compression and archiving.

Layers: The layers form a shell around the

Other uses for DEVONtechnology may be

kernel and provide high-level functions

chat-bots, context-sensitive help, optical

for the applications built on top of them.

character recognition (OCR), speech analysis,

The database layer, for example, is used to

recognition and synthesis, staticstics,

store and organize data and supports all

thesauri and automatic translations.

kinds of relations (1:n, n:1, n:n), hierarchies
and freeform databases. No indexing or
primary keys are required, strings can be
unlimited in size and it's possible at any time
to extend the range of pre-defined data
types (Boolean, character, float, double,
signed, unsigned, string, date, time, blob,
color, size, and point). Another layer, the

In particular, applications dependant on
processing human language, either written or
spoken, benefit from the flexible technology
foundation. So, DEVONtechnologies' main
focus in the development of new applications
is in these areas: databases, 'intelligent'
agents, text and speech analysis, statistics.

XML layer, makes it easy to handle XML code

Look forward to see a great range of different

within the DEVONtechnology; it has a very

applications based on the DEVONtechnology.

small overhead, compared to DOM parsers or

A few have already been announced

available XML databases, requires no indexing

on the DEVONtechnologies web site:

and supports the tight integration of other

www.devontechnologies.com.

databases (and vice versa).
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If you have a moment feel free to visit our

Overview

99

DEVONthink

99

DEVONagent

99

DEVONsphere

100

Needful Things

100

lively user community. Here users of all skill
levels meet to discuss our applications, talk
about our technology, and exchange tips and
tricks for DEVONagent Pro & Co.

DEVONTHINK
Besides DEVONagent Pro,
DEVONtechnologies publishes a number of
other commercial, shareware, and freeware
applications and services that might be
helpful for you.

Organize and work with all your documents,
bookmarks, email messages, text files,
images, PDFs, in one place, regardless where
they originated. Quickly capture data without
interrupting your workflow. DEVONthink's

OVERVIEW
DEVONtechnologies is focused on developing
innovative applications for finding, storing,
and organizing information. Our main
objective is to make complex yet flexible

unique AI assists you in getting the most out
of your data collection.
Learn more about DEVONthink
Check your upgrade options if you want to
upgrade to a higher edition

technology that is both easy to use and
lightning fast. All applications are based on

DEVONAGENT

the DEVONtechnology, a powerful and solid

DEVONagent Pro helps you search more

core unique to DEVONtechnologies.

efficiently on the web. It searches multiple

DEVONthink
DEVONagent
DEVONsphere

sources, frees you from hunting for the really
relevant results, and gives you power tools
for your research. DEVONagent Express and
DEVONagent Lite (free) make searching

We also publish some freeware apps and

the web as easy as using Spotlight. Search

services for your everyday work with your

Google, Bing, YouTube, Facebook, Twitter,

Mac.

even the Mac App Store, right from the menu
bar.

NEWSLETTER & COMMUNITY
Learn more about DEVONagent Pro.
Would you like us to keep you informed about
updates and new product releases? Visit our
blog and subscribe to our free newsletter.
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DEVONSPHERE

NEEDFUL THINGS

Make your Mac smarter: Let DEVONsphere

Search files on your hard disk, watch web

Express keep track of related emails, articles

cams, create thumbnails, or access all your

on the same subject, and similar web pages.

files and apps from the menu bar. Reformat

Discover the hidden connection between

paragraphs in your favorite word processor or

seemingly unrelated files.

do little calculations anywhere you can type

Learn more about DEVONsphere Express.

in text. All for free.
Learn more about our freeware apps and
services.
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directly with the clicked object. See also p.
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110
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49ff
Plugin: Modules that act as the connector
between DEVONagent Pro and search
engines. Each plugin is the interface for one
or more search engines. In addition, plugins
can extend DEVONagent Pro with other
functionality, e.g., scanners. DEVONagent
Pro knows two types of search engine

GLOSSARY
Become familiar with these terms to get the
most out of working with DEVONagent Pro.

plugins: Cocoa-based (compiled) plugins,
and XML-based plugins that can be created
using the Plugin Assistant or using a simple
text editor. See also p. 104ff

KEYBOARD SYMBOLS

Scanners: Plugins that act as filters for
formal criteria such as 'is a thumbnail

⌘ The Command key, usually next to the

gallery' or 'contains links to Word

Space bar.

documents'. Scanners are used to refine a

⌥ The Option key.

search. See also p. 110ff

⌃ The Control key (usually labeled with

Search Window: A window in DEVONagent

"ctrl").

Pro that lets you select a search set, type

⇧ The Shift key.

in a query, start the search run, and view

⇥ The Tab key.

the search results. See also p. 50ff

↩ The Return key.

Topics: A list of words extracted by
DEVONagent Pro from search results--

INTERFACE ELEMENTS
Alternative menu item: Some menu items
have less frequently used counterparts
that are hidden by default. Press the
⌥Option key when visiting the menu or
contextual menu to make them appear.
Contextual Menu: The menu that appears
when you right-click, or click on something

generally the most important words in the
found documents. Topics can be selected
in the search window to focus the visualizer
to this topic. See also p. 51ff
Visualizer: A graphic representation of
topics and their relationships. The graphic
looks like a 'spider web,' with 'bubbles'
representing each topic. See also p. 51ff

with the ⌃ Control key held, something;
the contextual menu gives you access
to frequently used commands that deal
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OPERATORS, QUERIES, SEARCH SETS
Boolean operators: Boolean operators are
AND, OR, and NOT. They are used to define

customers use DEVONagent Pro for their
research work, but don't necessarily archive
the results in DEVONthink.

how words or parts of search terms relate

Can I write my own plug-ins for DEVONagent

to each other. Example: 'steve AND jobs'.

Pro? Sure. The complete documentation

See also p. 23ff

on how to make plug-ins for DEVONagent

Query: A 'question' sent to one or multiple

Pro is included in DEVONagent Pro's online

search engines through a search engine

documentation.

plugin. The query (the question) is written
in a formalized style using search words,
Boolean operators, and parentheses. See
also p. 23ff
Search engine: A computer that keeps an
index of documents or information and
that can be searched by providing it with

Can I search my hard disk instead of the
Internet? Not with the current version of
DEVONagent Pro, no. However, our freeware
application EasyFind is able to preview found
documents and highlight occurrences in file
names. And, of course, there is still Spotlight.

a query. Search engines are generally used

How can I search already archived pages

through a web browser. DEVONagent Pro

Open the archive (Tools & Open Archive) and

emulates this human-computer interaction

use the search field there.

through plugins.
Search results: A pool of documents or
links to documents, e.g., webpages or PDF
documents, returned by a search run.
Search run: The process of sending a query

What advantages does DEVONagent Pro
have over Google & Co? The most important
advantages over web search engines like
Google are:

to one or multiple search engines.

DEVONagent Pro comes with an innovative

Search set: A set of parameters that

visualizer.

defines how DEVONagent Pro conducts

DEVONagent Pro can query multiple search

a search run. Search sets contain which

engines simultaneously.

search engine plugins shall be used, which

Scanners look for certain kinds of

scanners shall be applied, and what to do

webpages, e.g., pages with webcams,

with the search results when the search run

thumbnail galleries, videos, etc.

is completed. See also p. 27ff

DEVONagent Pro removes duplicate URLs/

Search term: See above: Query. See also p.

webpages, advertisements, spam, and

23ff

HTTP errors.
DEVONagent Pro also removes similar

FAQ (PRODUCT-SPECIFIC)

pages on demand.
DEVONagent Pro scans the current

Is DEVONagent Pro an add-on to
DEVONthink? Although we sell DEVONagent
Pro with DEVONthink in a bundle, it is

contents of the pages; therefore, it doesn't
return wrong results from outdated search
engine indexes

a stand-alone application. Many of our
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DEVONagent Pro supports more advanced

Remove the Acrobat plugin from "/Library/

operators like NEAR, BEFORE, and AFTER

Internet Plug-Ins" and everything should work

DEVONagent Pro can follow promising links

as advertised.

automatically.
DEVONagent Pro provides more useful
and complete summaries in the Pages tab
and complete digests based on selected/
entered topics or the used query.
You can easily find similar results ("See
Also"), archive results or transfer them to
DEVONthink.

Why does DEVONagent Pro crash when I
open a browser window or an archived page?
DEVONagent Pro uses Apple's WebKit as
its browser engine. When WebKit crashes
it draws DEVONagent Pro with it into the
abyss and there is little we can do about it.
So most DEVONagent Pro crashes related to
browsing are, in fact, WebKit crashes. Please

Why does DEVONagent Pro crash when

send us your crash log (in ~/Library/Logs/

displaying PDFs? DEVONagent Pro can crash

CrashReporter/) if you want to know what

when trying to display PDF files on Macs with

happened.

Adobe Acrobat installed. Acrobat's browser
plugin is incompatible to the web browser
engine of both OS X and DEVONagent Pro.

How do I completely uninstall DEVONagent
Pro? To completely remove DEVONagent Pro
from your Mac, see the instructions in the
Read Me.

LIST OF SEARCH SETS
Search sets are sets of parameters and options that control which search engines are used for a
search run, which sites are crawled directly, what is filtered, and what is done with the returned
results. DEVONagent Pro comes with a number of example search sets to get you started:
Apple (Feeds): Crawls some RSS feeds (Downloads, PR and Hot News) provided by Apple.
Marketing: Crawls more than 200 IT and Macintosh related news sites and feeds (the default
query looks for news related to DEVONtechnologies).
Mac > Latest Software: Crawls some software trackers and directories for new releases.
Mac > Latest News: Crawls the most popular Macintosh news sites and feeds.
Web (Scanner) > Movies: Queries the Web plugin and scans the results for linked movies and
videos.
Web (Scanner) > Thumbnail Galleries: Queries the Web plugin and scans the results for
thumbnail galleries.
Web (Scanner) > Downloads: Queries the Web plugin and scans the results for downloadable
archives.
Web > Deep: Queries Bing, Exalead, Google and Yahoo plugins (up to 100 results per plugin).
Web > Deeper: Queries Bing, Exalead, Google and Yahoo plugins (up to 100 results per plugin)
and follows links (one level).
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Web > Deepest: Queries Bing, Exalead, Google and Yahoo plugins (up to 100 results per plugin)
and follows links (maximum level).
Web > Fast: Queries the Web plugin (up to 100 results), but does not follow links to return
results as soon as possible.
Web > Express: Queries the Web plugin (up to 60 results) in express mode (no filtering).
Start with the Web > Fast search set for your first search runs, then use the Search Sets window
to make your own or adapt an existing one for your requirements. See also p. 27ff
To build your own search set consider buying DEVONagent.

LIST OF PLUGINS
Technically, plugins are collections of URLs and procedures that DEVONagent Pro uses to access
search engines on the Web. They are either written in Cocoa or in human-readable XML (plain
text with special syntax). In addition to simple HTML queries, DEVONagent Pro also supports and
analyzes Atom, RSS, and JSON feeds.
In the list below, you will find the associated quick search keywords in brackets. You use quick
search keywords to send a query to a plugin directly from the address bar of a web browser
window. You can change the quick search keyword in the Plugins & Scanners panel.
Note: Some sites need a valid log-in. If you want to query these sites with a plugin, you need
to enable cookies and manually log in with your web browser in advance. When you use
DEVONagent Pro, the websites then will recognize you as a returning user. You will find a note in
the plugin description if a site requires a log-in.

SEARCH
Note: DEVONagent Pro presents this category separately in its menu, above the other plugins
to make them more easily accessible.
Baidu: Searches the web using Baidu.
Bing: Searches the web using Bing, Microsoft's web search engine. Bing is considered to be the
only real competitor to Google.
DuckDuckGo: Searches the web using DuckDuckGo, a search engine that claims that it doesn't
track its users and delivers unbiased results (see also: filter bubble).
Google: Searches the web using Google. Google is famous for ranking websites by the number
of other sites linking to it. Google is now widely recognized as the world's largest search engine.
Google (PDF): Searches for PDFs using Google.
Qwant: Searches the web using Qwant, a search engine that, like DuckDuckGo, claims that it
doesn't track its users and has no filter bubble.
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StartPage: Searches the web using StartPage. The search engines uses results from Google and
claims that it respects its users' privacy and has no filter bubble.
Web: Searches the web using Bing, Google, and Yahoo. Depending on the system language,
DEVONagent Pro also uses local search engines or local variants.
Yahoo: Searches the web using Yahoo, one of the three major search engines.
Yandex: Searches the web using Yandex.

APPLE
App Store: Searches Apple's App Store.
Developer Connection: Searches the Apple Developer Connection database, the number one
source for OS X developers.
Knowledge Base: Searches the Apple Knowledge Base, the #1 resource for finding technical
information about Mac computers, Mac OS and Apple software.
Macintosh News: Scans major Macintosh news sites, namely Macworld, MacCentral,
Macintouch, and MacNN.Use this plugin to stay up-to-date about everything Macintosh.
MacUpdate: Searches for OS X software using Macupdate. MacUpdate watches for the latest
Macintosh software updates and visits over more than 800 websites a day, looking for version
changes to software titles not submitted by developers.

BLOGS
Google Blog Search: Searches blogs using Google Blog Search.

BROWSERS
All Cached Pages: Scans all pages cached by earlier search runs. Use this to include already
scanned pages again in a new search.
Bookmarks: Scans all websites bookmarked in DEVONagent, Safari, OmniWeb, Camino,
Chrome, or Firefoxfor the search query. You can use this plugin to create your private mini-web
with bookmarks and search only this collection.
DEVONthink databases: Searches all web sites bookmarkes in the currently opened
DEVONthink databases.
DEVONthink server: Searches shared DEVONthink Pro Office databases through the local web
server. DEVONthink Pro Office has to be running and web sharing started by the same user.
History: Scans the pages you have visited recently with Safari or DEVONagent Pro for the
search query. This is useful for searching for something you remember you have seen recently,
but you cannot remember where.
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COMPUTER SCIENCE
ACM Digital Library: Searches the digital library of the Association for Computing Machinery.
Apple Cocoa-Dev: Searches Apple's cocoa-dev mailing list. This is very useful if you do OS X
software development.
Citeseer: Searches the CiteSeer library. Citeseer is a scientific literature digital library and
search engine that focuses primarily on the literature in computer and information science.
Cocoabuilder: Searches Apple & Omnigroup Cocoa mailing lists using Cocoabuilder. Very useful
if you do OS X software development.
GitHub Code Search: Searches GitHub for code.
Ohloh Code Search: Searches for open source code examples and projects using Ohloh.
ohloh.net is a free search engine for open source code.
Stack Overflow: Searches Stack Overflow for answers to development questions.

DICTIONARIES
Acronym Finder: Searches Acronym Finder, the world's largest and most accurate dictionary of
acronyms, abbreviations and initialisms.
Dictionaries: Looks for word definitions in online dictionaries, namely Reference.com and
Hyperdictionary.
Infoplease: Searches Infoplease, a reference source that combines the contents of an
encyclopedia, a dictionary, an atlas, and several almanacs with statistics, facts and historical
records.
Onelook: Searches for word definitions or translations using Onelook. Onelook is a search
engine that provides access to web-based dictionaries that define or translate words.
Wiktionary: Looks for word definitions in the online dictionary Wiktionary. Wiktionary is a free
multilingual dictionary and thesaurus that's being written collaboratively. Anybody can edit
any article and a record of changes is kept. This plugin is localized and searches in the selected
language.

DIRECTORIES
Open Directory: Searches the Open Directory. The Open Directory (Dmoz.org) seeks to be the
largest free web catalog.
WoW: Searches the WoW catalog. WoW categorizes websites by country, state or region and
uses a professional editorial team.
Yahoo Directory: Searches the Yahoo directory. The Yahoo directory was the world's first
professionally edited web directory. It is currently divided into 14 main categories.
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DISCUSSION LISTS
DEVONtech Forum: Searches DEVONtechnologies' online discussion forum. Find answers to
your most pressing questions regarding DEVONagent Pro & Co.
Yahoo Answers: Looks for answers to user-posted questions on Yahoo Answers.

GOVERNMENT
USA.gov: Searches for U.S. government information using FirstGov.gov. FirstGov.gov is the
official U.S. gateway to all government information, with millions of webpages from federal and
state governments, the District of Columbia and U.S. territories.

IMAGES & VIDEOS
Google Video: Finds videos using Google Video.
Images: Finds images using Google.com and Yahoo (including Flickr). Whatever image you are
looking for, if it's on the Internet, you should be able to find it.
Picsearch: Searches for pictures using Picsearch. Picsearch is a search engine specialized in
creating a searchable index of images.
YouTube: Searches for videos on the popular video clip service YouTube.

LEGAL
EUR-Lex: Searches EUR-Lex for law documents and other public documents of the European
Union. The contents of the site amount to more than 2.8 million documents with texts dating
back to 1951. The database is updated daily and every year around 12,000 documents are
added.
FindLaw: Searches for legal materials using FindLaw. FindLaw is the highest-trafficked
legal website, providing a comprehensive set of legal resources on the Internet for legal
professionals, businesses, students and individuals.
Google Scholar (Case Law): Searches for legal materials using Google Scholar. Google Scholar
provides a way to broadly search for scholarly literature.
Lexis: Searches for legal materials using Lexis. LexisNexis provides customers with access to
billions of searchable documents and records from more than 45,000 legal, news, and business
sources.

MEDICAL
Clinical Trials: Searches for materials on ClinicalTrials. ClinicalTrials provides regularly updated
information about U.S. federally and privately supported clinical research on human volunteers.
FDA: Searches for material on the website of the U.S. Food and Drug Administration. The index
is updated every night as many FDA documents are time sensitive.
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Healthfinder: Searches for health-related materials using Healthfinder. Healthfinder is a
gateway to selected consumer health and human services information resources provided by
government agencies and other organizations.
MedlinePlus: Searches for health-related materials using MedlinePlus. MedlinePlus brings
together authoritative information from the National Library of Medicie (NLM), the National
Institutes of Health (NIH) and other government agencies and health-related organizations.
PubMed: Searches the PubMed bibliographic database. PubMed provides access to
bibliographic information that includes MEDLINE and OLDMEDLINE, as well as out-of-scope
citations, citations that precede the date that a journal was selected for MEDLINE indexing,
and some additional life science journals that submit full text to PubMedCentral and receive a
qualitative review by the NLM.
WebMD: Searches for health-related materials using WebMD. WebMD provides valuable health
information, tools for managing your health and support to those who seek information.

NEWS
BBC News: Searches for news on BBC News.
Google News: Searches for news using Google News. Google uses its own search engine to scan
important news websites and automatically compile a news portal using the found data.
Reuters: Searches for news on the Reuters news database. Reuters is a global information
company providing information tailored for professionals in the financial services, media, and
corporate markets.
RocketNews: Searches for news using Rocketinfo. Rocketinfo continuously searches and
indexes over 16,000 Internet sites, 70,000 RSS and blog sources, as well as client-defined
content channels, for current news and business information.
Topix: Searches for news using Topix. Topix provides a news portal that aggregates news from
other sources.
WorldNews: Searches for news on the World News Network. World News Network ranks as one
of the top sites for world news on the Internet. It includes more than 3,000 sites and covers 24
languages, categorized by geography and subject.
Yahoo: Searches for news on Yahoo News. Yahoo uses its own search engine to scan important
news websites and automatically compile a news portal using the found data.

PATENTS
Google Patent Search: Covers the entire collection of patents made available by the USPTO,
from patents issued in the 1790s through those issued in the middle of 2006. It doesn't include
patent applications, international patents, or U.S. patents issued over the last few months.
US Patent Office: Searches for patents on the US Patent and Trademark Office homepage.
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REFERENCES
British Library: Searches the British Library.
Google Scholar (Articles): Searches for scholarly literature using Google Scholar. Google
Scholar indexes scholarly literature across many disciplines and sources.
Googlism: Lists the 'knowledge' stored in the Google database about a given search word.
Googlism will find out what Google thinks of you, your friends or anything else.
Gutenberg.de: Searches for literature in the German-language Project Gutenberg database of
free ebooks.
Gutenberg.org: Searches for literature in the English-language Project Gutenberg database of
free ebooks.
Highbeam: Searches for articles on Highbeam Research. HighBeam regards itself as the premier
online research tool for business and academic use, with more than 80 million articles culled
from the archives of over 6,500 newspapers, magazines, journals, and other publications.
Internet Public Library: Searches for literature in the The Internet Public Library. The Internet
Public Library is a public service organization and a learning and teaching online environment at
the University of Michigan School of Information.
JSTOR: Searches for articles on JSTOR. With more than a thousand academic journals and over
1 million images, letters, and other primary sources, JSTOR claims to be one of the world's most
trusted sources for academic content.
Philosophy: Searches for literature in the Stanford Encyclopedia of Philosophy.The Stanford
Encyclopedia of Philosophy is maintained and kept up-to-date by an expert or group of experts
in the field.
Poetry: Searches for English poetry using the Electronic Poetry Center, founded by Loss
Pequeno Glazier and Charles Bernstein.
SEC: Searches the EDGAR database of the SEC.
Wikipedia: Searches for articles in the free online encylopedia Wikipedia. The content of
Wikipedia is free and is written collaboratively by people from all around the world. Begun
in 2001, Wikipedia has grown rapidly into the largest reference website on the Internet. This
plugin is localized and searches in the selected language.

SCIENCE
American Chemical Society: Searches for materials on the American Chemical Society (ACS)
website. The American Chemical Society is a self-governed individual membership organization
that consists of more than 158,000 members at all degree levels and in all fields of chemistry.
IngentaConnect: Searches online journals using IngentaConnect. IngentaConnect publishes
scholarly and professional journals in all subject areas. It supports and produces more than
3,000 online journals.
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SHOPPING
Amazon: Searches for articles on Amazon. Chooses Amazon in the USA, Germany, or France
depending on the system language.

SOCIAL NETWORKING
Twitter: Searches for tweets on Twitter. No available on macOS High Sierra as access to
system-wide social accounts is no longer possible.
Facebook Profiles: Searches Facebook profiles.
Note: The Twitter plugin is not available when you purchased DEVONagent Pro in the Mac App
Store due to sandboxing restrictions.

LIST OF SCANNERS
Scanners do not query search engines, but rather filter webpages that do not match their
criteria. For example, scanners can filter all pages that do not contain links to images or Office
documents, pages that do not contain email addresses, or pages that have no embedded images.
You can also use scanners to restrict search runs to Atom/RSS/JSON feeds, pages with linked
documents, or to thumbnail galleries. Scanners filter out all pages that do not match.
Also, scanners are used by the sidebar of web browser windows to filter certain elements and
display them lists, e.g. links, images, or news feeds.
By default, DEVONagent Pro comes with the following scanners that you can use in search sets.
All Links: Lists all links of a page, e.g., those found by a secondary query.
Atom, RSS & JSON Feeds: Looks for linked Atom, RSS, and JSON news feeds.
Audio files: Looks for linked or embeddedaudio files and audio streams.
Code: Looks for code snippets.
Email Addresses: Looks for email addresses and recognizes even non-linked and scrambled
addresses like "info at devon-technologies dot com".
Embedded Images: Lists all images of the page, e.g., those found by a secondary query.
Linked BibTeX & LaTeX Files: Looks for linked BibTeX and LaTeX files.
Linked Binary Files: Looks for linked downloadable compressed archives and disk images.
Linked Documents: Looks for linked PDF, PostScript, OpenOffice, StarOffice, WordPerfect,
Microsoft Word, Microsoft PowerPoint, or text documents.
Linked Scripts: Looks for linked AppleScript scripts.
Linked Spreadsheets: Looks for linked spreadsheet files (XMLSS, Microsoft Excel, CSV, TSV).
Linked Vcard files: Looks for linked business card files (.vcf).
Recipies: Looks for cooking recipies.
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Thumbnail Galleries: Looks for images in an image gallery, but lets pass all pages containing
(usually smaller) images linked to (usually larger) image files, a.k.a. thumbnail galleries.
Twitter Accounts: Looks for links referencing unique Twitter IDs.
Video Files: Looks for linked or embedded video files and streams.
Wallpapers: Looks for desktop background pictures.
Webcams: Looks for web cams and live streams.

LOG MESSAGE CODES
DEVONagent Pro logs all pages filtered out in the log, together with a short code describing
why the page was filtered. Use the log tab of search windows to find out which pages have been
dropped and for what reason.

HTTP ERROR CODES
These error codes are standard HTTP error codes delivered directly from web server that
DEVONagent Pro asked for a file:
204: No response
301: Moved permanently
302: Moved temporarily
401: Authorization required
403: Forbidden
404: Page not found
408: Request timeout
410: Gone
500: Internal server error
501: Not implemented
502: Service temporarily overloaded
503: Gateway timeout
522: Connection timed out
Wikipedia has a complete list of all possible HTTP error codes.

DEVONAGENT PRO ERROR DESCRIPTIONS
These errors appear in the log when communication problems with the web server occurred, or,
more likely, when DEVONagent Pro filtered the page out due to search strategy or user-defined
settings.
Advertisements: Link or frame probably contains only advertisement or banners
Archived: Identical page has already been archived (if "Archived Pages"filter is activated)
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Disabled format: Page isn't in a suitable format
Disallowed: Page couldn't be downloaded due to permissions
Duplicate: Identical page already found
Excluded: URL or domain excluded by the user
Failed: Search engine could not be reached
Filtered by scanner: Page did not pass the selected scanner
Host not found: Website not found
Identical: Identical page with different URL already found
Incomplete: Download could not be completed
Junk: Page contains almost no useful information (if the article filter filter is activated)
Language: Page does not match the language selected in the language filter
Links: x of y: Pages delivered as a result by a search engine. Numbers indicate used links vs.
returned links. If the number of used links is lower than the returned one, then either another
search engine already returned the same link or the host is blocked.
Lookup failure: Domain of website not found
No content: Page does not contain any text
No match: Page does not match the query term
Only links: Only links matching the query term found (if Follow Links is activated)
SPAM: Page tried to fool search engines, but does not match the query term without those
tricks
Similar: Similar page (different layout but similar text) with different URL already found (if
Similar Pages is activated)
Skipped: Domain was skipped because it matches one or more entries in the list of unwanted
sites
Timeout: Web server didn't respond in time
Too big: Page is larger than the maximum size defined in the preferences
Unknown data: No HTML or text content
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